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WYSIWYG 2025 Update 5 Release Notes 
Welcome to WYSIWYG 2025 Update 5! (New users looking to learn the basics of using WYSIWYG will likely not 

benefit from reading this document; instead, please work through the Quick Start Guide, accessible from the 

Windows Start menu.) These Release Notes provide information about new features, updates and bug fixes 

that were developed for this version. Click here for a list of fixtures and other Libraries were added and/or 

updated in this version. 

IMPORTANT: to run this Update with a Perpetual Dongle License, its Membership Expiry Date must be 

December 2025 or later. 

New in WYSIWYG 2025 Update 5 

Ultra High Shaded View (Real-Time) Rendering 

A higher quality real-time rendering option has been added to Shaded View: Ultra High. To enable it, access 

the Shaded View’s View Options, click the Simulation tab and the Beam dropdown in the Quality container. A 

powerful GPU (NVIDIA GTX 4070 or higher, or equivalent, recommended) and a minimum of 10GB of VRAM is 

required to enable this mode.  

Area Measurement 

It is now possible to measure areas in CAD Mode. To measure the area of a single Surface object, select it, click 

the TOOLS menu, then click Area. Alternatively, the rectangular area defined by clicking two points may be 

measured by having nothing selected, clicking TOOLS > Area, clicking the starting point of the measurement 

and then the ending point; Snapping may be used for precise measurements. In both cases, the area will 

appear in the Status Bar’s Prompt Line (or in the cursor tooltip). Note that areas “defined by two points” are 

measured based on projection onto the workplane: for example, while working in Plan View, if a Rectangular 

Surface is not parallel to the XY-plane, measuring its Area will provide different results if it is selected while the 

measurement is initiated – versus not having it selected, initiating the measurement and then End Point 

Snapping to its opposite corners. 

WYSIWYG Perform Lite Free Trial Replaces WYSIWYG Demo 

After 20+ years, the WYSIWYG Demo product has been retired, to be replaced with a free and more useful 10-

day trial of Perform Lite, which allows you to use all features of this product, including saving and printing. All 

users except those who own a current license of WYSIWYG Perform or WYSIWYG Perform Lite qualify for a 

Trial license; to find out if you do, sign in to the Customer Portal and click the FREE TRIAL tab. 

Enhancements 

➢ It is now possible to reset Cable Objects that were modified back to their original Profile. 

➢ NDI® has been updated to version 6.2.1.  

➢ Vivien’s Guest Management feature has been ported over to WYSIWYG and may be accessed in DATA 

mode’s new Guest Management tab. 

https://cast-soft.com/wysiwyg-2025-library-updates/
https://app.cast-soft.com/signin
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Fixed Issues 

➢ Multiple Cables-related issues and inconsistencies have been addressed, too many to detail here. 

➢ It is no longer possible to create incorrect Surfaces via the TOOLS > Convert > Lines into Surfaces tool. (This 

tool allows for the creation of a Surface after selecting three or more co-planar Lines.) 

➢ When exporting fixtures to DWG/DXF, their spigots respect the User Origin (if this was set). (Spigots are 

the visual representation of the clamp by which they are hung from their hang structure.) 

New in WYSIWYG 2025 Update 4 

DMX Control for Ambient Light 

Much like being able to control Light Emission (and other functions such as switching Scenes or Cameras) via 

DMX, as its name implies, this new feature allows Ambient Light to be patched and controlled from a 

connected console while working in LIVE mode (i.e., while running WYSIWYG Perform Lite or Perform). To 

enable Ambient Light control by DMX, access the Shaded View’s View Options > Simulation tab in LIVE mode, 

define the channels which will control Intensity and/or Color (RGB only) by clicking the new Patch… button 

within the Ambient Light container, then click OK and tick the DMX Control checkbox; for convenience, you 

may also toggle DMX Control on and off via the Shaded View Settings Tool. (Intensity will require one DMX 

channel – or two if the 16-bit checkbox is ticked; Color will require three – or six, for 16-bit. Note that Ambient 

Light is not simulated with 16-bit control; this option is intended for patch purposes only.) When enabled, DMX 

Control replaces all manual control for Ambient Light; thus, to change its colour to something other than pure 

white (i.e., R/G/B = 255/255/255) you must patch Color control as well, then set the desired colour from the 

console. Please note that even when running WYSIWYG Perform Lite or Perform, Ambient Light is controlled 

manually in CAD and DESIGN modes’ Shaded Views; as a result, even when the same Shaded View Profile is 

used in all three modes, Ambient Light may be different between LIVE mode and the others when DMX Control 

for Ambient Light is enabled.  

Enhancements 

➢ When a fixture is renamed in a Legend, it is now possible to set that name as the fixture’s Alias – but the 

Alias may (continue to) be set from the fixture’s Library Properties > Data tab. (As a reminder, the Alias is 

an alternate name that may be assigned to any fixture; once set, that fixture will appear with that name 

everywhere in the .wyg file.) 

➢ Higher performance is to be expected when simulating/visualizing lighting in a file that contains lots of 

multi-Element Library Items, including Custom ones and imported 3D models which were turned into 

Custom Library Objects – which are lit by many fixtures. 

Fixed Issues 

➢ When Shaded View’s Fullscreen mode is activated, it correctly follows the resolution of the screen 

containing the WYSIWYG application window. 

➢ Custom Library Items no longer ignore the Insertion Point with which they were defined. 

➢ Nested blocks from DWG imported as nested Library Items do not render correctly in Shaded View 
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➢ Ortho options are now respected when Vivien fixtures which are not hung are copied (and pasted – though 

like with all fixtures in WYSIWYG, the paste (CTRL+V) action is performed automatically and thus not 

required).  

➢ WYSIWYG no longer crashes when a Legend with Automatic Updates disabled is opened after one of the 

fixtures it contains gets an Alias.  

Enhancements and Fixed Issues in WYSIWYG 2025 Update 3 

In addition to the many new fixtures and fixture corrections/improvements, this Update also features the 

following software enhancements and bug fixes.  

➢ Distribute Fixtures Between Two Points is now able to operate on Floor-Inserted fixtures (as well). 

➢ The background of the Cuts and Adjustments Tool’s preview area will no longer black out. 

➢ Images used as textures no longer appear blurry when stretched to a different aspect ratio. If your textures 

still appear blurred when stretched, check the AMD Software: Adrenalin Edition or NVIDIA Control Panel 

for the Anisotropic Filtering setting and set this to Maximum. 

➢ The method by which Bounding Boxes calculate geometry complexity was improved, leading to more 

accurate Bounding Box colours. 

➢ … And more! 

New in WYSIWYG 2025 Update 2 

Register up to two Devices per Cloud License 

This version introduces the ability to register two devices for a Cloud License and use WYSIWYG on either one 

(but it will not be possible to run WYSIWYG on both devices at the same time). This eliminates the need to wait 

for up to 24 hours before you can register, and use the license on another device. Moreover, as long your 

current device is connected to the Internet and you ensure the License is Released when you exit WYSIWYG, 

you will be able to run it on the other device immediately.  

The option to release the license automatically when WYSIWYG exits, found in Application Options > General 

tab, is enabled by default; with this enabled, there is nothing else you need to do to release the license (except 

to exit WYSIWYG). You may turn this option off if you like, so the license is not released on exit – which can 

protect you from a short-term Internet outage the next time you start WYSIWYG. Should you choose to turn it 

off, you may still release the license on exit, by clicking Release License and Exit in the FILE menu. 

For emergencies, it is possible to force-release the license via the License Manager app, by clicking the new 

Release button there. It is important to note that you may only force-release three times per month; as such, 

this option should only be used in actual emergencies. For example, do not force-release the license if 

WYSIWYG happened to crash: instead, run WYSIWYG again and then exit if you don’t need to use it anymore, 

allowing the license to release automatically or via FILE > Release License and Exit; similarly, try to avoid 

releasing the license from the License Manager if you forgot to exit WYG on one device and now need to run it 

on another: access the first device instead (directly or via remote desktop) and exit WYSIWYG to give up its 

license. 

https://cast-soft.com/wysiwyg-2025-library-updates/
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If you have released your license, your device must be connected to the Internet the next time you start 

WYSIWYG, in order to acquire the license again. If you only ever use WYSIWYG on one and the same device, 

releasing the license is not recommended (and there is never any need to do this). 

Cable Bundles 

Cable Bundles, also referred-to as “Cable Looms”, are collections of two or more Single Cables and/or 

Multicables, all of which start at the same location and all of which end at a different location. Unlike Single 

Cables, Multicables and Splitters, Bundles are not based on Profiles (because they are always custom-built and 

they are (almost) never the same, unlike the other Cable Items). 

To create a Bundle, click the CABLES menu > Draw Cable Bundle and draw it as you would a regular Cable. As 

soon as you’ve finished drawing it, the Bundle’s Properties window opens, where you may add Single Cable 

Profiles or Multicable Profiles; these may be added at any time later as well, by accessing the Bundle’s 

Properties. Cables within the Bundle may be designated as spares, or set to run in reverse (as is sometimes 

required for DMX/data cables). Cables and Splitters that are already in the file, or new ones that you 

draw/insert, can connect to cables within the Bundle – as long as the connector of the Cable you are 

connecting matches the connector of a Cable within the Bundle. Bundles themselves do not appear in 

Spreadsheets, but the cables they contain do.  

Color Controls 

A new Color Controls tab has been added to the Shaded View’s View Options, and the controls within it may 

be used to adjust the Shaded View’s appearance by changing the Tone Map and by adjusting Contrast, 

Luminance and/or Saturation.  

The Tone Map controls the method by which WYSIWYG converts its “natural” HDR rendering to what is 

displayed in the Shaded View. The three options – FILMIC (which was the Tone Map that WYSIWYG has always 

used), FILMIC2 and ACES – are industry standards. The default Tone Map for WYSIWYG 2025 Update 2 is 

FILMIC2. 

Contrast, Luminance and Saturation are standard colour controls which operate identically to how the same do 

in any photo or video editing software – or on your TV or computer monitor, for that matter. 

RAW HDR Image Exports 

It is now possible to export Shaded View images in the Digital Negative (.DNG) and OpenEXR (.EXR) HDR RAW 

image formats. To export as such, simply choose the format you wish to use when you save the image. 

Resulting images may then be fully processed using software such as Photoshop, Lightroom, Affinity, and so 

on.  

IMPORTANT: when exporting to DNG or EXR, WYSIWYG captures the image before the Tone Map or any of the 

other new Color Controls are applied; such an image will therefore look different than the Shaded View, but 

this is normal.  

Other/Miscellaneous 

➢ When using a Cloud License, it is now possible to start multiple instances of WYSIWYG on the same device 

(the same as with dongles). 

https://en.wikipedia.org/wiki/Tone_mapping
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➢ Cables drawn with multiple segments and/or those to which you added Vertices after having drawn them, 

no longer display a length of zero in Spreadsheets or in their Tooltip. 

➢ Tooltips for Break-In-style Splitters have been improved to display more accurate/meaningful information. 

New in WYSIWYG 2025 Update 1 

This version introduces the WYSIWYG CORE Product Level. Please click here for more information. 

Updates and Enhancements in WYSIWYG 2025 Update 1 

➢ When multiple Cables with (of) the same Profile are selected, choosing to insert a Splitter whose Plug 

matches the Cables’ Sockets, will insert multiple identical Splitters, each connected to the selected Cables. 

➢ It is now possible to save (Export) Tolerance and Rounding settings to WYSIWYG User Data files (all settings 

are saved at once/into one file) so they can be recalled (Imported) into other files. 

➢ It is now possible to edit multiple Cable objects’ Category, Purpose, Type and Specification at once via 

Spreadsheets (much like fixtures’ Gobo, for example). 

➢ It is now possible to edit multiple Cable objects’ Name, Length, Gauge, etc. via Spreadsheets (much like 

assigning the same Purpose to several fixtures at once, for example).  

➢ Cables remain connected to fixtures when fixtures are nudged along their hang structure or when moved 

between hang structures (or between chords of the same truss). 

➢ Language Packs are back – enjoy using WYSIWYG in Spanish, French or Italian once more. 

➢ WYSIWYG Viewer: added control over layers’ visibility. 

➢ Improvements to Patching error detection. 

➢ All Camera objects are now affected by the Camera Objects options in Document Options. 

Fixed Issues in WYSIWYG 2025 Update 1 

➢ Coordinates on the Status Bar now update when Cable object’s connector is being dragged around. 

➢ Cable objects’ Connectors always show the correct connection status (i.e., green for ‘connected’). 

➢ Tailed Splitter objects will no longer become “distorted” as a result of their tails’ lengths being changed 

(via their Properties).  

➢ Non-Tailed Splitters’ Length is now reported correctly. 

➢ Tolerance and Rounding no longer get applied to Tailed Splitters whose length is defined as 0. 

➢ It is no longer possible to remove Cables’ Category via Spreadsheets – which could have caused problems 

in the file if done, since Cables always require a Category. 

➢ Resolved a rare potential crash that could have been caused by Daisy Chaining.  

➢ Markers no longer appear at fixtures’ hang points when fixtures are not selected. 

➢ The Average Center 3D Model import option now also accounts for Z-up. 

➢ User Origin is now considered when exporting to MVR and DWG. 

➢ The D hotkey decrements QuickTools once again. 

https://cast-soft.com/WYSIWYG/
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➢ When drawing Dimension objects, it is once again possible to select any layer to place them onto. 

➢ Overly-large meshes will no longer corrupt .wyg files – but this still doesn’t mean it’s a good idea to import 

them. 

➢ Addressed multiple issues related to DWG exports, such as incorrect scale of Pipe objects, and incorrect 

location and rotation of Dimensions. 

New Features in WYSIWYG 2025 Release 

Cloud Licensing 

A Cloud License allows WYSIWYG to run without a dongle attached, as long as an Internet connection is 

available (and for up to 24 hours even without being online). Aside from no longer having to worry about 

misplacing or losing your dongle, a Cloud License also makes it possible for WYSIWYG to be used on ARM-

based Mac computers by running Windows 11 ARM64 Edition within the Parallels virtual environment. 

To use a Cloud License, you must first purchase one from the CAST Software Store, and, if needed, assign it to 

yourself in the Portal. (This happens automatically for the first Cloud License you purchase.) Detailed 

instructions for how to use this license are provided at the time of purchase, but in brief: (1) ensure that the 

device where you installed WYSIWYG 2025 is connected to the Internet; (2) double-click on the WYSIWYG icon 

on the desktop; (3) sign in to the CAST Cloud License Manager app (which opens automatically) using the 

same credentials as for the CAST Software Customer Portal; (4) add your device to your account and WYSIWYG 

will run.  

Additional information about the operation of Cloud Licensing: 

▪ Once it is running, WYSIWYG can continue to be used for up to 24 hours even if the Internet 
connection is no longer available. (It may be quit and run again an unlimited number of times during 
this period.) This rule applies only for cases where WYSIWYG was started while an Internet 
connection was available.  

▪ Four hours after starting up, and every four hours after that, WYSIWYG will attempt to check in with 
CAST’s Cloud Licensing Server. If the check-in is successful, WYSIWYG can continue to be used for 24 
hours starting from this check-in. 

▪ If a check-in fails, WYSIWYG can still continue to be used for the remainder of the period of time 
established at the last successful check-in. IMPORTANT: startup is not considered a successful check-
in if an Internet connection was not available at that time. 

▪ Once WYSIWYG has run without an Internet connection for 24 hours since the last successful check-
in, an Internet connection is once again required in order for the software to continue running (as per 
the aforementioned rules). 

Cables 

The Cables feature adds the ability to draw Single Cables and Multicables and to insert twofers, quad boxes, 

multicable break-outs and other similar cabling-related devices, collectively referred to as Splitters, to 

WYSIWYG’s toolset. These Cable Objects are based on Profiles which define cables’ attributes; Profiles may be 

stored and recalled in future files or copied to other WYSIWYG installations (so any particular Cable object 

need only be defined once). Tolerance and Rounding options enhance cable objects’ final length calculations in 

Cable Spreadsheets. The Quick Tool-like Daisy Chaining function facilitates easy inter-fixture connections and 

rounds out this first version of the Cables feature. 

https://app.cast-soft.com/shop
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To learn how to use Cables: consult the Guide provided on the WYSIWYG 2025 Release page. 

New Particle Effects 

Confetti, Fireworks (Comet, Flash Pot, Gerb, Glitter, Multi-Mine, Multi-Fx, Sparkle and Starburst) and Spark 

machines were added to the library, each of which produce a different and exciting particle effect! In addition, 

more accurate screenshots of Particle Effects are now facilitated by the ability to pause animation.  

To use (and pause) the new Particle Effects: add the desired Particle Effects machine(s) to your file; they are 

located in the Fixtures > Type > Effects > Particle Effects Fixtures Library. Working in DESIGN mode, select the 

desired Particle Effects machine(s) and use the Particle Effects Designer Tool to activate them and control the 

effect they each produce. To fine-tune the effect, access their Properties > Fixture tab > Options subtab, and 

change options such as color, type, range and others. To pause the animation, tick the new Pause checkbox 

found in the top-right corner of this tool. 

Real People 

A variety of nearly sixty modern people models have been added to the Library, in various poses and styles of 

clothing.  

To use the real people models, add them to your file from the (Objects) Library > People & Mannequins > 

People – Generation 3 - 2025 folder. Once inserted, access their Properties > Appearance tab to change their 

Elements’ texture (Image Source) and, if desired, enhance the texture with a Normal Map; the Tint and 

Materials options may also be used, as always before, to alter Elements’ colour and further enhance their 

appearance, respectively. 

WYSIWYG Viewer Installed together with WYSIWYG 

The WYSIWYG Viewer is now part of the standard WYSIWYG installation. The Viewer allows you to open .wyg 

files to view the model in wireframe, visualize Looks and Cue Lists, or print any Reports and Layouts stored 

within – all without requiring a Cloud License or a dongle to be connected. (Files opened in Viewer cannot be 

changed in any way.) 

The WYSIWYG Viewer is accessible from the Windows Start menu’s CAST Software folder. 

Updates and Enhancements in WYSIWYG 2025 Release 

➢ Truss objects export to .DWG/.DXF as “complete” 3D models (i.e., with cylindrical chords and cross-

members) by default. (If desired, they can still export as lines, like they always did until now.) 

➢ Custom Library Items that were created strictly from imported 3D models and saved at the Application 

Level (i.e., “made available to other documents”) now remain smoothed (if they imported as such) and 

retain any and all textures they were initially imported with. 

➢ Textures and Normal Maps may now be applied to Library Objects. 

➢ Self-shadows now appear for fixtures that feature continuous tilt as well as for Minuit Une laser units. 

➢ The Shaded View’s Sketch option received two new modes, Color and Color Fixtures. When the former is 

selected, all objects (including fixtures) display in their layer’s colour, while when the latter is selected, 

https://cast-soft.com/wysiwyg-2025-cables/
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only fixtures display in their layer’s color. As a result of this change, the “classic” black-on-white option has 

been renamed to Default, and Invert has been renamed to Black Background. 

➢ Improved visualization for LED-based tube- and strip-type fixtures. 

➢ Improved visualization for fixtures fitted with a frost or diffusion gel when no gobo is used. 

➢ The number of reflective surfaces has been increased to 20; the same rules apply, though: while a Sphere 

is considered a single reflective surface, a Riser has six reflective surfaces. 

➢ The MVR Library has been updated to version 1.5.  

➢ Fixture weights are now exported to MVR.  

➢ The number of Pipe and Truss Objects to which Position Names have not been assigned appears in the 

MVR Export (information) dialog. 

➢ It is now possible to Purge empty DMX Universes. 

➢ CTRL+SHIFT+D is once again the keyboard shortcut for the Distribute Between Two Points function. 

➢ Pan Circles' colour can now be set to display in the colour of the layer their fixtures are on. 

➢ Improved docking behaviour for Designer Tools, Cuts and Adjustments, etc. 

➢ The Shortcuts list automatically scrolls to display a new shortcut that was created. 

➢ Gobo manufacturer info now appears in gobos' Library Properties. 

➢ NDI® has been updated to version 6.  

Fixed Issues in WYSIWYG 2025 Release 

➢ Objects created by Vivien's 3D Transform function that were also textured retain their textures when 

imported into WYSIWYG. 

➢ Source Disc artifacts no longer appear in mirror surfaces.  

➢ Global Illumination settings now save with Shaded View Profiles. 

➢ The issue which, on rare occasions, caused some fixtures to output two beams has been fixed. 

➢ Importing issues resulting from DWG files which contained Leader lines have been addressed. 

➢ All Insertables appear once again after the Insertables Category is switched to All. 

➢ Pipes’ Border and/or Legs now export to MVR (if they were enabled in Pipes’ Properties). 

Library Updates and Additions 

The list of fixtures and other Library items that were added and updated in WYSIWYG 2025 is available here. 

Known Issues 

Known issues are listed here.  

System Requirements 

https://cast-soft.com/wysiwyg-2025-library-updates/
https://cast-soft.com/wysiwyg-2025-known-issues/
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Click here for our Hardware Guide, which is the key to understanding how WYSIWYG uses various system 

components (CPU, GPU, RAM, etc.) and to making decisions regarding what hardware to purchase or what to 

look for in an “off-the-shelf” system.  Click here for additional information as well as for a list of system 

requirements.  

License Requirement 

To use WYSIWYG 2025 Update 5, your Cloud License must not be expired. If using a dongle, its Lease must be 

current, or its Membership must expire no earlier than December 2025. 

Feedback 

Should you wish to provide feedback regarding WYSIWYG, please email wygfeedback@castgroupinc.com.  

Copyright Information 
© The CAST Group of Companies Inc. 2004-2025. All rights reserved. 

35 Ripley Avenue, Unit 1 – Toronto – Ontario – Canada - M6S 3P2 

“WYSIWYG”, “Vivien” and “CAST Software” are registered trademarks of CAST Group of Companies Incorporated. Other 

brands or products are the trademarks or registered trademarks of their respective holders and should be treated as such. 

https://cast-soft.com/downloads/downloads-wysiwyg-vivien-hardware
https://cast-soft.com/downloads/downloads-wysiwyg-minimum-optimum/
mailto:wygfeedback@castgroupinc.com

