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About this guide

This guide provides an introduction to the basic functionality available in 
Vivien. Completing the lessons in the guide is the fastest way to get 
started using the program.

The lessons take you step-by-step through the process of planning an 
event in Vivien, and since each lesson builds on the previous one, it is 
important to do them in sequence. At the end of each lesson, you will 
save your work so that you can continue with the next lessons at your 
convenience.

The lessons guide you through basic concepts. For complete coverage of 
the features you learn in this guide, see the Vivien Users’ Guide or online 
Help.

Text conventions

The following text conventions are used in this guide:

 Menus and menu commands appear in Arial bold. For example, 
“from the Draw menu, choose Cylinder.”

 User interface elements such as buttons, tools, shortcuts, and 
dialog boxes appear in Tahoma Oblique. For example, “to draw a 
riser, click the Riser tool on the Draw toolbar.”

 Keyboard keys are indicated in ALL CAPS. For example, “press the 
TAB key to enter the missing coordinate.”

 References to manuals appear in italic font. For example, “for 
additional information on rendering, refer to the Vivien User’s 
Guide.”
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Lesson 1 - Getting started

This lesson introduces you to the basic parts of the Vivien user interface. 

In this lesson, you will learn:

 how to start Vivien
 how to create a new event document
 the basic parts of the Vivien interface

Step 1 - Start Vivien

To start Vivien

Double-click the Vivien shortcut icon on your desktop.

or

Select All Programs > CAST Software and then Vivien 2021 from the 
Windows Start menu. 

Result: The Vivien Welcome window opens.

 The Vivien icon.
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Under Create Event you can click a venue to create a new event file with a 
predefined venue, or you can click Blank to create a blank event file and 
define the venue later.

A list of shortcuts to recently opened event files is displayed under 
Recent Events. You can click any listed file to open it, or click More... to 
locate and open another event file.

Note: If this is the first time you have used Vivien, or if you have not yet 
saved any Vivien files, there are no files listed under Recent Events.

Step 2 - Create a new event document

From the Vivien Welcome window you can create a new event document 
or open an existing event document. In this lesson, you will create a 
new, blank event document.

To create a new event document

1 Under Create Event, click Blank to create a Vivien event document 
with no venue defined for it. 

Result: The Vivien main window opens. 

Menu bar Toolbars

Shortcut
bars

Layout
tabs
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Step 3 - Get to know the user interface

The Vivien interface includes the following components:

Menu bar
The menu bar is located at the top of the Vivien user interface, above the 
work area. The available menus change depending on the view tab 
selected at the bottom of the work area.

Toolbars
The toolbars appear below the menu bar. Toolbars provide button access 
to most commands and can be used in lieu of the menu bar. Like menus, 
the available toolbars change based on the view tab selected at the 
bottom of the work area. You can right-click on a toolbar and select 
which toolbars display.

Shortcut bar
The shortcut bar displays on the left side of your screen. The shortcut bar 
organizes shortcuts, which provide quick access to library items and 
views. Each view tab has designated shortcut bars.

Click a shortcut name to list the available shortcuts in that category. 
Vivien includes some useful Render, Spreadsheet, Layouts and Event 
Resources shortcuts, but you must create all your own Library shortcuts.
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Library Browser
Vivien includes an extensive library of predefined objects that you can 
quickly add to your files by double-clicking them and dropping them into 
a wireframe view of your drawing. These are 3-dimensional shapes 
drawn to scale representing the real-life objects that you need to account 
for when planning your event (for example, tables, chairs, podiums, 
projectors, lights, and so on).

You can view the contents of the Vivien library in the Library Browser, 
which is categorized to help you find the items you are looking for. Each 
category is represented by a menu item in the Library menu and a tab in 
the browser.
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View tabs
View tabs appear at the bottom of the screen. These tabs define work 
areas or views that are designed for specific tasks. For example, the 
Drawing Wireframe tab contains a grid outline for drawing your event. The 
Event Resources tab includes a spreadsheet work area that lets you work 
with your information in the drawing and manipulate it in tabular format, 
much like and Excel spreadsheet. Click a tab to switch to that work area.

Status bar
The status bar appears along the bottom of the Vivien screen, below the 
view tabs. The status bar includes:

 the prompt line, which provides information about tools and 
commands as you hover your cursor over them and instructions for 
actions with multiple steps

 the coordinates of the cursor
 the Height value, which you will learn about in Lesson 3



8

 Version 2024

 the working measurement units
 the status of the snap and ortho commands
 the selection count: “O” stands for the number of objects currently 

selected; “F” stands for the number of fixtures selected

Work area
The work area displayed depends on the selected tab.

Drawing Wireframe tab
The Drawing Wireframe tab displays a drawing work area where you create 
your event drawing. By default, the work area on the Drawing Wireframe 
tab has a grid to help you place objects.

Lighting Wireframe tab
The Lighting Wireframe tab also displays a drawing work area. However, 
you can use this tab only for customizing the lighting for the event; you 
cannot add or modify objects in the Lighting Wireframe tab. You can only 
select lights and customize their effects.

Selection Count Tables and Seats Coordinates Height Units, Ortho, SnapPrompt 
Line

The grid is useful for placing objects in your drawing.
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Drawing Quad and Lighting Quad tabs
The Drawing Quad and Lighting Quad tabs each display four work areas: 
three drawing areas, and one Virtual View. This Virtual View is a 3D view 
that simulates the way the event would look in real life with the default 
lighting. 

Virtual View tab
The Virtual View tab displays a shaded (rendered) view of the drawing in 
3D. This view simulates the way the event would look in real life with the 
custom lighting you added. Surfaces, are “filled-in” or solid (shaded) 
rather than outlined as in drawing wireframe views. 

Note: The work area on the Virtual View tab is black until you define the 
venue.
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Images tab
The Images tab provides an area to store images, such as renderings and 
logos. Renderings are stored here automatically when you render your 
event using the default render options. You can import any other images 
in many formats (bitmap, jpeg, gif, etc.), and then add these images to 
your printable Layouts for the event. When you first click this tab, it 
shows a placeholder image. You can replace this image with your own 
company logo so that you can use it in your proposals and printable 
layouts.
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Spreadsheet tab
The Spreadsheet tab provides a work area where you can create 
spreadsheets containing any information you want (for example, 
budgets, schedules, and lists of items required for the event, but not 
included in the inventory). You can add these spreadsheets to your 
printable layouts for the event or export them to Microsoft Excel for 
further work.
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Layouts tab
The Layouts tab provides all the tools necessary for creating professional 
printouts of your event document. You can include drawings, 
spreadsheets, and images in your layouts.

Event Resources tab
The Event Resources tab enables you to work with your information in a 
wireframe drawing view and manipulate it in tabular format. 

The inventory provides a list of all the items in the drawing that were 
added from the library. Changes to the inventory view are reflected in the 
drawing view and vice versa. You can export the inventory to an external 
spreadsheet program where you can format and manipulate the 
information.
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Reports tab
The Reports tab enables you to open a series of pre-formatted reports 
containing all guest information and table seating assignments, plus 
some catering lists for your event. These reports are available for you in 
three pre-defined template styles. Reports are designed to be printed 
documents and can be exported as PDF files or spreadsheet files that you 
can open with an external program such as Microsoft Excel.
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Guest Management tab
The Guest Management tab enables you to seat your guests at tables 
and chairs, track which guests have been seated and which have not yet 
been seated, number tables using the numbering tool, and label chairs 
and tables using a variety of options. Once you have assigned your 
guests to the appropriate seats, you can print reports containing all of 
your seating information.
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3D coordinate system
When drawing in Vivien you are working in a 3D environment. Objects 
are drawn as 3D objects, with width, depth, and height values based on a 
coordinate system of 3 working axes—X, Y, and Z. The point where the 3 
axes meet is called the origin. The values of X, Y, and Z at this location 
are 0, expressed as (0,0,0), as shown in the following graphic.

Drawing views
While working in your Vivien drawings, you can use the View menu to 
change the perspective of your drawing in either of the wireframe or 
quad tabs. You can view your drawing from the top (plan view), front, 
back, right side, left side, or you can choose to view it in a more realistic 
3D representation called a 3D view.

To switch to a different view type

From the View menu, choose View Type and then select one of the 
following views:

Origin (0,0,0)

Z

XY
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Plan view

Plan views display the drawing from above looking down. This is similar 
to a plan view drawing on paper. In plan views, the working axes are X 
and Y and the Height value 
is Z. 

Left view

Left views display the drawing looking from the left side through the 
venue. This is similar to a section on paper. In left views the working 
axes are Y and Z.

Right view

Right views display the drawing looking from the right side through the 
venue. This is similar to a section on paper. In right views the working 
axes are Y and Z.

Front view

Front views display the drawing looking from the front side through the 
venue. This is similar to an elevation on paper. In front views the working 
axes are X and Z.

Back view

Back views display the drawing looking from the back side through the 
venue. This is similar to an elevation on paper. In back views, the 
working axes are X and Z.

3D view 

A 3D view is a 3D perspective drawing. Although you view the drawing in 
the 3D perspective while in 3D view, you can only work in two axes. In 
3D views, the working axes are dependent on the workplane selected. 
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To switch to a different workplane in a 3D view

The workplane is only applicable if you are in a 3D view. From the View 
menu, choose Workplane and then select one of the following 
workplanes:

Note: For information on the missing coordinate, see see “The Height 
value” on page 43.

 Workplane Plan - The working axes are X and Y.

 Workplane Section - The working axes are Y and Z.

 Workplane Elevation - The working axes are X and Z.
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Lesson 2 - Defining the venue

The venue is the physical space where your event will take place. In this 
lesson, you will set the dimensions for the venue and customize the 
space to correspond with the real world event space. 

In this lesson, you will learn how to:

 Define a venue
 Use the Cylinder drawing tool
 Duplicate objects in Vivien
 Add an object from the Vivien object library
 Save an event document
 View a 3D Virtual View representation of the event

Step 1 - Define the venue

When you set the dimensions of the event space, Vivien draws the 3-
dimensional (3D) plan for it, defining where the walls, floors, and ceilings 
are.

To define the venue

Note:
 This step continues directly from Lesson 1. Therefore, to follow the 

procedure correctly, you must first proceed through Lesson 1, 
leaving the Vivien file open at the end.
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1 Click the Drawing Wireframe tab at the bottom of the work area, if it is 
not already selected.

2 From the Draw menu, choose Venue, and then choose Room. 
Result: The New Venue - Room dialog box opens.

3 If it is not selected already, click Imperial to change the units of 
measure to feet and inches. 

4 Type the following values, and then click OK.
 Width: 64

 Depth: 88

 Height: 20

Result: Your drawing now contains a very basic plan of the room, 
viewed from the top (Plan view). 

Note: If you do not see the entire room in the workspace, from the 
View menu, choose Zoom Fit.

The view of your room from the top (or the floorplan) is referred to 
as the Plan view in Vivien. It is a flat, 2-dimensional (2D) view. 

Note: You can view 2D drawings of the room from the top, left, right, 
front, and back. You can also view a 3D perspective view of the 
room, called a 3D view.
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5 From the View menu, choose View Type, and then choose 3D to see a 
3D perspective view of the room.

6 From the View menu, choose View Type and then Plan to return to the 
floorplan view of the drawing.

Step 2 - Customize the venue

Your drawing currently represents an empty room. The room where the 
event will take place has characteristics that should be included in the 
drawing before you start setting up the room (for example, doors and 
architectural elements, such as pillars). 

You can build your event space from basic objects such as circles, 
spheres, cylinders, and risers, which are available from the Draw menu.

You can also select ready-made architectural items from the Vivien 
Library, a repository of predefined objects that are drawn to scale.

In this step, you will add four pillars to the drawing and place a door.

To add pillars

Note before you begin:
 In step 11 of this procedure, you are prompted to type a value. When 

you start typing, a small box automatically appears in the bottom left 
of the window. This box is called the Command Line and looks like 
this:
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1 From the Draw menu, choose Cylinder.

Result: The New Cylinder dialog box opens.

2 Type the following values, and then click OK.
 Height: 20 (The height of the room is 20’.)

 Diameter: 3
Result: The cylinder attaches to the cursor, ready to be placed.

3 Move the cursor inside the room until the coordinates on the status 
bar at the bottom of the window read: 
x=-24’0”, y=-24’0”, z=0’0”
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Note: There is a minus sign in front of the first two values (they are 
both negative values).

4 Click to place the cylinder in the drawing.
5 On the Draw toolbar, click the Cylinder tool. 

Result: The New Cylinder dialog box opens with the values you 
entered in Step 2.

6 Click OK.
7 Move the cursor inside the room until the coordinates on the status 

bar read: 
x=24’0”, y=-24’0”, z=0’0”

 The Cylinder button.
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Note: There is a minus sign in front of the second value (the “y” 
value).

8 Click to place the cylinder in the drawing.
9 Click anywhere in the drawing to finish placing the cylinder.
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10 While pressing the left mouse button, drag an outline from left to 
right around both cylinders to select them, as shown in the following 
graphic:

This outline appears as you drag
your cursor from left to right 
and down

Cursor dragged down
to the bottom
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11 Release the mouse button.
Result: The box outline that you drew disappears and the cylinders 
are each selected, as shown below.

12 From the Edit menu, choose Copy and then choose Paste.
Result: The copied cylinders attach to the cursor, ready to be 
pasted.

When you release the mouse button,
the cylinder are selected and change
to this shape.
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13 Type the following values: -24,24,0 (When you start typing, the 
Command Line automatically appears below the work area.) 

The Command Line appears
automatically when you start typing.



28

 Version 2024

14 Press ENTER on your keyboard.
Result: Vivien pastes the copy of the cylinders at the coordinates: 
x=-24’0”,y=24’0”,z=0’0”.

To place a door

Note before you begin:
 The term “cross hairs” refers to the two lines that form a cross 

wherever you move your cursor in the drawing.
 In Step 10 of this procedure, you are prompted to type a value. 

When you start typing, the value is entered in a small box (the 
Command Line) that automatically appears in the bottom left of the 
window. 

 The Status bar is located at the bottom left corner of the window and 
displays messages for you.
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1 From the Library menu, choose Architecture.

Result: The Architecture tab of the Library Browser opens.

2 Double-click Doors to expand the heading and view all the available 
doors in the library.

3 Double-click Wood Double Doors and move your cursor onto the work 
area.
Result: The doors attach to the cursor, ready to be placed. 
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4 Click anywhere inside the room to place the door in the drawing. 

Note: The doors are still attached to the cursor, enabling you to 
continue to place more doors simply by clicking on the drawing (i.e., 
you do not need to reselect the door from the Library). 

5 Right-click anywhere in the drawing and select Finish Library Item to 
finish placing doors.
Result: The doors are no longer attached to the cursor.

6 Press the PAGE UP key on your keyboard (or use the middle roller 
wheel on your mouse, if applicable) to zoom in for a larger view of 
the doors. Use the scroll bars to centre the view.

7 Click on the door outline to select it.
Note: You must click a line on an object to select it. Clicking an area 
inside the object lines will not select the object. When you have 
successfully selected an object, its lines become gray and dashed.

8 From the menu, choose Rotate.
Result: The cross hairs of the cursor turn red and the Status bar at 
the bottom left of the window prompts you to pick a base point.
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9 Move the cursor so that it is aligned with the base of the door and 
click once.

Result: The door icon changes to indicate you are in the middle of a 
rotate operation and you are prompted to enter the rotation angle. 
Do not click in the drawing again.

Cursor
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10 Type 90 and press ENTER on your keyboard. When you start typing, 
the Command Line automatically appears below the work area, 
listing the value that you type. 
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When you press ENTER, Vivien rotates the door 90 degrees. Do not 
click in your drawing yet.

11 Press PAGE DOWN to zoom out so you can see the outline of the 
room and the selected door.

12 Without clicking in the drawing, hover your cursor over the outline of 
the door until the cursor changes to an arrow with a box. 
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13 Click on the door and drag it to the right wall, as shown in the 
following picture.

14 Click in the work area to ensure that no objects are selected.

Step 3 - Save the document

In this step, you save your event document, giving it a unique name.
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1 From the File menu, choose Save As.

Result: The Save As dialog box opens.

Note: If the following box appears, it is because you did not deselect 
all objects in your drawing. Click Cancel, and then click anywhere in 
your drawing to deselect all objects. From the File menu, choose 
Save As again, and then proceed to the next step.

2 In the Save In box, select the location where you want to save the 
file.

3 In the File name box, type:
VivienLesson2

4 In the Save as type box, ensure that the file type is Vivien Files (.vvn) 
and click Save.
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Step 4 - View the venue in 3D

Virtual Views simulate the way the event would look in real life. Surfaces 
in the Virtual View are “filled-in” or solid (shaded) rather than outlined as 
in the drawing wireframe views. 

To view the venue in a 3D view

1 Click the Virtual View tab below the work area to switch to a 3D virtual 
view of your venue design. 

2 Click anywhere in the drawing to make it active.
3 Press the PAGE DOWN key on your keyboard to zoom out to see the 

entire venue in the work area.
Tip: If you have a middle roller wheel on your mouse, you can also 
use it to zoom in and out of your drawings.
Result: Your venue should look similar to the following picture.

To move the camera

The “camera” is like your point of view; it is the angle at which you see 
the drawing. You can move the camera with your mouse for a different 
perspective of the room. 
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1 Move the cursor over the view, press the left mouse button and drag 
left or right, up or down. 

Result: The cursor changes to a hand and the view changes. 

2 Release the mouse button to set the view.

Note: As you move the image around, notice that the wall of the 
room that is currently in front of the camera becomes temporarily 
invisible, enabling you to see inside the room. 
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3 Proceed to the next lesson.
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Lesson 3 - Setting up a stage

In this lesson, you will set up a stage for the event. The stage will have a 
podium on it and a projection screen. It will also have a backdrop of pipe 
and drape.

In this lesson you will learn how to:

 Use the Riser tool
 Use the Projection Wizard
 Add objects to a raised surface
 Use the Pipe and Drape Wizard

Step 1 - Add the stage

In this step, you will add a stage to the venue and then resize it.

To add a stage

1 Open the file VivienLesson2.vvn, if it is not already open. (From the File 
menu, choose Open, and then locate and select the file.)

2 Click the Drawing Wireframe tab if it is not already selected.
3 From the View menu, choose Zoom Fit to display the entire venue in 

the work area.
4 From the Draw menu, choose Riser. 

Result: The New Riser dialog opens.

5 Specify the dimensions of the riser as follows, and then click OK:
 Width: 16

 Depth: 8
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 Height: 4
Result: The riser attaches to the cursor, ready to be placed.

6 To make placing the riser easier, right-click, and select Bottom Center 
as the insertion point.

7 Using the following graphic as a guideline, move the cursor inside the 
room so that coordinates on the status bar read:
x=0’0”,y=28’0”,z=0’0”

Note: The “x” value is negative (it has a minus sign in front of the 
number).

8 Click to place the riser in your drawing.

To resize the stage

Note before you begin:
 The term “selection box” refers to the small squares that appear at 

each corner of the riser when you select it with your mouse. When 
you click on one of these boxes and drag, you can resize the riser.



Getting Started Guide 41

April 2024  

1 Click on one of the lines of the riser to select it. (If you click in the 
middle of the riser, you do not select it.)

Result: Small squares (selection boxes) appear at each corner of the 
riser.

2 Drag the top right selection box up and to the right to make the 
stage wider and longer. Release the mouse button when the stage is 
as shown in the following picture.

Note: You may notice as you drag that the lines snap to the grid like 
a magnet. Snapping is a feature that helps you align objects to the 
grid as you place, resize, and move objects.

3 From the Tools menu, choose Snap Mode and then Snap State to turn 
snapping off.

4 Drag the top right selection box to see the difference when snap is 
turned off.

5 Restore the stage to the size shown in Step 2.
6 Press F9 on your keyboard to turn snapping on again.

Step 2 - Add a podium to the stage

The following diagram shows the three working axes in a 3D space (like a 
room):

 x axis is the width of the room
 y axis is the length of the room
 z axis is the height of the room

The point at which they meet is called the origin, where each of their 
values is 0 (0,0,0).
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2D views

The Plan view (or floorplan) is a 2-dimensional view represented by the x 
and y axes, as shown in the following graphic. 

Note: For more information about the different types of views available 
in Vivien, see “The Height value” on page  43.

Since this view is flat, letting you see only the width and length of the 
room (x and y respectively), you cannot see the axis that goes from the 
floor to the ceiling of your room (z axis). 

X

Y
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You cannot move an object in your drawing along an invisible axis (the z 
axis in Plan view). You can only move objects in the direction of the 
visible axes (in this case, the x and y axes). In this view, therefore, the 
value of the invisible z axis is always equal to zero (0) until you manually 
change it. 

If you need to place an object on a raised surface (for example, a podium 
on top of a stage), then you need to adjust the height of the z value to 
match the height of the object (i.e., the stage), as described below. 

The Height value
Whenever you want to place an object above the floor you have to tell 
Vivien how high you want to place it. This distance is known as the 
Height value and is given the axis letter z in Plan view.

In this procedure, you have to tell Vivien how high the stage is so that 
you can place the podium on top of it. If you do not set the Height value 
to match the height of the stage, the podium will be placed on the floor 
of your venue instead. 

Notes: 

 You can set the Height value only in Plan view.
 Whenever you set the Height value, it stays at the value you type 

until you reset it. This means that all objects that you add to your 
drawing are placed at this height. For example, in this procedure the 
stage is 4 feet high, so you set the Height value to 4 feet (z=4’). 

After you add the podium to your drawing, you must reset it back to zero 
(z=0’) if you want to place objects on the floor.

To set the Height value

1 From the View menu, choose View Type and then Plan to switch to the 
Plan view, if you are not already in it.

2 From the Tools menu, choose Height.
Result: The Enter the Height dialog box opens.

3 Enter the Height value. The riser is 4’ high, so type 4 and then click 
OK.
Result: The status bar indicates the change: Height:z=4’0”. 
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To add a podium to the stage

1 From the Library menu, choose Staging. 

Result: The Library Browser displays the Staging Library tab.

2 Double-click the Podiums & Lecterns heading to view the selection of 
podiums in the library.

3 Double-click Large Podium to attach it to the cursor. 
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4 Move the cursor over the riser and click to place the podium. 

5 Right-click anywhere on the drawing and select Finish Library Item to 
finish placing podiums.

6 From the View menu, choose View Type and then Front to view the 
stage from the front of the room.

The Front view is represented by the X and Z axes.

Notice that the podium is sitting on top of the stage (z=4’0”) and not 
on the floor.

Podium

X

Z
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Step 3 - Add a projection screen to the stage

In this step you add a folding projection screen with a drape kit to the 
stage using Vivien’s Projection Wizard. You then place an image of your 
choice on the screen. 

Note: You can also use the Projection Wizard to add projectors, but in 
this example, you only add a screen.

To add a projection screen to the stage

1 Click the Plan tool on the View Type toolbar to view the floorplan of the 
room. 

2 From the Draw menu, choose Projection Wizard.
Result: The Select Wizard Options window opens.
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3 Click Create a Screen, and then click Next.
Result: The Select Screen Type window appears.

4 Click Folding Screen, and then click Next.
Result: The Define Folding Screen Dimensions window appears.

5 From the Predefined Size drop-down list, select 9’ x 12”.
6 Keep the default values for the Elevation Above Floor (3’0”) and the 

Length of Support Feet (2’0”).
7 Ensure that a check mark appears in the Include Drape Kit box.
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8 Click Next.
Result: The Define Drape Kit Dimensions window appears.

9 In this window you can choose where the drape kit appears, and set 
the dimensions of the drape panels. In this example, accept the 
default values, and then click Next.
Result: The Content Selection window appears.

10 Click Image Source.
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11 Click the New button.
Result: The Image Manager window opens.

12 In the Image Manager, click the New button.
13 Navigate to a location on your computer where an image is stored 

(for example, the My Pictures folder), click the image select it, and 
then click Open.
Result: The image is added to the Image Manager.

14 Click OK.
Result: The Image Manger window closes. The image is now listed 
under Image Source in the Projection Wizard window.

15 Click Finish.
Result: The screen attaches to the cursor, ready to be placed. 
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16 Move the cursor over the stage and click to place the screen in your 
drawing, as shown in the following picture.

17 On the toolbar, click the Height icon, and then type 0 to reset the 
Height back to z=0’0”. 

18 Click OK.
Note: The status bar at the bottom right of the window reads Height: 
z=0’0”.

19 Click the Front tool on the View Type toolbar to view the stage from the 
front of the room. 

Note: You cannot see the screen image in wireframe views. The 
image displays only in Virtual Views and in the final rendering.

20 Click in the work area so that no objects are selected.
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Step 4 - Add pipe and drape

In Step 4, you use the Pipe and Drape Wizard to add a length of drape 
behind the stage. This Wizard gives you two options for drawing 
drapeline, with each option giving you progressively more choice in 
terms of customization. 

You can use this Wizard to draw standard lengths of drape, or whatever 
size and shape of drapeline you like. In this step you will place a straight 
length of drape behind the stage.

To add pipe and drape

1 Before you draw the drape, you must adjust the Height value back to 
0’ so the drape rests on the floor. Click anywhere in the drawing.

2 Press TAB, and then type 0’.
3 Click OK. The Height value on the Status bar changes to Height:z=0’0”.
4 Press F9 on your keyboard to disable all snaps (so the drape does not 

snap to the grid in the drawing area).
5 Click the Pipe and Drape Wizard icon. 

Result: The Select Drawing Method window appears.
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6 Select Specify, and then click Next.
Result: The Define Drape Line Dimensions window appears.

7 In the Height box, type 15’.
8 Leave all other defaults selected and click Finish.

Result: The drapeline attaches to your cursor.

9 Using the following graphic as a guideline, click to place the drapeline 
behind the stage, centered:

10 Click the Virtual View tab to see the drape behind the stage.

Step 5 - Save the document

Save your event document, giving it a unique name.
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To save your document

1 From the File menu, choose Save As.

2 In the Save In box, select the location where you want to save the 
file.

3 In the File name box, type VivienLesson3.
4 In the Save as type box, ensure that the file type is Vivien Files (.vvn) 

and click OK.
5 Proceed to the next lesson. 
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Lesson 4 - Adding and assigning seating

To add multiple chairs to your venue, you could place each chair 
individually or add a single chair and then copy it using the Clone tool. A 
more efficient approach is to use the Seating Wizard.

In this lesson you will learn how to add multiple chairs and tables using 
the Seating Wizard.

Then, you will use the Guest Management feature to add guests and 
assign them to seats.

Step 1 - Add dining tables

In this step you will add 10 dining tables in front of the stage.

To add dining tables

1 Open the file VivienLesson3.vvn, if it is not already open. (From the File 
menu, choose Open, locate and select the file.)

2 Click the Drawing Wireframe tab.
3 Click the Plan tool on the View Type toolbar to change the view to the 

Plan view. 
4 Press PAGE DOWN on your keyboard to zoom out, if necessary.
5 From the Draw menu, choose Seating Wizard.

Result: The first pane of the Seating Wizard opens.
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6 You want the tables to fill a rectangular area in front of the stage, so 
leave the default Layout Shape as Rectangular, and then click Next.
Result: The Wizard pane closes, prompting you to draw the layout 
area.

7 As shown in the graphic on the next page, drag a rectangle from the 
top left, where the coordinates have this value:
x=-20’0”,y=24’0”,z=0’0”

...to the bottom right, where the coordinates have this value:

x=20’0”,y=-8’0”,z=0’0”

Note: Two of these values have minus signs in front of them (they 
are negative values).
...and click.

Result: The next pane of the Seating Wizard opens instructing you 
to point the layout arrow in the direction of interest.
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8 Click Next.
Result: The Wizard pane closes and the layout direction arrow 
attaches to your cursor.

9 Point the cursor towards the stage, as shown in the following picture, 
and click.

Result: The next pane of the Seating Wizard opens instructing you 
to select a layout style.
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10 Click Banquet, and then click Next.
Result: The next pane of the Seating Wizard opens instructing you 
to specify whether aisles are required in the seating area.
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11 Click Next without making any changes as no aisle is required.
Result: The next pane of the Seating Wizard opens, instructing you 
to select an item from the library.

12 Click on the Tables Sets heading, then double-click the Imperial 
heading to choose from tables drawn in imperial units. 

13 Click on the Dining heading.
14 Click on the Round heading to list all the available round dining 

tables.
15 Click on the 4ft heading to list all the tables that are 4 feet in 

diameter.
16 Click on the w 6 Banquet Chairs heading to list all the tables that 

seat 6.
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17 Scroll down and click 4ft Round Dining Table w/ 6 Chairs and Tablecloth 
and Overlay to select a four-foot round table with a tablecloth and six 
chairs.

18 Click Next.
Result: The next pane of the Seating Wizard opens instructing you 
to specify the spacing between tables.

19 In the Center to Center box, type 10’ to space the centers of each table 
10’ from each other.
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20 Click Next.
Result: The next pane of the Seating Wizard opens instructing you 
to select how you want the tables aligned within the layout area.

21 Leave Center as the selection, to space the tables uniformly between 
the left and right edges of the defined area, maintaining the seating 
style.

22 Click Next. 
Result: The next pane of the Seating Wizard opens instructing you 
to specify any restrictions on the number of tables in each row
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23 Click Next without making any changes to impose no restrictions.
Result: The next pane of the Seating Wizard opens, instructing you 
to specify the number of items you want placed in the layout area 
you defined.
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24 Click Next without making any changes to the maximum seating 
capacity.
Result: The Seating Wizard Results dialog box opens, summarizing the 
number of seating items you added, the seating capacity, the venue 
area, and so on. If you resize the seating area, the Seating Wizard 
Results dialog box summarizes the new total seating capacity and 
available seats, as well as the total seating area and venue area.
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25 Click Finish.
Result: The tables are placed in the defined area according to your 
specifications.

Step 2 - Add chairs

In this step you will add as many chairs as possible to the remaining 
seating area.

To add a chairs

1 Click the Seating Wizard tool on the Draw toolbar. 

Result: The first pane of the Seating Wizard opens.

2 You want the chairs to fill a rectangular area behind the tables so 
leave the default Area Type as Rectangle, and then click Next.
Result: The Wizard pane closes and the cursor cross-hairs change to 
red.

3 As shown in the graphic on the next page, drag a rectangle from the 
top left:
x=-20’0”,y=-4’0”,z=0’0”

...to the bottom right:

x=20’0”,y=-40’0”,z=0’0”
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...and click.

Note: There are minus signs before some of these values.

Result: The next pane of the Seating Wizard opens instructing you 
to select a direction for the chairs to face.

4 Click Next.
Result: The Wizard pane closes and the Seating Direction arrow 
attaches to your cursor.
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5 Point the cursor towards the stage, as shown in the following picture, 
and click.

Result: The next pane of the Seating Wizard opens instructing you 
to select a layout style.

6 Select Classroom as the layout style.
7 Click Next.

Result: The next pane of the Seating Wizard opens instructing you 
to specify whether an aisle is required in the seating area.
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8 Click Next without making any changes to accept the default setting.
Result: The next pane of the Seating Wizard opens instructing you 
to select the chairs from the library.

9 Scroll down and, in the Chairs, All category, click Stacking Chair.
10 Click Next.

Result: The next pane of the Seating Wizard opens instructing you 
to specify the spacing between chairs.
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11 Click Next without making any changes to accept the defaults.
Result: The next pane of the Seating Wizard opens instructing you 
to select how you want the chairs aligned within the layout area.

12 Leave Center as the selection, to space the tables uniformly between 
the left and right edges of the defined area, maintaining the seating 
style.

13 Click Next. 
Result: The next pane of the Seating Wizard opens instructing you 
to specify any restrictions on the number of chairs in each row.
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14 Click Next without making any changes to impose no restrictions.
Result: The next pane of the Seating Wizard opens instructing you 
to select how many chairs you want placed in the area you defined.

15 Click Next to fit as many chairs as possible in the area.
Result: The Seating Wizard Results dialog indicates how many items 
were placed.
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16 Click OK.
Result: The chairs are placed in the defined area according to your 
specifications.

Step 3 - Adding guests

Before you can assign guests to seats, you first have to add the guests to 
Vivien. In this step, you are going to use the Guest Management feature 
to add guests to Vivien. 

You can add guests one at a time manually (using the New Guest button in 
the Guests dialog box) or you can add all guests at once by importing a 
spreadsheet containing your guest information (by clicking File > Import 
Guest on the Guest Management tab).

In this procedure, you are going to add guests manually.

1 On the Guest Management tab, click Tools > Guests. 

Result: The Guests dialog box appears.
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2 Click New Guest.
Result: The Add New Guests dialog box appears.

3 Fill in the information to add the guest:
 Title: Type the guest’s title (i.e., Mr., Mrs., Miss, Ms.).

 First Name: Type the guest’s first name.

 Last Name: Type the guest’s last name.

 RSVP Status: Select whether the guest has indicated they are 
attending (Yes, No Reply, No).

 Group Name: Type the name of the group that this guest belongs 
to.

 Age Group: Select the age group for this guest (Adult, Senior, 
Child).

 Menu Option: Specify any particular menu preferences for this 
guest.

 Note: Add any notes for this guest.

4 To save this guest and continue adding more guests manually, click 
Add. 

5 Continue adding as many guests as you like. When you are finishing 
adding the last guest, click Add and Close.
Result: The guests appear in the Guests dialog box.
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Step 4 - Assigning guests to seats

You can assign guests to seats that are around a table or to freestanding 
seats that you have placed in your drawing. 

When seating guests at tables, you may only seat them at table sets, 
that is, tables that are already grouped with chairs, as opposed to tables 
with chairs placed manually around them. For more information on table 
sets, see the Vivien User’s Guide.

In this procedure, you are going to assign guests to individual seats.

To assign guests to freestanding seats

Note: Before you perform this procedure, your seating arrangement 
must already be prepared. If you change your seating arrangement after 
you assign guests, all of your seating assignments are lost. 

1 On the Guest Management tab, if the Guests window is not already 
visible, click Tools > Guests to show it.

2 If the Unassigned Guests window is not already visible, click Tools > 
Unassigned Guests to show it.

3 In the Unassigned Guests window, click to select the first guest and 
drag to place the guest on the appropriate seat.
Result: The seat turns green and the guest’s name is highlighted in 
green in the Guests window to indicate that the Guest is assigned.
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4 Continue clicking and dragging guests to the appropriate seats until 
all guests are seated. 
 To assign a group of guests to a series of freestanding seats, 

press CTRL and, in the Unassigned Guests window, click to select 
each of the guests that are in the group. Then, drag the group to 
the appropriate seats and click on the first seat that you want to 
assign to a member of the group. Vivien assigns the remainder of 
the group to the other seats. 

 To automatically seat all guests at once, click Seat All. Vivien 
chooses the seats for each guest.

5 Click File > Save As and save the document as VivienLesson4.
6 Proceed to the next lesson.
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Lesson 5 - Changing the color scheme

You can experiment with colors in Vivien, enabling you to customize your 
event design.

In this lesson you will learn how to:

 Change the venue color
 Change the color of drawing objects
 Add materials to drawing objects
 Change the color of library objects

Step 1 - Change the ceiling, wall, and floor color

In this step, you will change the color of the ceiling, walls, and the floor.

To change the ceiling, wall, and floor color

1 Open the file VivienLesson4.vvn, if it is not already open. 

2 Click the Drawing Quad tab at the bottom of the work area.
Result: Four distinct views of your drawing display in the work area 
by default (you can change any of these views).

 A Plan view displays in the top left corner.

 A Right section view displays in the top right corner

 A Front elevation view displays in the bottom left corner.



76

 Version 2024

 A Virtual View displays in the bottom right corner.

3 Click the top left (Plan) view to make it active.
Tip: You can make color changes in this view (or any of the 
wireframe views) and see their effect immediately in the Virtual View 
in the lower right-hand corner.
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4 Click the room outline to select it, and then right-click and select 
Object Properties. 
Result: The Properties window opens.
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5 Click the Appearance tab.

6 Press CTRL on your keyboard, and then click Ceiling, Floor, Wall - 
Back, Wall - Front, Wall - Left Side, and Wall - Right Side. 

7 Click Custom Color, and then click the small box beside it.
Result: The Color window opens.

8 Click a purple hex, and then click OK.

Result: The color box changes to the color you selected.

Click to select as 
the venue color.



Getting Started Guide 79

April 2024  

9 Click OK.
10 Click Apply.
11 Click OK.

Result: The wall, ceiling, and floor color changes to the color you 
selected.

Step 2 - Change the color of the stage

In this step, you will change the color of the stage to black.

To change the stage color

1 Click in the top left view (Plan view) to make it active.

2 Click an edge of the stage to select it, and then right-click and select 
Properties.

3 From the Modify menu, choose Object Properties.
Result: The Properties window opens.

4 Click the Appearance tab.

5 Press CTRL on your keyboard, and then click Riser - Back, Riser - 
Bottom, Riser - Front, Riser - Left Side, Riser - Right Side, and 
Riser - Top to select all components of the riser.
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6 Click Custom Color, and then click the small box beside it.
Result: The Color window opens.

7 Click the black hex (bottom right corner) and click OK.
8 Click Apply.
9 Click OK.

Result: The stage color changes to black in the Virtual View.

Step 3 - Add a material to the columns

Materials affect how objects or surfaces interact with light. Vivien 
includes a variety of materials to make your renderings look more 
realistic (i.e., simulating how light reflects off of fabric, glass, metal, and 
so on).

In this step, you will make the columns look like mirrors.

To add a material to the columns

1 Click in the top left view (Plan view) to make it active.

2 If necessary, press PAGE DOWN on your keyboard until you can see 
all four columns in the drawing.

3 Hold down the CTRL key and click each of the four columns to select 
them all.

4 From the Modify menu, choose Object Properties.
Result: The Properties window opens.

5 Click the Appearance tab.
6 In the Elements box, select each of the column elements by pressing 

CTRL, and then clicking each element.
7 Click the ellipsis button (...) beside the Material box.

Result: The Material Select dialog box opens.

8 Double-click the Mirror heading to list available mirror-like materials.
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9 Click Mirror 2 and then click the Select button.
Result: Mirror 2 displays in the Material box.

10 Click OK.
11 Click Apply.
12 Click OK.

Result: You will not be able to see the effect in the Virtual View, but 
it will be apparent when you render the view in Lesson 7.

Step 4 - Change the color of the tablecloths

You can change the color and apply different materials and textures to 
each element of a Library object.

In this step you will change the color of the tablecloths.

To change the tablecloth color

1 In the Drawing Quad tab, click in the top left view (Plan view) to 
make it active.

2 Click a table to select all the tables. (They were automatically 
grouped when you created them using the Seating Wizard.)

3 Right-click and select Object Properties.
Result: The Properties window opens.
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4 Click the Appearance tab.

5 In the Elements box, click Tablecloth to select it.
6 Click the box beside Use Custom Color.

Result: The Color chooser opens.

7 Click a light blue hex) and click OK.
Result: The color box changes to light blue.

8 Click OK.
9 Click Apply.
10 Click OK.

Result: All the tablecloths change to light blue in the Virtual View.

11 Click anywhere in the drawing to ensure that all objects are 
deselected.

12 Save the document as VivienLesson5.
13 Proceed to the next lesson.
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Lesson 6 - Customizing the lighting

In this lesson you will add two lights and focus them on the speaker.

You will learn how to:

 Add a hang structure to your drawing
 Hang light fixtures
 Focus light beams
 Change the intensity and zoom of the light beam

Step 1 - Add a hang structure

Some light fixtures need to be suspended or hung. The structures they 
are hung on are called “hang structures,” which can be pipes or truss. 

To insert truss

1 Open the file VivienLesson5.vvn, if it is not already open. 

2 Click the Drawing Quad tab at the bottom of the work area, if it is not 
already selected.

3 Click in the bottom left view (Front view) to make it active.
4 From the Draw menu, choose Truss Wizard.

Result: The Truss Wizard dialog box opens.

5 In the Create section, click Specify.
6 In the Units section, leave Imperial selected.
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7 In the Fixture Direction section, leave Down selected.
8 In the Shape section, click Linear, and then in the Length box, type 20.
9 In the Type section click Ladder. 
10 In the Orientation section, select Horizontal and in the Trim Height box, 

type 18 to place the truss 18 feet up from the floor and then click OK.
Result: The truss attaches to the cursor, ready to be placed.

11 Using the graphic below as a guideline, move the cursor inside the 
room so that the coordinates on the status bar read:
x=-12’0”,y=0’0”,z=16’0”

...and then click to place the truss. 

Note: The truss is placed 18’ off the floor, according to your 
specification, rather than 16’, where your cursor was positioned.

12 Click in the top left view (Plan view).
13 Click on the truss to select it.
14 Drag the truss so that it sits above the podium, as shown in the 

following picture:
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Step 2 - Hang light fixtures

In this step you will hang light fixtures from the truss.

To hang light fixtures

1 On the Drawing Quad tab, click in the bottom left view (Front view) to 
make it active.

2 From the Library menu, choose A/V. 
Result: The Library Browser displays the AV tab.

3 Double-click the Lighting heading, and then double-click Moving 
Light.

4 Move the cursor over the active drawing (the Front view in the 
bottom left corner).
Result: The light attaches to the cursor.

5 Move the cursor over the truss and click to hang the light fixture, as 
shown in the following graphic:

6 Move the cursor along the truss to the right and click to place a 
second light, as shown in the following graphic:
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7 Right-click anywhere in the view and choose Finish Placing Fixtures. 
8 Look at the Virtual View in the bottom right corner. Notice that the 

selected light fixture casts a beam of light.

Step 3 - Focus light fixtures 

In this step you will focus the light fixture behind the podium.

To focus light fixtures

Note before you begin:
 You place light fixtures in Drawing Wireframe views, but you 

manipulate them in the Lighting Wireframe view. 
 You cannot draw anything within Lighting Wireframe views. To make 

changes to your drawing, you must switch to the Drawing Wireframe 
view.

1 Click the Lighting Quad tab.

2 Click in the bottom left view (Front view) to make it active.
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3 Double-click the light farthest to the left to show the light beam.

4 Drag the light beam in front of the podium to focus it, as shown in 
the following graphic:

Note: In wireframe views, light fixtures do not rotate to align with 
the focused beam of light. However, fixtures display rotated in the 
rendered view.
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5 As shown in the following graphics, look at the Plan and Right views. 
Notice that the light beam is not focused near the podium.

6 Click in the top left view (Plan view) to make that view active.
7 Click to select the light.
8 Click the light beam and, without releasing the left mouse button, 

drag the beam behind the podium, as shown in the following graphic:
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9 Repeat Steps 2 – 8 for the other light fixture.

Step 4 - Change the lighting effects

You can change the intensity of the light beam, the width of the beam 
and the light color. You can also make the light project a pattern (called a 
‘gobo’). 

To change the lighting effects

1 Click the Lighting Wireframe tab. 

2 Click the Plan tool on the View Type toolbar to switch to the Plan view. 
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3 From the Tools menu, choose Light Tool.
Result: The Light Tool displays to the right of the work area.

4 Drag a box around both lights to select them. 
Note: No other objects in the drawing can be selected in the Lighting 
Wireframe tab—only lights.

5 In the Intensity box beside the Off button, type 80. This changes the 
intensity to 80% of full intensity.
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6 In the Zoom section, click Wide to give the beams a wide zoom angle, 
as shown in the following graphic:

7 Move the pointer over the Zoom dial.

8 Hold down the left mouse button and drag down on the dial until the 
light beam is contained on the stage, as shown below, and then 
release the mouse button.

9 Click any color on the color pad to change the color of the light 
beams.

10 Beside the color pad, slide the arrow on the bar up or down to make 
the chosen color lighter or darker.



92

 Version 2024

11 In the Gobo box, click the down arrow on the scroll bar to step 
through the available light patterns. 

12 When you see a pattern that you want to apply to the selected lights, 
click the pattern. It is applied to both lights. 

13 Click the Virtual View tab at the bottom of the work area for a preview 
of the lighting effects you just added.

Step 5 - Save different lighting looks

When you experiment with lighting effects, you can save your settings as 
individual “looks”. Looks let you quickly switch between lighting effects 
for comparison without having to recreate them each time.

The default look is called ‘My Look’.
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To create a new look

1 Click the Lighting Quad tab

1 In the Looks shortcut bar area, right-click on My Look and choose 
Clone Shortcut. 

2 Type Multicolored Lights as the name of the new look, and then click 
OK.

3 In any of the wireframe views, click a light to select it.
4 Change the color of the light to a different color than the original.
5 In the Shortcut bar, click My Looks.

Result: The look changes to the original lighting.

6 In the Shortcut bar, click Multicolored Lights.
Result: The look changes to the two-colored lighting.

7 Save the document as VivienLesson6.
8 Proceed to the next lesson.
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Lesson 7 - Rendering images of the event

In Vivien, you can render your drawings to produce high quality images 
of your event. Rendering uses a full range of effects, including depth of 
field, motion blur, soft shadows, and antialiasing settings to produce a 
photo-realistic image. An easy-to-use Render Wizard provides interactive 
editing and advanced visual effects.

When you are creating a rendering, you have two choices:

 Render Wizard You can use the interactive editing and advanced 
visual effects of the Render Wizard to set up the look that you want 
to render, and then create the rendering. In this case, you must 
leave Vivien running while the Render Wizard finishes the image. You 
have the choice of saving the image to an external folder that you 
specify or within Vivien on the Images tab.

 Background Rendering Manager You can use the Render Wizard 
to set up the look that you want to render, and then send the render 
job to the Background Rendering Manager to create the rendering. 
This feature lets you use the Windows taskbar to queue render jobs 
that will execute in the background without requiring Vivien to run, 
letting you do other tasks while the Render Engine works 
independently. You can also pause and resume renderings without 
losing your render, and shut down/restart your computer without 
losing your rendering progress. For details on this feature, see the 
Vivien User’s Guide.

In this lesson you will learn how to render your event drawing using the 
Render Wizard.

Step 1 - Render the event

To render the event

1 Open the file VivienLesson6.vvn, if it is not already open. 

2 Click the Virtual View tab at the bottom of the work area.
Note: You can also render from the Lighting Wireframe and Lighting 
Quad tabs.
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3 From the Tools menu, choose Render Wizard.
Result: The Render Wizard opens and guides you through a series of 
options. 

4 Drag your mouse on the image to the right to adjust the view to 
render. When adjusting the view, perform the following actions:
 Pan/Tilt To move side to side or up and down in your drawing 

(i.e., without zooming in and out), press your left mouse button 
and move your mouse around.

 Zoom The zoom feature in Vivien is just like using a regular zoom 
lens on a camera—you stay in the same spot, but the camera lens 
brings the image into tighter or further focus. To zoom in and out, 
use the Page Up / Page Down buttons on your keyboard or the 
mouse wheel, if you have one. Note that the image can become 
distorted if you zoom too far out from the object, just like a 
regular camera. In this case, it’s much better to use the dolly 
feature described below.

 Dolly To view your drawing from very far away without distorting 
it, press CTRL on your keyboard and use your mouse wheel (or 
Page Up / Page Down buttons on your keyboard) to move the 
camera away from your drawing. You can also use the dolly 
feature to move the entire camera up/down and side to side (as 
opposed to just moving its lens). Press CTRL on your keyboard, 
hold down the left mouse button, and drag the image around.

5 In the Image section, change the image size (resolution) settings as 
follows:
 Width (X): 640
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 Height (Y): 480

6 Leave all defaults in the Background Rendering Manager section 
and click Next.
Result: Step 2 of the Render Wizard displays.

Note: By default, the Background Rendering Manager runs on the 
same system as Vivien. It is also possible to run it on a separate 
machine; for information on how to set this up, refer to the 
Background Rendering Manager section of the Vivien User’s 
Guide.



98

 Version 2024

7 Leave all defaults in this window and click Next.
Result: Step 3 of the Render Wizard displays. Options in step 3 of 
the Render Wizard affect the atmospheric conditions in your 
rendering. 
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8 Accept the defaults and click Next.
Result: Step 4 of the Render Wizard displays. Options in step 4 of 
the Render Wizard affect how shadows are projected in your 
rendering. 
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9 Slide the Beam Saturation to Realistic and click Next.
Result: Step 5 of the Render Wizard displays. Options in step 5 of 
the Render Wizard affect the radiosity level. Radiosity determines 
how light beams are reflected in your drawing. 
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10 Accept the defaults and click Next.
Result: Step 6 of the Render Wizard displays. Options in step 6 of 
the Render Wizard affect the presence and quality of environmental 
or outdoor lighting. For environmental lighting to have an effect, your 
event cannot be contained within a venue. 
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11 Since this event is indoors, the environmental settings are not 
necessary. Accept the defaults and click Next.
Result: Step 7 of the Render Wizard displays. Options in step 7 of 
the Render Wizard affect the antialiasing settings. Antialiasing is a 
method of smoothing and sharpening rough or jagged edges of 
images to produce a more polished result. 

12 Click Best for the highest quality.
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13 Click Finish. 
Result: Vivien generates the rendering of your event and makes it 
available on the Images tab.

Tip: During any step, you can click on the image and change the 
perspective (using the arrow, CTRL and PAGE UP/PAGE DOWN keys 
or the mouse). The Render Wizard calculates the rendering based on 
the state of the image composition and light settings at the moment 
when you click Finish.

Step 2 - View the rendered image

In step 2 of the Render Wizard, you specified that the rendered image 
should be stored internally, which means that the rendering is now saved 
within your event file.
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To view the rendered image

1 Click the Images tab below the work area.

Result: The default Logo placeholder image displays in the work 
area.

2 In the Shortcut area, click the Image shortcut.
Result: Your rendered image displays.

3 Right-click on the Image shortcut icon and choose Rename.
Result: The Enter New Image Name dialog box opens.

4 Type ‘Event Rendering’ and click OK.
5 Save the event document as VivienLesson7.
6 Proceed to the next lesson.
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Lesson 8 - Viewing the event resources

Vivien includes an event resources view that provides a list of all the 
items in the drawing that were added from the Library. Changes to this 
view are reflected in the drawing view and vice versa. You can export the 
event resources to an external spreadsheet program like Microsoft Excel 
where you can format and manipulate the information.

In this lesson, you will learn how to view and manipulate the event 
inventory.

You will learn how to:

 Sort the resources
 Move columns in the resources
 Hide resource columns
 Remove items from the drawing and resources
 Group items in the resources
 Cost items

Step 1 - View the event resources

The Event Resources tab enables you to view your information in a 
wireframe drawing view and manipulate it in tabular format. 
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To view the event inventory

1 Open the file VivienLesson7.vvn, if it is not already open. 

2 Click the Event Resources tab at the bottom of the work area.

3 In the drawing, select the podium.
Result: The row for the podium is highlighted in the resource 
spreadsheet. You may need to scroll down the inventory list to see 
podium row.

4 Scroll through the resources and click the row number beside 
Architecture | Wood Double Doors.
Result: The doors are selected in the drawing.

Step 2 - Manipulate the resources

You can rearrange and hide resource columns and you can sort the 
resources by columns. You can delete resource items, which also 
removes the items from the drawing.
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To manipulate the resources

1 Click the Type column heading to sort the list alphabetically by type.

Result: An arrow displays beside the column name indicating that 
the resources are sorted by this column. An up-pointing arrow 
indicates the row is sorted in ascending order. A down-pointing arrow 
indicates the row is sorted in descending order.

2 Drag the Purpose column heading to the right of the Cost heading. 
Release the mouse button when the red arrows are positioned 
between the Cost heading and the Period heading.

3 Right-click on the Order # column heading and select Hide Order # 
Column.

4 Right-click on any column heading and select Show Order # Column.
Result: The doors are removed from the inventory and from the 
drawing.

Step 3 - Group items

Grouping items in the resource list automatically tabulates how many 
items there are in the group and the total cost of the items (if you have 
applied a cost to the item).
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To group items

1 Click anywhere in the Event Resources spreadsheet to make it active.

2 From the Options menu, choose View Options.
Result: The View Options dialog box opens.

3 In the Sorting and Grouping section, from the Key 1 selection box, 
select Type and click Group By to select it.

4 From the Key 2 selection box, select Model and click Group By to select 
it.

5 Click OK.
Result: The items are grouped by type, and within each type, by 
model.

6 Click the plus sign (+) beside Chairs to expand the group. 
Notice that the chairs are grouped by model within the chair group.
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Step 4 - Costing items

You can tabulate the cost of items by grouping them.

To cost an item

1 Click the plus sign (+) beside Model: Stacking Chair.

2 Click the Cost cell for the first chair listed.

3 Type 4 and press ENTER on your keyboard.
Result: The cell now has $4.00 in it.

4 Click the cell with $4.00 in it. 
5 Right click the cell and choose Copy.
6 Click the cell below the copied cell and drag to select all the cost cells 

for the chairs.

7 Right click and choose Paste.
Result: All the selected cells populate with $4.00. 
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Also notice that the row for the group displays a total cost for all the 
items in the group.

Step 5 - Create a new resource list

You can create any number of resource lists containing the same 
information but sorted and grouped differently. You create different 
resource lists by creating a shortcut for each one on the Event Resources 
shortcut bar. 

To create a new resource list

1 Right-click on the Event Resources shortcut area and choose New 
Resources.

2 Type the name of your inventory and click OK.
Result: A new resource list displays with the default sort and group 
information.

Note: Any changes you make to a resource list while its shortcut is 
selected are saved automatically and associated with that shortcut. 
You can quickly switch between the versions of the resource list by 
clicking their shortcut icons.

3 Save the event document as VivienLesson8.
4 Proceed to the next lesson.
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Lesson 9 - Assembling drawings and images for 
printing

Vivien includes tools for turning your event plan into documents that can 
be viewed and used by anyone involved in the event. You can create 
professional proposals of your event document that include drawings, 
images, and spreadsheets. 

In this lesson, you will learn how to:

 Create spreadsheets
 Create layouts
 Add drawings, images, and spreadsheets to layouts
 Add graphic elements and text to layouts

Step 1 - Create a spreadsheet

The Spreadsheets tab contains a spreadsheet that is similar to many other 
spreadsheet programs. You can enter data here, as well as import and 
export data to other spreadsheet programs. This is useful for creating 
spreadsheets for staff requirements, schedules, budgets or any other 
event-specific data that you want to add to your presentation layouts.

Vivien comes with two predefined spreadsheets that you can use to form 
the basis of your own customized spreadsheets.

In this lesson you will use one of these predefined spreadsheets and 
update it with your own event information.

To update a spreadsheet

1 Open the file VivienLesson8.vvn, if it is not already open. 

2 Click the Spreadsheet tab.
Result: The default spreadsheet, Title Block, displays.

The Title Block spreadsheet contains variables that are replaced 
automatically with information that you enter about the event 
document when you print it.
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Variables are expressed with SmartCells, indicated by cells 
containing a drop-down arrow. 

3 From the Options menu, choose Document Options.
Result: The Document Options dialog box opens.

4 Click the Event Info tab.
5 In each of the boxes, type the following information and click OK:

Producer: C. Lee
Event Name: ABC Company Awards Night
Client Company: ABC Company
Venue: King George Ball Room
Show Start Date: November 12, 20XX

Notice that the names for the boxes correspond with the variable 
names in the Title Block spreadsheet.

6 Click in cell A8, type the following, and then press ENTER:
*Conceptual drawings only. Subject to change.

7 Move the cursor over the column divider between columns B and C. 
8 When the cursor changes to a left and right pointing arrow, drag the 

divider to the right to make column B wider.



Getting Started Guide 113

April 2024  

9 From the File menu, choose Print Preview.
Result: A preview of the spreadsheet as it will be printed appears. 
Notice that the variable names were replaced with the information 
you provided in the Document Options dialog box.

10 Click Close to close the preview window.

Step 2 - Create a layout for printing

The Layouts tab opens the layout design and storage area. You create 
layouts by arranging various drawing, image, and other items on a 
defined paper size. Layouts are a great way to add various types of 
information to your proposals all on one page that you define. You can 
add a rendering, a spreadsheet summary of costs, and a detailed 
floorplan to give your clients a snapshot of your event design and its 
associated costs.
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To create a layout

1 Click the Layouts tab at the bottom of the work area.

Result: The Small Layouts layout displays with drawings, an image, 
spreadsheet, and text already arranged on the page.

2 In the Layouts shortcut bar area on the left side of the window, right-
click on a blank area and choose New Layout. 

3 Type My Custom Layout as the name of the new layout, and then click 
OK.
Result: A new layout is created with a blank page.

4 From the View menu, choose Zoom Fit.
5 From the Insert menu, choose Drawing.

Result: The cursor changes to cross-hairs.

6 Move the cursor so that the x and y coordinates on the status bar 
read:
x=0.750”, y=1.000”

7 Click at that point and drag a box on the layouts page, releasing the 
mouse button when the x and y coordinates on the status bar are:
x=5.250”, y=7.750”



Getting Started Guide 115

April 2024  

Result: A wireframe view of your drawing is placed on the page.

8 From the Insert menu, choose Image.
Result: The cursor changes to cross-hairs.

9 Drag a box on the layouts page, from:
x=6.000”, y=1.000”

to...

x=10.000”, y=4.000”

Result: The Select Image View to be referenced dialog box opens.
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10 Click Event Rendering, and then click Select.
Result: The image is placed on the layout.

11 From the Insert menu, choose Spreadsheet.
Result: The cursor changes to cross-hairs.

12 Drag a box on the layouts page, from:
x=6.000”, y=6.000”

to...

x=9.750”, y=7.750”

Result: The Select Spreadsheet to be referenced dialog box opens.
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13 Click Title Block, and then click Select.
Result: The selected spreadsheet is placed on the layout.

Step 3 - Customize the layout

You can customize the design of your layout page by adding graphic 
elements and text.

To customize the layout

1 From the Insert menu, choose Rectangle.

2 Drag a box on the page from:
x=0.500”, y=0.500”

to:

x=10.500”, y=8.000”
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...to create a border.

3 From the Modify menu, choose Send to Back.
4 From the Insert menu, choose Text.
5 Drag a text box on the page from:

x=3.500”, y=0.500”

to:

x=8.500”, y=1.000”

6 From the Modify menu, choose Item Properties.
Result: The Item Properties dialog box opens.

7 Click the Text tab.

8 In the Text box, replace “Your Text” with “ABC Company Awards 
Night”.
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9 Click Set Font.
Result: The Font dialog box opens.

10 Under Font Style click Bold and click OK.
11 Click OK again to close the Item Properties dialog box.

12 Click the Drawing item (the box with the Plan view of the drawing in 
it) to select it.

13 From the Modify menu, choose Item Properties.
Result: The Item Properties dialog box opens.

14 In the Weight box, select 0.
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15 Click OK.
Result: The border is removed from the drawing item and the 
drawing is resized to fit the item box.
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