WYSIWYG R45 Update 1 Release Notes
Welcome to WYSIWYG R45! (If you are a new user, it is recommended that you work through the Quick
Start Guide (accessible from the Windows Start menu) in order to learn the basics of using WYSIWYG.)
These Release Notes are intended primarily for users who are familiar with WYSIWYG and they provide
information about new features, updates and bug fixes that were developed for R45.
Update 1: click here to see what enhancements were released with this update, and here for a list of issues
that were fixed.
Other documentation resources for WYSIWYG include the Reference Guide found in the Windows Start
menu, which provides information about all functions and features in WYSIWYG; the Tips and Tricks section
of our website, which offers tutorials for using various features; and our Forum, which is the best place to
find answers to usage questions – and/or to ask such questions.

New Features
Relocate & Clone Fixtures. This feature allows you to move or copy multiple fixtures between hang
structures. It may also be used to move imported fixtures from their individual pipes to other hang
structures. For more information and to learn how to use the feature, please watch this video:
https://www.youtube.com/watch?v=6jEeK7TQh7Q

Rigging Points Spreadsheets. Rigging Points’ data/attributes may now be manipulated via their own
Spreadsheets. A Rigging Points Spreadsheet is available in all R45-native files, but such a Spreadsheet must
be created in legacy files opened in R45. The entire range of Fixture Spreadsheet operations is available in
Rigging Points Spreadsheets.

Switch to a Standard Camera by right-clicking on it (in the Shaded View). Switch to any Standard
Camera visible in the Shaded View by hovering over it so it becomes highlighted, and right-clicking to
Switch to This Camera.

Set a Maximum Resolution for the Shaded View. It is now possible to define the maximum resolution
at which a Shaded View will appear within the Shaded View layout tab, or within the Shaded Pane of the
Quad layout tab or a Custom layout tab. Its main purpose is to output the Shaded View (i.e. by recording it
or streaming it out via NDI) at a specific resolution; in addition, Maximum Resolution can be used to
increase performance in files where the GPU is the bottleneck.

"Sketch" View Style for Shaded Views. This new View Style removes all color and shading from the
Shaded View and causes all objects to appear hand-drawn or “sketched” either in black-on-white or whiteon-black (inverted). Note: Deferred Shading is required in order for this feature to work.

Shaded View Quality Setting. Manually lower the quality of the Shaded View (via the Shaded View
Options’ Performance tab) when the Beam Quality is set to High or Medium (in the Simulation tab) in order
to increase performance. Tip: In most cases (in our humble opinion) the visual fidelity degradation that
results from lowering the quality to 70-80% should be acceptable, considering the gains in real-time
performance.
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Enhancements and Updates
Performance Improvements. The overall speed of the application itself (i.e. “the UI”—user interface) has
increased; this is most noticeable when switching between Layout Tabs and between Modes, as well as
when performing Layer operations such as making them visible/invisible, and when selecting large amounts
of objects. In addition, the Shaded View is now using a new texture compression algorithm which virtually
eliminates delays that used to be caused by high-resolution textures that were imported from Sketchup
files or other 3D models. (Such delays were often noticed when switching to a Shaded View, or, while
working in Shaded View, when Layers which contained objects using such textures were set to Visible.)

New Shaded View Profiles. Three new Shaded View Profiles have been added to R45: High Performance
(Volumetric Beams), High Performance (Enhanced Beams) and High Quality. Use them as they are or modify
them for your particular needs. (To set the Shaded View to use them, simply click on them in the Shaded
View Profiles Shortcuts Bar or select them from the dropdown at the top of the Shaded View Settings Tool.)

Light Emission Glow for Individual Objects/Elements. Light Emission Glow (“LE Glow”) may now be
enabled or disabled for individual Objects or for individual Elements of objects that contain multiple
Elements, via the Light Emission tab. For LED Walls, this option is accessible in their Properties > LED Wall
tab and in the third step of the LED Wall Wizard.

The Render Wizard’s Step 7 has been removed. Since as of R43 this step was no longer able to show a
preview rendering, adjusting the Saturation and Brightness for the rendering became impossible. As such,
there was no reason to keep this step: Saturation and Brightness may easily be adjusted in virtually any
freely available image editing software.

The Toolbar Positions .WUD now Includes ‘Visual’ Application Options. WYSIWYG User Data files
(.WUDs) which carry Toolbars’ locations now also carry the Appearance options (set in Application Options
> General tab), making it even easier to match your preferred User Interface settings on other computers.

Other Enhancements & Updates
•

Line Patterns were added to 2D Shapes.

•

Drag-selecting fixtures hanging from Curved Pipes now considers their order on the pipe instead of
their location in space.

•

Several Insertables are now included with WYSIWYG, which will make it easier to add multiple DMX
universes to files; simply Add the one that most closely matches your requirement.

•

A "Missing Purpose" Option Added to DATA Error Tracking.

•

‘H’ is now the hotkey for the Highlight function in DESIGN and LIVE modes.

•

Image or Video Sources may now be set to appear only on Screens’ Front Side.

•

Objects’ and Shutter Cuts’ quality has been increased and they appear less aliased (in Shaded Views)
when Beam Quality is set to Medium.

•

The maximum number of universes that WYSIWYG can simulate has been increased from 200 to 256.

•

The DMX Camera’s Yaw and Pitch rotations may now be controlled by supplying angular DMX values.

•

The NDI protocol has been updated to the latest version, 4.5.2.0.
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•

The Art-Net connectivity driver supplied with WYSIWYG has been updated to Version 4.

•

Binding multiple DMX universes to multiple Outputs at once (by selecting the required number and
clicking Bind) is now much faster.

Enhancements in Update 1
•

The following additional video file formats may now be used: .mp4, .mkv,.wmv and .mov. Such files
continue to depend on the necessary CODEC to be installed on the computer where WYSIWYG is used,
as explained here.

•

While Cloning (or Relocating) fixtures, it is now possible to clear the resulting fixtures’ Attributes (i.e.
Unit, Patch, Spot, Channel, Dimmer, Circuit, Focus, Gel, Gobo, Purpose, Notes, and Custom Color/Gobo
Wheels) by selecting Remove Resulting Fixtures’ Attributes from the right-click menu after activating
Clone or Relocate. Notes:
•

Fixtures’ Unit numbers will only be cleared if AutoUnit is disabled on the target hang structure; if
this is not disabled, the resulting fixtures will get Unit numbers assigned automatically.

•

Fixtures’ Properties (i.e. fixture Mode & other operation options, Lens, Lamp, Layer, Appearance
options and Beam options) will not be cleared.

•

Much like drawn objects can have their Insertion Point changed after they’ve been inserted, the same
can now be done with Library Items.

•

Switching between Cameras (in Shaded Views) is now faster. (This is more noticeable in complex files.)

•

A ‘Quality’ field was added to View Statistics, which shows what the Shaded View Quality is set to (in
the Shaded View’s View Options > Performance tab).

•

The PSN driver has been updated to 64-bit; as such, it can now be used to control more than 5 (five)
Motion Frames.

•

The .OBJ file type now appears by itself in the list of 3D file formats that may be imported.

Fixed Issues
•

The crash that used to occur when adjusting certain Fixtures’ shutter cuts via their Properties > Fixture
tab > Cuts subtab has been resolved. (However, using Cuts and Adjustments tool is preferred for setting
shutter cuts, so the adjustments can be seen in real-time.)

•

On occasion, shutter cuts applied to fixtures did not match the fixture’s beam in Shaded Views. This
issue has been resolved. Note: this fix may affect shutter cuts in legacy files; it is recommended that
files in which shutter cuts were applied are examined for such issues after opening them in R45.

•

Shaded Views set to display the Fixture Point of View (the “Fixture PoV ‘camera’”) now correctly
simulate fixtures’ barrel rotation.

•

All Cues that are played back while recording the Shaded View in DESIGN mode are now recorded.

•

The controls in a Frame’s Properties > Frame tab used to get disabled when that Frame was changed to
a BlackTrax Trackable and patched to a Motion Universe. This issue is now fixed.

•

Geometrically complex objects no longer fail to print.
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•

The fixture order defined by a drag-select action is now matched in DATA Spreadsheets.

•

The Print Color and Grayscale options for Layers are no longer ignored by truss.

•

Crashes that may have occurred in very large files when switching Cameras via the Camera Toolbar
have been resolved.

•

Fixture Groups and Selection Sets now remember the order in which fixtures/objects were selected
when the Fixture Groups or Selection Sets were created.

•

When using a multi-pane Layout tab which contains a Wireframe pane and a Spreadsheet pane (among
others), selecting fixtures in the Wireframe now results in the same selection order being applied in the
Spreadsheet.

•

When switching back to CAD mode, if the Library Browser and/or Layer Database windows were
docked at the right of the screen, they would expand to the right of their own accord, which
necessitated shrinking them back to the right manually. This issue manifested most often when
multiple monitors were used but is now fixed.

•

WYSIWYG no longer stalls when accessing View Tabs and Custom Tabs (in any mode) that contain at
least one Patch View Pane, while working with files that contain large numbers of patched objects (be
they fixtures, light emitting objects, or both).

•

Beams can no longer disappear, regardless of the Camera’s location.

•

Video Projectors’ manual zoom may now be controlled via the Cuts & Adjustments tool.

•

The entirety of complex 3D objects’ meshes are now printed to PDF.

•

Cylinder-based 3D Solid objects from DWG/DXF files no longer incorrectly import as basic Cylinders.

•

Enabling a Layer’s Grayscale option now correctly affects custom-coloured objects.

•

Fixture Shortcuts’ names are no longer allowed to appear as “duplicates”; this was possible before, by
adding <space>s at the end of their name.

•

The Normal Map’s Scale dropdown in the Properties window > Appearance tab now works correctly.

•

Using Auto Dimension on Truss no longer causes a crash.

•

Objects whose Insertion Point has been changed now Array from that Insertion Point.

•

The Video Manager now sorts Video Sources alpha-numerically (i.e. 1, 2, 3, 10, 11, not 1, 10, 11, 2, 3).

•

Library Fixture Notes are now available in DATA mode.

Fixed Issues in Update 1
•

Objects’ coordinates (based on their Insertion Point) now appear correctly in the Position Tool.

•

The crash that used to occur when the Define North function was activated, was fixed.

•

Enabling the Sort by Selection Order option for Spreadsheets via its toolbar button no longer requires a
manual refresh in order for its effect to be activated.

•

Rigging Points no longer appear in Shaded Views when the Sketch View Style is active – unless their
‘Show in Shaded View’ option was enabled.

•

Letterboxes or Pillarboxes on Screens no longer display an outline when the Sketch View Style is active.
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•

Beams that intersect Border and Leg objects (that are enabled for Pipes) are now correctly truncated in
Wireframe Views.

•

When printing, Floorplans are no longer incorrectly offset.

Library Additions and Updates
Click here for a list of Library updates and additions included in R45. (This list includes Library changes from
Update 1.)

Known Issues
Known Issues are published on our website; click here to access them.

Other Useful Information
Membership Requirement
To use WYSIWYG R45 Update 1, the Membership on your dongle must expire no earlier than June 2020; the
software may also be used with a Lease dongle on which the Lease has not yet expired.

Compatibility with Vivien 2020
To open files created in WYSIWYG R45 using Vivien 2020, they must be saved in this format by selecting it
via the Save as type: dropdown in WYSIWYG’s Save or Save As dialog. The Vivien 2020 Update and the
WYSIWYG R45 Compatibility Pack for Vivien 2020 are required in order for R45-native files saved in the
Vivien 2020 format to correctly open in Vivien 2020, and to ensure that nothing is lost from these files
when saved from Vivien.

System Requirements
Click here for the current system requirements. Note that as of R45, the Windows 7 and Windows 8.1
operating systems are no longer supported. In case you are looking to purchase or build a new workstation
for WYSIWYG, reading our Hardware Guide is strongly recommended.

Copyright Information
© The CAST Group of Companies Inc. 2004-2020. All rights reserved.
35 Ripley Avenue, Suite 1
Toronto, Ontario
Canada M6S 3P2
“WYSIWYG”, “Vivien” and “CAST Software” are registered trademarks of CAST Group of Companies
Incorporated. Other brands or products are the trademarks or registered trademarks of their respective
holders and should be treated as such.
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