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Chapter  1

Introduction

This chapter introduces you to the WYSIWYG Reference Guide, 
provides information for troubleshooting, and lists contact 
information if you need further assistance.

In this chapter
About this manual 3

Troubleshooting 4

Welcome to WYSIWYG 6
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About this manual

Introduction

This manual provides instructions for the installation and operation of the 
different levels of the WYSIWYG application. WYSIWYG is available at the 
following levels:

 WYSIWYG Report
 WYSIWYG Design
 WYSIWYG Perform
 WYSIWYG Perform - Console Edition
 WYSIWYG Learn
 WYSIWYG Network

All levels are discussed in this manual. For a detailed description of the 
levels, refer to Chapter 2, “The WYSIWYG suite of software products.”

All the levels use the same user interface, described in Chapter 4, 
“WYSIWYG user interface.” However, you can perform different tasks in 
each mode. For example, you draw in CAD mode and edit in Data mode. 
These modes may have different features based on the level of 
WYSIWYG that you are running. 

Text conventions

The following text conventions are used in this manual:

 Menus and menu commands appear in Arial bold. For example, “from 
the Edit menu, choose Layers.”

 User interface elements such as buttons, tools, shortcuts, and dialog 
boxes appear in Tahoma Oblique. For example, “to draw a riser, click 
the Riser tool on the Draw toolbar.”

 Keyboard keys are indicated in ALL CAPS. For example, “press TAB to 
enter the missing coordinate.”

 References to manuals appear in italic font. For example, “for 
additional information on working with recorded loads, please refer 
to your Sensor CEM User Manual.”

 Internal and external cross references appear in “underlined text”. 
For example, for details, see “WYSIWYG Perform”.
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Troubleshooting

Introduction

If you have problems using your software, please consult the following 
resources:

 the contents of this manual or the online Help available from within 
WYSIWYG

 the WYSIWYG Web site at http://www.cast-soft.com/wysiwyg

If these resources are insufficient, please contact Technical Support. 

Help from Technical Support

For assistance with a problem, contact Technical Support directly at one 
of the offices identified below. 

When calling for help, please have the following information ready:

 the level of WYSIWYG that you are using (Report, Design, or 
Perform)

 software version (from the Help menu, choose About WYSIWYG)
 the kind of computer that you are using (processor and speed, 

amount of memory, graphics card, operating system)
 DMX interface type (if applicable)

North America

CAST Software

Technical Support

35 Ripley Avenue, Unit 1

Toronto, ON M6S 3P2

Canada

Phone: +1 877 989 2278

Fax: +1 416 597 9594

E-mail: techsupport@cast-soft.com

Web site: www.cast-soft.com

http://www.cast-soft.com/wysiwyg
http://www.cast-soft.com
http://www.cast-soft.com
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United Kingdom

A.C. Lighting Ltd.

Technical Sales & Support: 

Centauri House

Hillbottom Road

High Wycombe

Bucks, HP12 4HQ 

UK

Phone: +44 (0)1494 446000

Fax: +44 (0)1494 461024

E-mail: wysiwyg@aclighting.com

Web site: www.aclighting.com

Germany

ARCUS GmbH

Obermeiers Feld 2-4

33104 Paderborn

Germany

Phone: +49 (0) 5254 93069 0

Fax: +49 (0) 5254 93069 29

E-mail: support@arcus-lighting.com

Web site: www.arcus-lighting.com

Support for WYSIWYG Perform - Console Edition

For assistance with a problem related to WYSIWYG Perform - Console 
Edition, contact the manufacturer of the console to which you are 
connected. The console manufacturer is listed on the Welcome page that 
appears when you launch the application. 

http://www.aclighting.com
http://www.arcus-lighting.com
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Welcome to WYSIWYG

Introduction

The WYSIWYG suite of software products, designed specifically for 
lighting professionals, offers a range of solutions to meet the needs of 
designers, assistants, electricians, console operators, teachers, and 
students. 

WYSIWYG is the essential tool if you are looking to

 increase creative freedom
 save time
 win more contracts
 cut costs
 be more environmentally friendly

Within the WYSIWYG suite of products, any higher level product contains 
all the features of a lower level product. WYSIWYG Report, Design, and 
Perform are the core products, with WYSIWYG Report offering basic CAD 
and paperwork solutions, and WYSIWYG Perform providing an end-to-
end solution including CAD, paperwork, rendering, and pre-visualization. 

In less than one day of training, you can begin working with WYSIWYG 
and see your lighting design without actually installing any lights. You 
can even see what a new lighting fixture can do before you rent, buy, or 
install it. Once your design is complete, WYSIWYG handles the logistics; 
it automatically generates plots, schedules, pipe-tapes, and color and 
gobo lists. 

For more information on each of the three main levels of WYSIWYG, see 
the appropriate section:

 WYSIWYG Report - For details, see "WYSIWYG Report".
 WYSIWYG Design - For details, see "WYSIWYG Design".
 WYSIWYG Perform - For details, see "WYSIWYG Perform".
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The WYSIWYG suite of software 
products

This chapter describes the different levels of WYSIWYG. 

In this chapter
WYSIWYG Report 9

WYSIWYG Design 11

WYSIWYG Perform 13

WYSIWYG Perform - Console Edition 15

WYSIWYG Learn 17

WYSIWYG Network 19
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WYSIWYG Report

Introduction

WYSIWYG Report is the basic WYSIWYG package. This application allows 
lighting professionals to create show drawings and explore designs in 3D 
environment with 3D CAD tools, isometric and shaded views, and photo-
realistic rendering tools. View and edit all fixture data, and generate 
professional reports, plots, and images. 

WYSIWYG Report is also available in an educational edition. This product, 
WYSIWYG Report Educational Edition, is a fully functional version of 
Report that is available to students and faculty at a special price.

Note: The following specifications are subject to change.

Software features
 3D plotting of set and lighting designs (plans, sections and 

elevations)
 Multiple working views including isometric 
 Comprehensive 3D library of fixtures, accessories, truss, colors, 

gobos, props, and so on
 Extensive CAD tools
 3D visualization in Shaded View in CAD mode
 Excellent zooming and maneuvering abilities
 Custom layers and scenes for complete control and management of 

information
 Loading and exporting of DXF, DWG, Excel, BMP, and JPG file types
 Tabular editing of lighting information including channel, dimmer, 

color, and so on
 Fully integrated paperwork and CAD systems
 Error checking of production paperwork and hookups
 Reports including instrument counts and schedules, patch sheets, 

and so on
 Printing of plots and reports up to 36”x 48” / A0
 Custom report and plot content and layout
 Ability to print all view types including CAD, reports, spreadsheets, 

bitmap files, jpeg files, and logos
 Multi-monitor support
 12 months of software and library updates included
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Upgrade suggestions
 A faster processor improves responsiveness.
 Memory requirements depend on the size of the show. Insufficient 

memory can seriously affect performance. Add memory if there is 
excessive disk activity.

Modes

The following working modes are available in WYSIWYG Report:

 CAD 
 DATA
 PRES 

Refer to the respective chapters of this guide for detailed explanations 
about the features in each mode.
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WYSIWYG Design

Introduction

WYSIWYG Design builds on the feature set of Report and adds the ability 
for lighting professionals to create lighting looks using the integrated 
design tools, then save and render as photo-realistic images. 

WYSIWYG Design is also available in an educational edition. This product, 
WYSIWYG Design Educational Edition, is a fully functional version of 
Design that is available to students and faculty at a special price. 

Note: The following specifications are subject to change.

Software features
 Includes all the features of WYSIWYG Report
 3D plotting of set and lighting designs
 Multiple working views including isometric
 Comprehensive 3D library of fixtures, accessories, truss, colors, 

gobos, props, and so on
 Extended library includes textures and materials
 Library objects are multi-layered for realistic texturing
 Objects have variable translucency
 Fully integrated paperwork and CAD systems
 Loading and exporting of DXF, DWG, Excel, BMP, and JPG file types
 Print all view types including 3D views, bitmap files, jpeg files, 

spreadsheets and logos
 Integrated design mode allows creation of static lighting looks 

without a console
 Rendering generates a photo-realistic picture of your lighting look
 Rendering wizard provides options for smoke, shadows, ambient 

light, and so on
 Renderings include bounce and reflection from surfaces
 Background Rendering Manager that enables you to queue up 

multiple renderings to run in the background without even requiring 
WYSIWYG to run

 OpenGL technology for improved beam simulation
 Multi-monitor support
 Cameras and Camera Paths to view visualizations.
 Video playback on Screens, LED Walls and other supporting objects
 Laser visualization 
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 12 months of software and library updates included

Upgrade suggestions
 A faster processor improves responsiveness and rendering times.
 Memory requirements depend on the size of the show. Insufficient 

memory can seriously affect performance. Add memory if there is 
excessive disk activity.

 A high-performance OpenGL accelerator card significantly improves 
the performance of real-time simulation.

Modes

The following working modes are available in WYSIWYG Design:

 CAD 
 DATA
 DESIGN
 PRES 

Refer to the respective chapters of this guide for detailed explanations 
about the features in each mode.



Reference Guide 13

January 2019 The WYSIWYG suite of software products 

WYSIWYG Perform

Introduction

WYSIWYG Perform builds on the feature set of Report and Design and 
adds the ability for lighting professionals to pre-cue entire shows in real 
time. Users can create their productions in 3D along with all the 
necessary paperwork. A console can then be connected to the computer 
and WYSIWYG Perform will simulate the exact effect of the console’s 
output in real-time. 

Note: The following specifications are subject to change.

Software features
 Includes all the features of WYSIWYG Report and Design
 3D plotting of set and lighting designs
 Multiple working views including front, back, sides, top, bottom, and 

isometric
 Comprehensive 3D library of fixtures, accessories, truss, colors, 

gobos, props, and so on
 Connect with media servers over CITP protocol
 Connect to motion control (automation) system to move props/truss 

on stage
 Connect to laser protocols
 Fully integrated paperwork and CAD systems
 Live mode for real-time lighting visualization
 DMX camera to allow you to dynamically reposition your point of 

view in Live mode.
 Accurate simulation of conventional and automated fixtures
 OpenGL technology for improved beam simulation
 LED grids allow simulation of lasers, neon, LEDs, projection screens, 

and so on
 Image Console enables you to map an image to patched grids of 

light-emitting surfaces and control its intensity in Live mode
 Easy hook-up to consoles and other DMX sources
 Auto Focus protocol lets WYSIWYG send color and focus data to 

consoles
 Integrated design mode allows you to create lighting looks without a 

console
 Rendering generates a photo-realistic picture of your cue or lighting 

look
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 Renderings include bounce and reflection from surfaces
 Background Rendering Manager that enables you to queue up 

multiple renderings to run in the background without even requiring 
WYSIWYG to run

 Animated renderings available though certified service providers
 Multi-monitor support
 12 months of software and library updates included

Upgrade suggestions
 A faster processor improves responsiveness and rendering times.
 Memory requirements depend on the size of the show. Insufficient 

memory can seriously affect performance. Add memory if there is 
excessive disk activity.

 A high-performance OpenGL accelerator card significantly improves 
the performance of real-time simulation.

Modes

The following working modes are available in WYSIWYG Perform:

 CAD 
 DATA
 DESIGN
 PRES
 LIVE

Refer to the respective chapters of this guide for detailed explanations 
about the features in each mode.
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WYSIWYG Perform - Console Edition

Introduction

WYSIWYG Perform - Console Edition is a version of WYSIWYG Perform 
intended for distribution with a specific console or family of consoles. 
Users purchasing a compatible console will receive this edition of 
WYSIWYG Perform to create shows and begin pre-cueing activities. The 
Console Edition of WYSIWYG Perform includes most of the functionality 
of Perform with certain features restricted or removed.

Note: The following specifications are subject to change.

Software features
 Includes all the features of WYSIWYG Perform, other than printing or 

exporting in any format 
 3D plotting of set and lighting designs
 Multiple working views including front, back, sides, top, bottom, and 

isometric
 Comprehensive 3D library of fixtures, accessories, truss, colors, 

gobos, props, and so on
 Fully integrated paperwork and CAD systems
 Live mode is restricted to visualizing one patch universe at a time
 Accurate simulation of conventional and automated fixtures
 OpenGL technology for improved beam simulation
 LED grids allow simulation of lasers, neon, LEDs, projection screens, 

and so on
 AutoPatch transmits the entire show patch regardless of channel 

count
 Rendering is available in Design and Live modes but is limited to 

76,800 pixels

Upgrade suggestions
 A faster processor improves responsiveness and rendering times.
 Memory requirements depend on the size of the show. Insufficient 

memory can seriously affect performance. Add memory if there is 
excessive disk activity.

 A high-performance OpenGL accelerator card significantly improves 
the performance of real-time simulation.
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Note: You cannot upgrade from WYSIWYG Report or Design to 
WYSIWYG Perform - Console Edition. You can, however, upgrade from 
WYSIWYG Perform - Console Edition to WYSIWYG Perform, removing any 
console restrictions.

Modes

The following working modes are available in WYSIWYG Perform - 
Console Edition:

 CAD 
 DATA
 DESIGN
 PRES
 LIVE

Refer to the respective chapters of this guide for detailed explanations 
about the features in each mode.
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WYSIWYG Learn

Introduction

WYSIWYG Learn is a special configuration of WYSIWYG that allows an 
educational institution to run ten instances of the software on a Local 
Area Network. The workstations can be configured to run any 
combination of WYSIWYG Report or WYSIWYG Design. In addition, one 
workstation can run WYSIWYG Perform. 

Note: The following specifications are subject to change.

Software features
 Includes all the features of WYSIWYG Report, Design, or Perform
 2D and 3D plotting of set and lighting designs
 Multiple working views including front, back, sides, top, bottom, and 

isometric
 Comprehensive 3D library of fixtures, accessories, truss, colors, 

gobos, props, and so on
 Fully integrated paperwork and CAD systems
 Accurate simulation of conventional and automated fixtures
 OpenGL technology for improved beam simulation
 LED grids allow simulation of lasers, neon, LEDs, projection screens, 

and so on
 Easy hook-up to consoles and other DMX sources
 Auto Focus protocol lets WYSIWYG send color and focus data to 

consoles
 Rendering generates a photo-realistic picture of your cue or lighting 

look
 Renderings include bounce and reflection from surfaces
 Background Rendering Manager that enables you to queue up 

multiple renderings to run in the background without even requiring 
WYSIWYG to run

 Animated renderings are available though certified service providers
 Multi-monitor support

Upgrade suggestions
 A faster processor improves responsiveness and rendering times.
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 Memory requirements depend on the size of the show. Insufficient 
memory can seriously affect performance. Add memory if there is 
excessive disk activity.

 A high-performance OpenGL accelerator card significantly improves 
the performance of real-time simulation.

Modes

The following working modes are available in WYSIWYG Learn:

 CAD 
 DATA
 DESIGN
 PRES
 LIVE

Refer to the respective chapters of this guide for detailed explanations 
about the features in each mode.
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WYSIWYG Network

Introduction

WYSIWYG Network allows you to run as many licenses of WYSIWYG 
Report, Design, and Perform as you want to over a network. The 
workstations can be configured to run any combination of these products 
with the use of a single network dongle. 

Note: The following specifications are subject to change.

Software features
 Includes all the features of WYSIWYG Report, Design, and/or Perform
 2D and 3D plotting of set and lighting designs
 Multiple working views including front, back, sides, top, bottom, and 

isometric
 Comprehensive 3D library of fixtures, accessories, truss, colors, 

gobos, props, and so on
 Fully integrated paperwork and CAD systems
 Accurate simulation of conventional and automated fixtures
 OpenGL technology for improved beam simulation
 LED grids allow simulation of lasers, neon, LEDs, projection screens, 

and so on
 Easy hook-up to consoles and other DMX sources
 Auto Focus protocol lets WYSIWYG send color and focus data to 

console
 Rendering generates a photo-realistic picture of your cue or lighting 

look
 Renderings include bounce and reflection from surfaces
 Background Rendering Manager that enables you to queue up 

multiple renderings to run in the background without even requiring 
WYSIWYG to run

 Animated renderings available though certified service providers
 Multi-monitor support
 12 months of software and library updates included

Upgrade suggestions
 A faster processor improves responsiveness and rendering times.
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 Memory requirements depend on the size of the show. Insufficient 
memory can seriously affect performance. Add memory if there is 
excessive disk activity.

 A high-performance OpenGL accelerator card significantly improves 
the performance of real-time simulation.

Modes

The working modes available in WYSIWYG Network depend on your 
product configuration. Refer to the WYSIWYG Report, Design, or Perform 
sections accordingly. Detailed explanations of each of the various modes 
are included in this guide.
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Chapter  3

Installation, configuration, 
activation, and registration

This chapter provides instructions on how to install, configure, 
activate, and register the WYSIWYG software. You must activate 
and register the software before you can start using WYSIWYG. 

In this chapter
Installation 23

Configuration, activation, and registration 36

Dongle Reauthorization 42

Upgrades 45

Membership and Leases 47

Passwords 52
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Installation

Introduction

The following requirements are separated according to the level of 
functionality that you want to achieve (Minimum or Optimal). The 
Minimum requirements are sufficient to run the software, but 
performance will be slow for some features and graphics support will be 
limited. Use the Optimal system to achieve the best possible 
performance and graphics. Since computer hardware is always changing, 
for the latest recommended WYSIWYG system requirements, please 
refer to: http://cast-soft.com/wysiwyg-minimum-and-optimum-system-
requirements/

If you are planning to purchase/build a new computer system to run 
WYSIWYG, we recommend that you first consult the WYSIWYG Hardware 
Guide in http://cast-soft.com/selecting-hardware-for-a-wysiwyg-
workstation/, for comprehensive details on selecting (components for) a 
WYSIWYG workstation.

Notes: 

 WYSIWYG must be installed on a hard drive formatted with the NTFS 
file system.

 When running WYSIWYG on a MAC via Bootcamp, performance will 
be comparable to running WYSIWYG on a PC. When running 
WYSIWYG on a MAC via the Parallels virtual environment, 
performance will be degraded when compared to a PC; using 
Parallels is not recommended for pre-visualization (i.e. Design mode) 
and pre-cueing (i.e. Live mode). 

 For Enhanced Simulation, a video card supporting OpenGL 2.1 is 
required; otherwise the software will disable Enhanced Simulation. 
For full details on the visualization requirements, please refer to the 
section below which outlines the increasing levels of beam 
visualization in WYSIWYG.

Attention:  WYSIWYG Release 41 is officially supported on a 
computer running Windows 7, Windows 8.1, or Windows 10. 
WYSIWYG Release 41 does NOT install on a computer running 
Windows XP or Windows Vista. 

Minimum System requirements 

(for basic functionality)

 Intel Core i3 or compatible processor, 2.0 Ghz, or better

http://www.cast-soft.com/wysiwyg/tip/view/selecting-hardware-for-a-wysiwyg-workstation
http://www.cast-soft.com/wysiwyg/tip/view/selecting-hardware-for-a-wysiwyg-workstation
http://www.cast-soft.com/wysiwyg/tip/view/selecting-hardware-for-a-wysiwyg-workstation
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 PC running Windows 7 with Service Pack 1 or Windows 8.1 or 
Windows 10
- OR -
MAC computer with Intel Processor platforms running Windows 7 
with Service Pack 1 or Windows 8.1/Windows 10 via Bootcamp 
(recommended), or Parallels Virtual Machine*

 * WYSIWYG installed on a Parallels Virtual Machine will run with 
limited graphical functionality, as it is running on an Integrated video 
card.

 4GB RAM
 2GB free disk space (NTFS file system)
 1280 x 800 resolution
 OpenGL-accelerated “gaming-level” video card, with 1GB (or better) 

video memory and OpenGL 2.1 (minimum) support** 
 Free USB port.

Attention: ** Integrated video cards may be used, but are not 
recommended.

Optimal System requirements 

(for enhanced visualization performance and faster rendering 
times)

 Intel Core i5 / i7 / i7 “Extreme Edition” or equivalent AMD processor, 
quad-core or better, 2.4 Ghz or better

 Windows 7 with Service Pack 1, Windows 8.1 or Windows 10; 64bit 
version of Windows OS is not required, but highly recommended
- OR -
MAC computer with Intel Processor platforms running Windows 7 
with Service Pack 1, Windows 8.1 or Windows 10, running via 
Bootcamp 

 8GB RAM or better, configured for dual-, triple- or quad-channel 
operation (depending on the memory architecture supported by the 
system processor)

 2GB free disk space (NTFS file system)
 OpenGL-accelerated “gaming-level” video card, with 2GB (or better) 

video memory and OpenGL 3.3 support required for Deferred 
Rendering simulation and Volumetric Beams in Shaded Views**

 Free USB port

Attention: **No integrated video cards should be considered for the 
Optimal System.
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Visualization requirements

There are two levels of beam simulation offered in WYSIWYG's Shaded 
Views.

 Enhanced Beams: The minimum video card requirements to 
display the default Enhanced Beams must support OpenGL 2.1.

 Volumetric Beams: To obtain the highest graphics level offered by 
Deferred Rendering with Enhanced Visualization, your video card 
must support OpenGL 3.3, or better.

Notes: 

 Both Enhanced Visualization and Deferred Rendering options are 
required to run Volumetric Beams. If these options are not available 
on your system, it means the graphics card on your computer does 
not support the necessary version of OpenGL to run Volumetric 
beams. In this instance, you must therefore use Enhanced Beams for 
your Shaded View visualization.

 The use of the Alpha Beam Shadows feature requires a video card 
that supports OpenGL 4.3 or better.

General requirements

In addition to the requirements listed above, note the following product-
specific requirements:

WYSIWYG Perform
 WYG-it 2 DMX reception device (except when used with certain 

consoles - contact the console manufacturer for details)
 MIDI output port to use with AutoFocus

WYSIWYG Network/WYSIWYG Learn
 Network interface card running TCP/IP

For WYSIWYG Perform workstations:
 Use a WYG-it 2 or compatible DMX reception device (except when 

used with certain consoles - contact the console manufacturer for 
details)

 MIDI output port to use with Autofocus-enabled consoles
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Unicode support

Unicode is supported in WYSIWYG. This enables the use of hundreds of 
different scripts containing over 110,000 characters. In WYSIWYG, you 
can work in whatever language you prefer, be it Arabic, Chinese, Hebrew 
or Japanese. 

Installing WYSIWYG

The installation procedure for WYSIWYG is the same regardless of the 
level that you have purchased. You can download the WYSIWYG installer 
from the WYSIWYG website and install in your computer. Follow the steps 
in the installer and ensure that you do not plug the dongle into your 
computer until prompted to do so by the installer.

To install WYSIWYG

1 Download a copy of the WYSIWYG software installer to your 
computer.

2 In your computer, double-click the downloaded install file of the 
WYSIWYG software.
Result: The WYSIWYG - InstallShield Wizard appears.

3 Follow the steps in the WYSIWYG - InstallShield Wizard.

Note: The executable files (.exe) and the installer for WYSIWYG R42 
have been signed with a digital certificate. The Publisher is listed as: Cast 
Group of Companies Inc.
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Installing an in-place update

If you already have a previous release of WYSIWYG installed on your 
computer, you can easily update to the current release by installing an 
in-place update. This update allows you to enhance a version of 
WYSIWYG that is a maximum of two releases back from the current 
release. You do not have to uninstall the previous version of WYSIWYG to 
perform the update. 

To install an in-place update

Note: Before proceeding with updating your current WYSIWYG release 
with the in-place-update, ensure that the WYSIWYG software is not 
running on your computer. 

1 From the WYSIWYG Install window, select Install WYSIWYG.

2 Select Update the product selected below. 
3 From the list of WYSIWYG releases, highlight the release that you 

want to update, and then click Next.
4 On the WYSIWYG Update window, select Next.
5 On the WYSIWYG Update window, click Yes to accept the terms of the 

license.
Result: The updated files are copied to your computer. 

6 After all the files are copied, click FINISH to complete the update.

Installing WYSIWYG Learn or WYSIWYG Network

Software components
The WYSIWYG Network and WYSIWYG Learn systems comprise a 
computer that acts as the server and one or more clients. In your 
network, you need to have only one computer that acts as the server 
(the computer with the network dongle attached to it). 

The server can be standalone, in which case WYSIWYG is not installed on 
it, or it can act as both server and client. In the former scenario, you 
install the WYSIWYG Network Server which installs the Sentinel 
Protection service. In this latter scenario, you install the full WYSIWYG 
program, which also includes the network server portion of the Sentinel 
Protection service. (As a result, in the latter scenario, installing the 
WYSIWYG Network Server should not be performed.) This Sentinel 
Protection service is required and its status should be started to detect 
the WYSIWYG Learn or Network dongle (a list of current services on a 
workstation can be viewed under Control Panel > Administrative Tools > 
Services).
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The Learn or Network Client computers should have WYSIWYG installed 
on them, which also includes the network Sentinel Protection service. (As 
a result, the WYSIWYG Network Client is no longer required and should 
not be performed.) As in the case of the Server computer, the Sentinel 
Protection service enables the software to function over the network. 
WYSIWYG Learn can run multiple clients (usually in groups of 10, 20, 30, 
40 or 50) on a network. The number of clients for WYSIWYG Learn/
Network is restricted based on the configuration purchased.

A typical WYSIWYG Network/Learn setup is illustrated on the following 
page. All computers running Network/Learn components must be on the 
same network (and therefore have the same network ID and subnet 
mask). It is also necessary that Server and Client computers have their 
firewall turned off. Following the installation, please ensure that the 
computers are rebooted before running the WYSIWYG Learn/Network 
configurations.

Network services

Windows
Services are supported in Windows operating systems. Services start 
running as soon as your computer is turned on, regardless of whether 
the user is logged in. The service begins automatically each time the 
workstation is restarted, and runs in the background without any 
prompting from the user. The service may also be started manually; the 
choice is available during the installation process.

Network protocol
WYSIWYG Learn or WYSIWYG Network will run on any LAN that supports 
TCP/IP protocol (NetBEUI and IPX/SPX networks are not currently 
supported).
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Detecting the network dongle
If the service is not running, the Clients will not detect the dongle and 
the application will terminate. (To check the Sentinel Protection service, 
check under the Control Panel > Administrative Tools > Services). Attach the 
dongle to the workstation that is acting as the Server. Turn off the 
firewall on all the computers running as the server computer and all 
client computers.

Installation options

Based on whether your Server computer is a combined Learn/Network 
Server and Client or a standalone Server, the installation varies slightly.

 If you intend to run WYSIWYG on the server computer (i.e., you want 
a combined Learn/Network Server/Client), then you must install the 
full WYSIWYG program on this computer. While this installation 
includes all required server files, they are only activated after you 
reboot the computer and then attach the network dongle to the 
Server. For details, see “To install WYSIWYG”.

 If you do not want to run WYSIWYG on the Server computer (i.e., 
you want to have a standalone Learn/Network Server), the 
installation is condensed. See “To install the Learn/Network Server 
(standalone)” below.

Before you begin
Remove previous versions of WYSILAB or WYSIWYG Learn/Network 
before you start the install process (if this step is not completed, the 
install menu will offer the option before continuing with the installation). 
Restart the workstations for the changes to take effect. 

To install the Learn/Network Server (standalone)

Perform this installation if you want to configure a standalone Learn/
Network Server (i.e., you do not want to run WYSIWYG on this 
computer). After the installation, simply reboot the computer and then 
attach the network dongle to it to activate the Server functionality.

1 Download a copy of the WYSIWYG software into the server.

2 In the server, double-click the install file of the WYSIWYG software.
Result: The WYSIWYG - InstallShield Wizard appears.

3 Select Install WYSIWYG Network Server. 
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Note: The Server should only be installed on one computer on the 
network. This is the computer to which you will attach the network 
dongle. 

4 On the Setup window, select Next to continue the install process.
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5 Click Yes to accept the terms of the license.
Result: The Choose Destination Location window appears.

6 Select a destination location for the Server files. The default location 
is C:\Program Files\WYSIWYG Server.

7 Click Next.
Result: The Select Program Folder window appears.

8 Select a program folder for the shortcut. The default is WYSIWYG 
Server.
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9 Click Next.
Result: The Start Copying Files window appears.

10 Review the installation settings, and then click Next to begin the 
installation.

11 After all the files are copied, click FINISH to complete the installation.

To install the Network/Learn Client

1 Download a copy of the WYSIWYG software into your computer.

2 In your computer, double-click the install file of the WYSIWYG 
software.
Result: The CAST license screen appears.
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3 If you accept the terms of the license, click Yes to continue. The 
installation begins.

4 Click FINISH to complete the installation.
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Customer Experience Improvement Program 
(CEIP)

In order to better serve our customers, and to enable our products to 
meet our customers ongoing and growing needs, we regularly engage in 
various methods to gather client feedback, including direct responses to 
support and problem requests, as well as various other comments and 
queries. We encourage our customers to participate in giving feedback in 
order to get the most out of our products and create positive 
experiences. However, given the large scope of our customer base, it is 
impossible to reach out to all our customers directly. 

Our Customer Experience Improvement Program (CEIP) allows all our 
customers to contribute to the features, design and development of 
CAST Software products. This program enables our customers to provide 
us with various information, including information about the hardware 
configuration, the features you use most (and least), and the nature of 
the problems you face. Based on this information, we will be able to 
improve our products and the features that you use the most. 

The Customer Experience Improvement Program dialog box appears during 
the installation process to offer the option to participate. When enabled, 
the program runs automatically in the background, and will not interfere 
with your work in any way.
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CEIP will collect general information that will lead to software 
improvements and enhanced functionality to better meet the needs of 
our customers. For more information, please visit http://cast-soft.com/
ceip/.

Participating in the CEIP enables the Message Center. Message Center is a 
feature which displays a message dialog box when WYSIWYG opens. It is 
in-application messaging that allows CAST to deliver important messages 
to the user through the software. For example, if we want to share 
information to all users, or to only some users (based on information 
collected through CEIP), we would be able to send it through Message 
Center. Also, if there are any critical issues discovered, or suggestions on 
how to fix a problem (e.g. update your graphics drivers to avoid a crash), 
we can send this information directly through WYSIWYG, and you would 
see it the next time you launch the software. But as mentioned earlier, to 
receive these messages CEIP must be enabled.
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Configuration, activation, and registration

Introduction

After installing the product, when you launch WYSIWYG for the first time, 
the Product Configuration Wizard appears, enabling you to choose the 
product level that you want to run. You can choose from standard 
product levels (such as Design and Report), Network products, or you 
can run the Demo or Viewer versions of WYSIWYG.

To run any of the products listed in the Wizard, you must first have the 
appropriate dongle installed on your computer (to run a network product, 
you must have a network dongle installed on a computer that is 
accessible from your PC).

After you proceed through the steps of the Wizard, you are prompted to 
activate your product (only if you are upgrading from version 3.X to the 
latest version), and then you are prompted to register the software. You 
must activate and register the WYSIWYG software before you can start 
using it. To activate the WYSIWYG software involves entering an 11-digit 
activation code. To register the software involves entering a validation 
code.

This section is broken down into the following three steps:

1 Starting WYSIWYG for the first time and running through the Product 
Configuration Wizard.

2 Activating the software.
3 Registering the software.

To start WYSIWYG for the first time

Note: Before you perform this procedure, ensure that you have the 
correct dongle installed on your computer, or that the network dongle is 
installed on a computer that you can access from your PC.
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1 On your desktop, click the shortcut icon to start WYSIWYG (or click 
Start > All Programs > CAST Software > WYSIWYG Release 
41).

Result: The WYSIWYG Launching Screen appears with the progress 
bar while WYSIWYG is preparing to load, and then the WYSIWYG 
Product Configuration Wizard appears. 

2 To ensure that the Wizard appears the next time you launch 
WYSIWYG, leave the check mark in the box beside Show me this wizard 
next time I run WYSIWYG; to configure the program so the Wizard does 
not appear the next time you launch WYSIWYG, clear this checkbox.
Note: If you clear this checkbox, you can always set it again in the 
Application Options window. For details, see “General tab”.
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3 Click Next.
Result: The Product Selection window appears, enabling you to choose 
the product level that you want to launch.
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4 Select the product that you want to launch (you must have the 
correct dongle installed to launch the program), and then click Next.
Result: The program verifies that you have the correct dongle 
attached.

5 Click Finish.
6 The product that you chose launches and the Activate or Register 

window appears (based on the level of product that you have 
purchased). 
 If you have purchased a new box product containing a new 

version dongle skip to the product registration process. For 
details, see “To register WYSIWYG”. 

 If you are upgrading from WYSIWYG 3.X, please contact CAST 
Technical Support.
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To register WYSIWYG

1 Once you have gone through the Product Configuration Wizard and you 
have successfully activated your product, the Register window 
appears, prompting you to register your software.

Note: You can postpone registration for a period of up to 15 days 
after installation. 
To register later, click Register Later. You must register and obtain a 
Registration Validation Code to continue using the product after this 
time. It is recommended that you register as soon as possible to 
avoid any restrictions on using the product. 

You can register by phone, online, fax, or e-mail. 

2 To register by phone, click Phone, and then proceed to Step 3. 
To register by any of the other methods, select the appropriate 
button and follow the instructions as prompted. 

When you have obtained your validation code, click I have my 
validation code, and then proceed to Step 4.
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3 If you have chosen to register by phone, the Register by Phone dialog 
box appears. 

Follow the instructions in the dialog box. Type your validation code, 
and then click Register. A successful registration completes the 
registration and activation process.

4 If you selected I have my validation code in Step 2, the Insert Registration 
Code dialog box appears. 

5 Type your validation code, and then click OK. A successful 
registration completes the registration and activation process.
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Dongle Reauthorization

Introduction

Reauthorization requires that all WYSIWYG Members “reauthorize” their 
dongle periodically by logging into the WYSIWYG Members site 
(https://cast-soft.com/cast/member/index.php) getting their Dongle 
Reauthorization Code, and then applying this code to the dongle. 

This initiative will help safeguard your dongle, ensuring that if it is lost, 
stolen, or found by someone else, it will be useless beyond the 
reauthorization date. 

Reauthorization codes and WYSIWYG releases

Following Release 24, all dongles will have a Reauthorization Expiry Date 
burned onto them as follows: 

 Dongles that were registered with a version of WYSIWYG prior to 
Release 24 will have their Reauthorization Expiry Date set to 30 days 
forward from the time when Release 24 or later is first launched with 
such a dongle. Within these 30 days, you must follow the 
Reauthorization process described below or the dongle will cease to 
function. (It will resume functioning once you reauthorize the 
dongle.)

 Dongles that are registered with Release 35 (and on) will have the 
Reauthorization Expiry Date set to 6 months from the exact day of 
registration. For example, if you register the dongle on January 1, 
2015, the Reauthorization Expiry Date will be July 1, 2015. 

How it works

Exactly 30 days prior to the Reauthorization Expiry Date, regardless of 
when your Membership expires (or expired), every time you open 
WYSIWYG a window appears, requesting that you supply a 
Reauthorization Code for your dongle or the program will cease to 
function. 

Note: You have 30 days from the first appearance of the Reauthorization 
window to complete the process. To postpone the process during this 
period and continue working in WYSIWYG, click Later in this window. At 
the 30-day mark, however, you must reauthorize your dongle or 
WYSIWYG will cease to function (until you complete the process). 

https://cast-soft.com/cast/member/index.php
https://cast-soft.com/cast/member/index.php
https://cast-soft.com/cast/member/index.php
https://cast-soft.com/cast/member/index.php
https://cast-soft.com/cast/member/index.php
https://cast-soft.com/cast/member/index.php
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To reauthorize your dongle

Note: You require an Internet connection to perform this procedure.

1 To begin the reauthorization process, select the Now radio.
Result: The steps for completing reauthorization will become 
accessible in the Dongle Reauthorization window.

Note: If you do not wish to perform reauthorization at this time, 
select the Later radio and click the Later button at the top right of the 
Dongle Reauthorization. This option is only available during the 30 days 
leading up to the reauthorization expiry date.
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2 Click Member’s Login.
Result:  The WYSIWYG Members site will open in your Internet 
browser to begin the reauthorization process.

3 In the WYSIWYG Members site log into your account using your user 
name and password then click Login.
Note: If you do not have an account, you must create one by 
entering your contact details and selecting a password. Ensure that 
the email address you provide is valid.

4 Follow the directions in the Member site verifying your contact 
information and that you want to reauthorize your dongle. 
Result: The browser will list your Reauthorization Validation Code.

5 Select this code and copy it (CTRL +C).
6 Switch back to WYSIWYG.
7 In the Dongle Reauthorization window, enter the reauthorization 

validation code in the Reauthorization Validation Code field.
8 Click Reauthorize. 

Result: A Reauthorization Successful message appears.

9 Click OK.
Result: WYSIWYG launches. Your dongle is reauthorized.

Note: You require an Internet connection to perform this procedure so 
that the information you provide can be validated by our servers. Unlike 
registration, reauthorization cannot be performed over the phone.



Reference Guide 45

January 2019 Installation, configuration, activation, and registration 

Upgrades

Introduction

An upgrade code enables you to run the advanced features of a higher 
level product, either Design or Perform, using the same dongle that you 
already own. Contact your local WYSIWYG dealer to purchase an 
upgrade. You will be given an upgrade code at the time of purchase.

To upgrade the level of your WYSIWYG product

1 Start WYSIWYG.

2 From the Help menu, choose Upgrade.

The current level of WYSIWYG installed on your computer is 
displayed in the Current Level box. The serial code of your dongle is 
shown in the Serial Code box. 

3 In the Upgrade Code box, type your upgrade code, and then click 
Upgrade.

4 Exit WYSIWYG, and then restart your computer.
5 Launch WYSIWYG.

Result: The new level of software is displayed in the upper right 
corner of the WYSIWYG user interface.
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Note: If you would like to purchase an upgrade but are unsure of who to 
contact, click More Info to obtain a list of WYSIWYG dealers.
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Membership and Leases

Introduction

As of Release 24, you have two options for running WYSIWYG: you can 
purchase a Membership or you can lease a WYSIWYG dongle for one 
year.

Membership
When you purchase a Membership to WYSIWYG, you purchase the 
dongle. Your Membership is valid for a specific period of time, during 
which you can take advantage of all new software updates and releases. 
You can easily view and renew your Membership from within WYSIWYG 
by following the procedure in “Obtaining membership details”.

Leases
As of Release 24, you are able to lease WYSIWYG dongles on a yearly 
basis. Leased dongles carry the same privileges as purchased ones (for 
example, software updates, library updates, and technical support). 
However, unlike purchased dongles, once the lease is over, WYSIWYG will 
no longer run with that dongle, giving you the choice of renewing the 
lease or purchasing the dongle.

Leasing a dongle compared to Membership
 If you choose to lease WYSIWYG for 12 months, you pay less than 

the cost of purchasing WYSIWYG, but more than the cost of 
renewing a WYSIWYG membership. 

 With the Lease program, when the Lease Expiry Date is reached, the 
lease is over and the dongle will not run the software anymore 
(unless you choose to purchase another lease period or buy a 
WYSIWYG Membership). 

 The Lease Expiry Date differs from the Dongle Reauthorization Date 
(associated with the Member program) in that once you reauthorize 
your dongle, you can continue to use WYSIWYG for another year. 
Further, if you choose not to purchase a Membership renewal but 
continue to reauthorize your dongle, you can continue to use your 
old (non-current) WYSIWYG software.

 A leased dongle can be re-leased at any time (for another year), at 
which point it will receive the latest version of WYSIWYG, plus all 
upgrades available that year. 

 Unlike with Membership, a new Lease starts on the date when the 
Lease is purchased, not when the last Lease expired.
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 At the end of your lease, you can convert to Membership. For pricing 
details, please contact Customer Service. You cannot (nor would it 
make sense to) switch from Membership to leasing. Instead, have 
the option to lease a new dongle as needed.

Obtaining membership details

Details of your Membership are stored within WYSIWYG.

To obtain Membership details

From the Help menu, choose About WYSIWYG. 

Result: The month and year that your Membership expires is displayed 
in the Membership Expiry Date box. 

 1

Renewing your membership

Your WYSIWYG Membership is valid for a specific period of time. You can 
continue to use WYSIWYG beyond your Membership expiry date; 
however, you will not be able to access software updates until you renew 
your Membership.

Contact your local WYSIWYG dealer to purchase a renewal for your 
Membership. CAST Software provides you with the Membership code that 
you require. 

1. NDI™ is a trademark of NewTek, Inc.
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To renew your Membership

1 From the Help menu, choose Renew Membership.

 

The date when your WYSIWYG Membership expires is displayed in 
the Membership Expiry Date box. 

2 In the Membership Code box, type the code. The code is 10 
alphanumeric characters long. 

3 Verify that you have entered the correct information.
4 Click Renew. 
5 Exit WYSIWYG, and then restart the software for the renewal to take 

effect.

Note: If you would like to renew your Membership but are unsure of who 
to contact, click More Info to obtain a list of WYSIWYG dealers.

Obtaining lease details

Details of your Lease are stored within WYSIWYG.

To obtain Lease details

From the Help menu, choose About WYSIWYG. 

Result: The date when your Lease expires is displayed in the Lease Expiry 
Date box.
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Renewing your lease

Your WYSIWYG Lease is valid for one year from the date of purchase. 
You cannot continue to use WYSIWYG beyond your Lease expiry date; 
you must either renew your lease, or purchase a Membership to use the 
program.

Contact CAST Software or your local WYSIWYG dealer to purchase a 
renewal for your Lease.

To renew your Lease

Starting 30 days before your lease expires, the Dongle Lease Renewal 
window appears each time you open WYSIWYG until the Lease Expiry 
Date is reached, prompting you to renew your lease (or purchase a 
Membership).

1 In the Dongle Lease Renewal window, select the checkbox if you accept 
the terms of the license agreement. 

2 Note the Lease Request Code shown in this window.
3 Call CAST Software Customer Service at one of the numbers 

provided.
4 When requested by the Customer Service Representative, recite the 

Lease Request Code.
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5 The Customer Service Representative will give you the Lease 
Validation Code. Type the code in the box provided.

6 Click Renew.
Result: A Lease Renewal Successful message appears and your 
dongle is leased for another year.

7 Click OK.
Result: WYSIWYG starts.
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Passwords

Introduction

You can set a password in WYSIWYG to password-protect your dongle. 

To set a password

1 From the Help menu, choose Password.

Result: The Change Password dialog box appears.

2 In the New password box, type your new password. The password can 
be any combination of letters, numbers, and characters. As you type 
the password, WYSIWYG displays an asterisk (*) for each character 
that you type. The length of the password can be between 6 and 20 
characters.

3 In the Confirm password box, re-enter the password.
4 Click OK.

Result: The next time that you launch WYSIWYG on the same 
computer, you will be prompted to enter your password. In the Enter 
password box, type your password. If you do not want to be prompted 
to enter a password every time you launch WYSIWYG, select the 
Remember for next time checkbox.

ATTENTION: If you forget the password that you set on the dongle, the 
only way to reset if is by returning the dongle to the CAST 
Software office in Toronto, Canada. You will not be able to use 
WYSIWYG while the dongle is in transit. As such, it is strongly 
recommended that you make note of the password for safekeeping. 
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To change a password

1 From the Help menu, choose Password.

Result: The Change Password dialog box appears.

2 In the Current password box, type the password that you previously 
set. You must type the current password if you want to change the 
password. As you type the password, WYSIWYG displays an asterisk 
(*) for each character you type.

3 In the New password box, type a new password.
4 In the Confirm password box, re-enter the password. 
5 Click OK.

Note: If you decide that you do not want to password-protect your 
dongle, select the No password checkbox.
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Chapter  4

WYSIWYG user interface

All of the WYSIWYG levels use the same set of screens. The user 
interface was designed to facilitate smooth transitions from mode 
to mode, and to keep the data organized and easy to find.

In this chapter
Navigation and screen set-up 57

Languages 62

WYSIWYG User Data Profile 63

Shortcut bars 66

Toolbars 73

Status bar 91

Wireframe views 94

Shaded views 103
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Navigation and screen set-up

Welcome window

When you start WYSIWYG, the Welcome window appears. The application 
level is shown in the upper right corner of the window.

On the Welcome window or from the File menu, you can choose to create 
a new File or a new Project; or open an existing file or project. A list of 
template files and a list of recently saved files are displayed on the 
screen. 

WYSIWYG file

On the Welcome window, click a file name to start working with 
WYSIWYG.

Note: It is possible to open an existing WYSIWYG file by dragging the file 
icon from the desktop or folder and dropping it into the Welcome window.

To open an existing WYSIWYG file using drag and drop

1 Open the WYSIWYG Welcome window.

Select the .wyg file where it is located.
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2 Drag and drop the file icon into the Welcome window.
Result: The selected .wyg file will open.

WYSIWYG project

When saving your work as a WYSIWYG Project, the .wyg file and all its 
associated files are stored in a folder structure automatically within the 
My Projects folder. If you choose to accept the default settings when a 
WYSIWYG Project is saved, all files associated with that project are 
automatically stored in the Project folder and its subfolders. (e.g. 
C:\Users\<UserName>\Documents\WYSIWYG Files\My Projects\...)

A WYSIWYG Project can be packaged as a zip file with the option to 
include the external images and videos used in the file. 

Modes

Once you start working on a file, the Mode buttons located along the top 
of the user interface are used to access the different working modes 
available within the WYSIWYG levels. The currently selected mode is 
shown in orange, while modes not selected are shown in grey. Clicking 
the appropriate button will change the view to that mode. 

Note: Specific mode tabs can be selected from the mode’s drop-down 
menu, enabling rapid change of views easily.

CAD mode
CAD mode is where you create your show drawings or “model.” This 
includes drawing your venue, set pieces, lighting positions, focus 
positions, and lighting fixtures. This is also where you can import CAD 
files. CAD mode operates like many other CAD programs, so many of the 
concepts will be familiar to those who have used a computer-aided 
drafting program before. WYSIWYG adds features that are specific to the 
entertainment industry, such as a comprehensive 3D library containing 
truss, lighting equipment and accessories, as well as props, musical 
instruments, and various human figures.

Data mode
As you draw in CAD mode, all of your fixture information is compiled into 
spreadsheets that you can access in Data mode. In this mode, you can 
view and edit the data for all your fixtures. Data mode operates like 
many other spreadsheet programs, so many of the concepts will be 
familiar to those who have used a spreadsheet program. The CAD and 
Data modes remain completely interactive and any information modified 
in either mode is updated in the other.
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Design mode
Design mode was created to provide lighting designers with an avenue 
for experimentation. Design mode can be used as a troubleshooting tool 
or as a creative tool to help you come up with cue concepts. In Design 
mode, you can create static lighting looks using the design tools, and 
then save and render those looks to output photo-realistic pictures. You 
can turn on and control fixtures without having to patch or connect to a 
console.

Presentation mode
Presentation (Pres) mode contains all the tools necessary for creating 
professional printouts of your show document including reports, plots, 
and images. As with all other modes, the contents of the Pres mode are 
continually updated as you draw, input data, and modify your show file. 
In addition to being able to create your own plots, WYSIWYG provides a 
series of default plots and reports that are ready for printout. These 
defaults can be used as is or customized to suit your preferences. 

Live mode
Live mode is used for graphically simulating the output of a lighting 
control console or compatible offline editor. This is where you can pre-cue 
and visualize your show. Live mode also has rendering ability so that you 
can create photo-realistic pictures of the simulated lighting looks. Live 
mode will fully display a console's output, including transitions from cue 
to cue, allowing you to see the programmed changes to lights over time.

Availability of modes

The following working modes are available in WYSIWYG Report:

 CAD 
 DATA
 PRES

The following working modes are available in WYSIWYG Design:

 CAD 
 DATA
 DESIGN
 PRES

The following working modes are available in WYSIWYG Perform:

 CAD 
 DATA
 DESIGN
 PRES
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 LIVE

Layouts

Beneath the work area in each mode is a series of layout tabs. A layout is 
a configuration of work views. Views and layouts are mode specific. 

Custom layouts can be created in CAD, DESIGN and LIVE modes. The 
only layout that is editable are Quad layouts, and only the sizes of the 
panes can be changed. For more information, see “Custom tab window 
layout”. 

To this end, WYSIWYG supports pop-up frames and has multi-monitor 
functionality, thus providing alternative tools for customizing your work 
environment. These features are discussed below.

Click the appropriate Layout tab to change layouts.

Views

Views are the windows in the work space. The windows are pre-
configured on the screen based on the layout, as discussed above.

The WYSIWYG views include: Wireframe, Flight Case, Shaded, 
Spreadsheet, Patch, Error, Report, Image, Plot, and Worksheet. 

The layouts and views available in each mode are discussed at the 
beginning of each chapter.

For more information, see “Wireframe views” and “Shaded views”.

Pop-up frames

You can place a view in a “pop-up frame” so that it remains active across 
modes. For example, if you place the patch view in a pop-up frame, it will 
remain visible even if the mode is changed from Data to CAD. 

The position of pop-up frames are remembered when a file is saved. 
When the saved file is reopened, all pop-up frame positions will be 
remembered and set exactly how they were working last. 

To place a view in a pop-up frame

1 Make the desired window active.

2 Click the Pop-Up Window tool on the View toolbar. 

Result: A new window containing a copy of the selected view opens. 

 The Pop-Up Window button.
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 Pop-up frames retain all the functionality of the original view so 
you can work in the pop-up view if you want to.

 Are fully integrated with the remaining show document and are 
continually updated (and vice versa).

 Can be resized and moved to any location on the screen or across 
monitors.

To display pop-up frames in full screen mode

1 Make the pop-up window active. 

2 Click the Full Screen button. 

Result: The pop-up frame expands to fill the entire screen with no 
title bar visible.

Tip: To return the pop-up frame to normal size, press ESC.

To minimize a pop-up frame

1 Double-click the title bar of the pop-up window. 

Result: The title bar only is displayed. 

Tip: You can also click the Minimize button. 

 The Full Screen button.

 The Minimize button.



62

WYSIWYG user interface  R42

Languages

Introduction

From the Options menu in the Welcome window, you can choose a 
different language that will be used in WYSIWYG. Selecting a different 
language will require to restart WYSIWYG. English, français (French) and 
italiano (Italian) are the options available at the present, and more 
languages will be added in the future.

To open WYSIWYG with a different language

1 On the Welcome window, click Options > Language and choose either 
English or français or italiano.

Result: If the selected language is different from the default, the 
“Your changes will not be applied until the next time WYSIWYG is started. 
Please remember to save your work.” dialog box appears.

2 In the dialog box, click OK.
3 Exit WYSIWYG.
4 Start WYSIWYG again.

Result: WYSIWYG opens with the selected language.



Reference Guide 63

January 2019 WYSIWYG user interface 

WYSIWYG User Data Profile

Introduction

You can save WYSIWYG settings that are specific to a particular 
installation of the WYSIWYG software into an external file with a .wud 
extension. You can then load this file into WYSIWYG to automatically load 
all the user settings saved in the .wud file. With .wud files, you can share 
your custom user data between multiple computers and when upgrading 
to newer WYSIWYG releases.

The following user data and settings are found in a.wud file:

 CAD Block /WYSIWYG Fixture Associations
 Custom Conventional Fixtures
 Custom Gobos
 Custom Layout tabs
 Custom Library Items
 Fixture Attribute Layout Templates
 Layout Templates
 Modified Fixture Symbols/Attribute Layouts
 Shared Keys
 Toolbar Positions
 Truss Manager Data

Attention: WYSIWYG User Data files can only be imported and exported 
from the WYSIWYG Welcome window. 
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Exporting user data

To export a User Data Profile

1 From the Welcome screen, click File > Export User Data. 

Result: The Export User Data window appears. 

2 In the Export User Data window, select the checkbox(es) of features 
you want to export. Select the checkbox on the top row of the list to 
select all the check boxes below.

3 Click Continue.
4 The Save As window appears.
5 In the Save As window, navigate to where you want the file to be 

saved, and enter an appropriate name in the File Name field.
6 Click Save.

Result: The User Data Profile is saved at the chosen location.

Importing user data

To import a User Data Profile

1 From the Welcome screen, click File > Import User Data. 

Result: The Select User Data File window appears.
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2 In the Select User Data File window, navigate to where the desired 
WYSIWYG User Data file (*.wud) is located. Select the file and click 
Open.
Result: The Import User Data window appears.

3 In the Import User Data window, select the checkbox(es) of features 
you want to import. Select the checkbox on the top row of the list to 
select all the check boxes below.
Note: [Overwrite] appears next to settings stored in the *.wud file 
that will overwrite existing WYSIWYG settings if imported. 

4 Click Continue.
Result: The User Data settings will be successfully imported. 
WYSIWYG will need to restart for the new settings to take effect.

Exporting and resetting WYSIWYG UI 

You can save your user interface settings into an external file with a .wud 
extension, which can be loaded back into WYSIWYG. Click Export my 
WYSIWYG Registry on the WYSIWYG Tech Support dialog box that appears 
when you click Support from the Help menu.

You can reset the user interface settings of WYSIWYG to default by 
clicking the Reset my UI to default button on the WYSIWYG Tech Support 
dialog box that appears when you click Support from the Help menu.
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Shortcut bars

Introduction

Shortcuts are created for quick access to library items and view types, 
among other things. The shortcut bars are located on the left side of your 
screen. Shortcut bars are mode and layout specific. Each layout has 
designated shortcut bars. 

In general, there are three types of shortcuts:

 navigation
 library
 views/tools
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Navigation shortcuts

The first type of shortcut is used for navigation purposes. The navigation 
shortcuts are:

  Navigation
  Views

Navigation shortcuts store the mode and layout destination. For 
example, you can save a navigation shortcut to Data mode / Patch 
layout. The next time you want to go back to that location, click the 
shortcut to save you at least one step.

View shortcuts store the plot type and zoom level. View shortcuts only 
apply to Wireframe views.

Library shortcuts

The second type of shortcut is used in place of browsing the library. The 
library shortcuts are:

Views/tools shortcuts

The final type of shortcut is used to open and save views and tools. The 
views/tools shortcuts are:

Fixtures

Accessories

Color

Gobo

Library

Truss



68

WYSIWYG user interface  R42

Working with shortcuts

Generally the procedure for creating, modifying, and working with 
shortcuts is the same regardless of the type of shortcut.

To create a new shortcut

1 Right-click on the open space on the appropriate shortcut bar, and 
then choose the appropriate New option.

Note: For navigation type shortcuts, ensure that the destination is 
set up, and then proceed with step 1.

2 Based on the type of shortcut, you are prompted to select the object 
or type a name for the new shortcut.

3 Click Insert or OK.
Result: The shortcut is created and added to the bottom of the list 
on the shortcut bar that you selected in step 1.

To remove a shortcut

1 Right-click the shortcut icon that you want to remove.

2 Choose Delete.
Result: You are prompted to confirm the deletion.

Columns

Patch

Errors

Worksheets

Images

Layouts

New Plots

Legend

Key

Reports

Looks

Fixture Group

Palettes

Render

Shaded View Profiles

Selection Sets
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3 Click OK to confirm.
Result: The selected shortcut is deleted.

To rename a shortcut

1 Right-click the shortcut icon that you want to rename.

2 Choose Rename.
3 Type a new name for the shortcut.
4 Click OK.

Result: The selected shortcut is renamed.

To clone a shortcut

1 Right-click the shortcut icon that you want to clone.

2 Choose Clone Shortcut.
3 Type a name for the copy.

Result: The selected shortcut is cloned and the copy is added to the 
bottom of the list.

To arrange shortcuts

You can arrange shortcuts on the shortcut bar area by using drag-and-
drop functionality. 

1 Click the shortcut that you want to move. 

2 While holding down the mouse button, press ALT to move the 
shortcut to the desired location. 

3 Release the mouse button to place the shortcut. 

To set the display size for shortcuts

Right-click on the open space on the appropriate shortcut bar, and then 
choose either Icons or List (depending on your current setup).

Result: When you choose Icons, all shortcuts are displayed as icons. List 
will cause the shortcuts to be listed in the shortcut bar area, thereby 
allowing you to fit more shortcuts in the area. 

The settings are retained for all shortcuts. 

Note: To scroll to the bottom of a long list of shortcuts, use either the 
scroll button on your mouse or the scroll bar along the side of the 
shortcut bar. 
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To use a shortcut

Click the shortcut icon. 

Note: As with all objects in WYSIWYG, all shortcuts have properties that 
affect the object being inserted, the view or tool, or the navigation 
method.

To modify a shortcut’s properties

1 Right-click the shortcut icon that you want to modify.

2 Choose Properties. 
Result: The Properties dialog box appears. The settings modified here 
affect the object, view, tool, or navigation destination of the selected 
shortcut. An example of the Navigation Shortcut Properties dialog box is 
shown below; however, the shortcut properties window varies based 
on the type of shortcut that you select.

3 In the Name box, type the new name of the shortcut. 
4 To open the shortcut in a pop-up frame, select the Pop-Up Windows 

checkbox. For more information on pop-up frames, refer to “Pop-up 
frames”.

To configure the shortcut bar

You can configure the shortcut bar to show fewer/more categories, and 
reorder the categories that you see.

1 On the bottom right corner of the shortcut bar, click the Configure 
Shortcuts arrow.

2 In the resulting pop-up menu, you have the following choices:
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 Show More Buttons: Click to add the next shortcut category to the 
bottom of the shortcut bar. This button is enabled only if you have 
hidden some shortcut categories.

 Show Fewer Buttons: Click to remove the bottom-most shortcut 
category from the shortcut bar. Click consecutively to remove 
each category shown from the bottom upwards.

 Navigation Pane Options: Click to arrange the order of the shortcut 
categories shown on the shortcut bar. 

To manage shortcuts

Shortcuts in your file can be sorted and deleted as needed. Sorted 
shortcuts can be managed manually or alphabetically. You can also insert 
separators between shortcuts to group, segregate and organize the 
shortcut icons.
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1 On the shortcut bar, right-click and select Manage Shortcuts menu.

Result: The Manage (shortcut type) Shortcuts window appears.

2 On the Manage (shortcut type) Shortcuts window, select the checkbox 
next to the shortcuts you want to manage. You may click Select All to 
select all shortcuts in the list. 

3 To insert a shortcut separator in the list, select a shortcut and click 
the Add Separator button. A separator indicator will be added to the 
list after the selected shortcut.
Result: On the shortcut bar, a shortcut separator appears on the 
space below the selected shortcut.

Tip: On the shortcut bar, you may also right-click on the space where 
you want to insert a separator and click the Add Separator menu.

4 To move a selected shortcut in the list, click Up or Down. The shortcut 
will move one position up or down respectively. 

5 To move a selected shortcut to the top of the list, click Move selected 
shortcuts to top. 

6 To sort selected shortcuts alphabetically, click Sort alphabetically. 
7 To remove a selected shortcut, click Delete.
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Toolbars

The Menu bar

The Menu bar is located within the WYSIWYG user interface, below the 
Mode buttons and above the work area. The available menus change 
when moving from mode to mode. The individual menus are explained 
within the context of each mode chapter.

The Menu bar is dockable. It has a grab bar on the left that is used to 
move the Menu bar around the screen. It may be placed on the edges of 
the work area; top, bottom, left or right. It may also be dragged off the 
edge of the work area and into its own window. This window remains on 
top of the WYSIWYG screen and may be dragged anywhere on your 
display.

Menu commands can be accessed using a mouse, keyboard, or by using 
hot keys. 

To access menu commands using the keyboard

1 Press ALT + n, where n is the underlined letter in the menu name. 

Result: The menu will be displayed.

2 Press the key corresponding to the underlined letter in the command 
that you want to execute.
Note: Some commands have shortcuts that do not require menu 
selection. In those cases, the shortcut keys are listed to the right of 
the command in the menu. 

Example: To undo the last command, press CTRL + Z.

Toolbars

Toolbars provide button access to most commands. This is in lieu of 
selecting the commands through the menus in the Menu bar. 

Toolbars, like menus, are mode sensitive. However, unlike menus, you 
can customize how the toolbars are displayed and which toolbars are 
open for each mode. Toolbars that are greyed out in the toolbar selection 
list are not used in the current mode.
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Toolbars are typically found directly under the Menu bar and have a grab 
bar on the left that is used to move the toolbar around the screen. They 
can be placed on the edges of the work area (top, bottom, left or right), 
and can also be dragged off the edge of the work area and into their own 
window. This window remains on top of the WYSIWYG screen and can be 
dragged anywhere on your display.

Toolbars drop-down menus

To save on space, similar toolbar buttons are grouped together in a 
Toolbar drop-down menu. If a drop-down menu is available for a button, 
it can be identified by the small triangle in the lower right side of the 
button. 

Click and hold the button until the drop-down menu appears, and then 
click on your choice. The selected item in the drop-down menu is then 
displayed at the top level of the toolbar. 

Available toolbars 

The following toolbars are available (listed in alphabetical order).
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Align toolbar (CAD, PRES/Layouts and /New Plots)

Align to Extents

Align to First Selected

Align to Last Selected

Align Top

Align Bottom

Align Left

Align Right

Center Horizontally

Center Vertically
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CAD Options toolbar

Plan View

Left View

Right View

Back View

Isometric View

Workplane Plan

Workplane Section

Workplane Elevation

Grid Snap

Mid-Grid Snap

Point Snap

Midpoint Snap

Endpoint Snap

Intersection Snap

Center Snap

Library Snap

Truss Snap

Assembly Snap

Pipe Snap

Focus Snap

X-Axis

Y-Axis

Z-Axis

Missing Coordinate

Interactive Mode

Toggle Grid

Toggle Beam Dragging

Toggle Rulers

Front View
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Camera toolbar

Command Line toolbar

Data toolbar

Data Fonts toolbar

Camera 
Lock

Reset 
Camera

Reset Y 
Rotation

Lock X 
Rotation

Lock Z 
Rotation

Use DMX for 
Cameras

Current 
Camera

Camera 
Properties

Save View 
as New 
Camera

Reset X 
Rotation

Reset Z 
Rotation

Lock Y 
Rotation

Camera 
Manager

Edit box

Fixture

Colour Select

Gobo Select

Accessory

Quick Tools

Font 
Color

Left 
Align

Right 
AlignBold

Center 
Align

Word
Wrap 

ItalicFont 
Size

Font
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Design toolbar

Device toolbar

At Full and Focus

Toggle Intensity Designer Tool

Toggle Focus Designer Tool

Toggle Iris Designer Tool

Toggle Zoom Designer Tool

Toggle Color Designer Tool

Toggle Gobo Designer Tool

Toggle Prism Designer Tool

Toggle Video Designer Tool

Toggle Moving Scenery Designer Tool

Toggle Footprint Designer Tool

Render Wizard

Fade looks

Toggle Cuelist Editor Tool

Toggle Camera Path Editor Tool

Toggle Timeline Tool

Connect Properties

Select Device Disconnect
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Draw toolbar

Draw a point

Lines

Circles

Rectangles

Text Label

Dimensions

Surface

Riser

Cylinder

Cone

Sphere

Wall

Library

Pipe

Curved Pipe

Rigging Point

Fixture

Accessory

Focus

Draw a screen

LED Wizard

Pipe and Drape Wizard

Insert Camera

Rectangle

Polygon

Circle

Arc

Elliptical Arc

Line

Centered Line

Dashed Line

Dotted Line

Spline Linear Dimension

Continue Dimension

Baseline Dimension

Arc Length Dimension

Radial Dimension

Angle Dimension

Linear Scale

Focus Position

Focus Line

Focus Arc

Truss
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Edit toolbar

Edit (Pres) toolbar

Item Properties

Cut

Copy

Paste

Delete

Undo

Redo

Repeat Last Command

Item Properties

Cut

Copy

Paste

Delete

Undo

Redo

Repeat Last Command

Bring to Front

Send to Back

Content Properties

Open Contents

Lock object to prevent move and resize

Show Placeholders

Rotate object to 0 degrees

Rotate object to 90 degrees

Rotate object to 180 degrees

Rotate object to 270 degrees
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Fixture Selection toolbar

Layout Insert (Pres) toolbar

Layer toolbar

Select 
Fixtures

Re-select 
Fixtures Highlight

Select by                                      
Spot/Channel Number

Previous 
Fixture

Next 
Fixture

Line

Rectangle

Rounded Rectangle

Ellipse

Text

Image

CAD Item

Report Item

Worksheet Item

Legend

Key

New Plot Item

Create Layout Template

Insert Layout Template

Delete Layout Template

Current 
Layer
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Layout Text (Pres) toolbar (Pres > Reports, Layouts and 
Worksheets)

Live toolbar

Align 
Vertical 
Center

Align    
Horizontal 
Center

        
Wrap 
Text

                                                                                                             
         
Underline

                                  
          
Bold

Font Font 
Size

Italic Font 
Color

Background 
Color

Align 
Right

Align 
Top

Align 
Bottom

Align 
Left

At Full and Focus

Toggle Intensity Designer Tool

Toggle Focus Designer Tool

Toggle Iris Designer Tool

Toggle Zoom Designer Tool

Toggle Color Designer Tool

Toggle Gobo Designer Tool

Toggle Prism Designer Tool

Toggle Video Designer Tool

Toggle Camera Path Editor Tool

Toggle Timeline Tool
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New Plot Options

New Plot View

Selection toolbar

Scene toolbar

Solid Line

Center Line

Dashing Line

Dotted Line

Circle

Arc

Elliptical Arc

Rectangle

Text Label

Symbol

Grid Snap

Midpoint Snap

Endpoint Snap

Intersection Snap

Center Snap

X-Axis

Y-Axis

Z-Axis

Zoom Fit

Zoom In

Zoom Out

Zoom Window

Pan

Select All

Select Current Layer

Specify Layers to Select

Restore Previous Selection

Select Last Object Created

Invert Selection

Current scene Use DMX for Scenes
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Data Spreadsheets toolbar

Standard toolbar

Text toolbar (CAD, and Pres > New Plots)

Zebra Stripping

Non-Editable Column Tint

Show Selected Only

Sort by Selection

New Blank Documents

Open

Save

Print

Print Preview

Italic Anchor Direction

Font Size Bold Underline

Anchor Left

Anchor Center

Anchor Right

Anchor Middle

Anchor Bottom

Anchor Top
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Tools toolbar

Move

Rotate

Mirror

Break

Convert

Divide

Extrude

Revolve

Boolean Operation

Array

Trim

Extend

Group

Ungroup

Bring to Front

Send to Back

Quick Tools

Distance

Set User Origin

Subtract Objects

Unite Objects

Intersect Objects

Quick Tools

Quick Focus

Quick Light Emission Tool

Quick Video/Image Tool

Array Linear

Array Polar

Array Grid

Distribute Objects 
Between Two Points

Scale
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View toolbar

Window toolbar

To hide and display toolbars using the toolbar list

1 Right-click on the toolbar area. 

Result: The toolbar list is displayed.

View options

Zoom Fit

Zoom In

Zoom Out

Zoom Window

Undo View Change

Redo View Change

Rotate View Left

Rotate View Right

Rotate View Up

Rotate View Down

Pan

Refresh

Pop-Up Window

Render Wizard

Cut and AdjustmentsTool

Fanning Tool

Toggle Camera Path Editor Tool

Toggle Shaded View Settings Tool

Toggle Video Designer Tool

Display Wireframe View

Display Shaded View

Display Spreadsheet View

Display Patch View

Reset Views

Position Tool
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2 Click on the name of the toolbar that you wish to display. A check 
mark to the left of the toolbar name indicates it is currently 
displayed.

3 Repeat to display or hide multiple toolbars.
Tip: From the toolbar list, select Toolbars to open the Application 
Options dialog box. In this dialog box, you can choose multiple 
toolbars and configure other screen options, such as the Status bar 
and tooltips.

To hide and display toolbars using the Options menu

1 From the Options menu, choose Application Options.

2 Click the Toolbars tab. 

3 Select the check boxes of the toolbars that you want to display. 

Note: Since toolbars are mode-sensitive, certain toolbars are disabled 
based on the mode that you are currently in. 
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Window position management

Most tools in WYSIWYG create a separate window where all the options 
of the tool are available. Window positions of these tools can be 
customized to suit most work styles. If a WYSIWYG document is saved, 
WYSIWYG will remember the window preference of the tool the next time 
the document is opened.

Window position options can be accessed by clicking the down arrow at 
the top of the window, and opening the Window Position drop-down 
menu.

 Floating: The window will appear in the foreground of the WYSIWYG 
file. The window will not be attached to any border of the work space 
or any other window. If the resolution of WYSIWYG or the work space 
is resized, the window will remain in its current position and in the 
foreground.
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 Docking: The window will be attached to a border of the work space. 
If the resolution of WYSIWYG or the work space is resized, the 
window will change its resolution to match the new work space size.

 Tabbed Document: Tools with similar display options can share the 
same window space. The tabbed document can be either floating or 
docked. At the bottom of the window will be tabs showing the names 
of the different tools. Click on the tabs to switch between tools as 
needed.

 Auto Hide: This option is only available for docked windows. When 
enabled, the window will be hidden from view by default. A tab will 
appear on the side of the WYSIWYG application window with the 
name of the auto hidden window. When the tab is selected, the 
window will reappear in its previously docked location. The window 
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will continue to be visible until another window or feature is selected, 
or until you click off of it.

 Hide: The selected window will close. To view the window again, the 
feature must be accessed again.

To display a window as tabbed

1 Identify the tools/features that you wish to tab together. 

2 Click and drag one tool window over to another tool window, until the 
arrows appear over the tool.

3 Without releasing the mouse, move your cursor to the square in the 
middle of the arrows that appear, and then release the mouse.
Result: The tools will now be tabbed together.

To toggle the auto hide setting of a window

Click the Pin icon to toggle the Auto Hide setting of a window.

Floating toolbars

Floating Toolbars are available in WYSIWYG to offer common features 
conveniently at your cursor. When you right-click on a view, in addition to 
the usual right-click menu, a floating toolbar will appear either above or 
below the right-click menu (depending on where you clicked on the 
screen).

The icons displayed are the same as the ones displayed in the menus and 
toolbars. If you are not familiar with an icon, hover over it and a tooltip 
will appear displaying the feature's name.
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Status bar

Introduction

The Status bar is displayed along the bottom of the WYSIWYG screen, 
below the Layout tabs. The Status bar displays the prompt line, the 
number of unused channels (WYSIWYG Perform), selected object 
information, and tracks the status of the snap, ortho and absolute 
coordinates commands. It also tracks and displays the coordinates of the 
cursor.

The Status bar can be turned on or off from the toolbar list. You can also 
customize the contents of the Status bar from the Application Options 
window. 

For more information on setting the options of your drawing, refer to 
“Application Options”.

Prompt line
The prompt line displays the current status of a command within your 
drawing. If you are currently working with a command that requires 
multiple steps (the placement of a pipe, for example), the prompt line 
displays a message indicating the next step required to accomplish that 
task. The prompt line also displays a short description of a command 
when you point to it using your mouse.

Selected object count
In this display, “O” stands for the number of objects currently selected. 
The “F” stands for the number of fixtures selected and the “C” stands for 
the number of circuits currently selected.

Unused channels
Although there is never a limitation on how many fixtures can be patched 
in a file, there is a limitation on the number of DMX channels that can be 
simulated in Live mode. WYSIWYG will not simulate the DMX values 
being received on channels exceeding the Perform channel count of your 

Selected object Unused channels
Absolute Missing Units of 

measurement
Snap and 
OrthocoordinatecoordinatesPrompt line
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system. WYSIWYG Perform is available in 500, 1000, 2000, 5000 and 
Unlimited channels. (WYSIWYG Unlimited has 100,000 channels.) The 
unused channels displayed on the Status bar track the remaining 
channels for simulation based on the level of your Perform system. Note 
that fixtures on layers that are not visible, or which are not included in 
the current scene, are not counted. 

Absolute and Relative coordinates
This setting determines how coordinate information is displayed mid-
command. In ABS (Absolute) mode, which is the default, the coordinates 
display always shows the coordinates currently under your cursor. In REL 
(Relative) mode, the Coordinates display shows the relative distance and 
angle from the last position, indicated with a mouse click.

Coordinates
Coordinates are displayed in the order of X, Y and Z. The coordinates 
display the position of the cursor as a distance from the origin of the 
drawing. For more information on coordinates and setting the origin 
point, refer to “Coordinate system and origin”.

Missing coordinate
Double-click this label to set the missing coordinate. The missing 
coordinate (X,Y,or Z) is the coordinate whose value cannot be entered by 
clicking on the screen. The easiest way to determine the missing 
coordinate in a Wireframe view is to move the mouse around and look at 
the Status bar at the bottom of the working area. You will see only two 
values changing. The value that is not changing is the missing coordinate 
for that view or workplane. 

The missing coordinate is dependent on the plot type and the workplane 
selected. Once entered this value will affect all subsequent objects 
inserted in the current view. For example, if the missing coordinate is set 
to 5’ in a plan view, all objects will be placed 5’ off the floor (X,Y,5) until 
the missing coordinate is changed again. Note that the missing 
coordinate is not a move tool; objects are not moved to the missing 
coordinate value. The missing coordinate only affects subsequent inserts.

Units of measurement
Click this label to toggle between metric and imperial units of 
measurement.

Snap and Ortho
The snap and ortho entry shows the status of these items. If the 
indicator is white, a snap or ortho setting is active. If the indicator is dark 
grey, snap and ortho are not active.
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Instruction tooltip

The Instruction Tooltip is a helpful window that appears automatically 
when you start an operation. The Instruction Tooltip explains how to 
perform the current operation. The information shown is the same 
information that is displayed in the Status bar.

Note: By default the Instruction Tooltip is turned on.

For some operations, such as snapping truss or hanging a fixture, the 
tooltip color will be red when the operation can not be performed, then 
change to green when you can insert the object.

To turn off Instruction Tooltips

1 From the Options menu, choose Application Option....

2 In the General tab, clear the Enable Instruction Tooltip checkbox.
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Wireframe views

Introduction

When you first create a new show document and enter CAD mode, 
WYSIWYG defaults to the Wireframe view. All drawing is done in 
Wireframe view. Click the Quad tab to display three Wireframe views and 
a shaded view of your drawing.

Keyboard and mouse control

To modify the point of view
 The arrow keys move you in their respective directions.
 The PAGE UP and PAGE DOWN keys zoom you in and out. You can 

also roll the middle mouse button up and down to zoom in and out. 
The zoom action is centered on the mouse pointer rather than the 
center of the window. 

 In a 3D perspective view (isometric or shaded), the CTRL key, in 
combination with any of the aforementioned keys, rotates you 
around your drawing.

 Holding down the middle mouse button will allow you to drag the 
drawing around the window. Alternatively, the Pan tool on the View 
toolbar also enables this type of movement.

 At any time you can use the SHIFT key in combination with any of 
the movement keys to move in smaller increments.

 In shaded views, the mouse can substitute all key strokes. Click and 
drag to pan around and use the mouse wheel for zooming.

Zoom tools

Zoom tools allow you to view smaller or larger sections of a plot or 
drawing. There are seven zoom tools available in WYSIWYG. 

Note: The zoom tools are not applicable in the Shaded view; to zoom in 
or out in this view, use the arrow keys or the roller wheel on your mouse 
instead.

 The Pan button.
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To access the Zoom tools

1 From the Zoom menu, choose one of the Zoom tools. 

Tip: You may also use the Zoom tools on the View toolbar.
Result: The viewpoint is adjusted accordingly.

The Zoom tools that are available are listed in the following table. 

Zoom tool Description

Zoom In Moves your viewpoint 
closer to the center of the 
view.

Zoom Out Moves your viewpoint 
farther away from the 
center of the view. 

Zoom Fit Adjusts the viewpoint so 
that the extremities of the 
drawing fit into the current 
view.

Zoom Fit All (only 
available on the Zoom 
menu)

For Quad layout, adjusts 
the viewpoint so that the 
extremities of the drawing 
fit into the three Wireframe 
views simultaneously. In 
Wireframe view, adjusts 
the viewpoint so that the 
extremities of the drawing 
fit the window.

Zoom Window Allows you to specify the 
area of the drawing to be 
viewed. For more 
information on using this 
tool, refer to the procedure 
below.

Undo View 
Change 

Adjusts the viewpoint so 
the most current changes 
to the view are undone

Redo View
Change 

Adjusts the viewpoint so 
that any changes to the 
view caused by Undo View 
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To use the Zoom Window tool

1 In Wireframe view, from the Zoom menu, choose the Zoom Window 
tool. 

2 Click the left mouse button and drag a window around the area into 
which you want to zoom.

3 Click the left mouse button again to capture the second point of the 
window.
Result: The view changes to the area that you have selected.

View shortcuts

View shortcuts record the plot type as well as the zoom and pan settings 
of a specific point of view. You can use the shortcut to get back to that 
exact view point the next time you need to.

To record a view shortcut

1 Set up the active window for the plot type, zoom, and pan settings 
you wish to record.

2 Right-click on the Views shortcut bar, and then choose New View.
3 Type a name for the new shortcut, and then click OK.

Result: The shortcut is recorded and available on the Views shortcut 
bar.

To modify the properties of a view shortcut

1 Right-click on the Views shortcut icon that you want to modify, and 
then select Properties.

Result: The View Shortcut Properties dialog box appears.

2 In the Name box, type the new name of the shortcut.
3 To open the shortcut in the current active window, enable the Current 

Window option button. 
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4 To open the shortcut in a pop-up frame, enable the Pop-Up Window 
option button. For more information on pop-up frames, refer to “Pop-
up frames”.

Modifying Wireframe views

The properties of a Wireframe view affect how objects are drawn and 
how much information is visible. These settings are modified in the View 
Options. 

To modify a Wireframe view

1 Ensure the Wireframe view that you want to modify is active. 

2 From the Options menu, choose View Options.
Result: The View Options window appears.

Tip: You can also use the View Options tool on the Standard toolbar to 
open the view options.

 The View Options button.
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3 Modify options as desired.
4 Click OK.

General tab
Options on the General tab affect the current scene.

 Follow Current Scene: Select this checkbox to use the currently 
selected scene. Clear this checkbox, and then select the desired 
scene from the Scenes drop-down list. To learn more about scenes, 
refer to “Editing objects”.
Tip: You can also change the current scene at any time by using the 
drop-down list on the Scene toolbar.

 Scene: Name of the Wireframe view.

Draw Options tab
Options on the Draw Options tab affect the draw defaults. This tab is 
similar in function to the Draw Defaults tab available in Document Options. 
For more information on the Draw Options tab, refer to “Draw Defaults 
tab”.
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 Use Document Settings: Select this checkbox to reference the options 
selected on the Draw Defaults tab of Document Options. Clear the Use 
Document Settings checkbox to make specific changes for the active 
view.

 Get Document Settings: Retrieves the values set on the Draw Defaults tab 
of Document Options.

View Type tab
Options on the View Type tab affect the plot type of the active view.
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 View Type: The view types available are as discussed in “Plot types”. 
Tip: The view type can be toggled using the tools on the CAD Options 
toolbar.

 Scrollbars On: Select this checkbox to display the scrollbars on the 
bottom and left side edges of the Wireframe view. Clear this 
checkbox to turn the scrollbars off. 

Wireframe Details tab
Options on the Wireframe Details tab affect what and how objects such as 
truss, text, point, library and other object information are displayed. This 
tab is similar in function to the Wireframe Details tab available in Document 
Options. For more information on the Wireframe Details tab, refer to 
“Wireframe Details tab”.
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 Use Document Defaults: Select this checkbox to reference the options 
set in the Wireframe Details tab of Document Options. Clear the Use 
Document Defaults checkbox to make specific changes for the active 
view.

Fixture Attribute Details tab
Options on the Fixture Attribute Details tab affect what and how fixture 
information are displayed. This tab is similar in function to the Fixture 
Attribute Details tab available in Document Options. For more information on 
the Fixture Attribute Details tab, refer to “Fixture Attribute Details tab”.
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 Use Document Defaults: Select this checkbox to reference the options 
set in the Fixture Attribute Details tab of Document Options. Clear the Use 
Document Defaults checkbox to make specific changes for the active 
view.
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Shaded views

Introduction

Shaded or OpenGL views offer a 3D perspective view of your drawing. 
Surfaces, truss, and fixtures are “filled-in” or solid, rather than outlined 
as in Wireframe views. 

Shaded views will follow scenes just like any other view.

Keyboard and mouse control

To modify the point of view
 Use the arrow keys to move the position of the virtual target. PAGE 

UP/PAGE DOWN will zoom you in and out. 
 At any time you can use the SHIFT key in combination with any of 

the movement keys to move in smaller increments.
 The mouse pan tool can be set to rotate the model or the camera 

around the target. You can also use the mouse wheel to zoom in and 
out. The arrow keys will continue to move the target position as you 
do this.

To open Shaded view full screen mode

You can expand the Shaded view to encompass the entire screen by 
right-clicking anywhere within the view and selecting Open in Full Screen. 
To exit full screen mode, press the ESC key.

Note: The Full Screen Mode for Shaded view can be set to Windowed Full 
Screen Mode or Exclusive Full Screen Mode. See “Simulation tab” in the 
Application Options for details.

Camera controls

This section defines how a camera is controlled in Shaded view when 
Traditional WYSIWYG is selected as the Shaded View Camera Control. Traditional 
WYSIWYG is the default camera control in Shaded view. 

In the Application Options window, you can choose Other 3D Applications on 
the Shaded View Camera Control drop-down list if you want to use camera 
control that complies with other 3D applications. See “Camera Control” 
for alternative mouse and keyboard action commands.
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Note: The Camera-to-Target distance is maintained for all operations 
listed below. To change this distance, hold down simultaneously CTRL 
and ALT and spin the mouse wheel up or down while the Shaded view or 
the shaded pane of Quad view is active. You need to perform this action 
to alter the Camera’s orbit; it also serves to set the target distance when 
rendering with Aperture enabled. This does not apply to Flying Cameras, 
since the target system for Flying Cameras is different than World or 
Standard Cameras’ target systems. 

 Holding down the left SHIFT key on the keyboard while performing 
any of the actions below will decrease the speed at which changes 
are applied, regardless of how the actions are performed (i.e., by 
mouse or keyboard).

 Holding down the right SHIFT key on the keyboard while performing 
any of the actions below will increase the speed at which changes are 
applied, again regardless of how the actions are performed (i.e., by 
mouse or keyboard).

Orbit
Orbiting the camera causes it to spin around its target without altering 
the target’s position. When the camera is orbiting, its own position 
changes. This control applies to World and Standard Cameras.

 To orbit a Camera using the mouse, click and drag with the left 
mouse button in the Shaded view or the shaded pane of Quad view.

 To orbit a Camera by using the keyboard, hold down ALT and tap 
the arrow keys while the Shaded view or the shaded pane of Quad 
view is active.

Notes: 

 In order to prevent accidentally changing the shape of Camera Paths, 
it is not possible to orbit Flying Cameras.

 This is the “default” behavior for a Camera in WYSIWYG; it has not 
changed despite the introduction of the new camera system in 
Release 29.

Pivot
Pivoting the Camera causes it to change its orientation/where it is 
pointing to (without altering its own position). Another way to think of it 
is that by pivoting the Camera, its target’s position is altered.

This control applies to World, Standard and Flying Cameras (at user-
defined nodes).

 To pivot a Camera using the mouse, hold down ALT on the 
keyboard and click and drag with the left mouse button in the 
Shaded view or the shaded pane of Quad view.

 To pivot a Camera using the keyboard, tap the arrow keys 
(without holding down ALT) while the Shaded view or the shaded 
pane of Quad view is active. 
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Notes: 

 This is one of the two ways in which a Flying Camera can be modified 
at a user-defined node—dollying is the other.

 Flying Cameras cannot be pivoted at nodes where Behaviour was set 
to Follow Path or Follow Target. In cases where something is 
“interfering with the shot” and the Flying Camera at such a node 
must be pivoted, simply change the Behaviour at that node to user 
defined—the Camera’s current position and orientation will not be 
altered by the Behaviour change.

Dolly
Dollying the Camera alters its own position and its target’s position at the 
same time. This control applies to World, Standard and Flying Cameras 
(at user-defined nodes).

 To dolly a Camera up, down, left or right using the mouse, 
hold down CTRL and click-and-drag with the left mouse button in the 
Shaded view or the shaded pane of Quad view. 

 To dolly a Camera in or out using the mouse, hold down CTRL 
and spin the mouse wheel up or down while the Shaded view or the 
shaded pane of Quad view is active.

 To dolly a Camera using the keyboard, hold down CTRL and tap 
the arrow keys while the Shaded view or the Shaded pane of Quad 
view is active.

 To dolly a Camera in or out using the keyboard, hold down CTRL 
and tap the Page Up or Page Down keys while the Shaded view or the 
shaded pane of Quad view is active.

Important: Dollying a Flying Camera will physically alter the shape of its 
Camera Path.

Notes: 

 This is the second of two ways in which a Flying Camera can be 
modified at a user-defined node—pivoting is the other.

 Flying Cameras cannot be dollied at nodes where Behaviour was set 
to Follow Path or Follow Target. In cases where something is 
“interfering with the shot” and the Flying Camera at such a node 
must be dollied, simply change the Behaviour at that node to user 
defined—the Camera’s current position and orientation will not be 
altered by the Behaviour change.

Roll
Rolling the Camera causes it to tilt left or right so that its bottom edge is 
no longer “parallel to the ground.” This control applies to all Cameras, at 
all times.

 To roll a Camera using the mouse, click and drag left or right with 
the middle mouse button (i.e., the mouse wheel) in the Shaded view 
or in the shaded pane of Quad view.
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 To roll a Camera using the keyboard, hold down ALT and tap the 
PAGE UP or PAGE DOWN keys while the Shaded view or the shaded 
pane of Quad view is active.

Zoom
Zooming the Camera causes its field of view to increase or decrease. This 
control applies to all Cameras, at all times. 

 To zoom a Camera using the mouse, spin the mouse wheel up or 
down while the Shaded view or the shaded pane of Quad view is 
active.

 To zoom a Camera using the keyboard, tap the PAGE UP or PAGE 
DOWN keys while the Shaded view or the shaded pane of Quad view 
is active.

Mouse Actions

Action Traditional WYSIWYG Other 3D Applications

Select a point With Selection Mode 
On, Left Mouse click

Always (i.e. 
permanent Selection 
Mode On), Left Mouse 
click

Selection box With Selection Mode 
On, Left Mouse click 
and drag; on Left 
Mouse button Up

Always (i.e. 
permanent Selection 
Mode On), Left Mouse 
click and drag; on Left 
Mouse button Up

Move camera along 
plane defined by 
initial camera axis as 
normal; target 
follows translation of 
camera

Ctrl+Left Mouse drag/
Right-click held during 
Left Mouse drag*

Middle Mouse drag*

Move camera around 
sphere with camera 
target at its center, 
target is fixed

Left Mouse drag* Right Mouse drag*

Pan camera along 
camera axis; target 
is fixed

Ctrl+Alt+Scroll Scroll

Pan camera and 
target along camera 
axis maintain 
distance between 
them

Ctrl+Scroll Ctrl+Scroll
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*Affected by View Option, “Pan tool moves objects”.

Keyboard Actions

Change Field of View Scroll Alt+Scroll

Fine control modifier Shift Shift

Roll Camera Middle Mouse drag Ctrl+Alt keyboard 
button+Mouse Right 
button pressed, and 
dragged

Right-click menu Right Mouse button 
Down

Right Mouse button Up 
if and only if no drag 
occurred between 
Mouse Down

Camera pitch and 
yaw; camera axis 
rotates; camera 
target moves but 
maintains distance

Alt+Left Mouse drag* Alt+Right Mouse drag*

Action Traditional WYSIWYG Other 3D Applications

Field of View Page Up/Page Down 
(unmodified)

Always (i.e. 
permanent Selection 
Mode On), Left Mouse 
click

Pan camera and 
target along camera 
axis

Ctrl+Page Up/Page 
Down

Always (i.e. 
permanent Selection 
Mode On), Left Mouse 
click and drag; on Left 
Mouse button Up

Roll Camera Alt+Page Up/Page 
Down

Ctrl+Alt+Page Up/
Page Down

Pan camera only 
along camera axis; 
target is fixed

Ctrl+Alt+Page Up/
Page Down

Page Up/Page Down

Camera pitch and 
yaw

Arrow Keys 
(unmodified)

Alt+Arrow Keys

Move camera along 
plane

Ctrl+Arrow Keys Ctrl+Arrow Keys

Move camera around 
sphere

Alt+Arrow Keys Arrow Keys

Action Traditional WYSIWYG Other 3D Applications
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Creating a camera from shaded view

If you have set up a “perfect shot” in the shaded view, you can quickly 
and easily save the view to a camera. For more information on cameras, 
see “Drawing cameras”.

To create a camera from shaded view

1 In the shaded view, use your mouse to arrange the view that you 
want to see.

2 Once you are satisfied with the viewpoint, right-click on the shaded 
view and select Save View as New Camera.
Tip: Alternately, on the Camera toolbar, you can click the Save View as 
New Camera icon. 

3 In the window that appears, type a name for the new camera, and 
then click OK.
Result: The camera is now available from the Current Camera drop-
down list on the Camera toolbar.

Creating an image from shaded view

When you have positioned the camera in shaded view, you can export 
the view as an image stored in your computer.

Fine control modifier Shift Shift

 The Save View as New Camera button.

Action Traditional WYSIWYG Other 3D Applications
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To export an image from shaded view

1 Right-click in the shaded view and select Export to Image.

Result: The Specify Image Dimensions window appears.

Note: The maximum resolution of an image for export is 8192 x 
4096 pixels if WYSIWYG detects the user’s computer video card has 
enough Video Memory to support a large panorama image.

2 Use the appropriate boxes to adjust the height and width of the 
image. 
Note: The height and width correspond to the current dimensions of 
the shaded view.

3 Select the Lock Aspect Ratio checkbox to lock the aspect ratio of the 
dimension. Type the new value in the Aspect Ratio box to change the 
aspect ratio.

4 In the Panorama Images section, select the Export Panorama checkbox 
to export a panoramic image of your Shaded View and enable the 
projection options.

5 Select Spherical Projection to export the panoramic image as a 
Spherical image showing up to a full 360 degrees camera view that 
includes top and bottom.
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Or select Cylindrical Projection to export the panoramic image as a 
Cylindrical image showing up to a full 360 degrees camera view of 
the sides only.

6 Click the Resolution drop-down list of the selected option to set the 
image display quality in pixels.

7 In the Field Of View field, type the maximum panoramic angle for the 
image.

8 Select the Open file location after export checkbox to launch the 
exported file after saving.

9 Click OK.
10 Select a file name, location, and file type, and then click Save.

Notes: 

 A file name template can be specified in Shaded View Export Options in 
the File Options tab of the Application Options window.

 Alternately, a file name is automatically assigned using smart 
variables, which is also defined in Shaded View Export Options in the File 
Options tab in the Application Options window. See “File Options tab”.

Modifying shaded views

The properties of a shaded view affect the view point, fixture beam 
quality, and ambient light. These settings are modified in the View 
Options.
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To modify a shaded view

1 In Shaded view, from the Options menu, choose View Options.

Result: The View Options window appears.

Tip: You can also use the View Options tool on the Standard toolbar to 
open the view options.

2 Modify options as desired.
3 Click OK.

 The View Options button.
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General tab
Options on the General tab affect the scene that is displayed in the 
Shaded view.

 Scene
 Follow Current Scene: Select this checkbox to use the scene that is 

displayed in the drop-down list on the Scene toolbar. Clear the 
checkbox, and then select the desired scene from the Scene drop-
down list. To learn more about scenes, refer to “Scenes”.
Tip: You can also change the current scene at any time by using 
the Scene toolbar.

 Shaded View Profile: Previously created Shaded View Profiles can be 
enabled from the drop-down list. See “Shaded view profile” for more 
information.

 View Styles: These options allow you to define how the Shaded 
view appears.
Note: These options do not impact the Shaded view performance.
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 Object Bounding Boxes: Select this option to show green bounding 
boxes around all objects in the scene. This view style was designed 
to be used in conjunction with the Consolidated Mesh feature (for 
details see “Consolidated mesh”) and enables you to visually 
analyze an object’s complexity.

 Disabled Textures: Select this option to hide (not remove) all 
textures used in a scene. This option is useful when verifying why 
a particular texture doesn’t seem to sit properly on an object and 
you want to check the underlying geometry for anomalies. 

 Wireframe Geometry: Select this option to display all objects in a 
scene (except beams) as wireframe outlines instead of solids. This 
feature helps you analyze the complexity of a scene so you can 
alter objects as necessary to speed up rendering times and 
minimize file size. For example, when you see complex objects in 
your file (those shown with a high-density wireframe), you can 
optimize them by reducing their polygon counts, either with the 
Consolidated Mesh feature or by re-importing a less complex 
version.

 Simulation Information: These options allow you to define how 
simulation information is presented. 
 View Statistics: Select this option to see information about the scene 

in the upper-left corner of the Shaded view. Note that enabling this 
view style will not modify the look of the scene. The information 
displayed is based on the layers and/or scene that are enabled. 
The following statistics are displayed:
 FPS: Shows the framerate (frames per second) as the Shaded 

view is altered by moving the image with your mouse (which 
affects the fixtures in your file), changing Looks in Design 
mode, or by incoming DMX in Live mode. Note that when the 
Shaded view is static (as it is most of the time), the FPS field 
displays “n/a”.

 Number of Objects: Provides information about the total number 
of visible objects.

 Number of Beams: Displays the number of beams currently 
appearing in the Shaded View. Note that it is normal for the 
number of beams to be different from the number of fixtures. 
For example, a three-cell Cyc fixture will count as a single 
fixture, but when all three cells are on, the number of beams 
will read “3”.

 Number of Glowing Screens: Displays the number of screens and 
LED walls currently appearing in the Shaded View.

 View Complexity: Displays information about the complexity of 
the Shaded view. The four complexity levels - low, medium, 
high, and very high are meant to help you understand how 
complex the current scene is. When the complexity level is 
high or very high, it is strongly recommended that you 
consider optimizing the file. For example, you could use the 
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Consolidate Mesh feature to reduce the number of polygons in 
a highly-detailed model. See “Consolidated mesh”.

 Camera Information: Select this option to view information in Shaded 
view about the Cameras that you have drawn.

 Performance Graph: Select this option to view a performance graph 
in Shaded view.

 Visual References: These options allow you to define how visual 
references are presented. 
 Wireframe Selection Bounding Box: Select this checkbox to highlight 

fixtures selected in Wireframe view when the view is switched to 
Shaded view.

 World Grid: Select this checkbox to show the World Grid in Shaded 
views.

 World Axis: Select this checkbox to show the World Axis in Shaded 
views.

 Gyroscope: Select this checkbox to show the Gyroscope in Shaded 
views. The Gyroscope allows for continuous orientation monitoring 
while moving around in Shaded view. 

 Fixture Tooltips: Select this checkbox to display the specific 
information about a fixture when you hover over it in Shaded view.
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Simulation tab
Options on the Simulation tab affect the view point, beam quality, and 
ambient light levels.

 Ambient Light: Use the slider to increase or decrease the amount of 
ambient light level shown in the shaded view. The percent box 
indicates the degree of ambient light you have chosen. 

 Ambient Color: Modifies the color of the ambient light. For example, 
use this feature if you'd like the Ambient light in your file tinted 
yellow or blue to match the type of house lighting in your venue. By 
default, the Ambient Color is set to white.

 Background Color: Modifies the background color used in the shaded 
view. This color is visible when you zoom far enough away that you 
can see beyond the venue. 

 Quality: Controls the degree to which you want to emphasize beam 
quality over performance.
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 Mode: Choose one of the following beam simulation modes. Note 
that when you select this value, and then choose the beam control 
options, you will automatically see the results in the Shaded view, 
enabling you to adjust them as necessary before you click OK to 
save your changes:
 Enhanced: Enhanced is the default beam mode. Select to 

enable enhanced beam control options affecting beam quality. 

 Volumetric: This mode delivers higher quality visualization of 
beams than enhanced beams. Improved lens flair effects and 
beam throws are just some of the noticeable improvements. 
Due to the required system resources need to run Volumetric 
beams, system performance may be effected depending on 
system running WYSIWYG. 
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Note: Deferred Rendering is required to run Volumetric Beams. If 
this option is not available, it means the graphics card on your 
computer does not support Volumetric beams.
 Detail: Use the slider to increase or decrease the level of details 

displayed in Volumetric mode. An increase in details will result in a 
decrease in performance. The default detail setting is  0.                                                                      
Note: For most users, an increase in detail will not be noticeable, 
except in certain camera positions and situations. 

An example of a scene using Enhanced Beams in Shaded View.

An example of a scene using Volumetric Beams in Shaded View.
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 Beam: Lower beam quality affects the beams’ footprint, sometimes 
making them appear blurry. While it is recommended that this 
value be set to High, if you notice a reduction in performance, 
particularly when viewing a complex scene with many moving 
lights, you can increase performance by lowering the quality to 
Medium or Low. Note that if you find it necessary to use Low quality 
for acceptable performance, it is recommended that you upgrade 
to a more powerful system.

 Enhance Projected Video: This option is available only when High 
Beam Quality is selected. It should only be used when video is 
being projected, not when video is being used on a Screen, 
Surface, Object, or LED Wall. Enabling this feature decreases 
Shaded View performance, but increases the visual quality of the 
footprint (video) created by the projector. 

 Brightness: Use the Brightness sliders (or type a value in the 
corresponding box) to control the visual brightness of beams, 
footprints, and lens flares. 
Every fixture/bulb in the WYSIWYG library has “brightness value” 
defined in its properties. The “brightness value” of a fixture/bulb is 
the relative intensities between light beams from different fixtures 
based on their published photometric data.
The Beam, Lens Flare and Footprint sliders will alter all beams relatively 
in comparison to all the fixture beams in the scene. For example, you 
can see this when a bright fixture is hung beside a fixture that is less 
bright. (i.e. 10” Fresnel with 2KW bulb is hung beside a 6” Fresnel 
with 500W bulb, both at full intensity). The relative brightness 
between both fixtures matches the difference in intensity from both 
fixtures with reference to their published photometric data.
A scene with many lights may be better visualized when some of the 
beams’ components are less bright. Note that brightness settings 
affect all beams in the scene equally and are for aesthetic purposes 
only; the sliders are not connected to the fixtures’ intensity. 
The Brightness sliders enable you to balance the brightness values for 
different scenes, each scene varying based on the density and 
intensity of its fixtures. These values are saved into the scene file 
and will, therefore, change when new scenes are loaded.
Note: The default value of 50 is the baseline value generated by the 
values from the library definitions. If the scene does not show any 
beams or footprints, ensure that none of the brightness sliders is set 
to zero. 
 Beam: Controls the brightness of the beam cone. A scene with 

many overlapping beam cones will tend to saturate, which can be 
reduced by decreasing the brightness.

 Footprint: Controls the brightness of the beam footprint. A scene 
with many overlapping footprints will tend to saturated, which can 
be reduced by decreasing the brightness.
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 Lens Flare: Controls the brightness of the lens flare, which is the 
dominant visual effect when the camera is aimed directly into a 
fixture’s lens. In addition, when you are behind a fixture that is 
directed away from the camera, the lens flare component is used 
to create a simulated beam cone.

 Beam Exposure: Use this slider to adjust the overall exposure of the 
beams. The default value is 50 which is the baseline value generated 
by the values from the library definitions. Increasing the exposure 
causes all beams in the scene to become brighter exponentially. This 
may be required if you feel all beams seem too dim. Decreasing the 
exposure causes all beams in the scene to become dimmer 
exponentially. This may be required if you feel all beams seem too 
bright/saturated. If you wish to correct the relative brightness of one 
fixture, it is best to adjust its beam brightness by going into Fixture's 
properties and using the Beam Intensity Multiplier on the Beam Options 
tab.
Note: Beam Exposure works similar to the exposure control of a 
camera but the values are not based on the F-stop. The fixture’s 
output is affected relatively; and beam, footprint and flare are all 
affected at the same time. For example, when you adjust the 
exposure of two Fresnels at full intensity - a 10” and a 6”:
 When increasing, the beam, footprint and flare of the 10” fresnel 

stops getting brighter at a value of about 95, but the value from 
the 6” fresnel goes up to 100.

 When decreasing, the 6” fresnel stops getting dimmer at around 
20, but the value from the 10” fresnel goes down to 0.

 Scattering: Use the Scattering slider to enable and control the 
simulation of the light energy that deflects and scatters when 
passing through the imperfect medium of air filled with various 
particles/molecules. Light is deflected off of its straight path and 
scatters in many directions. 
Use the Scattering slider to increase or decrease the scattering effect. 
When Scattering is set to 0, no scattering effect is applied to the light 
beam from a selected fixture. 
When Scattering is enabled, the intensity of the light beam from a 
fixture appears to vary when viewed from different angles.
Note: By default, Scattering is only available when the Simulation 
Quality is set to Volumetric mode.

 Shadows
 Enable: Select Enable checkbox to display shadows. Turning 

Shadows on creates a more realistic Shaded View, but adds extra 
complexity, which may also slow down performance as more 
calculations are required.

 Soft Shadows: Select Soft Shadows checkbox to display higher quality 
soft shadows. Use this option to soften the shadows for best visual 
quality, for example when capturing a screenshot of a look. 

Note: Enabling Soft shadows while running cues in Live mode is not 
recommended, as it will drastically slow down performance.
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 Alpha Beam Shadows
 Enable: Alpha Beam Shadows in Shaded View is enabled when 

Volumetric Beam quality is selected. Select Enable checkbox to 
display Alpha Beam Shadows.

 Num. Levels: Click this drop-down list to select the number of levels 
to be calculated for Alpha Beam Shadows. 
For example, if you select 2 from the drop-down list, a beam’s 
color and intensity will be calculated based on alpha levels only 
that pass through 2 surfaces, and any additional surfaces with 
alpha levels will be ignored as the beam will just pass through 
them.

Note: Each Alpha shadow level supported for this feature requires 
additional video memory from your graphics card, and can impact 
performance, depending on your scene and computer hardware. 

 Footprint 
 Hot Spot: Select Hot Spot checkbox to display hot spots. Hot spots 

are usually noticeable with conventional fixtures, which have 
lenses that refract the beam non-uniformly; the center of the 
beam is bright and it gradually drops off moving outward to the 
edge of the beam. Conversely, the majority of automated fixtures 
have a different type of lens that corrects the beam refraction to 
have a more uniform footprint.

 Footprint Focus: Select Footprint Focus checkbox to enable footprint 
focus functionality. Enable this option to visualize the footprint 
focus, otherwise, fixtures for which you have defined footprint 
focus will not display. This toggle also offers an easy way to turn 
off the display of the footprint focus when not needed (for a 
performance boost) without losing the footprint focus settings of 
the fixtures.

 Focus Lines: Select Focus Lines checkbox to enable the display focus 
lines, when the Footprint Focus option is enabled for conventional 
fixtures in CAD mode (fixture's Properties) and/or automated 
fixtures in Design mode (Footprint Designer tool).

 Materials 
 Enable: Select Enable checkbox to enable materials functionality. 

When a material is applied to an object, it affects how the object 
interacts with light. This interaction is visible in shaded view and in 
rendered images from the WYSIWYG Render Wizard.

 Reflections: Select Reflections checkbox display reflections on 
materials. When a reflection is applied to an object, it will reflect 
light depending on the material settings. This interaction is visible 
in shaded view and in rendered images from the WYSIWYG Render 
Wizard.

 Screen/LED Wall Glow: Click Enable checkbox to toggle a glow that will 
emit from screens and LED walls, increasing the realism of 
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visualizations. When enabled, use this slider to adjust the intensity of 
the glow.

An example of a LED Wall with Glow enabled in Shaded View.
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Performance
Options on the Performance tab are features that let you manage between 
system efficiency and visual quality. 

 Auto-Adjust FPS: When enabled WYSIWYG is granted permission 
to attempt to maintain a consistent frames per second when 
visualizing. WYSIWYG achieves this by reducing the quality of the 
Shaded View image to increase performance.
 Enable: Will enable the Auto-Adjust FPS function when the 

checkbox is selected.
 Target FPS: The desired amount of frames per second which 

WYSIWYG will attempt to maintain.
 Min. Quality: The minimum level of visualization quality which 

WYSIWYG will attempt to maintain.
Note: The Auto-Adjust FPS option only works with Volumetric 
Beams. With Enhanced Beams, Auto-Adjust FPS is set to off. In the 
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View Statistics, this is displayed with Virtual Resolution being set to 
N/A.
Note: When you turn Auto-Adjust FPS on, you are permitting 
WYSIWYG to vary the Shaded View resolution automatically - as 
needed - to deliver the highest frame rate possible on your computer.

 Performance: You have the option of improving system 
performance by adjusting the following two object types:
 Draw Fixtures: When selected, the fixture body will be drawn in 

shaded view. When deselected, the fixture body will not be drawn 
in shaded view, only the beam, which will reduce the amount of 
geometry being drawn in shaded views and offer slight 
performance improvements.

 Enhance LED Walls: Select to improve the visual appearance of LED 
Walls. If there are many large LED Walls in the document, then 
performance may decrease as a result of having enabled this 
option; turn this option off and check whether performance 
improves. 

 Show Footprints/Shadows: You have the option to show 
footprints and shadows in the Shaded view for one or more of the 
following two object types:
 Hang Structures: This option controls whether hang structures like 

pipes and truss will cast shadows and receive footprints in the 
Shaded view. It is extremely useful for checking effects or looks 
such as truss warmers, but it is recommended to keep this option 
disabled in order to increase performance.
 All: Select this radio button to display in Shaded view the 

footprints/shadows of all the hang structures in your drawing.

 Enabled Only: The footprint/shadow of a hang structure object 
appears in Shaded view only when the Cast Shadow option in 
the Appearance tab of its Properties window is enabled. Select 
this radio button to display in Shaded view only the footprints/
shadows of hang structures with enabled Cast Shadow feature.

 Fixture Bodies: This option controls whether the bodies of fixtures 
will cast shadows and receive footprints. This feature is useful 
when checking to see if certain fixtures are blocking the beams of 
other fixtures, but it is recommended to keep this option disabled 
in order to increase performance.
 All: Select this radio button to display in Shaded view the 

footprints/shadows of all the fixtures in your drawing.

 Enabled Only: The footprint/shadow of a fixture appears in 
Shaded view only when the Cast Shadow option is enabled in 
the Appearance tab of its Properties window. Select this radio 
button to display in Shaded view only the footprints/shadows 
of fixtures with enabled Cast Shadow feature.

By default, the Cast Shadow option is disabled on a hang structure and a 
fixture when created in your drawing; on the other hand, all objects have 
the Cast Shadow option enabled by default.
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Visual Effects
Options on the Visual Effects tab are visual effects that can be added to 
enhance visualization.
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 Ambient Occlusion: Varies the ambient light contribution to the scene 
by using localized geometric visibility. The amount of ambient light 
can be controlled by adjusting the slider.

 Global Illumination: Simulates the indirect illumination of light 
bouncing off of geometric surfaces onto other surfaces. 
 Method: Determines how object are illuminated. Approximation 

Method 1 illuminates objects from all directions. Approximation 
Method 2 illuminates only the visible sides of an object.

 Range: Determines how far illumination will travel from objects.
 Brightness: Determines how luminous objects will appear.
 Quality: Determines the quality of light illuminated from the object.

A visualization with Ambient 
Occlusion disabled.

The same visualization with 
Ambient Occlusion enabled. 
There is now mini shadows on 
the stairs.

A visualization with Global 
Illumination disabled.

The same visualization with 
Global Illumination feature 
enabled. Additional light 
(illumination) on the stairs 
behind the singer.
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 Source Disc Bloom: Creates a halo of light around a fixture's aperture 
to simulate light diffusion for very bright sources. The size and 
brightness of the Disc Bloom can be adjusted by moving the slider.

Environment tab
Options on the Environmental tab control non-uniform atmospheric effects 
in beams. 

A visualization with Source Disc 
Bloom disabled.

A visualization with Source Disc 
Bloom enabled. There appears a 
slight bloom or halo of blue light 
around the Fixture’s Source Disc
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 Smoke Simulation: Beams can display non-uniform atmospheric 
effects in their beam cones. 
 Smoke Density: Select Smoke Density checkbox to display a non-

uniform smoke suspension in the beam cone, which also enables 
Animate Smoke and Turbulence. Use the slider to change the density 
of the smoke. 

 Animate Smoke: Select Animate Smoke checkbox to make the non-
uniform smoke move, and then specify the direction and speed 
using the X, Y, Z sliders. When the slider is in the middle at 0, 
smoke will not be animated in that axis. Move the slider off 0 to 
animate the smoke in that direction. The further away the slider is 
from 0, the faster the smoke will travel. (For example, to make the 
suspended smoke move in an upward direction to simulate a rising 
smoke effect, move the Z slider to the positive (right) side of 0, 
leaving the X and Y sliders at 0. To increase the speed at which the 
smoke is rising, move the slider further along on the positive 
scale.)

 Turbulence: Select Turbulence checkbox to display atmospheric 
smoke effects and low-lying ground smoke or fog effects with 
irregular and turbulent flow.
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Turbulence is enabled when Volumetric Mode is selected in the Qual-
ity section in the Simulation tab of the View Options window. 
Turbulence is disabled when Enhanced Mode is selected in the Qual-
ity section in the Simulation tab of the View Options window.

 Ground Smoke
 Enable Ground Smoke: Select Enable Ground Smoke checkbox to 

display low-lying ground smoke or fog effect, and enable its 
properties for changes.

 Base Height: Specify the height of the horizontal bottom plane 
of the ground smoke from the floor of the drawing where Z 
coordinate is at 0. 

 Height: Specify maximum height of the ground smoke when it 
rises from its horizontal bottom base.

 Variance: Use the slider to increase or decrease the maximum 
peaks and troughs of the ground smoke turbulence. You may 
type the value in the adjacent box. The ground smoke will be 
displayed without turbulence if the slider is set to the 
minimum at 0. The ground smoke turbulence will be displayed 
with maximum peaks and troughs when the slider is set to the 
maximum at 100. 

 Intensity: Use the slider to increase or decrease the brightness 
of the ground smoke or fog. You may type the value in the 
adjacent box.
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Time of Day Lighting tab
Just as you can simulate time of day/outdoor lighting when setting up 
your renderings in the Render Wizard, you can now achieve the same 
effect in the Shaded view in real time for all events that take place 
outside. Just like when you are setting up a rendering, in order to 
achieve the correct outdoor lighting conditions in the Shaded view, you 
must define the geographical location for your event and set the direction 
North. For details, see “To draw a compass”.

 Enable Time of Day Lighting: Select this checkbox to consider outdoor 
lighting conditions in the Shaded view, and then specify the lighting 
conditions below. The Shaded view adjusts accordingly, in real time.
 Date: The date determines the position of the sun and/or moon 

and the resulting amount of light available. Type the date when 
the event will take place.

 Time: The time determines the position of the sun and/or moon 
and the resulting amount of light available. Type the time when 
the event will take place.
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 End: Select this checkbox if you want to specify an end time for the 
event, and then type the date and time in the boxes provided.

 Timeline: By defining Start and End Dates/Times, you can check 
lighting conditions between those times. Use the Timeline slider to 
adjust the current Shaded view time.

 Sky Conditions: The amount of light available determines the 
brightness of the resulting image in the Shaded view. Use the Sky 
Conditions slider to adjust the quality of light (cloudy or clear). 

 Enable soft shadow: Select this checkbox, and then use the slider to set 
the softness of shadows that are created by sunlight. The softer the 
setting, the less sharp the resulting shadow.

 Regional Settings: Click to set the geographic location of your show. 
You can either select the country and city or enter the latitude and 
longitude of the location. These settings are used in Shaded views 
and renderings that use environmental options.

Camera tab
Options on the Camera tab affect the Cameras in your file.
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 Camera: Select a camera to change the point of view. Click Reset to 
Defaults to remove any previous association with a camera and to 
display the original view point. 
Note: You can also control the camera view point with the Camera 
toolbar. For details, see “Using the camera toolbar”.

 Pan tool moves objects: Select this checkbox if you want to rotate the 
model on the target. Clear this checkbox if you want the pan tool to 
rotate the camera around the target. You can use the right, left, up, 
and down arrow keys in addition to the mouse button to pan to the 
desired location.

 Camera Path
 Follow Camera Path playback: Select this checkbox if you want to lock 

the Shaded view to the camera path’s camera view whenever the 
camera path is playing.

 Fixture FOV
 Display Information of Selected Fixture: In the Fixture POV section, 

select this checkbox to display information about the selected 
fixture at the bottom of the view. 

Note: This option becomes active when the Camera drop-down list is 
set to POV of selected fixture, and only works if one fixture is selected. 
(When multiple fixtures are selected, the camera reverts to its 
previous camera setting and no fixture information displays). 

 Camera Target
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 Display Target: In the Camera Target section, select this checkbox to 
show the focus point of the selected camera in the shaded view. 
Choose the color of the displayed target by clicking the Color box, 
and then selecting the color from the resulting palette. The target 
is visible in shaded views only. 

 Infinite Lines: In the Camera Target section, select this checkbox to 
show the camera target lines of the selected camera in the Shaded 
view, extending the camera target lines to infinity.

 Letter/Pillar Box: Select from the Color box the color for the letter or 
pillar box that will be displayed to indicate the viewing definition 
boundaries.

Fixture Attribute Details tab
Options on the Fixture Attribute Details tab affect which attributes of the 
fixture are displayed with the fixture object in Shaded view.

 Fixture Attributes: Select the attributes that you want displayed around 
the fixture symbols. To modify how the attributes are laid out, refer 
to Fixture Notation and Information Layout in “Fixture notation”.
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 Plot: Select the corresponding checkboxes in this column to display 
the selected attributes in the plot.

 Wireframe Views: Select the corresponding checkboxes in this 
column to display the attributes in the Tooltips in Wireframe view. 
Displays tooltips on the CAD item. Tooltips are the pop-up 
messages that display specific information about a fixture when 
you hover over it. Choose the information that you want to display 
in a tooltip by selecting the appropriate check boxes in the Fixture 
tooltips group box. Tooltips are often helpful when trying to locate a 
specific fixture in a plot.

 Shaded Views: Select this checkbox to display the attributes when 
you hover over a fixture in Shaded view.

Tip: Select the checkbox on the top row of the Plot or Wireframe Views 
or Shaded Views column to select all check boxes below.

 Use Document Defaults: Select this checkbox to reference the options 
selected on the Wireframe Details tab of Document Options. Clear the Use 
Document Defaults checkbox to make specific changes for the active 
view.

Beam quality color theory

The footprint technology of the beam simulation in our Shaded Views 
calculates footprints using color modulation, which is based on color 
theory. When a light beam strikes an object, some of the light is 
absorbed and some is reflected. The reflected color that the human eye 
can see is a subset of the source light spectrum that was not absorbed by 
the object.

For example, when a red light is shining on a blue riser, no light will be 
reflected back to the human eye. The blue riser absorbs all colors that 
are not blue (its own color). Since there is no blue in the red source light, 
the light is completely absorbed. This means no footprint is displayed on 
the blue riser in our visualization.
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Another scenario affected by this modulation would be a white beam 
hitting a black object. The white light contains all colors in the spectrum, 
while pure black is the total absence of color. As a result, the black object 
absorbs the entire spectrum of color and therefore reflects no light. This 
means no footprint is displayed on the black riser in our new 
visualization.

The next scenario shows two beams, a non-pure red and a non-pure 
blue, hitting a pure-green riser. The pure green riser absorbs all color 
components from the beam except for the green component and 
therefore reflects only green light. The blue beam has a bit more green in 
its spectrum than the red beam, and appears slightly brighter than the 
red beam footprint. This example also shows that the portion of the 
footprints which fall on the grey floor result in the reflected color 
matching the beam colors. Using color theory, grey which has an equal 
amount of red, green and blue would therefore absorb an equal amount 
of the beam color components as well as reflect an equal amount of 
these colors, resulting in the reflected color (footprint) being the same as 
the beam color.

Note: If you have a black stage, the footprints do not display on the 
stage because they are totally absorbed. To display footprint colors on 
black, use an unpure black or dark grey instead.

Color Temperature and Inverse Square Law

When in Shaded view, color temperature and inverse square law 
calculations are applied to all beams. These features create a greater 
degree of realism to Shaded view visualizations. 

Color temperature calculations
For beams, the color temperature calculations take into account both the 
type of bulb used in the fixture and its wattage. For example, the beam 
of a fixture with an arc bulb displays with a blue tint, while the beam of a 
fixture with a tungsten bulb displays with a yellow tint. Likewise, the 
beam from a fixture using a 1000W bulb will be brighter than the same 
fixture using a 500W bulb, but, naturally, not twice as bright.

In the graphic below, note the difference in appearance of each of the 
beams: as the wattage increases, the beam appears brighter, and as the 
bulb differs, so does the tint of the beam.
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Inverse square law calculations
The inverse square law calculations apply to beam footprints, providing a 
realistic intensity falloff that is proportional to the beam angle and 
distance from source to target. For example, the footprint of a fixture 
lighting a flat surface 20’ away appears much brighter than if the same 
fixture were lighting the same flat surface at 30’. Similarly, for zoom 
fixtures, the intensity of the footprint is automatically adjusted when the 
beam angle is changed (by zooming in or out). 

In the graphic below, note the difference in appearance of each of the 
footprints: as the beam gets narrower, the footprint appears brighter.

Shaded view profile 

Introduction
Shaded View Profiles are a feature that can be used to improve your 
workflow by making it easier to manage multiple Shaded Views and their 
settings. The Shaded View Profile contains all options of the Shaded 
View. Use the View Options to configure the Shaded View as you wish, 
and the settings will be stored in the Shaded View Profile. To store other 
combinations of Shaded View options, simply create another Shaded 
View Profile. Shaded View settings can then be easily toggled by 
selecting different Shaded View Profile shortcuts. You can also use the 
Shaded View Settings Tool to configure Shaded View options in addition 
to managing Shaded View Profiles.

Note: By default, the Shaded View Profile is set to "Default" for a new 
file. This means the same Shaded View Profile is shared amongst all 
views by default and all views are initially synchronized.
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The grey bar in CAD, Design, and Live mode displays the current Shaded 
View Profile. The grey bar can be found across the top of the Shaded 
View and will display the name of the Shaded View Profile you have 
selected. 

If you prefer not to use a Shaded View Profile, then set your Shaded View 
Profile to  "None", and the Shaded View will work like before. The "None" 
profile is individually associated to one particular Shaded View. 
WYSIWYG files saved in versions before Release 33 will have their 
Shaded View Profile set to "None".

Note: Shaded View Profile will save settings associated to the General, 
Simulation, Environment, and Time of Day tabs in the View Options. It DOES 
NOT include any options found in the Camera tab or "SCENE" properties 
controlled via the Scene toolbar.

See “Modifying shaded views” for information how to edit shaded views.

To create a new Shaded View Profile using the Navigation 
Pane

Note:  A new Shaded View Profile sets all options to default settings.
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1 In the Navigation Pane, select Shaded View Profiles.
2 In the Shaded View Profiles shortcut area, right-click and select New 

Shaded View Profile.

Result: The Enter new shortcut name window appears.

3 In the Enter new shortcut name window, enter a name for the new 
Shaded View Profile.

4 Click OK.
Result: The new Shaded View Profile is created.

Note: Alternatively, you can create a new Shaded View Profile using the 
Shaded View Settings Tool.
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To clone an existing Shaded View Profile using the 
Navigation Pane

1 In the Navigation Pane, select Shaded View Profiles.
2 In the Shaded View Profiles shortcut area, right-click the shortcut of a 

profile you want to clone and select Clone Shortcut.

Result: The Enter new Shaded View Profile name window appears.

3 In the Enter new Shaded View Profile name window, enter a name for the 
new Shaded View Profile.

4 Click OK.
Result: A new Shaded View Profile is created, retaining all the 
settings of the original.

Note: Alternatively, you can clone a Shaded View Profile using the Shaded 
View Settings Tool.
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To delete a Shaded View Profile using the Navigation Pane

1 In the Navigation Pane, select Shaded View Profiles.
2 In the Shaded View Profiles shortcut area, right-click the shortcut of a 

profile you want to delete and select Delete.

Result: A dialog box appears, asking if you really want to delete the 
profile.

3 Click OK.
Result: The Shaded View Profile is deleted.

Note: Alternatively, you can delete a Shaded View Profile using the 
Shaded View Settings Tool.

Shaded view settings tool
The Shaded View Settings tool is a feature that allows you to further 
improve workflow using Shaded View Profiles. The changes made in this 
Tool update the Shaded View Options and vice versa. This tool can be open 
at all times and offers quick access to some of the more popular Shaded 
View settings. Settings available in the Shaded View Settings Tool are:

 Mode
 Quality
 Detail
 Materials
 Glow
 Reflections
 Smoke
 Ambient Light
 Beam
 Footprint
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 Lens Flare
 Beam Exposure

To create a new Shaded View Profile using the Shaded View 
Settings Tool

1 From the View menu choose Shaded View Settings Tool.

Result: The Shaded View Settings window appears.

2 In the Shaded View Settings window, click New.
Result: The Enter new shortcut name window appears.

3 In the Enter new shortcut name window, enter a name for the new 
Shaded View Profile.
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4 Click OK.
Result: The Shaded View Profile is created. You can edit the settings 
of the profile from the Shaded View Settings window, or by going to the 
Options > View Options menu. See “Modifying shaded views” for more 
information.

Note: Alternatively, you can create a new shaded view profile using the 
Navigation Pane.

To clone an existing Shaded View Profile using the Shaded 
View Settings Tool

1 From the View menu choose Shaded View Settings Tool.

Result: The Shaded View Settings window appears.

2 From the Shaded View Profile drop-down list, select the Shaded View 
Profile you want to clone.

3 Click Clone.
Result: The Enter new Shaded View Profile name window appears.

4 In the Enter new Shaded Profile View name window, enter a name for the 
cloned Shaded View Profile.

5 Click OK
Result: A new shaded view profile is created, retaining all the 
settings of the original shaded view profile.

Note: Alternatively, you can clone a new shaded view profile using the 
Navigation Pane.

To delete a Shaded View Profile using the Shaded View 
Settings Tool

1 From the View menu choose Shaded View Settings Tool.

Result: The Shaded View Settings window appears.

2 From the Shaded View Profile drop-down list, select the shaded view 
profile you want to delete.

3 Click Delete.
Result: A dialog box appears, asking if you really want to delete the 
profile.

4 Click OK.
Result: The shaded view profile will be deleted.

Note: Alternatively, you can delete a shaded view profile using the 
Navigation Pane.
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To select a Shaded View Profile 

1 In the Navigation Pane, select Shaded View Profiles.
2 In the Shaded View Profiles shortcut area, click the shortcut of a profile 

you want to select.
3 The selected shaded view profile is enabled. 

OR

1 From the View menu choose Shaded View Settings Tool.

Result: The Shaded View Settings window appears.

2 From the Shaded View Profile drop-down list, select the shaded view 
profile you want to use.
Result: The shaded view profile is enabled.
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Chapter  5

Managing your WYSIWYG 
document

This chapter provides information on how to work with your 
WYSIWYG document.

In this chapter
File menu 147

Options menu 161

WYSIWYG Viewer 197
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File menu

Introduction

The File menu contains the basic commands required to manipulate your 
WYSIWYG document.

The File menu is the same in all the modes. 

New command

The New command creates a new show document. If another show 
document is currently open, you will be prompted to save changes to 
that document before a new untitled file is created. Only one show 
document may be open at a time.

To create a new document

From the File menu, choose New.

Tip: You can also use the New tool on the Standard toolbar. 

New Project command

The New Project command creates a new project folder with the new 
show document (.wyg file) and all its associated files automatically 
stored within the My Projects folder, or you may specify a different folder 
path for the new project folder.

To create a new project

1 From the File menu, choose New Project.

2 Type the name of the new project in the Create New Project dialog box.
Tip: You can also specify the path and location to which you will save 
the project folder, in the Location cell. 

3 Click OK.

 The New button.
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Open command

The Open command opens a previously created show document. If 
another show document is currently open, you will be prompted to save 
changes to that document before another show document is opened. 
Only one show document may be open at a time.

To open an existing document

1 From the File menu, choose Open.

2 Select the file, and then click Open.
You can open the following file types:

 WYSIWYG files (.wyg)
 WYSIWYG template (.wyt)
 Vivien files (.vvn)
 Vivien template files (.vvt)
 WYSIWYG backup files (.bak)
 Wysiwygv2 files (.wys)
 DWG files (.dwg)
 DXF files (.dxf)
 LW2 files (.lw2)
 SketchUp files (.skp)
 Wavefront (.obj)
 Collada (.dae)
 Filmbox (.fbx)
 3D Studio (.3ds)

Open Project command

The Open Project command opens a previously created project folder 
which contains the saved show document with all its associated files.

To open an existing project

From the File menu, choose Open Project.

Result: The My Projects folder opens to display the stored projects.

DWG/DXF export

This command exports the current show document to a DWG or DXF 
formatted file type. DWG and DXF formats are used to transfer 
documents to AutoCAD or other compatible drafting applications. 
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To export to DWG or DXF format

For details, see “To export to DWG/DXF in 2D”.

Save command

The Save command saves the open document to the same file name and 
location (folder, disk, and so on) under which it was previously saved. If 
you are saving the document for the first time, this command will 
perform the Save As function.

To save your document

From the File menu, choose Save.

Tip: You can also use the Save tool on the Standard toolbar. 

Save As command

The Save As command is used to save the current document to a new file 
name, a new file type, or new destination, such as an external hard 
drive. 

To save the current document 

1 From the File menu, choose Save As.

2 In the dialog box that opens, browse to the location where you want 
to save the file. Ensure that the destination appears in the Save in 
box.

3 In the File name box, type a name for the file.
4 In the Save as type box, choose the saved file type. There are a 

number of choices available. 
5 Click Save.

Note: WYSIWYG allows you to save an object or group of objects 
contained within your document as a separate file.

 The Save button.
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To save an object

1 Ensure the object(s) to be saved are selected.

2 From the File menu, choose Save As.
Result: The Save As dialog box appears.

3 Click Full Document to save the current document to a new file name, 
file type, or new destination. You are prompted to enter the 
destination and file name of the file.

4 Click Selected Objects to save the selected object(s) as a separate 
WYSIWYG (.wyg) document. 

5 Click Use 0,0,0 as Basepoint to align the incoming drawing at 0,0,0 with 
the existing drawing. 

6 Click Select Basepoint with mouse to use the mouse to select the 
basepoint for the merge of the CAD drawings.

7 Select the Create Insertable checkbox to create an insertable from the 
object. For more information, see “Insertables”.

8 Click OK.

Save as Project command

The Save As Project command is used to save the current project folder 
to a new project folder name containing the new file, and into the new 
folder location.

To save the current project

1 From the File menu, choose Save as Project.

2 Type the new project name in the Save as Project dialog box.
Tip: You can also specify the path and location to which you will save 
the project folder, in the Location cell. 

3 Click OK.
Result: The project folder with the new name is stored in My 
Folders, or saved in your specified folder and location. 
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Package Project as Zip command

The Package Project as Zip command packs the folders in the project into 
a zip file, with the option to select which files to include, and the option 
to include the external images and video used in the file.

To package project as zip

1 From the File menu, choose Package Project as Zip.

2 Type the name of the zip file in the Package Project as Zip dialog box.
Tip: You can also specify the path and location to which you will save 
the zip package, in the Location cell. 

3 Select the checkbox to include copies of the external images and 
video files.

4 Click OK.
Result: The Project Files dialog box appears.

5 Select the files you wish to include in the package.
6 Click OK.

Result: The zip package is saved and stored in My Projects folder, or 
saved in your specified folder and location. 

To save a WYSIWYG document as a Vivien file

1 From the File menu, choose Save As.

2 In the dialog box that opens, browse to the location where you want 
to save the file. Ensure that the destination appears in the Save in 
box.

3 In the File name box, enter a name for the file.
4 In the Save as type box, choose Vivien Files (*.vvn).
5 Click Save.

Template files
The WYSIWYG Save As command lists a file type called.WYT. WYSIWYG 
template files are similar to the type of template file you may use on your 
word processor to set up fax cover sheets, memos, or letters. Once you 
have drawn your venue with all of its lighting positions and everything 
else that is common to all shows, save it as a .WYT file in the \Templates 
directory. Each time you start a new drawing, that file will be available as 
a template to start from.

You can also enter all your lighting equipment inventory into the Flight 
Case and save that as a template. When users start their drawings with 
your template, they will not have to choose from an endless list of 
fixtures but rather just what you have in stock.
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This is also the ideal option for saving your preferred working settings. 
Template files save all the shortcuts including custom reports, plots, and 
so on. However, toolbar settings are not saved in template files since 
they are saved by the application.

A list of most recently opened template files appears under the heading 
Create New Plot on the WYSIWYG welcome screen. The more... link will 
prompt you to open a template file from the WYSIWYG Templates 
directory.

To save a template file

1 In an active view, and with no objects selected, from the File menu, 
choose Save As.

2 In the dialog box that opens, browse to the location where you want 
to save the file. Ensure that the destination appears in the Save in 
box. To ensure that your template file is available on the WYSIWYG 
Welcome screen, save your file to the WYSIWYG/Templates 
directory.

3 In the File name box, type a name for the file.
4 In the Save as type box, choose WYSIWYG Template files (*.wyt). 
5 Click Save.

Save back to previous version

Starting from R41, you can save back to earlier releases of WYSIWYG for 
up to four (4) releases back of the current release. For example, from 
R41, you can save back to earlier releases R40, R39, R38 and R37.

Insertables

WYSIWYG ships with several files that contain sets of pre-configured 
objects called “Insertables”. Insertables can be merged into your current 
file and inserted as needed. WYSIWYG also allows you to create and save 
your own insertables.

Creating insertables
If a part of your file has objects that you would like to reuse again, you 
can save it as an insertable. This is similar to merging one WYSIWYG file 
into another one, but the insertable will be listed conveniently for you in 
the Insert Insertable dialog box. 
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To create insertables

1 In Wireframe view, select the object(s) you want to become an 
insertable.

Note: The object will be saved exactly as it appears in the file, with 
the same properties. 

2 From the File menu, select Insertables... > Create.
Result: The Create Insertable window appears.

 

3 In the Create Insertable window, type the name for the new insertable 
object. 

4 In the Name field, type the name for your insertable.
5 Select one of the two base point options for your insertable.

 Use 0, 0, 0 as Base point.
 Select Base point with mouse.

6 Click OK.
Result: The insertable will be saved. You can now insert it into any 
file from the Insertables... menu.
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To insert insertables into a file

1 From the File menu, select Insertables... > Inset.

Result: The Insert Insertables window appears.

2 In the Insert Insertables window, in the Insertables section, click the 
item that you want to insert.

3 In the Base Point section, select the appropriate base point option.
4 Click Add.

a. If you chose to select the base point with your mouse, click in 
your drawing to select the base point and insert the insertable.

Result: The insertable will be inserted into the file.

Purge command

Purge enables you to lower your file size by ridding the file of unused 
data such as old images, old renders, unused Layers, lighting positions, 
imported items from AutoCAD or SketchUp, and so on.
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To use the Purge command

1 Click File > Purge.

2 In the warning box that appears, click Yes to proceed with the purge.
Note: Once you purge objects from your file, the action cannot be 
undone.
Result: The Purge window appears.

3 Click to select the items that you want to purge from your file, and 
then click Purge.

Merge command

The Merge command is used to combine multiple show documents into 
one. All file types that can be opened directly by WYSIWYG can also be 
merged. Therefore, an existing WYSIWYG document can be merged with 

 other WYSIWYG documents 
 DWG/DXF files 
 Lightwright2 files
 SketchUp files

To merge WYSIWYG documents

1 Open or create the destination document. 

2 From the File menu, choose Merge.
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3 Click to select the file, and then click Open. 
4 The Merge window appears.

5 In the dialog box that opens, choose whether you want to Ignore 
Shortcuts in the file that you are merging by selecting or clearing the 
checkbox.

6 Click OK.
Result: The Merge > Basepoint window appears.

7 Click to select how you want to merge the file, and then click OK.
Result: The Layer Import window appears. This window enables you 
to rename layers instead of combining them and will display the state 
of the layer in both files.
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Tip: It is typically sufficient to accept these settings and click Finish. 
This dialog box shows you which layers don't already exist and will be 
added, and which already exist and will have objects merged into 
them. By using the drop-down menu in the Action column, you can 
rename layers instead of merging objects to your existing layers, 
which can help keep your file clean.

8 Click Finish.
9 If you chose to select the basepoint using your mouse in step 5, you 

must click on the document or enter the coordinates to set the 
basepoint.
Result: The file you selected is merged with the current file.

Note: For information on merging DWG/DXF or SketchUp documents, 
see “Merging a DWG/DXF document” and “To merge SketchUp files”.

Close command

The Close command closes the current show document and returns you 
to the Welcome window.

To close a show document

1 From the File menu, choose Close.

2 When prompted to save changes to the current show document, click 
Yes to save changes and close the document. 
Note: Click No to skip saving and close the document. Click Cancel to 
skip saving and keep the document open.

Print command

The Print command varies from mode to mode. In general, this command 
prints the active view to the selected printer. 

To print a document

From the File menu, choose Print.

Result: Based on the mode you are in, the program may print the 
document directly or it may open the following dialog box so that you can 
set printing options: 
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Considerations when printing from CAD mode

Note: While you can print from CAD mode, it is strongly recommended 
that do not do so. Instead, please create a Layout and print it from PRES 
mode. For details, see “Creating a new layout” and “To print a layout”.

The Print command opens the Print dialog box. 

This dialog box displays the printer that is used to print your WYSIWYG 
document. The printer shown is the default printer that you have set up 
in Windows. Click Setup to change the printer or printer settings. 

Select the Print to File checkbox to print your WYSIWYG document to a file 
instead of to a printer. When you print, WYSIWYG prompts you to enter a 
file name and path.

The Print command prints the active window using the options you 
specify. 

Print What options:

 Extents: prints the entire drawing.
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 View: prints the currently displayed view in the active window.
 Window: allows you to draw a window around the area you wish to 

print.
 Last Window: prints the portion contained in the last window you 

drew for a Window print. If you have not used or previewed a 
Window print yet, this option is unavailable.

Scaling options:

 Fit will print the drawing to the scale required to fill the available 
print area based on the selection in the Print What group box. When 
you select this checkbox, the drawing will print to fit.

 If the Fit checkbox is cleared, you must choose the scale from the 
drop-down list. Standard scales are displayed in this menu. If the 
scale you want to use is not displayed, choose Custom.

 When Custom is selected, you must enter the ratio. Type the ratio 
in the On Paper and Real World boxes. The value in the On Paper box 
is the scale ratio that you want to use on a paper copy of the 
document. The value in the Real World box is the “real” 
measurement for the scale ratio that you specify in the On Paper 
box. For example, you may want to use a scaling of one inch in a 
paper copy of your document. This one inch measurement 
translates to a “realistic” measurement (for example, 3 feet).

The value in the Point Size box is the size at which points are printed. 

While it is possible to print your drawing directly from the CAD mode, it is 
preferable to print plots from the Presentation mode. Presentation mode 
includes the ability to lay out your plot with multiple views, reports, 
borders, and title blocks. Refer to “Printing layouts” for more information 
about printing plots.

Print Preview command

Print Preview displays the document as it will look when printed. This 
allows you to double-check that the printed output is exactly what you 
want.

Print Setup command

The Print Setup dialog box allows you to choose the print destination, the 
page orientation and size, and paper tray (if applicable). The print 
destination may be a physical printer, or it may be a file type or fax 
program, for example. Paper size and source options will correspond to 
the printer type selected.
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Recent file shortcuts

The list of recent files at the bottom of the File menu gives you quick 
access to the last four files opened. This list will continually update as 
show documents are opened. If the file you are looking for is not on this 
list, use the Open command.

To open a recent file

1 From the File menu, choose the file you want to open.

2 If another show document is currently open, you are prompted to 
save changes to that document before another show document is 
opened. Only one show document may be open at a time.

Exit command

Use the Exit command to exit WYSIWYG. If you have made changes to 
your document but have not saved yet, you will be prompted to save 
your changes before exiting.

To exit WYSIWYG

1 From the File menu, choose Exit.

2 When prompted to save changes to the current show document, click 
Yes to save changes and exit WYSIWYG. 
Note: Click No to skip saving and exit WYSIWYG. Click Cancel to skip 
saving and not exit WYSIWYG.
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Options menu

Introduction

WYSIWYG offers you many options to customize the functionality of the 
software. You can view and set options on the Options menu.

The Options menu is the same in all the modes.

Application Options

Application Options are general settings for the WYSIWYG software and 
apply to the entire application regardless of the show file that you are 
working on. You might want to update these settings to change 
WYSIWYG’s appearance or indicate your file-saving preferences, for 
example. 

To modify the application options

1 From the Options menu, choose Application Options.

Result: The Application Options dialog box appears. 
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General tab
Options on the General tab affect the numeric separators used in 
WYSIWYG, and the properties for the Product Configuration Wizard. 

 Show WYSIWYG configuration wizard on startup: Select this checkbox if 
you want to see the Product Configuration Wizard each time you launch 
WYSIWYG. The wizard enables you to choose the level of WYSIWYG 
that you want to run (for example, it gives you the option of 
launching a standard version of WYSIWYG, such as Report or Design, 
or a network version of WYSIWYG). If you leave this checkbox 
cleared, the same level of WYSIWYG that you chose when running 
the program for the first time appears by default. 

 Participate in the Customer Experience Improvement Program (CEIP): Have 
this box checked to participate in the Customer Experience 
Improvement Program (CEIP). Participation will enable you to 
contribute to the betterment of WYSIWYG. See “Customer 
Experience Improvement Program (CEIP)” for more details.

 Region profile for new documents: The profile to be used for such items 
as units of measurement, voltage and which default lamp should be 
used in a fixture.

 Shaded View Camera Control: Click the drop-down menu and select how 
the camera is controlled in Shaded view. See “Camera Control” for 
more information.
 Traditional WYSIWYG: Select this option to use the standard 3D 

camera control in the Shaded view of WYSIWYG.
 Other 3D Applications: Select this option if you want to use the 3D 

camera control that complies with a different 3D application.
 Appearance
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 WYSIWYG Visual Theme: A WYSIWYG visual theme changes how the 
UI windows and other elements are colored. Select the desired 
theme from the list to change how WYSIWYG looks. The default 
setting is the Dark theme. 

Example images of the Light and Dark themes applied to 
WYSIWYG.
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 Toolbar Icons Size: Select from the list the size icons will appear on 
the toolbar. The default setting is Large - 24X24 pixels.

 Toolbar Icon Style - Select the style you want icons to appear as, 
either mono colored (Default - Orange) or multi colored (Colored-
highlights). 

 Ruler Style: Changes how the Ruler looks in CAD mode Wireframe 
views. Options include Classic White, View Color, and View Color with 
Border.

 Enable Instruction Tooltip: Select this checkbox to view helpful 
instruction tooltips whenever a function is performed. 

 Decimal: Select the style for separating whole numbers from 
decimals. Available options are comma and period. Note that the 
decimal separator cannot be the same as the co-ordinate 
separator. 

 Co-ordinate: Select the style you want to use to separate 
coordinates in WYSIWYG. Available options are comma, period, 
semicolon, colon, or slash. Note that the co-ordinate separator 
cannot be the same as the decimal separator.

An example of toolbars using the 
Large icon size (24 x 24 pixels).

An example of the same toolbars 
using the Small icon size (16x16 
pixels).
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File Options tab
Settings on the File Options tab affect your file saving settings. It is 
important to save your work often during your work session. WYSIWYG 
has an Auto Save function that will help to keep your data safe; however, 
it is always a good idea to get in the habit of saving your show document 
to an external disk periodically during your work session. 

 Auto Save Options
 Auto Recover: Select this checkbox to make WYSIWYG store Auto 

Recover data for the currently open file. WYSIWYG will store data at 
the interval specified in the Save every ___ minutes field. If 
WYSIWYG closes unexpectedly (such as due to a power loss), it 
may be possible to recover the file you were working on based on 
this data. See “Auto Recover function” for more information.

 Save every ___ minutes: The interval of time in which WYSIWYG will 
store Auto Recover data. 

 Enable during: Select this checkbox to enable Auto Recover while 
working in various modes and views. It is recommended that you 
keep this option disabled since it can negatively affect 
performance during simulation.

 Keep backup files: Select this checkbox to save a copy of your 
document with the “.bak” extension every time you save the file. 
The backup copy is one save behind the saved copy and is saved in 
the same folder as the original document. Each new backup copy 
replaces the previous backup copy. If the main show document 
becomes corrupted, you can open the backup file to recover your 
data. 

 Choose File Locations...: Select this option to change where Auto 
Recover and Backup Files are saved.

The default settings for these options are Auto Recover enabled with 
an interval of 10 minutes and Keep backup files enabled.
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 Document Saving
 Compress files: Select this checkbox to compress your file up to ten 

times its original size without affecting the contents of the file. 
When you select this option, files will take up less space in your 
computer's memory. You will also be able to send these 
compressed files as email attachments to your partners and clients 
with greater ease.

 Save external textures within the document: Select this checkbox if you 
want the jpeg and/or bitmap used as textures to be saved within 
your WYSIWYG document. The textures will “travel” with the 
document and will be visible regardless of the computer on which 
the document is opened.

 Document Loading
 Reload last document on startup: Select this checkbox to ensure that 

the last document that you have been working on in WYSIWYG is 
loaded automatically when you launch WYSIWYG. 

 Default to Read Only: Select this checkbox to load documents in 
read-only format. This format is helpful if you are loading someone 
else’s document and you do not want to accidentally make 
changes to it. 

 DWG Import Options
 Reset DWG import association: Click this button to reset the 

association of specific blocks in DWG files with certain pre-selected 
fixtures. When you import DWG files, one of the options is to 
associate a block that is found in a DWG file with a specific fixture. 
If you decide to remember this association for future imports, all 
blocks with that name will be imported as the chosen fixture.

 Hatch Pattern
 Hatch Pattern unit type: This setting will set a hatch pattern loaded 

from file to either Imperial or Metric.
 Shaded View Export Options: Specify a template for naming the 

exported image file. Click the Export Options button to open the Export 
Options dialog box where you can choose a file name and folder 
location for the image file you wish to export.
 Folder Location: Select the Use Current file’s Folder checkbox to select 

the active folder currently in use, or browse and select a different 
folder location.

 Image Name Template: Type the name that appears as a name 
template for all images you wish to export and save, or use smart 
variables to define the name as the template that appears for the 
image you wish to export and save.
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 Insert Smart Variable: Click to open the Smart Variables window and 
select a smart variable text from the table of smart variables that 
are listed in the Production Team Info tab in Document Options.

Result: The name is displayed in the Shaded View Export Options box 
and appears automatically as the default name for all the images for 
export.

Tip: You can use smart variables to specify a file name using 
information listed in the Production Team Info tab in the Document 
Options window. 
 Use smart variables “%Variable Name%” in the Image Name 

Template box and this information will be displayed automatically 
if stored in the Production Team Info tab. For example, type 
%Show Name% and the show name that was stored will be 
displayed.

 In addition to the smart variables in the Production Team Info, there 
are additional ones that work for Shaded View Export, such as 
%file name%, %mode%, %camera%, and %look%.

Auto Recover function
The Auto Recover function, unlike the Save Backup File function, does not 
save a .wyg file with a different extension. Instead, multiple file 
fragments are collected at the specified interval and stored into a 
temporary file. This temporary file cannot be opened by the user. The 
default path for ASV files is C:\Users\<USER>\AppData\Local\Temp (if 
not specified by the user).

WYSIWYG looks for this temporary file every time it runs. If the 
temporary file is found, WYSIWYG prompts you to load its contents.

 Should you choose to proceed, WYSIWYG will attempt to restore the 
file based on the data found in the temporary file. If successful, the 
restored file will be up-to-date as of the last instance when Auto 
Recover was activated. 

 Should you choose not to proceed, the Auto Recover data will be 
deleted permanently and you will not be able to use it to recover the 
file.

If the temporary file is not found, WYSIWYG will not display a “recovery” 
prompt and you will not be able to recover the file using this method. 

Note: Many system cleanup utilities and some antivirus software contain 
settings which automatically delete temporary files. If you do use such 
software, please ensure that it does not delete files created by 
WYSIWYG's Auto Recover function. This will prohibit the Auto Recover 
function from working.
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Auto Recover will not function when more than one instance of 
WYSIWYG is active on the same computer. Running multiple 
instances of WYSIWYG is neither recommended nor supported, and you 
will not be notified about Auto Recovery failing if you do choose to run 
multiple instances.

Toolbars tab
Options on the Toolbars tab affect which Toolbars and Status bar panes 
you want to display in WYSIWYG, and whether you want to display 
tooltips. 

You can also hide the tooltips that display information about a specific 
fixture, hang structure, or object when you hover over these objects. 
Tooltips are displayed by default. For more information on toolbars, refer 
to “Toolbars”.
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Simulation tab
Options on the Simulation tab affect the type of simulation that you want 
to use, the processing power for beam simulation, and the memory and 
processing power available for rendering.

 OpenGL Simulation
 Enable Enhanced Visualization: Clear this option if your video card 

does not support enhanced features for beam simulation. This 
option enables enhanced visualization features. If this option is not 
selected, some advanced visualization features will turn off in the 
visualization and revert to a simplified Enhanced Beam 
visualization. For more information, see “Visualization 
requirements”.
Note: Switching to another non-Shaded view, then returning back 
may be required to allow this change to take effect. 

 Enable Anti-Aliasing: Clear this option if your video card does not 
support Anti-Aliasing. Anti-Aliasing is a method of smoothing out 
and sharpening rough or jagged edges of images to produce a 
more polished result. For more information, see “Visualization 
requirements”.

 Enable Deferred Rendering: Deferred Rendering provides a 
performance boost to WYSIWYG's Shaded views. Clear to disable 
Deferred Rendering for all Shaded views whenever WYSIWYG is 
run. On some systems, deferred rendering is not supported and 
will be automatically disabled. For more information, see 
“Visualization requirements”.

 Rendering Simulation
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 Number of Cores: This box is auto-filled with the number of 
processors and/or processor cores available in your computer. It is 
used to specify the number of processors available for rendering. 
Modify this number only if you want WYSIWYG's renderer to use 
less than the total number of processors/processor cores available 
in your computer.

 Write log files: Select this checkbox to generate a log file during 
rendering. Log files are stored in the "Render" folder, which is 
located inside the "Bin" folder within the WYSIWYG installation 
folder. The typical path to this folder on some operating systems 
(Windows 7, 8, 10) is C:\ProgramData\CAST 
Software\WYSIWYG\<Release folder>.

 DMX Processing
 Number of Cores: Select the number of cores that you have available 

on your computer for DMX. Modify this number only if you upgrade 
the number of processors.

 Full Screen Mode: Select the full screen mode that will render your 
Shaded view simulation.
 Windowed Full Screen Mode: The default full screen mode of the 

Shaded View. Windowed Full Screen Mode renders all application 
windows that are open in your computer.
Tip: Shifting the viewing angle of the Shaded View in full screen 
will be smoother in Windowed Full Screen Mode, and also depend-
ing on the video hardware installed in your computer. However, 
high frequency strobing and similar effects will not be visualized 
accurately as programmed with reference to the video hardware.

 Exclusive Full Screen Mode: The regular full screen mode that renders 
only the single application (Shaded View) that is active on your 
desktop.
Tip: In this mode, a single application is rendered, and as a result, 
when you have a dedicated video card, higher performance is 
achieved, and some features such as high frequency strobing will 
be visualized accurately as programmed. However, shifting the 
viewing angle of the Shaded View in full screen may flicker 
between views or windows in Exclusive Full Screen Mode, and also 
depending on the video hardware installed in your computer.
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Additional Interfaces tab
Options on the Additional Interfaces tab affect the options that will allow 
you to monitor EDMX data directly, the pipe tape printer, as well as the 
CITP, Art-Net, sACN and RTTrPM interfaces. Direct EDMX reception allows 
WYSIWYG Perform users to monitor EDMX data without the need to 
connect to a console with the Device Manager. 

Tape Printer Interface
WYSIWYG supports EPSON POS printers with USB and Ethernet 
interfaces.

To use EPSON POS printers

Download and install the EPSON OPOS ADK driver.

Result: 

 The POS model is added to your computer.
 The POS model is added to the Device drop-down list in the Tape 

Printer Interface section of the Additional Interfaces tab in the 
Application Options window.
Note: 
 To continue using your old POS printer like before, select COM 

from the Device drop-down list and there is no need to install the 
OPOS ADK driver.

 The old POS printer will also work with the OPOS ADK driver 
installed if COM is selected from the Device drop-down list.

 Tape Printer Interface
 Device: Select from the drop-down list the tape printer model.
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 Port: Select from the drop-down list which port on your computer 
the pipe tape printer connects to.

 Baud: Select from the drop-down list the baud rate at which the 
pipe tape printer is running. The baud rate is the rate at which 
your modem can transmit and receive data.
Attention: Ensure that the Baud (rate) value set for the tape 
printer matches the communication speed set for the printer.

 Flow Control: Select from the drop-down list the method of data 
control between the pipe tape printer and the computer. Available 
options are Hardware, Software, and None. The default is 
Hardware.

 Printer DPI: Select from the drop-down list the printing density for 
the pipe tape printer, which varies from one printer to another. 
Choose from either 180 or 203.

 Use USB/Serial converter: Select this option if your pipe tape printer 
is connected through a USB/Serial converter. (This is required if a 
Serial port is not available on your computer).

 Delay buffer: Set the delay buffer (in milliseconds) for the USB/
Serial converter here. Check the documentation that came with 
your converter for details. The default is 0, which should be 
acceptable in most cases.

Note: Be sure to check in the Device Manager that these parameters 
match those of the COM port to which the Pipe Tape Printer is 
connected.

 Art-Net Interface
 Local Address: Select from the drop-down list the IP address from 

which the incoming Art-Net device data is being received by this 
computer.

 sACN Interface: For information on how to set up and use the sACN 
connectivity, see “Connecting to an sACN Device”. This option is only 
available with WYSIWYG Perform.
 Local Address: Select from the drop-down list the IP address from 

which the incoming sACN device data is being received by this 
computer.

 RTTrPM Interface: For information on how to set up and use the 
RTTrPM connectivity, see “Connecting to an RTTrPM Device”. This 
option is only available with WYSIWYG Perform.
 Local Address: Select from the drop-down list the IP address from 

which the incoming RTTrPM device data is being received by this 
computer.

 Group Address: Select from the drop-down list the IP multicast 
address from group data transmissions.

 Port: Select from the drop-down list the port used by the RTTrPM 
device connection.

 ETC Interface: This option is available only with WYSIWYG Perform.
 ETCNet2Version: Select from the drop-down list which ETCNet2 

network version you want to monitor. You can monitor only one 
version at a time.
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 Allow EDMX reception: Select this checkbox to enable direct EDMX 
reception in WYSIWYG.

 CITP Interface: This option is available only with WYSIWYG 
Perform.
 Enable CITP: Select this checkbox to enable CITP data reception, 

and then restart WYSIWYG. For more information about working 
with CITP, see “To configure a new video source for streaming 
video”.

File Locations tab
Options on the File Locations tab direct WYSIWYG where to save and find 
certain files used during operation.

 Default WYSIWYG Files Folder: This is the default path where WYSIWYG 
files are saved. Edit the path to save files to a new location.

 Auto Recover: This is the default path where WYSIWYG Auto Recover 
data is saved. Edit the path to save files to a new location. The 
default path of ASV files is C:\Users\<USER>\AppData\Local\Temp 
(if not specified by the user). See “Auto Recover function” for more 
information.

 Backup Files: This is the default path where WYSIWYG Backup Files 
are saved. Edit the path to save files to a new location

 Hatch Pattern Files: Enter the location of hatch pattern files (.pat files) 
on your computer here to add the files for use in WYSIWYG.

Document Options

Document Options are a variety of settings that control how WYSIWYG 
operates and looks. Document Options are separated into 4 sections:
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 Show/File: Settings and information specific to the current show 
file.

 User Options: Settings to configure your working preferences in 
WYSIWYG. 

 Object Settings: Setting to affect how various objects are placed or 
drawn.

 Reports: Settings to configure your working preferences while 
working in reports. Error conditions in your show file is also specified 
here.

Show/File

The Show/File section contains settings that are specific to the current 
show file, such as show name, designer, and venue. You might want to 
modify these settings when you start a new show file. 

Document Summary tab
Options on the Document Summary tab affect the document information 
(such as name of the person who created the document and the name of 
the person who last modified the document). The date stamps are not 
editable, but will track the creation and modification dates of the file.
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Production Team Info tab
The Production Team Info tab shows all of your production team’s 
information in one easy to access place. The values in this tab reflect 
those that you enter in the Production Team Information Wizard. For more 
information on this Wizard, see “Production Team Info Wizard”.
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Regional Settings tab 
Options on the Regional Settings tab set the geographic location of your 
show. You can either select the country and city or enter the latitude and 
longitude of the location. These settings are used in Shaded views and 
renderings that use environmental options.

 Custom Location: Select this checkbox to enter the latitude and 
longitude values in the Latitude and Longitude boxes, respectively. 
Clear this checkbox to select a country and city from the Country and 
City drop-down lists, respectively.

 Time Zone: After selecting Custom Location, select the time zone for 
your show. When you select a time zone, the current time as set on 
your computer is displayed in the Current Time box. The GMT value is 
also shown. 

 Currency: Select the Show Currency Symbol checkbox to show monetary 
symbols in the WYSIWYG document. Specific currency symbols can 
be chosen from the Currency Symbol drop-down list.
Note: Changing the currency symbol will only change the symbol 
shown. No conversion of currency will occur.
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 To ensure accuracy in Time of Day simulations, you must define the 
North direction in your document. For more information on defining 
the North direction, see “Drawing a compass”. 

 The values that you enter on this tab are reflected in the Render 
Wizard. For more information on the Render Wizard, refer to 
“Rendering”.

 The values that you enter on this tab are also reflected in the Shaded 
view options' Time of Day tab. For more information on the Shaded 
view options, refer to “Modifying shaded views”.

User Options

The User Options section enables you to set up your working 
preferences. You might, for example, want to specify how the snap 
operation will work or how much information will be displayed on your 
plot. 

General tab
Options on the General tab contain settings for current scenes as well as 
general display options.



178

Managing your WYSIWYG document  R42

 Current Scene: The current layer shown on the plot. The current scene 
can also be changed on the Scene toolbar.

 Display Options: General display preferences.
 Enable Tooltips: Displays tooltips on your drawing. Tooltips are the 

pop-up messages that display specific information about a fixture 
when you hover over it.

 Show Fixture notes when inserting: Select this checkbox to display the 
fixture notes when you are hanging fixtures, if applicable to the 
selected fixture.

 Show Dimension Layer selection dialog: Select this checkbox to be 
prompted to select a layer when inserting a new dimension.

 Show Linear Scale Layer/Name selection dialog: Select this checkbox to 
be prompted to select a layer when inserting a new linear scale.

 Show Motion Object Layer/Name selection dialog: Select this checkbox 
to be prompted to select a layer when inserting a new motion 
object.

 Show Bounding Box for CAD operations: Select this checkbox to enable 
a framing outline or bounding box to appear as a substitute 
placeholder to objects when scaling or rotating in CAD. Using the 
bounding box improves the performance of Scale and Rotate tools.

 Show Label Background for Rigging Point text: Select this checkbox to 
display the text of the Rigging Point object with a background in 
Wireframe views, Plots and Layouts. The label background which 
will be the color of the view’s background will cover the parts of 
objects directly below the Rigging Point text. Clear this checkbox 
to display the text label of the Rigging Point without a background, 
and the parts of the object directly below the Rigging Point text 
will not be covered.

 Prompt to put deleted fixtures in flight case: Select this checkbox to be 
prompted when you delete a fixture. You will be prompted to 
delete it completely or send it to the Flight Case. If you choose to 
send it to the Flight Case, the fixture is reserved for you in case 
you want to reinsert it.

 Layer Options: Choose how layers are displayed in the Layer 
Database and highlighted in your drawing.
 Enable Layer Groups: Select this checkbox to display the layers in the 

Layer Database as items organized in Layer groups. Clear this 
checkbox to display Layers as a list. New Layer Groups are created 
in the Layer Database window. The Layer Groups and the list of 
layers will be displayed in the Layer Database and Properties 
windows.

 Prompt to confirm Layer Group delete operation: Select this checkbox to 
be prompted to delete the selected Layer Group.

 Position “Ungrouped”: Choose where the Ungrouped Layer Group is 
displayed in the Layer Database window.
 Top: Select this option to display the ungrouped layers at the 

top of the list of layers in the Layer Database window.
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 Bottom: Select this option to display the ungrouped layers at 
the bottom of the list of layers in the Layer Database window.

 Greyscale Layer Behavior: Choose how the objects in the layer(s) will 
be displayed when the layer(s) are set to greyscale.
 Always display object custom color: When you select this option, 

objects that were set to a custom color (in Object Properties) 
will always be displayed in the custom color even if the 
object’s layer is in greyscale.

 Use greyscale layer for all objects: When you select this option, 
objects that were set to the layer color or a custom color will 
be displayed in greyscale when the layer(s) for all objects are 
in greyscale.

 Greyscale: Set the greyscale intensity for the selected layer(s).
 Layer Color Intensity: Select this option to display the layer in 

greyscale with the same intensity as that of the layer’s set 
color.

 Custom (for all): Select this option and click the box to adjust 
the greyscale intensity for all the objects in the selected 
layer(s).

 Highlight Color: Set the color for the highlighted layer.
 Layer Color: Select this option to display the highlighted layer 

with the color of the layer.

 Custom (for all): Select this option and click the color select box 
to select the color for all the objects in the highlighted layer.
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Draw Defaults tab
Options on the Draw Defaults tab affect general preferences for snap, grid, 
and units settings.

 Units: The units of measurement used in WYSIWYG. For more 
information on these units, refer to “Metric vs. Imperial”. The units 
can be toggled from metric to imperial at any time by double-clicking 
the units display on the Status bar.

 Precision: This option affects the units of drawing precision. For more 
information on these units, refer to “Coordinate notation”. Based on 
your choice for measurement units, you can choose to display the 
drawing precision in centimeters, millimeters, whole numbers, or 
fractions.

 General: Options that affect the general appearance and ability to 
work in Wireframe views.
 Background Color: The color that will be used in all wireframe views. 

Click the box to choose a different color.
 Show Crosshairs: Select this checkbox to set the cursor display to 

use cross hairs in plot views. Cross hairs are useful for lining up 
objects.

 Enable Grip Dragging: Select this checkbox to resize objects by 
clicking and dragging on their markers.
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 Show Ruler: Select this checkbox to show the rulers in drawing 
modes.

 Snap Box Size: Sets the size of the snap box that appears around 
the cursor when in snap mode. Consequently, this affects how 
close the cursor must be to the objects before the snap is applied. 

 Grid: Options that affect the drawing grid.
 Interval: Select the spacing between points on the drawing grid. 

Although the WYSIWYG drawing grid might not be visible, it exists 
in the background. The settings in this group box are important 
when using the snap to grid tool. For more information on this 
tool, refer to “Snaps”. 

 Angle: Select the angle of rotation for the drawing grid. Although 
the WYSIWYG drawing grid might not be visible, it exists in the 
background. The settings in this group box are important when 
using the snap to grid tool. For more information on this tool, refer 
to “Snaps”.

 Origin: The point of origin. For more information on the origin, refer 
to “Coordinate system and origin”.

 Show Grid: Select this checkbox if you want to add a grid to your 
wireframe view (in every view except isometric). 

 Grid Color: Click this box to choose the color that grid lines will be 
displayed as in the Wireframe view. 

 Style: You can also choose the style of the grid by selecting the 
appropriate option button. Standard creates a grid with evenly 
spaced, closed squares. Open creates a grid with open squares. 
Point creates a grid of dots. The lines in the resulting grid are 
spaced at the interval specified in the Interval box. If the interval is 
short, you may have to zoom in on your plot to see the gridlines.

 Missing Coordinate: Sets missing coordinate options. For more 
information on missing coordinates, refer to “The missing 
coordinate”.
 CAD coordinate: The missing coordinate in CAD mode.
 Focus coordinate: The missing coordinate when manually focusing 

fixtures.
 Use CAD as Focus coordinate: Select this checkbox to use the same 

missing coordinate for Focus coordinate as CAD coordinate.
 Draw Order: Arrange the order in which fixtures, hang structures, and 

objects will be drawn in your model by selecting the items and 
moving them up or down with the arrow buttons. Whichever item 
appears at the top of this box will always appear on top of the other 
items in your model. 

Example: If you leave the default order of Fixtures > Hang 
Structures > Objects, then fixtures will always appear on top of 
truss and truss will always appear on top of all other objects, 
regardless of how you arrange them via the Send to Back and/or 
Bring to Front commands. For more information on these 
commands, see “Sending to back/bringing to front”.
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 Snap: Enables or disables the snap function. For more information, 
refer to “Snaps”. Snap tools can be toggled at any time using the 
tools on the CAD Options toolbar.

Wireframe Details tab
The Wireframe Details tab affect what and how fixture, truss, text, and 
point information are displayed.

 Show on Plot: If selected, the information of the object will be 
displayed on the plot.
Tips: 
 Select the checkbox on the top row of the list to select all check 

boxes below.
 Click the arrows in the leftmost column to expand and display the 

rows with additional options.
 Fixture Symbols: Select this checkbox to always show 2D symbols in 

2D wireframe views, and then select the option below. When this 
option is disabled, fixtures will be displayed as 3D models instead of 
their 2D symbols.
 Fixture Symbol Fill: Select this checkbox to always show filled 2D 

Fixture Symbols in wireframe views.
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 Beams for Selected Fixtures: Select this checkbox to automatically turn 
on beams when selecting a fixture on your drawing. If this checkbox 
is not selected, the beam is not visible when you select a fixture.
Note: Only applies to CAD and DATA modes.

 Hang Structures: Select this checkbox to always show truss and pipes 
in wireframe views, and then select the options below.
 Truss and Pipe Thickness/Fill: Select this checkbox to always show 

filled 2D Pipe and Truss objects with chords and cross-member 
thickness.

 Truss Cross-Members: Clear this checkbox to hide truss cross 
members on your drawing to reduce the clutter or to increase the 
speed of the display. Select this checkbox to see the cross 
members.

 Truss Indicators: Truss Indicators show where the breaks in your truss 
sections are for quick assembly on site and ease-of-use for rental 
shops and other personnel who need to analyze your truss 
configuration. Select the Truss Indicators checkbox to enable this 
feature, and then select the options below. For more details on using 
this feature, see “Configuring truss indicators”.
 Linear Dividers: Select this checkbox to show the lines that appear 

parallel to the ends of your truss sections. These lines are always 
thick and can be colored any way you choose.

 Angled Dividers: Select this checkbox to show the lines that appear 
at the junction of truss sections on a 45 degree angle with the 
truss end. The Angled Section dividers can be thick or thin, and 
can be colored any way you choose.

 Library Objects: Select this checkbox to always show library objects in 
wireframe views and then select the option below.
 Library Symbols: Select this checkbox to always show library objects 

as 2D symbols in wireframe views. When this option is disabled, 
library objects will be displayed as 3D models instead of their 2D 
symbols.

 Hatching: Select this checkbox to always show hatching styles 
assigned to objects in wireframe views.

 Text Labels: Select this checkbox to always show text labels in 
wireframe views.

 Dimensions: Select this checkbox to always show dimensions in 
wireframe views.

 Focus Objects: Select this checkbox to always show focus objects in 
wireframe views.

 Motion Objects: Select this checkbox to show objects set with motion 
in wireframe views. 

 Cameras: Select this checkbox to always show Cameras in wireframe 
views.
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Fixture Attribute Details tab
The Fixtures Attribute Details tab affect what and how fixture information 
are displayed.

 Plot: If selected, the fixture information will always be displayed on 
the plot.

 Wireframe Views: If selected, the fixture information will always be 
displayed on the tooltip in Wireframe views.

 Shaded Views: If selected, the fixture information will always be 
displayed on the tooltip in Shaded views.

Select the checkbox on the top row of the Plot, or Wireframe Views, or 
Shaded Views column to select all check boxes below.

Object Settings 

The Object Settings section contains settings that affect CAD objects 
such as fixtures, hang structures and drawn objects. 
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Fixture Settings tab
Options on the Fixture Settings tab determine how detailed simulation and 
wireframe views are. These options can affect the speed of beam 
simulation in views. For more information on simulation options, refer to 
“Visualization”.

 Wireframe Beam Details: Options to simulate effects with 
Wireframe view beams.
 Stick Beams Only: Select this checkbox to only display beams as 

stick beams. Selecting this option might increase system 
performance.
Note: The Stick Beam option only applies to the representation of 
beams in Wireframe views. Beam visualization in Shaded Views is 
not affected.

 Other Beam Details: Select this checkbox to enable other details for 
beams.
 Center Line: Select this checkbox to draw a point from the 

fixture to the point on the stage where the center of the beam 
hits. If the fixture has CMY color mixing, the line will change 
color to match the output from the console.

 Beam Angle: Select this checkbox to display the photometrics 
of the fixture’s beam angle instead of the field angle.
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 Head Height Circle: Select this checkbox to enable checking the 
light coverage at a certain height (the height of the 
performer).

 Complex Gobos: Select this checkbox to display complicated 
gobo patterns with details and coloring.

 Shaded Beam Details: Options to simulate effects with Shaded 
view beams.
 Colors: Clear this checkbox to ignore color settings and have all 

beams displayed as open-white.
 Prism: Select this checkbox to simulate prism effects. This might 

increase the number of lines that WYSIWYG has to draw, thus 
slowing down processing power.

 Gobos: Gobo wheels often take a lot of processing power and can 
slow down the refresh rate of other fixtures’ updates 
unnecessarily. If you are concerned about cue timing, clear this 
checkbox to disable gobos.
 Gobo Rotation: Select this checkbox to simulate gobo rotation. 

This option can slow down the refresh rate substantially as 
gobos can be rotating even when the fixture’s intensity is at 
zero. 

 Symbol Alignment: Options for organizing symbols.
 Line up symbols: Select this checkbox to line up fixture symbols at 

specific angles, and then select an increment from the drop-down 
list. Symbols will shift from their focused position to the nearest 
increment of the chosen angle. For example, symbols will be 
drawn in one of four directions when the increment is set to 90 
degrees. This setting does not affect the focus of the beam; rather 
it is intended for the “cleanliness” of the printed plot.

 Symbol Fill: Options for fixture symbols to be filled with a choice of 
colors and fill percentage.
 Enable: Select this checkbox to enable Symbol Fill.

 Percentage: Select this radio button if you wish to fill using the 
same hue of the Fixture Symbol, and select the percentage 
from the drop-down list for the hue intensity.

 Custom Color: Select this radio button and click the cell to 
choose a different color.

 Use Gel Color: Select this radio button if you wish to fill using 
the gel color that is attached to the fixture. Gel color will be 
displayed if only one gel is applied to the fixture.

Note: Once the Symbol Fill feature is enabled, the 2D fixture 
symbols will be displayed as filled in CAD Wireframe 2D views only, 
and not in Isometric view.

 Focus mode: Allows you to choose to focus a fixture as you hang it 
in your drawing. Specify one of the following options to set how a 
fixture will react after you hang it in a plot:
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 None: This setting indicates that you can continue to hang fixtures 
uninterrupted.

 Focus after hang: If enabled, you will be prompted to focus each 
fixture as you hang it. Once the fixture is focused, you can 
continue hanging other fixtures.

 Focus towards origin: If enabled, the fixtures that you hang are 
automatically focused towards the user origin.

 Enable beam dragging: Select this checkbox to enable click and drag 
positioning of beams in CAD, Design, and Live modes. This option is 
also available on the CAD Options toolbar in CAD, Design, and Live 
modes.

Hang Structure Settings tab
Options on the Hang Structure Settings tab affect how hang structures, such 
as pipes and truss, are placed or drawn in CAD mode.

 Hang Options: Options that affect how fixtures are placed.
 Snap Interval: If Pipe Snap is enabled (in the Draw Defaults tab), the 

number entered into the field will be used as the interval used for 
snap spacing. 
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 AutoUnit: Select this checkbox to automatically assign a unit 
number to each fixture that is hung. This option is available for 
pipes only. It does not apply to truss.

 Auto-Unit Order: The direction in which fixtures will be assigned a 
number, either Stage Left to Right or House Left to Right.

 Enforce Minimum Spacing: Type the minimum spacing between 
fixtures. This option prevents you from hanging the fixtures too 
close to one another. 

 Pipe drawing mode: Options that affect how pipes are drawn.
 Draw from start: Select this checkbox to have pipes drawn by 

specifying the start point and the end point (from one extremity of 
the pipe to the other).

 Draw from Center: Select this checkbox to have pipes drawn by 
specifying the center point and one end point or extremity of the 
pipe.

 Truss Assembly: Options that affect how truss is assembled.
 Automatically group truss: Select this checkbox to group truss objects 

together in a similar manner to choosing Group from the Edit 
menu. This option is helpful in that it treats the truss as a single 
unit and allows you to perform actions more effectively on multiple 
objects. If you want to edit one truss object, you must first use the 
Ungroup command on the Edit menu to remove the grouping from 
the truss objects.

 Only snap to truss on editable layers: Select this checkbox to enable a 
truss section to automatically snap onto truss sections in layers 
that were set as editable in the Layer Database.

 Truss/Pipe Thickness and Symbol Fill: Options that affect how 
truss and pipe symbols are displayed in Wireframe.
 Enable Thickness: Select this checkbox to display Truss and Pipe 

symbols with thickness in 2D CAD Wireframe views and in 
associated paperwork views (Not in isometric views). Clear this 
checkbox to display the truss and pipe objects as line drawings.
 None: Select this checkbox to disable Symbol Fill, and the 2D 

truss and pipe objects will not be filled when displayed in 
Wireframe.

 Percentage: Select this radio button if you wish to fill using the 
same hue of the truss or pipe object, and select the 
percentage from the drop-down list for the hue intensity.

 Custom Color: Select this radio button and choose a custom 
color from the color select box as fill color for the truss or pipe 
object.

 Default Pipe Thickness: Type a new value to change the default 
thickness of the pipes in your drawing.

 Truss Indicators: Options that affect how truss indicators appear.
 Use Truss Properties for Truss Indicators (Line Weight and Color): Select 

this checkbox to have truss indicators match the style truss are 
drawn.
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 Use thick lines for Truss indicators: If truss indicators do not use the 
same properties as the truss, then this option is chosen. Thick 
lines are used for truss indicators. Use the buttons below to 
change the color of dividers.
 Linear Divider Color: Click this button to choose a custom color 

for linear dividers.

 Angled Divider Color: Click this button to choose a custom color 
for angled dividers.

Object Settings tab
Options on the Object Settings tab affect how various simple objects are 
drawn in CAD mode.

 Line Weight: The default thickness lines created. Can be changed 
using the drop-down list.

 Point Options: Options that affect how points are drawn in CAD 
mode.
 Point Size: Sets the default size for all points. You can view a 

sample of the chosen size in the box to the right.
 Point Type: Indicates the default point type in your show document. 

You can choose to display points as a Dot, Cross, Square, or Circle.
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 Segment Options: Options that affect how multi-segment objects 
are drawn.
 Cylinder Segments: The number of segments into which you want to 

break a cylinder.
 Cone Segments: The number of segments into which you want to 

break a cone.
 Sphere Segments: The number of segments into which you want to 

break a sphere.
 Stack Options: Options that affect how objects are divided.

 Cone Stacks: The number of horizontal divisions into which you 
want to break a cone.

 Sphere Stacks: The number of horizontal divisions into which you 
want to break a sphere.

 Linear Scale mode: Options that affect how linear scales are 
drawn.
 Draw from start: Select this checkbox to have linear scales drawn by 

specifying the start point and the end point (from one extremity of 
the pipe to the other).

 Draw from Center: Select this checkbox to have linear scales drawn 
by specifying the center point and one end point or extremity of 
the pipe.

 Drawing Options: Options that affect how linear scales are drawn.
 Paste Base point: Select this checkbox to enter a base point before 

an object is copied or cut. This will be the object’s reference point 
for paste commands. Clear this checkbox to allow the base point to 
be the insertion point of the object. 

 Interactive object creation: Select this checkbox to allow yourself to 
draw objects using the mouse instead of entering values in dialog 
boxes.
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Dimensions tab
Options on the Dimensions tab affect how various dimensions are drawn 
by default.

 Display Units: The type of measurement unit displayed for dimensions 
in CAD mode. Choose the default imperial measurement units 
between Feet & Inches or Inches.

 Display Dash (for Imperial): When this option is enabled, a dash is 
displayed between foot and inches in imperial measurements, e.g. 
6’-8 3/4”.

 Display Alternate Units: Select this checkbox to display a second 
measurement with your dimensions, in the alternate unit. For 
example, if metric is your set unit but also wish to display all of your 
dimensions with both metric and imperial values, enable this option. 
The drop-down list offers the display unit options for the alternate 
unit displayed.
Note: In the Draw Defaults window, if Imperial is the selected default 
measurement unit, the Display Units will be Imperial and the Display 
Alternate Units will be Metric and vice versa.

 Linear Dimension: Options to affect the default settings of linear 
dimensions.
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 Text Height: The default text height for linear dimensions object in 
CAD mode.

 Text Offset: Sets the default distance of the text above or below the 
dimension line in CAD mode.

 Extension: The default length of the extension lines for linear 
dimensions in CAD mode.

 Offset: Sets the default offset value for linear dimensions in CAD 
mode. The offset is the distance between the extension lines and 
the object being measured.

 Arrow Type: Select the default arrow type for linear dimensions in 
CAD mode. There are several styles available to choose from.

 Arrow Size: Select the default size of the arrow head for linear 
dimensions in CAD mode.

 Baseline & Continue Dimensions:
 Extension: The default length of the extension lines for both 

Baseline and Continue Dimensions.
 Spacing Size: The default length of the space between the stacked 

and subsequent baseline dimensions from the same extension 
base line.

 Arc Length Dimension: Options to affect the default settings of arc 
length dimensions.
 Text Height: The default text height for arc length dimensions in 

CAD mode.
 Text Offset: Sets the default distance of the text above or below the 

dimension line in CAD mode.
 Extension: The default length of the extension lines for arc length 

dimensions in CAD mode.
 Offset: Sets the default offset value for arc length dimensions in 

CAD mode. The offset is the distance between the extension lines 
and the object being measured.

 Arrow Type: Select the default arrow type for arc length dimensions 
in CAD mode. There are several styles available to choose from.

 Arrow Size: Select the default size of the arrow head for arc length 
dimensions in CAD mode.

 Radial Dimension: Options to affect the default settings of radial 
dimensions.
 Text Height: The default text height for radial dimensions in CAD 

mode.
 Arrow Type: Select the default arrow type for radial dimensions in 

CAD mode. There are several styles available to choose from.
 Arrow Size: Select the default size of the arrow head for radial 

dimensions in CAD mode.
 Linear Scale: Options to affect the default settings of linear scales.

 Text Height: The default text height for linear scales in CAD mode.
 Text Position: Select the default position of text that appears for 

linear scales.
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 Tick Interval: Select the default interval at which ticks will appear on 
linear scales.

 Tick Mode: Select the default mode of which ticks appear on linear 
scales.

 Major Ticks: Select how major ticks will appear on linear scales.
 Tick Style: Select the default tick style that will appear on linear 

scales.

Fonts tab
Options on the Fonts tab affect how text is displayed by default on 
dimensions, scales and labels. 

 CAD Text Labels: The default setting of CAD Text Labels text.
 Font: The default font used for the text. Select the desired font 

type from the drop down menu.
 Bold: Select this checkbox to make the default text bold.
 Underline: Select this checkbox to make the default text underlined.
 Italics: Select this checkbox to make the default text italicized. 
 Arrow Type: The style of arrow head used on the dimension.
 Arrow Size: The size of the arrow head used on the dimension.

 CAD Dimensions: The default setting of CAD Dimensions text.
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 Font: The default font used for the text. Select the desired font 
type from the drop down menu.

 Bold: Select this checkbox to make the default text bold.
 Underline: Select this checkbox to make the default text underlined.
 Italics: Select this checkbox to make the default text italicized. 

 CAD Linear Scales: The default setting of CAD Linear Scales text.
 Font: The default font used for the text. Select the desired font 

type from the drop down menu.
 Bold: Select this checkbox to make the default text bold.
 Underline: Select this checkbox to make the default text underlined.
 Italics: Select this checkbox to make the default text italicized. 

 New Plot Text Labels: The default setting of New Plot Text Labels 
text.
 Font: The default font used for the text. Select the desired font 

type from the drop down menu.
 Bold: Select this checkbox to make the default text bold.
 Underline: Select this checkbox to make the default text underlined.
 Italics: Select this checkbox to make the default text italicized.
 Arrow Type: The style of arrow head used on the dimension.
 Arrow Size: The size of the arrow head used on the dimension.

 Fixture Layout Labels: The default setting of Fixture Layout Labels 
text.
 Font: The default font used for the text. Select the desired font 

type from the drop down menu.
 Bold: Select this checkbox to make the default text bold.
 Underline: Select this checkbox to make the default text underlined.

 Set Font for New Labels in Pres Layouts: The default setting of Set Font 
for New Labels in Pres Layouts text. Click this button to change the 
settings.

Fixture Data 
Options found in the Fixture Data section contains settings that affect 
reports and data errors in reports.
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Defaults tab
Options on the Defaults tab affect the default values for empty or non-
applicable cells in spreadsheets.
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Error Tracking tab
Options on the Error Tracking tab control what types of data errors trigger 
notifications. 

For more information on data errors, refer to “Errors”.

View Options dialog box

View options set how objects are drawn and displayed in Wireframe and 
shaded views. 

For more information on View options for Wireframe views, refer to 
“Modifying Wireframe views”.

For more information on View options for shaded views, refer to 
“Modifying shaded views”.
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WYSIWYG Viewer

The WYSIWYG Viewer is a separate application that allows non-
WYSIWYG users to view and print your WYSIWYG (.wyg) files. It is 
beneficial to those individuals who are interested in viewing or printing a 
WYSIWYG file but who do not own a licensed copy of WYSIWYG. 

Any file with a .wyg file extension can be viewed and printed from the 
WYSIWYG Viewer.

WYSIWYG Viewer comes with a Shaded view so you can see a realistic, 
3D representation of the file, as well as Presentation mode. To ensure 
that every aspect of your file can be seen properly, ensure that all 
relevant information is available in Presentation mode before opening 
your file in the WYSIWYG Viewer. 

All functionality except navigation and printing has been disabled. Users 
cannot edit files, nor can they insert items into a file. For more 
information on preparing your file in Presentation mode, refer to 
“Presentation mode”.

The WYSIWYG Viewer is available from the CAST Software Web site at 
http://www.cast-soft.com/wysiwyg/.

http://www.cast-soft.com/wysiwyg/
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Chapter  6

CAD mode - Creating Objects

CAD mode is where you create your show drawings. This includes 
drawing your venue, set pieces, lighting positions, focus positions, 
and lighting fixtures. CAD mode operates like many other CAD 
programs, so many of the concepts will be familiar to those who 
have used a computer-aided drafting program before. WYSIWYG 
adds features that are specific to the entertainment industry, such 
as a comprehensive 3D library containing truss, lighting equipment, 
lighting accessories, props, musical instruments, and various 
human figures.

In this chapter
Layout tabs 201

The CAD environment 206

The Library Browser 273

Drawing objects 282
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Layout tabs

Introduction

Beneath the work area in each mode is a series of Layout tabs. These 
layouts provide various configurations of the views you are working with. 
To change layouts, click the tab that corresponds to the layout you wish 
to use. 

The CAD mode contains the following layouts:

 Wireframe: The work area displays a full-screen Wireframe view.
 Quad: The work area is divided into quadrants, three of which can be 

modified to show Plan, Front, Side, or Isometric Wireframe views. 
The lower-right quadrant contains a Shaded view.

 Flight Case: The Flight Case is displayed in a section of the work area 
along with a Wireframe view.

 Shaded: The work area displays a full-screen Shaded view.
 Custom: A custom layout, with views defined by the user. See 

“Custom tab window layout”.

Custom tab window layout

You can create your own custom tab layouts, and specify your workspace 
as you wish. This feature is offered in the CAD mode, and allows you to 
customize your workspace with any combination of layout windows, and 
then saves these settings in a layout tab.

The Views that can be displayed in a Custom tab include:

 CAD Wireframe view
 CAD Shaded view
 DATA Spreadsheet view
 DATA Patch view

Custom tabs are stored with the application. Once created, a Custom tab 
will always be available on the computer (until it is deleted).

Note:  You can create up to 10 custom tabs in your installation. 
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To create a custom tab

1 In CAD mode, from the View menu, select Custom Tab > Create.

Note: You can also click the + tab by the layout tabs.

2 The New Custom Tab window appears.

3 In the New Custom Tab window, in the Custom Tab Name field, enter a 
name for the new tab.

4 In the Specify Workspace section, select how many panes will be 
in the custom tab. 
Note: A preview of how the tab will look appears in the Preview 
section.

5 In the Specify Views section, select what view will be displayed 
inside each pane from the drop-down menu.
Note: Refer to the Preview section for the location of the pane in 
the custom tab.

6 When done customizing the tab, click OK.
Result: The custom tab will be created. The custom tab will appear 
with the default tabs at the bottom of the layout.
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To rename a custom tab

1 In CAD mode, select the custom tab you want to rename.

2 From the View menu, select Custom Tab > Rename.
Note: You can also right-click the custom tab and select Rename.

3 The Enter new tab name window appears.

4 In the Enter new tab name window, type the new name for the custom 
tab.

5 Click OK.
Result: The custom tab will be renamed to the new name.

To duplicate a tab

You can copy any existing tab in CAD mode. This will create an exact 
duplicate of the original tab. You can then use or edit both tabs as 
needed. 

1 In CAD mode, select the custom tab you want to rename.

2 From the View menu, select Custom Tab > Duplicate.
Note: You can also right-click the tab and select Duplicate.
Result: The selected tab will be copied and appears with the other 
tab.

To hide a tab

You can hide a tab that you do not want to see in a mode. This is useful if 
you have a number of custom tabs and want to reduce clutter. 

1 In CAD mode, select the custom tab you want to rename.

2 From the View menu, select Custom Tab > Hide.
Note: You can also right-click the tab and select Hide.

3 The selected tab will be hidden from view.
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To unhide a tab

1 In CAD mode, from the View menu, select Custom Tab > Unhide > 
[Hidden tab name].

Tips: 
 To unhide all hidden tabs, select Open all Hidden Tab.
 You can also right-click the tab and select Unhide > [Hidden tab 

name].
Result: The selected hidden tab will be visible again.

To delete a tab

1 In CAD mode, select the custom tab you want to delete.

2 From the View menu, select Custom Tab > Delete.
Result: A dialog box appears asking if you really want to delete the 
tab. 

3 To confirm the deletion, click YES.
Result: The tab will be permanently deleted. 

To change tab ordering

You can change the order which tabs are ordered.

1 In CAD mode, select the custom tab you want to move.

2 Click and drag the tab left or right to a new position.

Custom tab manager
The Custom Tab Manager is a feature to help you keep track and manage 
any custom tabs you create.

 Select All: Will select all custom tabs in the manager.
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 Select None: Will clear all custom tabs in the manager.
 Delete: Will delete the currently selected custom tab(s).
 Name: The name of the custom tab.
 Visible: Displays if the custom tab is currently hidden from view.

To access the Custom Tab Manager

In CAD mode, from the View menu, select Custom Tab > Custom Tab 
Manager.

Note: The Manage Custom Tabs window appears.
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The CAD environment

Scales

When drawing in WYSIWYG, you are drawing in real scale (1:1). When 
you create a drawing in CAD, you are generating a virtual representation 
of your real set-up. If you were to do this on paper by hand, you would 
need to draw a scaled-down version of your space. However, since there 
are no paper size limitations in CAD mode, you can draw your venue, 
sets, pipes, trusses, and lighting fixtures in real scale. 

Scaling down for printing purposes is done during print set-up and in the 
Presentation mode when creating plots. These settings allow you to print 
your drawings in whatever scales are necessary without having to redraw 
anything.

Coordinate system and origin

When working in CAD you are working in a 3D environment (even in 
WYSIWYG Report). Objects are drawn as 3D objects, with width, depth, 
and height values using the Cartesian coordinate system of 3 working 
axes X, Y, and Z. The point where the 3 axes meet is called the origin and 
the value of X, Y, and Z is 0 respectively (0,0,0).

By default, the origin is set at the center point of the WYSIWYG venue 
that you insert. Inserting venues is discussed in “Drawing a venue”. You 
can reset the origin to another point in your drawing; you can set a user 
origin so that a different point will assume the values (0,0,0). 

To set the user origin

1 From the Tools menu, choose Set User Origin.

Tip: You can also use the Set User Origin tool on the Tools toolbar. 

2 Click a point on your drawing or type in the coordinates (X,Y,Z) that 
will assume the values 0,0,0. This point will remain 0,0,0 until you 
change it again.

To reset the user origin

From the Tools menu, choose Reset User Origin.

Result: This resets the origin back to the WYSIWYG default.

 The Set User Origin button.
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Coordinate notation

When entering coordinates in WYSIWYG, you can specify a location or 
distance in either inch fractions (to the sixteenth of an inch) or 
millimeters. For example, you can specify a measurement of 1’6”3/16, 
which translates to 1 foot, 6 and 3/16 inches. 

To set default options 

1 From the Options menu, choose Document Options.

2 Click the Draw Defaults tab.

3 Based on your choice for measurement in the Units section, you can 
choose to display the drawing resolution in whole numbers, fractions, 
centimeters, or millimeters. 
 Whole: (Only visible if you choose Imperial units.) Indicates that 

the measurements are rounded and displayed to the nearest 
whole number. 

 Fraction: Indicates that the measurements are displayed to the 
nearest sixteenths of an inch. 

 cm: (Only visible if you choose Metric units.) Indicates that the 
measurements are displayed in centimeters. 



208

CAD mode - Creating Objects  R42

 mm: Indicates that the measurements are displayed in 
millimeters.

4 Click OK.

Metric vs. Imperial

WYSIWYG enables you to use metric or imperial units at any time. You 
may choose to set a default type of unit, and you may choose to switch 
unit type on the fly. 

You can also indicate whether you want these units measured in whole 
numbers, fractions (to the sixteenth of a inch), centimeters, or 
millimeters.

To set the default unit type

1 From the Options menu, choose Document Options.

2 Click the Draw Defaults tab.
3 Click either Metric or Imperial.
4 Click either Whole, Fraction, mm or cm. 

Note: These choices vary based on whether you selected Metric or 
Imperial in step 3. 

To switch unit types on the fly

Double-click the units display on the Status bar.

Ruler tool

The Ruler tool helps you design your show file in the Wireframe views of 
the CAD Mode, providing a visual aid for coordinate reference and 
measurement. By default, the Ruler is aligned with the document origin 
and displays coordinate information along the top and left side of the 
view. Its scale matches the default grid scale. 

As shown in the graphic below, the Ruler has different colors to represent 
different axes (X=Red, Y=Green, Z=Blue).
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The Ruler dynamically updates as you zoom in and out. When you zoom 
in on your drawing, the precision of the ruler increases, displaying 
fractions and decimals; when you zoom out, the precision decreases to 
the point where both the grid and ruler disappear. The ruler matches the 
unit type currently set in your file, either Metric or Imperial. When 
working with larger venues, it is recommended that you increase the grid 
spacing so that the ruler will be visible when zoomed out further. The 
ruler matches the unit type.

The Ruler displays values with the negative sign to the left of 0’0” when 
in Plan, Front and Right view, or to the right of 0’0” when in Back and 
Left view.

Ruler icons

On the Quad tab (as shown above), each of the three drawing quadrants 
can have a different drawing origin, or View Origin. When you define a 
new view origin, you can move the zero position of the ruler (-0 0+) to 
correspond to this point. 

Based on the origin in the active quadrant and the corresponding position 
of the Ruler, the icon in the upper left corner of the Ruler changes.

Icon Description

The Ruler’s zero position (origin) is aligned with the 
Document Origin, which is set by default to be the 
center point of the WYSIWYG venue defined for the 
event.
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The following graphic shows a Quad tab in which the Ruler origin is 
different in each view:

To turn the Ruler on and off

By default, the Ruler is turned on when you open a new WYSIWYG file. 
You can turn the ruler on and off while working in your file by using the 
Ruler Toggle icon on the CAD Options toolbar.

By default, all views are set to the Document Origin. 
However, you can set the origin for each view, thereby 
defining a View Origin. This icon appears when you 
have defined a View Origin for the current view and 
have aligned the Ruler’s origin to it.

This icon appears when you have set a new User Origin 
for the file by clicking Tools > Set User Origin.

This icon appears when you have clicked Move Ruler 
(Set View Origin) from the Ruler menu and are in the 
process of defining your new origin.

Icon Description

This icon appears when
you are in the process
of moving the Ruler to
a new origin. It is 
replaced with the V icon
when you click in the 
drawing to set the new
View Origin.

This icon appears when
you have set a new
User Origin for the file
by clicking Set User 
Origin on the Tools
menu. 

This icon appears when
you have set the 
Document Origin for the
current view, thereby 
defining a new View
Origin, and have aligned 
the Ruler’s origin to it.
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1 To show the CAD Options toolbar, right-click on the toolbars area and 
click CAD Options.

2 On the CAD Options toolbar, click the Toggle Rulers icon. 

Result: The Ruler appears or disappears.

Note: You can also toggle the ruler on or off by using the Draw 
Defaults tab in Document Options. Click Options > Document Options > 
Draw Defaults.
a. To turn the Ruler off, clear the Show Rulers checkbox.

b. To turn the Ruler on, select in the Show Rulers checkbox.

3 Click OK.

To change the ruler’s style

You can change the appearance of the ruler. The ruler can be white, the 
view color or the view color with a boarder.

1 In CAD mode, click Options > Application Options.

Result: The Application Options window appears.

2 In the Application Options window, select the desired ruler style from 
the Ruler Style drop-down list.

3 Click OK.
Result: The ruler’s appearance will change to that of the selected 
style.

To change the Ruler’s origin

By default, the ruler is aligned with the document origin, which means 
that the zero mark (-0 0+) starts at the Document Origin. However, you 
can move the Ruler from this default position to the origin of the current 
view. Note that doing so does not affect the origin or ruler of any other 
view.

1 In the Quad tab, click the quadrant in which you want to move the 
Ruler. 

2 Click the icon in the upper left corner of the Ruler (or right-click on 
the actual Ruler) and select one of the following options:
 Display Ruler at Document Origin: Select this option to realign the 

Ruler’s zero point with the Document Origin, which is set by 
default to be the origin of the WYSIWYG file. When the ruler is 
displayed at the Document/User origin, the background color of 
the ruler follows the selected Ruler Style option in the General tab of 
Application Options.

 The Toggle Rulers button.
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 Display Ruler at View Origin: Select this option if you want to 
realign the Ruler to the View Origin of the current view, if 
different than the original Document Origin. To indicate this 
change, the background of the Ruler changes to match the axis 
colors.

 Move Ruler (Set View Origin): Select this option if you want to 
choose a new origin for the ruler. Then click the cursor on the 
point in your drawing that you want to designate as the zero 
mark for the Ruler. Once the Ruler is moved, you can use the 
previous two menu items (Display Ruler at Document Origin and 
Display Ruler at View Origin) to switch the ruler’s position from the 
default position to the user defined position.

Note: By moving the ruler, you are indirectly setting a new origin for the 
currently selected view. In the past, this was possible by changing the 
Origin in a CAD view’s View Options, or by clicking Tools > Set User 
Origin.

Position tool

The Position Tool helps you determine the position of your selected object 
or objects in the Wireframe views of CAD mode, providing the precise 
coordinate reference numbers for the X, Y and Z axes.

The Position Tool can be used to change the position of your selected 
object or objects by specifying new coordinate numbers for the X, Y and 
Z axes.

The Position Tool window is dockable with a grab bar on top which can be 
used to move around the screen. You can place it on the edges of the 
work area or you can drag it off the edge, to become its own window and 
stay on top of the WYSIWYG screen. WYSIWYG opens with the Position 
Tool window open and docked above the Layer Database window by default.

To use the Position Tool

1 Select an object in wireframe view.

2 From the View menu, choose Position Tool.
Result: The Position Tool window appears showing the selected 
object’s X, Y and Z position coordinates in the drawing.
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3 On the Position Tool window, click the X, Y or Z scroll box arrows to 
increase or decrease the reference coordinate numbers.
OR

On the Position Tool window, you may click the X, Y or Z boxes and 
type the numbers.

Result: The position of the selected object(s) changes according to 
the new coordinate reference numbers.

Notes: 

 You can select more than one object and you can move more than 
one object.

 If multiple objects are selected and arrow buttons are used, the 
objects move to relative positions.

 If multiple objects are selected and a coordinate value for an axis is 
entered, the objects move to the same position. For example, if 
multiple objects are selected and you entered a coordinate value in 
the Z axis box, the objects move to the same Z axis coordinate.

 The increment/decrement size is equal to the Grid Interval property 
in Document Options > Draw Defaults tab.

Position tool shortcuts
You can open the Position Tool using the following shortcuts:

 CTRL+ALT+P: Opens the Position Tool window.
 CTRL+SHIFT+X: With an object(s) selected, opens the Position Tool 

window and the cursor in X.
 CTRL+SHIFT+Y: With an object(s) selected, opens the Position Tool 

window and the cursor in Y.
 CTRL+SHIFT+Z: With an object(s) selected, opens the Position Tool 

window and the cursor in Z.

The missing coordinate

The missing coordinate (X,Y,or Z) is the coordinate whose value cannot 
be entered by clicking on the screen. The easy way to determine which 
coordinate is the missing coordinate in a wireframe view is to move the 
mouse around. Look at the Status bar at the bottom of the working area. 
You will see only two values changing. The value that is not changing is 
the missing coordinate for that view or workplane. The missing 
coordinate is dependent on the plot type and the workplane selected. In 
the following example, Y is the missing coordinate as its value is set at 
0’0”. 
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Once entered, this value affects all subsequent objects inserted in the 
current view. For example, if the missing coordinate is set to 5’ in a plan 
view, all objects are placed 5 feet off the floor (X,Y,5) until the missing 
coordinate is changed again. Please note that the missing coordinate is 
not a move tool. Objects will not be moved to the missing coordinate 
value. The missing coordinate only affects subsequent inserts.

To enter a value for the missing coordinate

1 Press TAB on your keyboard or click the Missing Coordinate tool on the 
CAD Options toolbar.

2 In the CAD coordinate box, type the value for the CAD coordinate.
3 The Focus Coordinate tells WYSIWYG where to place the cursor (i.e., at 

which missing coordinate) when manually focusing fixtures. If you 
type any value other than 0 in this box, you will notice that the 
beam's centreline extends past the crosshairs when you drag the 
beam around with your mouse. This represents the distance between 
the Focus Coordinate and the floor (or whatever is stopping the 
beam). 

4 If you want to use only the CAD coordinate for focusing and placing/
editing objects, select the Use only one missing coordinate checkbox. 

5 To automatically adjust the missing coordinate with any 3D 
coordinate value that you enter on the Command Line, select the 
Automatically adjust with Command Line checkbox. 

6 Select the Show head height checkbox to display the coverage of 
beams at the head height selected in the Head height box. 

7 In the Head height box, type a value to check the light coverage at a 
certain height (the height of the performer). 
Note: This box is enabled when the Show head height circle checkbox is 
selected. 

8 When you are finished with your selections, click OK.
Example: 

 The Missing Coordinate button.
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a. Change to the plan view in your drawing.

b. Press TAB, and then type a value of 0" for the missing CAD 
coordinate. 

c. Insert a few objects on the stage. All of these objects are drawn 
resting on the stage. 

d. Change the missing CAD coordinate to a height of 10’. 

e. Insert a riser by clicking the Riser button on the toolbar. 

f. Although we are in a plan view the riser has been drawn at the 
height of 10', as specified in the missing coordinate dialog box. 

g. Change to a side view and you will see that the riser has been 
placed above the stage.

Tip: If you select the Show head height circle checkbox, and then type 
a value in the Head height box, all subsequently focused fixture’s 
beams will display both the coverage at the specified head height, as 
well as the footprint of the beam on the surface below.

Command line

The Command Line is an area in WYSIWYG where you can enter 
coordinates for the purpose of placing or editing objects in a document. 
The placement of objects can often be done quicker and with more 
precision using the Command Line. 

Generally, coordinates are specified as X, Y, Z. You can, however, insert 
coordinates using either two or three values. When using two values, the 
third value will be assumed from the missing coordinate. For details, 
refer to “The missing coordinate”. 

The values that you specify in imperial mode are assumed to be in feet 
unless otherwise specified. Similarly, the values that you specify in metric 
mode are assumed to be in metres unless otherwise specified. At any 
time, you can specify values in both imperial and metric measurements 
(for example, 5”, 3 cm, 6’). 

The following example illustrates the many different ways of using the 
Command Line. 

Example

1 In a plan view, from the Draw menu, choose Line. 

2 From the sub-menu, choose Solid, Dot, Center, Hidden or Spline.
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3 Type 0,0 as the starting point of the line.
Result: When you start typing, the Command Line toolbar appears.

4 Press ENTER to establish the first point of the line at the origin. 
5 To set the next point at exactly X=5 and Y=5, type 5,5, and then 

press ENTER. 
Result: A new line segment is drawn and it assumes Z from the 
missing coordinate.

6 To place the next point of the line 10 units to the right and 5 units up 
(in Y) from the last point, type @10,5, and then press ENTER.
Result: A new line segment is drawn.

7 To place the next point at exactly 5 feet, 3 metres, and 6 inches from 
the last point, type 5’, 3m, 6”, and then press ENTER.
Result: A new line segment is drawn.

8 When you are finished drawing the lines, right-click, and then select 
Finish Line. 

Plot types

All objects occupy three-dimensional space. Different plot view types 
allow you to see and work with your drawing from different perspectives. 

There are six types of plot views accessible from the CAD Options toolbar. 
The following definitions identify the working axes X, Y, and Z and the 
missing coordinate for each plot type. The missing coordinate can be 
defined as the axis for which a value cannot be set simply by clicking on 
the work space. For details, see “The missing coordinate”. 

  Plan View

Plan views display the plot from above looking down. This is similar to a 
plan view drawing on paper. In plan views the working axes are X and Y 
and the missing coordinate is Z.

  Left View
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Left views display the plot looking from the left side through the venue. 
This is similar to a section on paper. In left views the working axes are Y 
and Z and the missing coordinate is X.

  Right View

Right views display the plot looking from the right side through the 
venue. This is similar to a section on paper. In right views the working 
axes are Y and Z and the missing coordinate is X.

  Front View

Front views display the plot looking from the front side through the 
venue. This is similar to an elevation on paper. In front views the working 
axes are X and Z and the missing coordinate is Y.

  Back View

Back views display the plot looking from the back side through the 
venue. This is similar to an elevation on paper. In back views the working 
axes are X and Z and the missing coordinate is Y.

  Isometric View

An Isometric view is a 3D perspective drawing. Despite this, you are still 
limited to two working axes. In isometric views, the working axes and 
the missing coordinate are dependent on the workplane selected. The 
workplanes available are:

  Workplane Plan
  Workplane Selection
  Workplane Elevation

If a plan workplane is selected, the working axes are X and Y and the 
missing coordinate is Z. 

If a side workplane is selected, the working axes are Y and Z and the 
missing coordinate is X. 
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If a front workplane is selected, the working axes are X and Z and the 
missing coordinate is Y. 

The crosshairs of your cursor change to reflect the selected workplane.

Note: Isometric views are not available in WYSIWYG Report.

Isometric view angle
You can rotate the isometric angle of the Isometric View using your 
keyboard CTRL and arrow keys or CTRL keys and the third mouse button. 

When using your mouse, you can also change the rotation speed when 
you increase or decrease the amount of pixels your mouse needs to 
travel to rotate the view on the screen using the CTRL keyboard and + or 
- keys in the keypad.

To rotate the isometric angle

Hold down the CTRL key and tap the arrow keys on your keyboard.

OR

Hold down the CTRL key, and then click and drag the third mouse button 
(scroll wheel) towards the direction of the angle change.

Result: The isometric angle of the Isometric View changes according to 
the direction of the mouse movement.

Tip: If you add SHIFT to either method, the rotation slows down for both 
keyboard and mouse movement.

Notes: 

 Rotation direction is determined by the dominant direction of mouse 
movement. For example, the view rotates in the left-right angle if the 
mouse is dragged towards the left and slightly up. The view rotates 
in the up-down angle if the mouse is dragged upwards and slightly 
left.

 Once the rotation direction has been determined and the rotation has 
started, the rotation cannot “switch” to the other direction. You have 
to release the mouse button and then click and drag again.
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To change the mouse cursor speed and travel distance

Press and hold CTRL + SHIFT and tap the + keypad key (i.e. not the + at 
the top of the keyboard, by the DELETE key) to increase the number of 
pixels your mouse cursor needs to travel to rotate the view on your 
screen and slow down the view rotation.

OR

Press and hold CTRL + SHIFT and tap the - keypad key (i.e. not the - at 
the top of the keyboard, by the DELETE key) to decrease the number of 
pixels your mouse cursor needs to travel to rotate the view on your 
screen and speed up the view rotation.

Result: 

 The number of pixels value is displayed on the Status Bar as you 
increase or decrease with your keyboard keys.

 It is faster for your mouse cursor to rotate the view when the travel 
distance is shorter because of the lesser amount of pixels set.

 It is slower for your mouse cursor to rotate the view when the travel 
distance is longer because of the greater amount of pixels set. 

Note: The default amount of mouse cursor travel distance in pixels is 20. 

Ortho

Ortho mode constrains movement and drawing to a direction parallel to 
the specified axis. When ortho mode is inactive, objects can be drawn or 
moved in any direction on the workplane. You can draw diagonal lines or 
move objects anywhere in the working area. 

You can activate ortho at any time by clicking the ortho tools on the CAD 
Options toolbar or by right-clicking the Ortho label on the Status bar. You 
can also press F8 on the keyboard or double-click the Ortho label on the 
Status bar to enable Ortho or to toggle your last recorded ortho setting 
on or off. 

Notes: 

 The plot type determines the axes of movement: XY for plan views, 
YZ for side views, XZ for front and back views. 

 To select the axes of movement with the toolbar buttons, click the 
appropriate two buttons to select both of them. For example, to 
choose the XY axis, click the X and Y buttons. 

 To cancel any ortho buttons that you have chosen, press F8; to reset 
the same ortho selection as that which was previously made, press 
F8 again.
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Snaps

Snaps are used to assist in the drawing and placement of objects. When 
a snap setting is active, the cursor will be drawn to the applicable snap 
point. You can have multiple snaps active at the same time. Snap 
selections can be made on the CAD Options toolbar or from the Tools 
menu. 

All snap tools function as follows: If no command is currently active, you 
can adjust the running snap tool. This means that the snap type is 
always active. If you are in mid-command and you select a snap tool, it 
becomes a “one time only” snap type. After the next click, the snap 
returns to the running snap. At any time you can toggle all snaps on or 
off by pressing F9 or double-clicking on the SNAP text in the Status bar.

 Grid snap

Aligns the placement of objects to grid points. You can set the grid 
interval and angle in the Draw Options page of the View Options window.

 Mid-grid snap

Aligns the placement of objects between grid points. 

 Point snap

Aligns the placement of objects to a point in the drawing.

Fixture insertion points are considered points. It is therefore possible, 
using the Point snap, to align the placement of objects to fixtures (snap 
to fixtures). This is useful for dimensioning.

 Midpoint snap

Aligns the placement of objects to the mid-point of another line.

 Endpoint snap

Aligns the placement of objects to the end-point of another line.

 Intersection snap

Aligns the placement of objects to the intersection of lines, circles or arcs 
on the same plane.
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 Center snap

Aligns the placement of objects to the center-point of circles, arcs, or 
cylinders.

 Library snap

Library Snap displays snap points at the bounding box corners of the 
library item, and one corner is displayed in red or green to indicate the 
library item’s insertion point, which aligns the placement of the item in 
the drawing. The snap point is displayed in red if the object is not 
selected or green if the object is selected. Refer to “Library snap”for 
more details.

 Truss snap

Truss Snap displays snap points at the extents of the truss objects 
(incorporating truss thickness if enabled) to help draw dimensions to 
measure the truss. Refer to “Truss snap” for more details.

 Truss Assembly snap

Use assembly snap to group multiple truss objects together as you insert 
them. This ensures proper structural assembly. Refer to “Using assembly 
snap with truss” for more details about truss assembly. 

 Pipe snap 

Constrains fixtures to placement on a pipe at a specific interval. For more 
information, refer to “Pipe snap”.

 Focus snap 

Orients one or more fixtures to a focus position. When you choose this 
value, you can also lock beam dragging to the incremental values of your 
choice, as specified in the Pan and Tilt boxes of the Draw Options tab (the 
defaults are increments of 45 degrees for pan and increments of 10 
degrees for tilt). These are the values to which you want the fixture's 
beam to “snap” while manually dragging and focusing it. For example, if 
you set a value of 30 degrees, when you drag the fixture's beam, it will 
snap at 30 degrees, 60 degrees, 90 degrees, and so on. Note that any 
focus positions that you have set take precedence over the pan and tilt 
values (if you drag the beam over the focus position, it will automatically 
snap to the focus position instead).
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Interactive mode

Interactive mode is an alternative method for drawing objects. Objects 
are typically drawn using a dialog box to set the object’s size (width, 
depth, and height, for example). The full-size object is then attached to 
the cursor so you can place it in the drawing. 

An Interactive button enables you to switch modes. Interactive mode 
allows you to click an insertion point for the object first, and then drag to 
create the scope of the object as allowed by the view (XY for plan view, 
XZ for front view, and so on). 

Once those dimensions are set, a dialog box may open to allow you to set 
the third dimension, if required. Interactive mode works with Risers, 
Cylinders, Circles, Arcs, Spheres, and Pipes. There are some special 
considerations when drawing pipes in interactive mode, as explained in 
“Drawing pipes”.

To set interactive as the default drawing mode

1 From the Options menu, choose Document Options.

2 Click the Object Settings tab.
3 In the Drawing options section, select the Interactive object creation 

checkbox.

To set interactive mode on the fly

Press F11 on your keyboard or click the Interactive tool on the CAD 
Options toolbar. 

Importing SketchUp files

SketchUp is a modeling tool that enables you to create realistic 3D 
models of many different types of objects and then save the files with an 
.skp extension. You can import these SketchUp files into WYSIWYG in 
much the same way as you import DWG/DXF files. 

Before you import SketchUp files into WYSIWYG, note the following:

 While SketchUp supports two textures per surface, one each for the 
front and back, WYSIWYG supports only one texture for both sides of 
imported surfaces; when you are importing SketchUp files, 
WYSIWYG will automatically apply the front texture to both sides of 
the object.

 WYSIWYG supports “.skp” files from SketchUp version 2016 format 
and earlier at the time of this release.
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Textures
When you import SketchUp files into WYSIWYG, the textures associated 
with these files are saved in a folder on your computer so you can apply 
them to imported surfaces. By saving them to a folder outside of 
WYSIWYG, you can use them repeatedly instead of only applying them to 
the surfaces that are within the current WYSIWYG document. 

Upon import, you can choose the location for saving the associated 
texture files (or accept the default location). If there is already a texture 
with the same name saved in the location specified, WYSIWYG will 
prompt you to save the file with a new name.

Import options
When importing a SketchUp file into WYSIWYG, you have two options:

 You can open a file.
 You can merge a file into an existing WYSIWYG document.

If you open a SketchUp file while another show document is currently 
open, you are prompted to save changes to that document before 
another show document is opened. Only one show document may be 
open at a time. When you merge documents, you can add the contents 
of the SketchUp file to the contents of the current WYSIWYG document.

To open SketchUp files

This procedure creates a new WYSIWYG document out of the SketchUp 
file, prompting you to save changes to any current document that is open 
and close it before importing the file. 

Before you begin
You must have the SketchUp file saved on your computer to begin this 
procedure.

1 From the File menu, choose Open.

2 From the Files of type box, select SketchUp files (.skp), and then 
navigate to the location where the file is saved on your computer. 
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3 In the browser, click the file name, and then click Open. 
Result: The Import Directories window appears.

4 Click the browse button to specify the location where you want to 
save the textures that have been applied to the object in SketchUp, 
or accept the default location shown. By saving textures to a folder 
outside of WYSIWYG, you can use them repeatedly instead of only 
applying them to the surfaces that are within the current WYSIWYG 
document.
Note: If a default path is not shown, you must click the browse 
button and navigate to the desired folder. If there is already a 
texture with the same name saved in the location specified, 
WYSIWYG will prompt you to save the file with a new name.

5 Click Next.
Result: The Layer window appears.

6 In the Layer window, select the layers that you want to import. 
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 If there is more than one layer listed, you can select multiple 
layers simultaneously by pressing Ctrl on your keyboard and then 
clicking on the desired layers. 

 For each layer that you want to import, ensure that the Import 
checkbox is checked. If you do not want to import a certain layer, 
highlight it and clear this checkbox. For example, if you have 
drawn both a venue and elements in SketchUp and you have put 
them on separate layers, you can choose to only import a 
particular element into the WYSIWYG file by selecting the 
appropriate layer in this window.

7 To add a description to the layer, enter the information in the Layer 
Description field of the layer.

8 To add metadata to the layer, enter in a descriptive tag in the Tag 
field of the layer.

9 To import a single-sided layer, highlight the layer and select the 
Single Sided checkbox. 
Note: Single-sided layers use less processor time to display in 
Shaded views and to render in the Render Wizard. However, they only 
appear properly in each of these views if the faces of the object are 
drawn facing outward. Unless you know how the SketchUp file was 
drawn, it is recommended that you leave Single Sided deselected by 
default when importing the layers so that the object appears 
correctly. Note that you will not be able to see “through” the walls of 
an imported double-sided venue when you rotate the image around 
in the Shaded view (unlike the WYSIWYG venues, which are single 
sided). 
If the imported object does not appear correctly in the Shaded view, 
you can change its sidedness by using the Properties window. You can 
change it from single sided to double sided, or vice versa. You can 
also flip the object’s sides if the wrong side is currently facing 
outward. For details, see “To change an object’s sidedness”.

10 To add a prefix to selected layers, click Change prefix for selected 
layers... button.
Result: The Change Layer Prefix dialog box appears.

a. In the Change Layer Prefix dialog box, enter in the desired prefix 
you want to add to the selected layers.

b. Click OK.

Result: The selected layers will have the prefix added to the 
layer’s name.
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Note: If a prefix is added to a layer that previously had a prefix 
assigned, the new prefix will override the old prefix.

11 Click Next.
Result: The Component window appears.

12 Blocks in SketchUp are called components. If you have components 
in your drawing, you have the option to ignore them, explode them, 
convert them into a library item, or substitute WYSIWYG fixtures for 
the existing components.
 Component Name: The name of the block.
 Status: This icon  indicates that the block is currently on a layer 

being imported. This icon  indicates that the block is on a layer 
that will not be imported.

 Block Type: This icon  indicates that the block is a singular block 
and does not contain any sub-blocks. This icon  indicates that 
the block is a nested block and contains one or many sub-blocks.
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 Ignore: Select this action to ignore the block. The block will not be 
added to the resulting file.

 Add to Library: Converting a block into a library item imports the 
object and creates a duplicate of it to add to the library for future 
use. To make it available globally, see “To create a custom library 
item”. When you convert SketchUp files into custom library items, 
they appear on the Library tab of the Library Browser within the 
SketchUp folder. 

 Explode: Exploding the component breaks it into its sub-
components. That is, it breaks the block into its components. You 
must be careful of components that are made up of other 
components as WYSIWYG will only explode down one level.

Note:  Exploding is not recommended. Exploding should be your last 
resort to import files, as it is taxing on performance.
 Convert: Converting a component into a fixture replaces the 

SketchUp component with a WYSIWYG fixture of your choice. Once 
you have selected this option, select the ellipsis in the neighboring 
column. 

Result: The Fixture Select window appears.
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13 Select the fixture that you want to use to replace the block. If you 
find that you are always replacing a particular type of component 
with a specific fixture, you can set an option in WYSIWYG so that the 
substitution will automatically occur each time you import the 
component. For example, if you have files in which the ‘PAR64M’ 
block is always a PAR 64 fixture with an MFL bulb, you have the 
option of telling WYSIWYG to automatically import the component in 
that way. To change this option, edit the Import.lst file that is 
created in the Library folder (usually C:\Program Data\CAST 
Software\WYSIWYG\1.xx.xx.x\Library) once the first fixture is set to 
be remembered for future imports.
Note: WYSIWYG creates a pipe for every imported fixture since 
fixtures in WYSIWYG need to hang on a hang structure. If, however, 
fixtures are on a straight pipe represented by a straight line in the 
DWG file, WYSIWYG will convert the entire line into a pipe.
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14 Click Finish.
Result: The Import Summary window appears. 

15 Click OK.

To merge SketchUp files

This procedure merges the SketchUp file into the current WYSIWYG 
document, placing the object in the location you specify. 

Before you begin
You must have the SketchUp file saved on your computer to begin this 
procedure.

1 Open the WYSIWYG file into which you want to add the SketchUp file.

2 From the File menu, choose Merge.
Result: The Merge dialog box appears.

3 In the Merge dialog box, beside the File name box, select SketchUP 
Files (*.skp) from the drop-down list.

4 Locate the location of the SketchUp file on your computer. Select the 
file and click Open.
Result: The Merge dialog box will change asking for a Base point.

5 Select the radio next to the desired Base point.
6 Click OK.
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7 Browse to locate the file, select it, and then click Open.
Result: The Import Directories window appears.

8 Click the browse button to specify the location where you want to 
save the textures that have been applied to the object in SketchUp, 
or accept the default location shown. By saving textures to a folder 
outside of WYSIWYG, you can use them repeatedly instead of only 
applying them to the surfaces that are within the current WYSIWYG 
document.
Note: If a default path is not shown, you must click the browse 
button and navigate to the desired folder. If there is already a 
texture with the same name saved in the location specified, 
WYSIWYG will prompt you to save the file with a new name.

9 Click Next.
Result: The Layer window appears.

10 In the Layer window, select the layers that you want to import. 
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 If there is more than one layer listed, you can select multiple 
layers simultaneously by pressing CTRL on your keyboard and 
then clicking on the desired layers. 

 For each layer that you want to import, ensure that the Import 
checkbox is checked. If you do not want to import a certain layer, 
highlight it and clear this checkbox. For example, if you have 
drawn both a venue and elements in SketchUp and you have put 
them on separate layers, you can choose to only import a 
particular element into the WYSIWYG file by selecting the 
appropriate layer in this window.

11 To add a description to the layer, enter the information in the Layer 
Description field of the layer.

12 To add metadata to the layer, enter in a descriptive tag in the Tag 
field of the layer.

13 To import a single-sided layer, highlight the layer and select the 
Single Sided checkbox. 
Note: Single-sided layers use less processor time to display in 
Shaded views and to render in the Render Wizard. However, they only 
appear properly in each of these views if the faces of the object are 
drawn facing outward. Unless you know how the SketchUp file was 
drawn, it is recommended that you leave Single Sided deselected by 
default when importing the layers so that the object appears 
correctly. Note that you will not be able to see “through” the walls of 
an imported double-sided venue when you rotate the image around 
in the Shaded view (unlike the WYSIWYG venues, which are single 
sided). 
If the imported object does not appear correctly in the Shaded view, 
you can change its sidedness by using the Properties window. You can 
change it from single sided to double sided, or vice versa. You can 
also flip the object’s sides if the wrong side is currently facing 
outward. For details, see “To change an object’s sidedness”.

14 To add a prefix to selected layers, click Change prefix for selected 
layers... button.
Result: The Change Layer Prefix dialog box appears.

a. In the Change Layer Prefix dialog box, enter in the desired prefix 
you want to add to the selected layers.

b. Click OK.

Result: The selected layers will have the prefix added to the layer’s 
name.
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Note: If a prefix is added to a layer that previously had a prefix 
assigned, the new prefix will override the old prefix.

15 Click Next.
Result: The Component window appears.

16 Blocks in SketchUp are called components. If you have components 
in your drawing, you have the option to ignore them, explode them, 
convert them into a library item, or substitute WYSIWYG fixtures for 
the existing components.
 Component Name: The name of the block.
 Status: This icon  indicates that the block is currently on a layer 

being imported. This icon  indicates that the block is on a layer 
that will not be imported.

 Block Type: This icon  indicates that the block is a singular block 
and does not contain any sub-blocks. This icon  indicates that 
the block is a nested block and contains one or many sub-blocks.

 Ignore: Select this action to ignore the block. The block will not be 
added to the resulting file.

 Add to Library: Converting a block into a library item imports the 
object and creates a duplicate of it to add to the library for future 
use. Note that the component will lose all surface properties, such 
as color and texture, and it will only be available in the library of 
the current document. To make it available globally, see “To create 
a custom library item”. When you convert SketchUp files into 
custom library items, they appear on the Library tab of the Library 
Browser within the SketchUp folder. 

 Explode: Exploding the component breaks it into its sub-
components. That is, it breaks the block into its components. You 
must be careful of components that are made up of other 
components as WYSIWYG will only explode down one level.

Note:  Exploding is not recommended. Exploding should be your last 
resort to import the file, as it is taxing on performance.
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 Convert: Converting a component into a fixture replaces the 
SketchUp component with a WYSIWYG fixture of your choice. Once 
you have selected this option, select the ellipsis in the neighboring 
column. 

Result: The Fixture Select window appears.

17 Select the fixture that you want to use to replace the block. If you 
find that you are always replacing a particular type of component 
with a specific fixture, you can set an option in WYSIWYG so that the 
substitution will automatically occur each time you import the 
component. For example, if you have files in which the ‘PAR64M’ 
block is always a PAR 64 fixture with an MFL bulb, you have the 
option of telling WYSIWYG to automatically import the component in 
that way. To change this option, edit the Import.lst file that is 
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created in the Library folder (usually C:\Program Data\CAST 
Software\WYSIWYG\1.xx.xx.x\Library) once the first fixture is set to 
be remembered for future imports.
Note: WYSIWYG creates a pipe for every imported fixture since 
fixtures in WYSIWYG need to hang on a hang structure. If, however, 
fixtures are on a straight pipe represented by a straight line in the 
DWG file, WYSIWYG will convert the entire line into a pipe.

18 Click Finish.
Result: The Merge Summary window appears. 

19 Click OK.
20 If you chose Select Basepoint with mouse in Step 5, click to place the 

object in the drawing.

Importing .DWG/.DXF files 

When importing a .DWG/.DXF file into WYSIWYG, you have two options:

 You can open a .DWG/.DXF file.
 You can merge a .DWG/.DXF file into an existing WYSIWYG 

document.

If you open a .DWG or .DXF while another show document is currently 
open, you are prompted to save changes to that document before 
another show document is opened. Only one show document may be 
open at a time. When you merge documents, it enables you to add the 
contents of the .DWG or .DXF file to the contents of the current 
document.

3D solids contained within an AutoCAD file are automatically placed 
inside blocks by AutoCAD. When you import any file that contains a 
block, WYSIWYG will automatically explode the blocks in the DXF or DWG 
files for you if you decide to do this before opening them in WYSIWYG. 

Note: WYSIWYG supports .dwg or .dxf files from AutoCAD version 2018 
format and earlier at the time of this release.
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Entities that can be imported
The DWG/DXF entities that can be imported are detailed in the following 
table. The resulting WYSIWYG objects are also shown.

DWG/DXF entity WYSIWYG object

Circle Circle

Point Point

Arc Arc

Line Line

Leader Line and Text

MLeader Line and Text

Ellipse Circle or line*

2D Polyline Line

3D Polyline Line

Mline Line

Spline (see Note) Spline or Line

Text Text

MText Group of text items

Polyface Mesh (PFACE) Set piece

Polygon Mesh (3D 
Surfaces)

Set piece

Face (3D Face) Surface

Aligned dimension Dimension

Rotated dimension Dimension

Region Surface

Cylinder Cylinder

Sphere Sphere

Cone Cone

Box Riser

Planar Surface Surface

Revolved Surface Set Piece

Helix Line

Lines with bulges Lines and Arcs
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* A closed AutoCAD ellipse will be imported as a circle; otherwise, it is 
imported as a multi-segment line.

Entities that can be imported as a library item
 Circle
 Arc
 Line
 2D Polyline
 3D Polyline
 Polyline
 Mline
 Polyface Mesh (PFACE)
 Polygon Mesh (3D Surfaces)
 Face (3D Face)

 Spline
 Ellipse
 Revolved Surface
 Helix
 Text and MText (See Note) 

Note: Text and MText entities in blocks are not integrated directly into 
library items (a feature WYSIWYG does not support). However, a copy of 
each Text or MText entity is extracted from the block and inserted into 
WYSIWYG document as a text label. Attributes are substituted.

Limitations
 Multilines becomes single lines.
 Multiline text becomes a group of individual text items, with each line 

represented by its own item. 

Note: The formatting for each line is taken from that of the first 
character of the line, except in the case of bullets, in which case the first 
character after the bullet point is used.

 Segments that are not straight (for example, arcs) become straight 
line segments. 

 A spline must contain “Fit” data for it to be imported. When a Spline 
is initially drawn in AutoCAD, it is defined by a series of user-
provided Fit Points, which are automatically converted to Control 
Points by AutoCAD. To import Splines into WYSIWYG properly, you 
must maintain the Fit Points that define the Spline. If the Spline is 

Attribute Text Text Label (with attributes 
substituted)

DWG/DXF entity WYSIWYG object
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defined only by Control Points, it will import into WYSIWYG as a 
regular line, with additional points to help follow the curvature.

 Stretched (scaled) blocks are not supported.
 Blocks to be converted to library items cannot imbed other blocks.
 Blocks to be replaced by a fixture cannot imbed other blocks.
Tips: 
 Do not import 2D/3D solids whenever possible. Instead, use 3D Face 

and 3D Surface entities.
 It is recommended that you explode Polyface Mesh or Polygon Mesh 

entities in AutoCAD before importing to WYSIWYG so you can access 
each face in WYSIWYG.

Opening a DWG/DXF document

Before you begin
 Clean up the CAD file by removing all unnecessary layers, such as 

doors, windows, and architectural details. Generally you want to 
remove items that you do not need to see or will not use in the plot.

 Use the Purge command in AutoCAD to remove layers, blocks, and so 
on, that are not wanted or needed. You may want to do this several 
times since layers and blocks are sometimes linked to other parts of 
the drawing, and the Purge command might not pick them up the 
first time. The more unwanted items you can remove, the smaller 
the file size will be, and the easier/faster it is to import.

To open a DWG/DXF document

This procedure creates a new WYSIWYG document from the imported 
DWG/DXF file. If you are already working in a document, you are 
prompted to save any changes and close the document before you 
import the file into WYSIWYG. 

1 From the File menu, choose Open.

2 From the files of type box, select the DWG or DXF type. Files of this 
type appear in the browser window.
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3 In the browser, click the file name, and then click Open. 
Result: The Pre-Processing Options window appears.

4 In the Pre-Processing Options window, you can specify which DWG/DXF 
blocks and non-block entities are converted into Library items.
a. From the Define Content section, choose which layers and items 

will be converted into your drawing. 

 Select the Import All radio button to include in the import, all 
blocks, block references, all non-block items and layers for 
conversion into your drawing. You can import all entities in one 
pass if you select this option.

 Select the Only import Blocks radio button to include in the 
import, only items that are blocks and block references for 
conversion into your drawing. You can import one or more 
times selecting different sets of blocks if you select this option.

 Select the Only import non-block entities to exclude from the 
import, all items that are blocks and block references. You can 
import only once if you select this option.

b. From the Number of Segments per Mesh drop-down menu in the 
Mesh Segments section, choose the number of segments that will 
affect how the Library Items and Set Pieces are converted into 
your drawing. Blocks with higher number of segments consume 
more memory which affect the performance of your computer 
hardware.
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c. Click Next.
Result: The Working dialog box appears showing the Pre-processing 
progress bar, and then the Scale window appears.

5 Select the unit type used in the DWG/DXF drawing. 
6 Click Next.

Result: The Layer window appears.

7 Highlight the layers that you want to import. Note that you do not 
need to import all the layers at once. Refer to “Importing scenario” 
for suggestions on how to import the various layers. For each layer 
that you want to import, ensure that the Import checkbox is checked. 
If you do not want to import a certain layer, highlight it and clear this 
checkbox. 
Note: In the Layer window, the State column shows the state of the 
layer in the DWG/DXF file. Frozen layers are not selected for import 
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by default. Off layers are selected but will be set to Not Visible in 
WYSIWYG after import.

8 To add a description to the layer, enter the information in the Layer 
Description field of the layer.

9 To add metadata to the layer, enter in a descriptive tag in the Tag 
field of the layer.

10 To add a prefix to selected layers, click Add/Edit prefix for selected 
layers... button.
Result: The Change Layer Prefix dialog box appears.

a. In the Change Layer Prefix dialog box, enter in the desired prefix 
you want to add to the selected layers.

b. Click OK.

Result: The selected layers will have the prefix added to the 
layer’s name.

Note: If a prefix is added to a layer that previously had a prefix 
assigned, the new prefix will override the old prefix.
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11 Click Next.
Result: The Block window appears.

12 If you have blocks in your drawing, you have the option to ignore the 
blocks, explode the blocks, convert them into a library item, or 
substitute WYSIWYG fixtures for the existing blocks.
Note: 3D solids are automatically placed inside blocks by AutoCAD, 
and assigned an abstract block name (for example, *X1). The 
number of “blocks” that are found are dependent on the number of 
solids that were in the AutoCAD file. You will be prompted to 
determine what action to take for each type of “block.”
 Block Name: The name of the block.
 Status: This icon  indicates that the block is currently on a layer 

being imported. This icon  indicates that the block is on a layer 
that will not be imported.

 Type: This icon  indicates that the block is a singular block and 
does not contain any sub-blocks. This icon  indicates that the 
block is a nested block and contains one or many sub-blocks.

 Ignore: Select this action to ignore the block. The block will not be 
added to the resulting file.

 Add to Library: Converting a block into a library item imports the 
object and creates a duplicate of it to add to the library for future 
use. Note that the component will lose all surface properties, such 
as color and texture, and it will only be available in the library of 
the current document. To make it available globally, see “To create 
a custom library item”. When you convert DWG or DXF files into 
custom library items, they appear on the Library tab of the Library 
Browser within the DWG or DXF folder. 
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 Explode: Exploding the component breaks it into its sub-
components. That is, it breaks the block into its components. You 
must be careful of components that are made up of other 
components as WYSIWYG will only explode down one level.

Note:  Exploding is not recommended. Exploding should be your last 
resort to import the file, as it is taxing on performance.
 Convert: Converting a component into a fixture replaces the DWG/

DXF component with a WYSIWYG fixture of your choice. Once you 
have selected this option, select the ellipsis in the neighboring 
column. 

Result: The Fixture Select dialog box appears.
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13 Select the fixture that you want to use to replace the block. If you 
find that you are always replacing a particular type of component 
with a specific fixture, you can set an option in WYSIWYG so that the 
substitution will automatically occur each time you import the 
component. For example, if you have files in which the ‘PAR64M’ 
block is always a PAR 64 fixture with an MFL bulb, you have the 
option of telling WYSIWYG to automatically import the component in 
that way. To change this option, edit the Import.lst file that is 
created in the Library folder (usually C:\Program Data\CAST 
Software\WYSIWYG\1.xx.xx.x\Library) once the first fixture is set to 
be remembered for future imports.
Note: WYSIWYG creates a pipe for every imported fixture since 
fixtures in WYSIWYG need to hang on a hang structure. If, however, 
fixtures are on a straight pipe represented by a straight line in the 
DWG file, WYSIWYG will convert the entire line into a pipe.

14 Click Advanced Block Options to filter objects within the block based on 
their layer. 
Result: The Advanced Block Options dialog box appears.

Use the drop-down menu to control how the contents of incoming 
Blocks should be handled based on the layers on which the Blocks’ 
components reside.

 Ignore Frozen and Off Layers (Recommended): This is the preferred 
option in most cases, since it offers the best optimization for the 
import: no parts of Blocks that are on layers which have been 
turned Off and/or Frozen will be imported. Once the import is 
complete, what you see will most-closely match what is seen 
when this file is opened in AutoCAD or DWG TrueView—with the 
exception of DWG entities that cannot be imported at this time. 
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(Use the radio buttons in the Empty Library Item Options section 
to control how to deal with such entities.)

 Ignore Only Frozen Layers: Choosing not to import parts of Blocks 
that are on layers which have been Frozen will skip those parts, 
but parts that are on layers which have been turned Off will 
import. This will lead to a potentially more complete, but also 
more complex model—but entities that cannot be imported at this 
time will still not import. It is important to remember that if you 
chose to convert such Blocks to DWG Library Items, you will have 
no control over them: you will not be able to “edit” the DWG 
Library Item in order to “remove” from it the parts which were 
imported from the layers that were Turned Off.

 Ignore All Layers Not Being Imported: This option offers layer-based 
control over which parts of a Block should be ignored for import: 
entities which exist on layers that you have chosen not to import 
(in the previous step of the DWG/DXF Import Wizard) will not 
import. It is recommended that you only select this option if you 
are very familiar with the contents of the file you are importing 
AND when you are performing a “multi-pass” import (i.e. 
importing the same file multiple times, with different options and/
or with only handful layers at a time).

 Import Everything (All Layers): This option should only be used when 
the previous options fail to yield the desired import result, and 
should (ideally) only be chosen when a single Block, or only a 
handful of Blocks, are selected for import; while it will lead to a 
complete import (with the exception of DWG entities that cannot 
be imported at this time), the resulting model (DWG Library 
Item) may look altogether different than what you see when you 
open the file in AutoCAD or DWG TrueView. In addition, the 
model may end up being very complex, which can lead to 
performance issues. Use this option with caution, and, ideally, 
only when performing a “multi-pass” import.

 Extract Block text as Text Labels when converting to a Library Item: Since 
WYSIWYG’s Library Items cannot contain text, Text or MText 
objects contained within Blocks being imported would have to be 
discarded; select this option (recommended) in order to extract 
text from such Blocks and add it to the resulting .wyg file as a 
Text Label object. 

 Empty Library Item Options: Use the radio buttons in this section to 
control what will happen with Blocks which only contain entities 
that cannot be imported, if you choose to convert them to DWG 
Library Items; these options will not affect DWG Blocks that you 
have chosen to Explode.

 Allow Blocks to convert to empty Library Items: This option will 
allow such blocks to convert into empty/”zero-length” DWG 
Library Items. You will not be able to select them, and 
inserting them will result in a non-selectable item. Not 
recommended.
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 Use placeholder geometry for empty library items: This option 
(recommended) will replace entities contained in such Blocks 
with a 1m “Spike” DWG Library Item. 

 Rename library items with placeholder geometry: Enable this 
checkbox to add a “PH” prefix to all such DWG Library Items.

 Remove empty library items: When this option is selected, all 
such Blocks will be ignored: no empty Library Items will be 
created, but at the same time, there will be no indication 
whatsoever that something was supposed to be there. Only 
select this option if you are sure that you do not require that 
information.

a. Click OK to apply the set options and close the Advanced Block 
Options dialog box.

15 Click Finish.
Result: The Import Summary window appears. 

16 Click OK.

The CAD Importing Guide
For more detailed information about importing DWG/DXF files, please 
read through the CAD Importing Guide, at                                          
http://cast-soft.com/wysiwyg/cad-importing-guide/.

Merging a DWG/DXF document

To merge a DWG/DXF document

This procedure inserts the imported DWG/DXF file into an existing 
WYSIWYG document in the location of your choice. 

1 From the File menu, choose Merge.

Result: The Merge window opens.

2 In the Merge window, beside the File name box, select DWG or DXF 
Files (*.dwg or .dxf) from the drop-down list.
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3 Locate the location of the DWG file on your computer. Select the file 
and click Open.
Result: The Merge dialog box appears asking for a Base point.

4 Select the radio next to the desired Base point.
5 Click OK.

Result: The Pre-Processing Options window appears.

6 In the Pre-Processing Options window, you can specify which DWG/DXF 
blocks and non-block entities are converted into Library items.
a. From the Define Content section, choose which layers and items 

will be converted into your drawing. 

 Select the Import All radio button to include in the import, all 
blocks, block references, all non-block items and layers for 
conversion into your drawing. You can import everything in one 
pass if you select this option.

 Select the Only import Blocks radio button to include in the 
import, only items that are blocks and block references for 
conversion into your drawing. You can import one or more 
times selecting different sets of blocks if you select this option.

 Select the Only import non-block entities to exclude from the 
import, all items that are blocks and block references. You can 
only import once if you select this option.
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b. From the Number of Segments per Mesh drop-down menu in the 
Mesh Segments section, choose the number of segments that will 
affect how the Library Items and Set Pieces are converted into 
your drawing. Blocks with higher number of segments consume 
more memory which affect the performance of your computer 
hardware.

c. Click Next.
Result: The Working dialog box appears showing the Pre-processing 
progress bar, and then the Scale window appears.

7 Select the unit type used in the DWG/DXF drawing, and then click 
Next.
Result: The Layer window appears.

8 Highlight the layers that you want to import. Note that you do not 
need to import all the layers at once. Refer to “Importing scenario” 
for suggestions on how to import the various layers. For each layer 
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that you want to import, ensure that the Import checkbox is checked. 
If you do not want to import a certain layer, highlight it and clear this 
checkbox. 
Note: In the Layer window, the State column shows the state of the 
layer in the DWG/DXF file. Frozen layers are not selected for import 
by default. Off layers are selected but will be set to Not Visible in 
WYSIWYG after import.

9 To add a description to the layer, enter the information in the Layer 
Description field of the layer.

10 To add metadata to the layer, enter in a descriptive tag in the Tag 
field of the layer.

11 To add a prefix to selected layers, click Add/Edit prefix for selected 
layers... button.
Result: The Change Layer Prefix dialog box appears.

a. In the Change Layer Prefix dialog box, enter in the desired prefix 
you want to add to the selected layers.

b. Click OK.

Result: The selected layers will have the prefix added to the layer’s 
name.
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12 Click Next.
Result: The Block window appears.

13 If you have blocks in your drawing, you have the option to ignore the 
blocks, explode the blocks, convert them into a library item, or 
substitute WYSIWYG fixtures for the existing blocks.
Note: 3D solids are automatically placed inside blocks by AutoCAD, 
and assigned an abstract block name (for example, *X1). The 
number of “blocks” that are found are dependent on the number of 
solids that were in the AutoCAD file. You will be prompted to 
determine what action to take for each type of “block.”
 Block Name: The name of the block.
 Status: This icon  indicates that the block is currently on a layer 

being imported. This icon  indicates that the block is on a layer 
that will not be imported.

 Type: This icon  indicates that the block is a singular block and 
does not contain any sub-blocks. This icon  indicates that the 
block is a nested block and contains one or many sub-blocks.

 Ignore: Select this action to ignore the block. The block will not be 
added to the resulting file.

 Add to Library: Converting a block into a library item imports the 
object and creates a duplicate of it to add to the library for future 
use. Note that the component will lose all surface properties, such 
as color and texture, and it will only be available in the library of 
the current document. To make it available globally, see “To create 
a custom library item”. When you convert DWG or DXF files into 
custom library items, they appear on the Library tab of the Library 
Browser within the DWG or DXF folder. 
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 Explode: Exploding the component breaks it into its sub-
components. That is, it breaks the block into its components. You 
must be careful of components that are made up of other 
components as WYSIWYG will only explode down one level.

Note: Exploding is not recommended. Exploding should be your last 
resort to import the file, as it is taxing on performance.
 Convert: Converting a component into a fixture replaces the DWG/

DXF component with a WYSIWYG fixture of your choice. Once you 
have selected this option, select the ellipsis in the neighboring 
column. 

Result: The Fixture Select window appears.

14 Select the fixture that you want to use to replace the block. If you 
find that you are always replacing a particular type of component 
with a specific fixture, you can set an option in WYSIWYG so that the 
substitution will automatically occur each time you import the 
component. For example, if you have files in which the ‘PAR64M’ 
block is always a PAR 64 fixture with an MFL bulb, you have the 
option of telling WYSIWYG to automatically import the component in 
that way. To change this option, edit the Import.lst file that is 
created in the Library folder (usually C:\Program Data\CAST 
Software\WYSIWYG\1.xx.xx.x\Library) once the first fixture is set to 
be remembered for future imports.
Note: WYSIWYG creates a pipe for every imported fixture since 
fixtures in WYSIWYG need to hang on a hang structure. If, however, 
fixtures are on a straight pipe represented by a straight line in the 
DWG/DXF file, WYSIWYG will convert the entire line into a pipe.
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15 Click Advanced Block Options to filter objects within the block based on 
their layer.
Result: The Advanced Block Options dialog box appears.

Use the drop-down menu to control how the contents of incoming 
Blocks should be handled based on the layers on which the Blocks’ 
components reside.

 Ignore Frozen and Off Layers (Recommended): This is the preferred 
option in most cases, since it offers the best optimization for the 
import: no parts of Blocks that are on layers which have been 
turned Off and/or Frozen will be imported. Once the import is 
complete, what you see will most-closely match what is seen 
when this file is opened in AutoCAD or DWG TrueView—with the 
exception of DWG entities that cannot be imported at this time. 
(Use the radio buttons in the Empty Library Item Options section 
to control how to deal with such entities.)

 Ignore Only Frozen Layers: Choosing not to import parts of Blocks 
that are on layers which have been Frozen will skip those parts, 
but parts that are on layers which have been turned Off will 
import. This will lead to a potentially more complete, but also 
more complex model—but entities that cannot be imported at this 
time will still not import. It is important to remember that if you 
chose to convert such Blocks to DWG Library Items, you will have 
no control over them: you will not be able to “edit” the DWG 
Library Item in order to “remove” from it the parts which were 
imported from the layers that were Turned Off.

 Ignore All Layers Not Being Imported: This option offers layer-based 
control over which parts of a Block should be ignored for import: 
entities which exist on layers that you have chosen not to import 
(in the previous step of the DWG/DXF Import Wizard) will not 
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import. It is recommended that you only select this option if you 
are very familiar with the contents of the file you are importing 
AND when you are performing a “multi-pass” import (i.e. 
importing the same file multiple times, with different options and/
or with only handful layers at a time).

 Import Everything (All Layers): This option should only be used when 
the previous options fail to yield the desired import result, and 
should (ideally) only be chosen when a single Block, or only a 
handful of Blocks, are selected for import; while it will lead to a 
complete import (with the exception of DWG entities that cannot 
be imported at this time), the resulting model (DWG Library 
Item) may look altogether different than what you see when you 
open the file in AutoCAD or DWG TrueView. In addition, the 
model may end up being very complex, which can lead to 
performance issues. Use this option with caution, and, ideally, 
only when performing a “multi-pass” import.

 Extract Block text as Text Labels when converting to a Library Item: Since 
WYSIWYG’s Library Items cannot contain text, Text or MText 
objects contained within Blocks being imported would have to be 
discarded; select this option (recommended) in order to extract 
text from such Blocks and add it to the resulting .wyg file as a 
Text Label object. 

 Empty Library Item Options: Use the radio buttons in this section to 
control what will happen with Blocks which only contain entities 
that cannot be imported, if you choose to convert them to DWG 
Library Items; these options will not affect DWG Blocks that you 
have chosen to Explode.

 Allow Blocks to convert to empty Library Items: This option will 
allow such blocks to convert into empty/”zero-length” DWG 
Library Items. You will not be able to select them, and 
inserting them will result in a non-selectable item. Not 
recommended.

 Use placeholder geometry for empty library items: This option 
(recommended) will replace entities contained in such Blocks 
with a 1m “Spike” DWG Library Item. 

 Rename library items with placeholder geometry: Enable this 
checkbox to add a “PH” prefix to all such DWG Library Items.

 Remove empty library items: When this option is selected, all 
such Blocks will be ignored: no empty Library Items will be 
created, but at the same time, there will be no indication 
whatsoever that something was supposed to be there. Only 
select this option if you are sure that you do not require that 
information.

a. Click OK to apply the set options and close the Advanced Block 
Options dialog box.
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16 Click Finish.
Result: The Merge Summary window appears. 

17 Click OK.

The CAD Importing Guide
For more detailed information about importing DWG/DXF files, please 
read through the CAD Importing Guide, at                                         
http://cast-soft.com/wysiwyg/cad-importing-guide/.

Importing scenario

You do not need to import everything in your file at once. You can import 
items one by one or separately to ensure accuracy. The following 
scenario may help you when importing DWG/DXF files into WYSIWYG:

1. After choosing to open a DWG/DXF file, switch to the Layers tab in the 
Select DWG Settings dialog box. In this tab, you can clear the layers 
that you do not want imported in the first round. For example, you 
may only want to import the venue and all the layers related to it. In 
the case of a 2D CAD drawing, it is easier to extrude lines into walls 
and do everything else needed to complete the virtual venue. It will 
also be quicker as WYSIWYG will have a lot less objects with which to 
work.

2. Once you have completed working on the venue, you may want to 
merge in the hang structures if they exist in the CAD file. Using the 
Merge command from the File menu, you can open the same CAD file 
once again, and choose the appropriate layer(s) from the Layers tab. 
When WYSIWYG asks you to pick the insertion point, make sure you 
select Use 0,0,0 as Basepoint. This will ensure that everything in the 
new layer is placed accurately in the WYSIWYG plot.

3. Continue in the same manner with fixtures and the other objects. 
Note that if in the CAD file the fixtures exist on different layers, you 
may want to bring these in separately/one by one as well.
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Exporting DWG/DXF files

If you need to send your WYSIWYG drawings to someone using another 
drafting program, you can export your file to the DWG or DXF file type. 
DWG and DXF formats are used to transfer documents to AutoCAD or 
other compatible drafting applications. 

Entities that can be exported
 2D DWG/DXF: When you export WYSIWYG objects to a 2D DWG/

DXF file, all objects, including fixture attributes, are converted to 
lines.

 3D DWG/DXF: The objects that can be exported to a 3D DWG/DXF 
file and the resulting DWG/DXF entities are shown in the following 
table. Fixture attributes cannot be exported to 3D DWG/DXF.

Note: You cannot export truss.

Limitation
 The slope near the end of two lines may be slightly off.

To export to DWG/DXF in 2D

Note: When you export WYSIWYG objects to a 2D DWG/DXF file, all 
objects, including fixture attributes, are converted to lines.

WYSIWYG object DWG/DXF entity

Line 3D Polyline

Spline Spline

Point Point

Circle Circle

Arc Arc

Text Text

Pipe Line

Rigging Point (3D) Block - line, circle, text

Dimension Lines and MText

Callout Leader

All other objects PolyFace Mesh
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1 From the File menu, choose 2D DWG/DXF Export.

2 In the Export dialog box, navigate to the location where you want to 
save the exported file. Ensure that the destination appears in the 
Save in drop-down box.

3 In the File name box, type the name of the exported file.
4 From the Save as type drop-down box, choose the exported file type. 

There are a number of choices available for file type, based on 
AutoCAD versions.

5 Click Save. 
Result: The Select DXF/DWG Settings For Export dialog box appears.

6 On the Scale tab, click the option button for the units to be used in 
the DWG/DXF drawing.
a. To specify a custom unit of measurement, select the Custom 

option button. 
b. In the DXF Unit To boxes, specify the mapping of the units of 

measurement to use in the exported file.

7 Click OK.
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Note: The current type of the drawing will be used as the point of view in 
the exported 2D drawing.

To export to DWG/DXF in 3D

Note: When you export WYSIWYG objects to a 3D DWG/DXF file, the 
resulting DWG/DXG entities vary. For details, see the table on “Exporting 
DWG/DXF files”.

1 From the File menu, choose DWG/DXF Export.

2 In the Export dialog box, navigate to the location where you want to 
save the exported file. Ensure that the destination appears in the 
Save in drop-down box.

3 In the File name box, type the name of the exported file.
4 From the Save as type drop-down box, choose the exported file type. 

There are a number of choices available for file type, based on 
AutoCAD versions.
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5 Click Save. 
Result: The Select DXF/DWG Settings For Export dialog box appears.

 

Note: You cannot export a 3D drawing from WYSIWYG Report.
6 On the Scale tab, click the option button for the units to be used in 

the DWG/DXF drawing.
 To specify a custom unit of measurement, select the Custom 

option button, and then specify the mapping of the units of 
measurement to use in the exported file, in the DXF Unit To boxes.

7 Click the Layer tab. 

8 Select the layers that you want to include in the DWG/DXF drawing 
by highlighting them and ensuring that the Export checkbox is 
checked.
a. Click Select All to select all the layers that are listed. 

b. Click Select None to deselect all layers. 
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9 Click OK.

Importing Wavefront/Filmbox/Collada2/3DS files

WYSIWYG allows the import of models created with Wavefront (.OBJ), 
Filmbox (.FBX), Collada (.DAE) and 3D Studio Max (.3DS) for use in 
WYSIWYG. These models will be imported as one object, and their 
colors, texturing and materials will be preserved in the import.

Note: Any properties which are not supported by WYSIWYG will be lost 
from the model on import.

To import Wavefront (.OBJ) / Collada (.DAE) / Filmbox 
(.FBX) / 3D Studio (.3DS) files

Note: This procedure creates a new WYSIWYG document from the 
imported object file. If you are already working in a document, you are 
prompted to save any changes and close the document before you 
import the file into WYSIWYG. 

1 From the File menu, choose Open.

Result: The Import window appears.

2 In the Import window, from the File Type drop-down menu, select the 
desired file type you want to import. Files of this type will be visible 
in the window.
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3 Navigate to the desired file, click the file name, and then click Open.
Result: The Scale window appears.

4 Click the The Model was drawn in a 3D software where drop-down menu 
and select one of the following that describes how the software in 
which the object was drawn defines its 3D space. 
Note: If you do not have this information, inquire with the person 
who created the model you are importing, or view the model in a 
model viewer such as in order to determine its orientation. You may 
also leave this option at its default (Z-axis points up) and if the 
object is not oriented correctly once imported, Rotate it as required.
 Z - axis points up
 Y - axis points up

5 Click the The Model’s Base Point should be located drop-down menu and 
select one of the following that describes where the base point of the 
object should be:
 Bottom - Center
 Center of Model
a. To have the insertion point of the model act instead as the base 

point, select the Move Model Base Point to Insertion Point checkbox.
6 In the Model is in the following Scale section, select the radio 

next to the scale you want to use for the model.
a. If Auto-Scale was selected, select the checkbox under the Auto-

Scale radio to change how the object will be auto-scaled. Edit the 
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auto scale as desired by editing the following fields/drop-down 
menus next to the radio:
 Scale Model to a length of [number] [units of measure] along the 

model’s [axis/side of model]
7 Select the Mesh Decimation checkbox to reduce the number of 

polygons in the model based on the original model.
a. Select from the drop-down menu the percentage of polygons to 

reduce.
8 Click Finish.

Result: The Import Summary window appears. 

9 Click OK.
Result: The object will be imported into WYSIWYG

Importing floorplans

If you have an existing floorplan saved in bitmap (.bmp), JPEG (.jpg), 
GIF (.gif), TIFF (.tif), PNG (.png), Targa (.tga) or Portable Document 
Format (.pdf), you can import it into your drawing using the Floorplan 
Importing Wizard, and then use WYSIWYG's Drawing Tools to "trace" it 
and, in so doing, create a 2D, then a 3D model of the venue in the 
floorplan. 

You can import floorplan images in 3 view types:

 Plan: Floorplan images in Plan view can be imported into Wireframe 
that is set to Plan View Type.

 Front/Back: Floorplan images in Front or Back profile views can be 
imported into Wireframe that is set to the Front or Back View Type. 

 Left/Right: Floorplan images in Left or Right profile views can be 
imported into Wireframe that is set to the Left or Right View Type. 
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Notes: 

 You can print with Imported Floorplans from CAD mode Wireframe, 
New Plots and Layouts in Presentation mode.

Attention: Imported floorplans are a purely visual feature without 
any guarantee of accuracy and precision in the printed document. 
When printing a floorplan, a Warning dialog box appears asking for 
you to acknowledge that there are no guarantees about the 
content, accuracy, precision, or anything else in the printed 
document and that you will not hold CAST responsible for any 
errors or inaccuracies in the document. Select the checkbox and 
click OK to proceed.

 The images in the profile views allow you to import wall outlines for 
the room that you are building in your 2D drawing.

Before you begin

Before you import a floorplan, you must know the precise dimensions of 
at least one of the elements in your imported floorplan. For example, if it 
contains a stage, note the width of the stage before you import the 
graphic into your drawing. The floorplan should also be to scale.

To import a floorplan

1 In either the Wireframe or Quad tab, in Plan view, click File > Import 
Floorplan....

or, in Front or Back view, click File > Import Floorplan... > Front/Back



262

CAD mode - Creating Objects  R42

or, in Left or Right view, click File > Import Floorplan... > Left/Right.

Result: The Floorplan Importing Wizard window appears.

2 In the window click Browse.
Result: The File Browser window appears.

3 In the File Browser window, navigate to your floorplan file, select it, 
and then click Open. 
Result: The file browser window will close. The location of the 
floorplan image will be in the Browse field.
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4 Click Next.
Result: The wizard will switch to the Rotate Floorplan page. Here the 
floorplan image can be rotated 0°, 90°, 180° or 270°.
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5 Select the angle of rotation for the floorplan, then click Next.
Result: The wizard will switch to the Define Anchor Point page. You can 
select from predefined anchor points or create your own.

6 From the Anchor drop-down menu, select the anchor point of the 
floorplan. 
a. If a custom anchor point was selected, click a point in the floor 

plan to create the anchor point. 
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7 Click Next.
Result: The wizard will switch to the Define Insertion Base Point page. 
The anchor can be inserted at either the origin or a user selected 
point.

8 Define the insertion base point, then click Next.
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a. If a user selected point was chosen, the wizard window will 
minimize. Click on a point in the WYSIWYG file where you want 
the insertion point to be.

Result: The wizard will switch to the Specify Floorplan Scale page. Here 
a dimension line is drawn between two points of the floorplan to 
determine its scale.

9 Ortho X and/or Ortho Y can be enabled to ensure any dimension line 
drawn is parallel with the respective axis.
Note:  This step can be skipped if you are modifying a previously 
imported floor plan, by selecting the box next to Skip this Step....

10 Click Next.
Result: The window will minimize and show the floorplan inserted 
into WYSIWYG.

11 In the floorplan image, choose an item in your drawing whose 
measurements you know, and then click on one end of the item. For 
example, if you know the dimensions of the stage, click on one 
corner of it.
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12 Click on a second end of the item. For example, if you had clicked on 
one edge of the stage, click on an opposite edge of it.

Result: The Import Floorplan window will reappear, prompting you to 
enter the length of the line that you have just drawn.
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13 Type the length of the line, and then click Next.
Result: WYSIWYG adjusts the size of the floorplan based on the 
scale that you have entered to ensure that your drawing is accurate. 
The floorplan appears in your drawing in plan view (the only view in 
which you can see it).

14 Click Finish to finish editing the floorplan. Click Back to change any of 
the previous settings.
Tips: 
 Once you import the floorplan, you can hide it from sight by right-

clicking on your drawing and selecting Hide Floorplan. To show the 
floorplan again, simply right-click and select Show Floorplan. 

 To modify the properties of the floorplan after it has been inserted, 
right-click the floorplan image and select Modify Floorplan.

Note: You can delete floorplans, but once deleted, the floorplan must be 
re-imported in order for it to be available once again. Since this process 
may affect the measurements set in the above procedures, it is 
recommended that you only delete floorplans once your show is 
“finalized".
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Importing fixtures

Fixture information listed in a spreadsheet file (CSV, XLS, XLSX) that was 
exported from other software and/or lighting consoles can be imported 
into your drawing using the Fixture Import wizard. The fixture objects 
listed in the spreadsheet will be inserted into your drawing according to 
the settings that were included in the spreadsheet. 

Fixture Import option enables you:

 To define the file for import and the unit type.
 To map your file’s column headers to match the appropriate 

WYSIWYG fixture property (e.g. Fixture type, position X Y Z, rotation 
Rx Ry Rz, Fixture ID, patch, channel, etc.)

 To match fixtures that are not recognized with the corresponding 
fixtures from the WYSIWYG Library.

To import fixtures

1 In either the Wireframe or Quad tab (not in Shaded view), click File > 
Import Fixtures...

Result: The Fixture Import window appears.

2 In the Fixture Import section, click the ellipsis button to browse and 
select the spreadsheet file with the fixture data you wish to import.

3 The file location that was selected will be displayed in the Fixture 
Import box.

4 Select the Treat first row as column headers checkbox if you want the 
first row of your spreadsheet to be displayed as the column headers.

5 In the Spreadsheet is in section, click the radio button to choose which 
unit of measurement were used in your spreadsheet.
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6 Click Next to continue.
Result: The Fixture Import Preview window appears with the fixture 
data in the table.

7 In the row at the top indicated with the blue arrow, click the drop-
down arrows in each column to map your spreadsheet headers to the 
appropriate WYSIWYG column headers. For example, starting with 
the Type drop-down menu, click to make sure that the matching 
header is selected. Proceed through each of the columns to map all 
the headers of columns that you wish to import. 
Notes: 
 For any column that you do not wish to import, set the drop-down 

menu to Ignore.

 Only fixtures with checked boxes will be imported. Columns are 
highlighted in pink color if the data listed are not recognized and 
do not match with information in WYSIWYG.
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a. To correct the invalid data, click on the highlighted cell(s) and 
type to change the value, or click on the ellipsis button to browse 
the selected fixture attribute.

Result: The Library Browser dialog box appears.

b. In the Library Browser dialog box, browse and choose the object 
and settings to match the selected fixture that will be imported.

c. In the Library Browser dialog box, click Insert.
Result: The WYSIWYG confirmation dialog box appears where 
you may choose to replace all instances of the selected fixture 
type.

d. Click Yes. 
Result: The fixture data in the spreadsheet is replaced with settings 
that match the WYSIWYG Library. All selected rows (checkbox in the 
left-most column) must have valid information to proceed with the 
import process. 

8 You can ignore any fixtures or objects in the spreadsheet and 
proceed with the import. Click Uncheck Invalid Fixtures to select only 
the valid fixtures without error settings. 

9 Click Select All to choose and import all the fixtures listed in the table.
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10 Click Select None to clear all the fixtures and import none.
Note: In the Fixture Import Preview window, error messages indicating 
conflicts are displayed in red text, and the table columns with the 
unrecognized fixture data are highlighted in pink color. The values in 
the rows can be changed to resolve conflicts.

11 Click Finish.
Result: The fixtures will be inserted in your drawing in the specified 
layout and with all the settings in the spreadsheet.
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The Library Browser

Introduction

An essential component of WYSIWYG is its extensive library. You can 
browse the contents of the library in the Library Browser, choosing from a 
multitude of 3D objects to add to your plots. 

Working with the Library Browser

The Library Browser is dockable, which means that it has a grab bar on the 
top that is used to move it around the screen. You can place it on the 
edges of the work area, at the top, bottom, left, or right. You can also 
drag it off the edge of the work area and into its own window. This 
window remains on top of the WYSIWYG screen and may be dragged 
anywhere.

Note: If you experience difficulty undocking the browser, hold down the 
CTRL key while dragging the grab bar.
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To open the Library Browser

1 From the Library menu, choose Browse Library.

Tip: You can also click the Library on the Draw toolbar.
Note: You can also access the Library Browser from the Options menu 
on the Welcome window when a document is not opened.

2 Click any of the tabs along the bottom of the browser window to view 
the contents of different sections of the library. The library is divided 
into the following sections:

 Fixtures

 Accessories

 Truss

 Library Items (scenic)

 Symbols
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 Gel (color)

 Gobos

 Lamps

 Lenses

Library entries are divided into sort criteria. These criteria may be 
organized alphabetically, by manufacturer, by type, or by other pertinent 
classifications. For example, you can find the ETC Source 4 in the 
Fixtures section > Manufacturer > EFGH > ETC > ERS sub-menu.

Depending on the library item that you click, you may see a sample 
image of the item in the preview pane at the bottom of the browser.

To search the Library Browser
You can save time by using the Library Search feature. In the Library 
Browser, simply click the category tab that you are interested in, and then 
type the object name (or part of it) in the Search box at the top of the 
browser panel. All objects that match your query are shown. 

1 Open the Library Browser.
2 Click the category tab that you are interested in. For example, click 

Fixtures.
3 In the Search box, type the name of the item that you are searching 

for, or a partial name. For example, if you are searching for the CE 
Source 4 Par, you could type “par”.

4 Click the Search icon. 

Result: The results of your search appear in the browser pane.

Tips: 
 To return to the top level of the current category, click the Home 

icon. 

 To clear the search, but remain in the current category, click the 
Clear button. 

 The Search button.

 The Home button.

 The Clear button.
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To view the properties of library objects

1 Open the Library Browser.
2 Navigate to and select the desired object. 
3 Click the Property tool at the top of the Library Browser. 

4 Repeat steps 2-3 to view the properties of multiple objects. You may 
want to open the properties of different objects to compare data, 
such as photometric information. 
Tips: 
 You can also hold the ALT key and double-click on the object 

name.

 To view library objects without opening property windows, browse 
the library using the shortcut bar. To do this, select the shortcut 
bar for the type of object you want to view. Right-click in the 
shortcut bar, and then choose New <library item>. The Library 
Selection dialog box opens with a viewing pane included. 

To insert objects from the library

1 Open the Library Browser.
2 Navigate to the desired object or use the Search feature to locate it 

(for details, see “To search the Library Browser”). 
3 Click the Insert tool at the top of the Library Browser. 

Tips: 
 You can also double-click on the object name.

 For library objects, you can activate the Library Snap tool to display 
the snap points and the "Default" insertion point of the Library 
item displayed in red if the object is not selected or green if the 
object is selected. When the Library object insertion begins, right-
click to access and select a different insertion point from the 
menu list. See “Library snap”.

 For truss objects, you can activate the Truss Snap tool to display 
snap points of the truss. See “Truss snap”.

Note: Fixtures may only be placed on hang structures. Please refer 
to “Inserting fixtures” for more information.

4 Click in your drawing to insert the object.
5 Click away from the object to deselect it.

To replace inserted library objects

You can use the Replace Library Item command to quickly and easily 
replace one or more library items with another.

 The Properties button.



Reference Guide 277

January 2019 CAD mode - Creating Objects 

1 Select the library item(s) that you want to replace.

2 Right-click and choose Replace Library Item.
3 In the Library Selection window, select the new type of library item.
4 Click Insert.

Result: All the library items that you selected in step 1 are replaced 
with the item chosen in step 3. 

To create a shortcut for an object

In the Wireframe and Quad views you can create shortcuts for frequently 
used objects, fixtures and truss. Shortcuts are tools found on the various 
shortcut bars to the left of the working area. Clicking a shortcut for an 
object is the same as finding the object in the Library Browser and using 
the Insert command.

1 Open the Library Browser.
2 Navigate to the desired object. 
3 Click the Create Shortcut tool at the top of the Library Browser. 

Result: A shortcut to the object will appear on the appropriate 
shortcut bar.

Tip: You can also right-click on the object name, and then select 
Create Shortcut. 

To create a shortcut for an object already inserted 

Rather than going to the Library Browser to create a shortcut, you can also 
create shortcuts by conveniently selecting already inserted items and 
using the right-click menu to create multiple shortcuts.

Note: While you can create shortcuts for multiple items at once, the 
items have to be of the same type (i.e. all fixtures, all truss or all 
objects). If you have multiple items of different types you want to make 
shortcuts for, it will take a separate action for each item type.

1 In CAD mode, in Wireframe view, select the item(s) you want to make 
a shortcut for.

2 Right-click and select Create shortcut for selected [Item types].

Result: A shortcut to the item(s) will appear on the appropriate 
shortcut bar.
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To modify a shortcut for a library object

1 Right-click on the shortcut, and then select Properties.

Result: The Properties dialog box appears. An example of the 
accessories Shortcut Property dialog box is shown below.

2 In the Name box, type a new name for the shortcut.
The name of the fixture, color, gobo, accessories, library, or truss as 
listed in the library, is displayed in the Type box. 

3 For fixtures, you can modify the type of lens and lamp associated 
with the fixture by selecting the appropriate option from the Lens and 
Lamp drop-down lists, respectively. 

4 Click Properties to view the properties of the library entry. 
5 When you are satisfied with your selections, click OK.

To apply a texture to a library object

You can alter the appearance of library objects by applying textures to 
them. You can choose from thousands of textures in the WYSIWYG 
library or you can apply a custom texture that you have saved as a 
graphic file on your computer (for example, .bmp or .jpg). 

Note: Since most library objects are small with complex surfaces, it is 
best to apply even, plain textures to them. Complicated textures 
containing text or other recognizable images will not display properly on 
small, irregular surfaces.

1 Once you have inserted the library object in your plot, click on it to 
select it, and then right-click and select Properties.

2 Click the Appearance tab.
3 In the left pane, highlight the elements of the library item to which 

you want to apply the texture, and then click the type of texture file 
that you want to use, either from the Library or a custom texture 
that you have saved. For detailed descriptions of the texture and 
material options available on the Appearance tab, see “Appearance 
tab”.

4 Click OK when you are finished.
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Custom library items

You can create custom library items, custom conventional fixtures, 
custom gobos, and custom color and gobo wheels or scrolls.

When creating custom gobos and custom library items, you are given the 
option to make the item or gobo available to other documents, in which 
case the item or gobo is saved to the application’s library. If you do not 
choose to make the items available to other documents, the items are 
only saved within the one document. In either case, the items are saved 
and visible in the document regardless of which computer (or 
application) the document is opened in.

Custom conventional fixtures must be created from the WYSIWYG 
welcome screen and are saved directly to your application’s library. The 
new conventional fixture is available for you to use in all documents 
created using this application. If used in a show document, the custom 
conventional fixture is available in the document regardless of which 
computer (or application) the document is opened in.

Custom color, gobo wheels, and scrolls are only saved in the document 
and cannot be saved to the application’s library. They travel with the 
document, but if you need to use the same wheel or scroll on another 
show, you must regenerate it every time.

Note: You can delete custom library items, custom conventional fixture, 
and custom gobos. For details, see “To delete a custom library item”, “To 
delete custom fixtures”, and “To delete custom gobos”.

To create a custom library item

See “To create a custom library item”.

To create a custom fixture

See “To create a custom fixture”.

To create custom color or gobo lists

See “To create a custom color/gobo list”.

To create a custom gobo

See “To create a custom gobo”.
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Loading custom library objects on-demand

The custom library objects will be loaded on-demand when a second 
instance of WYSIWYG is launched. Only one instance of WYSIWYG has 
full permissions to edit the custom library object database, to preserve 
memory usage on loading of the application.

When the second instance of WYSIWYG is launched, a warning dialog box 
appears to inform that the second instance will be running in read-only 
mode.

Library snap

Library Snaps are snap points drawn at the bounding box corners of the 
library item, and one corner is displayed in red or green to represent the 
library item's insertion point.

When Library Snap is enabled, all library items that are in the drawing will 
display their snap points, which can be used as a snap capable insertion 
point that will align the placement of the item in CAD Wireframe views.

When Library Snap is enabled, the insertion point is identified by a red 
square if the object is not selected. The red square turns to green if the 
object is selected. The default insertion point can be changed by 
selecting a different insertion point from the menu list that appears when 
you right-click the library item you are inserting. The cursor switches to 
the specified insertion point.

Notes: 

 Library Snap only applies to objects from the Library tab in the Library 
Browser.

 Once a Library Item's insertion point has been changed during 
insertion within the project, it is remembered for future insertions 
from the Library Browser, and will be used when performing some CAD 
operations such as Copy/Paste, Move and Rotate.
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To use library snap

1 From the Tools menu, choose Snap, and then choose Library.

Tip: You can also click the Library Snap tool on the CAD Options toolbar.    

2 Insert the library object.
Result: The library object is displayed with the snap points at its 
bounding box corners and the cursor is attached to the default 
insertion snap point displayed in green. 

Note: Library Snap is automatically enabled at the start of Mirror and 
Paste, Move and Rotate operations in CAD mode.

To specify the library object’s insertion point

1 From the Library Browser, double-click on the object name you want to 
insert in your drawing.

2 Right-click the object to display the menu list of insertion points.
3 Click on the new insertion point.

Result: The cursor switches to the specified insertion point.

Tip: The snap point options are also useful when you copy, paste and 
move the library objects using keyboard shortcuts.

 The Library Snap button.
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Drawing objects

Introduction

In WYSIWYG, the Draw menu lists the objects that you can draw. Keep 
the following tips and aids in mind when you are drawing the various 
objects.

Drawing tips 

 At any time, instead of clicking points with the mouse, you can type 
in the desired coordinates. When you start typing, the Command 
Line automatically appears in the lower left-hand corner of the 
window.

 Create shortcuts for library objects.
 Use the missing coordinate.
 When you draw multi-segmented lines, surfaces, or when drawing a 

room using the Room Builder, the next point of the line or surface 
you wish to add snaps automatically to the previously drawn line/
surface's endpoint, midpoint or intersection when the Endpoint Snap, 
Midpoint Snap and/or Intersection Snap are enabled.

Drawing aids
Several commands and icons are available to help you when drawing in 
CAD mode. For a complete list of these aids, refer to “Keyboard shortcuts 
and hotkeys”.

Drawing a custom room

The Room Builder tool allows you to build a custom room of any shape in 
Wireframe view.

To draw a custom room

1 From the Draw menu, choose Room Builder.

Result: A cross-hair will appear on your cursor in the drawing 
wireframe.

2 Click to place a corner of the wall at the location of the cursor. Each 
subsequent click will connect the current corner to the previous 
corner.

3 To finish the room drawing, connected the first and last created 
corner.
Notes: 
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 Alternately, the room can be closed, connected the first and last 
created corner automatically, by right-clicking and selecting Close 
Room Outline. 

 To finish a room without closing it, right-click and select Finish 
Room Outline. 

Result: The Room Builder window appears.

4 In the Room Builder window, enter in the missing characteristics of the 
room walls.

5 Select the Place Wall objects on the opposite side of the Room Outline 
checkbox if you want to place object on the opposite side of the 
Room Outline. 

6 Select the Group Walls after creation checkbox if you want all created 
walls to be in the same group. 

7 Select the Close Room outline checkbox if you want to add floors or 
ceilings to the room.
Note: This option is only available if the room is closed. When a 
room is closed, WYSIWYG automatically makes the Walls transparent 
from outside of the room looking inwards, and makes the ceiling and 
floor single sided, so when the camera is outside of the room the 
user can see inside. These properties can be changed if the user 
wishes, by going to the objects' properties

8 Select the Add Floor checkbox to add a floor to the room
9 Select the Add Ceiling checkbox to add a ceiling to the room.
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10 Click Ok.
Result: The custom room will be created in Wireframe view.

Drawing a venue

To begin your drawing, insert a venue. 

To insert a venue

1 From the Draw menu, choose Venue. 

Result: A sub-menu will appear prompting you to choose the type of 
venue to be inserted.

2 Select Black Box, Arena, Proscenium Arch, Frame Tent, or Circus Tent.
Result: A dialog box appears in which you can modify the properties 
of the room. The Proscenium Arch dialog box is shown below.

3 Accept the defaults, or choose custom properties.
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4 Click OK.
Result: The selected venue is inserted into the drawing.

The venue types are defined as follows:

Proscenium Arch
A proscenium arch venue is a basic theatrical space with a stage, 
proscenium arch, and an auditorium. The origin is set at the intersection 
of the center line and the proscenium line on the stage floor.

The following entries describe the parts of the proscenium arch. 

 A: The stage width; the dimension from the extremity of the SR wing 
to the extremity of the SL wing. In WYSIWYG, the default value is 
90’0”.

 B: The stage depth; the dimension from the proscenium line to the 
back of the stage space. In WYSIWYG, the default value is 50’0”.

 C: The stage height; the dimension from the auditorium floor to the 
stage deck. In WYSIWYG, the default value is 4’0”.

 D: The thrust depth; the dimension from the edge of the stage to the 
proscenium line. In WYSIWYG, the default value is 8’0”.
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 E: The thrust width; the dimension from the extremity of the SR 
edge of the thrust to the SL extremity of the thrust. This dimension 
cannot be greater than the Arch width (G). In WYSIWYG, the default 
value is 35’0”.

 F: The Fly height; the dimension from the stage deck to the top of 
the fly house. In WYSIWYG, the default value is 60’0”.

 G: The proscenium arch width. In WYSIWYG, the default value is 
40’0”.

 H: The depth of the proscenium arch wall. In WYSIWYG, the default 
value is 2’0”.

 I: The height of the proscenium arch; the dimension of the opening 
of the proscenium arch. In WYSIWYG, the default value is 20’0”.

 J: The back of house (BOH) width; the dimension of the auditorium 
from the extremity of house right to the extremity of house left at 
the back of the house. In WYSIWYG, the default value is 100’0”.

 K: The auditorium depth; the dimension from the proscenium line to 
the back of the house. In WYSIWYG, the default value is 100’0”.

 L: The auditorium height; the dimension from the ceiling of the 
auditorium to the floor of the auditorium at the edge of the stage. In 
WYSIWYG, the default value is 45’0”.

 M: The front of house (FOH) width; the dimension of the auditorium 
from the extremity of house right to the extremity of house left at 
the front of the house. In WYSIWYG, the default value is 68’0”.

 N: The auditorium slope height. In WYSIWYG, the default value is 
12’0”.

Black Box 
A black box venue is an empty rectangular room. The origin is set at the 
center of the room on the floor.

The following entries describe the parts of the black box:

 A: The width of the room. In WYSIWYG, the default value is 60’0”.

 B: The depth of the room. In WYSIWYG, the default value is 40’0”.
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 C: The height of the room. In WYSIWYG, the default value is 30’0”.

Arena
An arena venue is a basic stadium space. The following entries describe 
the parts of the arena. The origin is set at the center of the venue on the 
floor or ice rink.

 A: The width of the arena. In WYSIWYG, the default value is 170’0”.

 B: The depth of the arena. In WYSIWYG, the default value is 250’0”.

 C: The total height of the arena. In WYSIWYG, the default value is 
60’0”.

 D: The width of the floor or ice rink. In WYSIWYG, the default value 
is 60’0”.

 E: The depth of the floor or ice rink. In WYSIWYG, the default value 
is 130’0”.

 F: The height of the stands or seating; the portion of the total height 
that is occupied by seating or stands. In WYSIWYG, the default value 
is 40’0”.

Tent
There are two types of tents that you can create in WYSIWYG: frame 
tents and circus tents.

 Frame tents: These tents are square or rectangular in shape and 
usually have two center poles. Each wall is made of a single piece of 
fabric supported by as many poles as you specify.

 Circus tents: These tents are styled after the classical “Big Top” of 
the circus. They are more rounded in shape than the frame tent, the 
walls comprising multiple sections, each supported by as many poles 
as you specify. The roof is held up by one center pole.

When drawing either type of tent, you can specify many different 
properties, including the number of poles, length, height, or perimeter of 
the walls, and the color of different parts of the tent. 



288

CAD mode - Creating Objects  R42

You can also choose from different materials and you can choose 
whether you want to apply either a custom color or texture to different 
parts of the tent. When assigning a texture, you can choose your own 
texture, such as a company logo or symbol, or you can choose a texture 
from the WYSIWYG library.

The origin for both types of tents is at the center of the tent on the floor. 

Frame tent

The following entries describe the parts of the frame tent:

Description
New Venue - Tent 

Field
WYSIWYG 

Default Value

A The height of the 
tent walls.

Wall height 20’0”

B The length of the 
tent walls.

Width 80’0”

C The width the tent 
walls.

Depth 70’0”

D The height that the 
center pole extends 
above the height of 
the walls.

Height above 
walls

10’0”

E The distance 
between the center 
poles.

Separation 20’0”
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Circus tent

The following entries describe the parts of the circus tent:

Drawing lines

Lines are 2D objects. Lines are drawn continuously, allowing you to 
create shapes made up of multiple vertices.

Lines come in four styles: 

 Solid 
 Center 
 Hidden
 Dot 

Line styles determine how line objects appear on your plot and can be 
modified at any time. They look similar to the following.

Description
New Venue - Tent 

Field
WYSIWYG 

Default Value

A The number of 
individual segments 
in the tent.

Segments 6

B The height of the 
tent walls.

Wall height 20’0”

C The height that the 
center pole extends 
above the height of 
the walls.

Height above 
walls

10’0”

D The diameter of the 
tent, measured from 
pole to opposite pole.

Diameter 70’0”
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You can make a multi-vertex line appear as a spline or french curve by 
selecting the option in the properties box. You can then drag the markers 
around to adjust the curves. Alternatively, you can choose to draw a 
spline directly. Splines have the same line style options as regular lines.

When you draw multi-segmented lines, or add a line to a surface, the 
next point of the line you wish to add snaps automatically to the 
previously drawn line/surface’s endpoint, midpoint or intersection when 
the Endpoint Snap, Midpoint Snap or Intersection Snap are enabled.

Lines can be extruded into surfaces. For more on extruding lines, refer to 
“Extrude”.

To draw a line freehand

1 From the Draw menu, choose Line.

2 From the sub-menu, select Solid, Dot, Center, Dashed, or Spline.
Tip: You can also use the appropriate line tool on the Draw toolbar. 
The available line tools are as follows:
  Solid 

  Centered

  Dashed

  Dotted

  Spline 

3 Click in the wireframe at the starting point of the line.
4 Drag the next vertex to its end point and click.
5 Continue to place vertices of the line as needed.
6 To end the line at its last end point, right-click and choose Finish 

Line. To abort the line entirely, choose Abort Line. This erases the 
whole line from the drawing.

To draw a line by specifying coordinates

You can also draw lines using coordinates by specifying absolute or 
relative values. 
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1 From the Draw menu, click Line and choose Solid, Dot, Center or 
Hidden.

2 In the Command Line, type the absolute X, Y and Z coordinates 
(separated by commas) where you want the line to start (i.e. 0,0,0).

3 Press ENTER to establish the first point of the line.
4 In the Command Line, type the absolute X, Y and Z coordinates 

(separated by commas) where you want the next point of the line.
or,

Using the relative values, in the Command Line, type @, followed by 
the length towards the next point of the line (positive or negative 
direction), (i.e. @2’,0,3’). 

5 Press ENTER to draw the new line segment.
6 Continue to type absolute or relative values and press ENTER to draw 

the next line segments.
7 When you are finished drawing the lines, right-click and click Finish 

Line.

To draw a line by specifying its length and angle

1 From the Draw menu, click Line and choose Solid, Dot, Center or 
Hidden.

2 In the Command Line, type the X, Y and Z coordinates (separated by 
commas) where you want the line to start.

3 Press ENTER to establish the first point of the line.
4 Type the length towards the next point of the line, followed by the < 

sign, and the angle (direction), (i.e.3’6”<180).
5 Press ENTER to draw the new line segment.
6 Continue to type the length and angle in the Command Line.
7 When you are finished drawing the lines, right-click and click Finish 

Line.
Tip: You can also determine the direction of the line from the 
cursor’s current position relative to the start point set in step 2.

Drawing points

Points are identifiers of a specific coordinate in 3D space. Points are 
inserted as references or as scenic elements.
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To draw a point

1 From the Draw menu, choose Point.

Tip: You can also use the Point tool on the Draw toolbar. 

2 Click on the drawing to place the point. 

Note: Points can be drawn as a dot, a cross, a square, or a circle.

To set the point type default

1 From the Options menu, choose Document Options.

2 Click the Object Settings tab.
3 Select the desired point type.
4 Click OK.

Drawing circles

There are two ways in which you can draw circles:

 Non-interactive mode in which you type the exact horizontal and 
vertical radius of the circle.

 Interactive mode in which you click and drag to set the radius.

To draw a circle in non-interactive mode

1 From the Draw menu, choose Circle.

Tip: You can also use the Circle tool on the Draw toolbar. 

Result: The New Circle dialog box appears. 

2 In the Horizontal Radius box, type the horizontal radius for the circle. 
The default value is 4’0”.

 The Point button.

 The Circle button.
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3 In the Vertical Radius box, type the vertical radius for the circle. The 
default value is 4’0”.
Notes: 
 To ensure that the circle remains proportionately the same when 

resized, leave the Lock Ratio checkbox checked. If you clear this 
checkbox, then you can manually resize the circle in any 
direction, regardless of its original measurements.

 To convert the circle into a surface, select the Convert to Surface 
checkbox.

4 Click OK.
5 Click on the drawing to place the circle.
6 Click elsewhere in the drawing to finish placing the new circle.

To draw a circle in interactive mode

Note: To turn interactive mode on, click the Interactive Mode button on the 
toolbar.

1. From the Draw menu, choose Circle.

Tip: You can also use the Circle tool on the Draw toolbar. 

2 Click to place the center of the circle.
3 Click to set the radius for the circle.

Drawing arcs

There are two ways in which you can draw arcs:

 Non-interactive mode in which you type the exact radius, start, and 
end angles of the arc.

 Interactive mode in which you click and drag to set the arc.

 The Interactive Mode button.

 The Circle button.
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To draw an arc in non-interactive mode

1 From the Draw menu, choose Arc.

Tip: You can also use the Arc tool on the Draw toolbar. 

Result: The New Circular Arc window appears.

2 In the Radius box, type a radius for the arc. The default value is 4’0”.
3 In the Start Angle box, type the start angle. The default value is 0.00.
4 In the End Angle box, type the end angle for the arc. The default value 

is 180.00.
5 Click OK.
6 Click on the drawing to place the arc.
7 Click elsewhere in the drawing to finish placing the arc.

To draw an arc in interactive mode

Note: To turn interactive mode on, click the Interactive Mode button on the 
toolbar.

1 From the Draw menu, choose Arc.

Tip: You can also use the Arc tool on the Draw toolbar. 

2 Click to place the start point of the arc.
3 Click to place the end point of the arc.
4 Click to place the middle point of the arc.
5 Click elsewhere in the drawing to finish placing the arc.

Drawing elliptical arcs

There are two ways to draw an arc:

 The Arc button.

 The Interactive Mode button.

 The Arc button.
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 Non-interactive mode in which you specify the elliptical arc radius, 
start and end angles and place the arc in the drawing.

 Interactive mode in which you draw the elliptical arc.

To draw an elliptical arc in non-interactive mode

1 From the Draw menu, choose Elliptical Arc.

Tip: You can also use the Elliptical Arc tool on the Draw toolbar. 

Result: The New Elliptical Arc window appears.

2 In the Radius box, enter a radius for the elliptical arc. The default 
value is 4’0”.

3 In the Start Angle box, enter the start elliptical angle. The default 
value is 0.00.

4 In the End Angle box, enter the end angle for the elliptical arc. The 
default value is 180.00.

5 Click OK.
6 Click on the drawing to place the elliptical arc.
7 Click and drag the mid point of the arc to create the desired elliptical.

To draw an arc in interactive mode

Note: To turn interactive mode on, click the Interactive Mode button on the 
toolbar.

1 From the Draw menu, choose Elliptical Arc.

Tip: You can also use the Arc Elliptical tool on the Draw toolbar. 

2 Click to place the start point of the elliptical arc.
3 Click to set the horizontal and vertical radii of the elliptical arc.

 The Elliptical Arc button.

 The Interactive Mode button.

 The Elliptical Arc button.
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4 Click to set the start point of the ellipse. 
5 Click to set the end point of the ellipse. 

Drawing rectangles 

There are two ways to draw rectangles:

 Non-interactive mode in which you enter the exact length and width 
of the rectangle.

 Interactive mode in which you draw the size of the rectangle.

To draw a Rectangle in non-interactive mode

1 From the Draw menu, choose Rectangle.

Tip: You can also use the Rectangle tool on the Draw toolbar. 

Result: The New Rectangle window appears.

2 In the Length box, type the length for the rectangle. The default value 
is 4’0”.

3 In the Width box, type the width for the rectangle. The default value 
is 8’0”.
Tips: 
 To ensure that the rectangle remains proportionately the same 

when resized, select the Lock Ratio checkbox. Otherwise you can 
manually resize the rectangle in any direction, regardless of its 
original measurements.

 To convert the rectangle into a surface, select the Convert to 
Surface checkbox.

 To add hatching to the rectangle, select the Show Hatch Lines 
checkbox.

4 Click OK.

 The Rectangle button.
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5 Click in the drawing to place the rectangle.

To draw a Rectangle in interactive mode

Note: To turn interactive mode on, click the Interactive Mode button on the 
toolbar.

1 From the Draw menu, choose Rectangle.

Tip: You can also use the Rectangle tool on the Draw toolbar. 

2 Click to place one corner of the rectangle.
3 Click to place the opposite corner for the rectangle.

Drawing polygons

Polygons are regular shaped objects comprising multiple vertices. You 
can draw polygons as 2D objects or specify a height value to draw 3D 
objects. You can use polygons to create either wireframe or solid objects. 

Unlike the Surface tool, with the Polygon tool you can quickly and easily 
create symmetrical shapes like squares, pentagons, hexagons, 
hectagons, and so on. The maximum number of edges that a polygon 
can have is 40.

Notes: 

 Unlike most other tools, the polygon tool does not have an 
interactive mode.

 The size of the polygon can be defined either by specifying the edge 
length or radius.

 The Interactive Mode button.

 The Rectangle button.
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To draw a polygon

1 From the Draw menu, choose Polygon.

Tip: You can also click the Polygon tool on the Draw toolbar. 

 

2 In the Number of Edges field, type the number of edges or sides of the 
polygon.

3 Click Edge Length if you want to define the size of the polygon by the 
length of its edges, and then type the value in the box provided.

4 Click Radius if you want to define the size of the polygon by the 
distance between the center and the vertices or the edges' 
midpoints, and then type the distance in the box provided.
 Click Circumscribed if you want to define the size of the polygon by 

the distance between the center and the vertices. This is equal to 
the radius of the circumscribed circle.

 Click Inscribed if you want to define the size of the polygon by the 
distance between the center and the edge midpoints. This is 
equal to the radius of the inscribed circle.

5 Click Surface if you want to create the polygon as a surface (i.e., a 
filled in object to which you can apply a texture, etc.).

6 Click Closed Line if you want to create the polygon as a closed line 
(i.e., a polygon comprised of an outline that is open in the middle).

7 Click Height if you want to extrude the polygon into a 3D object, and 
then type the height value in the box provided.

8 Select the Show Hatch Lines checkbox to add hatching lines to the 
polygon.

9 Click OK to place the polygon in your drawing.

 The Polygon button.
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Drawing text labels

Before you draw your text labels in CAD mode, you can select the font 
that will be used in all labels. You can choose from any font installed on 
your computer. 

To change the Text Label font globally

You can specify the font that you would like to appear globally in all text 
labels, both new and existing.

1 In any drawing mode, click Options > Document Options.

2 Click the Fonts tab.
3 Under CAD Text Labels, from the Font drop-down list, select the font 

that you want to appear in all new text labels.
4 Choose whether you want the letters to appear bold, underlined, or 

in italics.
5 Click OK.

To draw a text label

1 From the Draw menu, choose Text Label.

Tip: You can also use the Text Label tool on the Draw toolbar. 

Result: The New Text Label window appears.

 The Text Label button.
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2 In the Text box of the New Text Label window, type the desired text.
Notes: 
 Use SHIFT+ENTER to add new text lines.

 You may include text labels containing information listed in the 
Production Team Information table. Use smart variables 
“%Variable Name%” in the Text Label box and this information 
will automatically be displayed if it is stored in the Production 
Team Information table. For example, type “%Director%” and 
the name of the Director stored in the table will appear in the 
Text Label.

3 Click Insert Smart Variable to open the Smart Variables window where you 
can select the smart variable names and values that are listed in the 
Production Team Info tab in Document Options. 
Result: The Smart Variables window appears.

4 From the table in the Smart Variables window, click on the name or 
value that you wish to insert in the text box.
Tip: Click the Filter drop-down menu and choose which information to 
display in the table. See “Show information”.

5 Select the Include Name and Value checkbox to display both texts under 
the Name and Value columns, or clear the checkbox to display only 
the texts under the value column.

6 Click Insert.
Result: The smart variable text appears in the Text box of the New 
Text Label window.
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7 Click Insert Item Data to open the Item Data window, where you can 
select retrieved catalog name and other information of fixtures and 
trusses, to insert in your drawing.
The retrieved information are displayed in the Item Data window only 
after “Retrieve Item Data” is initiated from the Library > Retrieve Item 
Data menu in CAD, and then clicking the Fixture or Truss item. See 
“To retrieve data from a fixture or truss object”.

Result: The Item Data window appears.

8 From the table in the Item Data window, click on the row that contains 
the name and value text that you wish to add into the text box.

9 In the Item Data window, you may click the Recent Items drop-down 
menu and select the fixture or truss item. The Recent Items drop-
down list displays a maximum of five items recently selected.

10 Click Insert.
Result: Information from the selected fixture or truss appears in the 
Text box of the New Text Label window.

11 Using the radio buttons, choose how you want to specify the Height 
of the Text Label, and enter the value in the corresponding field. 
 Individual Line of Text: Each line of text will be the chosen height. 

The text label will change size to accommodate the height.

 Total Text Label: The total text box will be the chosen height. Text 
will change size to accommodate the height.

a. To add space between the text and the border of the text label, 
select the checkbox next to Text Label Padding, and enter the value 
of the padding in the field.

Note: The Total Text Label Height field will tell you the exact height of 
the text label based on your choices.

12 To add a callout to the text label, select the Show Callout checkbox.
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13 From the Position drop-down list, select where the callout will be 
located on the text label.

14 To have an arrow at the end of the callout, select the Show Arrow 
checkbox.

15 To add a border to the text label, select the Show Border checkbox.
16 To fill the text label with color, select the Fill checkbox.

a. Click the Color Selector button to choose the color that will fill the 
text label.

17 To align the text label to the current view, select the Align to View 
checkbox.

18 To insert the text label, click OK.
Result: The New Text Label window will close and you will be in the 
Wireframe view.

Note: If the Callout checkbox was selected in the New Text Label 
window, the first click in Wireframe view will be the arrow's position, 
and the second position will place the text label.

19 Click on the drawing to place the text label.
Result: The text label will be placed.

Notes: 

 To change the font of existing text labels in CAD mode, see ““To 
change the font of Text Labels”” below.

 The insertion point for the text label is at the intersection of the 
crosshairs.
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To change the font of Text Labels

To change the font and appearance (bold, italic, or underline) of existing 
labels, you can use the label’s Properties window or the CAD Text toolbar. 
The following procedure outlines how to use the Properties window.

1 Select the text label whose font you want to change.

2 Right-click, and then choose Properties.
3 Click the Text Label tab.
4 Under Font, clear the check mark beside Use Document Defaults.
5 From the Font drop-down list, select the new font.
6 Choose whether you want the letters to appear bold, underlined, or 

in italics.
7 Click OK.

To set alignment for a text label

You can use the alignment buttons on the CAD Text toolbar to align text 
labels.

 

1 Select the text label that you want to align.

2 On the CAD Text toolbar, click the appropriate button to align the text 
label in the desired position (left, center, right, top, middle, or 
bottom).
Result: The text label is relocated around the insertion point, based 
on the options selected.

To retrieve data from a fixture or truss object

1 From the Library menu, choose Retrieve Item Data. 

2 Point the cursor to the fixture or truss you want to select, which 
highlights the item in orange.

3 Click on the fixture or truss item.
Result: The New Text Label window appears.

4 In the New Text Label window, you can click Insert Item Data to display 
in your drawing, the information that you retrieved from the selected 
fixture or truss.



304

CAD mode - Creating Objects  R42

Drawing dimension objects

Dimension lines are 2D objects. They have a start and end point, and 
measure and display the distance covered based on the measurement 
mode selected. The measurement modes available are: X, Y, XY, XZ, YZ, 
and XYZ. The dimension will only be visible in one view type. The view 
type is set when the dimension is drawn and is dependent on the plot 
type and workplane in which the dimension is drawn.

There are several types of dimensions available:

 Linear dimensions: These dimensions measure and display the 
distance covered between two points in your plot, based on the 
measurement mode selected.

 Continue dimensions: These dimensions display sequential chains of 
linear measurements that are aligned to the start (base) 
measurement of the Continue Dimension, always using the last point 
of the previous measurement as the initial point of the next 
measurement.

 Baseline dimensions: These dimensions display linear measurements 
stacked above or below the Base Dimension while maintaining 
uniform spacing between, always using the first click as the initial 
coordinate for all subsequent measurements.

 Arc length dimensions: These dimensions are used to measure the 
length of arcs drawn in CAD mode.

 Radial dimensions: These dimensions are used to measure the radius 
of any circle or arc drawn in CAD mode.

 Angle dimensions: These dimensions measure and display an angle, 
either between two intersecting lines and objects, or as drawn in 
Freehand mode.

Note: The properties of dimension objects, such as the arrow type, can 
be changed in the Dimensions tab under Options > Document Options....
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To draw a linear dimension

1 From the Draw menu, Dimensions sub-menu, choose Linear 
Dimension.

Tip: You can also click the Linear Dimension tool on the Draw toolbar. 

Result: The Select Layer for Dimension dialog box appears.

2 In the Select Layer for Dimension dialog box, choose the layer for the 
linear dimension and select the options for the selected layer.

3 Click OK to apply and close the dialog box.
4 Click on the drawing to set the dimension start point.
5 Right-click to set the measurement mode.

Tip: In measurement mode, you can choose Multiple, which enables 
you to draw multiple Linear Dimensions, using the last point of the 
previous measurements as the initial point for the next 
measurement.

6 Click on the drawing to set the dimension end point.
7 Click and drag the grab point in the center of the dimension text to 

drag the text to the correct side of the object, if required.
8 Click to set the dimension line.

Notes: 

 Use snaps to connect dimensions directly to other objects.
 You can set the rotation angle of the Linear Dimension to rotate the 

extension lines around the dimension end points. The rotated Linear 
dimension will then display the distance between the two points at 
the angle specified. Right-click on the Linear Dimension and select 
Properties.

 You can change the Fill color behind the dimension text of the Linear 
Dimension. Right-click the Linear Dimension and select Properties.

 You can enable Display Dash in Document Options > Dimensions tab to 
display the linear dimensions with a dash between foot and inches in 
imperial measurements (e.g. 19’-3 11/16”).

 The Linear Dimension button.
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 To adjust the font used in all dimensions, click Options > Document 
Options > Font. In the CAD Dimensions area, select the font options 
to be used in all dimensions. 

To draw a continue dimension

1 From the Draw menu, Dimensions sub-menu, choose Continue 
Dimension.

Tips: 
 You can also click the Continue Dimension tool on the Draw toolbar.

 You can also start the Continue Dimension on an existing Linear 
Dimension.

Result: The Select Layer for Dimension dialog box appears.

2 In the Select Layer for Dimension dialog box, choose the layer for the 
continue dimension and select the options for the selected layer.

3 Click OK.
Result: The Dimension Draw Options dialog box appears.

4 In the Dimension Draw Options dialog box, select the Use Document 
Defaults checkbox to use the default setting for extension height or 
clear the Use Document Defaults checkbox and type the custom 
Extension height for the Continue Dimension.

 The Continue Dimension button.
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5 Click OK to apply and close the dialog box.
6 Click on the drawing to set the dimension start point.
7 Click on the drawing to set the next point and direction of the 

subsequent measurements in the Continue Dimension.
8 Repeat setting the next point and direction to continue on the 

subsequent dimensions.
9 Right-click on the drawing to set the dimension end point.

Note: After completing a Continue Dimension, the measurements 
created are individual Linear Dimensions.

To draw a baseline dimension

1 From the Draw menu, Dimensions sub-menu, choose Baseline 
Dimension.

Tips: 
 You can also click the Baseline Dimension tool on the Draw toolbar.

 You can also start the Baseline Dimension on an existing Linear 
Dimension.

Result: The Select Layer for Dimension dialog box appears.

2 In the Select Layer for Dimension dialog box, choose the layer for 
baseline dimension and select the options for the selected layer.

 The Baseline Dimension button.
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3 Click OK.
Result: The Dimension Draw Options dialog box appears.

4 In the Dimension Draw Options dialog box, select the Use Document 
Defaults checkbox to use the default settings for extension height and 
spacing size for the baseline dimension. Or you may clear the Use 
Document Defaults checkbox and type custom values for the Extension 
height and Spacing Size for the Baseline Dimension.

5 Click OK to apply and close the dialog box.
6 Click on the drawing to set the dimension start point.
7 Click on the drawing to set the end point of the first Baseline 

Dimension.
8 Click on the drawing to set the position (above or below) for the 

next/subsequent Baseline Dimension.
9 Click on the next point to complete the next Baseline Dimension 

measurement, and set the direction of the subsequent 
measurement. 

10 Repeat setting the next point to create the subsequent Baseline 
Dimensions.

11 Right-click on the drawing to set the dimension end point.

Note: After completing a Baseline Dimension, the measurements created 
are individual Linear Dimensions.

Arc length dimensions
The arc length can be displayed for any arc drawn in CAD mode. Once 
enabled, the arc length dimension is attached to the arc and 
automatically updates itself whenever the arc is changed. The dimension 
is only visible in the view type in which it was drawn. 

Although the arc length dimension is attached to the arc, it is a separate 
entity. Each arc length is individually selectable and has its own 
properties. Arc length dimensions can be separated onto their own 
layers, and given their own colors and line weights.
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To draw an arc length dimension

1 In a CAD wireframe, select the arc for which you want to display an 
arc length dimension.

2 From the Draw menu, Dimensions sub-menu, select Arc Length 
Dimension.

Tip: To adjust the font used in all dimensions and with the Angle 
Dimension tool, click Options > Document Options > Font. In the CAD 
Dimensions area, select the font options to be used in all dimensions 
and with the Angle Dimension tool.

Radial dimensions
The radius of a circle/arc is defined as the distance from the center of a 
circle/arc to its perimeter. The radius can be displayed for any circle or 
arc drawn in CAD mode. Once enabled, the radial dimension attaches to 
the circle/arc and automatically updates itself whenever the circle/arc is 
changed. Note that the dimension is only visible in the view type in which 
it was drawn.

Although the radial dimension is attached to the arc, it is a separate 
entity with its own properties and can be individually selected. Radial 
dimensions can be separated onto their own layers, and given their own 
colors and line weights.

To draw a radial dimension

1 In a CAD wireframe, select the circle/arc for which you want to 
display a radial dimension.

2 From the Draw menu, Dimensions sub-menu, select Radial 
Dimension.

Tip: To adjust the font used in all dimensions and with the Angle 
Dimension tool, click Options > Document Options > Fonts. In the CAD 
Dimensions area, select the font options to be used in all dimensions 
and with the Angle Dimension tool.

Angle dimension
The Angle Dimension object measures and displays an angle, either in 
Line Select, between two intersecting lines and objects, or as drawn in 
Freehand mode. 

 The Arc Length Dimension button.

 The Radial Dimension button.
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To draw an angle dimension in Line Select

1 From the Draw menu, Dimensions sub-menu, select Angle Dimension. 

2 Choose Line Select from the Dimension Draw Options dialog box.
3 Click on the first line segment in the drawing.
4 Click on the second line segment in the drawing.

Result: The angle between the two selected lines is displayed.

To draw an angle dimension in Freehand

1 From the Draw menu, Dimensions sub-menu, select Angle Dimension.

2 Choose Freehand in the Dimension Draw Options dialog box.

3 Click on the drawing to define the first end point (point number 1 in 
the diagram above) of the Angle Dimension.

4 Click a second time to define the vertex of the angle (this is the point 
at which the two lines of your angle meet, shown as point number 2 
in the diagram above).

5 Click a third time to define the second end point (point number 3 in 
the diagram above). 
Result: The new object displays the interior (or exterior) angle 
defined by the arc between the end points of the Angle Dimension. 

Tips: 
 You can change the angle option of measuring the exterior or 

interior angle by toggling the Flip Angle checkbox in the Angle 
Dimension Properties page. Simply right-click the Angle 
Dimension, and choose Properties > Angle Dimension tab. 

 The Angle Dimension button.
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 To adjust the font used in all dimensions and with the Angle 
Dimension tool, click Options > Document Options > Fonts. In the 
CAD Dimensions area, select the font options to be used in all 
dimensions and with the Angle Dimension tool.

Linear scales
A Linear Scale is a visible line divided into equal proportions used to 
compare distances in WYSIWYG wireframe to actual distances. 

To draw a linear scale

1 From the Draw menu, Dimensions sub-menu, select Linear Scale.

Result: The New Linear Scale window appears.

2 In the Length field, enter in the desired length of the linear scale.
3 Select either Horizontal or Vertical to determine how the line scale is 

positioned.
4 From the Text Alignment drop-down list, choose how the linear scale 

text will be presented. 
5 From the Layer drop-down list, choose in which layer the linear scale 

will be visible.
 Selecting the checkbox next to Show non-editable layers (indicated by 

*) will show non editable layers in the Layer drop-down list.
6 To change the default document settings of the linear scale, clear the 

checkbox next to Use Document Defaults.

 The Arc Length Dimension button.
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7 Click OK.
Result: The linear scale is attached to the cursor.

8 Click to place the linear scale in the drawing.

Auto truss dimension
When Auto Truss Dimension is applied, truss objects that are selected in 
the drawing will be displayed with linear dimensions automatically, and 
with the option of showing values that were set in Truss Manager or the 
default values from the Library. See “Truss manager”.

To apply auto truss dimension

1 In Wireframe, select the truss object(s).

2 From the Draw menu, Dimensions sub-menu, select Auto Truss 
Dimension. 
Result: The Select Layer for Dimension dialog box appears. 

3 Select the layer and the options in the Select Layer for Dimension dialog 
box.
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4 Click OK.
Result: The Auto Truss Dimension window appears.

5 Select the Use Truss Manager Values checkbox to apply the values that 
were set in Truss Manager or select Use Measured Truss Values to apply 
manually applied linear dimensions.

6 Select the checkboxes for Dimension X, Dimension Y, and/or Dimension Z 
to specify which dimensions of a truss to add into your drawing.

7 Click Open Truss Manager to launch Truss Manager.
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8 Click OK.
Result: The truss object(s) that were selected in your drawing are 
displayed with the linear dimensions showing the values set in Truss 
Manager if Use Truss Manager Values was selected. The manually applied 
linear dimension values will be displayed if Use Measured Truss Values 
was selected.

Drawing surfaces

Surfaces are 2D objects. Surfaces are drawn continuously, stretching out 
behind the cursor and can be used to create backdrops or other flat 
objects. Surfaces can be extruded to create odd shaped risers, or other 
custom shaped 3D objects. For more information on extruding, refer to 
“Extrude”.

When you draw multi-segmented lines or surfaces, the new line or 
surface snaps automatically to the previously drawn line or surface's 
endpoint, midpoint or intersection when the Endpoint Snap, Midpoint Snap 
or Intersection Snap are enabled.

Note: The beam will pass through a surface with the Transparency value 
set to 80% or greater. The beam will not pass through the surface when 
the value is lower than 80%. Transparency value is set in the Material 
Properties section in the Appearance tab of the Properties window. Refer to 
“Appearance tab”.

To draw a surface

To ensure that textures, if any, are applied properly, the surface must be 
drawn in a counter-clockwise direction.
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1 From the Draw menu, choose Surface.

Tip: You can also click the Surface tool on the Draw toolbar. 

2 Click on the drawing at the starting point of the surface.
3 Moving in a counter-clockwise direction, drag to the next point of the 

surface and click.
4 Continue to place points for the surface as needed, always moving 

counter-clockwise. In the following graphic, the starting point is 
labelled A:

5 To finish and close the surface, right-click and choose Finish Surface 
from the sub-menu. To abort the surface entirely, choose Abort 
Surface. This erases the whole surface from the drawing.

Surfaces as curtains
Vertical surfaces can have their appearance changed to mimic the look of 
curtains in 2D Plan View. The curtain will appear as a wave or semicircles 
pattern, instead of the usual straight line of a surface. The depth, width 
and number of segments in the curtain pattern can be customized.

 The Surface button.
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Note: Curtains are limited to being visible only in 2D Plan View, with a 
surface that is vertical and rectangular in shape, with no surface area 
visible in Plan View. 

A Plan View of an example surface with a semicircle curtain enabled 
in red, and a surface with a wave curtain enabled in blue.
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To display a surface as a curtain.

1 Right-click an eligible surface and select Properties.

2 In the Properties window, click the Surface tab.

3 To enable the curtain feature for the surface, select the checkbox 
labeled Enable.
Note: If the surface is ineligible to be a curtain, this option will be 
greyed out.

4 Select from the Style drop-down list which pattern of curtain should 
be displayed.

5 Enter the desired depth of the curtain pattern in the Depth field. 
6 Enter the desired width of the curtain pattern in the Width field. 
7 Enter the desired number of segments in the curtain pattern in the 

Number of Segments field. 
8 Click Apply.
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Drawing walls

Walls are 2D objects that describe flat rectangular planes representing 
walls in your drawing. Walls can have different hatching styles for easy 
identification in the plot.

There are two ways to draw a wall:

 Non-interactive mode in which you specify the width and height and 
place the wall in the drawing.

 Interactive mode where you draw the wall freehand.

To draw a wall in non-interactive mode 

1 From the Draw menu, choose Wall.

Tip: You can also click the Wall tool on the Draw toolbar. 

Result: The New Wall window appears.

2 In the Width box, enter the width for the wall. The default value is 
12’0”.

3 In the Height box, enter the height of the wall. The default value is 
8’0”.

4 In the Thickness box, enter the thickness of the wall. The default 
value is 0'6"

5 To enable hatching for the object, select the Show Hatch Lines 
checkbox.

6 Select the desired hatching style for the object from the Hatch Style  
drop-down list.

7 Click OK.
Result: The wall attaches to the cursor.

8 Move the cursor to the desired position for the wall, and then click to 
place it in the drawing.

 The Wall button.
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To draw a wall in interactive mode 

Note: To turn interactive mode on, click the Interactive Mode button on the 
toolbar.

1 From the Draw menu, choose Wall.

2 Click to place the start point of the wall.
3 Click to place the end point of the wall.
4 In the dialog box that opens, enter the missing dimension of the wall.
5 Click OK.

To define the transparency of a wall

1 Right-click a wall, and select Object Properties.

Result: The Properties window appears.

2 In the Properties window, click the Wall tab.

Note: 0% = Opaque, 100% = Transparent.

 The Interactive Mode button.
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3 To change how the back of the wall will look, set the Back Transparency 
field to the desired transparency percentage.

4 To change how the front of the wall will look, set the Front 
Transparency field to the desired transparency percentage.

5 Click Apply to enable the new wall transparency settings.
6 Click OK.

Drawing risers

Risers are solid 3D rectangular objects. You can use risers for creating 
platforms, square columns, or any other box-shaped objects. 

There are two ways in which you can draw risers:

 Non-interactive mode in which you type the exact width, depth, and 
height of the riser.

 Interactive mode in which you click and drag to set the dimensions of 
the riser.

To draw a riser in non-interactive mode

1 From the Draw menu, choose Riser.

Tip: You can also click the Riser tool on the Draw toolbar. 

Note: To ensure that the riser remains proportionately the same 
when resized, leave the Lock Ratio checkbox checked. If you clear this 
checkbox, then you can manually resize the riser in any direction, 
regardless of its original measurements.

2 In the Width box, type the width for the riser. The default value is 8’0”

3 In the Depth box, type the depth for the riser. The default value is 
4’0”.

4 In the Height box, type the height for the riser. The default value is 
2’0”.

 The Riser button.
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5 To enable hatching for the object, select the Show Hatch Lines 
checkbox.

6 Select the desired hatching style for the object from the Hatch Style  
drop-down list.

7 Click OK. 
Result: The riser is attached to the cursor.

8 Drag the new riser to its position, and then click to place it in the 
drawing.

To draw a riser in interactive mode

Note: To turn interactive mode on, click the Interactive Mode button on the 
toolbar.

1 From the Draw menu, choose Riser.

2 Click the starting point of the riser on the drawing. The insertion 
point is the lower left corner of the riser.

3 Drag in any direction to stretch out the riser’s shape. Click to place 
the upper right corner of the riser.

4 In the dialog box that opens, type the missing dimension of the riser.
5 Click OK.

Note: You can now snap to all eight points on a riser: top corners and 
bottom corners.

Drawing cylinders

Cylinders are solid 3D objects. Cylinders can be used for creating 
platforms, columns, or any other cylinder-shaped objects. 

There are two ways in which you can draw cylinders:

 Non-interactive mode in which you type the exact height and radius 
of the cylinder.

 Interactive mode in which you click and drag to set the dimensions of 
the cylinder.

 The Interactive Mode button.
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To draw a cylinder

1 From the Draw menu, choose Cylinder.

Tip: You can also click the Cylinder tool on the Draw toolbar. 

Result: The New Cylinder window appears.

2 In the Height box, type the height for the cylinder. The default value is 
8’0”.

3 In the Horizontal Radius box, type the horizontal radius for the cylinder. 
The default value is 4’0”.

4 In the Vertical Radius box, type the vertical radius for the cylinder. The 
default value is 4’0”.

5 To ensure that the cylinder remains proportionately the same when 
resized, leave the Lock Ratio checkbox checked. If you clear this 
checkbox, then you can manually resize the cylinder in any direction, 
regardless of its original measurements.

6 To have the cylinder appear smooth in the Shaded view, leave the 
Smooth Shading option enabled; to see a faceted cylinder in the 
Shaded view, disable this option. The default for this option is ON.

7 To change the default number of cylinder segments, clear the 
checkbox beside Use Document Defaults and type the new number of 
segments. Note that the higher the number of segments, the better 
the cylinder will appear in Shaded view, but the more performance 
will degrade.

8 To enable hatching for the object, select the Show Hatch Lines 
checkbox.

9 Select the desired hatching style for the object from the Hatch Style  
drop-down list.

 The Cylinder button.
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10 Click OK. 
Result: The cylinder is attached to the cursor.

11 Drag the new cylinder to its position, and then click to place the 
object in the drawing.

To draw a cylinder in interactive mode

Note: To turn interactive mode on, click the Interactive Mode button on the 
toolbar.

1 From the Draw menu, choose Cylinder.

2 Click to place the center of the bottom surface of the cylinder.
3 Click to set the radius for the cylinder.
4 In the dialog box that opens, type the desired height, horizontal 

radius and vertical radius for the cylinder.
5 To ensure that the cylinder remains proportionately the same when 

resized, leave the Lock Ratio checkbox checked. If you clear this 
checkbox, then you can manually resize the cylinder in any direction, 
regardless of its original measurements.

6 To have the cylinder appear smooth in the Shaded view, leave the 
Smooth Shading option enabled; to see a faceted cylinder in the 
Shaded view, disable this option. The default for this option is ON.

7 To change the default number of cylinder segments, clear the Use 
Document Defaults checkbox and type the new number of segments. 
Note that the higher the number of segments, the better the cylinder 
will appear in Shaded view, but the more performance will degrade.

8 Click OK.

Drawing spheres

Spheres are solid 3D circular or oval objects. 

There are two ways in which you can draw spheres:

 Non-interactive mode in which you type the exact horizontal radius, 
depth radius and vertical radius of the sphere.

 Interactive mode in which you click and drag to set the dimensions of 
the sphere.

 The Interactive Mode button.
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To draw a sphere in non-interactive mode

1 From the Draw menu, choose Sphere. 

Tip: You can also click the Sphere tool on the Draw toolbar. 

Result: The New Sphere window appears.

2 In the Horizontal Radius box, type the horizontal radius for the middle 
of the sphere.

3 In the Depth Radius box, type the depth radius for the middle of the 
sphere.

4 In the Vertical Radius box, type the vertical radius for height of the 
middle of the sphere.

5 To ensure that the sphere remains proportionately the same when 
resized, leave the Lock Ratio checkbox checked. If you clear this 
checkbox, then you can manually resize the sphere in any direction, 
regardless of its original measurements.

6 To change the default number of sphere segments and stacks, clear 
the Use Defaults checkbox and type the new values for Number of 
Segments and Number of Stacks. Note that the higher the number of 
segments or stacks, the better the sphere will appear in Shaded 
view, but the more performance will degrade.

7 To have the sphere appear smooth in the Shaded view, leave the 
Smooth Shading option enabled; to see a faceted sphere in the Shaded 
view, disable this option. The default for this option is ON.

8 Click OK. 
Result: The sphere is attached to the cursor.

9 Click to place the sphere in the drawing.

 The Sphere button.
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To draw a sphere in interactive mode

1 From the Draw menu, choose Sphere. 

Tip: You can also click the Sphere tool on the Draw toolbar. 

2 In the New Sphere window, click Interactive.
3 Click and drag out the shape of the sphere in your drawing. When 

you have the desired size, click again.
Result: The New Sphere window appears again.

4 In the New Sphere dialog box, you can change the default Horizontal 
Radius, Depth Radius, and Vertical Radius of the new sphere.

5 To ensure that the sphere remains proportionately the same when 
resized, leave the Lock Ratio checkbox checked. If you clear this 
checkbox, then you can manually resize the sphere in any direction, 
regardless of its original measurements.

6 To change the default number of sphere segments and stacks, clear 
the Use Defaults checkbox and type the new values for Number of 
Segments and Number of Stacks. Note that the higher the number of 
segments or stacks, the better the sphere will appear in Shaded 
view, but the more performance will degrade.

7 To have the sphere appear smooth in the Shaded view, leave the 
Smooth Shading option enabled; to see a faceted sphere in the Shaded 
view, disable this option. The default for this option is ON.

8 Click OK.

Drawing cones

Cones are solid 3D objects. 

There are two ways in which you can draw cones:

 Non-interactive mode in which you type the exact horizontal and 
vertical radius of the cone.

 Interactive mode in which you click and drag to set the dimensions of 
the cone.

 The Sphere button.
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To draw a cone in non-interactive mode

1 From the Draw menu, choose Cone. 

Tip: You can also click the Cone tool on the Draw toolbar. 

Result: The New Cone window appears.

2 In the Height box, type the height of the cone.
3 In the Horizontal Radius box, type the horizontal radius for the cone.
4 In the Vertical Radius box, type the vertical radius for the cone.
5 To ensure that the cone remains proportionately the same when 

resized, leave the Lock Ratio checkbox checked. If you clear this 
checkbox, then you can manually resize the cone in any direction, 
regardless of its original measurements.

6 To change the default number of cone segments and stacks, clear 
the Use Defaults checkbox and type the new values for Number of 
Segments and Number of Stacks. Note that the higher the number of 
segments or stacks, the better the cone will appear in Shaded view, 
but the more performance will degrade.

7 To have the cone appear smooth in the Shaded view, leave the 
Smooth Shading option enabled; to see a faceted cone in the Shaded 
view, disable this option. The default for this option is ON.

8 To enable hatching for the object, select the Show Hatch Lines 
checkbox.

9 Select the desired hatching style for the object from the Hatch Style  
drop-down list.

10 Click OK. 
Result: The cone is attached to the cursor.

11 Click to place the cone in the drawing.

 The Cone button.
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To draw a cone in interactive mode

1 From the Draw menu, choose Cone. 

Tip: You can also click the Cone tool on the Draw toolbar. 

2 In the New Cone window, click Interactive.
3 Accept the default values, and then click and drag out the shape of 

the cone in your drawing. When you have the desired size, click 
again.
Result: The New Cone window appears again.

4 In the dialog box that opens, type the height and the horizontal and 
vertical radius of the new cone.

5 To ensure that the cone remains proportionately the same when 
resized, leave the Lock Ratio checkbox checked. If you clear this 
checkbox, then you can manually resize the cone in any direction, 
regardless of its original measurements.

6 To change the default number of cone segments and stacks, clear 
the Use Defaults checkbox and type the new values for Number of 
Segments and Number of Stacks. Note that the higher the number of 
segments or stacks, the better the sphere will appear in Shaded 
view, but the more performance will degrade.

7 To have the cone appear smooth in the Shaded view, leave the 
Smooth Shading option enabled; to see a faceted cone in the Shaded 
view, disable this option. The default for this option is ON.

8 To enable hatching for the object, select the Show Hatch Lines 
checkbox.

9 Select the desired hatching style for the object from the Hatch Style 
drop-down list.

10 Click OK.
11 Click in the drawing to finish placing the new cone.

Drawing pipes

For details on drawing pipes and curved pipes, refer to “Drawing pipes”in 
the “Hang Structures” section.

Drawing rigging points

For details on drawing rigging points, refer to “Drawing rigging points” in 
the “Hang Structures” section.

 The Cone button.
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Drawing focus objects

For details on drawing focus objects, such as focus positions, focus lines 
and focus arcs, refer to “Focus objects”in the “Hanging and focusing 
fixtures” section.

Drawing screens

You can draw a screen and then attach an image or video source or 
subsource to it. 

To draw a screen

1 From the Draw menu, click Screen.

Result: The New Screen window appears.

2 In the appropriate fields, enter the width and height of the screen.
3 To configure the image that will appear on the screen, click the 

appropriate option button:
 To leave the screen blank, click the Blank Screen option button.

 To show a static image on the screen, follow the procedures in 
the Image Manager section. For details, see “Image Manager”.

 To attach a video source to the screen, click the Video Source 
option button, and from the drop-down list, choose the video 
source or video subsource, or an I-Mag screen from a WYSIWYG 
Camera, (or click Create New to configure a new video source with 
the Video Manager). For details on creating a new video source, 
see “To configure a new video source for streaming video”. For 
details on splitting video into subsources, see “To create a single 
video subsource”. For details on creating an I-Mag Camera 
source, see “To create an I-Mag Camera in the Video Manager”.

 The Screen button.
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4 Click OK.
Result:  The screen is placed into the drawing.

Creating video walls with screens 
After a screen has been created, the Grid Array tool can be applied to 
build a video wall. Applying Grid Array opens the Quick Video/Image Tool 
where you can set the video/image sources to the screen panels that 
were created. 
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To create video walls with screens

1 In Front or Back view in Wireframe, select the screen.

2 From the Tools menu, click Array > Array Grid.
Result: The Grid Array window appears.

3 In the Grid Array window, modify the settings as desired. Refer to 
“Array” for information on Grid Array settings.

4 Click OK.
Result: The Quick Video/Image Tool appears.

5 In the Quick Video/Image Tool window, specify the video or image 
sources and subsources for the video wall that was created.
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6 Click OK.
Result: The video wall is created with the video or image applied to 
the individual screens.

Notes: 

 The Quick Video/Image Tool can be applied to previously drawn screen 
files, if re-arranged into rows and columns that WYSIWYG can 
recognize and automatically apply subsources to the individual 
screens.

 The Quick Video/Image Tool can be applied to missing panels in the 
video wall if WYSIWYG can recognize the arrangement of rows and 
columns. 

 The functionality of the Quick Video/Image Tool remains available if no 
screens are selected.

Screen properties
After a screen has been created, the properties of a screen can be 
altered from the properties menu. The following properties of the screen 
can be changed:

 Dimensions: The size of the screen can be changed from its original 
dimensions. 
 Screen Width: The width of the screen.
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 Screen Height: The height of the screen.
 Display Source: Options for controlling what will be visible on the 

screen.
 Display Source: Drop-down list for selecting what will be visible on 

the screen.
 Image Source: Available images that can be displayed on the 

screen.
 Video Source: Available videos that can be displayed on the screen. 
 Keep Aspect Ratio: Toggle whether to have images/videos displayed 

on the screen maintain their aspect ratio or stretch/constrict when 
the size of the screen changes.

 Reassign Video/Image Subsource(s): This checkbox is available when 
the screen is set with Multi-split subsources. Select this checkbox 
to open the Reassign Video/Image Subsource dialog box and reassign 
the video and image source types and options for the screen.

 Glow Settings: Setting for controlling the glow of the selected 
screen, independent of the global settings.
 Hide: Toggle to enable/disable the screen glow feature.
 Glow Intensity Multiplier: When enabled can enhance the glow of the 

screen on a scale of 0 to 10.

Drawing cameras

You can add cameras to the drawing to provide additional view points in 
shaded views and renderings.

Note: For tips on moving your cameras, see “Camera controls”.

To insert a camera

The following procedure outlines how to insert a camera in a Wireframe 
view. For details on creating a camera directly from the Shaded view, see 
“To create a camera from shaded view”.

1 From the Draw menu, click Camera > Camera.

Result: The New Camera properties dialog box appears.
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2 Type a name for the camera and a value in degrees for the field 
angle. The default value for the field angle is 53.13.

3 From the Layer drop-down list, select the layer of your file on which 
you want to draw the camera. By default, the Camera object is 
inserted on the Camera layer.
Note: If you do not see all layers in the Layer drop-down list, click 
Show non-editable layers.

4 (Optional) Select the Aspect Ratio checkbox to set a fixed Aspect Ratio 
for the new camera. From the Aspect Ratio drop-down list, select the 
fixed Aspect Ratio for the new camera.
Result: The Shaded view will be defined by the set Aspect Ratio of 
the selected Camera, with pillar or letter bars displayed to indicate 
the viewing definition boundaries.

5 Click OK to apply the settings or Cancel to discard.
6 Click on the drawing to place the camera.
7 Drag the cursor to aim the camera, and then click to place the target. 

Result: The camera is inserted into your drawing and available in the 
camera selection list for shaded views and renderings. 

Tip: Use the missing coordinate tool while placing the camera and 
target.

Note: The target of your camera is easily identifiable in Wireframe views 
as defined by the marker points of the camera drawing. Camera drawings 
are invisible in shaded views because you are looking through the 
camera. For this reason, in this view you can choose to display the 
target. For more information on displaying the target, refer to “Modifying 
shaded views” or see “Using the camera toolbar”.

Using the camera toolbar
After you have drawn a camera, you can use the Camera toolbar in 
Shaded views to view your drawing through the camera of your choice. 

You can also use this toolbar to quickly access the camera Properties page 
and change properties, such as the camera name and field angle, and to 
lock the camera in place so that you cannot accidentally move it. For 
details, see the procedures on the next page.

Finally, the Camera toolbar also enables you to quickly insert a camera 
directly from the shaded view, based on the current viewpoint. For 
details, see “To create a camera from shaded view”.
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To switch to a camera using the Camera toolbar

1 In CAD, Design, or Live mode, click the Quad or Shaded tab.

2 Right-click in the toolbar area and select Camera.
Result: The Camera toolbar appears.

3 From the Current Camera drop-down list, select the camera through 
which you want to view your model.
Note: To switch back to the default view, select World, and then click 
the Reset Camera button to reset the view.
Result: The viewpoint switches to reflect that of the currently 
selected camera.

To use Camera hotkeys

To help you quickly switch from one Camera to another, Number/
Numpad keys 1 through 9 are now automatically assigned to new 
Cameras as you create them. 

Hotkeys are assigned in ascending order (starting with 1 for the first 
Camera you create, 2 for the next one, and so on, all the way to 9). 

1 On the number pad of your keyboard, ensure that the NUM LOCK is 
activated.

2 In WYSIWYG, click to view your drawing in a Shaded view.
3 On the Number Pad of your keyboard, press the numbers associated 

with the Cameras in your drawing to switch quickly from one Camera 
to another.

Tip: Press the 0 key to quickly switch to the World camera. 

Click to select 
the desired 
camera from 
the list

Click to view the 
Camera’s properties

Click to lock the Camera in 
its current position - does not 
work for default camera

Click to save the current 
Shaded view viewpoint 
as a new Camera

Click to reset the view to 
the default position

Camera reset buttons for 
rotations on the X, Y, and 
Z axes. 

The Pitch, Roll and Yaw 
locks for rotations (around 
the X, Y, and Z axes).

Click to view 
Camera Manager

Click to enable/disable 
DMX Control of Cameras/
Camera Paths
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To change or delete the Camera hotkey assignment

To change or delete the hotkey assignment for a Camera, complete the 
following steps.

1 Select the Camera, right-click, and select Properties.

2 Click the Camera tab.
3 From the Assigned Hotkey drop-down list, select the new hotkey; to 

remove a hotkey assignment, simply choose None from the same 
drop-down list.

4 Click OK.

Note: Hotkey assignments can be set and changed in the Camera Manager 
window, see “Camera Manager”.

To view or edit Camera Properties

1 In CAD, Design, or Live mode, click the Quad or Shaded tab.

2 Right-click on the toolbar area and select Camera.
Result: The Camera toolbar appears.

3 From the Current Camera drop-down list, select the camera whose 
Properties you want to view.

4 On the Camera toolbar, click the Camera Properties button. 
5 In the window that appears, you can change any of the following 

properties:
 Name: You can edit the name that appears on the Camera toolbar 

for the selected Camera.

 Field Angle: You can change the field angle of the currently 
selected Camera, measured in degrees.

 Assigned Hotkey: Click to assign a new numbered hotkey for this 
Camera. This is the number that you can press from your Number 
pad to instantly switch from one Camera to the next.

 Aspect Ratio: Select this checkbox and choose a fixed Aspect Ratio 
for the selected Camera.

 Lock camera in Shaded View: Select this checkbox to lock the 
selected camera in its current position in all shaded views. To 
unlock it, simply select the camera from the Camera toolbar, and 
then press the Camera Lock button. 

 DMX Patch: In this section, you can assign a DMX value to the 
camera when the Assigned Hotkey is set to None. Select a value 
from the Assigned DMX Value drop-down list. 

Note: When a hotkey of 1-9 is assigned, the DMX value matching 
the hotkey number is automatically assigned.
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 DMX Patch enables the DMX control of the switching between 
Cameras in Live mode, instead of using the drop-down list on 
the Camera toolbar or the numpad hotkeys.

 Assigned DMX Value drop-down list goes from #10-255 (#1-9 
are reserved for hot key assignments).

 When the camera has an assigned hotkey, the Assigned DMX 
Value drop-down list will display the hotkey value as read-only.

 Enable DMX Control of Cameras/Camera Paths must be enabled in 
the Camera Manager window to enable DMX control of the 
cameras. Refer to “Camera Manager”.

To lock a Camera

Follow the steps below to lock a Camera in its current position in the 
shaded view. This feature helps prevent you from accidentally moving or 
zooming a camera while adjust the viewpoint in the shaded view. 

1 In CAD, Design, or Live mode, click the Quad or Shaded tab.

2 Right-click on the toolbar area and select Camera.
Result: The Camera toolbar appears.

3 From the Current Camera drop-down list, select the camera that you 
want to lock in position.

4 On the Camera toolbar, click the Camera Lock icon. 

Result: The Camera is now locked in position in the shaded view. 
Whenever you select this camera and attempt to adjust the 
viewpoint in the shaded view, a lock symbol appears in the middle of 
the shaded view. To unlock the Camera, simply select it from the 
Camera toolbar, and press the Camera Lock icon again.

To use the Pitch, Roll and Yaw locks for rotations 

Use the Lock-X, Lock-Y, and Lock-Z buttons on the Camera toolbar to 
prevent in-place rotations along the specified axis:

 Lock-X, or Rotation around the X Axis = PITCH [tilting forward and 
backward]

 Lock-Y, or Rotation around the Y Axis = ROLL [tilting side to side]
 Lock-Z, or Rotation around the Z Axis = YAW [also called Heading or 

Direction]

 The Camera Lock button.
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To see the effect of these locks in the Shaded view, you must press ALT 
while dragging the view; these locks have no effect if you do not press 
ALT. 

Note: Press the reset buttons (Rx, Ry, Rz) to re-orient the camera to the 
world's axes. 

Drawing camera paths

Camera paths allow you to define a path along which the camera will 
travel during playback in the Shaded View, either in Design or Live 
Modes. You draw Camera paths in CAD Mode just as you would draw a 
spline. Each point along the path is called a “Node”. 

Note: You can keep the camera path, nodes and targets visible during 
file editing, and once you’re done, go into the Properties of these objects 
and toggle their visibility off in Shaded View.

To draw a Camera path

1 In Wireframe view, from the Draw menu, click Camera > Camera 
Path.

2 Click in your plot where you want to start drawing the Camera path.
3 Continue clicking in your drawing to create your path. When you are 

finished, right-click and select one of the options on the pop-up 
menu:
 Finish Camera Path: This option finishes the path at the last point, 

and places it in your plot.

 Close Camera Path: This option closes the path from one end to 
the next, and places the path in your plot.

 Abort Camera Path: This option cancels the drawing of the Camera 
path altogether.

 Remove Last Step: This option removes the last point of the path.

Note: Camera paths are controlled from Design and/or Live modes, 
using the Camera Path Editor and the Timeline tool. For details, see 
“Using the camera path editor”.

Camera path properties

Camera Paths have unique properties, as shown below:
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 Name: Camera Paths can have unique names
 Shaded View Options

 Show Camera Path in Shaded Views: This option shows or hides the 
Camera Path in Shaded Views while playing the path.

 Use Layer Rendering Color: This option controls the color of the 
Camera Path and its Layer behavior.

 Show Nodes: This option shows or hides the Nodes along the 
Camera Path.

 Show Node Numbers: This option shows or hides the Node numbers 
along the Camera Path.

 CAD Options
 Closed: If checked, this option enables the Camera Path to play as 

a continuous loop with no gaps.
 Tension: A value between 0 and 1, where 0 is no tension and 1 is 

maximum tension; this option enables the Camera Path to allow 
curving between nodes along the path. If the Tension is set to 0, 
the nodes will be connected with straight lines.

 Camera Path Arrow - Size: This option allows you to control the size of 
the direction arrows on the Camera Path.

 Patch
 None: Select this option if the Camera Path is not patched.
 DMX Patch: Select this option if the Camera Path is patched, and 

then enter the patch properties.
 Aspect Ratio: This option allows you to select a fixed Aspect Ratio for 

this Camera Path.
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Drawing camera targets

After you draw a Camera path, you can also insert a “Camera target” at 
points of interest where you would like the camera to focus while 
traveling along a path.

Note: You can keep the camera path, nodes and targets visible during 
file editing, and once you’re done, go into the Properties of these objects 
and toggle their visibility off in Shaded View.

To draw a Camera target

1 In Wireframe view, from the Draw menu, click Camera > Camera 
Target.

2 Type a descriptive name for the camera target.
3 Click OK and then click to place the target along the camera path.

Camera target properties

Camera targets also have unique properties, as seen below:

 Label: Camera targets can have unique labels.
 Height: This controls the height of the text associated with the 

Camera Target.
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 Align to View: This option aligns the target to the specific view that it 
is in (i.e., Side, Front, Back, Iso)

 Show Label: This option shows or hides the Camera Target label text.
 Shaded View Options

 Show in Shaded Views:  This option shows or hides the Camera 
Target in Shaded Views while playing the path.

 Use Layer Rendering Color: This controls the color of the Camera 
target and its Layer behaviour.

 Text Justification: This section controls the Horizontal and Vertical 
alignment of the text associated with the Camera Target.

 X, Y, and Z Coordinates: These options allow you to control the position 
in 3D space of the Camera Target.

 Font: This section displays options that allow you control of the font 
face of the Camera Target. Settings in Document Defaults are used 
by default.
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Drawing a compass

You can add a compass to a drawing to define the direction that is north. 
This definition is important to set the position of the sun and/or moon for 
renderings and Shaded views that use environmental options. 

Note: There can be only one compass in a file. 

In the top image, an example of a path and camera target is 
drawn. In the bottom image, the camera at each node of the path 
is now pointing to the camera target.
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To draw a compass

1 From the Tools menu, choose Define North. 

2 Click to place the starting point of the compass.
3 Click to place the end point of the compass. The end point must be 

directly north of the start point.
Result: A compass is drawn, centered on the start point and pointing 
towards the end point.

Notes: 

 To remove the compass from the drawing, choose Clear Direction 
from the Tools menu.

 To redefine north, repeat steps 1-3. You do not need to remove the 
compass from the drawing when redefining north as there can be 
only one compass in a file.

Drawing motion axes

For every motion axis that you draw in CAD mode, you can attach one or 
more objects to it, and then define the object’s position along the axis. 
You can attach objects such as risers, library objects, or custom objects 
that you have drawn. 

To be able to move an object in different planes, you can attach multiple 
motion axes to one another. Simply attach the object to one of the axes, 
and then control the object’s movement along any of the axes by 
selecting it with the Moving Scenery Designer tool. This feature is useful, 
for example, if you have a set piece that needs to be able to move in 
both a vertical and horizontal motion. 

Notes: 

 When attaching axes to one another, you cannot create a circular 
linking pattern. For example, you can link Axis A to Axis B, and then 
link Axis B to Axis C, but you cannot then link Axis C back to Axis A 
because this creates a circular link.

 You cannot attach fixtures to motion axes; however, you can attach 
pipes that hold fixtures to axes. 

 Currently, you cannot attach focus positions or groups containing 
focus positions to motion axes. However, in future releases you will 
be able to attach either of these items to motion axes.

You can draw axes either diagonally or straight along any direction of 
movement—X, Y, or Z—choosing between the following two main types of 
axes:

 Linear: Choose this type of axis to have an object move in a straight 
line along the path that you specify (or in a series of straight 
segments all joined together at different vertices to create the path). 
You can create a linear axis in any length or shape that you require, 
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as long as it comprises straight line segments; you cannot draw a 
curved axis. For example, you could have a person walk across a 
stage in a zig zag path, if desired. 
When you draw this type of axis, and then attach an object to it, the 
distance from the axis to the object does not affect the object’s 
movement; the object will always follow the path of the axis 
regardless of where you have placed the axis or object. 
By default, all linear axes are displayed in your drawing with the label 
name, and shows an arrow on one end, signaling the direction in 
which the object will move. In the Properties page, the axes names 
are displayed with the prefix “[AX-L] to identify a Linear axis. 
You can change the name placement and adjust the size of the arrow 
by opening the Properties page for the axis. 

 Rotation: Choose this type of axis if you want to have an object 
rotate in a circular motion. When you click to place this type of axis 
in your drawing, a circle with a center dot appears. The circle acts as 
a visual cue, telling you the direction in which the object will rotate; 
the center dot is the actual axis around which the object rotates. 
The orientation of the object’s rotation changes based on the view in 
which you draw the axis (plan, side, or front/back). When placing the 
object to be rotated in your drawing, note that its position relative to 
the center dot of the rotation axis is important. The distance from 
the center dot to the object represents the size of the circle in which 
it will rotate, with the dot marking the center of the circle. To have 
the object rotate in a very tight circle (for example, a dancer doing a 
pirouette, or a spinning object), place the object directly on the 
center dot. 
By default, all rotation axes are displayed in your drawing with the 
label name, and shows an arrow on one end, signaling the direction 
in which the object will rotate. You can change the name placement 
by opening the Properties page for the axis. In the Properties page, 
the axes names are displayed with the prefix “[AX-R]” to identify as 
Rotation axis. While you cannot adjust the size of the arrow head 
directly, you can click and drag the circle to the desired size, which 
adjusts the arrow head proportionately. To change the direction of 
the object’s rotation, switch views, and then drag the center point to 
the new orientation.

To draw a linear motion axis

1 In Wireframe view, select the view in which you want to draw the 
axis (plan, front, back, side, or isometric).

2 Click Draw > Axis > Linear Axis.
3 In the window that appears, type a name for the axis, and then click 

OK.
4 In your drawing, click in the position where you want to start the 

axis, and then move your cursor to the next point of the axis and 
click. To create an axis with multiple segments, continue clicking at 
each point (vertex) of the axis. 
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5 When you are finished creating the axis, right-click and choose Finish 
Axis.

To draw a rotation motion axis

Unlike linear axes, rotation axes cannot have multiple vertices. Instead, 
when you draw one of these axes, the object rotates around the center 
point.

1 In Wireframe view, select the view in which you want to draw the 
axis (plan, front, back, side, or isometric).

2 Click Draw > Axis > Rotation Axis.
3 In the window that appears, type a name for the axis, and then click 

OK.
4 In your drawing, click in the position where you want the axis to 

appear.

Note: The circle that appears when you draw a rotation axis is only a 
visual cue to show you the direction in which the object rotates—it does 
not affect the size of path on which the object rotates. The circle is given 
a default size, but you can change it to suit your needs.

To patch a motion axis to a DMX universe

To move the object with a DMX control, you first have to attach the 
motion axis to a named DMX patch universe that you have created in 
Data mode.

Note: For information on creating a patch universe, see “To create a new 
patch universe”.

1 Click to select the axis that you want to attach to the patch universe.

2 Right-click and select Properties.
3 Click the Axis tab.
4 From the Patch Type drop-down list, select DMX Patch.
5 From the Universe drop-down list, select the DMX patch universe to 

which you want to attach the axis.
6 In the Address box, type the starting DMX address.
7 Click OK.

To patch a motion axis to a motion universe

To move the object with a motion control system, you first have to attach 
the motion axis to a named motion control patch universe that you have 
created in Data mode. 
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Note: For information on creating a patch universe, see “To create a new 
patch universe”.

1 Click to select the axis that you want to attach to the patch universe.

2 Right-click and select Properties.
3 Click the Axis tab.
4 From the Patch Type drop-down list, select Motion Patch.
5 From the Universe drop-down list, select the motion control patch 

universe to which you want to attach the axis.
6 From the ID drop-down list, select the ID on the motion control 

system with which you want to associate this axis. 
Note: The motion control system must be connected to your 
computer for the ID to appear in this drop-down list. If the system is 
not currently connected, you can also type the ID directly into this 
drop-down list.

7 Click OK.

To attach an object to a motion axis

Notes: 

 You can attach one or more objects to each axis; however, each 
object can be attached to only one axis at a time. 

 When you attach an object to a linear axis, the distance from the axis 
to the object does not affect the object’s movement; the object will 
always follow the path of the axis regardless of where you have 
placed the axis or object. 

 When placing the object to be rotated in your drawing, note that its 
position relative to the rotational axis is important. The distance from 
the central point of the axis to the object represents the size of the 
circle in which it will rotate. To have the object rotate in a very tight 
circle (for example, a dancer doing a pirouette, or a spinning object), 
place the object directly on the center point of the axis.

1 Place the object that you want to attach to the axis at the 
appropriate position in your drawing, either by adding a new object, 
or moving an existing object to this location.

2 Select the object, right-click, and then choose Properties.
3 On the General tab, from the Attach to Axis drop-down list, select the 

axis to which you want to attach this object.
Note: The label names of the drawn axes that appear on the drop-
down list are displayed with prefixes to identify as either Linear “[AX-
L] name” or Rotation “[AX-R] name”.

4 Click OK.
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To add a vertex to a linear motion axis

To change the path of an existing linear axis, you can add one or more 
vertices, and then drag these vertices to the new position.

1 In your drawing, click on the point of the axis at which you want to 
add a vertex.

2 Right-click and select Add Vertex.
Result: The vertex is added at the point where you clicked.

Tip: To change the path of the axis, click to select the axis and view 
all the vertices. Click the desired vertex, drag it to the new position, 
and then release the mouse. Any objects that are attached to the 
axis will now follow the new path.

Motion frames

The Frame Motion System delivers more functionality and flexibility than 
its predecessor, the Axis system. A single motion frame can simulate 
motion for up to six Degrees of Freedom (DoF) for each frame.

Much like the motion axis, you can attach one or more objects to a single 
motion frame, and then define the motion ranges of each DoF.

Notes: 

 When attaching one frame to another, you cannot create a circular 
linking pattern.

 You cannot attach fixtures to frames; however, you can attach pipes 
that hold fixtures to axes.

To draw a motion frame

1 In a Wireframe view, select the view in which you want to draw the 
frame.

2 Click Draw > Frame.

3 In the window that appears, type the name of the frame, and then 
click OK.

4 In your drawing, click in the position where you want the frame to 
appear.
Result: The motion frame is inserted in your drawing with its label 
name on display.

To adjust the motion range

1 In a Wireframe view, select the frame that you want to adjust.

2 Right-click and select Properties.
3 Select the Motion Ranges tab. 



Reference Guide 347

January 2019 CAD mode - Creating Objects 

4 To restrict the motion frame, click to enable/disable any of the six 
Degrees of Freedom (DoF) shown, and then adjust the movement 
ranges of each DoF by modifying the Minimum and Maximum values 
for each corresponding axis.

5 To enforce these motion ranges while controlling objects in Live 
mode, click to enable the Use Motion Ranges in Live Mode checkbox.

6 Click OK. 

To patch a frame to a DMX universe

To move the object with a DMX control, you have to attach the motion 
frame to a named DMX patch universe that you have created in Data 
mode. Patching a single motion frame creates 12 DMX channels: X, X 
Fine, Y, Y Fine, Z, Z Fine, Rx, Rx Fine, Ry Fine, Rz Fine.

Note:  For information on creating a patch universe, see “To create a 
new patch universe”.

1 Click to select the axis that you want to attach to the patch universe.

2 Right-click and select Properties.
3 Click the Axis tab.
4 From the Patch Type drop-down list, select DMX Patch.
5 From the Universe drop-down list, select the DMX patch universe to 

which you want to attach the axis.
6 In the Address box, type the starting DMX address.
7 Click OK.

To patch a frame to a motion universe

To move the object with a motion control system, you first have to attach 
the frame to a named motion control patch universe that you have 
created in Data mode.

Note: For information on creating a patch universe, see “To create a new 
patch universe”.

1 Click to select the frame that you want to attach to the patch 
universe.

2 Right-click and select Properties.
3 Click the Axis tab.
4 From the Patch Type drop-down list, select Motion Patch.
5 From the Universe drop-down list, select the motion control patch 

universe to which you want to attach the axis.
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6 From the ID drop-down list, select the ID on the motion control 
system with which you want to associate this axis.
Note: The motion control system must be connected to your 
computer for the ID to appear in this drop-down list. If the system is 
not currently connected, you can also type the ID directly into this 
drop-down list.

7 Click OK.

To attach an object to a frame

Notes: 

 You can attach one or more objects to each frame; however, each 
object can be attached to only one frame at a time.

 When placing the object to be rotated in your drawing, note that its 
position relative to the frame is important. The distance from the 
central point of the frame to the object represents the size of the 
circle in which it will rotate.

 To have the object rotate in a very tight circle (for example, a dancer 
doing a pirouette, or a spinning object), place the object directly on 
the center point of the frame.

1 Place the object that you want to attach to the frame at the 
appropriate position in your drawing, either by adding a new object, 
or moving an existing object to this location.

2 Select the object, right-click, and then choose Properties.
3 On the General tab, from the Attach to Axis drop-down list, select the 

Frame to which you want to attach this object.
Note: The label names of the drawn frames that appear on the drop-
down list are displayed with prefixes to identify as a Frame “[FRM] 
name”.

4 Click OK.

BlackTrax Trackable frames
BlackTrax Trackable Frames are Motion Frames specifically designed for 
use with BlackTrax. When a BlackTrax Trackable Frame is patched to a 
DMX and Motion Universe, and an object is attached to the frame, 
BlackTrax will use this information to create a Trackable. A Trackable is 
an object in BlackTrax whose real time location you want the BlackTrax 
system to track.

To draw a BlackTrax Trackable Frame

1 In a Wireframe view, select the view in which you want to draw the 
frame.

2 Click Draw > BlackTrax Trackable.
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3 In the window that appears, type the name of the frame, and then 
click OK.

4 In your drawing, click in the position where you want the frame to 
appear.

Viewing moving scenery
After you create the axes/frames and attach the objects to them, you can 
watch the objects move along the axes/frames by using the Looks 
feature in Design mode. Just as you can simulate moving lights by cross-
fading between one lighting look to the next, you can also simulate 
moving scenery by creating Looks that contain motion axes/frames and 
fading from one Look to the next. For more information, see “To view 
moving scenery”.

You can also patch the axis in Data mode so you can control the 
movement of the object with either a DMX console device, such as a Mini 
Console, or a motion control system. For details on patching motion 
axes, see “To patch a motion axis to a DMX console device” or “To patch 
a motion axis to a motion control system”.

Creating complex motion systems
To create more complex motion systems (for example, to have an object 
revolve around itself or around another object while it is also moving 
across the stage), you can attach motion frames to axes, or vice versa 
(you can attach axes to motion frames). 

Quick motion patch tool

The Quick Motion Patch Tool allows you to quickly and easily manage the 
patching of all frames and axes in CAD Wireframe view. The tool allows 
for frames and axes to be patched or cleared from any created universe. 
A summary of patching activity is also displayed in the tool for your 
convenience. 
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To patch Frames/Axes to a motion universe using the Quick 
Motion Patch Tool

1 Select the Frames/Axes you want to patch.

2 Click Tools > Quick Tools > Quick Motion Patch Tool.
Result: The Quick Motion Patch Tool window appears.

3 In the Auto-Patch Motion section, from the Motion Universe Name 
drop-down list, select the motion universe the frames/axes will patch 
to.

4 Select either All Frames/Axes OR Only Selected Frames/Axes to patch to 
the motion universe.

5 Click Patch.
Result: The chosen frames/axes will be patched to the selected 
motion universe. A summary of the frames'/axes' patching will be 
displayed at the bottom of the Quick Motion Patch Tool window
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To clear Frames/Axes from a motion universe using the 
Quick Motion Patch Tool

1 Select the Frames/Axes you want to clear.

2 Click Tools > Quick Tools > Quick Motion Patch Tool.
Result: The Quick Motion Patch Tool window appears.

3 In the Clear Motion Patch section, select either All Frames/Axes OR 
Only Selected Frames/Axes to be cleared the from the motion universe.

4 Select Only Selected Universe radio to clear the selected frames/axes 
from only a specific motion universe. Select the specific universe 
from the drop-down list. Otherwise, the selected frames/axes will be 
cleared from all universes. 

5 Click Clear.
6 The chosen frames/axes will be cleared from the selected motion 

universe. A summary of the frames'/axes' patching will be displayed 
at the bottom of the Quick Motion Patch Tool window.

Saving custom library items

Custom library items are made of one or more objects, including custom 
items that you have drawn, as well as existing library items. You can 
save a custom library item for a complex object that you have drawn and 
think you might want to use again. 

When you save custom library items, all of the item’s original properties 
are saved, including its texture and color. In addition, if the item that you 
are saving is broken down into separate elements, then these elements 
are also saved with the item and can be viewed on the Appearance tab. 
For example, if you are saving an object like a riser, each of the four riser 
elements is saved with the custom library item. 
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Notes: 

 You cannot save fixtures or hanging structures, such as pipes and 
truss, as components of custom library items.

 You cannot rename the elements of custom library items in the 
Appearance tab; therefore, it is recommended that you give elements 
custom names before you save the item as a custom object. For 
details, see “To rename object elements”.

To create a custom library item

1 Select the objects to be saved as a custom item.

2 From the Library menu, choose Create New Library Item. 
Tip: If the menu item is greyed out, one or more of the objects 
selected cannot be included in the custom library item. 

3 Pick a base point for the item. This will become the insertion point for 
the item.
Result: The Library Item Wizard opens displaying a rotating shaded 
view of your new item.

4 Type a name for the new library item.
5 To make this item available to other documents, check the 

appropriate box.
6 Click Next.
7 Add or modify the path, if desired.

Note: The path is the location in the library where the item will be 
stored. An item assigned to the path “Custom/Tables” would be 
available in the custom section of the items library in a sub-category 
named Tables.

8 Click Next.
9 Type all pertinent information including manufacturer, weight, and 

any notes.
10 Click Next.
11 Type your name.
12 Click Finish.

Result: The custom item is placed in the item library as per the path 
you specified in step 7.

Rules for deleting custom library items

In general, a custom library item that has been shared with the 
application library, (i.e. by selecting the Make this item available to other 
documents in the first step of its creation) can only be deleted from the 
Welcome Screen's Library Browser. A custom library item can be deleted 
from within a file as long as there are no instances of the item in the file.
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The following are specific examples of when a custom library item can be 
deleted.

 A custom library item that was created in a file, and was added to the 
application library, cannot be deleted from the Library Browser while a 
file is open. The custom library object now exists in the application 
Library Browser. To remove the custom library item, it must be deleted 
from Welcome Screen’s Library Browser. This deletion cannot be 
undone. 
Note: A custom library item will always be included in the “private 
library” of the file in which it was created. This means that if a 
custom library item is created (and used) in a file, then deleted from 
the application library, that item is still not removed from the file. 
Only once the item is removed from the application library, and the 
item is not in use in the file it was created in, may the item be 
deleted from the file. This deletion is permanent and cannot be 
undone.

 A custom library item that is created in a file, and is not added to 
the application library: 
 Can be deleted from the Library Browser inside the file if no 

instances of the item are inserted into the file. The deletion cannot 
be undone.

 Cannot be deleted from the Library Browser if there are instances of 
the custom item in the file. 

 A "DWG" library item (imported from AutoCAD file and listed in the 
Library Browser) can be deleted while the file is open if no instances of 
the item are inserted into the file. The deletion cannot be undone.

To delete a custom library item

If you do not want to keep a custom library item any longer, you can 
delete it from the Library Browser. 
1 In the Library Browser, navigate to the folder where you stored the 

custom library item. 

2 Highlight the library item name, and then right-click and choose 
Delete.
Note: This option is disabled if the item is currently inserted in your 
plot. You must delete the item from your plot, and then save and 
close the file. When you reopen the file you can delete the item from 
the Library Browser.

3 A message box appears telling you the action is irreversible. Click Yes 
to delete the item.
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Drawing pipe and drape

Use the Pipe and Drape Wizard to add lengths of drapery in your 
drawing. You can add default length and height of drapery, or specify 
custom sizes for your drapery panels, and define drapery properties such 
as color, texture, and material. 

The several components in a drape line are shown in the graphic:

 Drape panels: These are the individual pieces of fabric that hang 
from the horizontal pieces of pipe called crossbars. You can specify 
the number of drape panels in each of the pipe and drape drawing 
methods. The default number of panels is three per section.

 Section: A section consists of a series of drape panels hanging from 
a horizontal pipe called a crossbar, which is supported on each end 
by an upright pipe. You can specify the number of panels per section 
and, based on the drawing method you choose, either the exact 
width of the section or the maximum width.

 Upright pipes: These are the pipes that stand on either end of each 
section in your drape line, supporting the crossbar pipes. 

 Base plates: These are support plates for the upright pipes.

The Wizard offers you two drawing options:

 Draw: This option gives you the most flexibility when drawing your 
drape line. It enables you to specify the height, maximum width of a 
section, and the number of drape panels per section. When you click 
Finish, the Wizard returns you to the drawing where you can click and 
drag to draw as many drape lines as desired in whatever length 
required.

 Specify: This option enables you to define the height, width, the 
number of sections in your drape line, and the number of drape 
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panels per section. This option enables you to either draw a new 
drape line section, or add to an existing drape line.

To draw pipe and drape - Draw method

Note: If you are adding a new drape section to an existing panel in your 
drawing, click the Midpoints snap tool first. This ensures that the new 
drape panel “snaps” to the existing one in the correct position.

1 From the Draw menu, click Pipe and Drape Wizard.

Result: The Select Drawing Method window appears.
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2 Click the Draw option button, and then click Next.
Result: The Draw Pipe and Drape window appears. 

3 Select Create a New Drape Line option to create a new section of the 
drape line; or select the Add to an Existing Drape Line option to add the 
next section of the drape line.
Notes: 
 Drawing a new drape line includes all uprights for the drape line.

 Adding to an existing drape line uses an existing upright as the 
beginning of the added drape line. 

4 In the Height box, type the height of the drape line, or accept the 
default value of 15’0”.

5 In the Max. Crossbar Length box, type the maximum length of each 
horizontal pipe, or accept the default value of 10’0”. This is the 
length of the horizontal pipe in a section between the upright pipes. 
If you click to insert a section at a shorter interval than this value, 
WYSIWYG automatically adjusts the width of each drapery panel 
accordingly and a shorter section is inserted in the drawing.

6 Select the Use Equal Crossbar Length/Space Upright Evenly checkbox to 
automatically set the same length for all the crossbars. If you clear 
this checkbox, then WYSIWYG creates drapery panels of equal size 
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for all full-size sections, but resizes the panels in the last section 
accordingly if you choose to make this panel smaller.

7 In the Pipe Diameter box, type the diameter of all crossbars and 
upright pipes.

8 Click the Base Plate drop-down list box to select the size of the base 
plate support for the upright pipes.

9 Select the Add Base Plate Weight checkbox to add thickness to the base 
plate in Wireframe and Shaded views.

10 In the Drape Panels per Crossbar box, type the number of drape panels 
that you want to see in each section of the drape line, or accept the 
default value of 1 panel per section. 

11 The default or previously set texture of the drape is displayed in the 
Drape Texture box. To change the texture, click the Drape Texture 
ellipsis button to browse and select a new texture from the Texture 
Select dialog box that opens.

12 In the Drape Description box, type additional user information or 
identification for the drape line, which will be displayed in Reports.

13 Click Finish.
14 Click in the desired spot in your drawing where you want to start 

drawing the drape line. 
15 Move the cursor to the spot where you want the first section to end, 

and click. Then move your cursor to the spot where you want the 
next section to end, and click. You can draw as many sections as you 
like. When you are finished drawing your drape line, right-click and 
select Finish Pipe and Drape.

Note: For details on customizing the new drape line, see “To customize 
drapery elements (color, material, and texture)”.

To draw pipe and drape - Specify method

Note: If you are adding a new drape section to an existing panel in your 
drawing, click the Midpoints snap tool first. This ensures that the new 
drape panel “snaps” to the existing one in the correct position.
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1 From the Draw menu, click Pipe and Drape Wizard.

Result: The Select Drawing Method window appears.
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2 Click the Specify option button, and then click Next.
Result: The Specify Pipe and Drape window appears.

3 Select the Create a New Drape Line option to create a new section of 
the drape panel; or select the Add to an Existing Drape Line option to 
add the next section of the drape panel.
Notes: 
 Drawing a new drape line includes all uprights for the drape line.

 Adding to an existing drape line uses an existing upright as the 
beginning of the added drape line. 

4 To specify the total length of the drape line section, select Total Length 
and type the length of the drape line, or accept the default value of 
10’0”. The Crossbar Length option is disabled if the Total Length option is 
selected.

5 To specify drape line section by the length and quantity of it’s 
crossbars, select Crossbar Length and type the length of the crossbar, 
or accept the default value of 10’0”. The Total Length option is disabled 
if the Crossbar Length option is selected.
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6 In the Number of Crossbars box, type the number of crossbars in the 
drape line, or accept the default value of 1.
Note: The length of each crossbar will automatically change with 
reference to the specified Total Length and Number of Crossbars.

7 In the Height box, type the height of the drape line, or accept the 
default value of 15’0”.

8 In the Pipe Diameter box, type the diameter of all crossbars and 
upright pipes.

9 Click the Base Plate drop-down list box to select the size of the base 
plate support for the upright pipes.

10 Select the Add Base Plate Weight checkbox to add thickness to the base 
plate in Wireframe and Shaded views.

11 In the Drape Panels per Crossbar box, type the number of drape panels 
that you want to see in each section of the drape line, or accept the 
default value of 1 panel per section. 

12 The default or previously set texture of the drape is displayed in the 
Drape Texture box. To change the texture, click the Drape Texture 
ellipsis button to browse and select a new texture from the Texture 
Select dialog box that opens.

13 In the Drape Description box, type additional user information or 
identification for the drape line, which will be displayed in Reports.

14 Click Finish.
15 Click in the desired spot in your drawing where you want to start 

drawing the drape line. 
16 Move the cursor to the spot where you want the first section to end, 

and click. Then move your cursor to the spot where you want the 
next section to end, and click. You can draw as many sections as you 
like. When you are finished drawing your drape line, right-click and 
select Finish Pipe and Drape.

Note: For details on customizing the new drape line, see “To customize 
drapery elements (color, material, and texture)”.

To quickly change Pipe and Drape Wizard settings 

This procedure shows you how to quickly change some of the structural 
pipe and drape settings for a selected drape line, such as the height and 
diameter of the upright pipes and crossbars. Use this procedure to 
customize the structural properties of a single drape line. 

1 In your drawing, select the pipe and drape sections that you want to 
customize.To select multiple sections, press CTRL, and then click the 
appropriate sections.

Note: The sections that you select must have been drawn in the 
same way. For example, all drape lines created with Specify method.
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2 Right-click and select Change Pipe and Drape Settings.
Result: The appropriate Settings window appears. Based on the type 
of drape line that you selected, a different window appears.

3 Change any of the settings that you see in this window. For help on 
any of the boxes, click in the box, and then press F1.

4 Click Finish to save and apply your new settings.

To customize drapery elements (color, material, and 
texture)

You can add custom color, texture and material to selected drapery 
elements (such as the front and back of the drape panels, the crossbars, 
upright pipes, the drape loops that attach to the crossbars, or the drape 
lines as a whole). 

Notes: 

 If you select multiple drape lines in your drawing, you can apply the 
same properties to all of them simultaneously through the following 
procedure. However, note that if you had already selected varying 
properties (for example, if you had chosen one color for the front 
panel of some drape lines, but another color for the front panel of 
others), or if some of the elements had no properties selected at all, 
then when you choose new properties in the following procedure, it 
applies to all drape lines selected, overwriting any existing settings 
that you may have saved.

 When you select multiple drape lines, the Appearance tab only lists the 
properties of selected elements if they are common across all drape 
lines. For example, if the front panel of all selected drape lines 
already has the same custom texture applied, and it is set to tile in 
one meter squared intervals, then these values are shown in the 
Appearance tab. However, if at least one of the front panels in the 
selected drape lines has a different custom texture value applied, the 
Appearance tab does not list the texture settings at all. If you choose 
new texture settings, your choice overwrites all existing settings for 
the selected element across all selected drape lines. 

 You can apply the same properties to all drapery elements by 
highlighting “Group” in the Elements box. 

1 In your drawing, select the pipe and drape sections that you want to 
customize. To select multiple sections, press CTRL, and then click the 
appropriate sections.

2 With the desired sections selected, right-click and select Properties.
Result: The Properties window appears.

3 Click the Appearance tab.
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4 In the left pane, click the drapery element that you want to 
customize. For example, to customize the front of the drape panels 
(each panel is double-sided), click Drape Front. 
Note: You can select multiple elements by pressing CTRL, and then 
clicking the elements; you can select all elements by clicking Select 
All.

5 You have a choice of applying one of the following settings to the 
selected elements:
 Layer Rendering Color: Click this option to apply the same color as 

the current layer to the selected elements.

 Custom Color: To apply a custom color, click this option button, and then 
click the color box. In the resulting color dialog box, select the custom color 
that you want to use, or click Define Custom Colors to create your own 
color. Click OK, and then click Apply.

 Texture from Library: Click this option to apply a custom texture file 
from the WYSIWYG library to the selected elements, and then 
click the ellipsis button (...). In the resulting dialog box, navigate 
to and highlight the desired texture. Click Select.

 Image Source: Select this option to apply to the selected object(s) a 
custom texture file that you have created and saved in either 
.bmp, .jpeg, .png, or .gif format. To apply the image, you must 
create a new image source. To do so, click New, and then use the 
Image Manager to create a new image source with the image you 
created. See “To create a new image source in the image 
manager”for details.

 Video Source: You can apply a video source or a subsource as a 
“dynamic texture” to 3D primitives - surfaces, risers, spheres, 
cylinders, or cones - or individual elements of 3D primitives. 
Select this option to apply a previously created video source or 
subsource, or click New to create a new video source or subsource 
directly from this window. See “Video Manager”for details.

6 If you have chosen to apply a texture to the elements, you can 
choose how the texture will appear on the selected drapery elements 
as follows (if you have applied a color instead, you can skip directly 
to step 7):
 To view the texture file as a series of square or rectangular “tiles” 

that are repeated over the entire surface of the drapery element, 
click the Tile option button, and then type the size of the tiles in 
the boxes provided.

 To view the texture file stretched out as a single surface over the 
entire drapery element, click the Stretch option button.

 To preserve the aspect ratio of the texture so it is not distorted 
when stretched over the element, click Keep Aspect Ratio.
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 To choose a custom border color for the texture when it is 
stretched over the surface of the element, click the Border Color 
box, and then choose the custom color.

 To set the angle at which the texture appears on the drapery 
element, type or select the value in degrees from the Rotation 
(Deg.) drop-down list.

 To change the color of the texture, click the Color Tint color box 
and select a new color, then click the Scale drop-down list box to 
specify the intensity of the color.

7 To choose a custom material for the selected drapery elements (such 
as metal, paper, plastic, or fabric) click the ellipsis button (...) in the 
Material Properties section.

8 In the resulting dialog box, navigate to and highlight the desired 
material, and then click Select.

9 Click Apply.
10 You can apply a transparency level to the selected element. Based on 

the settings that you have chosen for color, texture, and material, 
the transparency options vary as follows:
 Transparency: This setting controls the proportion of light that 

passes through the material. All materials in WYSIWYG specify a 
level of transparency that varies from one material to the next. 
For example, glass is more transparent than brick. If you select 
Default, the transparency level is set to 0% (opaque). 

 Specular Level: This setting controls how prominent other specular 
effects appear on the material.

 Specular Gloss: This setting controls the level of gloss the material 
will project.

 Specular Color Source: This setting controls the amount of light that 
is projected on the material.

 Light Reflection: This setting controls the amount of light that is 
reflected off the material.

Notes: 
 Use the drop-down menus to change any of the material 

properties. Use the Reset button to revert back to defaults.

 The beam will pass through a surface with the Transparency value 
set to 80% or greater. The beam will not pass through the surface 
when the value is lower than 80%.

11 Display Reflection in Shaded Views: Select this checkbox to display the 
set reflective characteristics in Shaded Views.

12 Click Apply.
13 Click OK to save your changes and close the Properties dialog box.
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To customize pipe and drape structure for individual drape 
lines

This procedure shows how to the structural properties of individual drape 
lines that you have selected.

Note: While the tabs in the Properties window are best used to customize 
a single drape line, if you have selected multiple drape lines, the values 
that you type in these tabs apply to all selected drape lines; they 
overwrite any custom settings that you may have previously saved for 
individual crossbars, uprights, or drape panels.

1 In your drawing, select the pipe and drape section that you want to 
customize.

2 With the desired section selected, right-click and select Properties.
Result: The Properties window appears.

3 On the Properties window, click the Pipe and Drape tab.
 Pipe: This section displays the properties of the drape line crossbars 

and upright pipes.
 Crossbar section:

 Length: Type the length of all crossbar pipes in the selected 
drape line.

 Diameter: Type the diameter of all crossbar pipes in the 
selected drape line. Updating the crossbar diameter will 
update the loop diameter.

 Upright section:

 Height: Type the height of all upright pipes in the selected 
drape line. Changing the upright height will update the height 
of the drape line.

 Diameter: Type the diameter of all upright pipes in the selected 
drape line.

 Base Plate: Click the Base Plate drop-down list box to change the 
size of the base plate support for the upright pipes.

 Select the Add Base Plate Weight checkbox to add thickness to 
the base plate in Wireframe and Shaded views.

 Use Document Defaults (Segments): Click to clear this checkbox if 
you want to specify the number of segments that comprise the 
circumference of the crossbar pipes. You can choose between 
three and 40 segments. This value is largely for rendering 
purposes—the greater the number of segments, the greater the 
rendering time. Leave this checkbox checked to accept the 
default value of 8 segments.

 Drape: This section displays the properties of the drape line panels.
 Panel section:
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 Description: Type to add or replace the additional information 
for the drape line.

 Height: Type the height of all panels in the selected drape line.

 Width: Type the width of all panels in the selected drape line. 

 Loop Diameter: Type the diameter of the loops that wrap 
around the crossbar pipes at the top of all panels in the 
selected drape line. This value should be greater than the 
diameter of the crossbar pipes. 

 Use Document Defaults (Segments): Click to clear this checkbox if 
you want to specify the number of segments that comprise 
the drape panel loop that wraps around the crossbar pipe. You 
can choose between three and 40 segments. This value is 
largely for rendering purposes—the greater the number of 
segments, the greater the rendering time. Leave this 
checkbox checked to accept the default value of 8 segments.

 Notes: Type additional user information for the drape line.

 Curtain section:

 Enable: Select this checkbox to display the curtain as a wave in 
Plan View.

 Curtain Folds (2D Plan Only): 
 Style: Choose the style of how the wave is displayed.

 Depth: Type the depth of each wave period.

 Width: Type the width of each wave period.

 Number of Segments: Type the number of segments for the 2D 
wave object.

4 Click Apply.
5 Click OK.

Result: Your changes are applied to all selected drape lines.

BlackTrax zone

There are three types of Zones which can be defined: Rectangular Zones, 
Cylindrical Zones and Spherical Zones. These new CAD objects are used 
to define zones of interest for the BlackTrax system, which can be 
associated with a trigger relationship in the BlackTrax software. 

The BlackTrax Zone objects must be given a unique name when created 
so they can be referenced in the BlackTrax System. By default, BlackTrax 
Zones will appear as a red, semi-transparent volume in the Shaded 
views.
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Chapter  7

CAD mode - Editing Objects

CAD mode is where you edit your show drawings. This includes 
editing your venue, set pieces, lighting positions, focus positions, 
and lighting fixtures. Editing in CAD mode is similar to many other 
CAD programs, so many of the concepts will be familiar to those 
who have used a computer-aided drafting program before. 
WYSIWYG adds features that are specific to the entertainment 
industry, such as a comprehensive 3D library containing truss, 
lighting equipment, lighting accessories, props, musical 
instruments, and various human figures.

In this chapter
Editing objects 369

CAD tools 463
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Editing objects

Selecting

Before you can manipulate objects, you must select them. Selected 
objects are easily identifiable: a white box appears at the insertion point 
and the lines of the object become dotted. Fixtures that are selected are 
filled in green and their beams can be set to either on or off.

Use the following table to identify the selection method for objects.

Desired action Selection method

Select a single object.  Click on the object.

Select a single fixture.  In Wireframe view, click on or inside the 
fixture symbol’s outline.

 In Isometric view, click the symbol’s 
outline to select the fixture.

Select multiple objects.  Press and hold CTRL while clicking on the 
desired objects. 

 Draw a box from left to right to select all 
objects fully within the box. 

 Draw a box from right to left to select all 
objects fully within the box, as well as the 
objects partially contained in the box.

Select all the objects on 
the current layer.

 Press and hold CTRL+SHIFT and type A 
or use the Select Current Layer tool on the 
Selection toolbar.

Select all the objects on 
the screen.

 Press and hold CTRL and type A or use 
the Select All tool on the Selection toolbar. 

Select previous selected 
object

 From the Edit menu, choose Select 
Special, and then choose Restore Previous 
Selection or use the Restore Previous 
Selection tool on the Selection toolbar. 

Select last object created  From the Edit menu, choose Select 
Special, and then choose Select Last 
Object Created or use the Select Last Object 
Created tool on the Selection toolbar. 
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Select all the objects on 
one or more layers or in 
layer groups.

 From the Edit menu, choose Select 
Special, and then choose Specify layers to 
select. You can also use the Specify Layers 
tool on the Selection toolbar. 

 To select multiple layers, press and hold 
CTRL while selecting the layers. 

 To select multiple layer groups, press 
CTRL while selecting the layer group cell.

Invert Selection  From the Edit menu, choose Select 
Special, and then choose Invert Selection. 
You can also use the Select all editable 
objects that are not currently selected tool on 
the Selection toolbar. 

 Press CTRL+I to deselect all editable 
objects currently selected, and 
consequently select all the other editable 
objects that were previously not selected. 
See “Invert Selection”.

 Press CTRL+SHIFT+I to select and 
deselect only fixtures in CAD, Design and 
Live mode. See “Invert fixture selection” 

Select native objects.  In Wireframe view, right-click and choose 
Select Native Objects. 

 Choose the desired native object from 
the list of created native objects.

Selection sets  In CAD, DATA, DESIGN, and LIVE Modes, 
click on the Selection Sets shortcut on 
the Selection Sets shortcut bar to select 
objects by their selection sets.

Set beam display for 
selected fixtures.

 Set the Show beams for selected fixtures 
option. For more information on this 
option, refer to the “Wireframe Details 
tab”. 

Select all instances of a 
particular library item.

 In Wireframe view, right-click and choose 
Select Library Items, and then either 
select the library item from the menu 
that appears, or click Specify to select the 
item from a selection box.

Select all library items.  In Wireframe view, right-click and choose 
Select Library Items > Select All Library 
Items. 

Select all instances of a 
particular fixture.

 In Wireframe view, right-click and choose 
Select Fixtures, and then either select the 
fixture from the menu that appears, or 
click Specify to select the fixture from a 
selection box. To save time, you can also 
press SHIFT+S.

Select all fixtures.  In Wireframe view, right-click and choose 
Select Fixtures > Select All Fixtures.

Desired action Selection method
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To select various fixtures in your file, right-click in a wireframe, click 
Select All, and then choose which fixture type to select. This functionality 
is available in CAD, Design, and Live modes.

Cycle selection

This feature is helpful when you need to select an object that shares an 
edge with another object. For example, if you need to select the roof of a 
building that shares its edges with the building’s walls. Left-to-right drag-
selection in a side or elevation view works, of course, but there are many 
cases when this method cannot be used. 

To use cycle selection

1 To activate Cycle Selection, simply press SHIFT before clicking to 
select. When Cycle Selection is active, Cycle On appears in the 
WYSIWYG Status bar. 

2 To select the object, click in a spot where two or more lines overlap 
or intersect (“lines” do not necessarily mean Line objects, but rather 
lines that are part of anything drawn or inserted from the library). 

Select all fixtures on a 
particular type of pipe or 
truss.

 In Wireframe view, select the type of 
pipe/truss containing the fixture that you 
want to select. Right-click and choose 
Select Fixtures > Select on Selected Pipe/
Truss and then choose the type of fixture 
from the list, or click Select All to select 
all fixtures on this type of pipe or truss.

Select fixtures by their 
fixture group.

 In CAD Mode (Wireframe, Quad, Shaded 
view), DATA Mode (H Select and V 
Select), DESIGN Mode (Wireframe, Quad, 
and Shaded View), and LIVE Mode 
(Wireframe, Quad, and Shaded view), 
click on the fixture group shortcut on the 
Fixture Group shortcut bar to select 
fixtures by their fixture group.

Select fixtures by their 
lighting position.

 In CAD Mode (Wireframe, Quad, Shaded 
view), DATA Mode (H Select and V 
Select), DESIGN Mode (Wireframe, Quad, 
and Shaded view), and LIVE Mode 
(Wireframe, Quad, and Shaded view), 
you can right-click to select fixtures by 
their lighting position. Note, however, 
that you have to name all of your lighting 
positions before you can use this feature. 
If you do not have any lighting positions 
named, then you cannot use this tool 
because the position names will not 
populate in the list.

Desired action Selection method
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3 To continue selecting, keep pressing SHIFT to continue cycling 
through all the items that share the coordinate where you have 
clicked (in the order in which they were added to the drawing). 
Tips: 
 If you also press CTRL at the same time as SHIFT, you can add 

items to an existing selection set when those items can only be 
selected by Cycle Selection. 

 Hold down CTRL+SHIFT and click at a coordinate where 
something in the same “cycle set” was already selected to cycle 
through all items again, including the one already selected. 

 Ensure that when cycling through the cycle set, you do not make 
a mistake by canceling the selection of an item that you need to 
have selected (although in order to do so, you would have to 
release CTRL+SHIFT when you cycle to this item instead of 
holding CTRL+SHIFT down as you “pass over it”).

Invert Selection

This feature is helpful if you want to cancel the selection of all the 
currently selected editable objects (in CAD), and consequently select all 
objects that were previously not selected. 

 From the Edit menu, choose Select Special > Invert Selection to 
activate invert selection, or press the INV button on the Selection 
toolbar, or press CTRL+I, which applies to all objects displayed in 
CAD Wireframe and Shaded views.

 Pressing CTRL+SHIFT+I activates invert selection of fixtures and 
applies only to all the fixtures displayed in CAD Wireframe and 
Shaded views.

Note: Invert selection is also available in Design and Live mode. See 
“Using the design tools”.

To use invert selection

For example, if your drawing has a total of 10 objects, and 4 objects out 
of the 10 are currently selected. Press CTRL+I to activate invert 
selection. 

Result: The 4 selected objects will be deselected and the other 6 objects 
that were previously not selected, will be selected automatically.

Note: Press CTRL+SHIFT+I to select and deselect only fixtures in CAD.
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Shaded view selection

You can select fixtures in Shaded view in CAD, Design and Live modes. 
This allows you to click on a fixture in the Shaded view, which will then 
activate the fixture for editing with the Designer tools. You can select 
multiple fixtures at one time by either drag-selecting or holding down 
CTRL while selecting fixtures.

Using Shaded View Selection
You can activate Shaded View Selection by pressing TAB while in CAD, 
Design or Live mode > Shaded View. Once you press TAB, you will notice 
a message in magenta on the top right-hand corner of the Shaded view 
window: “Shaded View Select ON”.
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To Activate Shaded View Selection

1 In a Shaded view in CAD, Live or Design mode (meaning the amber 
outline appears around the Shaded view), press TAB once. You are 
now in Shaded View Selection mode.

2 To select a fixture in Shaded View Selection mode, click directly on a 
fixture’s image in the Shaded view:

3 To select multiple fixtures in Shaded View Selection, press CTRL and 
click each fixture that you want to select. You can also select multiple 
fixtures at once by drag-selecting with the mouse as you would in 
wireframe modes; Shaded View Selection disables the camera 
movement controls so you can drag a marquee box around fixtures 
to select them.

4 Once you are finished selecting fixtures, press TAB again to exit from 
Shaded View Selection mode. You will then regain control of the 
Shaded View camera.
Tips: 
 It is helpful to keep your hand near the TAB key while selecting 

fixtures and maneuvering around with the camera; once you 
need to move around your view, press TAB to exit Shaded View 
Selection. Your fixture selection is maintained as you move in and 
out of the Shaded View Selection mode.

 Make sure while you navigate around in the Shaded View that you 
give yourself a good angle on the view in which you want to 
select fixtures. It may be difficult to select a fixture in the middle 
of a lighting position or truss while you’re looking at a side view of 
it.
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To focus a fixture using Shaded View Selection

Shaded View Selection enables you to focus your fixture by clicking on 
the target in Shaded views. 

1 Activate Shaded View Selection by pressing TAB while in Design or 
Live mode > Shaded View. 

Result: A message in magenta appears on the top right-hand corner 
of the Shaded view window: “Shaded View Select ON”.

2 Click to select the fixture that you want to focus. To select multiple 
fixtures, press CTRL and click to select them. Alternately, fixtures can 
be selected using the Fixture Selection toolbar.

3 Activate the focus feature by pressing F on your keyboard (or right-
clicking and selecting Focus from the menu). Alternately, you can 
press L to activate the “Full and Focus” feature (or right-click and 
select Full and Focus from the menu). The Status bar will indicate 
when a focus operation is active.

4 Click in the Shaded view to select the focus target.
5 Press TAB to exit Shaded View Selection.

Using the fixture selection toolbar

The Fixture Selection toolbar offers three convenient methods to select 
fixtures in your file and a method to traverse your selection.

Fixture Selection by Spot number
The toolbar has a combo box in which you can type in Fixture spot 
numbers that you would like to select (as you would on most lighting 
consoles). For a consecutive range of fixtures, use a dash ( - ), or to 
enter a list use commas (,)

Note: This method will only work if fixtures have already been assigned 
Spot numbers.

Example: “1-10, 15, 20” will select 12 fixtures, with Spot 
numbers: 1,2,3,4,5,6,7,8,9,10,15,20.

The combo box will remember previous selection strings and display 
them when you click on the down arrow. 

Fixture Selection by Channel value
In the combo box, you can type the channel value, using “ch” to identify 
the channel. Use a dash for a consecutive range. 
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Note: This method will only work if fixtures have already been patched 
with Channel numbers.

Example: “ch1-10” will select all the fixture patched to channel 
numbers 1 to 10.

Select Fixtures By
The Fixture Selection toolbar offers a drop-down menu of all the “Select 
Fixture By” methods listed in the menus. 

Use the Next button to traverse the fixtures selected one by one from first 
to last, or use the Previous button to traverse the fixtures selected one by 
one in the reverse order. Select the All button to select all fixtures in your 
current selection.

Highlight fixtures
The Highlight feature is available on the Fixture Selection toolbar in Design 
mode only. In Shaded view, Highlight sets the currently selected 
fixture(s) to an open beam at 100% full intensity temporarily, without 
changes to the fixture’s saved settings. See “Highlight fixtures”in Design 
tools.

Undo/redo

If you discover that you have made an error while editing an object, you 
can easily reverse the error by using the Undo tool available in 
WYSIWYG. The name of the Undo tool changes based on what the last 
action was (for example, if the last action was a Paste operation, the 
Undo tool will be Undo Paste). You can use Undo to reverse the last 
series of actions until the tool is greyed out. 

If you decide that you did not want to undo an action, use the Redo tool. 
Similar to the Undo tool, the name of the Redo tool changes based on 
what the last undo action was.

To use the Undo tool

From the Edit menu, choose Undo.

Tip: You may also use the Undo tool on the Edit toolbar. 

Result: The last action you performed is reversed.

 The Undo button.



Reference Guide 377

January 2019 CAD mode - Editing Objects 

To use the Redo tool

From the Edit menu, choose Redo.

Tip: You may also use the Redo tool on the Edit toolbar. 

Result: The last undo action you performed is reversed.

Grouping/ungrouping

Grouping objects together ensures that they will always be selected as 
one. For example, you may want to group an object and its 
corresponding focus position. If you relocate the object in the drawing, 
the focus position will automatically follow, as will all the light beams 
pointing at it, saving you time and work.

To group objects

1 Select the objects to be grouped.

2 From the Edit menu, choose Group. 
Tip: You may also use the Group tool on the Tools toolbar.

To ungroup objects

1 Select the grouped objects.

2 From the Edit menu, choose Ungroup. 
Tip: You may also use the Ungroup tool on the Tools toolbar.

Note: You can group together objects located on different layers, but the 
resulting group can only exist on one layer.

To change or view the layer of a group

1 Select the object(s) for which you want to view the grouping.

2 Right-click and select Properties.
Tip: At any time, to access an object’s properties, you can click the 
Properties tool on the Edit toolbar. 

 The Redo button.

 The Group button.

 The Ungroup button.

 The Properties button.
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3 Click the Group tab.
Result: The layers for the objects in the group are listed with the 
layer for the group highlighted.

Note: By default, the group assumes the current layer when initially 
created.

4 To group the objects on a different layer, select the layer from the 
list.

5 Click OK.

Selection Sets

You can group non-fixture objects and create Selection Sets shortcuts in 
the Selection Sets shortcut bar in CAD, Data, Design, and Live modes. 
Selection Sets apply to any and all drawn objects and objects inserted 
from the Library Browser, which include Groups, Truss and Assembled 
truss. Multiple Selection Sets can be created on an object.

Selection Sets are NOT the same as Groups because they only save 
which particular objects are selected, and the order in which they are 
selected.

To create a Selection Set

1 Select the objects you want to group and select with a shortcut.

2 On the shortcut bar, click Selection Sets.
3 Right-click on the open space on the Selection Sets shortcut bar, and 

choose New Selection Set from the pop-up menu.
Result: The Enter new selection set name dialog box appears.

4 Type a name for the new selection set.
5 Click OK.

Result: The new Selection Set shortcut appears on the Selection Sets 
shortcut bar.

Moving

WYSIWYG supports two types of move commands: relative and absolute. 

 Absolute coordinates are relative to the origin of the drawing. An 
absolute move is defined as moving an object from one specific point 
to another. 

 A relative move is defined as moving an object to a destination 
relative to its original position.
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To move an object using the mouse

1 Select the objects to be moved.

2 Hover the cursor over the object until a grey box appears, and then 
click and hold.

3 Drag the object to the new position, and then release the mouse 
button to finish the move.

To move an object using absolute values

1 Select the objects to be moved.

2 From the Edit menu, choose Move. 
Tip: You may also use the Move tool on the Tools toolbar.

3 Press ENTER on your keyboard to move the object from its insertion 
point, OR click to set the base point for the move, OR type the 
coordinates of the base point, and then press ENTER.
Note: When you start typing, a box appears at the bottom left-hand 
corner of the window, showing the value that you enter.

4 Type the new coordinate location for the base point, and then press 
ENTER.
Tip: You can change only one or two coordinates to an absolute 
location while keeping the other coordinates as they are. 

Example: If you wish for an object to move to a height of Z=10, 
but you don’t know the X and Y coordinates. Start the Move 
command and type “x, y, 10” in the Command Line after picking the 
base point.

To move an object using relative values

1 Select the objects to be moved.

2 From the Edit menu, choose Move. 
Tip: You may also use the Move tool on the Tools toolbar.

3 Type @, followed by the distances to move the object, and then 
press ENTER. For example, to move an object 2’-0” stage right (X 
axis) and 3’-0” off the floor (Z axis), type the following, and then 
press ENTER:

@2’,0,3’ 

 The Move button.

 The Move button.
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To move an object using distance and direction

1 Select the objects to be moved.

2 From the Edit menu, choose Move. 
Tip: You may also use the Move tool on the Tools toolbar.

3 Type @, the distance that you want to move the object, the < sign, 
and the direction (as an angle, positive or negative) to move the 
object, and then press ENTER. For example, to move an object 3’-6” 
to the left, type the following, and then press ENTER:

@3’6”<-180

Nudging

To save time and for added precision when working in your model, you 
can use the Nudge feature to nudge any object except fixtures. The 
amount of the nudge is equal to the size of the Grid. For information on 
changing the grid size, refer to “Draw Defaults tab”.

To nudge an object

1 In your model, click to select the object that you want to move.

2 Press and hold the SHIFT and ALT keys on your keyboard 
simultaneously, and then press the ARROW keys on your keyboard to 
nudge the object in the desired direction.    
Tip: To nudge objects in increments ten times larger than the size of 
the grid, do not hold down SHIFT.

Sending to back/bringing to front

The feature is very useful for correcting draw order issues (among other 
things). WYSIWYG displays objects “on top of each other” in the order in 
which they were added to the drawing. For example, if you draw/insert a 
table after you draw/insert a piece of truss above it (i.e., at a different 
missing coordinate), the table will appear “above” the truss (in Plan 
View), even though the table is on the floor and the truss is up in the air. 

You can use the Send to Back or Bring to Front commands to arrange the 
way the objects appear in your drawing. Note, however, that when you 
do so the physical location of the objects is unchanged; you are only 
changing the way in which they are displayed.

 The Move button.
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To send an object to the back / bring an object to the front

Notes: 

 The Send to Back option will “place” the selected object “below” 
everything else in the drawing.

 The Bring to Front option will “place” the selected object “above” 
everything else in the drawing.

 You may note that sometimes the object will not move from its 
current position. This may be due to the Draw Order settings on the 
Draw Defaults tab of Document Options and View Options. These settings 
supersede any Send/Bring commands by essentially telling 
WYSIWYG to always draw fixtures, objects, and hang structures in 
the order shown. 

1 In CAD mode, select the object that you want to send to back or 
bring to front.

2 Right-click and select Bring to Front or Send to Back.
Tip: Alternately, you can use hotkeys to send items to the back/bring 
them to the front:
 open curly bracket for Bring to Front (i.e., { or SHIFT+[ )

 closed curly bracket for Send to Back (i.e., } or SHIFT+] ) 

Rotating objects

You can rotate objects around a base point to place them on angles in 
your drawing.

To rotate an object

1 Select the object(s) to be rotated.

2 From the Edit menu, choose Rotate.
Note: You may also use the Rotate tool on the Tools toolbar.
 Press ENTER on your keyboard to rotate the object from its 

insertion point.

OR

 Click to set the center point for the rotation.

OR 

 Type in the coordinates of the center point for the rotation, and 
then press ENTER.

3 Type the rotation angle, and then press ENTER, or drag the mouse 
and click to type the rotation angle. For example, to rotate an object 
45 degrees, type 45, and then press ENTER.
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Rotating objects in place

You can rotate multiple objects around their respective insertion points 
to place them all at the same angle in your drawing.

To rotate multiple objects in place

1 Select the objects to be rotated.

2 From the Edit menu, choose Rotate in Place.
 Click to set the base point used for the rotation angle.

OR 

 Type in the coordinates of the base point, and then press ENTER.

Note: The base point is only used to help determine the angle, as 
each object is rotated around its own insertion point.

3 Type the rotation angle, and then press ENTER, or move the mouse 
and click to set the rotation angle. For example, to rotate objects 45 
degrees, type 45, and then press ENTER.

Resetting object orientation

Resetting the orientation of an object keeps the object at its insertion 
point. The object rotates around the insertion point to its original 
orientation.

To reset the rotation of objects

1 Select the objects whose rotation needs to be reset.

2 From the Edit menu, choose Reset Orientation.
Result: The object’s orientation will be reset to its default 
orientation. 

Mirroring

The Mirror command duplicates and reverses an object, inserting it the 
same distance from an axis line as the original object.

Notes: 

 After mirroring an object that was originally created through a merge 
operation, you cannot reliably perform another merge procedure on 
this object; therefore, it is recommended that you perform all merge 
operations on these objects before you mirror them.

 Pipes and Truss (including fixtures hanging on them) and fixtures 
inserted on the floor can be mirrored. See “Mirroring pipes” and 
“Mirroring truss”.
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 When mirroring Text Label objects, the Text Label’s position/rotation, 
anchor position, callouts and arrows will be mirrored across the 
mirror plane, but the text will always face the screen and will not be 
reversed.

To insert a mirrored object

1 Select the object(s) to be mirrored.

2 From the Edit menu, choose Mirror. 
Tip: You may also use the Mirror tool on the Tools toolbar.

3 Click on the drawing to enter the first axis point.
4 Click on the drawing to set the second axis point. 

Result: The mirrored object is copied, reversed from the origin, 
based on the axis drawn.

Scaling

The Scale command changes the size of the object(s). The Scale 
command applies to a library object, an imported object, and some 
primitive objects.

When you use the Scale command menu on a selected 2D or 3D Primitive 
Object, it multiplies the scale factor specified, calculates a new dimension 
for the Primitive Object and updates the value in its properties. 
Whenever an object is scaled, the scale factor of the resulting scaled 
object in its new size will always be equal to 1 again.

When you use the Scale command menu and specify a scale factor equal 
to 1, the size of the selected object will not change.

If you want to reset the scaled object back to its original or normal size, 
select the object, and then choose Reset Scale from the Edit menu.

To use the Scale command on imported objects which did not import as 
single entities, we recommend for you to consolidate the selected objects 
first, using WYSIWYG’s Consolidate Mesh feature. If not consolidated, the 
relative position and size of such objects will not be preserved after the 
Scale operation is completed.

Notes: 

 Fixtures, Truss and Groups cannot be scaled.
 You can enable the Show Bounding Box for CAD operation option in the 

Object Settings tab in the Document Options window to improve the 
operation performance when you scale complex objects. A bounding 
box appears as a placeholder to complex objects when scaling or 
rotating in CAD. 

 The Mirror button.
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To scale one or more objects uniformly

1 Select the object(s) to scale.

2 From the Edit menu, choose Scale.
Tip: You may also click the Scale icon on the Tools toolbar.

3 In the Command Line toolbar, type the scale factor value (for example, 
“2” or “0.5” or “4”, etc) for a uniform and precise resize.
OR

Use the mouse wheel to increase or decrease the size of the objects 
for a uniform and experimental resize method; each notch of the 
mouse wheel will increase or decrease the object’s scale uniformly 
(i.e. on all three axes) by a factor of 0.5.

4 On your keyboard, press Enter.
Result: The size of the selected object changes according to the 
scale factor.

To scale one or more objects with different scale values in X, 
Y, Z

1 Select the object(s) to scale.

2 From the Edit menu, choose Scale.
Tip: You may also click the Scale icon on the Tools toolbar.

3 In the Command Line toolbar, type the three (3) values for X, Y, Z 
directions. 

Example: Type “2,3,1” in the Command Line to make the selected 
object 2x wider in the X direction, 3x longer in the Y direction, and 
the height remains the same as 1x in the Z direction.

4 On your keyboard, press Enter.
Result: The size of the selected object changes according to the 
scale factor for X, Y and Z.

To scale an object by stretching it with click and drag

Note: To scale Library objects (e.g. Trees, Plants, Festive objects, etc.) 
by stretching, Library Snap must be enabled.

1 Select the object(s) to stretch.

2 Click and hold on one of its grips, then drag inwards or outwards.
Result: The mouse pointer becomes an arrow at the corner, and the 
selected object changes its size according to the movement of the 
mouse.

3 Release the mouse when you reach the desired size.
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To reset the scaled object back to its original size

1 Select the scaled object(s).

2 From the Edit menu, choose Reset Scale.
Result: The size of the selected scaled object changes back to its 
original size.

Modifying object shapes

You can change the shape of certain objects after they are drawn. The 
objects that you can change include lines, risers, cameras, surfaces, 
spheres, and arcs. Modifying the shape changes one or more of the 
parameters of the object, such as its width, height, or radius.

Note: If you are changing the shape of a sphere, when you click and 
drag one of its vertices, it will be resized proportionately if the Lock Ratio 
checkbox is checked for the sphere’s properties. (Click Properties > Sphere 
tab, and then ensure the Lock Ratio checkbox is checked.) To resize the 
sphere in a disproportionate manner, clear this checkbox, and then click 
and drag one of its vertices.

To modify the shape of an object

1 Select the object whose shape you want to modify.

Result: You will notice that several white boxes will appear at the 
vertices of the object. These boxes are referred to as “markers.”

2 Move your cursor to a vertex. 
Result: The cursor changes to an arrow. 

Note: If you see a grey dotted box beside your mouse cursor, the 
object will be moved instead of reshaped. Move your cursor so that 
only the arrow appears.

3 Left-click to “grip” one of the markers. 
4 While holding down the left mouse button, click and drag the object 

until it reaches the desired shape. 
5 Release the mouse button to set the shape. 

Tip: As you move the mouse, the current coordinates appear at the 
bottom of the screen. 

Object properties

All objects in WYSIWYG have properties. Properties are the 
characteristics or attributes that shape and define an object. Modifying 
object properties is a form of editing and is the only way to make 
changes to objects once they have been drawn (some exceptions exist). 
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To edit object properties

1 Select the objects that you want to edit.

2 Right-click on the object, and then select Properties.
Tip: At any time, to access an object’s properties, you can click the 
Properties tool on the Edit toolbar, or you can double-click on an object 
(or fixture in DESIGN mode and LIVE mode). 

Result: The Properties window appears.

Note: All objects have general properties that affect the color and layer 
on which they are drawn. Objects also have properties that are particular 
to that type of object. For example, fixtures have unit numbers but do 
not have a radius. When an object is selected and its properties are 
displayed, a tab appears in the properties dialog box for that type of 
object. When you select multiple objects of different types, tabs appear 
for each type of object selected.

General object properties
In WYSIWYG, there are four tabs that appear in the properties window 
for every object. These four tabs are the General, Appearance, Light 
Emission, and Sidedness tabs. 

For 3D solids and surfaces, the Set Piece tab also appears in the Properties 
window. 

All tabs are explained here. 

General tab
Options on the General tab affect the layer’s color and line weight.

 The Properties button.
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 Layer: A list of the layers in your document is displayed. Click on a list 
item to change the layer on which the objects will be drawn.
 The layers are listed below the Layer Groups if the Display with Layer 

Groups checkbox is selected.
 Only the layers are listed if the Display with Layer Groups checkbox is 

clear.
 Display with Layer Groups: Select this checkbox to display the layers as 

items organized in Layer Groups. Clear this checkbox to display only 
the list of layers.
 On the list of Layer Groups, click the arrow at the far left to expand 

or collapse a single Layer Group.
 Collapse All: Click the Collapse All button to display only the Layer 

Groups.
 Expand All: Click the Expand All button to display the Layer Groups and 

all the Layers.
 Use Layer Color: Select this checkbox to set the object’s color for 

Wireframe views to be the same as the properties of the layer on 
which the object resides. For more information, refer to “Layer 
properties”. 
 Clear this checkbox, and then use the color button to set a specific 

color for the object.
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 Line Weight: From the drop-down list, choose the specific line weight 
for the selected object. The applied line weight is visible in all 
Wireframe views in all modes. For objects only, you can also choose 
the default setting, ByLayer, which sets the object’s line weight to be 
the same as the properties of the layer on which the object resides. 
The value Default means that the document's line weight setting from 
the Document Options > Object Settings window is applied to the object 
or layer. For more information, refer to “Layer properties”.

 Attach to Axis: From the drop-down list, select the motion axis to 
which you want to attach the selected object or objects. For details 
on attaching objects to motion axes, see “To attach an object to a 
motion axis”. 
Note:  You cannot attach Camera paths nor Cameras to axes. To 
create a moving Camera, you can either draw a Camera Path or use 
the DMX Camera.

 Hatching: Section for managing hatching effects of closed objects.
Note: Hatching is only available for closed objects, e.g. surfaces, 
closed lines, 3D primitives, walls.
 Show Hatch Lines: Will enable hatching for the object.
 Available hatching styles: A drop-down list of previously created 

hatching styles that can be applied to the object.
 New/Edit...: Create a new hatching style or edit and existing style.

To add hatching to an object

Note: Not all objects support hatching. If hatching is not supported, the 
checkbox to enable hatching is disabled.
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1 Right-click the object, and select Properties.

Result: The Properties window appears.

2 In the Properties window, click the General tab.
3 To enable hatching for the object, select the Show Hatch Lines 

checkbox.
4 Select the desired hatching style for the object from the Available 

hatching styles drop-down list.
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5 Click Apply to enable the hatching style for the object.

To edit or create a hatching style

1 Right-click an object that supports hatching, and select Properties.

Result: The Properties window appears.
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2 In the Properties window, click the General tab.
3 To enable hatching for the object, select the Show Hatch Lines 

checkbox.
4 To make a new hatch style or edit an existing style, click New/Edit....

Result: The Hatch Style Manager window appears. All existing hatch 
styles are displayed and can be edited here.

5 To create a new hatch style, click the New Hatch Style button.

Result: The New Hatch Style window appears.

6 In the New Hatch Style window, enter the details of the new hatch 
style.

7 Click OK.

 The New Hatch Style button.
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8 Click Apply to enable the new styles.
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To clone a hatching style

1 Right-click an object that supports hatching, and select Properties.

Result: The Properties window appears.

2 In the Properties window, click the General tab.
3 Select the Show Hatch Lines checkbox.
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4 Click New/Edit....
Result: The Hatch Style Manager window appears. All existing hatch 
styles are displayed and can be edited here.

5 To clone an existing hatching style, select the style you want to copy 
and click the Clone Hatch Style button.

Result: The Clone Hatch Style window appears. All the settings of the 
selected hatch style will be copied into the window.

6 In the Clone Hatch Style window, edit any hatching setting that you 
want to be different from the original hatching style.

 The Clone Hatch Style button.
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7 Click OK.
Result: The cloned hatching style will appear in the Hatching Style 
Manager window and be available for use.

To delete a hatching style

1 Right-click an object that supports hatching, and select Properties.

Result: The Properties window appears.

2 In the Properties window, click the General tab.
3 Select the Show Hatch Lines checkbox.
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4 Click New/Edit....
Result: The Hatch Style Manager window appears. All existing hatch 
styles are displayed.

5 To delete an existing hatching style, select the style you want to 
remove and click the Delete Hatch Style button.

Result: The Delete Hatch Style window appears.

6 In the Delete Hatch Style window, to delete the hatch style click Yes.
Result: The selected hatching style be removed from WYSIWYG.

To change the print scale of hatching styles

Spacing for built-in line patterns found in hatching use a default scale of 
1.0 equal to 0’6” (2.54 cm). Print Scale Options can be used to create a 
different scale when printing in Presentation mode.

 The Delete Hatch Style button.
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1 Right-click an object that supports hatching, and select Properties.

Result: The Properties window appears.

2 In the Properties window, click the General tab.
3 Select the Show Hatch Lines checkbox.
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4 Click New/Edit....
Result: The Hatch Style Manager window appears. All existing hatch 
styles are displayed.

5 Click Print Scale Options.
6 The Print Scale Options dialog box appears.

7 In the Print Scale Options window, to create a custom print scale, select 
the radio next to Custom scale. 
Note: To revert the print scale to its default settings, select the radio 
next to Print scale. 

8 Edit the print scale settings as desired.
9 Click OK.
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10 Click Apply.
Result: The print scale options will be changed.

To import hatching patterns

To import Hatch Pattern files (.pat files), save these files in the folder 
location that was entered as the Hatch Pattern Files location in the File 
Locations tab in Application Options window. When you restart WYSIWYG, 
these patterns will be listed in the Hatch Style Manager.
1 Right-click an object that supports hatching, and select Properties.

Result: The Properties window appears.

2 In the Properties window, click the General tab.
3 Select the Show Hatch Lines checkbox.
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4 Click New/Edit....
Result: The Hatch Style Manager window appears. All existing hatch 
styles are displayed.

5 Click Import Patterns.
Result: The Application Options window appears.
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6 In the Application Options window, enter the location/folder which 
contains the hatch pattern files (.pat files) in the Hatch Pattern Files 
field. 

7 Click OK.
Result: A dialog box appears warning that WYSIWYG needs to 
restart to display the imported hatching patterns in the Hatch Style 
Manager.

Appearance tab
Use this tab to specify the appearance of the different components that 
make up the currently selected items. Based on the items that you have 
selected, the options in this tab differ. 

You can use this tab to customize objects by adding different materials, 
colors, or textures to each element of the item. For example, if you have 
selected a library object, such as a podium, you can apply different 
materials, colors, and textures to each part of it (the body and the top 
portion). 

You can also use this tab to rename the individual elements of the 
currently selected object. This is useful for objects that contain many 
elements with similar names, like risers. 
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Note: You can apply textures to venues, surfaces, risers, walls, library 
items, spheres, cylinders, and cones. You can apply transparency to 
everything. When customizing the selected element, you can choose 
between applying a custom color or a custom texture—you cannot 
choose both. In addition to either color or texture, you can also apply 
material.

Highlight the element that you want to customize, and then choose one 
of the following options:

 Color/Texture
 Ignore Ambient Light: If checked, the selected element(s) will always 

appear in Shaded Views using the color values derived from the 
Appearance options specified (e.g., texture). While light emission 
and light from fixtures will further saturate the colors displayed for 
the selected object, ambient light will never affect this object if 
this option is enabled. This option is useful when objects (except 
Screens) are textured with images or video, and these need to 
appear in their original colors at all times. In renderings, this 
setting is ignored if light emission is enabled.

 Layer Rendering Color: Check this option to set the object(s) color for 
shaded views and renderings to the same as the properties of the 
layer on which the object resides. For more information on layer 
properties, refer to “Layer properties”.

 Custom Color: Click this option and then use the color button to set 
a specific color for the object(s). 

 Texture from Library: Click this option to apply a texture from the 
library to the selected object(s). In the resulting window, navigate 
to and select the desired texture. You can apply textures to 
venues, surfaces, risers, walls, library items, spheres, cylinders, 
and cones. Click the ellipsis button (...) to change the selected 
texture file.

 Image Source: Click this option to apply to the selected object(s) a 
texture that you have created and saved in either .bmp, .jpg, .png, 
or .gif format. To apply the image, you must create a new image 
source. To do so, click New, and then use the Image Manager to 
create a new image source with the image you created. See “To 
create a new image source in the image manager”for details

 Video Source: You can apply a video source or a subsource as a 
"dynamic texture” to 3D primitives--surfaces, risers, spheres, 
cylinders, or cones--or to individual elements of 3D primitives. 
Select this option to apply a previously created video source or 
subsource, or click New to create a new video source or subsource 
directly from this window. See “Video Manager”for details.

If you have chosen a texture option, then you can also set the properties 
of the texture as follows:
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 Tile: Click this option button if you want to have the texture 
repeated over the selected element in a continuous series of 
squares or rectangles, and then type the size of the frame in which 
you want the texture to appear in the Width and Height boxes. 
Based on the size that you enter, WYSIWYG calculates how many 
times the texture is repeated (or tiled) to completely cover the 
selected element. 

 When tiling a texture on a sphere, cylinder, or cone, by default it 
will completely wrap around the object. If you change the tile size, 
you will scale the texture up or down accordingly. If you revert 
back to the original tile values, you   return to the default view.

 Stretch: To have the texture stretch over the entire element 
surface, click this option button. Based on the aspect ratio and the 
rotation angle, WYSIWYG evaluates the surface with all of its 
edges and stretches the texture so the best fit is used. Note that 
this option is not applicable when you apply textures to spheres, 
cylinders, or cones. For these objects, Tile is the only option. 

 Keep Aspect Ratio: Click this option to keep the aspect ratio of the 
original image when it is stretched over the surface of the object 
you have selected. This option helps avoid distortion of complex 
textures. If the texture image cannot wrap completely over the 
entire surface of the object while maintaining its original aspect 
ratio, then the color that you choose in the Border Color box will be 
applied evenly around any excess surface area not covered by the 
texture (much like a picture frame around a picture). 

 Border Color: If you have chosen to preserve the texture’s aspect 
ratio, click this box to choose the color that will be applied evenly 
around any excess surface area not covered by the texture (much 
like a picture frame around a picture).

 Texture / Source Tint: This option will allow the color of an object’s 
texture to be altered from the source color.

 Texture Rotation: If the texture has text or another recognizable 
image in it, you might need to rotate the image to get it right-side 
up. Select the rotation angle from this box.

 Material Properties: Proceed with the following properties settings:
 Material: Click the ellipsis button (...) to choose a material for the 

selected elements. Click Default to remove the selected material 
from the element and return to the default material. For more 
information on materials, refer to “Materials”.

 Material Properties: When a material is selected, the properties of the 
material will vary from one material to the next. The Material 
Properties section enables these default material settings to be 
changed. Each property value can be changed on a scale from 0%-
100%. An explanation of the value is found on the right side of the 
property.
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 Transparency: This setting controls the proportion of light that 
passes though the material. 0% being completely opaque, 100% 
being completely clear. 

Note: The beam will pass through a surface with the Transparency 
value set to 80% or greater. The beam will not pass through the 
surface when the value is lower than 80%.
 Specular Level: This setting controls how prominent other specular 

effects appear on the material. 0% being no visibility of specular 
effects, 100% being a maximum visibility of specular effects.

 Specular Gloss: This settings controls the level of gloss a material 
will project. 0% will project the gloss over a wide area, 100% will 
concentrate the gloss in a small area. 

 Specular Color Source: This setting controls the color of light 
projected on a material. 0% will show only the color of the light, 
100% will show only the color of the material.

 Light Reflection: This setting controls the amount of light that is 
reflected off the material. 0% having no reflection, 100% being 
specular.

 Display Reflection in Shaded Views: Will display reflections in Shaded 
Views when enabled. For more information see “Material 
reflections”.

To rename object elements

You can use this procedure to rename object elements that have similar 
names, giving them a more descriptive name. For example, if you have 
customized a riser, you could give each side of the riser a distinct name 
according to its custom properties. This is especially useful for custom 
objects that you have drawn and are going to save as custom library 
items. Since you cannot rename individual elements of custom library 
items, it is best to do so before you save the item. 

1 Under Elements, highlight the element that you want to rename. For 
example, highlight Riser - Back.

2 Click Rename.
3 Type the new, descriptive name for the element.
4 Click OK. 
5 Click OK in the Appearance tab to save your changes.

Cast Shadow
The Cast Shadow feature gives you the option to cast shadows and display 
footprints of objects in the Shaded view.

 Cast Shadow: Select this checkbox to display in Shaded view the 
shadow/footprint of the selected object. Clear this checkbox if you do 
not want to display in Shaded view the shadow/footprint of the 
selected object. 
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By default, the Cast Shadow option is enabled on all objects, and 
disabled on all fixtures and hang structures.

Light emission tab
Options on the Light Emission tab affect the light emission properties for 
the selected object(s) or the elements that make up an object. Light 
emission is defined as the ability for objects to glow or emit light and can 
be used to simulate LEDs, lasers, neon, light boxes, projection screens, 
and so on. Light emissions can be either Static or Dynamic.

Static light emissions can be seen in CAD, DESIGN and unpatched LIVE 
mode. With Static light emissions you can choose different light 
emissions for each element in an object.

Dynamic light emission can be seen in DESIGN mode and patched LIVE 
mode where each element of the object inherits the same light emission 
properties.

In DESIGN mode, the light emitting properties of the entire object are 
controlled using the Color Tool and the Intensity Tool. In patched LIVE 
mode, the dynamic color and intensity are controlled through DMX.

Note: Instead of using the Properties > Light Emission tab to change the 
light emission for the selected object, you can use the Quick Light Emission 
Tool. For details, see “Quick light emission tool”.
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Highlight the element that you want to customize, and then choose one 
of the following options:

 Static Light Emission
 Enable: Select this checkbox to enable Static light emission for the 

object, and then choose the light emitting properties.
 Color: Click the color box to choose the static light-emitting color 

for the object. If you set only this value, and not the Dynamic 
Color Control, then this is the light-emitting color that the object 
will have in all shaded views and renderings in all modes (CAD, 
Design, Live). However, if you set the dynamic color value as well, 
then you can control the light-emitting color of the object in Live 
mode when connected to a console. (The static value still applies 
in Design mode.) 

 Intensity: Choose the static intensity of the light emission for the 
selected object. If you set only this value, and not the Dynamic 
Intensity Control, then this is the maximum light-emitting 
intensity that the object will have in all shaded views and 
renderings in all modes (CAD, Design, Live). However, if you set 
the dynamic intensity value as well, then you can control the light-
emitting intensity of the object in Live mode when connected to a 
console. (The static value still applies in Design mode.) 

 Dynamic Light Emission - Design Mode:
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 Enable Light Emission in Design Mode: Select this checkbox to enable 
the dynamic control of the light emitting properties of the selected 
object with the use of the Color Tool and the Intensity Tool. This can 
be defined for each Look, and you can cross-fade with Light 
Emission as you can with lighting.

 Dynamic Light Emission - Live mode: Dynamic light emission will 
apply to all elements of an object.
 Dynamic Color Control - Universe: When you select a value from this 

drop-down list, the selected object will have light-emitting 
properties controllable by three DMX channels (red, blue, green). 
The object must be patched according to the WYSIWYG patch 
notation: universe.DMX address. From the drop-down list, select 
the patch universe of the selected object, and then type the 
starting DMX address in the Address box below it. If you set this 
value, it overrides the static color control that you chose above (if 
any) in Live mode when you are connected to a console.

 Dynamic Color Control - Address: After selecting the patch universe of 
the selected object, type the starting DMX address for the patch in 
this box.

 Color: Component color settings are designed to be used in groups 
of three, meaning that you choose the color mode for one of the 
surfaces and then continue choosing color modes for the other two 
surfaces in the triplet, assigning one color to each surface (either 
red, green or blue). If you are not selecting colors in a group of 
three, choose Full Color Mode in this drop-down list. 
This feature is particularly useful to emulate a color-mixing source 
with discrete red/green/blue elements, such as fluorescent tubes 
or LEDs. The color mode affects how the surface responds to the 
colors that you assign to it, both static and dynamic. In Full Color 
mode, the surface will show the resultant color mix of the RGB 
channels controlling it. For example, if you choose white in the 
color picker (RGB 255, 255, 255), the surface will be white. How-
ever, when you create a triplet surface using each component 
color, one for each surface, and then you choose one of the com-
ponent colors, such as Component Color - Red, then this surface will 
only show the red component of the color. 

 Dynamic Intensity Control - Maximum Intensity: Enables you to set the 
maximum intensity of patched objects. Select the intensity from 
the drop-down list. 

 The DMX intensity value is treated as a percentage of the dynamic 
intensity value. For example, a DMX value of 127 results in 50% of 
the maximum intensity value that you set.

 Dynamic Intensity Control - Universe: When you select a value from 
this drop-down list, the selected object will have light emitting 
properties to a maximum of the intensity that you specify. The 
object must be patched according to the WYSIWYG patch notation: 
universe.DMX address. From the drop-down list, select the patch 
universe of the selected object, and then type the starting DMX 
address in the Address box below it.
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 Dynamic Intensity Control - Address: After selecting the patch universe 
of the selected object, type the starting DMX address in this box. 

 Dynamic Intensity Control - Maximum Intensity: Enables you to set the 
maximum intensity of patched objects. Select the intensity from 
the drop-down list. 

Quick light emission tool
Instead of using the Properties > Light Emission tab to change the selected 
object’s light emission, you can use the Quick Light Emission Tool. These 
tools allow you to quickly assign or change light emission properties for 
the selected object without opening the Properties window. You can enter 
repetitive information, as well as incremental information for each object 
as you click on it.

Note: The Quick Light Emission Tool applies light emission properties to the 
entire object. All elements of the object will be assigned the same color 
when using the Quick Light Emission Tool.
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To use the Quick Light Emission Tool

1 From the Tools menu, choose Quick Light Emission Tool.

Tip: You can also click the Quick Light Emission Tool from the Tools 
toolbar. 

 

Select the light emission properties for the selected object. For 
details on each of the options, see “Light emission tab”. If you want 
the value to auto increment for color, make sure you select the Auto 
Increment checkbox. WYSIWYG will assign the next sequential 
number based on the properties and requirements of the previous 
patch.

2 When you have chosen all desired values, click OK.

Sidedness tab
Options on the Sidedness tab affect how the selected object appears in 
Shaded views and Renderings. You cannot change the sidedness of any 
of the objects that come with WYSIWYG, either library objects or default 
venues. By default, all objects in the WYSIWYG library are double-sided, 
which means that when you rotate them in Shaded views, all sides 
display equally. Conversely, the default venues that come with WYSIWYG 
are single sided, which enables you to see “into” the venue when you 
rotate it in Shaded views. 

 The Quick Light Emission Tool button.
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You can, however, change the sidedness of objects that you have drawn 
in another program and imported into WYSIWYG (i.e., .dwg, .dxf files or 
SketchUp files) or objects that you have drawn in WYSIWYG, such as 
custom venues, surfaces or custom objects that you have added to the 
library. 

For these objects, you can use this tab to change the sidedness from 
single to double sided, or vice versa. For example, if you have drawn a 
venue as double sided, you can select it and change it to single sided so 
that it behaves in the same manner as the default WYSIWYG venues 
(i.e., you can see into the venue as you rotate it in Shaded views). If you 
prefer to have an outside view of the custom venue, then the double-
sided option is best as it prevents you from seeing “through” the walls. 
You can also use this feature to flip the faces of a custom surface from 
one direction to the other if you do not like the way the object appears in 
the Shaded view.

To change an object’s sidedness

You can use this procedure to change objects from single to double sided 
and vice versa. You can also flip the faces of a single-sided object so that 
they are oriented in the opposite direction, either inward or outward.

Note: You cannot change the sidedness of any of the objects that come 
with WYSIWYG, either library objects or default venues. By default, all 
objects in the WYSIWYG library are double-sided, which means that 
when you rotate them in Shaded views, all sides display equally. 
Conversely, the default venues that come with WYSIWYG are single 
sided, which allows you to see “into” the venue when you rotate them in 
Shaded views.

1 Select the object that you want to edit.

2 Right-click on the object, and then select Properties.
Tip: At any time, to access an object’s properties, you can click on 
the Properties tool on the Edit toolbar. 

Result: The Properties window appears.

3 Click the Sidedness tab.
4 Click the appropriate option button, either Double Sided or Single Sided. 

To leave the single-sided object’s faces oriented in the same 
direction in which they were drawn, proceed directly to step 6. To 
change the direction of the faces, see step 5. 

5 If you are changing a double-sided object to single sided, and you 
want to change the direction in which the object’s faces are oriented 
(either outward or inward), select the Flip Normal checkbox. 

6 Click OK.

 The Item Properties button.
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7 Review your changes in the Shaded tab and make adjustments as 
required.

 Sidedness: Choose the sidedness of the selected object:
 Double Sided: Select this option to turn the single-sided object into 

a double-sided object. Note that you cannot change WYSIWYG’s 
default venues from single to double sided. 

 Single Sided: Select this option to turn the double-sided object into 
a single-sided object. For example, if you have created a custom 
surface/wall/venue and have imported it as a double-sided object 
into WYSIWYG, you can select it and make it single sided so you 
can see “into” the venue when you rotate it in Shaded views. Note 
that you cannot change any of WYSIWYG’s library objects from 
double to single sided.

 Flip Normal: If you have imported a custom-drawn object or drawn an 
object in WYSIWYG and you see in the Shaded view that it appears 
incorrectly (the “faces” showing the texture/color are pointing 
inward), select this checkbox to flip the faces in the opposite 
direction, and then look at the object in the Shaded view again. 
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Object-specific properties
As explained above, objects also have properties that are particular to 
the type of object. For example, fixtures have unit numbers but do not 
have a radius. When an object is selected and its properties are 
displayed, a tab appears in the properties dialog box for that type of 
object. When you select multiple objects of different types, tabs appear 
for each type of object selected. The following objects are defined:

 points
 lines
 cones
 spheres
 text labels
 dimensions
 axes and motion frames

For all other types of objects (venues, circles, arcs, risers, cylinders, and 
cameras), refer to “Drawing objects”. In these cases, the properties 
dialog box offers the same options that were given when the object was 
initially drawn.

Hanging structures properties (pipes, truss, floor mounts, and so on) are 
fully defined in “Hang structures”.

Fixtures and lighting-specific object properties are fully defined in the 
“Fixture properties”section.

Colors window
The Colors window allows for full customization and control over colors 
used in WYSIWYG. From here the color of any object in WYSIWYG can be 
changed. This section will explain the various features of the color 
window.



Reference Guide 413

January 2019 CAD mode - Editing Objects 

 Standard: A hexagon of basic colors and shades available for 
selection.

 OK: Will confirm the use of a new color to replace the current color.
 Cancel: Will exit the color window without making a color selection.
 Select...: This option is used to gather a custom color sample from 

anywhere on your desktop. This option will turn the cursor into a 
dropper from which colors can be gathered.

 New: Color selected in the Color window.
 Current: The color that is currently in use.
 Saved Custom Colors: A saved palette of custom colors.
 Add to Custom: Will save selected New color to the Saved Custom 

Colors palette.
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 Custom: Section for editing a selected color’s properties.
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Point tab
Options on the Point tab affect how the selected point is drawn. The 
default point type used in a document is defined on the Object Settings tab 
of Document Options. To ignore the default setting, clear the Use Document 
Defaults checkbox, and then select the desired point type. 

Line tab
Options on the Line tab affect how the selected line is drawn. 
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 Line Pattern: Choose a line pattern for the selected lines. Refer to 
“Drawing lines” for an illustration of each type.

 Scale: Type a value in this box to change the length and spacing of 
dots and dashes for the selected lines. This value is applicable to 
center, hidden, or dot lines only.

 Spline: Select the Spline checkbox to transform a line into a spline or 
French curve. 

 Closed: Select the Closed checkbox to quickly connect the first point of 
a multi-segment line to the last point of that line. 
Note: You cannot change a line to a spline or French curve unless 
the selected line has more than two vertices.

 Arrow Options: How arrows attached to the line will be shown.
 Display: Select this checkbox to show an arrow at the end(s) of the 

line.
 Location: Where the arrow will appear on the line.
 Arrow Size: How large the arrow will appear.
 Arrow Offset: How far away the arrow if from the line.
 Arrow Type: The style of arrow that will be displayed.

 Double Line
 Double Line: Select this checkbox to display the line as a double 

line.
 Distance: How far apart the double lines will be from each other.

 Shaded View Options: Select the Shade checkbox to display the 
selected line(s) in shaded views and renderings, and in the Diameter 
box, type a value for the radius to set its thickness.
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Cone tab
Options on the Cone tab affect how the object is drawn.

 Height: Type a value to change the height of the cone.
 Horizontal Radius: Type a value to change the width of the base 

surface.
 Vertical Radius: Type a value to change the depth of the base surface.
 Lock Ratio: Select this checkbox to lock the shape proportion when 

the size of the cone is changed.
 Smooth Shading: Select this checkbox to display a smooth appearance 

in Shaded view.
 Number of Segments: Type a value to change the number of vertical 

divisions that appear when the cone is broken into surfaces, set 
pieces, or lines.

 Number of Stacks: Type a value to change the number of horizontal 
divisions that appear when the cone is broken into surfaces, set 
pieces, or lines.

 Use Document Defaults: Clear this checkbox if you want to specify the 
Number of Segments and the Number of Stacks.

Sphere tab
Options on the Sphere tab affect how the object is drawn.
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 Horizontal Radius: Type a value to change the width of the middle of 
the sphere or equator.

 Depth Radius: Type a value to change the horizontal depth of the 
middle of the sphere or equator.

 Vertical Radius: Type a value to change the vertical depth of the middle 
of the sphere or equator.

 Lock Ratio: Select this checkbox to lock the shape proportion when 
the size of the sphere is changed.

 Smooth Shading: Select this checkbox to display a smooth appearance 
in Shaded view.

 Number of Segments: Type a value to change the number of vertical 
divisions that appear when the sphere is broken into surfaces, set 
pieces, or lines.

 Number of Stacks: Type a value to change the number of horizontal 
divisions that appear when the sphere is broken into surfaces, set 
pieces, or lines.

 Use Document Defaults: Clear this checkbox if you want to specify the 
Number of Segments and the Number of Stacks.

Text label tab
Options on the Text Label tab affect the information, justification and style 
of the selected text labels.
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 Text Label: Type new text to change the label. 
 Use SHIFT+ENTER to type on the next line.
 Use ENTER to close the dialog box (equivalent to the OK button).

 Insert Smart Variable: Open the Smart Variables window and select a 
smart variable text from the table of smart variables that are listed in 
the Production Team Info tab in Document Options.

 Insert Item Data: Open the Item Data window and select data from the 
list of retrieved properties of selected fixtures and trusses.

 Multiline Text Alignment: How the text in the Text field will be aligned.
 Height: Section for controlling the height of the text label.

 Specify for: Choose how you would like to specify the height of the 
Text Label.

 Individual Line of Text: Sets the height for a single line of text.
 All Lines of Text: Sets the total height of all lines of text. 

Example: If you set this to 4' and there are 4 lines of text, then 
each line of text will be 1' in height.

 Text Label Padding: Adds space between the text and the text label 
border.

 Total Text Label Height: The height of the text and text label padding 
combined.

 Font: Section for controlling the font settings of the text label.
 Use Document Defaults: Clear this checkbox to choose the default 

font and font styles for all text labels, and then make your 
selections.

 Anchor Position: Section for controlling how the text label is 
anchored.
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 Horizontal: Select the Text label’s horizontal alignment from the drop-
down list. The available horizontal alignment options are:
 Left: Places the selected text label to the left of the insertion point.
 Center: Horizontally centers the selected text label on the insertion 

point.
 Right: Places the selected text label to the right of the insertion 

point.
 Vertical: Select the text label’s vertical alignment from the drop-down 

list. The available vertical alignment options are:
 Top: Places the selected text label below the insertion point.
 Center: Vertically centers the selected text label on the insertion 

point.
 Bottom: Places the selected text label above the insertion point.

 Outline:
 Show Border: Select this checkbox to display a border around the 

text label.
 Fill: Select this checkbox and click on the color box to add a fill 

color to the background of the text label.
 Callout and Arrow: Section for controlling how callout lines and 

arrows attached to the line will be shown.
 Show Callout: Select this checkbox to display the text label with a 

callout line.
 Pattern: The pattern of the callout line.
 Scale: The dimension at which the callout pattern is to be viewed at 

making it legible. 
 Callout Position: The position on the text label where the callout will 

extend.
 Show Arrow: Select this checkbox to show an arrow at the end of 

the callout.
 Style: The style of the callout arrow that will be displayed.
 Size: How large of the callout arrow that will appear.
 Use Label Color: When selected will use the same color as the text 

label for the callout. If not selected a different color can be chosen. 
 Lock Callout Position: When selected will lock the position of the 

callout when the text label is moved.
 Align to View: Select this checkbox to set the text labels to be legible 

regardless of plot type.

Linear dimension tab
Options on the Linear Dimension tab affect the appearance and 
measurement mode of the selected dimension. To change the length of a 
dimension, it must be stretched in the drawing. 
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 Linear Dimension: View and change how the linear dimension is 
displayed.
 Length: This box is not editable. It displays the actual length of the 

line drawn for the dimension.
 Displayed Length: Select this checkbox and type a value you wish to 

display.
 View Type: This box is not editable. It displays the plot type in 

which the dimension label is visible, which is determined when the 
dimension is drawn.

 Measurement Mode: Specify the view in which the dimension will be 
visible. Measurement modes are explained in “Drawing dimension 
objects”.

 Rotate: Select the checkbox to rotate the linear dimension.
 Angle: Type the angle of rotation.
 Fill: Select the checkbox and click the color select box to change 

the fill color behind the dimension text.
 Options: Customize the other elements of the linear dimension.

 Use Document Defaults: Toggle this option to specify whether the 
dimension is to use default document settings as configured in the 
Dimension Styles tab, or use custom settings. 

 Text Height: The height of the text used in the dimension.
 Text Offset: The positive or negative offset of the text.
 Show Leader Line: Select this checkbox to display the leader line 

which indicates the text to the linear dimension.
 Extension: The length of the extension lines.
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 Offset: The distance from extension line from the object being 
measured.

 Arrow Size: The size of the arrow head used on the dimension.
 Arrow Type: The style of arrow head used on the dimension.
 Measurement Units: Measurement modes are explained in “Drawing 

dimension objects”. Select Imperial or Metric to change the 
measurement units.

 Display Units: The preferred way to display measurements. For 
Imperial measurements, choose between Feet & Inches, or just 
Inches; For Metric, the options are Meters, Centimeters or 
Millimeters. 

 Precision: Specify the measurement precision of the dimension line. 
Based on your choice for measurement units, you can choose to 
display the drawing resolution in centimeters, millimeters, whole 
numbers, or fractions. 

 Display Alternate Unit: Select this checkbox to display the alternate 
unit.

 Align To View: The orientation of the text used in the dimension. 
Select this checkbox to set the horizontal alignment of the text to 
match your view.

Arc length dimension tab
Options on the Arc Length Dimension tab affect the appearance and 
measurement mode of the selected arc length dimension. The arc length 
dimension can only be changed when the arc itself changes.
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 Arc Length Dimension
 Arc Length: This box is not editable. It displays the actual length of 

the arc to which the dimension is attached.
 Displayed Length: Select this checkbox and type a value you wish to 

display.
 Options

 Use Document Defaults: Toggle this option to specify whether the 
dimension is to use default document settings as configured in the 
Dimension Styles tab, or use custom settings. 

 Text Height: The height of the text used in the dimension.
 Text Offset: The positive or negative offset of the text.
 Extension: The length of the extension lines.
 Offset: The distance from extension line from the object being 

measured.
 Arrow Size: The size of the arrow head used on the dimension.
 Arrow Type: The style of arrow head used on the dimension.
 Measurement Units: Measurement modes are explained in “Drawing 

dimension objects”. Select Imperial or Metric to change the 
measurement units.

 Display Units: The magnitude of scale which measurements will be 
shown, e.g. feet or inches. 

 Precision: Specify the measurement precision of the dimension line. 
Based on your choice for measurement units, you can choose to 
display the drawing resolution in centimeters, millimeters, whole 
numbers, or fractions. 

 Display Alternate Unit: Select this checkbox to display the alternate 
unit.

Radial dimension tab
Options on the Radial Dimension tab affect the appearance and 
measurement mode of the selected radial dimension. The radial 
dimension can only be changed when the circle or arc itself changes.
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 Radial Dimension
 Radius: This box is not editable; it displays the actual radius of the 

circle or arc to which the dimension is attached.
 Displayed Length: Select this checkbox and type a value you wish to 

display.
 Options

 Use Document Defaults: Toggle this option to specify whether the 
dimension is to use default document settings as configured in the 
Dimension Styles tab, or use custom settings. 

 Text Height: The height of the text used in the dimension.
 Extension: The length of the extension lines.
 Offset: The distance from extension line from the object being 

measured.
 Arrow Size: The size of the arrow head used on the dimension.
 Arrow Type: The style of arrow head used on the dimension.
 Measurement Units: Measurement modes are explained in “Drawing 

dimension objects”. Select Imperial or Metric to change the 
measurement units.

 Display Units: The magnitude of scale which measurements will be 
shown, e.g. feet or inches. 

 Precision: Specify the measurement precision of the dimension line. 
Based on your choice for measurement units, you can choose to 
display the drawing resolution in centimeters, millimeters, whole 
numbers, or fractions. 
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 Display Alternate Unit: Select this checkbox to display the alternate 
unit.

Angle dimension tab
Options on the Angle Dimension tab affect the appearance and 
measurement mode of the selected protractor object.

 Angle Dimension: Displays the actual measurements of the Angle 
Dimension.
 Angle: This box is not editable; it displays the angle as measured 

by the Angle Dimension.
 View: The box is not editable; it displays the view that the angle 

was drawn in. Angles are only visible as long as they are drawn in 
a views coplanar to either XY, XZ, or YZ planes.

 Flip Angle: Toggle this option to switch between measuring the 
interior and exterior angle defined by the Angle Dimension.

 Options: Specify display settings of the Angle Dimension. 
 Text Height: Type a value to change the height of the text displayed 

by the angle dimension tool.
 Extension Lines: Type a value to change the length of the extension 

lines.
 Radius: Type a value to change the radius of the angle dimension 

arc.
 Fixed Text Distance: Toggle this option to specify a fixed distance 

from the text to the middle of the arc.
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 Show Leader Line: Clear the Fixed Text Distance checkbox and toggle 
this option to display the anchored center line.

 Close Extension Lines: Toggle this option to close the center 
extension or to specify the length of the center extension. 

 Show Arrows: Toggle this option to display the arc with arrows. You 
can specify the size of the arrow and choose the arrow type from 
the drop-down list.

Axis tab
Options on the Axis tab affect the appearance of the selected axis. The 
Axis tab also enables you to specify the patch settings for the selected 
axis.

 Name: Modify this property to change the name of the axis.
 Type: Indicates the type of axis. Can be one of Linear or Rotation.
 Patch

 Patch Type: Allows you to specify which patch type you want. Can 
be one of DMX or Motion Patch. If DMX Patch is selected then the 
DMX Patch area will be enabled while the Motion Patch is disabled. 

 DMX Patch - Universe: Select the DMX Universe to which you want to 
bind the axis. The Universe must be created in DATA mode.

 DMX Patch - Address: Specify the starting address of the axis object. 
Linear and Rotational axes take up two channels in a DMX universe 
(Move, Move Fine).
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 Motion Patch – Universe: Select the Motion Control Universe to which 
you want to bind the axis. The Universe must be created in DATA 
mode.

 Motion Patch - ID: Specify the root ID of the axis. Linear and 
Rotational axes will take up one slot in the Motion Control 
Universe.

 Linear Axis Arrow: Enter a value to change the size of the arrow on a 
selected linear axis. 

 Label
 Height: Type the height of the text associated with the axis.
 Align to View: Select this checkbox to align the axis to the specific 

view that it is in (i.e. Side, Front, Back, Iso).
 Show Label: Select this checkbox to display the label text of the 

axis.
 Label Position: Choose where to place the label text along the axis.
 Text Justification- Horizontal: Choose how the label text is aligned 

horizontally to the axis.
 Text Justification - Vertical: Choose how the label text is aligned 

vertically to the axis.
 Font: Clear the Use Document Defaults checkbox to change the font 

face of the label text, or leave the Use Document Defaults checkbox 
selected to use defaults.

Frame tab
Options on the Frame tab affect the appearance of the selected frame. 
The Frame tab also enables you to specify the patch settings for the 
selected frame. 
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 Name: Modify this property to change the name of the frame.
 Patch

 Patch Type: Allows you to specify which patch type you want. Can 
be one of DMX or Motion Patch. If DMX Patch is selected then the 
DMX Patch area will be enabled while the Motion Patch is disabled. 

 DMX Patch - Universe: Select the DMX Universe to which you want to 
bind the frame. The Universe must be created in DATA mode.

 DMX Patch - Address: Specify the starting address of the frame 
object.    Frames take 12 channels (X, X Fine, Y, Y Fine, Z, Z Fine, 
Rx, Rx Fine, Ry, Ry Fine, Rz, and Rz Fine).

 Motion Patch – Universe: Select the Motion Control Universe to which 
you want to bind the frame. The Universe must be created in DATA 
mode.

 Motion Patch - ID: Specify the root ID of the frame. Frames will take 
up 6 slots in the Motion Control Universe, where each slot will take 
the form of ID:X, ID:Y, ID:Z, ID:Rx, ID:Ry, and ID:Rz.

 Frame Type: Select the BlackTrax Trackable Frame checkbox to set the 
frame for BlackTrax and associated with a BlackTrax Trackable. 

 Label
 Height: Type the height of the text associated with the frame.
 Align to View: Select this checkbox to align the frame to the specific 

view that it is in (i.e. Side, Front, Back, Iso).
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 Show Label: Select this checkbox to display the label text of the 
frame.

 Label Position: Choose where to place the label text along the 
frame.

 Text Justification- Horizontal: Choose how the label text is aligned 
horizontally to the frame.

 Text Justification - Vertical: Choose how the label text is aligned 
vertically to the frame.

 Font: Clear the Use Document Defaults checkbox to change the font 
face of the label text, or leave the Use Document Defaults checkbox 
selected to use defaults.

Motion ranges tab
Options in the Motion Ranges tab enable you to modify the allowed ranges 
of motion for the selected Frame. 

 X Direction: Select this checkbox to allow linear movement along the X 
axis. Edit the minimum and maximum extents to define the Frame’s 
motion range.

 Y Direction: Select this checkbox to allow linear movement along the Y 
axis. Edit the minimum and maximum extents to define the Frame’s 
motion range.

 Z Direction: Select this checkbox to allow linear movement along the Z 
axis. Edit the minimum and maximum extents to define the Frame’s 
motion range.
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 X Rotation: Select this checkbox to allow rotations around the X axis. 
Edit the minimum and maximum extents to define the Frame’s 
motion range.

 Y Rotation: Select this checkbox to allow rotations around the Y axis. 
Edit the minimum and maximum extents to define the Frame’s 
motion range.

 Z Rotation: Select this checkbox to allow rotations around the Z axis. 
Edit the minimum and maximum extents to define the Frame’s 
motion range.

 Use Motion Ranges in Live Mode: When disabled, the specified motion 
ranges will only be enforced in DESIGN mode, giving you the full free 
range of motion in LIVE mode. When enabled, the specified ranges of 
motion will be enforced in LIVE mode as well.

Textures

You can apply textures to different objects, such as venues, surfaces, 3D 
primitives, and library objects. Surfaces are created using the Surface 
tool, or by extruding a line. The textures provided with WYSIWYG 
emulate various types of surfaces, such as brick or cloth. You can also 
use your own bitmap or jpeg files as textures, to emulate projection 
screens, or to cover a surface with a texture specific to your show.

When customizing an object, you can apply either a color or a texture; 
you cannot apply both.

To apply a texture to a surface

The following procedure details how to apply a texture to a surface, but it 
can also be used to apply a texture to venues, risers, walls, library 
objects, spheres, cylinders, or cones by right-clicking, and then selecting 
Properties.

In order for textures to be displayed properly on surfaces, the surface 
must be drawn in a counter-clockwise direction. For details, see “To draw 
a surface”.

1 Right-click the surface to which you want to apply a texture, and 
then choose Properties.

2 Click the Appearance tab. 
3 Select the texture option that you want. The options are:

 Texture from Library: Indicates that the selected surface is a texture 
from the WYSIWYG library. The texture name appears in the box 
provided. Click the ellipsis button (...) to modify the selected 
surface. 

 Image Source: The selected surface uses a texture from an 
external bitmap or jpeg file on your hard drive rather than one 
from the WYSIWYG library. Click the drop-down list box to select 
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from the images stored and available in Image Manager or click 
New to create a new image source in Image Manager.

 Video Source: The selected surface uses a texture from a live or 
pre-recorded video source. Click the drop-down list box to select 
from the video files stored and available in Video Manager, or click 
New to create a new video source in the Video Manager.

4 Click Tile to have the texture repeated over the selected element in a 
continuous series of squares or rectangles, and then type the size of 
the frame in which you want the texture to appear in the Width and 
Height boxes. Based on the size that you enter, WYSIWYG calculates 
how many times the texture is repeated (or tiled) to completely 
cover the selected element. 

5 Check Stretch to make the selected texture grow to cover the entire 
surface. Based on the aspect ratio and the rotation angle, WYSIWYG 
evaluates the surface with all of its edges and stretches the texture 
so the best fit is used. This option is not active unless you choose a 
texture. You cannot choose this option for spheres, cylinders, or 
cones. If you choose this option, you can also choose the following:
 Aspect Ratio: Click this option to preserve the aspect ratio of the 

original texture image when it is stretched over the surface of the 
object you have selected. This option helps avoid distortion of 
complex textures. If the texture image cannot wrap completely 
over the entire surface of the object while maintaining its original 
aspect ratio, then the color that you choose in the Border Color box 
will be applied evenly around any excess surface area not covered 
by the texture (much like a picture frame around a picture). 

 Border Color: If you have chosen to preserve the texture’s aspect 
ratio, click this box to choose the color that will be applied evenly 
around any excess surface area not covered by the texture (much 
like a picture frame around a picture)

Note: Textures from a single image source can be applied to fit 
curved surfaces that were extruded from arcs and splines. See 
“Extrude”for more information.

6 If the texture has text or another recognizable image in it, you might 
need to rotate the image to get it right-side up. Select the rotation 
angle from the Texture Rotation drop-down list.

7 Click OK.

Alpha mapping

WYSIWYG supports simple Alpha Mapping with PNG images. In Shaded 
View, camera view can look through and lighting beams can pass through 
transparent sections of these images that were set as textures. 

Alpha Level supports Alpha Blending for Camera on surfaces with 
transparency. Two overlapping translucent surfaces will be displayed 
accurately showing the levels of intersecting transparencies.
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When Alpha Beam Shadows is enabled, alpha fill percentage/value in 
images are utilized when altering the beam’s color and intensity as it 
passes through the surface. See “Simulation tab” in Shaded Views.

Beams do not handle different levels of Alpha fill. Beams will only pass 
through the images with Alpha fill level between 0 and 127 of 255. 

In a PNG image file:

 Areas of the image filled with any level of transparency will work 
correctly as transparent or semi-transparent textures in Shaded 
view.

 Areas of the image filled with higher transparency (Alpha fill level 
between 0 and 127 of 255) will allow beams to pass through.

 Areas of the image filled with lower transparency (Alpha fill level 
between 128 and 255) will not allow beams to pass through.

Notes: 

 Each alpha shadow level supported for this feature requires 
additional video memory from your graphics card, which can impact 
performance depending on your scene and computer hardware.

 Alpha Texturing is supported with PNG images containing alpha 
transparency built into the image. For more information about using 
Alpha Textures, please see http://forums.cast-soft.com/
index.php?threads/using-alpha-in-r38.662/.

 The Image Manager window preview will display a grey checker 
pattern to identify the alpha levels that are defined in the image.
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Materials

Materials differ from textures in that they do not affect what the objects 
or surfaces will look like, but rather how they interact with light. The 
result of applying a material is only apparent in renderings and in Shaded 
view. Below is an example of a rendering with materials included:

Objects and surfaces can be assigned both a texture and a material.

You apply materials using the Appearance tab in the Properties dialog box. 
You can choose your preferred material from the list of materials 
provided with WYSIWYG. 
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To toggle materials in Shaded View

1 While in Shaded view, click Options > View Options....

2 In the Simulation tab, click the Materials checkbox to toggle materials 
in shaded view on or off.

A sample of mannequins, exactly the same except for the material 
applied: M0 default settings, M1 Metal 1(Dull), M2 Metal 2, M3 Metal 3, 
M4 Metal 4 (Shiny).

M0.
M1.

M2.
M3.

M4.
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To apply a material to an object (surface, object, or venue)

1 Right-click the object which you want to apply the material to, and 
then choose Properties. 

Result: The Properties window appears.

2 In the Properties window, click the Appearance tab.
3 From the Elements list box, choose the elements to which you want 

to apply the material. To choose a custom material for the selected 
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elements (such as metal, paper, plastic, or fabric) click the ellipsis 
button (...) beside the Material box.
Result: The Material Select window appears.

Tip: When a material is highlighted in the Material Select window, a 
preview of the material applied to objects is displayed.

4 In the Material Select window, navigate to and highlight the desired 
material, and then click Select.
Result: The settings of the element will be configured so that it 
simulates the material.

5 If desired, you can edit the default properties of the selected 
element. The element options vary as follows:
 Transparency: This setting controls the proportion of light that 

passes through the material.

 Specular Level: This setting controls how prominent other specular 
effects appear on the material.

 Specular Gloss: This settings controls the level of gloss the material 
will project.

 Specular Color Source: This setting controls the color of light 
projected on the material.

 Light Reflection: This setting controls the amount of light that is 
reflected off the material.

Note: Use the drop-down menus to change any of the material 
properties. Use the Reset button to revert back to defaults.

6 Click Apply.
7 Click OK.
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Material reflections
The reflective properties of a material can be toggled to enable true 
reflections in Shaded Views. When enabled, the material will produce a 
detailed and faithful representation of everything reflected on its surface.

Attention: The number of reflective material surfaces that WYSIWYG 
can support is 10. When enabling reflections on an object, note the 
number of surfaces that make up the object. For example, a cube has 6 
sides. If an entire cube was to be reflective, it would use 6 reflective 
surfaces. 

Note: Objects that have reflections enabled will be displayed with a blue 
bounding box in the Shaded view.

To apply reflections to an object (surface object or venue)

Note: The quality of reflection is based on the material properties of the 
object. Dull or unreflective materials will reflect poorly.

1 In CAD mode, Wireframe view, right-click the object which you want 
to apply the reflection to, and then choose Properties. 

Result: The Properties window appears.

2 In the Properties window, click the Appearance tab.
3 From the Elements list box, choose the elements of the object which 

you want to apply the reflection. 
Note: Remember WYSIWYG limits the number of reflective surfaces 
to 10.
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4 In the Material Properties section, select the Display Reflection in Shaded 
Views checkbox.

5 Click Apply.
6 Click OK.
7 Go to LIVE mode, Shaded view.
8 Go to Options > View Options....

Result: the View Options window appears.

9 In the View Options window, click the Simulation tab.
10 Under the Materials section, select the Reflections checkbox. 
11 Click OK.

Result: Reflective materials will be enabled and demonstrate true 
reflections.

Layers

Layers are drawing aids intended to help you organize your plot. They 
are like transparent acetate sheets upon which you can draw. In the 
same way that you can view several transparent sheets at once by 
placing them on top of each other, you can hide and unhide layers by 
choosing which sheets are in the stack. The top sheet is the layer that 
new objects are placed on and is called the current layer. You can also 
merge layers together if you decide that you need to combine one or 
more layers.

To find out the layer to which any object in your plot is assigned, just 
hover over the object with your cursor in any of the Wireframe views. A 
tooltip appears listing the object name and its layer. This is especially 
useful when you are working with multiple layers, some of which have 
the same color.

Layers can be organized into Layer Groups in the Layer Database 
window. The Layer Groups feature is enabled or disabled from the 
Document Options window. Layer Groups can be created, viewed, 
modified and deleted in the Layer Database window. See “Layer groups” 
for more information.
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Creating layers

To create new layers

1 From the Managers menu, choose Layers.

Result: The Layer Database window appears.

 

2 To create a new layer, click the New icon. 

 

3 Type a new name for your layer (for example, “Stage”).
4 Choose the color for the objects in the Layer, from the Layer Color 

color select box.
5 By default, the new layer is ungrouped but you may choose to set 

the new layer as part of a group if available from the Layer Group 
drop-down list.

6 Choose from the options: (WYSIWYG maintains this setting for the 
next layer that you create.)
 Make Current sets the new layer as the current active layer.

 Add Layer to current Scene adds the new layer to the current active 
Scene.

 The New Layer button.



440

CAD mode - Editing Objects  R42

 Add Layer to all Scenes adds the new layer to all the Scenes.

7 Click OK.
8 To make a layer and all objects on the layer visible on the plot and in 

shaded views, select the Visible icon. If not selected, the layer is not 
visible and is not, therefore, editable. 

9 To make a layer and all objects on the layer editable on the plot and 
in shaded views, select the Editable icon. If not selected, the layer is 
not editable and is not, therefore, visible.
Tip: You might want to cancel the selection of a layer when you are 
finished working with it to avoid possible errors while working on 
other parts of the plot. This is similar to freezing in AutoCAD. 

10 To change the color of the layer, click Color Select. 

Note: It is recommended that you select different colors for each 
layer so as to easily identify the layers on the plot. 

11 To change the line weight of the selected layer, choose the applicable 
thickness from the Line Weight drop-down list box. If you leave Default 
selected, the line weight from the Document Options window is 
applied to the selected layer. The line weight that you select applies 
to all objects on this layer (including library objects, pipes, and truss) 
and is visible in all Wireframe views in all modes. 

12 To set a different Print Color for a layer (while preserving the actual 
Layer Color), choose the color from the Color Select box under the Print 
column. By default, the Print Color is set to the Layer Color, and this 
is identified by the Color Select box shown with a checker pattern to 
identify them as the same. When the Print Color is set to a different 
color, the selected color will appear in the Color Select box.
Note: The print color will be displayed in Layouts and New Plots 
when it is set to a color.
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13 Select the checkbox on the Greyscale column to override the color of 
the layer and display it in greyscale, while preserving the actual layer 
color. This will display the layer(s) as grey, while another layer, which 
may be more important in the plot, will be displayed in their color 
and be more visible in the plot.

14 To view the properties of a layer (for example, name, color, and 
inventory of objects drawn on the layer), click the Layer Properties 
icon. For more information on these properties, refer to “Layer 
properties”.

15 Before closing the dialog box, set your current layer by highlighting 
it, and then clicking Set Current. Alternately, you can set the current 
layer buy double clicking in the first column on the left, beside a layer 
name.

Note: The current layer is the layer that you are working on at the 
moment – any object that you draw is placed on this layer and 
assumes the layer's default properties when it is drawn. A check 
mark appears beside the name of the current layer.

16 To view and modify the scenes in which a layer is included, select a 
layer, and then click Edit Scenes. For details, see “Scenes”. 

17 Click OK to close the Scenes for layer dialog box.

Notes: 

 To quickly sort the layers within the layer database, click the 
appropriate column heading in the Layer Database dialog box. For 
example, click the Editable column heading to sort the layers by edit 
setting; that is, those layers selected as editable appear at the top of 
the list in alphabetical order. 

 How columns appear in the Layer Database can be edited. The order of 
columns can be changed by clicking on a column header and 
dragging it left or right to the desired position. By right-clicking 
anywhere in the table area, a list is displayed which allows you to 
show/hide columns as you wish. On the list, click Layer Groups to 
show the layers in groups, see “Layer groups” section.

 To freeze columns, right-click on the column header and select Freeze 
Columns in the displayed list. The column that was clicked on and all 

 The Layer Properties button.

 The Set Current Layer button.

 The Edit Scenes button.
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the columns to its left will freeze, and will always be visible when 
scrolling over horizontally to the right.

Merging layers

After you add layers, you can merge two or more of them together if you 
decide that you need to combine them. 

To merge layers

1 From the Managers menu, choose Layer....

2 In the Layer Database window, hold CTRL and click to select the layers 
that you would like to merge together.
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3 With the layers selected, click the Merge Layers button.

Result: WYSIWYG asks you to specify the Target Layer, or the layer 
to which the additional layers will be merged.

4 From the drop-down list box, select the target layer, and then click 
OK.
Result: The layers are merged, and you will see only the target layer 
(the one you chose to merge other layers into). 

Layer descriptions and tags

Once layers are created, descriptions and tags can be added to the layers 
to easily sort the layers and show what they are used for. The Description 
column can contain a description of your layer, or any notes you wish. 

Note: If you import an AutoCAD file containing text in its Description 
column, the text will be imported into the Description column in 
WYSIWYG.

 The Merge Layers button.
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To add descriptions and tags to layers

1 From the Managers menu, choose Layers.

Result: The Layer Database window appears.

 

2 In the Layer Database window, click in the Description or Tag field next 
to the layer you want to add information to.

3 Type in the information in the field.

Result:  The layer will have descriptive information added.
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Layer prefixes 

The prefix tool is used to add a prefix to the existing name of all the 
selected layers.

To add prefixes to layers

1 From the Managers menu, choose Layers.

Result: The Layer Database appears.

 

2 In the Layer Database window, select the layers you want to add a 
prefix to.

3 Click the Prefix button.
Result: The Change Layer Prefix dialog box appears.

4 In the Change Layer Prefix dialog box, enter the prefix you want to use.
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5 Click OK.
Result: The selected layers will now have the chosen prefix before 
their name.

Layer properties

All layers have properties that describe the appearance of the layer. 
Objects that reside on the layer inherit the properties of the layer by 
default unless you decide to override the values. For more information on 
overriding object properties, refer to “General object properties”.

Layer highlight

You can highlight the current/active layer automatically, by keeping only 
the current layer displayed in its layer color while all the other layers are 
in greyscale.

To enable layer highlight

1 From the Managers menu, choose Layers.

2 In the Layer Database window, highlight a layer. 
3 Click the Set Current button. Alternately, you can double click the 

column on the left beside the layer name.
4 Click the Layer Highlight button. 

Result: The highlighted layer will be displayed in its layer color and 
all the other layers will be in greyscale.

 The Layer Highlight button.
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Adding filters to the layer database

When using scenes, the Layer Database can have filters applied so that 
only layers found in the scene will be visible. 

To filter the Layer Database

1 From the Managers menu, choose Layers.

Result: The Layer Database window appears.

2 In the Layer Database window, click the Select Filter icon. 

 The Select Filter button.
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3 In the filter list, select Layers in the Current Scene.

Result:  Only layers in the current scene will be visible in the Layer 
Database
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General tab
Options on the General tab affect the selected layer’s color, line weight, 
visibility, grouping, print and render color. 

 Name: The name of the selected layer.
 Description: A description of the selected layer.
 Visible: Select this checkbox to make the selected layer visible on the 

plot and in shaded views. If you modify the property here, it is 
changed on the Layer Database window.

 Editable: Select this checkbox to make the selected layer editable on 
the plot and in shaded views. Modifying the property here changes it 
on the Layer Database window.

 Tag: A descriptive tag applied to the layer. Used for sorting and 
categorizing information. 

 Line Weight: From the drop-down list, choose Default to set the layer’s 
line weight to the default value specified in Document Options. For 
more information, refer to the “Document Options”.
If preferred, you can also choose a specific line weight for the layer. 
The value is used as the line weight for all the objects that reside on 
the specified layer (including library objects, pipes, and truss), unless 
otherwise modified. To modify the line weight of an object, refer to 
the “General tab”.

 Group: From the drop-down list, choose the Layer Group where this 
layer will be set into.
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 Layer Color: Specify the color of this layer to set the color of all the 
objects that are displayed in this layer in all Wireframe views.

 Greyscale: Select this checkbox to override the color of the layer and 
display this layer in greyscale while preserving the actual color.

 Print Color: Specify a different color for objects that reside in the 
selected layer when printing the document. Select the Use Layer color 
for print checkbox to use the same layer color when printing the 
document. When the print color is the same as the layer color, the 
Color Select box will show a grey checker pattern to identify them as 
the same. When the print color is different from the layer color, the 
Color Select box will show the set color.
Note: The print color will be displayed in Layouts and New Plots 
when it is set to a color.

 Render Color: Specify a different color for objects that reside in the 
selected layer when rendering in Shaded view in Design mode. Select 
the Use Layer color for render checkbox to use the same layer color 
when rendering objects in this layer. When the render color is the 
same as the layer color, the Color Select box will show a grey checker 
pattern to identify them as the same. To modify the object color for 
rendering, refer to the “General tab”.

 Scene: The scenes that the layers appear in.

Object Counts tab
Entries on the Object Counts tab indicate the total number of objects that 
reside on the selected layer. Values on this tab are read-only. 
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Deleting layers

You must remove all objects from a layer before you can delete it. You 
cannot delete the current layer.

To delete a layer

1 Select all the objects on the layer that you want to delete, and then 
delete them or move them to another layer.

2 From the Managers menu, choose Layers.
Result: The Layer Database window appears.

3 Ensure that the layer you want to delete is not set as the current 
layer.

4 Select the layer from the list.
5 Click the Delete Layer(s) icon. 

6 Click OK.
Tips: 
 The Layer toolbar gives you quick access to all existing layers and 

the Layers database. Click the tool on the left end of the Layer 
toolbar to access the Layer database.

 Use the layer list in the Layer toolbar to quickly set the current 
layer. If objects are selected when you do this, those objects are 
moved to the selected current layer. 

Layer groups

A Layer Group is a selection of layers that are organized into a group in 
the Layer Database window. One or more layers can be selected and set 
into a Layer Group with a specified name. Layer Groups are created, 
viewed and modified in the Layer Database window. The Layer Group 
feature is enabled or disabled in the Document Options window. 

The ungrouped layers, by default are listed under the group name 
“Ungrouped”, which can be renamed like any other Layer Group. 

In the Layer Database window, the position of the “Ungrouped” group of 
layer(s) can be set to either top or bottom of the displayed list.

You can also right-click on the Layer Database window and locate Layer 
Groups from the list to toggle the display of Layer Groups in the Layer 
Database.

 The Delete Layer(s) button.

 The Layers button.
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Creating layer groups

To create new Layer Groups

1 From the Managers menu, choose Layers.

Result: The Layer Database window appears with the layer groups 
enabled and displayed.

2 Press and hold CTRL and select one or more layers.
3 Click the New Group icon.

4 Type a new name for your Layer Group.
5 Click OK.

Result: The new Layer Group with all its layers is added to the list.

6 To make all layers in the Layer Group visible or invisible on the plot 
and in shaded views, select the Layer Group, then click the Visible 
icon. All the layers in the Layer Group will not be editable if not 
visible.

 The New Group button.
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7 To make all the layers in the Layer Group editable or not-editable on 
the plot and in shaded views, select the Layer Group, then click the 
Editable icon.

8 To change the color of all the layers in the selected Layer Group, click 
Color Select. All the layers in the Layer Group will have the new color.

9 To change the line weight of all the layers in the selected Layer 
Group, choose the thickness from the Line Weight drop-down list box. 
If you leave Default selected, the line weight from the Document 
Options window is applied to all the layers in the selected Layer 
Group. The specified line weight sets the thickness for all the object 
symbols in the associated layers (including library objects, pipes, and 
truss) in the Layer Group, defining how they will appear in all the 
Wireframe views and printed Layouts.

10 To set a different Print Color for the selected layer group (while 
preserving the actual Layer Color of the group), choose the color 
from the Color Select box under the Print column. The print color 
selected for the layers in the group will be displayed in Layout and 
New Plots.

11 Select the checkbox on the Greyscale column to override the color of 
the layer group and display it in greyscale, while preserving the 
actual layer group color. This will display the layer(s) in the layer 
group as grey, while another layer, which may be more important in 
the plot, will be displayed in their color and be more visible in the 
plot.
Note: When layer groups are set in greyscale, you can change how 
the objects in the layer groups will be displayed in the General tab in 
Document Options. See the section “General tab”.
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12 On the list of Layer Groups, click the arrow at the far left of each layer 
to expand or collapse a single Layer Group.

13 Click the Collapse All button to display only the Layer Groups.

 The Collapse All button.
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14 Click the Expand All button to display the Layer Groups and all the 
Layers. 

Notes: 

 The use of Layer Groups can be switched off from the Layer Database 
window. Right-click the table area and from the list of columns that 
appear, clear Layer Groups. This links to the General tab in the Document 
Options window and disables the Enable Layer Groups option. Only the 
list of layers will be displayed in the Layer Database window.

 The order of how the columns appear in the Layer Database can be 
changed by clicking on a column header and dragging it left or right 
to the desired position.

 To show/hide columns, right-click anywhere in the table area, and 
then select or clear the columns from the displayed list.

 To freeze columns, right-click on the column header and select Freeze 
Columns in the displayed list. The column that was clicked on and all 
the columns to its left will freeze, and will always be visible when 
scrolling over horizontally to the right.

 The ungrouped layers, by default are listed under the group name 
Ungrouped, which can be changed, and listed on top or bottom of the 
list of layers.
 To change the name, click the name and type the new name.

 The Expand All button.



456

CAD mode - Editing Objects  R42

 To change the position, right-click anywhere in the table and click 
Options. Select Top or Bottom in the Grid Options window. You can 
also go to the General tab in the User Options section of the 
Document Options window. See “User Options”.

Layer group descriptions and tags

Descriptions and Tags can be added to a Layer Group which will be 
displayed to all the layers of the selected Layer Group.

To add descriptions and tags to Layer Groups

1 From the Managers menu, choose Layers.

Result: The Layer Database window appears.

2 In the Layer Database window, click in the Description or Tag field in the 
row of the Layer Group you want to add information to.
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3 Type the information in the field.

Result: The Layer Group and all the layers associated will have the 
descriptive information added.
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Moving layers between groups

To move a layer from one group to another

1 From the Managers menu, choose Layers.

Result: The Layer Database window appears.

2 In the Layer Database window, highlight one or more layers you want 
to move.

3 Click and drag the highlighted layer/s (NOT the active layer) into 
another layer group where you want the layer/s transferred.

Deleting layer groups

Deleting the Layer Group will remove the Layer Group from the Layer 
Database. All the layers of the deleted Layer Group will be ungrouped 
and returned to the Ungrouped group. All the settings of the deleted 
Layer Group will be removed from all the ungrouped layers.

To delete a layer group

1 From the Managers menu, choose Layers.

Result: The Layer Database window appears.

2 Select the Layer Group from the list.
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3 Click the Delete Layer(s) icon.

Result: The Warning dialog box appears to inform that the layers in 
this Layer Group will return to the Ungrouped Group. Select the 
checkbox Always move associated Layers to the Ungrouped Group when a 
Layer Group is deleted and the Warning dialog box will not appear 
again.

4 Click Yes.

Scenes

Scenes are collections of layers used to organize the plot. A scene may 
contain one or more layers.

Hiding a scene hides all the layers assigned to that scene. By organizing 
the layers and scenes in your plot, you can quickly perform set changes.

By default WYSIWYG creates two initial scenes: Current Layer Only and All 
Layers. You cannot delete these scenes. 

You can use keyboard hotkeys to activate and switch between scenes. 
You can also enable the DMX control of scenes feature on the Scene 
Database window and use a DMX channel to activate and switch between 
scenes. 

To create a new scene

1 From the Managers menu, choose Scenes.

Result: The Scene Database window appears.

Notes: 
 The default scenes All Layers and Current Layer Only are always 

displayed on top of the list, followed by all User-created scenes in 
ascending or descending order.

 The Ungrouped group of layers are displayed at the top or bottom 
of the list, as set in the Document Options > General tab.

 The Delete Layer(s) button.
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2 Click New to create a new scene.
3 Type the name of the new scene, and then click OK.

Result: 

 The layers associated with a scene are displayed in the Layers 
Included box with selected checkboxes.

 The new scene is added to the Scenes box with its corresponding 
Hotkey and DMX Value that were automatically assigned upon 
creation and displayed in separate columns. See the “Dynamic 
scene switching” section if you want to change the Hotkey or DMX 
Value of a scene.

4 On the Scenes box, click on a scene or multiple scenes, and on the 
Layers Included box, select the checkbox of each layer you want to 
include in the selected scene. See “Layers” to set layers from the 
Layers dialog box.
Notes: 
 To copy a scene, select the scene or multiple scenes, and then 

click the Copy button. The copied scene has the same properties 
of the selected scene. 

 To rename a scene, click on the name in the selected scene, and 
then type the new name. 
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 To remove a scene from the scene database, select the scene or 
multiple scenes (not the current), and then click the Delete 
button.

5 Click Set Current to activate your new scene. 
Note: If the current layer is not in the current scene, you will not be 
able to add any objects. 

6 Click OK.
Tip: The Scenes toolbar gives you quick access to all existing scenes 
and the Scene Database window. Click the tool on the left end of the 
Scenes toolbar to access the Scene Database window. 

Note: In order for fixtures to be displayed in scenes, both the layer on 
which the fixtures reside and the layer on which the respective hang 
structure resides (if different) must be included in the scene. You cannot 
display fixtures without their hang structures.

Dynamic scene switching
A keyboard Hotkey and a DMX Value are automatically assigned to a new 
scene upon creation. You can use the keyboard Hotkeys or enable DMX 
control of scenes to activate and switch between scenes. In the Scenes 
box, hotkeys and DMX values are displayed in separate columns where 
the settings can be changed.

To change a hotkey of a scene

1 On the Scenes box of the Scene Database window, select a scene with 
the hotkey (CTRL+NUMPAD<1-9>) that you wish to change.

2 Click the drop-down arrow on the Hotkey column of the selected 
scene.

3 From the Hotkey drop-down list of the selected scene, select the new 
hotkey setting (CTRL+NUMPAD<1-9>).

To enable DMX control for dynamic scene switching

1 On the Dynamic Scene Switching section of the Scene Database 
window, click the Universe drop-down box and select the patch 
universe of the DMX address channel.

Tip: If you want to create a new patch universe, you may click on 
the adjacent ellipsis button to open the Create Patch Universe dialog 
box.

2 In the Address box, type the DMX channel which will control the DMX 
values assigned to the individual scenes on the Scenes box.

 The Scenes button.
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3 Select the Enable DMX Control of Scenes checkbox to use the DMX 
values of the DMX control channel to activate and switch between 
scenes.

To change the DMX Value of a scene

You need to disable the current hotkey setting of your selected scene to 
change the DMX value of your selected scene.

1 On the Scenes box of the Scene Database window, select a scene with 
the DMX value that you wish to change.

2 Click the drop-down arrow on the Hotkey column of the selected 
scene.

3 From the Hotkey drop-down list, select None.
Result: The list of DMX values that can be assigned will appear in 
the DMX Value drop-down list of the selected scene when accessed.

4 Click the drop-down arrow on the DMX Value column of the selected 
scene.

5 From the DMX Value drop-down list of the selected scene, select the 
new DMX value.
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CAD tools

Break

The Break command allows you to break an object into smaller 
components.

To break an arc into arcs

1 Select the arc that you want to break.

2 From the Tools menu, choose Break, and then choose Arc into arcs.
3 Type the number of desired break arcs, and then click OK.

Result: The arc is broken equally into the number of arcs specified.

To break an arc into lines

1 Select the arc that you want to break.

2 From the Tools menu, choose Break, and then choose Arc into lines.
3 Type the number of desired break lines, and then click OK.

Result: The arc is broken equally into the number of lines specified.

To break a circle into arcs

Note: You can break circles into arcs only if they are perfectly round. If 
you have created a circle with a different horizontal and vertical radius, 
then you cannot break the circle into arcs. 

1 Select the circle that you want to break.

2 From the Tools menu, choose Break, and then choose Circles into 
arcs.

3 Type the number of desired break arcs, and then click OK.
Result: The circle is broken equally into the number of arcs 
specified.

To break a circle into lines

1 Select the circle that you want to break.

2 From the Tools menu, choose Break, and then choose Circles into 
Lines.
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3 Type the number of desired break lines, and then click OK.
Result: The circle is broken equally into the number of lines 
specified.

To break a rectangle at vertices

1 Select the rectangle that you want to break.

2 From the Tools menu, choose Break, and then choose Rectangles at 
Vertices.
Result: The rectangle is broken into lines between vertices.

To break a line at vertices

1 Select the multi-segment line that you want to break.

2 From the Tools menu, choose Break, and then choose Lines At 
Vertices.
Result: The continuous multi-segment line is broken at the segment 
intersections. Each vertex is now an independent line.

To break a line into lines

1 Select the line or multi-segment line that you want to break.

2 From the Tools menu, choose Break, and then choose Lines into lines.
3 Type the number of desired break lines, and then click OK.

Result: The line is broken equally into the number of lines specified.

To break a solid into surfaces

You can use this procedure to break solids like library objects, cones, and 
risers down into surfaces that you can customize individually. Note that 
when you do so, all of the object’s original appearance elements and 
sidedness properties remain intact.

1 Select the 3D solid that you want to break, a riser for example.

2 From the Tools menu, choose Break, and then choose Solids into 
Surfaces.
Result: Each segment of the solid becomes an independent surface. 

Tip: Alternatively, to perform a break command, you can use the 
Break tool on the Tools toolbar. This is the same as choosing Specify 
from the Break sub-menu.

 The Break button.
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To break a solid into lines
You can use this procedure to break solids like library objects, cones, and 
risers down into lines. Note that when you do so, all of the object’s 
original appearance elements and sidedness properties remain intact.

1 Select the 3D solid that you want to break, a riser for example.

2 From the Tools menu, choose Break, and then choose Solids into 
Lines.
Result: Each segment of the solid becomes an independent line. 

Tip: Alternatively, to perform a break command, you can use the 
Break tool on the Tools toolbar. This is the same as choosing Specify 
from the Break sub-menu.

To break using the Specify dialog box

1 Select the object that you want to break.

2 From the Tools menu, choose Break, and then choose Specify.

 

3 Select the desired break type from the available options by selecting 
the appropriate check boxes. Based on the object that you have 
selected to break, these options vary. 

4 In the boxes at the top right corner, specify the number of break 
lines or arcs if appropriate. 

5 Select the Delete original objects checkbox if you want the original 
object to be replaced with the new “broken” ones.

6 Select the Put new objects on current layer checkbox if you want the new 
“broken” objects to be placed on the current layer, as opposed to the 
selected object’s original layer, if different.

7 Click OK.

 The Break button.
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Convert

The Convert command turns an object into a different kind of object. For 
example, you can convert a circle into a circular surface, you can convert 
lines into pipes or surfaces, and you can convert points into focus 
positions, rigging points and vice versa.

To convert a circle into an arc

Note: You can convert circles into arcs only if they are perfectly round. If 
you have created a circle with a different horizontal and vertical radius, 
then you cannot convert the circle into an arc. 

1 Select the circle that you want to convert.

2 From the Tools menu, choose Convert, and then choose Circles into 
arcs.
Result: The circle is converted into a 360-degree arc. The marker 
points can be dragged out to open the arc, if desired.

To convert a circle into a surface

1 Select the circle that you want to convert.

2 From the Tools menu, choose Convert, and then choose Circles into 
Surfaces.

3 Type the number of segments to make up the contour of the surface. 
You cannot type the number 1. The higher the number, the more 
circular the surface.
Result: The circle is converted into a surface.

Notes: 
 If you type 2, the circle is converted into a linear surface. 

 If you type 3, the circle is converted into a triangular surface. 

 If you type 4, the circle is converted to a square surface. 

 This pattern will repeat for each increment in the number of 
segments.

To convert a line into a surface

You can use this tool to convert a multi-segment Line object into a 
surface. Note that if the Line is not closed, this operation will close it by 
connecting the start and end points. 

1 Select the Line object that you want to convert.

2 From the Tools menu, choose Convert, and then choose Lines into 
Surfaces.
Result: The line is converted into a surface.
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To convert a line into a pipe

1 Select the line that you want to convert.

2 From the Tools menu, choose Convert, and then choose Lines into 
pipes.
Result: The line is converted into a pipe, assuming all of the 
properties and characteristics of a pipe. You can name it and hang 
fixtures on it.

To convert a pipe into a line

1 Select the pipe you want to convert.

Note: There cannot be any fixtures hanging on the selected pipe. 
You must unhang or delete any fixtures before attempting to convert 
the pipe into a line.

2 From the Tools menu, choose Convert, and then choose Pipes into 
lines.
Result: The pipe is converted into a line.

To convert a focus position into a point

1 Select the focus position that you want to convert.

2 From the Tools menu, choose Convert, and then choose Focus 
positions into points.
Result: The focus position is converted into a point. Any fixtures that 
were focused to the initial focus position retain their orientation, but 
lose the association with that point.

To convert a point into a focus position

1 Select the point that you want to convert.

2 From the Tools menu, choose Convert, and then choose Points into 
focus positions.
Result: The points are converted into a focus position, and are 
automatically called “Label.” To change the name for the newly 
created focus position, refer to “Focus position properties”.

Tip: Alternatively, to perform a convert command, you can use the 
Convert tool on the Tools toolbar. 

 The Convert button.
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To convert a focus position into a text label

1 Select the focus position that you want to convert.

2 From the Tools menu, choose Convert, and then choose Focus 
Positions into Text Labels.
Result: The focus position is converted into a text label. Any fixtures 
that were focused to the initial focus position retain their orientation, 
but lose the association with that point.

To convert a text label into a focus position

1 Select the text label that you want to convert.

2 From the Tools menu, choose Convert, and then choose Text Labels 
into Focus Positions.
Result: The text label is converted into a focus position. 

To convert a line into a focus line

1 Select the line object that you want to convert.

2 From the Tools menu, choose Convert, and then choose Lines into 
Focus Lines.
Result: The line object is converted into a focus line. 

To convert a focus line into a line

1 Select the focus line that you want to convert.

2 From the Tools menu, choose Convert, and then choose Focus Lines 
into Lines.

Result: The line object is converted into a focus line. Any fixtures 
that were focused to the initial focus position retain their orientation, 
but lose the association with that line.

To convert an arc into a focus arc

1 Select the arc object that you want to convert.

2 From the Tools menu, choose Convert, and then choose Arcs into 
Focus Arcs.

Result: The arc object is converted into a focus arc.
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To convert a focus arc into an arc

1 Select the focus arc that you want to convert.

2 From the Tools menu, choose Convert, and then choose Rectangles 
into Lines.

Result: The arc object is converted into a focus arc. Any fixtures that 
were focused to the initial focus position retain their orientation, but 
lose the association with that arc.

To convert a rectangle into pipes

1 Select the focus rectangle that you want to convert.

2 From the Tools menu, choose Convert, and then choose Rectangles 
into Pipes.

Result: The rectangle object is converted into lines. 

To convert a rectangle into surfaces

1 Select the focus rectangle that you want to convert.

2 From the Tools menu, choose Convert, and then choose Rectangles 
into Surfaces.

Result: The rectangle object is converted into a surface.

To convert a point into rigging points

1 Select the point that you want to convert.

2 From the Tools menu, choose Convert, and then choose Points into 
Rigging Points.
Result: The point object is converted into a rigging point. 

Note: The type of converted rigging point symbol is Lighting by default.

To convert a rigging point into points

1 Select the rigging point that you want to convert.

2 From the Tools menu, choose Convert, and then choose Rigging 
Points into Points.
Result: The rigging point object is converted into a point.
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To convert using the Specify dialog box

1 Select the object that you want to convert.

2 From the Tools menu, choose Convert, and then choose Specify.

3 Select the desired conversion type from the available options by 
selecting the appropriate option buttons. Select the Don’t convert 
option button if you do not want to convert the circle into either an 
arc or a surface.
Note: For circles, select the Arcs or Surfaces option button, and then 
type the number of points as discussed above.

4 Select the Delete original objects checkbox if you want the original 
object to be replaced with the new “converted” one.

5 Select the Put new objects on current layer checkbox if you want the new 
“converted” objects to be placed on the current layer, as opposed to 
the selected object’s original layer, if different.

6 Click OK.

Divide

The Divide command separates objects into equal parts. The initial object 
is left intact (if not deleted), and the parts are identified by newly created 
objects, such as points or lines.

To divide an arc into lines

1 Select the arc that you want to divide.

2 From the Tools menu, choose Divide, and then choose Arcs into lines.
3 Type the number of lines desired.

Result: The arc is divided into equal parts by the number of lines 
specified. The lines are automatically drawn from the center of the 
arc outward, resulting in something similar to a pie chart.
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To divide an arc into points

1 Select the arc that you want to divide.

2 From the Tools menu, choose Divide, and then choose Arcs into 
points.

3 Type the number of points desired.
Result: The arc is divided into equal parts by the number of points 
specified. The points are placed along the arc at the calculated 
interval.

To divide a circle into lines

1 Select the circle that you want to divide.

2 From the Tools menu, choose Divide, and then choose Circles into 
lines.

3 Type the number of lines desired.
Result: The circle is divided into equal parts by the number of lines 
specified. The lines are automatically drawn from the center of the 
circle outward, resulting in something similar to a pie chart.

To divide a circle into points

1 Select the circle that you want to divide.

2 From the Tools menu, choose Divide, and then choose Circles into 
points.

3 Type the number of points desired.
Result: The circle is divided into equal parts by the number of points 
specified. The points are placed along the circle at the calculated 
interval.

To divide a cylinder into circles

1 Select the cylinder that you want to divide.

2 From the Tools menu, choose Divide, and then choose Cylinders into 
circles.

3 Type the number of circles desired.
Result: The cylinder is divided into equal parts by the number of 
circles specified. The circles are stacked within the cylinder at the 
calculated interval.

To divide a cylinder into lines

1 Select the cylinder that you want to divide.

2 From the Tools menu, choose Divide, and then choose Cylinder into 
lines.
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3 Type the number of lines desired.
Result: The cylinder is divided into equal parts by the number of 
lines specified. The lines follow the same pattern as the cylinder’s 
existing segments, but at the calculated interval.

To divide a line into points

1 Select the line that you want to divide.

2 From the Tools menu, choose Divide, and then choose Lines into 
points.

3 Type the number of points desired.
Result: The line is divided into equal parts by the number of points 
specified. The points are placed along the line at the calculated 
interval.

Note: Lines may also be divided by adding vertices. In this case, no new 
objects are created; the line is simply divided by marker points.

To divide a rectangle into points

1 Select the rectangle that you want to divide.

2 From the Tools menu, choose Divide, and then choose Rectangle into 
points.

3 Type the number of points desired.
Result: The rectangle is divided into equal parts by the number of 
points specified. The points are placed along the rectangle perimeter 
at the calculated interval.

To add a vertex to a line

1 Select the line to be divided.

2 Right-click on the line segment that you want to divide, and then 
choose Add Vertex.
Result: The original line remains intact. A marker point is placed at 
the midpoint of the line.

Tip: Alternatively, to perform a divide command, you can use the 
Divide tool on the Tools toolbar. This is the same as choosing Specify 
from the Divide sub-menu.

Notes: 

 This procedure can be repeated for vertices within a line. The marker 
points will always be placed at the mid point of the vertices. 

 Marker points can be dragged out to re-shape the line.

 The Divide button.
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 If the line is deleted, the marker points are also deleted.

To divide using the Specify dialog box

1 Select the object you want to divide.

2 From the Tools menu, choose Divide, and then choose Specify.

 

3 Select the desired divide type from the available options by selecting 
the appropriate check boxes.

4 Select the Delete original objects checkbox if you want the original 
object to be deleted when the new ones are created.

5 Select the Put new objects on current layer checkbox if you want the new 
objects to be placed on the current layer, as opposed to the selected 
object’s original layer if different.

6 Click OK.

Extrude

The Extrude command allows you to turn a 2D object like a line or an arc 
into a surface, or turn a surface into an extruded surface or 3D solid.

The extrusion will occur parallel to the axis of the missing coordinate. For 
example, objects such as line, circle, arc, or rectangle or a surface shown 
in plan view will extrude vertically.

To extrude an arc

1 Select the arc that you want to extrude.

2 From the Tools menu, choose Extrude, and then choose Arcs into 
Surfaces.

3 Type the distance to extrude the arc. 
4 Type the number of segments for the new surface in the # of Points 

box. You cannot type the number 1. The higher the number, the 
more circular the surface.
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To extrude a line

1 Select the line that you want to extrude.

2 From the Tools menu, choose Extrude, and then choose Lines into 
Surfaces.

3 Type the distance to extrude the line. 

Note: For splines, you must specify the number of segments for the new 
surface in the # of Points box.

To extrude a circle

1 Select the circle that you want to extrude.

2 From the Tools menu, choose Extrude, and then choose Circles into 
Surfaces.

3 Type the distance to extrude the circle. 
4 Type the number of segments for the new surface in the # of Points 

box. You cannot type the number 1. The higher the number, the 
more circular the surface.

To extrude a rectangle

1 Select the rectangle that you want to extrude.

2 From the Tools menu, choose Extrude, and then choose Rectangle 
into Surfaces.

3 Type the distance to extrude the rectangle. 

To extrude a surface into a solid

1 Select the surface that you want to extrude.

2 From the Tools menu, choose Extrude, and then choose Surfaces into 
Solids.

3 Type the distance to extrude the surface. 
Tip: You can also use the Extrude tool on the Tools toolbar.

Note: You can also view and edit the extrude properties in the extruded 
object’s Properties tab. 

Extrude objects

The Extrude Objects command allows you to turn a 2D object like a line 
or an arc into extruded objects where extruded surface geometry can be 
modified with options that apply textures to fit the geometry and a 
smoother appearance.

 The Extrude button.
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The extrusion will occur parallel to the axis of the missing coordinate. 
Objects such as line, spline, arc, circle or rectangle shown in plan view 
will extrude vertically.

To extrude an arc into an extruded object

1 Select the arc that you want to extrude.

2 From the Tools menu, choose Extrude Objects, and then choose Arcs 
into Extruded Objects.
Result: The Extrude Arcs into Extruded Objects window appears.

3 Type the value for Distance 1 to set the extrude distance of one end of 
the arc. 

4 Type the value for Distance 2 to set the extrude distance of the 
opposite end of the arc.
Note: If you wish to have a uniform height for the extruded object, 
set the same value for Distance 1 and Distance 2.

5 Type the Number of Points to set the number of vertices that divide the 
arc. You cannot type the number 1. The higher the number, the 
smoother the curve of the extruded arc.

6 Type the number of Extruded Segments to specify the number of 
dividing segments that will make the extruded object.

7 Select the Extrude in Both Directions checkbox if you wish to extrude 
the 2D object in both opposite directions from the axis with respect 
to the Wireframe view currently viewing the object.

8 Select the Stretch Texture checkbox if you wish to fit the applied image 
or video texture onto the resulting extruded surface geometry. If 
disabled, the default rectangular texture is applied to the largest 
extents of the object, and sections will be cut based on the resulting 
height (if two extrude distances were used).

9 Select the Smooth Shading checkbox if you wish to display extruded 
objects with a smoother appearance.

10 Click OK.

To extrude a line into an extruded object

1 Select the line that you want to extrude.

2 From the Tools menu, choose Extrude Objects, and then choose Lines 
into Extruded Objects.
Result: The Extrude Splines into Extruded Objects window appears.

3 Type the value for Distance 1 to set the extrude distance of one end of 
the line. 
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4 Type the value for Distance 2 to set the extrude distance of the 
opposite end of the line.
Note: If you wish to have a uniform height for the extruded object, 
set the same value for Distance 1 and Distance 2.

5 Type the Number of Points to set the number of vertices that divide the 
line. Minimum number is 1. 

6 Type the number of Extruded Segments to specify the number of 
dividing segments that will make the extruded object.

7 Select the Extrude in Both Directions checkbox if you wish to extrude 
the 2D object in both opposite directions from the axis with respect 
to the Wireframe view currently viewing the object.

8 Select the Stretch Texture checkbox if you wish to fit the applied image 
or video texture onto the resulting extruded surface geometry. If 
disabled, the default rectangular texture is applied to the largest 
extents of the object, and sections will be cut based on the resulting 
height (if two extrude distances were used).

9 Select the Smooth Shading checkbox if you wish to display extruded 
objects with a smoother appearance.

10 Click OK.

To extrude a circle into an extruded object

1 Select the circle that you want to extrude.

2 From the Tools menu, choose Extrude Objects, and then choose 
Circles into Extruded Objects.
Result: The Extrude Circles into Extruded Objects window appears.

3 Type the value for Distance 1 to set the extrude distance of one end of 
the circle. 

4 Type the value for Distance 2 to set the extrude distance of the 
opposite end of the circle.
Note: If you wish to have a uniform height for the extruded object, 
set the same value for Distance 1 and Distance 2.

5 Type the Number of Points to set the number of vertices that divide the 
circle. You cannot type the number 1. The higher the number, the 
smoother the resulting curve of the extruded circle.

6 Type the number of Extruded Segments to specify the number of 
dividing segments that will make the extruded object.

7 Select the Extrude in Both Directions checkbox if you wish to extrude 
the 2D object in both opposite directions from the axis with respect 
to the Wireframe view currently viewing the object.

8 Select the Stretch Texture checkbox if you wish to fit the applied image 
or video texture onto the resulting extruded geometry. If disabled, 
the default rectangular texture is applied to the largest extents of the 
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object, and sections will be cut based on the resulting height (if two 
extrude distances were used).

9 Select the Smooth Shading checkbox if you wish to display extruded 
objects with a smoother appearance.

10 Click OK.

To extrude a rectangle into an extruded object

1 Select the rectangle that you want to extrude.

2 From the Tools menu, choose Extrude Objects, and then choose 
Rectangle into Extruded Objects.
Result: The Extrude Rectangles into Extruded Objects window appears.

3 Type the value for Distance 1 to set the extrude distance of one end of 
the rectangle. 

4 Type the value for Distance 2 to set the extrude distance of the 
opposite end of the rectangle.
Note: If you wish to have a uniform height for the extruded object, 
set the same value for Distance 1 and Distance 2.

5 Type the number of Extruded Segments to specify the number of 
dividing segments that will make the extruded object.

6 Select the Extrude in Both Directions checkbox if you wish to extrude 
the 2D object in both opposite directions from the axis with respect 
to the Wireframe view currently viewing the object.

7 Select the Stretch Texture checkbox if you wish to fit the applied image 
or video texture onto the resulting extruded surface geometry. If 
disabled, the default rectangular texture is applied to the largest 
extents of the object, and sections will be cut based on the resulting 
height (if two extrude distances were used).

8 Select the Smooth Shading checkbox if you wish to display extruded 
objects with a smoother appearance.

9 Click OK.

Note: You can also view and edit the extrude objects properties in the 
extruded object’s Properties tab.

Fillet

The Fillet command joins two lines sharing the same end point or two 
apparent intersecting lines with an arc. A fillet radius must be specified to 
achieve the desired fillet angle.
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To set the fillet radius

1 From the Tools menu, choose Fillet, and then choose Specify fillet 
radius.

2 Type a radius measurement for the resulting fillet.

Note: All subsequent fillet commands will follow this value until it is 
modified again.

To fillet two lines

1 Select the lines to be filleted.

2 From the Tools menu, choose Fillet, and then choose Fillet.
Result: The lines are joined by an arc based on the value set for the 
fillet radius.

Notes: 

 You must set a fillet radius before you can perform this command. 
 If the fillet radius is 0, the lines will be extended and joined at their 

intersection. If they are already intersecting, nothing occurs.

Align

You can use the Align tools to quickly and precisely align a series of 
objects that you have drawn or have inserted from the Library into your 
drawing. For example, if you have manually placed some chairs in your 
drawing, you can select them all and align them in one of six ways. 

Note: You cannot use the Align tool to align fixtures.

You can align the selected objects from the:

 top
 bottom
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 left
 right
 center (horizontally)
 center (vertically)

Before choosing any of these options, you must select one of following 
three options:

 To First Selected: Objects selected after the first object was selected 
will align (Left, Right, Centered Horizontally, etc.) to that first object.

 To Last Selected: Objects selected before the last object was selected 
will align (Left, Right, Centered Horizontally, etc.) to that last object.

 To Extents: All selected objects (regardless of selection order) will 
align to the left-most, right-most, bottom-most, etc. point of the left-
most, right-most, bottom-most, etc. object, respectively.

To align objects

Note: You can align objects using the Align tools, or the CAD Align toolbar. 
The following procedure details how to use the CAD Align toolbar.

1 Select the objects that you want to align by clicking and dragging a 
selection box around them, or selecting them individually.

2 Ensure that the CAD Align toolbar is visible. 
3 Choose your preferred alignment option:

 To First Selected

 To Last Selected

 To Extents

Note: Before you align the objects, it is recommended you first 
verify that they will not overlap each other in their new positions. 

4 On the toolbar, select how you would like to align the selected 
objects:
 Top
 Bottom
 Left
 Right
 Center Horizontally
 Center Vertically

Array

The Array command is used to make multiple copies of an object 
distributed evenly along a line, arc, in a grid pattern, or, in the case of 
fixtures, along a pipe or straight length of truss.
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Note: For details about array fixtures along a pipe or truss, see “Hanging 
multiple fixtures”.

To perform a linear array

1 Select the object that you want to copy.

2 From the Tools menu, choose Array, and then choose Array Linear.
3 Click a point on your drawing or type in coordinates to specify the 

direction and interval for the linear array. For example, to place a 
copy of the selected object every 5’ at a 45-degree angle, type the 
following, and then press ENTER:

@5’<45 

Result: The Linear Array window appears.

4 In the Linear Array window, in the Length section, select whether the 
section drawn in Step 3 will be an Interval, or the Total Distance of the 
array. 

5 If you selected Interval, you may click Use object extents for interval to 
automatically populate the Interval box with the dimensions of the 
selected object.
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6 In the Object Placement section, click the Specify by drop-down list 
and select which values are available for editing.
Note: When performing an array copy, the value not chosen for 
editing is calculated automatically by WYSIWYG and is greyed out. 
Note: To undo changes made to the copy values, click Reset button.

7 In the Number in row box, enter the total number of copies desired 
(this includes the original object). 

8 In the Interval box, enter the interval distance between objects.
9 In the Total Distance box, enter the distance from the first to last 

object.
10 Select the Align Objects to Line checkbox to align objects to the line.
11 If you want to scale the copied objects, select the Apply Scale 

checkbox in the Scale Objects section and choose the scaling 
options that are available for editing.

12 Select the Uniform radio button to display all the copied objects in one 
size.
OR,

Select the Non-Uniform radio button to display the copied objects in 
different sizes.

13 If Uniform was selected, type the value in the X box to specify a 
uniform scale factor of the last copied object in the array. The sizes 
of the copied objects multiply uniformly in increments from the first 
to the last copied object.
OR,

If Non-Uniform was selected, type the values in the X, Y and Z boxes to 
specify the scale factors of the last copied object in the array. The 
sizes of the copied objects multiply in increments from first to the 
last copied object.

14 Click OK.

To perform an array along a path

Perform this procedure to copy a selected object along a path that shares 
the same design as a line, arc or spline. 

1 Draw a line, arc or spline that will act as a path for the cloned object. 

2 Select the object you want to copy.
Note: The object will be copied from its current location. To copy the 
object on top of the path, snap the object to the end point of the 
path. 

 The Reset button.
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3 From the Tools menu, choose Array, then choose Array Along Path.
Result: The Array Along Path window appears.

4 Under Length, select one of the two options:
 Number to clone a specific number of objects along the path.

OR
 Interval to clone the object at specific intervals along the path. 
Note: Objects can be cloned a specific number of times, or at 
specific intervals along the path. When one option is selected, the 
other will become unavailable.

5 Under the Object Placement section, if Number was selected 
previously, enter the number of time the object is to be cloned in the 
Number of items field. If Interval was selected, enter the distance at 
which the object will be cloned in the Interval field.
Note: If Interval was chosen, The Unused Distance field will show how 
much space along the path will be unused with no objects cloned.
a. Select from the Unused Location drop-down list where the unused 

space should be along the path.

6 To have the object clones aligned to the path, select the Align To Path 
checkbox.

7 If you want to scale the copied objects, select the Apply Scale 
checkbox in the Scale Objects section and choose the scaling 
options that are available for editing.

8 Select the Uniform radio button to display all the copied objects in one 
size.
OR,
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Select the Non-Uniform radio button to display the copied objects in 
different sizes.

9 If Uniform was selected, type the value in the X box to specify a 
uniform scale factor of the last copied object in the array. The sizes 
of the copied objects multiply uniformly in increments from the first 
to the last copied object.
OR,

If Non-Uniform was selected, type the values in the X, Y and Z boxes to 
specify the scale factors of the last copied object in the array. The 
sizes of the copied objects multiply in increments from first to the 
last copied object.

10 Click OK.
Result: The object will be cloned in a patter based on the path. 

To perform a polar array

1 Select the object that you want to array.

2 From the Tools menu, choose Array, and then choose Array Polar.
3 Click a point that will represent the center of the circle around which 

the objects will be arrayed.

An example of a non-snapped object using array along a path. 

An example of a snapped object using array along a path. 
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4 In the Polar Array dialog box that appears, type the total number of 
copies desired (this includes the original object) in the Number of items 
box. 

5 In the Angle to fill box, type the total angle in degrees to fill with 
copied objects.

6 Select the Rotate object checkbox if you want the copied objects to 
rotate as they are pasted around the center of the circular array, as 
shown below:

7 If you want to scale the copied objects, select the Apply Scale 
checkbox in the Scale Objects section and choose the scaling 
options that are available for editing.

8 Select the Uniform radio button to display all the copied objects in one 
size.
OR,

Select the Non-Uniform radio button to display the copied objects in 
different sizes.

9 If Uniform was selected, type the value in the X box to specify a 
uniform scale factor of the last copied object in the array. The sizes 
of the copied objects multiply uniformly in increments from the first 
to the last copied object.
OR,

If Non-Uniform was selected, type the values in the X, Y and Z boxes to 
specify the scale factors of the last copied object in the array. The 
sizes of the copied objects multiply in increments from first to the 
last copied object.

10 Click OK.

To perform a grid array

Perform this procedure to array the selected object in a grid pattern in 
the direction and at the distance that you specify. 
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1 Select the object that you want to array.

2 From the Tools menu, choose Array, and then choose Array Grid.
Result: The Grid Array window appears.

3 Select whether the horizontal and vertical lengths will be an Interval, 
or the Total Distance of the array. 
Note: Click Freehand to manually draw the horizontal and vertical 
lengths of the gird array.

4 If you selected Interval, you may click Use object extents for interval to 
automatically populate the Horizontal Interval and Vertical Interval 
textboxes with the dimensions of the selected object.

5 Specify which values will be available for editing.
Notes: 
 When performing an array, the value not chosen for editing is 

calculated automatically by WYSIWYG and greyed out. 

 To undo changes made to the clone values, click the Reset button.

6 Enter the number of columns in the grid. 
Note: This value includes the original object(s) as the first “column” 
of the grid. For example, if you type 3, the object is copied and 

 The Reset button.
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pasted twice beside the original object in the direction and at the 
distance that you specify.

7 In the Interval box, enter the spacing between each horizontal object 
in the grid.

8 In the Total Distance box, enter the distance from first to the last 
horizontal object in the grid.

9 Select the Fill direction in which you want the object(s) to be copied 
horizontally in the grid, either to the right or left of the original 
object.

10 Type the number of rows in the grid. 
Note: This value includes the original object(s) as the first “row” of 
the grid. For example, if you type 3, the object is copied and pasted 
twice above or below the original object at the distance that you 
specify.

11 In the Interval box, enter the distance between each vertical object in 
the grid.

12 In the Total Distance box, enter the distance from the first to the last 
vertical object in the grid.

13 Select the Fill direction in which you want the object(s) to be copied in 
the grid vertically, either above or below the original object.

14 Click OK.

To perform a random fill

Random fill is used to take an object and randomly copy it in a defined 
space. 



Reference Guide 487

January 2019 CAD mode - Editing Objects 

1 Select the object that you want to copy.

2 From the Tools menu, choose Array, and then choose Random Fill.
Note: The Random Fill window appears.

3 In the Number of Objects box, enter the number of copied objects to 
appear.

4 Enter the Horizontal Distance of the defined space.
Note: You can select Interactive to draw the horizontal and vertical 
lengths.

5 Select the Fill direction in which you want the object(s) to be copied 
horizontally, either left or right of the original object. 

6 Enter the Vertical Distance of the defined space.
7 Select the Fill direction in which you want the object(s) to be copied 

vertically, either above or below the original object. 
8 If you want to scale the copied objects, select the Apply Scale 

checkbox in the Scale Objects section and choose the scaling 
options that are available for editing.

9 Select the Uniform radio button to display all the copied objects in one 
size.
OR,

Select the Non-Uniform radio button to display the copied objects in 
different sizes.

10 If Uniform was selected, type the value in the X box to specify a 
uniform scale factor of the last copied object in the array. The sizes 
of the copied objects multiply uniformly in increments from the first 
to the last copied object.
OR,



488

CAD mode - Editing Objects  R42

If Non-Uniform was selected, type the values in the X, Y and Z boxes to 
specify the scale factors of the last copied object in the array. The 
sizes of the copied objects multiply in increments from first to the 
last copied object.

11 Click OK.

Distribute objects

A group of objects can be selected and then distributed in a straight line 
between two points. 

To distribute objects between two points

1 Select the objects to be distributed.

From the Tools menu, Distribute Objects sub-menu, choose Between 
Two Points.

or

Click the Between Two Points tool on the Tools toolbar. 

2 Click on the drawing to set the first distribution point.
3 Click on the drawing to set the second distribution point.

Result: The objects will be distributed evenly in a straight line 
between the two chosen points.

Distance

The Distance tool enables you to measure the distance and angle from 
one point to another.

To measure a distance

1 From the Tools menu, choose Distance.

Tip: You can also use the Distance tool on the Tools toolbar. 

2 Pick the starting point for the measurement.
3 Pick the end point of the measurement.

Result: The length and angle of the specified trajectory is displayed 
on the cursor’s instruction tooltip and in the bottom left corner of the 
Status bar.

Tip: When selecting the starting and end points for the measurement 
use the snap tools for precision.

 The Between Two Points button.

 The Distance button.
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Angle

The Angle tool enables you to measure the angle between two 
intersecting lines.

To measure an angle

1 From the Tools menu, choose Angle.

2 Pick the starting point of the measurement.
3 Pick the end point of the measurement.

Result: The angle between the two intersecting lines is displayed on 
the cursor’s information tooltip and in the bottom left corner of the 
Status bar.

Boolean operations

The Boolean Operations series of tools enable you to choose two different 
sets of objects and then perform one of three actions on them:

 Unite Objects: This option enables you to join the two sets of objects 
together as one, merging their common area so that it is 
indistinguishable from the original objects. 

 Intersect Objects: This option enables you to choose two sets of 
intersecting objects and then delete everything outside of their 
common area.

 Subtract Objects: This option enables you to select two sets of 
objects, and then subtract the overlapping area of the second set 
from the first set that you chose. 

Selection sets
When using any of the Boolean Operations tools, you must select two sets 
of objects, Set 1 and Set 2. Here are some guidelines for your selection 
sets:

 The only valid 2D object for Boolean operations is a surface.
 Valid 3D objects for Boolean operations include: Risers, Cylinders, 

Spheres, Cones, Extruded Surfaces, as well as any 3D objects 
resulting from a 3D x 3D Boolean operation. You cannot perform 
Boolean operations on library items or venues. To include a venue, 
you must first break it into surfaces.

 Each selection set include only one 2D object or only one 3D object. 
 You cannot combine 2D and 3D objects in a single selection set.
 Each set can include either 2D or 3D objects. You can specify a 

selection set comprising one 2D object and a selection set with one 
3D object in the same Boolean operation.

 All operations that involve a 3D object require that Set 1 intersects 
with Set 2. 



490

CAD mode - Editing Objects  R42

 For operations that involve only 2D objects, the objects in each 
selection set do not need to intersect physically; however, the 
projection of the objects in Set 2 must intersect with those in Set 1 
along the plane in which you are currently working. For details, see 
“Projection and intersection”.

 In a Boolean operation involving one 2D object in one selection set 
and a 3D object in the other selection set, the 3D object must be in 
the second selection set. 

With these rules in mind, the possibilities for selection set combinations 
are:

 one 3d object x one 3d object
 one 2d object x one 2d object
 one 2d object x one 3d object

Color and texture
Based on the type of object in your selection set, color and texture are 
treated differently after you perform a Boolean operation. 

 2D objects maintain their color and texture after a Boolean operation 
is performed on them; 3D objects maintain only their color (they lose 
any texture applied to them).

 In a Boolean operation involving only 2D objects or only 3D objects, 
the objects in the second selection set adopt the properties of the 
objects in the first selection set after the operation is complete.

 In a Boolean operation involving only 3D objects, if one or both of 
the objects has a texture applied, then both objects end up with no 
texture or color after the operation is complete.

 When you perform a Boolean operation on a 3D object, the object is 
converted into a set piece after the operation. Since you cannot 
apply a texture to set pieces, it is recommended that you convert it 
into a custom library object and then apply the texture. For details, 
see “To create a custom library item”. Alternately, you can convert 
the object into 2D surfaces before you perform the Boolean operation 
and then customize it. 

Projection and intersection
When performing any of the Boolean Operations procedures on selection 
sets involving 2D and 3D objects, note the difference between projection 
and intersection.

 Projection: When you are working with only 2D objects, the objects 
in one selection set need only “project” upon the objects in the other 
set within the active view; that is, the objects in each set do not have 
to physically touch, but they must overlap in the view in which you 
are performing the action.

 Intersection: When you are working with only 3D objects or a 
mixture of 2D and 3D objects, the objects in each selection set must 
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physically touch before you can successfully perform the Boolean 
Operations action, that is, they must intersect with each other. 

About the Boolean Operations feature and View Planes
There are three View Planes or axial planes in your drawing: (XY-plane, 
XZ-plane, and YZ-plane). Based on the view you are in (Plan, Front, 
Back, Left, or Right), some of these planes may not be visible. For 
example, when you are in Plan view, the XZ and YZ planes are invisible. 

When you perform any of the Boolean Operations procedures with a 2D 
surface in the second selection set, note how the objects appear on the 
active View Plane. Their appearance will give you an idea of the What-
You-See-Is-What-You-Get result from the perspective of the active view. 
By noting the active View Planes, you can perform any of the Boolean 
operations on surfaces without requiring them to be co-planar.

Examples - 2D parallel objects
In the following graphic, selection set 1 includes a red 2D surface, and 
selection set 2 includes a yellow 2D surface. Both surfaces were drawn so 
that they overlap in Plan View, as shown in the upper-left quadrant:

When you perform a Unite procedure with these sets in the Plan view 
quadrant, the results are successful because you can see that the yellow 
surface projects onto the red surface in this view (they overlap). 

The yellow surface
is selection set 2.

The red surface is
selection set 1.
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However, when you try to do the same action in the bottom left quadrant 
(Front View), the operation is unsuccessful because neither surface 
projects onto the other (they do not overlap in this view). 

Tip: To overcome this limitation, in the case noted above, you could 
extrude the surface in selection set 2 into a 3D solid, ensuring that the 
solid touches the surface in selection set 1. In some cases, it is much 
easier to perform a Boolean operation with 2D surfaces in the first 
selection set and a 3D solid in the second set because the operation is 
View Plane independent. For example, when you are cutting windows in 
walls, it is usually best to use 2D surfaces for both the windows and walls 
because you can project the image of the windows onto the walls (for 
details, see “To cut holes in walls with the Subtract tool”). However, if you 
have an odd-shaped building like a Pentagon, it would be impossible to 
align the walls with the View Plane. In this case, therefore, it would be 
easier to use cylinders for the shape of the windows and intersect them 
with the walls wherever you want a window to appear, before performing 
the Subtract procedure.

Examples - 2D non-parallel objects
If the surfaces in each of the selection sets are not parallel, the results of 
a Boolean operation can differ according to the active View Plane. In the 
following graphic, the red surfaces comprise selection set 1 and the 
yellow surface is selection set 2. Note that the yellow surface is rotated 
so that it is not parallel to any of the surfaces in set 1.
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In this case, when you perform a Subtract operation in Plan view, the 
results are predictable: the hole the size of the yellow surface appear on 
the selected red surface, as shown below. Note that the holes are not 
perfectly circular, but rather take on the exact shape of the angled circle 
as it appears in Plan view.

When you perform the same action in Front view, the operation fails 
because none of the surfaces in set 1 or set 2 is co-planar in this view. 

The red surface
is selection set 1.

The yellow surface
is selection set 2.
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However, when you switch to Right view and perform a Subtract, a hole 
appears only on the back surface (the one onto which the circle projects 
in this view), as shown below.

Example of 2D object and 3D solid
Note that if you convert the circular surface into a 3D solid, then you 
must ensure that it physically intersects with at least one of the 2D 
surfaces in set 1 before you can successfully perform a Boolean 
Operations procedure, as shown below; it is not enough for the object to 
project upon one of the surfaces. For details on projection and 
intersection, see “Projection and intersection”.
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When you perform a Subtract action on these sets in Plan view, the 
results are as follows:

Examples of each Boolean Operations procedure
The following graphic shows the two object sets that will be used as 
examples in each of the procedures in this section. 

Set 1 consists of the red cylinder and set 2 consists of the aqua cylinder:

The yellow 3D object is 
selection set 2. It must
intersect with set 1. 
 

The red surface
is selection set 1.



496

CAD mode - Editing Objects  R42

Uniting objects
This option enables you to join two sets of intersecting objects together 
as one, merging their common area. Note that when you unite objects, 
the second set of objects adopts the properties of the first set that you 
chose (i.e., its color, texture, etc.) 

Note: If you are uniting a 2D object like a surface with a 3D object like a 
riser, the 2D object must be in the first selection set and the 3D object in 
the second. After you perform this operation, the 3D object adopts the 
properties of the 2D object, becoming a flat surface with the same color 
and texture as the 2D object. 

The following graphic shows how the two sets of objects are united to 
become one object. Note how the second object set (the aqua cylinder) 
takes on the properties of set 1, becoming red.

Note: When you perform a Boolean operation on a 3D object, the object 
is converted into a set piece after the operation. Since you cannot apply 
a texture to set pieces, it is recommended that you convert it into a 
custom library object and then apply the texture. For details, see “To 
create a custom library item”. Alternately, you can convert the object into 
2D surfaces before you perform the Boolean operation and then 
customize it.

This cylinder

is set 2. This cylinder

is set 1.
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To unite objects with the Boolean Operations feature

Note that you can only select one 2D object in each selection set; you 
cannot select multiple 3D objects in a selection set.

1 In one of the 2D Wireframe views of CAD mode, select the first 
object that you want to join with the second object. 

2 Click Tools > Boolean Operations > Unite Objects.
3 Click to select the second object set that you want to join with first 

set. 
4 Right-click and choose Finish Unite.

Result: Based on the complexity of your selections, you may have to 
wait a few moments for the calculations to finish and the objects to 
be united.

Intersecting objects
This option enables you to choose two sets of overlapping or intersecting 
objects and then delete everything outside of their common area. Note 
that when you intersect objects, the intersection that remains behind 
maintains the properties of the objects in the first selection set. 

The following graphic shows the result of intersecting the red and aqua 
cylinders. Note how the remaining portion is red, just like the cylinder in 
set 1.
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To intersect objects with the Boolean Operations feature

Note that you can only select one 2D object in each selection set; you 
cannot select multiple 3D objects in a selection set.

1 In one of the 2D Wireframe views of CAD mode, select the first 
object that you want to intersect with the second object. 

2 Click Tools > Boolean Operations > Intersect Objects.
3 Click to select the second object set that you want to intersect with 

first set. 
4 Right-click and choose Finish Intersect.

Result: Based on the complexity of your selections, you may have to 
wait a few moments for the calculations to finish and the objects to 
be intersected.

Subtracting objects
This option enables you to select two sets of objects, and then subtract 
the overlapping area of the second set from the first set that you chose. 

This feature is particularly useful for cutting a hole in a surface to create 
a window. Note, however, that if you are cutting a hole in a wall to create 
a window, it is easiest to work only with 2D objects in each selection set 
since they do not have to physically touch. Instead, the “window” shapes 
need only to project onto the walls in the active view. For details, see 
“Projection and intersection”. For details on cutting holes into walls, see 
“To cut holes in walls with the Subtract tool”.

The following graphic shows the result of subtracting the aqua cylinder 
from the red cylinder. 
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To subtract objects with the Boolean Operations feature

Note that you can only select one 2D object in each selection set; you 
cannot select multiple 3D objects in a selection set.

1 In one of the 2D Wireframe views of CAD mode, select the first 
object that you want to keep in your drawing (the second set object 
will be subtracted from this set). 

2 Click Tools > Boolean Operations > Subtract Objects.
3 Click to select the second object set that you want to subtract from 

the first set. 
4 Right-click and choose Finish Subtract.

Result: Based on the complexity of your selections, you may have to 
wait a few moments for the calculations to finish and the objects to 
be subtracted.

To cut holes in walls with the Subtract tool

In this procedure, you can use the Boolean Operations > Subtract tool to 
cut a line of round windows into two opposing walls of your venue.

1 In the CAD Mode > Drawing Quad tab, draw a venue (for example, a 
black box).

2 Click the venue to select it, and then right-click and choose Tools > 
Break > Solids into Surfaces.
Note: Since the window shapes are a series of 2D surfaces, it is best 
to convert the 3D venue into a 2D surface as well. This way, the 
window shapes only have to project onto the “walls” in the same 
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plane. If the venue is a 3D object, then the windows would have to 
physically touch them (intersect) before you perform the Subtract 
operation. For details, see “Projection and intersection”.

3 Click to highlight the Front view quadrant.
4 Click the Circle tool, and then click OK to accept the default size of 4’.
5 In the Front view quadrant, click to place the circle half-way up the 

wall, at one end of the room, as shown below:

6 With the circle still selected, right-click and choose Tools > Convert > 
Circles into Surfaces.

7 Type 20 and click OK. (The higher the number of points, the 
smoother the outline of the circle.)

8 With the circle still selected, click Tools > Array > Linear.
9 In the Front view quadrant, click the extreme right-hand wall to pick 

the destination point.
10 Type 3 for the Number in row and 20 for the Interval, and then click 

OK.
Result:  The circular surfaces are arrayed along the length of the 
room.

11 In the Plan view quadrant, click the surface of the Black Box outline 
to select it, and then click Tools > Boolean Operations > Subtract 
Objects.

12 Click to select a circular surface, and then right-click and select 
Finish Subtract.

13 Apply step 11 and 12 for the next circular surface.
Result: The circular windows are “cut” into the walls of the venue, as 
shown in the following graphic: 
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Consolidated mesh

This feature helps increase performance in Shaded views by enabling you 
to consolidate complex objects comprising multiple polygons/”sub-
objects” into objects that behave as a single entity. Consolidating meshes 
is essentially the same as creating new (custom) Library Items. However, 
while both methods make WYSIWYG “see” the object as a single entity, 
when you use the Consolidate Mesh command, you don’t actually create 
a new Library Item, and the increase in file size depends on the items 
that are selected. 

To determine which objects in your scene to consolidate, it is 
recommended that you enable the new Object Bounding Box feature on the 
View Options tab. Once you do so, objects that appear with a high number 
of bounding boxes are all candidates for consolidation. 

Notes: 

 It is not recommended including library items from the WYSIWYG/
VIVIEN library as part of the selection which mesh consolidation will 
be performed on.

 If you consolidate an object to which a texture has been applied, the 
texture may not behave correctly because the object’s underlying 
geometry will be different. To maintain proper texturing AND have 
the file perform well for pre-visualization, it is recommended that you 
create a copy of the final file. Optimize the copy, and then use the 
optimized file for pre-programming purposes and the original file for 
screenshots and/or renderings. 
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To use the Consolidated Mesh feature

Note: Boolean Operations cannot be performed on Consolidated Mesh 
objects.

1 In a Wireframe view, select the object that you want to consolidate.

2 Click Tools > Consolidate Mesh.
Result: A message box appears to notify that a library item is 
selected, and offers the option to include or not.

3 Click Yes.
Result: A message box appears, confirming that the operation is 
complete, and displaying the number of polygons that have been 
removed from the file.

4 Click OK. The item is now consolidated into an abject that behaves as 
a single entity.

Revolve

This feature enables the creation of three-dimensional object by 
revolving a surface along an axis, copying the surface X number of times 
along the rotation, and filling in the spaces in between making it solid.
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An example simple surface before using the revolve.

The example surface revolved 180° from the axis.
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The example surface revolved 360° from the axis.

To use the Revolve feature

1 In a Wireframe view, select the surface that you want to revolve.

2 Click Tools > Revolve.
3 Click to place the first axis point the surface will revolve around.
4 Click to place the second axis point the surface will revolve around.

Result: The Revolve dialog box appears.

5 Enter in how many degrees the surface will rotate on the axis in the 
Angle field.

6 Enter the number of times the surface is to be copied in the Number of 
segments field.

7 To remove the original surface after revolving, select the Delete 
original objects checkbox.

8 To smooth the revolved surface, select the Smooth shading checkbox 
by.
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9 To include the revolved surface on the current layer, select the Put 
new objects on current layer checkbox.

10 Click OK.
Result: The surface will be revolved and create a three-dimensional 
object.

Trimming lines

The Trim tool can be used to remove sections of drawn lines that intersect a 
referenced object (arc, circle or line) drawn on the same plane. Trimming will 
remove all of the selected line segments, stopping at where it intersects with 
the referenced object.

To trim a line

1 In the drawing, select the reference object.

2 From the Tools menu, choose Trim.
Tip: The keyboard shortcut to access the Trim tool is CTRL+T.

3 Click on a segment of line you want to remove that intersects the 
referenced object.
Result: The selected line segment will be removed, from where the 
line intersects the reference object to where the line ends or 
intersects the object again.

4 Continue trimming lines as needed.
5 To end trimming line, right-click and choose Finish Trim or Abort Trim. 

Alternately, the ESC key can be pressed.

An arc used as a reference object (image A.) with intersecting lines 
trimmed (image B.).

A. B.
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Extending lines

The Extend tool can be used to lengthen straight lines until they touch a 
referenced object (arc, circle or line) drawn on the same plane.

Note: Lines can only be extended if they are able to intersect the 
reference object when extended. If they will not intersect, the line will 
not extend.

To extend a line

1 In the drawing, select the reference object (line, arc or circle).

2 From the Draw menu, choose Extend.
Tip: The keyboard shortcut to access the extend tool is 
CTRL+SHIFT+T.

3 Click on a line that you want to extend to the reference object.
Result: If the selected line can intersect the reference object, it will 
extend until it has done so. If the line can not intersect the object, it 
does not extend. The selected line will intersect all other objects in 
its path to reach the reference object. If the line can intersect the 
reference object on both ends, both line ends will extend until they 
intersect the reference object.

4 Continue extending lines as needed.
5 To end extending lines, right-click and choose Finish Extend or Abort 

Trim. Alternately, the ESC key can be pressed.

An arc is used as a reference object (image A.). Other lines are 
extended until they intersect with the arc (image B.).

A. B.A. B.
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Chapter  8

CAD mode - Hang Structures and 
Lighting

CAD mode is where you create and modify hang structures and 
lighting in your show drawings. This includes drawing rigging, 
lighting fixtures, lighting positions and focus positions. WYSIWYG 
adds features that are specific to the entertainment industry, such 
as a comprehensive 3D library containing truss, lighting equipment 
and lighting accessories.

In this chapter
Hang structures 509

Hanging and focusing fixtures 546

Color, gobos, and accessories 610

The Flight Case 618
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Hang structures

Introduction

Hang structures are a very important part of creating a lighting plot in 
WYSIWYG. All fixtures must be placed on a hang structure, which can be 
either a pipe or a truss. Truss hang structures are ACTUAL pieces of 
truss, ladders, booms, floor mounts or stands. Hang structures are not 
only a place to hang fixtures, but also a means to organize your 
paperwork. Some general facts about hang structures:

 Pipes are drawn, trusses are inserted from the truss library. There 
are many different types of truss pieces in the truss library, including 
box, triangle, and curved. 

 AutoUnit will assign and adjust unit numbers for fixtures on a pipe as 
you add, move, or delete them. AutoUnit does not work with truss.

 Hang structures can have the same name, even if they are not 
connected. For example, you can use this feature for set mounts, 
where you have many small pipes attached to the same piece of 
scenery. 

Position manager

The Position Manager organizes all the available position names in your 
show document. It also sets the sort order of your positions. You can use 
the Position Manager to change the sort order of the position names, 
which is important for printed paperwork like instrument schedules and 
other reports that use the Position field. The order of position names is 
also used for general sorting in the Data view and the order in which 
positions appear in the Flight Case. 

The Position Manager is accessible from the Properties window of a hang 
structure and from the Positions command in the Edit menu.
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To view and edit entries in the Position Manager

1 From the Managers menu, choose Positions.

Note: The ellipsis button [...] on the Hang Structure page of a pipe’s 
or truss’ properties will also open the Position Manager.

2 Click New.
3 Type the name of the new position, and then click OK.
4 To modify the name of a position, select the position, and then click 

Rename. 
5 Type the new name, and then click OK.
6 To remove a position name, select the name, and then click Remove. 

Removing the position name does not delete the hang structure. 
Rather the hang structure removes its association with the position 
name. 

7 Floor positions with unique names can be created in the Position 
Manager. To assign a position name as a floor position available for 
fixtures that are inserted on the floor, select the position(s) and click 
the Floor checkbox. 

8 To reorder the position names in the list, select the name of the 
position you want to move. Click Up or Down to move the name in the 
list.

9 Select the Sort Positions Alphabetically checkbox to sort the position 
names in alphabetical order.

10 If you are in a plot view and want to determine what a particular 
position references, click Select. If the plot view is open (and the 
correct layers are marked editable), the hang structures that use 
that position name are selected. To select more than one position, 
press CTRL, and then click the position.
Note: The list will set the order of the Position Names listed in the 
Spreadsheets and Reports.

11 Click OK to close the Position Manager.
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Hang structure properties
Options on the Hang Structure tab affect the properties of the selected 
hang structure(s). 

 Position Name: Select a new name for the hang structure from the 
Name drop-down list. Click the ellipsis (...) button to open the 
Position Manager and create new names.

 AutoUnit: Select this checkbox to automatically assign a number to 
each fixture that you hang. Fixtures are automatically renumbered if 
you add a new fixture into the middle of a row of fixtures. This option 
is available for pipes only and does not apply to truss. 

 Hang Options
 Snap: Select this checkbox to hang fixtures on the pipe at a certain 

interval, as specified in the Interval box. 
 Interval: Type the distance between fixtures in this box. This option 

is used for pipe snaps. 
 Use Document Defaults: Select this checkbox to use the interval for 

pipe snap as defined on the Fixture settings tab in Document Options. 
For more information on this tab, refer to “Fixture Settings tab”.

 Number of fixtures: The number of fixtures on the hang structure.
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 Fixture weight: The total weight of fixtures on the hang structure. The 
weight measurement accounts for fixture weight only and does not 
consider cable or other safety ratings.

Drawing pipes

Pipes are single member hang structures symbols that are displayed with 
thickness in 2D CAD Wireframe views and in associated paperwork 
views. In isometric views, pipes will be displayed in line representation. 
The default thickness of the pipe can be viewed and changed in the Hang 
Structure Settings tab in the Document Options window.

Pipes can be set to be drawn from the center or from the start. The first 
pipe drawing mode, Draw from Start, requires pipes to be drawn by 
specifying the start point and the end point (from one extremity of the 
pipe to the other). 

The second pipe drawing mode, Draw from Center, requires that the pipe 
be drawn by specifying the center point and one end point or extremity 
of the pipe. Although it is only necessary to enter all points when drawing 
in interactive mode, the pipe drawing mode will affect the insertion point 
of the pipe when drawing using the pipe dialog box. The drawing mode 
will also affect how the fixtures are hung when using pipe snap, how the 
fixture offset distance is measured, and how pipe tape prints are labeled.

Note: Only Pipe objects inserted in the drawing from the Library will be 
displayed in Truss Manager. Pipes drawn in CAD Wireframe will not be 
displayed in Truss Manager. 

To set the pipe drawing mode

1 From the Options menu, choose Document Options. 

2 Click the Hang Structure Settings tab. 
3 In the Pipe Drawing Mode section, select Draw from Center or Draw from 

Start.
Tips: 
 You can change the default setting for a pipe in mid-command by 

right-clicking and choosing the drawing mode for that pipe just 
before inserting it into the drawing.

 You can change the pipe mode for a specific pipe at any time in 
the pipe’s properties. For more information, refer to “Pipe 
properties”.
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To draw a pipe

1 From the Draw menu, choose Pipe.

Result: The New Pipe dialog box appears.

2 In the New Pipe dialog box, find the name of the pipe. If you need to 
create the name of the pipe, click the ellipsis button [...] to open the 
Position Manager. Click New, and then type the name of the pipe.

3 In the Length box, type the length of the pipe, if different from the 
default. The default value is 60’0”.

4 In the Trim Height box, type the desired trim height for the pipe. The 
default value is 20’0”.

Note: Pipes ignore the missing coordinate setting when drawn using 
this method.

5 To add a border to the pipe, under the Border And Legs section, in 
the Border subsection, select the Border checkbox. 
a. Enter the height of the border in the Height field.

6 To add legs to the pipe, in the Legs subsection, select the Legs 
checkbox. 
a. Enter the width of the legs in the Width field.
b. Enter the height of the legs in the Height field.

c. Enter the bottom elevation of the legs in the Bottom Elevation field.

7 Click OK.
Tip: You may also use the Pipe tool on the Draw toolbar.

 The Pipe button.
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To draw a pipe from center in interactive mode

1 From the Draw menu, choose Pipe.

Result: The New Pipe dialog box appears.

2 In the New Pipe dialog box, click Interactive.
3 Set the height of the pipe that you are about to draw by pressing the 

TAB key, and then entering a value for the missing coordinate, if 
applicable. 

4 Right-click and select Pipe - Draw from center.
5 Click to place the center point of the pipe.
6 Drag it to the proper length, and then click to place the end point of 

the pipe. Notice that the pipe extends in both directions - mirrored at 
center. 

7 Right-click on the pipe that you have just drawn, and then click 
Properties.

8 Click the Hang Structure tab.
9 From the Name drop-down list, select the name for this new pipe. If 

the name is not already in the list, use the Position Manager [...] to 
enter the new name.

10 Repeat to draw more pipes.

To draw a pipe from start in interactive mode

1 From the Draw menu, choose Pipe.

Result: The New Pipe dialog box appears.

2 In the New Pipe dialog box, click Interactive.
3 Set the height of the pipe that you are about to draw by pressing the 

TAB key, and then entering a value for the missing coordinate, if 
applicable. 

4 Right-click and select Pipe - Draw from start.
5 Click to place the starting point of the pipe.
6 Drag it to the proper length, and then click to place the end point of 

the pipe. Notice that the pipe extends in one direction.
7 Right-click on the pipe that you have just drawn, and then click 

Properties.
8 Click the Hang Structure tab.

 The Pipe button.

 The Pipe button.
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9 From the Name drop-down list, select the name for this new pipe. If 
the name is not already in the list, use the Position Manager [...] to 
enter the new name.

10 Repeat to draw more pipes.

Drawing curved pipes

In addition to drawing pipes linear in shape, pipes may be drawn curved 
in arcs.

To draw a curved pipe

1 From the Draw menu, choose Curved Pipe.

Result: The New Curved Pipe dialog box appears.

2 In the New Curved Pipe dialog box, find the name of the pipe. If you 
need to create the name of the pipe, click the ellipsis button [...] to 
open the Position Manager. Click New, and then type the name of the 
pipe.

3 In the Horizontal Radius field, type how long the pipe radius will be 
horizontally, if different from the default. The default value is 30’0”.

4 In the Vertical Radius field, type how long the pipe radius will be 
vertically, if different from the default. The default value is 30’0”.

5 In the Start Angle field, type what angle the pipe orientation will start 
at, if different from the default. The default value is 0°.

6 In the End Angle field, type what angle the pipe orientation will end at, 
if different from the default. The default value is 180°.

7 In the Trim Height box, type the desired trim height for the pipe. The 
default value is 20’0”.

Note: Pipes ignore the missing coordinate setting when drawn using 
this method.

8 Click OK.

 The Curved Pipe button.
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To draw a curved pipe from center in interactive mode

1 From the Draw menu, choose Curved Pipe.

Result: The New Curved Pipe dialog box appears.

2 In the New Pipe dialog box, click Interactive.
3 Set the height of the pipe that you are about to draw by pressing the 

TAB key, and then entering a value for the missing coordinate, if 
applicable. 

4 Right-click and select Pipe - Draw from center.
5 Click to place the first point of the horizontal axis.
6 Click to place the second point of the horizontal axis.
7 Click to set the vertical radius.
8 Click to place the center point of the pipe.
9 Drag it to the proper length, and then click to place the mid point of 

the pipe.
10 Click to place the start point of the pipe. Notice that the pipe extends 

in both directions - mirrored at center.
11 Right-click on the pipe that you have just drawn, and then click 

Properties.
12 Click the Hang Structure tab.
13 From the Position Name drop-down list, select the name for this new 

pipe. If the name is not already in the list, use the Position Manager 
[...] to enter the new name.

14 Repeat to draw more pipes.

To draw a curved pipe from start in interactive mode

1 From the Draw menu, choose Curved Pipe.

Result: The New Curved Pipe dialog box appears.

2 In the New Pipe dialog box, click Interactive.
3 Set the height of the pipe that you are about to draw by pressing the 

TAB key, and then entering a value for the missing coordinate, if 
applicable. 

4 Right-click and select Pipe - Draw from start.
5 Click to place the first point of the horizontal axis.
6 Click to place the second point of the horizontal axis.
7 Click to set the vertical radius.

 The Curved Pipe button.

 The Curved Pipe button.
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8 Click to place the center point of the pipe.
9 Drag it to the proper length, and then click to place the mid point of 

the pipe.
10 Click to place the start point of the pipe. Notice that the pipe extends 

in both directions - mirrored at center.
11 Right-click on the pipe that you have just drawn, and then click 

Properties.
12 Click the Hang Structure tab.
13 From the Position Name drop-down list, select the name for this new 

pipe. If the name is not already in the list, use the Position Manager 
[...] to enter the new name.

14 Repeat to draw more pipes.

Mirroring pipes

Once a pipe is created, a mirror image of the pipe can be created. 
Mirroring duplicates and reverses the pipe, inserting it the same distance 
from an axis line as the original pipe. Both straight and curved pipes can 
be mirrored. A mirrored pipe will also include any fixtures attached to the 
original pipe, but aiming the fixtures at the new mirrored angle. See 
“Mirroring” section for more information.
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Pipe properties

Options on the Pipe tab affect the mode, offset, and dimensions of a pipe. 

 Length: Type new text to change the length of the selected pipe.
 Trim Height: Type new text to change the trim height. If the pipe is 

vertical, this value determines the lowest Z value of the pipe.
 Pipe mode: Select the pipe mode for the specific pipe from the drop-

down list.
 Start: If enabled, pipes are drawn from one end to the other. When 

start mode is used, offset is measured from the beginning of the 
pipe in a positive direction.

 Centre: If enabled, pipes are drawn from the center out to both 
ends at the same time. When center mode is used, offset values 
are either positive or negative, measured from the center of the 
pipe. 

 Offset Type: Offset is a fixture property that measures where a fixture 
is hung on a pipe. The value depends on the pipe mode selected.
Pipes can also base the Offset on a specified coordinate. In this case, 
a fixture’s offset value is calculated as the distance on the specified 
axis from the specified coordinate. This is handy if you have many 
small pipes grouped together to form one hang position, for example 
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the Balcony Rail. If this is the case, choose all the pipes’ properties to 
have their Offset based about X=0. Fixtures on the Balcony Rail will 
then report where they are relative to the theatre, rather than the 
beginning of the pipe. 
This offset methodology can be extended to box booms as well. For 
example, a boom in the first box (which is 10’ above the deck) can 
be drawn as a vertical pipe and have its offset to be based about 
Z=10’. A fixture’s offset will then tell you how high (from the bottom 
of the box) to hang it. 
In WYSIWYG, set the offset mode that you want to use. The choices 
are:
 Normal, which indicates that the offset is based on the pipe mode. 
 X, Y, and Z, which calculates the offset based on the specified 

coordinate.
If you have selected an X, Y, or Z offset type, then you must specify 
a coordinate on the axis from which offset values will be calculated.

 Pipe Weight
 Specify by: Select how to specify the weight value. 
 Weight by Unit: Type a weight value equivalent to a unit of 

measurement.
 User Defined: Type a custom weight value for the selected pipe 

object.
 Total Weight: Displays the sum total weight for the selected pipe 

object.
 Pipe Thickness

 Use Document Defaults: Select this checkbox to reference the options 
selected on the Wireframe Details tab in Document Options. Clear the 
checkbox to make specific changes for the active view.

 Enable: Select this checkbox to display the selected pipe with 
thickness in 2D CAD Wireframe views and in associated paperwork 
views (Not in isometric views). 

 The box displays the default thickness of the pipe. Type a new 
value to change the default thickness.

 Symbol Fill: Click the drop-down list and select the fill option None, 
or Percentage or Custom Color.

 Percentage: Set the percentage from the drop-down list for the hue 
intensity of the fill.

 Custom Color: Click the color select box and select the custom color 
as the fill.

 Border and Legs
 Border: Select this checkbox to change the Height of the added 

border.
 Legs: Select this checkbox to change the Width, Height and Bottom 

Elevation of the added legs.
 Curtain

 Enable: Select this checkbox to add a curtain to the pipe.
 Style: Click this drop-down to change the pattern of the curtain.
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 Depth: Type a new value to change the depth of the curtain 
pattern.

 Width: Type a new value to change the width of the curtain pattern.
 Segments: Type a new value to change the number of segments in 

the curtain pattern.
 Offset: Type a new value to change the distance measurement 

value between curtain and pipe.

Hanging truss

Truss is a hang structure with multiple hanging members. Truss differs 
from pipes in that it is built from library objects instead of being drawn. 
WYSIWYG contains an extensive library of different truss types from 
many different manufacturers. The truss library also contains floor 
mounts, booms, and ladders.

Truss symbols are displayed with thickness in 2D CAD Wireframe views 
and in associated paperwork views. In isometric views, truss will be 
displayed in line representation. The default thickness values for the 
main chord and cross-members of the truss are specified in the Library, 
and can be specified and saved in the Truss Manager window. The Truss 
Manager can be accessed from the Welcome Screen and in CAD. See 
“Truss manager”.

Indicators for truss assembly

When hanging or selecting truss, a 3D indicator appears, displaying a 
directional/positional reference for the individual piece of truss. You can 
use these indicators as a visual guide, helping you to assemble truss 
structures and instantly determine if a truss piece was not assembled as 
intended.

Notes: 

 These 3D indicators are in no way related to WYSIWYG’s coordinate 
system.

 It is highly recommended that you build truss structures in Isometric 
view and follow the left-to-right truss assembly rule.

 When a truss structure is completed, as long as the indicators for all 
the component pieces align (taking into consideration corner blocks 
and connectors – see example below), fixtures will hang correctly 
from this structure. 

Indicators are visible whenever you select truss or when you are in the 
process of assembling/inserting it. When you are snapping a new piece of 
truss to an existing piece, if you see that the indicator for the existing 
piece does not align with the indicator for the new piece, right-click and 
select a different mount point, or roll the truss as necessary (rolling truss 
usually applies to triangular truss or with corner blocks), to ensure that 
the two indicators align.
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Naturally, corner blocks and connectors have to be taken into 
consideration. For example, in the truss structure shown below (starting 
from the bottom left-most section and traversing counter-clockwise), the 
two truss pieces along the bottom have matching indicators.

When the 90º corner block is used, the “running direction” of the truss 
changes. As such, the next truss piece is now rotated as shown by its 
indicator. This continues all the way around this rectangular truss 
structure until we connect back to the bottom left corner. 

As the example demonstrates, while not all indicators will align in the 
same orientation (which would be impossible), the assembly may still be 
correct. When creating truss structures, take a moment at each corner 
block to analyze how the running direction of the truss changes due to 
the corner block. To do so, look at the indicator alone and visualize what 
would happen if you rotated it by 90º (or another angle, depending on 
what corner block/connector you are using). 

If the indicator of the existing piece had the red line pointing to your 
right and green pointing up, rotating it 90º counter-clockwise would 
cause the green line to point to your left and the red to point up, while 
rotating the indicator 90º clockwise would cause the green line to point 
right and the red arrow to point down. 

These are the only two cases in which fixtures hanging from the two 
pieces attached to the 90º corner block would behave “as expected”; 
should the indicators appear in any other positions, undo and assemble 
the truss again, making sure not to activate any of the right-click roll/
alternate mountpoint options as you begin the assembly.
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As you can see from the isometric screenshot of this same truss 
structure (below), all of the blue indicators are pointing in the same 
direction, which means that all lights hung from this truss will point 
downwards to the floor.

Configuring truss indicators
You can configure how the breaks in your truss rig appear in your 
drawing, a handy feature for showing your stage crew and production 
house quickly and simply the features of your truss structure.

This feature is configured on the Document Options > Hang Structure Settings 
tab. For details, see “Hang Structure Settings tab”.

For example, the following graphics show two files, the first with thick 
angled dividers, the second with thin angled dividers:
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Truss with thick angled dividers

Truss with thin angled dividers

There are two types of Truss Indicators:
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 Linear Section Dividers: Lines that appear parallel to the ends of your 
truss sections. These lines are always thick and can be colored any 
way you choose.

 Angled Section Dividers: Lines that appear at the junction of truss 
sections on a 45 degree angle with the truss end. The Angled Section 
dividers can be thick or thin, and can be colored any way you choose.

To configure truss indicators

1 Turn on truss indicators by clicking Options > Document Options > 
Wireframe Details.

2 Select Show Truss Indicators checkbox.
3 Select the checkboxes for Linear Dividers and Angled Dividers.
4 You can choose to display thicker angled section dividers if you like 

by clicking the Use Truss Properties for Truss Indicators (Line Weight and 
Color checkbox in the Truss Indicators section in the “Hang Structure 
Settings tab”.

To hang truss

Before you hang truss, it is highly recommended that you enable Truss 
Assembly Snap, which connects truss pieces as you insert them, ensuring 
proper structural assembly and grouping. This is especially useful for 
long or complex structures made up of many individual pieces of truss. 
As with all snap functions (discussed in), you can select Assembly Snap in 
mid-command or as a running snap type. For details, see “To select 
Assembly snap as a running snap type” or “To select Assembly snap in 
mid-command”.

Note: Truss can now be hung horizontally or vertically. When a truss is 
hung vertically, the rotation of the truss is also set. The rotation angles 
available to vertical truss are  0°, 90°, 180°, 270°. The angles are based 
on the same Cartesian system used throughout WYSIWYG: 0º is the +X 
axis, 90º is the +Y axis, 180º is the -X axis and 270º is the -Y axis. 
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1 Open the Library Browser, and then click the Truss tab.

Tip: You can also click the Truss tool on the Draw toolbar to place 
truss. 

2 Navigate through the library to find the type of truss you want to 
use.

 The Truss button.

0° 90º 180º 270º
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a. To insert the truss horizontally, double-click the truss name. To 
insert the truss vertically, right-click and select the rotation of the 
truss from the list. 

Result: A piece of truss attaches to the cursor.

3 Click on the drawing to place the first piece of truss.
4 Continue placing pieces of truss as needed, using the truss indicators 

as guides when attaching one piece of truss to another. For more 
information, see “Indicators for truss assembly”. It is strongly 
recommended that you use Assembly Snap when building truss 
structures. See “Using assembly snap with truss” for more details.
Note: To change the truss type, return to the library, double-click on 
the name of the new desired truss type and continue placing truss 
pieces as normal.
Tip: You can also use Truss shortcuts. 

5 Right-click and choose Finish Placing Truss. 
6 Right-click on the truss that you have just inserted, and then click 

Properties.
7 Click the Hang Structure tab.
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8 From the Position Name drop-down list, select the name for this new 
truss. If the name is not already in the list, use the Position Manager 
[...] to enter the new name.

9 Click OK.

To insert a shortcut for truss objects

Refer to “To create a new shortcut”.

Using assembly snap with truss

Assembly snap assembles truss pieces together, ensuring proper 
structural assembly. This operation can be done as you insert truss, or to 
truss that is already inserted into the file. This is especially useful for 
long or complex structures made up of many individual pieces of truss. 

As with all snap functions (discussed in), you can select Assembly snap in 
mid-command or as a running snap type. 

To select Assembly snap as a running snap type

Enable Assembly snap before inserting truss to assemble and group all 
subsequently inserted pieces of truss.

To select Assembly snap in mid-command

Enable Assembly snap after inserting the first piece of truss to assemble 
selectively. Assembly snap disengages after you place the next piece of 
truss, assembling only the first truss (or group of trusses) with the 
second piece.

To use Assembly snap

1 From the Tools menu, click Snap, and then choose Assembly.

Tip: You can also click the Assembly Snap tool on the CAD Options 
toolbar. 

2 Insert the first piece of truss as described above. To snap truss 
pieces together, hover the cursor over the end of the piece of truss to 
which you want to attach the next piece and it will automatically 
snap into position. For added guidance, use the truss indicators to 
ensure that the truss is placed correctly. For more information, see 
“Indicators for truss assembly”.

3 Click to insert the piece of truss in the drawing.

 The Assembly Snap button.
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To use Assembly snap on truss already inserted

1 Select a truss that is already inserted into the file.

2 Right-click the truss and select Activate Truss Assembly on selected 
Truss.

3 Select a base point for the truss.
4 Click to place the truss in the drawing with Assembly Snap now 

enabled.
Result: The truss will be at the new location, snapped to any 
connecting truss.

Reassembling truss
Sometimes while building truss, you will notice that a mistake was made. 
It is easy to fix mistakes right away if noticed immediately, but 
sometimes these things are noticed much later after the truss structure 
was already built. 

It is possible to ungroup the assembled truss structure, make edits, and 
then if the truss objects are positioned so they can be reassembled, 
select them all and reassemble them easily.

To reassemble truss

1 Select truss that you want to assemble and are positioned to be 
assembled.

2 Right-click and select Activate Truss Assembly on selected Truss.
Result: The truss structure is reassembled as if it was built like this 
originally, and features like Fixture Array or Fixture Distribution along 
and features like Fixture Array or Fixture Distribution along a section 
of Truss will work. 

Note: After the selected truss is reassembled, any existing group will be 
deleted automatically.

Rolling truss and selecting alternate mount points during 
assembly

When inserting truss pieces in your drawing, you can roll them into the 
desired position by using the Roll tool in the right-click menu or the Roll 
hotkeys (X and Z). By enabling Assembly snap, pieces of truss that you 
drag into the drawing and bring close to the end of an already-inserted 
piece of truss will snap to connect to that truss, ensuring proper 
structural assembly.

Notes: 

 By default, truss will always insert parallel to the X-axis. If the truss 
structure you are building needs to start with a piece in a different 



Reference Guide 529

January 2019 CAD mode - Hang Structures and Lighting 

position, you must insert that piece, right-click to finish inserting it, 
and then use WYSIWYG's Rotate function (Edit > Rotate), to adjust it 
to the desired position. The Truss Roll commands can only be used 
when subsequent pieces of truss are inserted.

 When rolling truss, use the truss indicators as guides. For more 
information, see “Indicators for truss assembly”.

Rolling truss

It is sometimes necessary to roll truss—most often when you use corner 
blocks that change the (vertical) running direction of the truss.

The Truss Roll commands allow truss to be "rolled" or "spun" around its 
long axis, and are only available when you are attaching truss to an 
existing piece of truss (in the right-click menu and/or via hotkeys).

Note: You should only roll truss when you notice that the cords of the 
piece that you are attempting to assemble do not connect properly to the 
existing piece. 

To access the Roll options, you must have already inserted a piece of 
truss and the next piece must be attached to your cursor and ready to be 
attached to an existing piece. When you right-click, a menu appears that 
allows you to change the roll of the truss in 90º increments. 

Tip: In addition to, or instead of, the right-click menu, use the Z and X 
keys to cycle through the standard Roll options: 
 Pressing Z will cycle forward through the options. For example, if 

starting at the default Roll 0º, pressing Z once will change to the Roll 
90º, pressing it again will change to Roll 180º, and then to Roll 270º, 
and finally back to Roll 0º.

 Pressing X will cycle backward through the options. For example, if 
starting at the default Roll 0º, pressing X once will change to the Roll 
270º, pressing it again will change to Roll 180º, and then to Roll 90º, 
and finally back to Roll 0º.

The selection of a Roll option is NOT maintained after the piece of truss 
that it was used on, was assembled. In other words, once a piece of truss 
was assembled into the structure, the Roll option will ALWAYS change 
back to Roll 0º. It is not possible nor desired to maintain the Roll option 
since there are virtually no cases in which this would be required.

Examples
In the images below, you can clearly see that the cords of the piece 
that's about to be attached to the 'down' leg of the corner block do not 
align/connect properly with the default "Roll 0º" position, so a different 
Roll option must be selected. After cycling through the four Roll options 
(0º, 90º, 180º and 270º), it is clear that the Roll 270º is the correct 
position.
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Roll 0º

Roll 90º
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Roll 180º

Roll 270º

Select Mountpoint options
A Mountpoint is any part of a truss section, corner block and/or 
connector to which another section, corner block or connector can be 
attached. 
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As with the Roll options, the Select Mountpoint options are only available 
(in the right-click menu and/or via hotkey) while truss is being attached 
to an existing piece of truss and the next piece/section, corner block and/
or connector must be on the cursor and ready to be attached to the 
previous pieces. Their purpose is to allow a different Mountpoint of the 
truss to be selected during assembly. 

Selecting a different Mountpoint is sometimes necessary when you are 
attaching a connector or corner block to a straight or curved section of 
truss, in case attaching with the default Mountpoint is not desired or 
would result in an incorrect structure. 

Selecting a different Mountpoint is always necessary when you are 
assembling straight or curved truss section runs from the center out. For 
example, if you were to build the Front of House truss starting at the 
centreline and first attaching sections towards the right (stage left in 
some cases), and then attaching sections from the center towards the 
left (stage right in some cases), you would need to change to Mount 2 
once you start to attach sections towards the left; otherwise, the Truss 
Indicators would show you that the running direction of the truss is no 
longer correct, as shown in the graphics below.

Here, the section left of center has been attached without selecting the 
Mount 2 Mountpoint. Note that the Truss Indicator for this section 
appears in the opposite direction from the Truss Indicators for the pieces 
right of center.
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When you right-click and select the Mount 2 Mountpoint before attaching 
the truss, the Truss Indicator for the truss section left of center matches 
the Indicators for the existing sections.

Notes: 

 In addition to, or instead of, the right-click menu, you may use the S 
key to cycle through the available Mountpoints. Remember that for 
many truss pieces (and especially for sections), their appearance 
may not change when a different Mountpoint is selected, but the 
Truss Indicator will always change.

 The selected Mountpoint is maintained until a new piece of truss is 
selected for insertion. This is to facilitate building truss structures in 
the fashion described above (i.e., starting at the center and building 
towards the right, and then coming back to center and building 
towards the left).

Truss snap

When Truss Snap is enabled, a truss object is displayed with red points 
at the bounding box corners that can be used to assist with drawing 
dimension measurements for truss width and height. 

The red points that appear incorporate the truss thickness when used to 
snap and measure the outer extents of the truss object.
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Mirroring truss

Once a straight or curved truss is created, a mirror image of the truss 
can be created. Mirroring duplicates and reverses the truss, inserting it 
the same distance from an axis line as the original truss. Both linear and 
circular trusses can be mirrored. A mirrored truss will also include any 
fixtures attached to the original truss, but aiming the fixtures at the new 
mirrored angle. See “Mirroring” for more information on mirroring 
objects.

Notes: 

 The Mirror command menu or icon will be disabled when a truss 
object cannot be mirrored.

 If you mirrored a truss object that is part of an assembled truss 
structure, the warning message will be displayed listing the library 
names and number of instances of the truss object(s) that will be 
mirrored and truss object(s) that cannot be mirrored.
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Truss manager

The Truss Manager is a centralized location where you can view or edit 
the default properties of Truss objects from the Library, such as Pipe, 
Scaffold and Truss, which will affect how the symbols and their 
dimensions will be displayed in your drawing.

In Truss Manager, the changes applied to the default thickness of truss 
chord and cross-members will affect the appearance of the selected truss 
object in your drawing. 

In Truss Manager, the changes applied to the default width, depth and 
height of the truss object will be displayed in your drawing when the Auto 
Truss Dimension menu is applied.

The Truss Manager can be accessed from the Welcome Screen or from the 
Managers menu in CAD mode.

The Truss Manager window that opens from the Welcome Screen enables 
you to set your preferred default properties for any truss objects in the 
Library that you plan to use in your drawing. The default thickness values 
you set for the chord and cross-members of the individual truss object 
will be used for all your new files. The default dimension values you set 
for the truss objects will be used for all your new files.

The Truss Manager window that opens from within a file in CAD mode 
displays the list of truss objects that were inserted in your drawing. Any 
edited values in this window will only be used in the current file, unless 
you will set those as your new default values. 
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To access the Truss Manager in the Welcome Screen

1 From the Options menu in the Welcome Screen, choose Truss 
Manager.

Result: The Truss Manager window opens from the Welcome Screen.

To add truss objects

1 In the Truss Manager window, click the Add a truss object icon. 

Result: The Add Truss to Manager window appears.

2 In the Add Truss to Manager window, browse and select the truss 
object you want to add.

3 Click Insert Folder to add the truss object into the Truss Manager.
Result: The truss object will be displayed in the table in the Truss 
Manager window showing the editable and non-editable properties of 
truss objects.

4 In the table, click the arrow at the far left column of each truss 
object to select and highlight the row.
Tip: Use SHIFT and CTRL to select all or multiple truss objects in the 
table.

5 In the table, you can view or edit the default truss properties of the 
truss objects on display. See “To edit the default properties of the 
truss objects” to view or edit the properties in the table.

 The Add a truss object button.
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6 Click Reset to Defaults to reset the selected items in the table to their 
corresponding default properties.

7 Click Apply to activate the changes.
8 Click OK.

Result: All changes to the default properties of the truss objects 
listed in the Truss Manager will be applied to all the truss objects in 
your drawing and all new files.

To access the Truss Manager in CAD

1 From the Managers menu, choose Truss Manager.

Result: The Truss Manager window appears.

Note: In the table, the properties that were changed are displayed in 
colored text when the edited values are different from the loaded or 
saved defaults.

To edit the default properties of the truss objects

1 In the Truss Manager window, view or edit the following properties:

 Display Columns: Click this button to display the Truss Manager 
Options dialog box where you can choose which column and how 
to display in the Truss Manager window. 

 Select: Select this checkbox to choose the truss object and its 
properties.

 Truss Name: The name of the truss object that is stored in the 
Library. (Not editable)
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 Color Type: Click this drop-down menu to select Object Color or 
Custom Color. 
 Object Color: By default, Color Type is set to Object Color and 

truss objects are displayed as defined by their properties. 

 Custom Color: Select Custom Color to always display the selected 
truss object in a different color, ignoring the color of the Layer 
or the color that was assigned within its Properties dialog box. 
This does not change the properties of the truss object which 
will revert back to the color set in Properties when Color Type 
switches to Object Color.

 Color: Click the Color Box to select the custom color for the 
selected truss object. Color is enabled when Custom Color is 
selected from the Color Type drop-down menu.

 Truss Alias: Type a user name for the truss object.

 Chord: Type a new value to change the thickness of the chord for 
the selected truss object.

 Cross-Member: Type a new value to change the thickness of the 
cross-members for the selected truss object.

 Auto Dim X: Displays the specified length for the listed Truss item 
that will appear when the Auto Truss Dimension tool is applied. 
You may type a new value and the edited length will be displayed 
in blue text.

 Auto Dim Y: Displays the specified width for the listed Truss item 
that will appear when the Auto Truss Dimension tool is applied. 
You may type a new value and the edited width will be displayed 
in blue text.

 Auto Dim Z: Displays the specified height for the listed Truss item 
that will appear when the Auto Truss Dimension tool is applied. 
You may type a new value and the edited height will be displayed 
in blue text.

 Is Selected: Displays Yes if the truss object is selected in the 
drawing or No if not selected in the drawing. (Not editable)

 Manufacturer: Name of the manufacturer of the truss object that is 
stored in the Library. (Not editable)

 Weight: Default weight of the truss object that is stored in the 
Library. (Not editable)

 Load Thickness Values from Defaults: Applies the default thickness 
values stored in the Library database to all the selected truss 
objects listed in the table.

 Save Thickness Values as Defaults: Saves the edited values of all the 
selected truss objects as the new default values for all the 
selected truss objects listed in the table.

 Show Selected Truss: Select this checkbox to display the table with 
only the truss objects that are selected in the drawing.
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 Show Edited Truss: Select this checkbox to display the table with 
only the truss objects with properties that were edited.

 Show All Truss in File: Select this checkbox to display all truss 
objects in the drawing.

Note: Some truss objects from the Library, such as Pipe objects will 
show no effect in the drawing when certain properties are changed in 
Truss Manager. For example, a pipe object from the Library will show 
only the changes to the Chord and X values.

2 Click Apply to activate the changes.
3 Click OK.

Result: All changes to the default properties of the truss objects 
listed in the Truss Manager will be applied to all the truss objects in 
your drawing.

Drawing rigging points

A Rigging Point object delivers a method to indicate which of the venue’s 
rigging points will be used to hang the Hang Structures required by the 
show, or where in the venue’s ceiling rigging points must be “created” 
(by standard rigging techniques using baskets, shackles, stringers, 
bridles, etc.) in order for those hang structures to hang where required. 
In other words, in WYSIWYG, the Rigging Point is the “point in the 
ceiling” to which a chainfall’s hook is attached. Position Names can be 
assigned to Rigging Points in order to help identify which hang structures 
hang from them; this is useful in general, and required, if the Rigging 
Points List Report is to be of use.

When you insert a Rigging Point from the Draw menu, a dialog box 
appears where you can specify its name and properties. The available 
symbols are Lighting, Audio, Video and Scenic, and further options are 
available within the Rigging Point’s Properties window.

Notes: 

 Automatic replacement of truss rigging points: “Truss Rigging Points” 
refer to Rigging Point symbols that are available for insertion from 
the Symbol section of the Library Browser.
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A rigging point that is drawn in CAD have more capabilities than a 
Truss Rigging Point symbol that was inserted from the Library Browser. 
WYSIWYG will automatically replace inserted Truss Rigging Point 
symbols with drawn Rigging Point objects whenever a file is loaded or 
merged. Any shortcuts to Truss Rigging Point symbols will be 
removed when a file is loaded or merged.

 New plots update: The replacement of Truss Rigging Point symbols 
do not automatically update New Plots in the file. To remove the 
Truss Rigging Point symbols from New Plots, each New Plot must be 
updated using the Update New Plot command (right-click or use the 
Options menu). 
Drawn Rigging Point objects are standard CAD items which will 
appear in New Plots immediately.

 Rigging point reports: The “Rigging Points by Position” report on the 
Truss Rigging Point symbols will be replaced automatically when a file 
is loaded or merged. The new version will report on drawn Rigging 
Point objects.
The “Rigging Points List” report (which does not group Rigging Points 
by the Position column) will be added automatically if it does not 
already exist in the file.

 You can display the text of the Rigging Point object with a 
background in Wireframe views, Plots and Layouts if you enable the 
Show Label Background for Rigging Point text option in the General tab of 
the Document Options window. The label background will cover the 
parts of objects directly below the Rigging Point text. Clear this 
checkbox to display the text label of the Rigging Point without a 
background, and the parts of the object directly below the Rigging 
Point text will not be covered.
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To draw a rigging point

1 From the Draw menu, choose Rigging Point. 

Result: The New Rigging Point window appears.

2 In the New Rigging Point window, type the name for the new rigging 
point in the Name box.

3 In the Layer drop-down list, select which layer to insert the new 
rigging point.

4 Select the Show non-editable layers indicated by * checkbox to display 
the non-editable layers in the drop-down list.

5 In the Label Height box, type the size of the label name when 
displayed with the symbol.

6 In the Symbol Size box, type the size of the rigging point symbol.
7 Click the Symbol Type drop-down list and choose the type of rigging 

point to display. The options are Audio, Lighting, Scenic and Video.
8 Click the Show Coordinates drop-down list to choose the coordinates to 

display with the symbol or choose None to display no coordinates.
9 Click the Coordinate Format drop-down list and choose to display the 

coordinates in a Single Row or Multiple Rows.
10 Click the Position drop-down list to select a previously saved position, 

or click the ellipsis button to open Position Manager and create a new 
position.

 The Rigging Point button.
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11 In the Capacity box, type the maximum load which can be hung from 
the rigging point, and then select the unit (pounds “lbs” or kilograms 
“kg” or metric tons “t”) from the drop-down list beside it. 

12 In the Load box, type the actual load of the object that will hang from 
the rigging point. The unit that was selected for Capacity also applies 
to Load.

13 Click OK.
14 Click to place the new rigging point in the drawing. 

Tip: You may click Insert Multiple to insert multiple rigging points in 
succession.

Rigging point properties

After the Rigging Point object has been created, the properties of a 
rigging point object can be changed from the Properties window.

 Rigging Point: Properties that affect the type of symbol, how the 
symbol and coordinates are displayed.
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 Symbol Size: Type the new value to change the size of the rigging 
point symbol.

 Symbol Type: Click the drop-down list and select Audio or Lighting or 
Scenic or Video.

 Align to View: Select this checkbox to line up the rigging point 
object and label with the screen frame regardless of the selected 
View Type. Clear this checkbox to align the selected rigging point 
object to follow the selected View Type.

 Bridle: Select this checkbox to indicate and display the rigging point 
object with a bridle sling symbol.

Name
 Name: Type a new text to change the name of the selected rigging 

point.
 Height: Type a new value to change the size of the label name.
 Show Name: Select this checkbox to display the rigging point with 

the label name. Clear this checkbox to display the rigging point 
without a label name.

 Text Justification: Specify how the label name aligns.
 Click the Horizontal drop-down list and select the horizontal 

alignment of the label name. 

 Click the Vertical drop-down list and select vertical alignment of 
the label name.

Location
 Type the new values for X, Y and Z to change the position of the 

selected rigging point object.
 Show Coordinates: Click the drop-down list to change the 

coordinates to display or choose not to display the 
coordinates.

 Coordinate Format: Click the drop-down list and choose to 
display the coordinates in a Single Row or Multiple Rows.

 Height: Type a new value to change the size of the coordinates 
label text.

 Text Justification: Specify how the coordinates align.
 Click the Horizontal drop-down list and select the horizontal 

alignment of the coordinates. 

 Click the Vertical drop-down list and select the vertical 
alignment of the coordinates.

Hatching
 Properties that affect the hatching style and color of the selected 

rigging point object.
 Type: Click the drop-down list and select to display the rigging 

point object with hatching Lines or with Solid Fill.
 Use Rigging Point Color: Select this checkbox to enable the color 

box and select a custom hatching color for the rigging point 
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object. Clear this checkbox to use the Layer color for the 
Rigging Point.

 Position Name: Click the drop-down list and select a different saved 
position or click on the ellipsis button to open Position Manager and 
create a new position.

 Load: Properties that affect how to indicate the weight load and 
capacity of the selected rigging point.
 Capacity: Type a new value to change the maximum load which can 

be hung from the rigging point, and then select the unit (pounds 
“lbs” or kilograms “kg” or metric tons “t”) from the drop-down list 
box beside it.

 Load: Type a new value to change the actual load that will hang 
from the rigging point. The unit that was selected for Capacity also 
applies to Load.

 Height: Type a new value to change the size of the Load label text.
 Text Justification: Specify how the maximum load text aligns.

 Click the Horizontal drop-down list and select the horizontal 
alignment of the maximum load text. 

 Click the Vertical drop-down list and select the vertical 
alignment of the maximum load text.

 Show Capacity: Select this checkbox to display the maximum load 
capacity of the rigging point object.

 Show Load: Select this checkbox to display the actual load that will 
hang from the rigging point.

 Font: Properties that affect the font of the displayed text.
 Use Document Defaults: Select this checkbox to reference the font 

settings applied on the Wireframe Details tab in Document Options. 
Clear the checkbox to make specific changes to the font of the 
selected rigging point.

 Font: This option is enabled when Use Document Defaults is cleared. 
Click the Font drop-down list and select a different font for the 
label, and then select the check boxes to specify Bold, Italics and 
Underline.

 Notes: In the text box, type additional information about the selected 
rigging point.

 Show in Shaded View: Select this checkbox to display the selected 
rigging point object in Shaded View.

Exporting rigging points as DWG/DXF

Rigging points export to 3D DWG/DXF files from WYSIWYG. When 
exported, a Block is created for each type of Rigging Point symbol in the 
WYSIWYG file. Each Rigging Point is represented by a Block Reference 
(insertion).
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When a DWG/DXF file is re-imported, WYSIWYG automatically interprets 
all Block References for the Blocks as Rigging Point objects. The name, 
symbol type, symbol size, and other properties of the previously 
exported Rigging Point will be set correctly for the Rigging Point objects 
in WYSIWYG.

To export rigging points to 3D DWG/DXF

See “Exporting DWG/DXF files”.
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Hanging and focusing fixtures

Introduction

Fixtures are objects on the plot and appear in 3D in shaded views. When 
you insert a fixture into the plot, automated fixtures can be hung from a 
hang structure or inserted on the floor. Conventional fixtures must be 
hung from a hang structure. WYSIWYG has an extensive library of 
fixtures to choose from. 

Inserting fixtures into your drawing is as easy as pointing and clicking. 
You can insert individual fixtures directly from the Library Browser, or you 
can create shortcuts to your favorite fixtures. 

To quickly hang multiple fixtures on a pipe or straight truss 
simultaneously, you can use the array feature; to arrange multiple 
fixtures along a pipe/truss, use the distribute tool. For details, see 
“Hanging multiple fixtures” and “Distributing fixtures”.

Inserting fixtures

Note: When inserting fixtures on a truss or pipe, the tooltip will be red 
when it does not detect the cursor is over a hang structure. The tooltip 
will switch to green when the cursor is over a hang structure and can by 
hung.

To hang fixtures

Use this procedure to hang fixtures one by one on lengths of pipe or 
truss. To hang multiple fixtures simultaneously, use the Array feature. 
For details, see “To hang multiple fixtures”. After hanging the fixtures, 
you can arrange them simultaneously on pipes/truss by using the 
distribute feature. For details, see “Distributing fixtures”.

1 From the Library menu, choose Browse Library. Alternately, click the 
Fixture icon on the Draw toolbar.

2 Click the Fixtures tool at the bottom of the browser. 

3 In the menu that is now visible, double-click Manufacturer to select 
fixtures by manufacturer name, Type to select by fixture type, or All 
to see all the fixtures in alphabetical order.
Note: Alternately, you can use the Library Browser’s Search function 
to locate the fixture that you want to insert. Simply type the name of 
the fixture (or a partial name) in the Search box at the top of the 

 The Fixtures button.
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Library Browser, and then click the Search icon. For details, see “The 
Library Browser”.

4 Double-click on the name of the fixture that you want to insert. 
Result: A fixture with default settings for this type attaches to the 
cursor.

Note: You can change the fixture frame size using the Add Accessory 
option. For more information on adding accessories, refer to “To 
insert an accessory”.

5 To change the properties of the fixture before inserting, right-click on 
the fixture name, and then click Properties. 
Result: A dialog box opens with a shaded view of the fixture on the 
left and an image of its symbol on the right. Use the Photometrics tab 
to change the lamp and lens settings for the fixture, if applicable. For 
more information on the Photometrics tab, refer to “Photometrics tab”. 
Click Insert and the dialog box will close.

6 Select how you want the fixture to be hung on the structure, either 
the top or bottom. To change the hang position use CTRL + Mouse 
Wheel scroll to alternate between options, or you can use the 
keyboard by pressing key 1 for Position 1, and key 2 for Position 2.

7 Move the mouse over a hang structure, and then click to place the 
fixture. Continue placing this type of fixture by clicking on the other 
hang structures as desired.

8 Finish placing this fixture type by right-clicking, and then choosing 
Finish placing fixtures from the resulting menu. 

9 To place other fixture types, repeat the above steps for each type.

To insert fixtures on the floor

Use this procedure to insert automated fixtures one by one on the floor, 
without first attaching them to a pipe or truss. Fixtures inserted this way 
support CAD operations e.g., copy/paste, move, and rotate.

Note: Only automated fixtures can be inserted on the floor.

1 From the Library menu, choose Browse Library. Alternately, click the 
Fixture icon on the Draw toolbar.

2 Click the Fixtures tool at the bottom of the browser. 

3 In the menu that is now visible, double-click Manufacturer to select 
fixtures by manufacturer name, Type to select by fixture type, or All 
to see all the fixtures in alphabetical order.
Note: Alternately, you can use the Library Browser’s Search function 
to locate the fixture that you want to insert. Simply type the name of 
the fixture (or a partial name) in the Search box at the top of the 

 The Fixtures button.
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Library Browser, and then click the Search icon. For details, see “The 
Library Browser”.

4 Right-click on the name of the fixture that you want to insert. In the 
menu that appears, select Insert on Floor. 

5 Move the mouse anywhere in the plot, and then click to place the 
fixture. Continue placing this type of fixture by clicking as desired.

6 Finish placing this fixture type by right-clicking, and then choosing 
Finish placing fixtures from the resulting menu. 

7 To place other fixture types, repeat the above steps for each type.

Hanging multiple fixtures

Once you hang a single fixture, you can use the Array feature to instantly 
copy and paste multiple copies of it along the length of a pipe or straight 
piece of truss in the direction that you specify. This feature enables you 
to hang up to 100 fixtures quickly and precisely.

To hang multiple fixtures

1 On a pipe or a straight length of truss, hang the fixture of your choice 
by following the procedure in the section “To hang fixtures”.

Note: To hang fixtures along the length of truss or pipe, hang the 
first fixture at one end of the pipe/truss and then set the direction in 
which you want to copy and paste it. 

2 Click the fixture to select it, and then right-click and choose Tools > 
Array > Along Pipe. 
Result: An arrow attaches to your cursor when you hover over the 
pipe/truss.

3 Click on the pipe/truss to set the direction in which the fixture will be 
arrayed, either to the left or right of the fixture.
Result: The Array Along Pipe dialog box appears.

4 The Length box in the Array Along Pipe dialog box displays the distance 
from the selected fixture to the destination position of the first copied 
fixture in the array as indicated by the arrow and cursor. This value is 
not editable.

5 Choose between Interval or Total Distance.
6 In the Number of row box, type the number of fixtures you want to 

array along the pipe.
7 If you chose Interval, type the distance length between the selected 

fixture and the next fixture in the array. If you chose Total Distance, 
type the total sum of the distance lengths for all the intervals 
between all the fixtures in the array.

8 Click OK.
Result: The fixtures are placed along the pipe/truss.
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Selecting fixtures

You can use the Select feature to select all the fixtures in your plot, only 
certain types of fixtures, or only the fixtures on a certain hang structure. 
These features can also be accessed from the Fixture Selection toolbar. See 
“Using the fixture selection toolbar”.

This tool is most useful when all fixtures of one type need to be replaced 
with fixtures of another type.

To select all fixtures

1 In your plot, right-click and choose Select Fixtures By Type > Select All 
Fixtures.

Result: All fixtures are selected.

To select all fixtures of a particular type

1 Click to select the fixture that you want to select.

2 Right-click and choose Select Fixtures By Type > <CHOOSE FIXTURE 
NAME>.
Result: All fixtures of that type are selected.

To select a certain type of fixture on a particular type of 
hang structure

1 Click to select the hang structure containing the fixture that you want 
to select.

2 Right-click and choose Select Fixtures By Type > Select on Selected 
Pipe/Truss and then choose the type of fixture that you want to 
select.
Result: All fixtures of the specified type are selected on the chosen 
type of hang structure.

To select all fixtures on a particular hang structure

1 Click to select the hang structure containing the fixtures that you 
want to select.

2 Right-click and choose Select Fixtures By Type > Select on Selected 
Pipe/Truss > Select All.
Result: 

 All fixtures are selected on the chosen type of hang structure.

 All fixtures patched to the specified channel will be highlighted.
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To select all fixtures in a position name created for a hang 
structure

1 Click to select the position name in the hang structure containing the 
fixtures that you want to select.

2 Right-click and choose Select Fixtures By Position > Selected Pipe/
Truss.
Result: 

 All fixtures in the chosen position name are selected.

 All fixtures patched to the specified channel will be highlighted.

To select all fixtures in all the unassigned positions in the 
hang structure

1 Click to select all the hang structures containing the fixtures that you 
want to select.

2 Right-click and choose Select Fixtures By Position > All Unassigned 
Pipes/Trusses.
Result: 

 All fixtures in all the unassigned hang structure positions are 
selected.

 All fixtures patched to the specified channel will be highlighted.

Invert fixture selection

This feature is helpful if you want to cancel the selection of all currently 
selected fixtures, and consequently select all the other fixtures that were 
not selected before.

To use invert fixture selection

Press CTRL+SHIFT+I to activate invert selection to deselect only all the 
fixtures currently selected, and consequently select all the other fixtures 
that were previously not selected.

Note: Invert fixture selection is also available in Design and Live mode. 
See “Using the design tools”.

Distributing fixtures

You can use the Distribute feature to quickly arrange multiple fixtures 
evenly over a pipe or piece of straight truss starting at a specific point. 

You can distribute selected fixtures in three ways:

 Between two points that you choose on the pipe/truss.
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 In a specific direction from one point that you choose on the pipe/
truss.

 Centered around a specific point that you choose on the pipe/truss.

To distribute fixtures between two points

Note: Since you cannot mount fixtures directly on the end point of truss, 
before you distribute fixtures between two points, ensure that Endpoints 
snap is disabled.

Use this procedure to select two points on a pipe or length of straight 
truss and have WYSIWYG distribute selected fixtures evenly between 
those points. The spacing is determined by dividing the selected region of 
the pipe/truss by the number of fixtures selected.

1 Click to select the fixtures that you want to distribute on the pipe/
truss (to select multiple fixtures, press CTRL and then click on each 
one).

2 From the Tools menu click Distribute Fixtures > Between Two Points.
3 Click to set the two points on the pipe/truss. 

Result: The selected lights are evenly spaced between the two 
points.

To distribute fixtures in a direction

Use this procedure to select a point on a pipe or length of straight truss 
and have WYSIWYG distribute selected fixtures along the remaining 
length of the pipe/truss in the direction that you choose, spaced 
according to your specifications. 

1 Click to select the fixtures that you want to distribute on the pipe/
truss (to select multiple fixtures, press CTRL and then click on each 
one).

2 From the Tools menu click Distribute Fixtures > In a Direction.
3 Click to set the starting point on the pipe/truss from which you want 

to distribute the selected fixtures. 
4 Click on one side of the point (either to the left or right of it) to 

choose the direction in which the fixtures will be distributed.
Result: The Distribute - In a Direction window appears.

5 Type the desired distance between each fixture, and then press OK. 
Note: The value that you type must allow the selected number of 
fixtures to be evenly distributed over the remaining length of the 
pipe/truss. 
Result: The selected lights are evenly spaced between the two 
points.
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To distribute fixtures around a central point

In this procedure you choose a point on the pipe/truss and then 
distribute selected fixtures along the pipe/truss, using this point as the 
center. You specify the spacing of the fixtures.

1 Click to select the fixtures that you want to distribute on the pipe/
truss (to select multiple fixtures, press CTRL and then click on each 
one).

2 From the Tools menu click Distribute Fixtures > Center.
3 Click on the pipe/truss to set the point around which the selected 

fixtures will be centered. 
Result: The Distribute - Center window appears.

4 Type the desired distance between each fixture, and then press OK. 
Note: The value that you type must allow the selected number of 
fixtures to be evenly distributed over the length of the pipe/truss 
around the point that you have specified. 
Result: The selected lights are evenly spaced around the point.

Replacing fixtures

When the fixture requirements for a show change, instead of deleting 
and re-hanging fixtures, you can use the Replace Fixture function to 
quickly and easily replace one or more fixtures with another.

To replace fixtures

1 Select the fixtures that you want to replace using one of the selection 
methods described in “Selecting fixtures”.

2 Right-click and choose Replace Fixture.
3 Select the new type of fixture from the Fixture Selection dialog box.
4 Click Insert.

Result: All the fixtures that you selected in step 1 are replaced with 
the fixture type chosen in step 3. Some fixture attributes may be 
modified as a result of the replacement.

Custom fixtures

To create a custom fixture

You must create custom fixtures on the WYSIWYG welcome screen with 
all files closed. If you are currently working on a document, save and 
close it.
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Note: You do not have to complete all fields. Fill in as much information 
as you can. You cannot edit custom fixtures once saved, but you can 
delete them and create them from scratch with new properties.

1 On the WYSIWYG welcome screen, from the Options menu, choose 
Create new conventional.

Result: The Fixture Wizard opens.

2 Select the type of fixture that you want to create.
3 In the Name box, type a name for the new fixture.
4 Click Next.
5 From the Type drop-down list, select the circuit type. The default, 

REGDIM, is a regular dimmer.
6 Click Next.
7 Add or modify the path.

Note: The path is the location in the library where the fixture will be 
stored. A fixture assigned to the path “Custom/Fresnels” would be 
available in the custom section of the Fixture library in a sub-
category named FRESNELS.

8 Click Next.
9 Select the lamp base and default lamp for this fixture.
10 Click Next.
11 Specify the lens system for the fixture.
12 Click Next.
13 Type a value in degrees for the beam angle for this fixture.
14 Type a value in degrees for the field angle for this fixture.
15 Click Next.
16 Select the color frame slot size.
17 Click Next.
18 From the symbol library, select a 2D symbol for this fixture.
19 Click Next.
20 From the shape library, select a 3D symbol for this fixture.

Note: A 10” parcan is shown beside the selected shape in the 
viewing pane to offer a relative size measurement.

21 Click Next.
22 Type the manufacturer, weight, and any other information.
23 Click Next.
24 Type your name
25 Click Finish.
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To delete custom fixtures

If you do not want to keep a custom fixture any longer, you can delete it 
from the library browser. 

Notes: 

 You cannot delete a custom fixture if it is currently inserted in your 
plot; instead, you must delete the item from your plot, save and 
close the file. When you reopen the file you can delete the item from 
the library browser.

 When you delete a custom fixture, you do not delete the shortcut 
associated with it. You must delete shortcuts manually.

1 In the Library Browser, navigate to the folder where you stored the 
custom fixture. 

2 Highlight the fixture name, and then right-click and choose Delete.
Note: This option is disabled if the item is currently inserted in your 
plot. You must delete the item from your plot, and then save and 
close the file. When you reopen the file you can delete the item from 
the library browser.

3 A message box appears telling you the action is irreversible. Click Yes 
to delete the fixture.

Pipe snap

Pipe Snap places fixtures on a pipe at a specific interval. Pipe Snap does 
not work for truss or other hang structures. It allows you to specify a 
pre-determined distance between fixtures. 

As with all snap functions (refer to for more information about snap 
tools), you can select Pipe Snap in mid-command or as a running snap 
type.

To select Pipe snap as a running snap type

Enable Pipe Snap before inserting fixtures to hang fixtures equidistantly.

To select Pipe snap mid-command

Enable Pipe Snap after inserting the first fixture to enforce the interval 
selectively. Pipe Snap will disengage after you place the next fixture.

To use pipe snap

1 From the Tools menu, choose Snap, and then choose Pipe.

Tip: You can also click the Pipe Snap tool on the CAD Options toolbar. 

 The Pipe Snap button.
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2 Insert fixtures as described above. With pipe snap active, the fixtures 
are automatically hung at the pre-defined interval.

To set the snap interval

1 From the Options menu, choose Document Options.

Result: The Document Options window appears.

2 Click the Hang Structure Settings tab.
3 To set the snap interval, type the new value in the Snap Interval field.
4 Click OK.

To set an interval for a specific pipe

1 Right-click the pipe.

2 Click Properties.
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3 Click the Hang Structure tab. 

4 Click to clear the Use Document Defaults checkbox.
5 Select the Snap checkbox.
6 In the Interval box, type a new distance. This is the measurement 

between fixture insertion points.
7 Click OK.

Moving fixtures

You can move one or more fixtures along pipes and straight truss. (Not 
curved truss.) See “Moving” for basic information on moving objects.

 If the fixtures you want to move are all on the same hang structure, 
line markers will appear to display where the fixtures will be 
positioned after the move is completed.

 If the fixtures you want to move are selected from different hang 
structures, line markers will not be displayed and this move will be 
complete only if the fixture can slide across the specified distance 
while still positioned in the hang structure.

 To move the fixtures by exact distance, use the @ operator and a 
positive or negative direction along the hang structure.
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To move fixtures along pipes and straight truss

1 Select the fixture(s) you want to move.

2 From the Edit menu, choose Move Fixtures.
Tip: You may also choose the Move button from the Edit menu or the 
Move button from the Tools toolbar.
Result: If multiple fixtures are selected, line markers will appear to 
display where the fixtures will be positioned.

3 Click on the plot, to set the destination point.
Tip: You may also type @, and a positive or negative move distance 
value along the hang structure, and then press ENTER (e.g. @5 or 
@-5).

Nudging fixtures

You can nudge one or more fixtures along a pipe, straight truss or on the 
floor. (Not curved truss.) See “Nudging” for basic information on nudging 
objects.

Note: The nudge distance is the Snap Interval value defined in the 
Document Options > Hang Structure Settings tab. See “Hang Structure 
Settings tab”.

To nudge fixtures along a pipe or straight truss

1 Select the fixture(s) you want to nudge.

2 Press and hold the ALT key on your keyboard, and then press the 
ARROW keys on your keyboard to nudge the fixture towards the 
desired direction.
Tip: You may also nudge fixture(s) by half the Snap Interval distance 
by pressing and holding SHIFT and ALT, and then pressing the 
ARROW keys.

Grouping fixtures

You can group fixtures and create Fixture Group shortcuts in the Fixture 
Groups shortcut bar in CAD, Data, Design, and Live modes. You can also 
refer to the section “Fixture groups” in Design mode.

Notes: 

 If ONLY fixtures are selected, either CTRL+G or CTRL+J will create a 
Fixture Group.

 If fixtures AND more than one other object is selected, CTRL+G will 
create a normal “Objects Group” from the selected objects (the same 
if there were no fixtures in the selection), while CTRL+J will create a 
Fixture Group (the same as if CTRL+G was used with only fixtures 
selected).
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To create a Fixture Group manually

1 Select the fixtures you want to group and select with a shortcut.

2 On the shortcut bar, click Fixture Groups.
3 Right-click on the open space on the Fixture Groups shortcut bar, and 

choose New Fixture Group from the pop-up menu, or you can use 
CTRL+J.

4 Type a name for the new fixture group in the dialog box.
5 Click OK.

Result: The shortcut of the new fixture group is created on the 
Fixture Groups shortcut bar which can be used to select the fixtures in 
the group.

Note: The order of the selection during the fixture group creation is 
remembered, and will be applied when performing certain fixture 
operations, such as Fanning.

To create a Fixture Group automatically

1 Select all the fixtures in your drawing, or only the ones you wish to 
create automatic fixture groups.

2 On the shortcut bar, click Fixture Groups.
3 Right-click on the open space on the Fixture Groups shortcut bar, and 

choose Auto-Create Fixture Groups from the pop-up menu.
Result: Identical fixtures will be grouped together automatically and 
the corresponding shortcuts are created in the shortcuts bar. The 
shortcut icons are displayed with the name of the fixture model and 
the total number of fixtures in each group.

To add fixtures to an existing Fixture Group

1 On the Fixture Groups shortcut bar, click on a Fixture Group to select 
the fixtures in the group.

2 Press and hold CTRL and click on the fixtures that you wish to add to 
the selected Fixture Group.

3 Right-click on the selected Fixture Group on the Fixture Groups 
shortcut bar.

4 Select Update from the pop-up menu.
Result: The selected fixtures will be added to the Fixture Group.
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To remove fixtures from an existing Fixture Group

1 On the Fixture Groups shortcut bar, click on a Fixture Group to select 
the fixtures in the group.

2 Press and hold CTRL and click on the fixtures you want to remove 
from the selected Fixture Group.

3 Right-click on the selected Fixture Group on the Fixture Groups 
shortcut bar.

4 Select Update from the pop-up menu.
Result: The selected fixtures will be removed from the Fixture 
Group.

Focusing fixtures

You can focus the fixtures in your plot in multiple ways: 

 You can click and drag the beam of a selected fixture. 
 You can type the pan, tilt, and spin values for the fixture in its 

Properties box. 
 You can assign a focus position or focus object to the fixture.
 You can use the Fanning Tool feature to focus conventional fixtures 

in CAD mode (you can use this feature to focus automated lighting in 
Design mode)

To focus using click and drag

1 Ensure that the Toggle Beam Dragging option is enabled on the CAD 
Options toolbar. 

2 Select the fixture that you want to focus. 
Result: The fixture’s beam appears.

3 Click on the beam and drag it to its new position. When you are 
done, release the mouse button.
Tips: 
 You can also right-click the fixture, and then click Focus to drag 

the beam without having to hold the mouse button down 
continuously. Click to finish when the beam is focused where you 
want it.

 Use the missing focus coordinate to set a value on the inactive 
axis.

Drawing focus positions

Focus positions are: 

 The Toggle Beam Dragging button.
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 Points at which fixtures can be focused. 
 Objects in the drawing.

To insert a focus position

1 From the Draw menu, choose Focus Position. 

Tip: You can also click the Focus Position tool on the Draw toolbar to 
place focus positions. 

2 Type a label for the focus position.
3 Move the mouse so that the intersection of the crosshairs is placed 

where you want the focus position. 
4 Click to insert the focus position.
5 Repeat these steps to insert all focus positions.

Focus position properties

Options on the Focus Position tab affect the alignment and style of the 
selected focus position.

 The Focus Position button.
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You can modify the justification, height, and presentation of a focus 
position. For a description of the justification and presentation-type 
properties, refer to the “Text label tab”.

Focus positions are unique in that you can adjust the focus position 
coordinates without actually moving the focus position on the drawing. 
The X,Y, and Z coordinate is the coordinate of the location in 3D space 
where the focus position is to lie. 

Focus objects

Focus Objects allow you to draw an object, either a line or an arc, like 
you would a Focus Point. Selected fixtures can then be assigned directly 
to the drawn object. If you move or resize the object, the fixtures 
assigned to the object move along with your Focus Object. Focus Objects 
have many of the same properties of a Focus Point, but have 
considerably more functionality.

Note: Conventional fixtures can be assigned to Focus Objects in CAD 
mode; moving head units can be assigned to those same Focus Objects 
in DESIGN mode.

Linking fixtures to Focus Objects
When you draw a Focus Object, you can assign several pairs of fixtures 
to that object as you would like, and the fixtures will be organized in one 
of two ways, either using Spread Focus or Focus to Vertices. 

The Spread Focus function available is available to both focus lines and 
focus arcs. Spread Focus is where the object divides itself up based on 
the fixture “sets” that you select, and distributes the fixtures at even 
intervals along the object in the order selected. 
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Focus to Vertices is only available to focus lines. When using Focus to 
Vertices, the focus line is drawn with multiple segments separated by a 
vertices. When fixtures are assigned to the focus line, a single fixture will 
be focus to each vertex in the line in the order selected. The maximum 
number of fixtures that can be assigned is limited to the number of 
vertices in the focus line.
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Breaking the fixture links to Focus Objects
Once a group of fixtures is assigned to a Focus Object, they are 
essentially “linked” to that Focus Object until otherwise refocused. If you 
have a group of fixtures assigned to a Focus Object and you refocus or 
move one of them, any of the other fixtures will remain in the position 
they were focused, but their link will be removed from the group of 
fixtures and the Focus Object, as you would expect.

Focus Objects - Point naming
Keep in mind that since you can assign different sets of fixtures to the 
same object, the same point can be used for two different fixtures. In 
Spreadsheets and Reports (and CAD), the position points in the Focus 
column are indicated as "<name> - 1 of 3", "<name> - 4 of 5,” and so 
on (where one set has 3 fixtures and the other set has 5 fixtures). In this 
case, “1 of 3" and “1 of 5" would be the same point, as would “2 of 3" 
and “3 of 5", as would “3 of 3" and “5 of 5".

Assigning fixtures to Focus Objects
Creating Focus Objects and assigning fixtures to them is as easy as 
selecting the fixtures, selecting the Focus Object, and applying a key 
shortcut.

To assign conventional fixtures to a Focus Line in CAD mode

1 Draw a Focus Line by clicking Draw > Focus Line.

Result: The New Focus Line window appears.

2 Type a name for the new focus line.
3 Select the layer on which you want to draw the focus line.
4 Select the focus type.
5 Click OK.
6 Draw your focus line where you like.
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7 Select your fixtures in the order in which you would like to focus 
them.

8 While keeping the fixture selection you just created, also select the 
focus line to which you want to assign conventional fixtures in CAD 
mode.

9 Use the keyboard shortcut CTRL+SHIFT+F to assign the fixtures to 
the focus line.

To assign conventional fixtures to a Focus Arc in CAD mode

1 Draw a Focus Arc by clicking Draw > Focus Arc.

Result: The New Focus Arc window appears.

2 Type a name for the new focus arc.
3 Select the layer on which you want to draw the focus arc.
4 To drawn the focus arc free hand, click Interactive. To pre-construct 

the focus arc, enter in the radius, start angle and end angle details, 
then click OK.

5 Place your focus arc where you like.
6 Select your fixtures in the order in which you would like to focus 

them.
7 While keeping the fixture selection you just created, also select the 

focus arc to which you want to assign conventional fixtures in CAD 
mode.

8 Use the keyboard shortcut CTRL+SHIFT+F to assign the fixtures to 
the focus arc.
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Quick focus

Quick focus assigns a focus position or Pan and Tilt angle to the selected 
fixture.

To assign a focus position

1 From the Tools menu, choose Quick Focus.

Tip: You can also click the Quick Focus tool on the Tools toolbar. 

2 Click on the desired focus position. This will set that position as the 
destination for the next fixtures you select.

3 Click on each fixture that you want focused to that position or focus 
object.

4 Right-click anywhere in the Wireframe view, and then choose Finish 
Quick Focus.

To assign a pan and tilt angle

Note: For more information on Quick Tools, see “Quick fixture tools”.

1 From the Tools menu, choose Quick Tools.

2 In the dialog box that opens, check Focus.
3 Type values in degrees for Pan and Tilt.
4 Click OK.
5 Click on each fixture you want oriented to the specified angle.
6 Right-click anywhere in the Wireframe view, and then choose Finish 

Quick Tools.

To focus from the fixture’s properties

1 Select the fixtures that you want to focus.

2 Right-click and choose Properties.
3 Click the Fixture tab.
4 Type values in degrees for Pan, Tilt, and Spin, or select a focus 

position from the drop-down list.
Note: For the definitions of these attributes, please refer to “Data 
fields”.

5 Click OK.

 The Quick Focus button.
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Using the fanning tool feature in CAD mode

The Fanning Tool makes your aerial focuses and any other fan-like focus 
quick and easy, enabling you to select a group of fixtures, tilt and pan 
them as a group, and then spread the focus out with a simple wheel. This 
action can be performed in CAD mode (for conventionals) and Design 
mode (for moving heads).

To focus conventional fixtures using the Fanning Tool

1 Right-click on the toolbar area and select the Fanning Designer Tool 
menu to open Fanning Tool.

Result: The Fanning Tool window appears.

2 Select a group of fixtures by drag-selecting or control-clicking in 
either Wireframe or Shaded view (in DESIGN mode, this is part of 
the Focus Designer tool).

3 Use the Pan/Tilt wheel to move all of your fixtures together in order to 
be able to do a PAN fan; TILT fanning can be done without panning.

To use the interpolate feature with the Fanning Tool

Note: Interpolation (or auto-arranging fixtures) only works on 
conventional fixtures in CAD mode.

In CAD Mode only, you have the option of using the Interpolate buttons 
too, which allow for a different type of Fanning Tool operation. 

 The Fanning button.
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1 Select a group of fixtures by drag-selecting or control-clicking in 
either Wireframe or Shaded view (in DESIGN mode, this is part of 
the Focus Designer Tool).

2 Take the first fixture and the last fixture in your selection and move 
them where you would like them as the first and last units in your 
fan.

3 When you click the Interpolate button for Pan and Tilt, the internal 
fixtures of your selection between the first and last will interpolate 
(or auto-arrange) themselves between those first and last units. 
Interpolate Pan will arrange the focuses of the internal fixtures’ pan 
values; Interpolate Tilt will arrange the tilt values between the 
selection.

Fixture-specific focusing tools

All fixture-specific focusing tools such as shuttering, spotting/flooding, 
lens changes, and footprints are available through the selected fixture’s 
properties on the Shutter, Lens, and Fixture pages respectively.

To make shutter cuts

1 Select the fixtures for which you want to make shutter cuts.

2 Right-click and choose Properties or simply open the Shutter Cuts 
window.

3 Click the Fixture tab.
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4 Click the Cuts tab.
Note: The POV image is not available when a fixture is zoomable or 
articulable.

5 Use the sliders along the top, bottom, and the sides to move the 
shutter blades.
Result: The cuts that you make are visible in the drawing. 

Note: Click the small “lock” icon to lock a blade before or after 
moving one of its "ends." Once locked, the blades can be moved in or 
out from both "ends"/"sides" at the same time. If a blade is locked 
after moving only one of its "ends"/"sides", the blade will move in or 
out at an angle.

6 When applicable, use the Barrel Rotation slider to adjust the fixture's 
barrel orientation. You may also enter a barrel rotation angle or use 
the up/down arrow buttons to make these adjustments. 

7 Adjust the pan and tilt of the selected fixture(s) by typing the 
appropriate values in the boxes in degrees, or by using the up and 
down arrow buttons.

8 Click OK when finished.
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Note: If needed, click Reset Cuts to bring all the shutter cuts to the 
full-open position.
Tip: You can perform all of these steps with the Shutter Cuts tool, 
which is accessible from the Tools menu. The controls in this tool are 
identical to the ones described above in the Shutters tab; however, all 
changes made with the Shutter Cuts tool are applied instantly, 
without the need to click any other buttons.

To adjust the leaves of barndoors

1 Select the fixture with barndoors for which you want to adjust the 
leaves. 

2 Right-click and choose Properties.
3 Click the Fixture tab.
4 From the list on the left side, highlight the barndoor. 
5 Click the Barndoors tab. 

 

6 Use the sliders along the top, bottom, and sides to move the 
barndoor leaves. You will notice that the movement of the leaves is 
restricted to left, right, up, and down. 
Result: The cuts are visible in the drawing.
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7 Click OK when finished.

Using the Cuts and Adjustments tool
The Cuts and Adjustments Tool can handle a lot of Conventional changes 
dynamically, and gives you more controls for beam shaping. It is your 
one-stop tool for fixture beam shaping and edits.

Here’s an example of the Cuts and Adjustments Tool in use:

Note: When multiple fixtures of the same type, or multiple fixtures with 
the same barndoor/shutter accessories are selected, you can adjust the 
cuts of all of them at once. All the fixtures will share the same cut.
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Cuts and Adjustments tool properties

Shutters and Barrel Section
This section allows for shutter cuts on any fixture with shutters, as well 
as focusing the actual position of your fixture with accuracy. You can also 
quickly reset any and all of your shutter cuts, lock a blade on the Shutter 
mechanism, rotate your fixture’s barrel, and spin the fixture’s c-clamp on 
the lighting position.

Fresnels and PARnels Section
This section of the Cuts and Adjustments Tool is for fixtures with a Fresnel-
type lens or lamp train style body – the tool provides a slider for moving 
the lamp closer to the lens for wider angles and away from the lens for a 
tighter spot pool. You can also go Full Spot, Medium Flood, or Full Flood 
with the push of a button.

Note: When multiple fixtures of the same type are selected, you can 
adjust the Spot-Flood slider to change all the selected fixtures at the same 
time. 
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PAR Bottles Section
This section provides you with an easy access slider for rotating your PAR 
bottles. Quickly spin your PARs’ lamp bottles to get the angle you need 
and the coverage you want to achieve.

Note: When multiple fixtures of the same type are selected, you can 
adjust the rotation to change all the selected fixtures at the same time. 

Quick Adjust Section:
This section is copied from the Fixture Properties dialog box so that you 
can change a lamp or a lens quickly and across multiple fixtures. You can 
also spin your lamps and lenses and reassign Focus Positions to any 
conventional fixture on your plot with the Cuts and Adjustments Tool’s Quick 
Adjust section.

To open the Cuts and Adjustments tool

1 In Wireframe view, select the fixture that you want to adjust.

2 Click View > Cuts and Adjustments.
Result: The Cuts and Adjustments tool appears.

Manually adjust fixture attributes

To adjust flood or spot

1 Select the fixture(s) for which you want to adjust the flood or spot. 

2 Right-click and choose Properties.
3 Click the Fixture tab.
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4 Click the Lens tab.

5 Use the slider to adjust the spot and flood. 
6 Click OK when finished.

To change the bulb in a Par fixture

1 Select the PAR fixture that you want to focus. 

2 Right-click and choose Properties.
3 Click the Fixture tab.
4 From the Lamp drop-down list, select the lamp that you want to 

focus. 
5 In the Angle box for the lamp, type the rotation angle. The angle 

determines the degree of rotation of the lamp within the housing.
6 Click OK when finished.

Note: To focus Source 4 PAR fixtures, perform the same series of steps, 
except you must type a value in the Lens Angle box instead of the Lamp 
Angle. 
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To focus a footprint for a conventional fixture

Note: This feature is also available for automated fixtures (in Design 
mode through the Footprint Designer tool). For information, see “Focus 
tool”.

1 Select the conventional fixture.

2 Right-click and choose Properties.
3 Click the Fixture tab.

4 On the Beam Options tab, choose Enable Footprint Focus (Conventionals 
only).

5 Adjust the fixture’s minimum and maximum Focus Range in the Min 
and Max boxes.

6 Adjust the focus distance using the slider or by entering a value in 
the Focus Distance box.

7 Check Sync to Focus Position to adjust the footprint focus distance to 
the specified Focus Position.

8 Click OK when finished.
Result: The effect is visible in the Shaded view when Footprint Focus 
is enabled on the Simulation tab of the View Options window.
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To focus a footprint for a conventional fixture (interactive 
method)

Note: This feature is also available for automated fixtures (in Design 
mode through the Footprint Designer tool). For information, see “Focus 
tool”.

1 Select the conventional fixture.

2 Right-click and choose Footprint Focus. The fixture focus distance is 
represented by a yellow line in the CAD view.

3 Press the up and down arrows on your keyboard to adjust the focus 
distance.

4 When you are satisfied with the distance, right-click and select Finish 
Footprint Focus. To cancel your changes, right-click and select Abort 
Footprint Focus.
The effect is visible in the Shaded view when Footprint Focus is 
enabled on the Simulation tab of the View Options window.

Fixture properties

All fixtures in WYSIWYG have properties. Properties are the 
characteristics or attributes that shape and define a fixture. 

Fixture properties can be divided into two categories:

 Properties that are common to all fixtures in WYSIWYG.
 Properties that you define by assigning attributes to a fixture.
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Fixtures also have many non-visible attributes, some of which can be 
edited. These include Alias (found as Type in the reports), Cost, Weight, 
and AutoFocus codes.

General fixture properties
In WYSIWYG there are five tabs that appear in the properties dialog box 
for every fixture:

 Appearance
 Version
 Data
 Options
 Photometric 

Each tab is explained in this section. 

To view fixture properties that are common to all fixtures

1 From the Library menu, choose Browse Library. 

2 Click the Fixtures tool at the bottom of the browser. 

3 Browse to the desired fixture and click on it to select it.

 The Fixtures button.



Reference Guide 577

January 2019 CAD mode - Hang Structures and Lighting 

4 Right-click on the fixture name, and then click Properties. 
Tip: You can also click the Properties tool at the top of the Library 
Browser. 

Result: The properties window for the selected fixture appears, with 
a shaded view and an image of the fixture’s symbol displayed in the 
two boxes. An example is shown below: 

 

5 Click Plan, Side, or Front to view the fixture in the different views. The 
Wireframe view changes based on the view type that you select.

Version tab
Options on the Version tab are read-only and are set when the fixture is 
added to the library. 

 The Properties button.
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 Version: The release number of the fixture.
 Status: The status of the fixture. For example, Beta indicates that the 

fixture is completed but not verified. Release indicates the fixture has 
been tested and is accurate. A status of Preliminary indicates that the 
fixture has minimal functionality.

 Author: The individual or company who constructed the fixture.
 Notes: Any notes that pertain to the fixture. The notes usually pertain 

to the simulation capabilities in WYSIWYG.

Data tab
Options on the Data tab are read-only and are set when the fixture is 
added to the library. This does not, however, include the Alias, Weight, 
Cost, Manu, and Prod fields. To modify these fields, access the desired 
fixture’s properties from the Library Browser.
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 Manufacturer: The name of the manufacturer of the fixture. 
 Model: The model number of the fixture. 
 Alias: The alternate name for the fixture. 
 Weight: The weight of the fixture.
 Use default: Select this checkbox to use the default weight. 
 Cost: The cost of renting or purchasing the fixture. The cost of renting 

the fixture can be the price for a day, week, or month. The default 
value is 0.00.
Notes: 
 If a cost is assigned to a fixture type when a WYSIWYG document 

is open, the cost is applied to the current document only. 

 If a cost is applied to a fixture type when a document is not open, 
the cost is used as the default for all documents created on your 
copy of WYSIWYG. 

 When opening a document created by someone other than 
yourself, the cost entered in that person’s document is used. 

 The cost entered in this tab is displayed in WYSIWYG reports. For 
more information on the display of this data, refer to page “Data 
fields”.

 Catalog: The code that is used by the manufacturer to identify the 
fixture.

 Manu: The manufacturer’s code for those fixtures that are Autofocus-
compatible. Conventional fixtures do not have a manufacturer’s 
code. The default value is 0.
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 Prod: The product code for those fixtures that are Autofocus-
compatible. Conventional fixtures do not have a product code. The 
default value is 0.

 Use default: Select this checkbox to indicate that the default settings 
for Prod and Manu (0, 0) are to be used.

 URL: The internet address of the manufacturer.
 Open: If an internet address is shown, click this button to open the 

Web page of the manufacturer.

Options tab
The boxes on this tab indicate various options about the selected fixture, 
such as the number of channels and the available channels. Based on the 
fixture selected, the options shown on this tab vary. For example, if you 
choose a light like the Vari*Lite VL5, the options on the left side of the 
window affect those on the right side. In this case, based on the options 
that you select on the left side, the hookup for this fixture may differ.

 

 Mode: Select the mode in which you want to configure the fixture. 
This field is not applicable for certain fixtures.

 Dimmer: If applicable, select the type of dimmer for this fixture (for 
example, choose either Internal or External).

 Circuits: Indicates the type of DMX controls for this fixture (for 
example, Control, Intensity, RIntensity, Color, and so on).

 Number of Channels: Based on the circuit that you selected above (in 
addition to the options selected), this box indicates the number of 
channels for this fixture.

 Available Channels: The names of the channels available for this fixture 
(based on the circuit and options that you selected).
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Photometrics tab
Options on the Photometrics tab affect the lamp and lens settings for the 
fixture. 

 Lamp: Select the lamp to be used in the fixture. 
 Lens: If applicable, select the lens setting for the fixture. Changing 

the lens alters the photometric properties of the fixture.
 View: Select the graphical representation that you want to display in 

the box to the left. The choices are as follows:
 Beam vs. Field. Displays a graphical representation of the beam and 

field angles of the fixture. 
 Flood vs. Spot (Beam). Displays a graphical representation of the 

ratio between the flood and spot for the fixture’s beam angle.
 Flood vs. Spot (Field). Displays a graphical representation of the ratio 

between the flood and spot for the fixture’s field angle.
 Field: The measurement in degrees from the center of the beam to 

where the light level drops off to 10 percent of the peak. 
 Beam: The measurement in degrees from the center of the beam to 

where the light level drops off to 50 percent of the peak.

Quick fixture tools

Quick Tools allows you to quickly assign data, accessories and other 
important attributes to your lighting fixtures without having to switch 
back and forth between DATA mode or opening each fixture’s properties 
for each change. Quick Tools will enter in repetitive information, 
incrementing automatically if you choose, for all of your fixtures.
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The Quick Fixture Tool window allows you to expand or collapse each 
section of the Quick Fixture Tool as you see fit to improve your workflow 
and space.

Here is the Quick Fixture Tool completely collapsed:

Here is the Quick Fixture Tool completely expanded:
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Quick Fixture Tool Sections
When you enter data into the field associated with each value and click 
OK, a wireframe view appears, where you will click on the fixtures to 
which you would like to assign the changes you made in the tool.

Note: When your mouse is over a fixture using the Quick Tools Tool, the 
fixture will be highlighted to help indicate which fixture is selected. 
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Control Data section
This section allows you to assign repetitive values for Spot, Channel and 
Dimmer (and Auto Increment), DMX addresses per Universe with Auto 
Increment, and a Custom Increment Patch that allows you to assign 
addresses based solely on your custom increment and ignoring the 
logical patch increments. 

The Control Data section also allows you to assign repetitive Circuit 
Names and Numbers to your fixtures for any situation – an example of 
this would be labeling Socapex circuits on a touring lighting truss A-1 
through A-6. If the Multi-Cable option is enabled, Quick Tools will 
automatically increment the Circuit Name and reset the Circuit Number 
after every X fixture is placed, where X is the No. of Circuits selected. 

Descriptive notes can be created and added to fixtures. These notes are 
shown in the DATA > Spreadsheet for the selected fixtures. Fixture 
attribute layout templates can also be selected and applied to fixtures.

General Details section
This is where you can assign repetitive values for Unit numbers (with 
Auto Increment if desired) as well as Purpose and Focus (either by 
Position or by degrees).

Accessories Section
This section of the Quick Fixture Tools dialog box allows you to assign 
repetitive values for Color, Gobos, Lamps, Lens sets, and Other 
accessories as assigned.
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Using the Quick Fixture Tools panel

1 From the Tools menu, choose Quick Fixture Tools. When the Quick 
Fixture Tools dialog box opens, it defaults to the collapsed view. Click 
on the plus symbol next to each section to open it.

Tip: You can also click the Quick Tools tool on the Tools toolbar.

2 To activate a tool, select the checkbox to the left of the tool. You can 
activate as many as you want at a time. See below for explanations 
of the different tools.

3 Type the initial value for the tool in the box to the right of the tool 
name. If you want the value to auto increment, as for channels or 
spot numbers, make sure you select the Auto Increment checkbox. 
WYSIWYG will assign the next sequential number based on the 
properties and requirements of the previous fixture.
Note: When you patch a fixture in the Control Data section, the Custom 
Increment offers two options: Additional, where the increment is added 
at the end of each fixture patched; and Total, which is the total 
increment to the next fixture’s address).
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4 When the dialog box is set up the way you want it, click OK.
Result: The cursor will show a “Q”, indicating that Quick Tools have 
been activated. 

5 Click on each fixture in the order you want any auto-incrementing 
values to be assigned.
Note: The attributes to be assigned to the next fixture are logged in 
the bottom left hand corner of the Status bar.

6 When complete, right-click and choose Finish Quick Tools.
Tip: Use the Clear All button to reset all the values and cancel all 
quick tools.

Notes: 

 To change the values at any time, right-click and choose Change 
Options. 

 When typing values, type the exact value or use the [...] browse 
button to open a selection dialog box.

 The entry in the patch box must fulfill the requirements of patch 
notation which is universe.#. For more information regarding patch 
notation refer to “Reading the patch”.

 For more information about the data fields, refer to “Data fields”.
 When using the quick tools to insert a color or gobo, WYSIWYG 

automatically inserts a default color frame or gobo holder, which is 
already defined in the fixture. Remove the default frame and add a 
new one using Add Accessory. For information on adding accessories, 
refer to “To insert an accessory”.

 When you are applying a color to a multi-source fixture, a dialog box 
appears, listing the circuit names to which you can apply the Quick 
Tool color selection. To apply the same color to multiple circuits listed 
in this dialog box, press CTRL, and then select the desired circuits. 
Press Select when you are finished.

Fixture-specific properties
Customize the properties of a fixture by assigning specific attributes, 
such as point of view, patch information, and lens type.
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To edit/view fixture attributes

1 Select the fixture that you want to view or edit.

2 Right-click and select Properties.
Tip: At any time, to access an object’s properties, you can click the 
Properties tool on the Edit toolbar. 

Result: The Properties window appears. Based on the type of fixture 
that you have selected, the tab fields in the Properties window varies. 
An example is shown in the graphic below.

 Layer: A list of the layers in your document is displayed. Click on a 
list item to change the layer on which the fixture will be edited or 
viewed.

 Display with Layer Groups: By default, this checkbox is selected to 
show the list of layers within groups, and the Collapse All and Expand 
All buttons become active. Clear the checkbox to show only the list 
of layers.

 Collapse All: Click the Collapse All button to display only the Layer 
Groups.

 Expand All: Click the Expand All button to display the Layer Groups 
and all the Layers.

 The Properties button.
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 Use Layer Color: Select this checkbox to set the fixture’s color for 
Wireframe views to be identical with the properties of the layer on 
which the fixture resides. Clear this checkbox, and then use the 
color box to select a specific color for the fixture.

 Line Weight: From the drop-down list, choose the line weight for the 
selected fixture, which sets the thickness for the fixture symbol 
lines, defining how it will appear in all the Wireframe views and in 
the printed Layouts.

 Attach to Axis/Frame: From the drop-down list, select the motion axis 
to where you want to attach the selected fixture. 

 Hatching: Section for managing hatching effects only for closed 
objects. See “To add hatching to an object”.

 Fixture Symbol Fill: Section for managing fill options for fixture 
symbols.
 Use Document Defaults: By default this checkbox is selected to 

apply the fill settings that were set in Document Options. Refer 
to “Fixture Settings tab”. Clear this checkbox if you want to 
change the fill and color settings.

 Enable: Select this checkbox to change the fill settings of the 
selected fixture. 

    Select Percentage from the drop-down list if you wish to fill 
using the same hue of the Fixture Symbol, and set the 
percentage from the drop-down list for the hue intensity.

    Select Custom Color from the drop-down list and click the 
color box to choose a different color.

    Select Use Gel Color from the drop-down list if you wish to 
fill using the gel color that was attached to the fixture.

Fixture tab
Options on the Fixture tab affect the fixture properties and their 
accessories. On the left side of the dialog box is a list of the selected 
fixtures and their accessories. Click on a list item to obtain further details 
about the item. 
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General tab
Refer to “Data fields” for a description of the fields. 

 Edit Layout: Click to edit the text label layout for the selected fixture. 
For more information on layout refer to “Fixture label layout”.

 Clamp Type and Distance from Hang Structure: Click on the type of clamp 
from this drop-down list to set the distance of the fixture from the 
hang structure.
You may click Custom and then type the value on the adjacent box to 
set your preferred distance.
Note: By default, conventional fixtures are set with a C-clamp and 
moving fixtures are set with a Half-Cheeseborough.

Beam Options tab
Options on the Beam Options tab affect the beam and footprint settings for 
the selected fixture.
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 Beam Settings: Use these options to control the brightness of the 
fixture’s beam, footprint, or flare when turned on in Shaded View. 
The settings here will override the Shaded View > View Options 
settings.
 Source Disc: Use the slider to increase or decrease the brightness of 

the halo of light around a fixture's aperture.
 Intensity Multipliers: Use the sliders of these options to increase or 

decrease the brightness of the flare, beam and footprint. For 
example, to double the brightness of the beam, set the slider to 
2.0. 
 Flare: Increase or decrease the brightness of the lens flare for 

this fixture in Shaded View. The Source disc will still be visible.

 Beam: Increase or decrease the brightness of the beam cone 
for this fixture in Shaded View. Note: When you use the 
Render Wizard, the Beam value is used when rendering to the 
Renderer.

 Footprint: Increase or decrease the brightness of the beam 
footprint for this fixture in Shaded View.

 Lock Sliders: Select this checkbox to lock the Intensity 
Multiplier settings.
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 Reset to Default: Click to reset the Intensity Multipliers back to 
the default settings.

Note: All changes will be applied to all fixtures of this type in the file.
 Footprint Focus Settings: Use these options to control the 

footprint focus on conventional fixtures.
 Focus Range: Set the minimum (Min) and maximum (Max) focus 

distances for the fixture.
 Invert Focus in LIVE mode (Automated only): Check this option to invert 

the direction of Focus in LIVE mode.
 Enable Footprint Focus (Conventionals only): Check this option to 

control the footprint focus.
 Focus Distance: Set the focus distance for the fixture.
 Sync to Focus Position: Check this option to adjust the footprint focus 

distance to the specified Focus Position.
 Focus Lines: Check this option to display focus lines for the selected 

focus in Shaded Views.

Patch tab
Options on the Patch sub-tab affect the circuit, channels, and patch 
universe for the selected fixture. 
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 Control, Circuit, and Patch: Refer to “Data fields” for a description of 
these boxes. 

 Use EDMX address: Select this checkbox to use the EDMX address for 
the patch universe. This checkbox is enabled if you select EDMX from 
the Universe drop-down list. EDMX is an Ethernet protocol developed 
by ETC.

Shutters tab
For information on the Shutters tab, see “To make shutter cuts”.

Moving mirror/moving head tab
Options on the Moving Mirror and Moving Head sub-tabs affect the pan and 
tilt values. 

 Pan offset: Sets the manually adjustable pan angle.
 Tilt offset: Sets the manually adjustable tilt angle.
 Reverse Pan: Select this checkbox only if the real fixtures have an 

option to reverse the pan parameter and that option is set to true.
 Reverse Tilt: Select this checkbox only if the real fixtures have an 

option to reverse the tilt parameter and that option is set to true. 
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 Swap Axes: Select this checkbox only if the real fixtures have an 
option to swap the control channels for the tilt and pan and that 
option is set to true.

 Pan: (Only visible for certain fixtures.) Displays the manufacturer 
low, mid and high pan limit values for the fixture. To change a value, 
select it, click Change, and then type the new value.

 Tilt: (Only visible for certain fixtures.) Displays the manufacturer’s 
low, mid, and high tilt limit values for the fixture. To change a value, 
select it, click Change, and then type the new value.
Note: The Pan and Tilt limit behavior is defined by the Mode selected 
on the Options tab.

Display Source tab
Options on the Display Source sub-tab are used to add a video source to a 
Video Projection fixture, so that it can display a video source in the 
fixture's beam.

Select the Display Source. 

 To leave the screen blank, select Blank Screen.
 To show a static image on the screen, select Image File, and then click 

Browse to locate the graphic. (The image must be saved in either 
bitmap or JPEG format.)
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 To attach a video source to the screen, select Video Source, and then 
choose the video source from the drop-down list box (or click Create 
New to configure a new video source with the Video Manager). For 
details on creating a new video source, see “To configure a new video 
source for streaming video”. For details on creating an I-Mag camera 
screen, see “To create an I-Mag Camera in the Video Manager”.

Notes: 

 For details on patching the video control in Data mode, see “To patch 
the control of a video source”.

 For details on using the Video Designer tool to play the video in 
Design mode, see “To use the Video tool”.

 For details on using a console device to control the video in Live 
mode, see “To control a DMX patched video source with a console”.

Options tab
Options on this tab affect the mode selection for the fixtures. The options 
vary according to the fixture that you have selected.

 Mode: Sets the mode for the selected fixture. 
 Software: The software version that is loaded on the selected fixture.
 Slots: The mechanical components that are present in the selected 

fixture.
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 Control: Simulates the lamp control channel on the selected fixture. 
Since you can physically turn a fixture on or off, WYSIWYG enables 
this action in the software.

Note: Fixture options are displayed in the "Fixture Options" column in 
the DATA > Spreadsheet, and can also be displayed in PRES > Reports.

Control tab
Options on the Control tab enable you to set the channel, circuit, and 
patch universe information for the fixture.

 Control
 Channel: Type the channel number for the selected fixture.
 Dimmer: The dimmer number for the selected fixture.
 Use EDMX address: If checked, the EDMX address is used for the 

patch universe. This checkbox is enabled if either EDMX or 
Conventionals (for the DMX address) is selected from the Universe 
drop-down list. 

 Circuit
 Name: The circuit name for the selected fixture.
 Number: The circuit number for the selected fixture.

 Patch
 Universe: Select a patch universe for the fixture.
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 Address: The starting DMX channel number for the selected fixture.

Fixture notation

Fixture notation affects how fixtures and their properties are displayed on 
your drawing and consequently on your plot in Presentation mode. As 
illustrated below, two components comprise fixture notation: 

 symbol
 fixture label layout

Symbols

A symbol is a graphical representation of a fixture in a Wireframe view. 
In all wireframe views except isometric, symbols may be used to 
represent fixtures instead of three dimensional models. Fixtures are 
associated with specific symbols by default, but you can change the 
symbol to whatever you like. 

To turn fixture symbols on or off

1 From the Options menu, choose Document Options.

Result: The Document Options window appears.

2 Select the Wireframe Details tab.
3 Select the Show Symbols checkbox.
4 Click OK.

To change the symbol for a fixture type

The following procedure changes the symbol for all instances of the 
selected fixture type in the document. Similar procedures change the 
symbol at an application level.
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Notes: 

 To change fixtures at an application level, see ““To change the 
symbol for a fixture at the application level”” below.

 For fixtures with interchangeable lenses (or lamps in the case of 
PARs), you must change the symbol for the lamp or lens instead of 
the fixture. 

1 From the Library menu, choose Browse Library.

2 Select the Fixtures library.
3 Navigate through the library, and then select the fixture type for 

which you wish to change the symbol.
4 Click the Property tool.

Result: The properties dialog box for fixture type opens.

 When modifying the symbol for a specific fixture and lamp 
combination, use the Lamp drop-down list to select a specific 
Lamp for the fixture.

 When modifying the symbol for a specific fixture and lens 
combination, use the Lens drop-down list to select a specific Lens 
for the fixture.

5 Click Change Symbol.
Result: The symbol selection window appears.

6 Select the new symbol.
7 Click Select. 
8 Close the fixture property box.

To change the symbol for a fixture at the application level
Perform this procedure if you want to modify fixture symbols universally 
so that when you create new files, the symbols that you want are 
displayed for fixtures (instead of the default symbols).

1 Start WYSIWYG and from the welcome window, select Options > 
Browse Library.

2 Click the Fixtures tab.
3 Navigate through the library, and then select the fixture type for 

which you wish to change the symbol.
4 Right-click the Fixture name, and then select Properties. 

Result: The properties dialog box for fixture type opens.

5 Click the view that you want to change.
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6 Click Change Symbol.
Note: When the same symbol is used for two view types, the Change 
Symbol button is disabled for one of the view types. Click either of the 
other two view types to choose a new symbol. 
Result: The symbol selection window appears.

7 Select the new symbol, and then click Select. 
8 Close the fixture property box.

Notes: Your changes are stored in the file Default.ldb, which is stored in 
the WYSIWYG\Library folder (in the location where you installed 
WYSIWYG). If you need to upgrade or reinstall WYSIWYG and you want 
to keep the changes you have made to symbols, first make a backup of 
Default.ldb file. Then, once the upgrade or re-installation is complete, 
paste the backed up copy of the Default.ldb file into the 
WYSIWYG\Library folder, replacing the existing file.

Fixture label layout

You can place the following attribute labels around fixture symbols in 
WYSIWYG: 

 focus
 lamp
 lens
 notes
 position
 purpose
 spot
 unit
 channel
 circuit
 color
 gobo
 patch
 dimmer
 fixture notes
 type
 intensity

To set the position, visibility, color, and justification of these attributes, 
edit the Label Layout.
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Note: To see which options you have turned on, you may need to enable 
the master visibility toggle from View Options > Wireframe Details tab 
before the specified label layout appears in the wireframe. For details, 
see the “Wireframe Details tab”.

As with symbols, you can edit label layouts at an application level, 
document level, or selected fixture-only level. To change the font used 
for the attributes, see “To change the font in Label Layouts”.

To change the label layout at the application level

To change the label layout at an application level, you must browse the 
library from the WYSIWYG Welcome window. Note that changes you 
make to a fixture’s label layout at the application level will appear for 
that fixture whenever a new WYSIWYG file is created.

Note: Since the information is stored in the Default.ldb file in the 
C:\ProgramData\CAST Software\WYSIWYG\1.xx.xx.x\Library folder, it is 
recommended that you make a backup of this file so you can keep your 
changes if ever you need to reinstall WYSIWYG. In this case, simply 
replace the installed file with the backup to ensure your changes are not 
lost. Alternatively, you can use the Export User Data feature to back up 
your settings. For details, see “Exporting user data”.

1 In the Welcome window, select Options > Browse Library. 

2 Select the Fixtures tab.
3 Navigate through the fixtures library, and then select the fixture type 

for which you wish to change the label layout.
4 Right-click and select Properties.

Result: The Properties dialog box for the fixture appears. 

5 Click Edit Layout.
Result: The Edit Fixture Attribute Layout window appears.

6 Edit the label layout as desired, and then click OK to save your 
changes.

To change the label layout at the document Level

To change the label layout at the document level, you must browse the 
library from within a WYSIWYG file. Any changes made to the fixture’s 
label layout at the document level will only be applied to fixtures being 
inserted in the current file. New files containing the same fixtures will not 
be affected.

1 In your WYSIWYG file, select Library > Browse Library.

2 Select the Fixtures tab.
3 Navigate through the fixtures library, and then select the fixture type 

for which you wish to change the label layout.
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4 Right-click and select Properties.
Result: The Properties dialog box for the fixture appears. 

5 Click Edit Layout.
Result: The Edit Fixture Attribute Layout window appears.

6 Edit the label layout as desired, and then click OK to save your 
changes.

To change the label layout at the per-fixture level

Changes that you make to a fixture’s label layout at the per-fixture level 
only affect the selected instances of the fixture in the current file. There 
are two ways to change the label layout in this manner:

To modify any fixture’s layout in the current file

1 In a wireframe view, right-click on an empty area and select Fixture 
Attribute Layouts.

Result: The Edit Fixture Attribute Layout window appears.

2 Edit the label layout as desired, and then click OK to save your 
changes.

To modify a specific set of fixture label layouts in the current 
file

1 In a wireframe view, select the group of fixtures that you want to 
modify.

2 Right-click and select Fixture Attribute Layouts.
Result: The Edit Fixture Attribute Layout window appears.

3 Edit the label layout as desired, and then click OK to save your 
changes.
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Using the edit fixture attribute layout window

 Fixture: Use this drop-down list to select the fixture that you want to 
modify. This function is only available when accessing the Edit Label 
Layout window from the Wireframe view. With no fixtures selected, the 
Fixture Selection drop-down list will display the list of all the fixture 
types in the current WYSIWYG file. With fixtures selected, the Fixture 
Selection drop-down list will show the list of all fixture types in the 
selection set.

 Browse Layouts: Click this button to copy a layout from another fixture 
in the file. When you click this button, the Copy Layout window 
appears:
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From the list on the left, select the fixture layout you would like to 
copy, and then select the specific fixture using the arrow selectors 
above the preview on the right. When you have selected the fixture 
layout that you want to copy, click Apply Layout.

 Reset all: Will reset a fixture’s attributes to its default settings.
 Document Options: Will open the Document Options window. From here 

settings on what fixture attributes are visible can be edited.
 Fixture Attribute Layout

 Modify All: With Modify All selected, the changes that you make to 
the fixture’s label layout are applied to all of the fixtures of the 
specified type within the selection set. If no fixtures are selected, 
the changes will be applied to all fixtures of that type in the file. To 
show you which fixtures will be affected, the wireframe view 
highlights and selects all affected fixtures.

 Modify Individual: With Modify Individual selected, you can modify a 
specific fixture in the file. Use the arrows to cycle through the 
available fixtures, noting the preview image in the wireframe as it 
highlights and selects the corresponding fixture that you will be 
modifying.

 Copy: Will copy the characteristics of a selected fixture property, 
including the appearance and location in the Fixture Preview.

 Paste: Will apply any previously copied fixture property to the 
current fixture.

 Make Template: Will copy the current fixture attribute layout 
settings to make a template. This template can then be applied to 
other fixture attributes layouts, which will inherit the settings 
found in the template.

 Use FAL Template: Will apply a previously created fixture attribute 
layout (FAL) template to the current fixture attribute layout. You 
can select which FAL template to use from the drop down menu.

 New/Edit...: Will open the FAL Template Manager window where you 
can create new or edit existing FAL templates.

 Fixture Preview: A wireframe preview of the fixture’s label layout.
 Symbol: Controls how the fixture will be viewed in the layout. 

Available options are Plan (top down), Side and Front view. 
 Zoom: Adjust the Zoom slider to zoom the fixture’s preview in and out. 

Click the Zoom Reset button, identified by this icon  to reset the 
zoom back to its original levels.

 Rotation: Adjust the Rotation slider to rotate the fixture and preview 
the behavior of the labels at various rotation angles. Click the Rotate 
Reset button, identified by this icon  to reset the fixture rotation 
back to its original levels.

 Grid Snap: When enabled aligns the placement of objects in the Fixture 
Preview to grid points.

 Show Anchors: When enabled the anchor points of a fixture are shown 
in the Fixture Preview. The anchor points of a fixture are spots on the 
fixture where fixture attributes can be attached.
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 Adjust Labels: This grid allows you to show or hide attributes for 
the current fixture or fixture type.
Note: If a FAL template is in use for the fixture, this section is 
disabled. 
 Property: The named properties of the fixture. Use the checkboxes 

to turn various properties on/off in your layout. 
Note: Properties will not appear even if you turn them on in this 
window, unless you enable the master visibility toggle in the 
document options. For more information, see the “Document 
Options”.
 Color: The Color column indicates the current color assigned to the 

label. You can change the color by selecting the Color preview and 
using the drop-down list to select a new color.

 Attribute Anchor: The Attribute Anchor column indicates where on the 
fixture the property’s symbol will be anchored. This can only be 
changed by editing the FAL Template.

 Text:
 Height: Increase or decrease the height to modify the font size.
 Rotation: Set the angle to specify the label alignment in relationship 

to the fixture symbol.
 Italics: Select this checkbox to display the text in italics.

 Text Anchor: This section controls how the text of a fixture attribute 
will be aligned.
 Horizontal: Set the horizontal alignment of text relative to the 

insertion point/shape.
 Vertical: Set the vertical alignment of text relative to the insertion 

point/shape. 
 Shape: This section controls how the shape that represents a fixture 

attribute is displayed.
 Shape: Select a shape to be associated with this attribute, if 

desired. You can choose from none, circle, square, octagon, or 
diamond.

 Size: Increase or decrease the size of the Shape, as desired.
 Line Weight: Control the thickness of the line that creates the Shape, 

as desired.
 Position:

 Auto-Position: Select this option if you want the attribute’s label to 
maintain its position in relation to the fixture symbol regardless of 
where the fixture is focused.

 Auto-Rotate: Select this option if you want the attribute’s label to 
maintain its alignment in relation to the fixture symbol regardless 
of where the fixture is used. 

To change the font in Label Layouts

You can change the font that will appear globally in all Label Layouts, 
choosing from all fonts installed on your computer.
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1 In any drawing mode, click Options > Document Options.

2 Click the Font tab.
3 Under Fixture Layout Labels, from the Font drop-down list, select the 

font that you want to appear in all Fixture Layout labels.
4 Choose whether you want the letters to appear bold or underlined.
5 Click OK.

Using the FAL template manager

The FAL Template Manager enables you to make a template of a fixture 
attribute layout (FAL), and then use the FAL template for other fixtures. 

When using a FAL template with different fixtures, the fixture image of 
itself will be different, but the fixture properties displayed, how they are 
displayed and where in relation to the fixture they are displayed stay the 
same.

 New Fixture Attribute Template: Click this button to create a new FAL 
template.

 Delete Selected Fixture Attribute Layout: Click this button to delete the 
currently selected FAL template.

 FAL Template List: A grid displaying all created FAL templates and 
their status in the file.
 Status: This column will display a checkmark if the FAL template is 

currently selected.
 FAL Template Name: The name of the FAL template.
 In Use: Displays if the FAL template is currently in use in the 

WYSIWYG file.
 Use Existing Layout: This section uses information from existing 

fixture attribute layouts for the FAL template.
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 Pull from Current Layout: When clicked the fixture attribute layout 
information from the currently selected fixture will be added to the 
FAL template. 

 Browse Fixture Layouts in Current File: The fixture Selection drop-down 
list allows you to change the currently selected fixture to any other 
fixture in the file.

 Fixture Preview: A wireframe preview of the fixture’s label layout.
 Symbol: Controls how the fixture will be viewed in the layout. 

Available options are Plan (top down), Side and Front view. 
 Zoom: Adjust the Zoom slider to zoom the fixture’s preview in and out. 

Click the Zoom Reset button, identified by this icon  to reset the 
zoom back to its original levels.

 Rotation: Adjust the Rotation slider to rotate the fixture and preview 
the behavior of the labels at various rotation angles. Click the Rotate 
Reset button, identified by this icon  to reset the fixture rotation 
back to its original levels.

 Grid Snap: When enabled aligns the placement of objects in the Fixture 
Preview to grid points.

 Show Anchors: When enabled the anchor points of a fixture are shown 
in the Fixture Preview. The anchor points of a fixture are spots on the 
fixture where fixture attributes can be attached.

 Adjust Labels: This grid allows you to show or hide attributes for 
the current fixture or fixture type.
 Property: The named properties of the fixture. Use the checkboxes 

to turn various properties on/off in your layout. 
Note: Properties will not appear even if you turn them on in this 
window, unless you enable the master visibility toggle in the 
document options. For more information, see the “Fixture Settings 
tab”.
 Color: The Color column indicates the current color assigned to the 

label. You can change the color by selecting the Color preview and 
using the drop-down list to select a new color.

 Attribute Anchor: The Attribute Anchor column indicates where on the 
fixture the property’s symbol will be anchored.

 Text:
 Height: Increase or decrease the height to modify the font size.
 Rotation: Set the angle to specify the label alignment in relationship 

to the fixture symbol.
 Italics: Select this checkbox to display the text in italics.

 Text Anchor: This section controls how the text of a fixture attribute 
will be aligned.
 Horizontal: Set the horizontal alignment of text relative to the 

insertion point/shape.
 Vertical: Set the vertical alignment of text relative to the insertion 

point/shape. 
 Shape: This section controls how the shape that represents a fixture 

attribute is displayed.
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 Shape: Select a shape to be associated with this attribute, if 
desired. You can choose from none, circle, square, octagon, or 
diamond.

 Size: Increase or decrease the size of the Shape, as desired.
 Line Weight: Control the thickness of the line that creates the Shape, 

as desired.
 Position:

 Auto-Position: Select this option if you want the attribute’s label to 
maintain its position in relation to the fixture symbol regardless of 
where the fixture is focused.

 Auto-Rotate: Select this option if you want the attribute’s label to 
maintain its alignment in relation to the fixture symbol regardless 
of where the fixture is used. 

 Save and Apply: Will save any changes made to the FAL template and 
apply the changes to the fixture.

 Close: Will close the FAL Template Manager window.
 Save: Will save any changes made to the FAL template.

To create a FAL Template

1 In the FAL Template Manager window, click the New Fixture Attribute 
Template button.

Result: The New Layout Template dialog box appears.

2 In the New Layout Template window, enter the name of the new FAL 
template.

3 Click OK.
Result: The new template will be created. It will appear in the FAL 
Template List and be currently selected.

 The New Fixture Attribute Template button.
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To delete a FAL Template

1 In the FAL Template Manager window, in the FAL Template List, select 
the FAL template you want to remove.

2 Click the Delete Selected Fixture Attribute Template button.

Result: A dialog box will appear asking if you really want to delete 
the FAL template.

3 Click Yes.
Result: The FAL Template will be deleted

Attribute Anchors
When fixture properties are displayed, they can be anchored to the 
fixture. If the fixture is moved or rotated, the fixture attribute will move 
or rotate too, while keeping the same spacing in relation to its fixture.

Each fixture has nine Attribute Anchors which fixture attributes can be 
locked on to. The anchors point locations are:

 Top Left

 The Delete Selected Fixture Attribute Template button.

An example fixture with anchored attributes. The image on the left 
shows the default orientation of the fixture. The image on the right 
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 Top Center
 Top Right
 Center Left
 Center Center
 Center Right
 Bottom Left
 Bottom Center
 Bottom Right

Attribute Anchors are visible as a red box surrounding the fixture, with 
little squares around the perimeter and one in the center being the exact 
anchor points. 

Fixture attributes will maintain the same distance from their assigned 
Attribute Anchor across all fixtures. Even if the dimensions of the fixture 
change, the attribute will maintain the distance from the Attribute Anchor 
as it was originally assigned.

To assign an Attribute Anchor

Note: The default Attribute Anchor setting is Center Center.

1 In the FAL Template Manager window, select the FAL template you 
want to work with from FAL Template List. 

2 In the Fixture Preview section, position fixture attributes how you want 
them to appear in relation to an Attribute Anchor.

3 In the Adjust Labels grid, select the fixture attribute whose Attribute 
Anchor you want to change.

4 In the Attribute Anchor drop-down menu for the attribute, select which 
anchor point the attribute should be assigned to. 

5 To save any changes, click Save.

Two example fixtures using the same FAL template. The attributes are
assigned to the bottom center anchor position, and the FAL template
places the attributes around the fixture symbol accordingly.
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Inserting symbols

You can also insert symbols that are not associated with fixtures. This 
allows you to represent the fixtures when you draw a key or want to 
show the position of a boom in a plan view. Symbols are not fixtures and, 
therefore, are not counted in reports. Standard symbols, such as the 
United States Institute for Theatre Technology (USITT) symbols, are 
available from the library for your use.

To insert symbols

For information on inserting objects from the library, see “Working with 
the Library Browser”.

Symbol properties

Options on the Symbol tab affect the fill color and hatch style of a symbol. 

 Change Symbol: Click to select a different symbol. 
 Hatch Style: The style to use for the hatch. If the Hatch style is None 

the symbol is transparent. If it is Background, the symbol is filled with 
the color of the background and is not transparent.

 Fill Color: The color with which you want the symbol to be filled. If the 
hatch style is None or Background, the fill color is not enabled.
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Color, gobos, and accessories

Introduction

You can add to fixtures, colors, gobos and accessories such as barndoors, 
tophats, color scrollers, dousers, and so on. Accessories have their own 
section in the Library Browser and can be inserted just like other objects. 
You must insert accessories onto existing fixtures and can only insert 
them onto compatible fixtures.

Placing color and gobos

You can drop color and gobos onto fixtures by using the Library Browser 
or the Quick Tools method. Colors and gobos from many manufacturers 
are included in the library. You can preview the color or gobo by double-
clicking on the name.

Note: For more information on Quick Tools, see “Quick fixture tools”.

To insert colors and gobos using the Library Browser

1 Open the Library Browser.
2 Click the Color or Gobo section tool.

3 Find the color or gobo that you want to insert.
4 Right-click the color/gobo name, and then click Insert.

Result: The cursor shows a “Q”, the symbol denoting that Quick Tools 
have been enabled. 

5 Click on the fixtures to which you want to add the color or gobo.
6 Right-click, and then select Finish Quick Tools to finish placing the 

color or gobo.

To insert colors and gobos using the Quick Tools

1 Click Tools > Quick Tools > Quick Tools.

Result: The Quick Fixture Tool appears.

2 Under the Accessories heading at the bottom of the window, click the 
ellipsis button (...) beside the feature that you want to add (either 

 The Color button.

 The Gobo button.
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color or gobo), and then choose the color or gobo in the resulting 
window.

3 Click OK.
Result: The cursor shows a “Q”, the symbol denoting that Quick 
Tools have been enabled. 

4 Click on the fixtures to which you want to add the color or gobo.
Note: If you want to apply color to a multi-source light that has 
multiple circuits (such as the 528 Borderlight 6’ 4” Circuit), the 
following window appears, prompting you to select the circuit to 
which you want to apply the color:

In this case, select the circuit, and then click Select. To choose 
multiple circuits, press CTRL, and then select the desired circuits. 
Click Select when you are finished.

5 Right-click, and then select Finish Quick Tools to finish placing the 
color or gobo.

To create a new shortcut to a color or gobo

1 Click the Col/Gobo shortcut bar.

2 Right-click in the open space on the bar, and then choose New 
Shortcut.
Result: The Color Select or Gobo Select dialog box appears.

3 Select a color or gobo from the tree menu on the left side.
Result: The color or gobo is displayed on the right side.

4 Click Select.
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Color/gobo lists

Color and gobo lists are required for automated lighting fixtures and 
scrollers. By default, when inserted, automated fixtures and scrollers are 
set to use the manufacturer default color or gobo list. WYSIWYG contains 
a library of “stock” color and gobo lists provided by the fixture 
manufacturers. If you are using a custom set of colors or gobos, or want 
to generate a scroll for a color scroller, you will need to create a custom 
color or gobo list.

Note: To create a custom color or gobo list for a fixture or scroller, it is 
strongly recommended that you Clone the existing list for that fixture or 
scroller, modify the clone, and then insert that clone into the fixture, as 
described in “To insert custom scrolls into scrollers”.

To view an existing library list

1 From the Library menu, choose Edit Color/Gobo Lists.

2 In the Show section, click Stock.
3 Scroll to find the list you want to view.

a. OR the name of the item can be entered in the search field, then 
click the magnifying glass icon to locate items with the entered 
name.

4 Click on the list name. A list of slots and the color or gobo for each 
slot is displayed in the slot window. If OPEN appears in the Name 
column for a slot, the color, gobo, or prism has not been assigned or 
is intentionally left OPEN. 

5 Click on a slot to see the preview of that color or gobo in the box 
below the slot window.

6 Click Close when you are done.
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To create a custom color/gobo list

1 From the Library menu, choose Edit Color/Gobo Lists.

2 In the Show section, click Custom.
3 Click Add.
4 Type the name of the new list.
5 Type the number of slots on the wheel or scroll.
6 Click OK.
7 Click on the slot you wish to edit.
8 Click Insert Color, or Insert Gobo, or Insert Prism. Make sure if you are 

inserting different types of media into the same list that this is 
actually possible for that fixture or accessory.

9 Click on the item you want to insert, and then click Select.
10 Repeat for the remaining slots.
11 To reorder the items in the slots, click on the slot, and then click Up 

or Down to move that item to a new position.
12 To erase a color or gobo selection from a slot, click Remove. The slot 

returns to the default selection of OPEN.
13 Click Close when you are done creating lists.

Important Note: It is recommended to clone the stock wheel or list 
associated with the fixture(s) and edit the cloned list. The cloned list 
inherits the properties of the original list.

To clone a stock color/gobo list

1 From the Library menu, choose Edit Color/Gobo Lists.

2 In the Show section, click Stock.
3 Scroll to find the list you want to clone.
4 Click Clone.
5 Type a name for the cloned list, and then click OK.

Result: The cloned list appears in the custom lists.

To rename a color/gobo list

1 From the Library menu, choose Edit Color/Gobo Lists.

2 In the Show section, click Custom.
3 Select the color/gobo list that you want to rename.
4 Click Rename.
5 Type the new name for the list, and then click OK. 

Result: The list is renamed.
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To delete a color/gobo list

1 From the Library menu, choose Edit Color/Gobo Lists.

2 In the Show section, click Custom.
3 Select the color/gobo list that you want to remove.
4 Click Delete.

Result: The list is removed from the color/gobo list.

To insert custom scrolls into scrollers

1 Select the fixtures with scrollers for which you want to assign a 
custom scroll.

2 From the Edit menu, choose Object Properties.
3 Select the Fixture tab.
4 In the fixture list, highlight the scroller.
5 Select the Scroll tab.
6 Select the desired list from the pull-down list.

Note: Only custom lists that have the appropriate number of slots 
and media type are available.

7 Click OK.

To insert custom wheels into automated fixtures

1 Select the fixtures for which you want to assign a custom wheel.

2 From the Edit menu, choose Object Properties.
3 Select the Fixture tab.
4 Select the appropriate tab (for example, Color 1, Gobo, <Gobo>).
5 From the drop-down list, select the desired list.

Note: Only custom lists that have the appropriate number of slots 
and media type are available.

6 Click OK.

Custom gobos

You can generate custom gobos if you have the artwork in either bitmap 
or jpeg format. The Gobo Wizard walks you through the steps of making 
a custom gobo. Custom gobos are stored in the gobo library under the 
Custom category.

Custom gobos require an association with an existing WYSIWYG gobo to 
be visible in wireframe views. The associated gobo is used in lieu of the 
bitmap or jpeg image. In shaded views and renderings, only the custom 
gobo footprint is visible. Custom gobos do not break up the cone of light.
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To create a custom gobo

1 From the Library menu, choose Gobo Wizard.

2 Type the custom gobo name.
3 Add or modify the path.

Note: The path is the location in the library where the gobo will be 
stored. A gobo assigned to the path “Custom/Corporate_Logos” 
would be available in the custom section of the gobo library in a sub-
category named Corporate Logos.

4 To make this gobo available to other documents, check the 
appropriate box.

5 Click Next.
6 Type the path to the custom artwork file or use the browser [...] to 

open the image. The image file must be in either bitmap or jpeg 
format. 
Result: A preview of the image appears in the pane on the right and 
the image’s attributes are recorded in the box on the left.

7 Click Next.
Result: A short description of the next step appears. You will need to 
choose an existing library gobo to be displayed when the custom 
artwork cannot be displayed. 

8 Click Next.
9 Navigate the library to find a suitable association gobo.

Note: Generic association gobos are stored in the Proxy category.
10 Select the desired gobo.
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11 Click Finish.
Result: The custom gobo is placed in the gobo library as per the 
path specified in step 3.

To delete custom gobos
If you do not want to keep a custom gobo any longer, you can delete it 
from the library browser. 

Notes: 

 You cannot delete a custom gobo if it is currently inserted in your 
plot; instead, you must delete the item from your plot, save and 
close the file. When you reopen the file you can delete the item from 
the library browser.

 When you delete a custom gobo, you do not delete the shortcut 
associated with it. You must delete shortcuts manually.

1 In the Library Browser, navigate to the folder where you stored the 
custom library item. 

2 Highlight the library item name, and then right-click and choose 
Delete.
Note: This option is disabled if the item is currently inserted in your 
plot. You must delete the item from your plot, and then save and 
close the file. When you reopen the file you can delete the item from 
the library browser.

3 A message box appears telling you the action is irreversible. Click Yes 
to delete the item.

Accessories

You can add accessories to the fixtures such as barndoors, tophats, color 
scrollers, dousers, etc. Choose an accessory from the Accessories section 
in the Library Browser, and insert them into compatible fixtures.

To insert an accessory

1 Open the Library Browser.
2 Click the Accessory tab.
3 Find the accessory that you want to insert.
4 Double-click the accessory name.
5 Click on the fixtures to insert the accessory.

Tips: 
 To place an accessory on a selected fixture, right-click on the 

fixture, and then click Add Accessory. Use the browser to find the 
accessory you want to insert. Follow this procedure in Data mode 
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and only those accessories that can be applied to the selected 
fixture will be available.

 To place an accessory on a group of selected fixtures, use the 
Accessory library. With the fixtures selected, find the accessory in 
the Library Browser. Right-click on the accessory name, and then 
click Insert.

 You can add the correct frame size to a fixture using Add 
Accessory.

To create a new shortcut to an accessory
Refer to “To create a new shortcut”. 

Mountable yokes

Note the following before working with mountable yokes:

 While mountable yokes are considered accessories, they differ from 
other accessories in that you need to add them before you add the 
fixtures (you cannot insert a fixture, and then select Add Accessory to 
add a mountable yoke). 

 You cannot use the Add Accessory option to add a fixture on a recently 
inserted mountable yoke. Instead, you must add the fixture either by 
using a shortcut or by selecting it from the library browser. Then you 
can use the Add Accessory option to add an accessory to the fixture.

 Once you hang a fixture on a pipe, you cannot drag it onto a 
mountable yoke.

 To remove a fixture from a mountable yoke, right-click the fixture, 
and then select Remove Accessory. In the resulting tree menu, you can 
either remove the accessory from the fixture, or remove the fixture 
from the mountable yoke.

 If you insert a fixture onto a yoke by using a shortcut, and then you 
insert another fixture onto a pipe using the same shortcut, when you 
right-click, the option Finish Placing Accessories appears (instead of 
Finish Placing Fixtures).

 When you insert a fixture on a mountable yoke in CAD mode, you 
can no longer focus the beam by dragging it in CAD mode. 
Additionally, the beam direction might not point straight down.
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The Flight Case

Introduction

The Flight Case is a special view used to hold unhung fixtures, hang 
structures, and focus positions created or inserted in Data mode but not 
yet placed on the drawing. This is an ideal way to work from a set 
inventory as you can add all of your fixtures in Data mode, and then click 
and drag the fixtures out of the Flight Case until you have exhausted 
your stock. 

To open the Flight Case

In CAD mode, click the Flight Case tab.

Tip: The Flight Case layout is preconfigured with the flight case and a 
wireframe view.

How objects get into the Flight Case

As you enter fixtures in the Data mode spreadsheets, they appear in the 
Flight Case under the Unassigned Fixtures branch. When you type position 
names in the Position Manager, the individual positions appear under the 
Position branch. As you assign fixtures to those positions, they will move 
from the Unassigned branch to under the proper position. All fixtures that 
appear in the Flight Case are unhung fixtures, which means they are not 
in your drawing (regardless of whether they have been assigned a 
position or not).
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If you create focus positions in the Data mode by typing labels in the 
focus box of the spreadsheet, those focus positions will appear under the 
Focus Positions branch of the Flight Case. Unhung fixtures assigned to 
those focus positions will appear under their respective Flight Case 
headings. 

To learn more about inserting objects in Data mode, please refer to “Data 
mode”.

Entering and modifying objects in the Flight Case
 You can insert fixtures and focus positions directly into the Flight 

Case using the Library, Draw menu, or appropriate tools on the Draw 
toolbar. 

 You can change a fixture’s assigned position by selecting the fixture 
in the Flight Case and dragging it to another position within the Flight 
Case. 

 You can change a fixture’s assigned focus position by selecting the 
fixture and dragging it between Focus Positions within the Flight 
Case. 

Transferring objects from the Flight Case to the drawing

The items that appear in the Flight Case can be transferred to your 
drawing by clicking and dragging. 

To hang fixtures from the Flight Case

1 Open the Flight Case.

2 Click and hold on the desired fixture.
3 Drag the fixture into the wireframe view and place it on a hang 

structure. 
Note: If a fixture appears in the flight case under a position branch, 
that fixture must be hung on that position. Fixtures with no position 
or unassigned fixtures may be hung on any hang structure.

4 Release the mouse button. 
5 Repeat for the remaining fixtures.

Tip: You can hang all the fixtures on one position by dragging the 
entire position out of the Flight Case.
Selecting a fixture in your drawing and pressing the Backspace key 
will return the fixture to the Flight Case. The fixture will retain the 
position assignment.

To insert a hang structure from the Flight Case 

If you drag a position from the Flight Case, you will create a pipe. 
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1 Expand the Positions branch to see all the hang structures.

2 Click and hold on the position that you want to insert.
3 Drag the pipe onto the drawing.
4 Release the mouse button.
5 Use the pop up dialog box to answer the questions about the trim 

height and length of the pipe, or use the Interactive button to draw 
the pipe in interactive mode.
Result: If you do not choose interactive mode, the pipe is inserted 
centered on the origin at the trim height specified.

Note: Multiple positions can have the same name.

For more information about inserting pipes please refer to “Drawing 
pipes”.

To insert a focus position from the Flight Case 

1 Expand the Focus Positions branch in the flight case to see all the 
Focus positions that have not yet been placed in the drawing.

2 Click and hold on the focus position that you want to insert into the 
drawing.

3 Drag the Focus position onto the drawing.
4 Release the mouse button to place the focus position.

Flight case properties

The Flight Case properties affect which fixture attributes are shown.

To modify the Flight Case properties

1 From the Options menu, choose View Options.

Tip: You can also use the View Options tool on the Standard toolbar. 

2 Click the Wireframe Details tab.
3 Select the fixture attributes that you want displayed in the Flight 

Case. 

Note: The Unit Number is displayed by default, however, you can select all 
the attributes if you want. 

 The View Options button.
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CAD mode - Multimedia Sources 
and Rendering

CAD mode is where you create multimedia sources in your show 
drawings and render images of your show. WYSIWYG adds 
multimedia features that are specific to the entertainment industry. 
Rendering in CAD mode operates like many other CAD programs, 
so many of the concepts will be familiar to those who have used a 
computer-aided drafting program before. 

In this chapter
Lasers 623

LED Wizard 626

Camera Manager 649

Video Manager 653

Image Manager 667

Rendering 680
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Lasers

Laser visualization can be added into any WYSIWYG visualization. Lasers 
can be visualized in both LIVE mode and DESIGN mode. The Laser 
Options tab is where you specify if you want to visualize lasers in 
DESIGN mode or in LIVE mode. 

To visualize in LIVE mode, you need an external Laser controller 
software, from Pangolin Laser Systems or Sollinger 
LaserAnimation, and assign the corresponding protocol to the laser. 
Laser software can be running on the same computer as WYSIWYG or a 
different computer which is on the same network.

Lasers in LIVE mode are controlled using the Pangolin Laser Systems 
or the Sollinger LaserAnimation software. Both laser protocols need to 
connect with WYSIWYG and then can be visualized with the WYSIWYG 
laser beam system.

To visualize DESIGN mode, the Designer tools (intensity, color, zoom, 
gobo, prism) are used to control the laser parameters. Using the Gobo 
Designer tool, you can set one of the defined 12 laser patterns into the 
laser beam, or you can create your own gobo using the Gobo Wizard, and 
then import this image into the fixtures Gobo wheel through Library > 
Edit Color/Gobo Lists. See “To create a custom gobo” and “To insert 
custom wheels into automated fixtures” for more information. The Laser 
fixtures Gobo Wheel is named "Laser Patterns", it is a generic gobo list 
shared amongst all Laser fixtures.

In the Library Browser, all Laser fixtures are available in the Fixtures > Type 
> Laser folder, or under the respective Manufacturer folders.

Note: The Laser fixture needs to be patched to a DMX channel and this 
channel needs to be set to full to visualize the laser beams in Shaded 
View (like a dimmer). 
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To set a laser’s source

1 In CAD mode, right-click the laser and select Properties. 

Result: The Properties window appears.

2 In the Properties window, select the Fixture tab, Options sub-tab.
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3 From the Value drop-down list, select Design Mode to use the laser in 
DESIGN mode, or Laser Source to use the laser in LIVE mode.
Note: If Laser Source was chosen, the laser protocol you want to use 
has to be assigned before visualization can occur.

To set the protocol of a laser

1 In CAD mode, right-click the laser and select Properties. 

2 The Properties window appears.

3 In the Properties window, select the Fixture tab, Laser Source sub-tab.
4 From the Protocol drop-down list, select the laser protocol you want to 

use.
5 In the Input field, select what channel the laser will receive input from 

the protocol.
6 Click Apply.

Result: The laser will now accept input from the connected laser 
protocol.
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LED Wizard

Introduction

This Wizard enables you to quickly create a grid of LEDs that simulates 
LED walls or panels, as well as LED webs, star cloths and video curtains. 
The grid can have Image or Video Sources applied to it, or can be 
patched to DMX universes for control via LED mapping software or 
lighting consoles.

To use the LED Wizard

1 From the Draw menu, choose LED Wizard.

Result: The LED Wizard appears.
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2 Click Next.
Result: The Dimensions and style window appears.

 

3 Use the options in the View drop-down list to control the "zoom level" 
of the preview area:
 Fit: Choose this option to fit the grid to the preview area.

 Zoom: Choose this option to zoom in on the center of the grid, to 
check the image or video that was mapped to the pixels.

 Corner: Choose this option to zoom in on the lower-left corner of 
the grid. This is useful for checking how the frame appears in 
relation to the rest of the grid.

Note: The preview of the LED device will update as you provide its 
style and dimensions values. This helps you visualize your LED panel 
or wall before you move onto the next step.

4 In the Units section, choose the measurement unit you want to use 
in the grid you are creating. By default, the Units section is set to 
Metric.
 Metric: Choose this option to specify the measurements in meters.
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 Imperial: Choose this option to specify the measurements in feet 
and inches.

5 In the Style section, choose the style of LEDs that you want to use in 
the grid you are creating: 
 Single: Choose this option to use single LEDs which produce (all) 

three colors—Red and Green and Blue.

 Triplet: Choose this option to use LED clusters comprised of three 
LEDs, each of which produces a single color—Red or Green or 
Blue).

6 In the Shape section, choose the shape of the individual LEDs to use 
in the grid, and then specify their size:
 Round: Choose this option if you want the Single LED or each 

element of a Triplet to be round, and then type the diameter of 
the LEDs in this grid.

 Rectangular: Choose this option if you want the Single LED or each 
element of a Triplet to be rectangular, and then type the width 
and height of the LEDs in this grid.

7 In the Dimensions section, define the layout of the grid by 
specifying the number of rows and columns of LEDs:
 Number of columns: Type the number of columns in the grid.

 Number of rows: Type the number of rows in the grid.

 Offset rows: Select this checkbox to offset the rows in the grid by 
one-half of the Horizontal Pitch (described below).

8 Use the Specify By drop-down list and the fields below it to select the 
parameters of the device (i.e., LED panel, LED wall, LED web, video 
wall, etc.) that you will use to define this LED grid: 
 Choose Dimensions and Pitch to define the grid’s height and width 

and pixel pitch. (The pitch is the center-to-center distance 
between LEDs in the grid. The height and width are the overall 
height and width of the device as seen from the front—i.e., the 
height and width of an LED panel or LED wall.) When you choose 
this option, the LED Wizard will calculate the width of the device’s 
Borders for you.

 Width: Type the overall width of the device being simulated.

 Height: Type the overall height of the device being simulated.

 Horizontal Pitch: Type the horizontal center-to-center distance 
between LEDs in the grid of the device being simulated.
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 Vertical Pitch: Type the vertical center-to-center distance 
between LEDs in the grid of the device being simulated.

Tip: Since, in many cases, LED panels or walls have the same 
horizontal and vertical pixel pitch, you may click the Lock button to 
apply the same value to both.

 Choose Dimensions and Borders to define the height and width of 
the device being simulated, and its borders’ horizontal and 
vertical sizes. (The height and width are the overall height and 
width of the device as seen from the front—i.e., the height and 
width of an LED panel or LED wall. The border is the distance 
between the edge of the device and the edge of the first row and/
or column of LEDs in the grid.) When you choose this option, the 
LED Wizard will calculate the grid’s pixel pitch for you.

 Width: Type the overall width of the device being simulated.

 Height: Type the overall height of the device being simulated.

 Side Borders: Type the distance between the left edge of the 
device being simulated and the edge of the left-most column 
of LEDs. The same value will be applied to the right side of the 
device, between its right edge and the edge of the right-most 
row of LEDs.

 Top/Bottom Borders: Type the distance between the top edge of 
the device being simulated and the edge of the top row of 
LEDs. The same value will be applied to the bottom of the 
device, between its bottom edge and the edge of the bottom 
row of LEDs.

Tip: Since, in many cases, devices such as LED panels or walls have 
the same-size horizontal and vertical borders, you may click the Lock 
button to apply the same value to both.

 Choose Pitch and Borders to define the pixel pitch and borders’ 
horizontal and vertical sizes of the device being simulated. (The 
pixel pitch is the center-to-center distance between LEDs in the 
grid. The border is the distance between the edge of the device 
and the edge of the first row and/or column of LEDs in the grid.) 
When you choose this option, the LED Wizard will calculate the 
device’s height and width for you.

 Horizontal Pitch: Type the horizontal center-to-center distance 
between LEDs in the grid of the device being simulated.

 Vertical Pitch: Type the vertical center-to-center distance 
between LEDs in the grid of the device being simulated.

 Side Borders: Type the distance between the left edge of the 
device being simulated and the edge of the left-most column 

 The Lock button.

 The Lock button.
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of LEDs. The same value will be applied to the right side of the 
device, between its right edge and the edge of the right-most 
row of LEDs.

 Top/Bottom Borders: Type the distance between the top edge of 
the device being simulated and the edge of the top row of 
LEDs. The same value will be applied to the bottom of the 
device, between its bottom edge and the edge of the bottom 
row of LEDs.

Tip: Since, in many cases, LED panels or walls have the same-size 
horizontal and vertical pixel pitch as well as borders, you may click 
the Lock button to apply the same value to both.

9 In the Back Panel section, choose the back panel settings for LED 
Wall.

 Show Back Panel: Enable to create a black back panel for the 
LED Wall. This option is enabled by default. 

 Thickness: Type in the thickness of the back panel.

Tip: After the LED Wall is inserted the file, the Back Panel settings 
can still be changed from the properties menu of the LED Wall.

10 In the Pixel Detail section, 
 You can use the Pixel Detail slider to control the LED Wall quality 

vs. performance setting. An increase in pixel detail will result in a 
decrease in performance.
OR

 If the source of your LED wall is color, image or video, you can 
select the Display as Screen checkbox to display the LED wall as a 
screen with a projected image instead of a detailed grid of LED 
pixels forming the image. 

Display as Screen does not work if the source of the LED wall is 
Dynamic DMX patch.

 The Lock button.
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11 Click Next.
Result: The Apply Content window appears.

12 Use the Brightness drop-down list to set the overall brightness of the 
LED grid in CAD and Design modes. 
Note: If you do not enable Dynamic Intensity by DMX, the static 
intensity that you define will also apply in Live mode.

13 In the Color section, select what this LED grid will display:
 Single Color: Choose this option in order to have the grid display 

the selected color in all modes; click the color box next to this 
option to select the color to be displayed.

 Image Source: Choose this option in order to have the grid display 
the image from an Image Source or Subsource that you created 
in the Image Manager, and then select the Image Source or 
Subsource to display from the drop-down list. (For more 
information on using the Image Manager, see “Image Manager”.) 
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Click Create New to launch the Image Manager to create a new 
image source or subsource.

Tip: For optimum results, the number of rows and columns of this 
LED grid should be proportional to the dimensions of the Image 
Source or Subsource being selected here. 
 Video Source: Choose this option in order to have the grid display 

the video from a Video Source or Subsource, that you created in 
Video Manager. From the drop-down list select the Video Source or 
Subsource to display. (For more information on using the Video 
Manager, see “Video Manager”.) Click Create New to launch the 
Video Manager to create a new Video Source or Subsource.

IMPORTANT: When a video is used on an LED grid, if that video is 
not playing, that grid will not appear in Shaded Views in Design and 
Live modes. To play the video, use the Video Designer tool in Design 
or Live mode.
Tip: For optimum results, the number of rows and columns of this 
grid should be proportional to the dimensions of the Video Source or 
Subsource being selected here.
 Dynamic Color by DMX: Choose this option to control the color of the 

LEDs in this grid via DMX (by connecting to a lighting console or 
to LED mapping software), and then select how the color 
channels should be patched: 

 Single Patch: Select this option from the drop-down list in order 
to control the color of this entire grid with a single set of DMX 
channels. After selecting this option, if you choose red on your 
console, every point source in the entire grid will be red.

 Multi Patch: Select this option from the drop-down list to 
control individual LEDs in this grid via separate sets of DMX 
channels. After selecting this option, you will have the ability 
to control the color mix for every LED in the grid individually. 

Tip: Select this option when controlling the LED grid from specialized 
LED mapping software.
Note: If this option is selected, the LEDs will appear in the color of 
the Layer on which this grid is located in all Shaded views, except 
those in Live mode (where they will appear in the color provided by 
the incoming DMX data).

14 In the Intensity section, you have the option to select whether or not 
you wish to have dynamic control of the grid intensity, via DMX for 
Live mode.
Note: This option applies to Live mode only. The Brightness value 
will set the intensity of the LED grid for all other modes. 
 Single Patch: Select this option from the drop-down list in order to 

control the intensity of the entire grid with a single DMX channel. 
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 Multi Patch: Select this option from the drop-down list in order to 
individually control the intensity of each LED in this grid via 
individual DMX channels. 

 Maximum Intensity: Select the maximum intensity value of the 
LEDs in this grid when connected to a console and viewed in Live 
mode.

IMPORTANT: This value applies to the maximum intensity of the 
LEDs in Live mode. This is intended to control maximum brightness 
of each LED grid, because some LEDs are brighter than others. For 
example, if you set one LED grid to 100% and another LED grid to 
50%, when you then control them via DMX in Live mode and set the 
console channel to full (255), the LED grid with Maximum Intensity 
set to 100% will be brighter than the one set to 50%. 

15 Click Next.
Result: If the content of your LED grid is controlled by a Single 
Color, Image Source or Video Source, you are Finished. Otherwise, 
you’ve selected to control color and/or intensity dynamically, and the 
LED Wizard proceeds to the appropriate patching page, as shown 
below. Locate your patching scenario, and follow the steps listed. 

Single Patch DMX Address

This page is displayed if you set Dynamic Color by DMX to the Single 
Patch option. If you also set Dynamic Intensity by DMX to the Single 
Patch option, it will be active, otherwise it will disabled. 
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a. Select one of several Color Modes by which color is controlled, 
enter the DMX control channels for the entire grid, and then click 
Next:
 Color Modes: Choose between RGB, RGBA, RGBW and RGBAW, 

depending on the device you are simulating. “RGB” stands for 
“Red, Green, Blue”; “A” stands for “Amber”; “W” stands for 
“White”. The Color Mode setting defines the number of DMX 
channels required to control the color mix for this entire grid.

Note: WYSIWYG does not actually show white or amber LEDs in its 
simulation. The additional “A” and/or “W” channels are offered so 
this Wizard can account for these channels in the patch, if necessary.

 Dynamic Color Control Patch: Type the universe and starting 
channel number for this patch, in the format 
Universe_Name.DMX_Channel_Number. (If the 
Universe_Name you typed does not exist, you will be asked if 
you wish to create it when you click Next.) Alternately, you 
may click the ellipsis button to manually select a previously-
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created universe (or create a new one), and then type the 
channel number.

Tip: Once you have finished creating this grid and have inserted 
it, switch to Data mode > Patch view, and click the universe to 
which you patched it, in order to verify that the patch has been 
applied correctly. For example, if you chose the RGBAW color 
mode, this grid should span five DMX channels, starting with the 
channel number you defined. (For more information on using the 
Patch view in Data mode, see “Working in the patch view”.)
 (If active) Dynamic Intensity Control Patch: Type the universe and 

channel number for this patch, in the format 
Universe_Name.DMX_Channel_Number. (If the 
Universe_Name you typed does not exist, you will be asked if 
you wish to create it when you click Next.) Alternately, you 
may click the ellipsis button to manually select a previously-
created universe (or create a new one), and then type the 
channel number.

b. Click Next.
Result: The Finished page appears. 

c. Proceed to step 14. 
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Single Patch DMX Address with Single Color, Image or Video 
Source

This page is displayed if you set “Dynamic Intensity by DMX” to the 
Single Patch option, and color is controlled by Single Color, Image 
Source or Video Source. 

a. Enter the address of the (single) DMX channel used to control the 
intensity of this entire grid, then click Next:
 Dynamic Intensity Control Patch: Type the universe name and 

channel number for this patch, in the format 
Universe_Name.DMX_Channel_Number. (If the 
Universe_Name you typed does not exist, you will be asked if 
you wish to create it when you click Next.) Alternately, you 
may click the ellipsis button to manually select a previously-
created universe (or create a new one) and type the channel 
number.

b. Click Next.
Result: The Finished page appears.

c. Proceed to step 14. 
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Multi Patch and/or Single Patch DMX Address

This page is displayed if you set Dynamic Color by DMX to the Multi 
Patch option. Then, depending on the choice for Dynamic Intensity by 
DMX, it will be in Single Patch mode or Multi Patch mode accordingly.

a. In the Color section, enter the DMX address at which the “first” 
LED in the grid is to be patched, define which LED in the grid is 
“first” and how the rest of the LEDs “follow”, select one of several 
Color Modes by which color is controlled (for the entire grid), and 
then click Next.
 Start Address: Type the universe and channel number for the 

first LED in the grid, in the format 
Universe_Name.DMX_Channel_Number. (If the 
Universe_Name you typed does not exist, you will be asked if 
you wish to create it when you click Next.) The channel 
numbers for the rest of the LEDs in this grid will be 
“calculated” automatically by the LED Wizard, and the last 
channel number (and universe) will be displayed in the End 
Address field. 

Note: In cases where the number of DMX channels required to patch 
the grid in this manner exceed 512 (i.e., the maximum number of 
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channels in a DMX universe) the LED Wizard will automatically create 
new universes that start with the same name and have a number 
(starting with “1” and incrementing from there) appended to the 
name. For example, if the first LED was patched to universe ‘LED’, 
but two more universes were needed to patch the grid, the LED 
Wizard would create two new universes named ‘LED1’ and ‘LED2’.

 In the Numbering Style subsection, define which LED in the 
grid is to be considered “first” using the Start from drop-down 
list, and how the rest of the LEDs are to follow it using the 
Number along drop-down list. Select the Alternate direction 
checkbox to indicate that the numbering direction should 
change with every row or column. 

 Color Modes: Choose between RGB, RGBA, RGBW and RGBAW, 
depending on the device you are simulating. “RGB” stands for 
“Red, Green, Blue”; “A” stands for “Amber”; “W” stands for 
“White”. The Color Mode setting defines the number of DMX 
channels required to control the color mix for each LED in this 
grid.

Note:  WYSIWYG does not actually show white or amber LEDs in its 
simulation. The additional “A” and/or “W” channels are offered so 
this Wizard can account for these channels in the patch if necessary. 
a. In the Intensity section, specify the patching information for 

intensity.
 Single Patch Intensity: Type the universe and channel number 

for this patch, in the format 
Universe_Name.DMX_Channel_Number. (If the 
Universe_Name you typed does not exist, you will be asked if 
you wish to create it when you click Next.) Alternately, you 
may click the ellipsis button to manually select a previously-
created universe (or create a new one) and type the channel 
number.

Note: If the Intensity mode is set to Multi-Patch, then the following 
page appears. In this case, the intensity channel controlling the 
individual LED will either be before or after the color channels.

 Intensity Patch: If the intensity channel should follow the color 
channels, then set the drop-down list to After Color. Otherwise, 
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if the intensity channel is before the color channels, then set 
the drop-down list to Before Color.

Note: For tips on advanced patching techniques, see “Advanced 
patching”.
b. Click Next.
Result: The Finished page appears. 

c. Proceed to step 14. 
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Multi Patch and/or Single Patch with Color Set to Single Patch 
and Intensity Set to Multi-Patch

This page is displayed if you set Dynamic Color by DMX to the Single 
Patch option, and the Dynamic Intensity by DMX is set to Multi Patch. 

a. Enter the DMX address at which the “first” LED in the grid is to be 
patched, define which LED in the grid is actually “first” and how 
the rest of the LEDs “follow”, then click Next:
 Start Address: Type the universe and starting channel number 

for the first LED in the grid, in the format 
Universe_Name.DMX_Channel_Number. (If the 
Universe_Name you typed does not exist, you will be asked if 
you wish to create it when you click Next.) The channel 
numbers for the rest of the LEDs in this grid will be 
“calculated” automatically by the LED Wizard, and the last 
channel number (and universe) will be displayed in the End 
Address field. 

Note: In cases where the number of DMX channels required to patch 
the grid in this manner exceed 512 (i.e., the maximum number of 
channels in a DMX universe) the LED Wizard will automatically create 
new universes that start with the same name and have a number 
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(starting with “1” and incrementing from there) appended to the 
name. For example, if the first LED was patched to universe ‘LED’, 
but two more universes were needed to patch the grid, the LED 
Wizard would create two new universes named ‘LED1’ and ‘LED2’.

 In the Numbering Style subsection, define which LED in the 
grid is to be considered “first” using the Start from drop-down 
list, and how the rest of the LEDs are to follow it using the 
Number along drop-down list. Select the Alternate direction 
checkbox to indicate that the numbering direction should 
change with every row or column. 

Note: For tips on advanced patching techniques, see “Advanced 
patching”.
b. Click Next.
Result: The Finished page appears. 

c. Proceed to step 14. 

16 Click Finish.
Result: The LED grid attaches to your cursor.

17 Click to place the grid into your drawing at the desired location, or 
type in the coordinates at which to place it.
Result: The LED grid is placed into the drawing.

Modify LED Wall
This option displays the LED Wizard again, and the properties of the 
selected LED Wall can be modified. Right-click on the LED Wall and select 
Modify LED Wall.

Note:  This option is limited to a single LED Wall object at a time.
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Advanced patching
This option offers more control in defining your LED grid’s patching 
information. By using Auto Insert, each universe will start at channel 1 
and then automatically create all the universes required to control your 
LED grid for you. You then have the option to select a row and edit the 
start and end channels for each universe if you wish to do so. Otherwise, 
you can manually create each universe and specify start and end 
channels for each. 

Notes: 

 Before typing addresses, consult the figures shown under Addresses 
required and Addresses in pool for an up-to-date listing of the number 
that you will need for your grid and the number that you have 
already provided.

 Create the patch domain in the address pool box, following the 
format DomainName.StartAddress-EndAddress (for example, a.1-
169). 

 You can type multiple patch domains (for example, a.1-160 and 
b.1-20). If you assign more domains than are required, the extra 
domains are ignored.

 Use the arrow buttons to adjust the order of the patches (the order 
in which they appear is the order in which they are populated). 

 If you require more than 512 addresses (the standard DMX 
universe), then you must add additional patch domains to meet your 
requirement. The addresses can be split over universes.

Type the addresses manually

a. In the box provided, type the required addresses in the format 
DomainName.StartAddress-EndAddress (for example, a.1-169).
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b. Use the arrow buttons to adjust the order of the patches (the 
order in which they appear is the order in which they are 
populated).

c. Click Next, and then proceed to the next step.

Use Auto Insert to create the addresses automatically

a. Click the Auto Insert icon to have WYSIWYG automatically create 
all the addresses that you need for the grid. In the resulting Auto 
Insert window, type the Patch Domain Prefix (for example, a).

b. In the Number of Channels Per Domain box, accept the default value 
or type a new value based on the number of channels that you 
can control.

c. In the Start Address box, type the start address for the patch 
domain.

d. Click OK to have WYSIWYG populate the End Address (based on 
the number of channels required).

e. Click Next, and then proceed to the next step.

Select the addresses from a list

a. If you do not want to manually type the addresses, click the New 
icon, and then click ellipses button (...). 
 To create a new patch domain, click Create New, and then type 

the domain in the Domain Name box (for example, a).

 To choose a patch domain from those that you have saved with 
your current WYSIWYG file, click Select From List, and then 
highlight the domain name. 

b. Type the Start and End addresses for this patch universe.

c. Click OK.

d. Click Next, and then proceed to the next step.
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Creating Video Walls with LED Wall
After an LED wall has been created, the Grid Array tool can be utilized to 
build a video wall. Applying Grid Array opens the Quick Video/Image Tool 
where you can set the video/image sources to the screen panels that 
were created.

To create video walls with LED Wall

1 In Front or Back view in Wireframe, select the LED Wall.

2 From the Tools menu, click Array > Array Grid.
Result: The Grid Array window appears.

3 In the Grid Array window, modify the settings as desired. Refer to 
“Array” for information on Grid Array settings.
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4 Click OK.
Result: The Quick Video/Image Tool appears.

5 In the Quick Video/Image Tool window, 
a. Specify the video or image sources and subsources for the video 

wall that was created.

b. Apply existing subsources or create new subsources that will 
match the row and columns of the video wall. 

6 Click OK.
Result: The video wall is created with the video or image applied to 
the individual LED walls.

Notes: 

 The Quick Video/Image Tool can be applied to previously drawn LED 
Wall files, if re-arranged into rows and columns that WYSIWYG can 
recognize and automatically apply subsources to the individual LED 
Walls.

 The Quick Video/Image Tool can be applied to missing panels in the 
video wall, if WYSIWYG can recognize the arrangement of rows and 
columns.

 The functionality of the Quick Video/Image Tool remains available if no 
screens are selected.

LED Wall Properties
After an LED Wall has been created, the properties of the LED Wall can 
be altered from the properties window. 

Note: Multiple LED Wall objects can be selected and their properties 
edited all at once, if all specifications of the selected LED Walls are 
identical.
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The following properties of the LED Wall can be changed: 

 In the Display Source section, change the content and display 
properties.
 Source: Change what this LED Wall displays by selecting from the 

source drop-down list.
 Brightness: Change the brightness level by selecting from the 

percentage drop-down list.
 Color: If Color is the selected source, click this color box to change 

the color.
 Image Source: If Image Source is the selected source, select from 

the drop-down list or click Create New, browse and select the new 
image file.

 Video Source: If Video Source is the selected source, select from the 
drop-down list or click Create New, browse and select the new video 
file.

 Reassign Video/Image Subsource(s): This checkbox is available when 
the LED Wall is set with Multi-split subsources. Select this 
checkbox to open the Reassign Video/Image Subsource dialog box and 
reassign the video and image source types and options for the LED 
Wall.

 In the Glow Settings section, you can adjust the intensity of the 
glow from the LED Wall. 
Note: In Shaded View, the Screen/LED Wall Glow settings in the 
Simulation tab of the View Options window must be enabled to see 
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the glow from the LED wall lighting up an object. See “Simulation 
tab”.
 Hide: Select this checkbox to disable access to the Glow Intensity 

Multiplier.
 Glow Intensity Multiplier: Select this checkbox to enable the Glow 

Intensity Multiplier slider and use it to adjust the intensity.
 In the Back Panel section, change the back panel settings for the 

LED Wall.
 Show Back Panel: Select this checkbox to display the black back 

panel for the LED Wall.
 Thickness: Type in the thickness of the back panel.

 In the Pixel Detail section, 
 Pixel Detail slider: Use the slider to control the LED Wall quality vs. 

performance setting. An increase in pixel detail will result in a 
decrease in performance.

 Display as Screen: If the source of your LED wall is color, image or 
video, select this checkbox to display the LED wall as a screen 
with a projected image instead of a detailed grid of LED pixels 
forming the image. Display as Screen does not work if the source of 
the LED wall is Dynamic DMX patch.

 In the Style section, change the style of the LEDs that were used in 
the LED Wall.
 Single: Choose this option to use single LEDs which produce Red, 

Green and Blue.
 Triplet: Choose this option to use LED clusters comprised of Red, 

Green and Blue LEDs.
 In the Units section, change the measurement unit that were used 

in the LED Wall.
 Metric: Choose this option to specify the measurements in meters.
 Imperial: Choose this option to specify the measurements in feet 

and inches.
 In the Shape section, change the shape of the individual LEDs used 

in the LED Wall.
 Round: Choose this option if you want the shape of the Single or 

Triplet LED to be round.
 Rectangular: Choose this option if you want the shape of the Single 

or Triplet LED to be a rectangle.
 In the Dimensions section, change the layout properties of the LED 

Wall.
 Number of columns: Type the number of columns in the grid.
 Number of rows: Type the number of rows in the grid.
 Offset rows: Select this checkbox to offset the rows in the grid by 

one-half of the Horizontal Pitch.
 Specify By: Change the parameters that were used in the LED Wall 

by selecting from the drop-down list.
 Width: Type the overall width of the LED Wall.
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 Height: Type the overall height of the LED Wall.
 Horizontal Pitch: Type the horizontal center-to-center distance 

between LEDs in the LED Wall.
 Vertical Pitch: Type the vertical center-to-center distance between 

LEDs in the LED Wall.
 Side Borders: Type the distance between the left edge of the LED 

Wall and the edge of the left-most column of LEDs. The same 
value will be applied to the bottom row of LEDs.

 Top/Bot. Borders: Type the distance between the top edge of the 
LED Wall and the edge of the top row of LEDs. The same value will 
be applied to the bottom of the device.
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Camera Manager

Introduction

The Camera Manager enables you to view and set the properties of 
Camera objects and Camera Paths in a convenient way. The Camera 
Manager window opens in CAD, DESIGN and LIVE mode, and shows the 
following:

 The editable settings for New Camera Defaults showing Layer, Field 
Angle and Aspect Ratio.

 The option to Override all Cameras’ Aspect Ratio checkbox.
 The editable settings for Dynamic Camera Control showing Universe 

and Address.
 The table with the list of Camera objects inserted in the plot and their 

settings: Camera Name, Lock, Hotkey, Field Angle, Aspect Ratio and 
DMX Value.

 The table with the list of Camera Paths created in the plot and their 
settings: Camera Path Name, Show Path, Node Number, Aspect Ratio 
and DMX Patch.

 The option to Enable DMX Control of Cameras/Camera Paths 
checkbox.
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To access the Camera Manager

1 From the Managers menu, choose Camera Manager.

Result: The Camera Manager window appears.

To edit Camera and Camera Path properties in Camera 
Manager

1 In the Camera Manager window, you can change any of the following 
properties:

 New Camera Defaults: This section shows the default 
properties set for a new Camera object that will be inserted in the 
drawing.

 Layer: You can specify the default layer of the new Camera 
objects.

 Field Angle: You can specify the default Field Angle (degrees) of 
the new Camera objects.

 Aspect Ratio: You can specify the default fixed Aspect Ratio of 
the new Camera objects.
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 Override Aspect Ratio: This section shows the option to change 
the Aspect Ratios for all Cameras. 

 Override all Cameras’ Aspect Ratio - Display at: Select this checkbox 
to override the Aspect Ratios for all Cameras and click a 
temporary Aspect Ratio from the drop-down list to view all 
Cameras in your drawing.

Note: All previously set Aspect Ratios are preserved in the table, and 
can be used after this option is disabled.
 Dynamic Camera Switching: Use the Universe drop-down list 

and the Address box to set the DMX channel that will control 
switching between Standard Cameras. Sending a DMX value of 0 
(zero) on this channel switches to the World Camera. All other 
values, from 1 to 255, switches to the Standard Camera assigned 
to that value in the DMX Value column in the Camera table below 
it.

 Universe: Click this drop-down list to select the patch Universe 
for Dynamic Camera Switching. Click on the ellipsis button [...] to 
create a new universe.

 Address: Type the DMX address (DMX channel) for the Universe 
above, which controls Dynamic Camera Switching.

 Camera: This section shows the list of Camera objects inserted 
in the plot with their corresponding properties.

 Camera Name: Click the Camera name cell to edit the Camera’s 
name.

 Lock: Select this checkbox to Lock the selected Camera in the 
Shaded view.

 Hotkey: Click this drop-down list to assign a new numbered 
Hotkey for the selected Camera.

 Field Angle: Click the Field Angle cell and write the new Field 
Angle (degrees) for the selected Camera.

 Aspect Ratio: Click the drop-down list to select a new fixed 
Aspect Ratio for the selected Camera. This option is disabled 
when Override all Cameras’ Aspect Ratio is checked.

 DMX Value: This column displays the DMX value that was set in 
Camera Properties. You can select the value from this column 
drop-down list if it was not previously set in the Camera 
Properties.

 Camera Path: this section displays the list of Camera Paths 
created in the plot.

 Camera Path Name: Click the Camera Path Name cell to edit the 
Camera Path’s name.

 Show Path: Select this checkbox to show the selected Camera 
Path.
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 Node: Select this checkbox to show the Nodes created along 
the selected Camera Path.

 Node Num: Select this checkbox to show the Numbers assigned 
to each of the Nodes along the selected Camera Path.

 Aspect Ratio: Click the drop-down list to select a new fixed 
Aspect Ratio for the selected Camera Path. This option is 
disabled when Override all Cameras’ Aspect Ratio is checked

 DMX Patch: if the Camera Path is patched, click the DMX Patch 
box and enter the DMX value of the selected Camera Path.

 Enable DMX Control of Cameras/Camera Paths: Select this checkbox to 
enable Dynamic Camera Switching and DMX control of Camera Paths’ 
playback. When selected, the drop-down list on the Camera 
toolbar is disabled, and the only way to switch between cameras 
is by assigning the corresponding DMX values (i.e. those defined 
in the Camera table) from the connected console, on the DMX 
universe/address that were set in Dynamic Camera Switching section 
above. 

           Notes:

 Selecting the Enable DMX Control of Cameras/Camera Paths 
checkbox has the same effect as selecting the Use DMX for 
Cameras button on the Camera toolbar and the two are always 
in sync.

 In Live mode, the Current Camera drop-down list on the Camera 
toolbar, the Camera Hotkeys and the Camera Path drop-down 
list and playback controls on the Timeline tool are disabled 
when the Use DMX for Cameras button is enabled. These 
checkbox and button do not affect Design mode (even when 
using WYSIWYG Perform).

 The disabled Current Camera drop-down list will keep updating 
to display the name of the current Camera view that is active.

2 Click Apply to activate the changes.
3 Click OK.
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Video Manager

Introduction

You can bring a live or pre-recorded video into WYSIWYG and play it back 
while you set looks in Design mode and while you precue in Live mode. 

The Video Manager enables you to create video sources and subsources 
(and even split these subsources further or clone existing subsources), or 
videos from drawn I-Mag Cameras which you can then assign to screens, 
3D primitives (surfaces, risers, spheres, cylinders, and cones), LED 
Walls, and to projectors that you have inserted in your file from the Video 
Projection section of the Fixtures library.

Note: The Video Manager window can be resized to accommodate videos 
that have a higher or wider aspect then the default window size.

Live video comes from an external source, such as a video capture 
device, or a CITP/MSEX video stream from a media server. Pre-recorded 
video comes from video files, either in AVI or MPG format. 

Live or pre-recorded video can also be accessed in real-time from 
multiple video sources in the IP space through the NDI™ (Network 
Device Interface) streaming standard.

Note: If you cannot view these file types, you may not have the proper 
CODEC installed on your PC. Install the appropriate CODEC, and then try 
viewing the file again. 
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Video sources can be split it up into subsources. This enables you to 
apply portions of the video to multiple screens, 3D primitives, LED Walls, 
or projectors. For details, see “Splitting video into subsources”. 

Video source from the I-Mag Camera will display the view from Cameras 
drawn in WYSIWYG which can be applied to the Screens, LED Walls and 
Video Projectors.

To play the video, you use the Video Designer tool in Design mode. For 
more information, see “To use the Video tool”. You can view the video in 
any of the shaded views, using the controls on the Video Designer tool to 
pause, fast forward, rewind, or stop the video. 

You can also patch the control of the video source to a console. This 
means that you can use the console to control the progress of a live 
video stream or a video file by making the video play, pause, fast-
forward, or rewind; you cannot use WYSIWYG to change different 
aspects of the video itself.

To control the video source, the DMX patch is given three channels. For 
details on controlling the video with the console device in Live mode, see 
“To control a DMX patched video source with a console”.

Notes: 

 Before you render your drawing, you can either pause the video at 
the precise image you want to see in the final rendering, or you can 
let the video run while the Render Wizard processes the information 
in your drawing. In this case, the Render Wizard captures the video 
frame that was showing when it processed the screen information. 

 If the video control is patched and DMX connected in Live Mode, then 
you will not be able to control the video using any of the Video 
Designer tool commands in Design mode. Video sources can only be 
controlled by a Designer tool when the DMX source is disconnected; 
therefore, you must first disconnect the applicable console from Live 
Mode before using any of the Video Designer tool commands.

 For details on drawing screens, see “To draw a screen”.
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To access the Video Manager

1 In CAD mode, select Managers > Video Manager.

Result: The Video Manager appears.



656

CAD mode - Multimedia Sources and Rendering  R42

To create a new video source in the Video Manager

1 In the Video Manager, click the New Video Source icon.

2 The Video Source window appears. 
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3 Browse to locate the video on your computer, and then click OK.
Result: The Video is added as a source. 

Notes: 
 List of Video sources

 Name: The video’s file name.

 Border: When there are subsources, the Border columns shows 
the border color. To change the border color, click in the box 
and choose the new color from the color picker that appears.

 Source: The path to the physical file.

 Dimensions: The file’s dimensions in pixels.

 In Use: Informs you of whether the video source is in use. If 
the video source is currently in use, it cannot be deleted from 
the Video Manager.

 Mute: Indicates if the sound has been muted in the video.

 Patch: Indicates if the video source has been patched.

 Display Settings

 Show video at: Select the zoom level for the video. You can 
choose to Fit the video in the display window, or show it at a 
percentage of its actual size: 100%, 200% or 300%.

 Placeholder: Select this option to display the placeholder that 
was set in the Source Properties section.

 Borders: Select this option to show the subsource borders in 
the display.
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 Selected Only: When you have selected a subsource in the 
table, select this checkbox to only show the subsource in the 
display area; if you do not select this checkbox when a 
subsource is selected, the entire source is shown (with the 
subsource borders highlighted in the display if you selected 
Borders). 

 Grab New Video Frame For Preview: Click this button to display a 
preview frame for CITP Video Stream and Video Capture 
sources.

 Source Properties:
 Source Name: The video file’s name.

 Placeholder: Select the image file that was created in Image 
Manager, or click New to create a new placeholder image in 
Image Manager.

 Flip Horizontal: Select this option to flip the video source 
horizontally.

 Flip Vertical: Select this option to flip the video source vertically.

 4-byte Alignment: Select this option to align the pixels of a 
distorted video image. The 4-byte Alignment checkbox is 
automatically available only if the video source requires the 
alignment.

 For details on patching the video control in Data mode, see “To patch 
the control of a video source”.

 For details on using the Video Designer tool to play the video in 
Design mode, see “To use the Video tool”.

 For details on using a console device to control the video in Live 
mode, see “To control a DMX patched video source with a console”.

Splitting video into subsources
After you set up the video source in the Video Manager (see “To configure 
a new video source for streaming video”), you can take the video source 
(video file, capture card, or CITP) and literally split it up into subsources 
that you can apply to multiple screens, 3D primitives, LED Walls, or 
projector-style fixtures that you have inserted from the Video Projection 
section of the Fixtures library. 

To do so, you click the Split Video tab in the Video Manager, select a video 
source that you set up, and then split it either manually (by defining the 
pixel coordinates of each split) or automatically/evenly (by setting the 
number of rows and columns). You can then split these subsources 
further, if desired.

Once you split the video into subsources, you can attach the subsources 
to the objects that you want to use to display the video, just as you 
would attach a regular video source, and then play the video using the 
Video Designer tool (Design or Live modes) or via DMX control.
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To create a single video subsource

1 In the left pane of the Video Manager, click to highlight the image for 
which you want to create a subsource.

2 In the bottom left corner of the window, click Single Subsource - create 
one.

3 Type the subsource name.
4 By default, the system uses the start and end coordinates of the 

selected source, but you can change these values as desired. When 
you change these values, the system automatically updates the 
dimensions:
 Start Coordinate: Type the starting coordinate for the subsource 

(the top-left corner of the subsource) in the format "x,y", where x 
is the horizontal coordinate and y is the vertical coordinate. Note 
that the coordinate system uses the top-left corner as the origin 
(0,0). Also note that when video is shown at 100-300%, a tooltip 
appears under the cursor, indicating its position.

 End Coordinate: Type the ending coordinate for the subsource (the 
bottom-right corner of the subsource) in the format "x,y", where 
x is the horizontal coordinate and y is the vertical coordinate. 
Note that the coordinate system uses the top-left corner as the 
origin (0,0). 

5 Click the Border box to specify the color of the border that will appear 
around the subsource when displayed.

6 Click OK.
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To create multiple video subsources

1 In the left pane of the Video Manager, click to highlight the video for 
which you want to create subsources.

2 In the bottom left corner of the window, click Multiple Subsources - 
create many.

3 Type the subsource name. 
4 Define the subsource matrix by specifying the number of columns 

and rows. The dimensions of the subsources are displayed for your 
reference:
 Number of columns: Type the number of columns of subsources to 

be generated. If the video resolution cannot be equally divided by 
this number, the remaining pixels will be left at the end (for the 
horizontal pixels this means the ones at the far right, and for the 
vertical pixels this means the ones at the bottom).

 Number of rows: Type the number of rows of subsources to be 
generated. If the video resolution cannot be equally divided by 
this number, there will be a few gaps in the generated subsource 
grid.

5 By default, the subsources are created by taking the overall source 
area (height & width) and evenly dividing it by matrix provided. 
However, you can modify the total area by changing the start/end 
coordinates and, therefore, the overall dimensions used to create the 
subsources. To do so, select the checkbox beside Modify total area for 
subsources, and then enter the appropriate values:
 Start Coordinate: Type the starting coordinate for the subsource 

(the top-left corner of the subsource) in the format "x,y", where x 
is the horizontal coordinate and y is the vertical coordinate. Note 
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that the coordinate system uses the top-left corner as the origin 
(0,0). Also note that when video is shown at 100-300%, a tooltip 
appears under the cursor, indicating its position.

 End Coordinate: Type the ending coordinate for the subsource (the 
bottom-right corner of the subsource) in the format "x,y", where 
x is the horizontal coordinate and y is the vertical coordinate. 
Note that the coordinate system uses the top-left corner as the 
origin (0,0). 

6 Click OK.
Result: The following graphic shows a video with nine subsources 
(three columns and three rows).

 

Notes: 

 Subsources are always listed below the source from which they were 
created.

 The table in the Video Manager provides a convenient way of 
displaying source/subsource information; all sources and their 
subsources are grouped, and can be expanded/collapsed.

 You can rearrange the columns in the table by clicking the column 
header and dragging it to the new position. 

 You can adjust the width of columns by clicking the column border 
and dragging the column to its new width. 
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To clone an existing subsource to a new video

1 In the left pane of the Video Manager, click to highlight the video you 
want to clone a subsource to.

2 In the bottom left corner of the window, click Clone From Existing 
Subsources.

3 Select the media type that contains the subsource you want to clone, 
either Image Sources or Video Sources. 

4 Select the desired subsource from the corresponding source drop-
down list.

5 Enter a name for the cloned subsource in the Subsource Prefix field.
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6 Click Apply.
Result: The selected subsource will be cloned and applied to the 
selected video.

Changing the properties of video sources and subsources

Note: If you change the source after the subsources were created, and 
the new source has different dimensions that do not match the 
subsources dimensions, the affected subsources are highlighted in yellow 
(and a dialog box appears to notify you as such).

When you select a row in the Video Manager table, the properties of the 
video source or subsource are displayed in the Source Properties area of 
the window. You can change various properties of the video source and 
subsources as follows:

 To change the border color of video subsources, in the table, click 
the appropriate border color and then click the drop-down list box 
that appears to select the new color. Click Update.

 To change the name of the video source or subsource, in the table, 
click the appropriate row. Type the new name, and then click Update. 

 If you have already applied a video to multiple objects, and then you 
want to replace the source file with something different, you can 
make the change once in the Video Manager and have it 
automatically applied to all related objects (i.e., you don’t have to 
individually apply the changes to each object's properties). To do so, 
you change the underlying source file to the Video name. 

 You can define a subsource either by its start/end coordinates or by 
its dimensions:
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 To resize the subsource, click the appropriate row in the table. 
Change the start/end coordinates as desired, and then click 
Update. Note that if you change the coordinates, the system 
updates the dimensions automatically. 

 To change the dimensions of a subsource, click the appropriate 
row and then type the new dimensions. Note that when you 
change the dimensions, the system will automatically add to the 
start coordinate to determine a new end coordinate. Click Update.

Note: You can use the Quick Video/Image Tool to apply the Video 
Subsources. For details, see “Using the quick video/image tool”.

I-Mag camera screens from WYSIWYG camera
The view from a camera drawn in WYSIWYG which will be applied to the 
Screens, LED Walls, Video Projectors or any object that can display 
video.

To create an I-Mag Camera in the Video Manager

1 In the Video Manager, click the New icon. 

Result: The Video Source window appears.

2 Type the Name of the Video Source.
3 Click Camera (I-Mag) and select a Camera name from the drop-down 

list.
4 Set the Patch section (Optional, can be left as “None”).
5 Click OK.

Image placeholder for video
Instead of displaying the visuals of a selected video on screens, 
WYSIWYG allows for an image to be shown instead as a placeholder. The 
image has to be created in the Image Manager in WYSIWYG. See “Image 
Manager” for more information on how to create an image for use on 
screens.

To use an image as a placeholder

1 In the left pane of the Video Manager, click to highlight the video you 
want to add an image placeholder to

2 In the bottom center of the window, in the Placeholder drop-down list, 
select a previously created image to act as a placeholder for the 
selected video
Note: If the desired image has not yet been created, click New.... The 
Image Manager will open and you can then create an image to be a 
video placeholder. See “Image Manager” for more information.
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3 Click Apply.
Result: The selected image will now be displayed instead of the 
associated video in WYSIWYG.

Video stream
To create a new video source for streaming video, you use the Video 
Manager. There are a couple of ways of opening the Video Manager (for 
example, from the New Screen window, or from the Managers menu); 
the following procedure lists one possible way.

Note: You can only incorporate live video if you have WYSIWYG Perform; 
you cannot use a live video from a video capture device or video 
streaming via CITP/MSEX or NDI™ if you have WYSIWYG Design.

To configure a new video source for streaming video

1 Click Managers > Video Manager. 

2 Click the New Video Source icon in the upper-left corner.
Result: The Video Source window appears.

3 In the Name box, type a descriptive name for the video.
4 In the Input section, select and configure the new video source.

 Video File: To play a video from a file, click the Video File radio 
button, and then click Browse to locate the file.

 Video Capture: To capture a live video stream from an external 
source, such as a web cam or a video capture device that is 
attached to your computer, click Video Capture, and then use the 
drop-down arrow to select the appropriate device. (This option is 
available only if you are running WYSIWYG Perform.) WYSIWYG 
will detect what standard resolutions the capture device can 
support, and display them in the Resolution drop-down list box; 
click this drop-down list to choose your preferred resolution.

 If you select a video capture option, configure the Input and 
Resolution values for the device:

 Input: Choose between various inputs found on video capture 
devices (e.g., HDMI, DVI, S-Video, and so on). 

 Resolution: Select the resolution of the incoming video, 
provided that multiple resolutions are available from the 
selected input.

Note: The video capture device must already be configured on your 
computer and must be using WDM drivers. Also, it must not be 
currently in use by another application.
 CITP Video Stream: To stream video from a media server on your 

network, first ensure that the CITP Interface option is enabled on 
the Application Options > Additional Interfaces tab, as detailed on 
page “Additional Interfaces tab”. (This option is only available if 
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you are running WYSIWYG Perform.) Then, click CITP Video Stream 
and click Browse to select one of the media servers from the 
network. If you have just enabled this option, you will need to 
restart WYSIWYG before the CITP interface is turned on.

Note: In order for the media servers to be detected, they must be in 
the same logical network as your WYSIWYG computer and all 
firewalls (on your WYSIWYG computer, on the media servers, if 
applicable, and so on) must be disabled. For more information about 
how to correctly assign IP addresses for this purpose, consult your 
Media Server and/or Microsoft Windows documentation.
 If your media server is capable of outputting several video 

streams at once, you may select which output/stream to connect 
to by entering the number of the output/stream in the Video Num 
box. If you leave the default value of 0, WYSIWYG will connect to 
the first output; if you enter the number 1, WYSIWYG connects to 
the second output/stream of the same media server; the number 
2 connects to the third output/stream, and so on.

 NDI™ Source: Use the Network Device Standard to stream video in 
real-time from an external device within the IP space. NDI™ is a 
standard that allows multiple video systems to encode, transmit 
and receive streams of high quality, low latency, frame-accurate 
video over an IP in real-time. For more information on NDI™, 
click More Info to see the link http://ndi.newtek.com/ and access 
basic NDI™ tools from NewTek.1

Note: NDI™ video streams will be detected when they are in the 
same logical network as your WYSIWYG computer.

5 To control video playback via DMX, click DMX Patch, and then use the 
drop-down arrow to select the appropriate patch universe to control 
the video. In the box to the right of the drop-down list, type the 
starting DMX address. 
Note: A patch universe cannot be created from within the Video 
Manager window; if you wish to patch video control to DMX, you must 
create the necessary patch universe(s) before you open the Video 
Manager.

6 To mute the sound of the video, in the Video Manager table, select the 
checkbox in the Mute column. If this checkbox is not selected, the 
video’s sound will play.

7 Click OK. If the video is available, it connects automatically.
8 Click OK to save your changes and close the Video Manager.

1. NDI™ is a trademark of NewTek, Inc.
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Image Manager

Introduction

You can store images as sources in WYSIWYG using the Image Manager. 
By assigning textures to saved sources instead of to specific images, you 
can change or modify the texture of multiple objects at the same time 
using the Image Wizard.

The Image Manager also enables you to perform minor image 
modifications, such as flip horizontal or flip vertical to images without 
permanently changing the source file. This feature is useful in situations 
where the texture is flipped as a result of incorrect surface winding. For 
details, see “Drawing surfaces”.

You can use the Image Manager to create subsources of an image (i.e., 
divide the image up), which can then be applied to objects such as 
surfaces, screens, LED walls.
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Notes: 

 The Image Manager window preview can be resized to accommodate 
images that have a higher or wider aspect than the default window 
size.

 The Image Manager window preview will display a grey checker 
pattern to identify the alpha levels that are defined in an image.

 The maximum resolution of an image that can be imported into the 
Image Manager is equivalent to 4,194,304 pixels (2048 x 2048). You 
can import into the Image Manager, images that are very wide and not 
tall, or vice versa.

To access the Image Manager

1 In CAD mode, select Managers > Image Manager.

Result: The Image Manager appears.
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To create a new image source in the image manager

1 In the Image Manager, click New Image Source.

2 Browse to locate the image on your computer, and then click OK.
Result: The image is added as a source. 

Notes: 

 Source Name: The image’s file name.
 Source Path: The path to the physical file. Click the file open icon  

to select a new file.
 Flip Horizontal: Click this option to flip the image source horizontally. 

For details, see “To flip an image source”. Note that you cannot flip 
image subsources.

 Flip Vertical: Click this option to flip the image source vertically. For 
details, see “To flip an image source”. Note that you cannot flip 
image subsources.

 Dimensions: The file’s dimensions in pixels.
 In Use: Informs you of whether the image source is in use. If the 

image source is currently in use, it cannot be deleted from the Image 
Manager.

 Display Settings
 Show image at: Select the zoom level for the image. You can choose 

to Fit the image in the display window, or show it at a percentage 
of its actual size: 100%, 200% or 300%.

 Display Borders: Select this option to show the subsource borders in 
the display.
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 Display Selected Only: When you have selected a subsource in the 
table, select this checkbox to only show the subsource in the 
display area; if you do not select this checkbox when a subsource 
is selected, the entire source is shown (with the subsource borders 
highlighted in the display if you selected Display Borders). 

To flip an image source

In situations where a surface was drawn in a clockwise direction (see 
“Drawing surfaces”), the texture may appear to be “flipped” either 
horizontally or vertically. To avoid this problem, flip the image source 
using the Flip Horizontal or Flip Vertical checkboxes, as shown below. Note 
that you cannot flip image subsources; only the actual image source can 
be flipped.

1 Open the Image Manager.
2 In the table to the left, select the image source that you want to flip.
3 Based on the direction in which you want to flip the image, select 

either Flip Horizontal or Flip Vertical.
Result: The image is flipped, as shown in the following sample 
graphic, which was flipped vertically and horizontally.

To export an image source

After flipping the image, you may want to save your changes to a new 
image file as follows:

1 Open the Image Manager.
2 In the table to the left, select the image source that you want to 

export.
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3 Click the Save icon in the top left of the window.
4 Type a name and select a file type for the new image, or accept the 

default file type of PNG.
Note: When exporting an image source the default file type is PNG, 
but you can choose a different file type, if desired; when exporting a 
subsource, you cannot choose the file type. The subsource is 
exported to the same file type as its source. 

5 Click OK.

Missing images

If you have turned off the option Save external textures within the document 
in Application Options > File Options, when you move image files from 
their original location, they may not load from within WYSIWYG. When 
this happens, the image source will be highlighted in red, as shown in the 
following graphic:

To address this issue, select the image source highlighted in red, click 
the folder icon beside the Path box, and browse to select a new image. 
When you are finished, click OK.

Creating image subsources

Just as with videos, you can create one subsource or multiple subsources 
from an image using the following procedures. Image subsources are 
useful in scenarios where you need to apply part of an image to one 
object and another. Normally, to do so you would need to open the image 
in a photo editing software program, make your edits, crop the image, 
and then import two images. However, with the image subsource 
creation feature, you can just import the source file, and create the 
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necessary subsources within WYSIWYG. For example, you could use this 
procedure if you have a photo that you want to break into quadrants (2 x 
2), and then apply each quadrant to a separate surface, screen or LED 
wall, etc.

To create a single image subsource

1 In the left pane of the Image Manager, click to highlight the image 
which you want to create a subsource for.

2 In the bottom left corner of the window, click Single Subsource - create 
one.

3 Type the subsource name.
4 By default, the system uses the start and end coordinates of the 

selected source, but you can change these values as desired. When 
you change these values, the system automatically updates the 
dimensions. 

5 Click the Border box to specify the color of the border that will appear 
around the subsource when displayed.

6 Click OK.
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To create multiple image subsources

1 In the left pane of the Image Manager, click to highlight the image 
which you want to create subsources for.

2 In the bottom left corner of the window, click Multiple Subsources - 
create many.

3 Type the subsource name. 
4 Define the subsource matrix by specifying the number of columns 

and rows. The dimensions of the subsources are displayed for your 
reference.

5 By default, the subsources are created by taking the overall source 
area (height & width) and evenly dividing it by matrix provided. 
However, you can modify the total area by changing the start/end 
coordinates and, therefore, the overall dimensions used to create the 
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subsources. To do so, select the checkbox beside Modify total area for 
subsources, and then type the new coordinates.

Notes: 

 Subsources are always listed below the source from which they were 
created.

 The table in the Image Manager provides a convenient way of 
displaying source/subsource information; all sources and their 
subsources are grouped, and can be expanded/collapsed.

 You can rearrange the columns in the table by clicking the column 
header and dragging it to the new position. 

 You can adjust the width of columns by clicking the column border 
and dragging the column to its new width. 
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To clone an existing subsource to a new image

1 In the left pane of the Image Manager, click to highlight the image you 
want to clone a subsource to.

2 In the bottom left corner of the window, click Clone From Existing 
Subsources.

3 Select the media type that contains the subsource you want to clone, 
either Image Sources or Video Sources. 

4 Select the desired subsource from the corresponding source drop-
down list.

5 Enter a name for the cloned subsource in the Subsource Prefix field.
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6 Click Apply.
Result: The selected subsource will be cloned and applied to the 
selected image.

Changing the properties of image sources and subsources

Note: If you change the source after the subsources were created, and 
the new source has different dimensions that do not match the 
subsources dimensions, the affected subsources are highlighted in yellow 
(and a dialog box appears to notify you as such).

When you select a row in the Image Manager table, the properties of the 
image source or subsource are displayed in the Source Properties area of 
the window. You can change various properties of the image source and 
subsources as follows:

 To change the border color of image subsources, in the table, click 
the appropriate border color and then click the drop-down list box 
that appears to select the new color. Click Update.

 To change the name of the image source or subsource, in the table, 
click the appropriate row. Type the new name, and then click Update. 

 If you have already applied an image to multiple objects, and then 
you want to replace the source file with something different, you can 
make the change once in the Image Manager and have it automatically 
applied to all related objects (i.e., you don’t have to individually 
apply the changes to each object's properties). To do so, you change 
the underlying source file to the Image name. 

 You can define a subsource either by its start/end coordinates or by 
its dimensions:
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 To resize the subsource, click the appropriate row in the table. 
Change the start/end coordinates as desired, and then click 
Update. Note that if you change the coordinates, the system 
updates the dimensions automatically. 

 To change the dimensions of a subsource, click the appropriate 
row and then type the new dimensions. Note that when you 
change the dimensions, the system will automatically add to the 
start coordinate to determine a new end coordinate. Click Update.

Note: You can use the Quick Video/Image Tool to apply the Image 
Subsources. For details, see “Using the quick video/image tool”.

Using the quick video/image tool

The Quick Video/Image Tool enables you to quickly configure which video 
sources / subsources or images to attach to selected objects like screens 
and LED Walls in your drawing. 

To use the Quick Video/Image Tool

Note: Before you use the Quick Video/Image Tool, you must already have 
created the video source and/or subsources or images that you want to 
apply to the selected object(s). For details, see “To configure a new video 
source for streaming video” and “To create a single video subsource”.
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1 From the Tools menu, choose Quick Video/Image Tool.

Tip: Alternately, you can click the Quick Image/Video Tool icon on the 
Tools toolbar. 

 

2 In the Source Type section, select whether you want to apply either a 
video or image source, and then choose the source from the 
appropriate drop-down list.

3 Under Source Options, choose from one of the following options:
 Use the entire source: Select this option if you wish to apply the 

entire source (as opposed to its subsources). Proceed directly to 
step 12.

 Use a single subsource: Select this option if you wish to apply a 
single subsource, and then choose the subsource from the drop-
down list. Proceed directly to step 12.

 Use Multi-Split subsources: Select this option if you wish to apply 
Multi-Split subsources. This option will start at a specified 
subsource and increment the rows and/or columns until it 
reaches an ending subsource, at which point the tool will finish 
automatically.

4 If you have chosen Use Multi-Split subsources above, from the Subsource 
prefix drop-down list, select the Multi-Split subsource prefix to apply.

5 Note the # of rows and columns shown. These values denote the 
number of rows and columns available for this Multi-Split subsource 
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prefix. The Starting and Ending Row, and the Starting and Ending 
Columns may not exceed these numbers.

6 In the Starting Subsource - Row box, enter the row of the starting 
subsource. It may not exceed the number of rows for this subsource 
prefix.

7 In the Starting Subsource - Column box, enter the column of the starting 
subsource. It may not exceed the number of columns for this 
subsource prefix.

8 In the Ending Subsource - Row box, enter the row of the ending 
subsource. It may not exceed the number of rows for this subsource 
prefix, and cannot be less than the starting subsource's row value.

9 In the Ending Subsource - Column box, enter the column of the ending 
subsource. It may not exceed the number of rows for this subsource 
prefix, and cannot be less than the starting subsource's column 
value.

10 Under Increment Mode, choose the appropriate option:
 Click Left to right if you want subsources to be applied from left to 

right. This way, subsources on the same row will be applied first, 
and the current row will move down once all subsources on the 
current row have been applied.

 Click Top to bottom if you want subsources to be applied from top 
to bottom. This way, subsources on the same column will be 
applied first, and the current column will move right once all 
subsources on the current column have been applied. 

11 Click OK. The cursor will show a “Q”, indicating that Quick Tools have 
been activated.

12 Click an object, or multiple objects in sequence to apply the video/
image source or subsource(s) that you have chosen.
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Rendering

Introduction

At any time in CAD mode, you can generate a rendering of your set. Note 
that renderings in CAD mode are primarily intended for rendering your 
set with environmental lighting, but without theatrical lighting. However, 
if there are any fixtures selected on your plot, they are displayed in your 
rendering. 

Note: To queue your render jobs and process them independently, you 
can use the Background Rendering Manager (all levels of WYSIWYG 
except Report and Perform - Console Edition). For details on this feature, 
see “Background Rendering Manager”.

To render a lighting look

1 In the working area of the screen, display the lighting look that you 
want to render.

2 From the Tools menu, choose Render.
Tip: You can also click the Render Wizard tool on the View toolbar.

Result: The Render Wizard opens and guides you through a series of 
options. Click Next and Back to navigate through the Render Wizard.

3 Click Finish. 
Result: WYSIWYG generates the rendering of your lighting look or 
cue. If the rendering is saved internally, it is available as an image in 
Presentation mode.

Note: For more information, see “Rendering”.

 The Render Wizard button.
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Data mode

Data mode enables you to view and edit the data for all your 
fixtures. Data mode operates like many other spreadsheet 
programs, so many of the concepts will be familiar to those who 
have used a spreadsheet program.

In this chapter
Layout tabs 683

Spreadsheets 684

Patch 701

Errors 714
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Layout tabs

Introduction

Beneath the work area in each mode is a series of Layout tabs. These 
layouts provide various configurations of the views you are working with. 
To change layouts, click the tab that corresponds to the layout you wish 
to use. 

The Data mode contains the following layouts:

 Spreadsheet: The work area contains a spreadsheet of data currently 
in the show database.

 H Select: The work area is split horizontally, with a wireframe view 
above and a spreadsheet view below.

 V Select: The work area is split vertically, with a wireframe view on 
the left and a spreadsheet view on the right.

 Patch: The work area is split, with a wireframe view above and the 
patch window below.

 Errors: The work area contains a spreadsheet displaying fixtures with 
errors.

Note: The wireframe views in Data mode are used for fixture selection 
only. Any selections made in the spreadsheet are visible on the CAD 
drawing and vice versa. However, to make any drawing modifications, 
you must return to CAD mode.
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Spreadsheets

Introduction

The Data mode displays your fixture information in spreadsheet format. 
WYSIWYG compiles many spreadsheets that are accessible from the 
columns shortcut bar. All of these spreadsheets contain the same 
information, but are sorted and filtered differently. Each column in the 
spreadsheet represents one fixture attribute. The following information is 
compiled.

Data fields

Notes: 

 Data fields identified with an asterisk (*) are non-editable fields.
 Spot - This is an assigned identifier number usually used for 

automated fixtures. A spot number is required for automated 
fixtures when using AutoFocus.

 Channel - This is the assigned control channel number you will 
use at your control console to control the fixture. For moving 
lights, the channel number recorded in WYSIWYG is the starting 
channel number. 

 To use the AutoFocus feature properly, for most consoles, the 
Channel number that appears here must match the starting number 
of the fixture's DMX address. For example, if your Mac 500 is patched 
to universe "A" at address 101 (i.e., the Patch field reads "A.101"), 
you must enter the number 101 into this fixture's Channel field. This 
must be done manually because the automatic sequential numerical 
data entry method does not apply in this case. For details, see “To 
input sequential numerical data”.

 Data fields identified with an asterisk (*) are non-editable fields, and 
can be identified on the spreadsheet as tinted, if you enable the 
“Non-Editable Column Tint” option from the View Options or the Data 
Spreadsheets toolbar. 

Data fields
 Channel - The assigned channel of the fixture.
 Patch - This is the fixture’s assigned DMX channel number. This field 

is mandatory for simulation activity in Live mode. One show can have 
multiple DMX universes. A patch entry must be notated universe.#, 
where universe is a letter, number, or other label identifying the 
universe or output and # is the DMX channel number. For example, 
“A.1” or “Dim.26”. 

 Dimmer - This is the assigned dimmer number.
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 Spot - The spot ID of the fixture.
 Position - This is the hanging position for the fixture. Positions must 

be entered in the Position Manager. 
 Unit - The unit number identifies the fixture’s location on its 

respective hanging position.
 Type - This is the fixture name.
 Lens - This is the lens type.
 *Hookup - This identifies the component of a multi-circuit fixture or 

other device, such as a scroller (for example, intensity, control).
 Purpose - The purpose is a custom note that is most commonly 

used to describe how this fixture is being used in your show. For 
example, “SL Side”, “Diagonal Backs”. Purpose is an attribute of the 
fixture. It is not possible to assign multiple purposes for multi-circuit 
fixtures.

 Color - This is the assigned gel color number or scroller 
identification.

 Gobo - This is the assigned gobo number.
 Focus - This is the fixture’s focus position. 
 Circuit Name - This is an identifier note for the circuit box or multi-

cable.
 Circuit Number - This is the assigned circuit or multi-cable tail 

number.
 Mode - This is the fixture’s mode setting.
 Fixture Options - This is information on the fixtures options, e.g. 

the, reserved channels, lamp info, etc. 
 *Wattage - This is the wattage in watts of the lamp.
 Lamp Type - This is the lamp type.
 *Offset - This field identifies the fixture’s location on the hanging 

structure. It is a distance measurement referencing the pipe’s end or 
center point or another point as specified.

 *X - This field indicates the X coordinate of the fixture’s position.
 *Y - This field indicates the Y coordinate of the fixture’s position.
 *Z - This field indicates the Z coordinate of the fixture’s position.
 Pan - A focus attribute measured in degrees, defining the positioning 

of the fixtures yoke.
 Tilt - A focus attribute measured in degrees, defining the positioning 

of the fixture within the yoke.
 Spin - A focus attribute measured in degrees, defining the fixture’s 

yoke positioning in relation to the hang structure where 0 is down-
hung, 90 is side-hung, and 180 is over-hung for example.

 *Weight - This is the fixture’s weight. A fixture’s weight can only be 
modified through the Library Browser.

 Notes - This is a custom notes field.
 *Footnotes - This feature is currently disabled.
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 *# of Data Channels - This is the total number of DMX channels 
required by the fixture.

 *# of Color Frames - This is the number of color frame slots that 
the fixture has.

 *# of Lamps - This is the number of lamps required by the fixture.
 *Circuit Type - This describes what type of device the unit should 

be plugged into, for example, regular dimmer, scroller power supply.
 *Model - This is the fixture type.
 *Cost - This is the fixture’s cost or rental cost. This field is used to 

estimate a show budget. A fixture’s cost can only be modified 
through the Library Browser. For more information on setting costs, 
refer to “Data tab”.

 *Status - This is the fixture’s status relative to your drawing. If the 
fixture is HUNG it is in your drawing. If a fixture is UNHUNG, it is in 
the flight case. In fixture count reports, all fixtures are counted 
regardless of their status (unless a filter is applied).

 *Console - This identifies which console is controlling the fixture. 
This field references the binding settings in the device manager in 
Live mode.

 Layer - This field indicates which layer the fixture is drawn on.
 *Tag - This is an internal code used for importing and exporting data 

to/from third party programs.
 *Owner - This feature is currently disabled.
 Manufacturer - This field indicates the manufacturer of the fixture.
 Notes2 – Additional column for notes.
 Notes3 - Additional column for notes.
 Notes4 - Additional column for notes. 
 *RotX - The rotation of the fixture on the X axis.
 *RotY - The rotation of the fixture on the Y axis.
 *RotZ - The rotation of the fixture on the Z axis.
 *Patch Address - When a patch is specified for a fixture/accessory, 

this column just displays the starting address.
 *Patch Universe - When a patch is specified for a fixture/accessory, 

this column just displays the Universe it is patched on.
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Working in the spreadsheet

Data may be entered in a number of ways within the WYSIWYG file. The 
plot can be created, and then edited, or the data may be entered in a 
spreadsheet, and then placed on the plot. Any entries or changes are 
reciprocated throughout the file; changes made in Data mode will be 
updated in CAD mode and vice versa.

Selection
Standard selection functionality is offered in the DATA > Spreadsheets. 
Selected cells are highlighted in orange.

 To select one cell, just move your mouse over it and click. You will 
notice a blue outline appears around the cell.

 To select multiple cells, select your starting cell and either drag 
the mouse in any direction, or while holding the SHIFT key down, use 
the arrow buttons on the keyboard.

 To select non sequential cells, hold down the CTRL button and 
click with your mouse on the desired cells.

 To select an entire row, click on the row header (i.e. The left-most 
column which has the row numbers). 
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To add or modify data 

Select a cell, and type the desired value in the appropriate cell. Notice 
that some cells accept text (e.g. Channel column), so you click on them 
and start typing text. Some cells will display a drop-down menu when 
they are selected, so you can choose your data from the drop-down 
menu or type the desired option (e.g. Lens column).

The Spreadsheet has built in intelligence, and will not accept invalid data 
entry. For example, you cannot enter non-numerical data in the Channel 
column, (it will display an error message).

Columns that are read-only or non-editable cannot be modified from the 
Spreadsheet. These columns may be tinted slightly darker for easy 
identification from the View Options. 

Entering the same data into multiple cells
You can enter the same information to multiple cells at the same time by 
selecting a series of cells, typing your text in the first cell selected, and 
then pressing the ENTER button. You can also delete data in multiple 
cells at the same time by selecting the cells, and then pressing the 
DELETE button.

When entering data in some columns (such as Color and Gobo), a drop-
down menu will appear displaying some options to help you enter the 
data into the cell(s). For the Color column, for instance: 

 <None>: Select this option if no color is desired. 
 Multiple Gel Input: This option displays a dialog box where you can 

enter multiple gel manufacturer catalog codes for one fixture 
 Pick from Library: This opens the Library Browser and you can preview 

colors in the Gel Library 
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 List of previously used gels in your file: For your convenience all 
previously used gel color codes are displayed; click on the one you 
wish to use. 

To input sequential numerical data

If you are entering sequential numerical values for a field such as 
Channel or Spot, you can use incremental data entry to facilitate your 
work. WYSIWYG will calculate the next available value based on the 
number of required channels for the previous fixture. 

1 In a column, select a series of fixtures to enter incremental data, by 
using a selection method such as click and drag.

2 Enter in the first cell the starting value of the data, and then a plus 
sign ( + ).

Example: If the first channel in the selected fixtures should be 
101, enter “101 +” and then press ENTER. 

To assign sequential patch to fixtures 

If you are assigning a sequential patch for a list of fixtures, you can use 
incremental data entry to facilitate your work. WYSIWYG will calculate 
the next available value based on the number of required channels for 
the previous fixture. 
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1 Select the fixtures you want to patch sequentially.

2 In the first cell type “UniverseName. Starting Address +” 
Example: “F.1 +”

Note: You can skip channels between the patching of one fixture to 
the next. To specify the number of channels that should be skipped, 
add that number to the end of the equation “UniverseName . 
Starting Address + [# of channels to skip between patching]”. 

Example: “F.1 + 4”
3 Hit Enter.

Result: The selected fixtures are automatically sequentially patched.

To choose a new value

1 Select the appropriate cell.

2 If values are available, there will be a down arrow icon in the cell. 
Click the icon to see a list of available values. 

3 Select the value from the list.
Result: The cell will change to the selected value.

Inserting fixtures in data mode

Any fixtures inserted in Data mode are assigned the status “unhung” and 
are placed in the Flight Case. The Flight Case allows you to drag and drop 
“unhung” fixtures onto your drawing. For more information about the 
Flight Case, refer to “The Flight Case”.

Fixtures selected for multi-
fixture sequential patching. The 
example patch used is “F.1 +”

After performing the multi-fixture 
patching command, the fixtures 
are patched sequentially.
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To insert fixtures in Data mode

1 Click the Fixture tool on the Data toolbar.

2 Navigate to the desired fixture. 
3 In the Multiple box, type the number of fixtures of that type required.
4 Click Insert.

Result: The fixtures are inserted below the last entry in the 
spreadsheet.

Tip: If you have a shortcut created for the desired fixture, you can 
right-click on the shortcut and choose Insert or Insert Multiple.

Inserting positions in data mode

A position cannot exist in WYSIWYG unless it is recorded in the Position 
Manager. You can if you type a new value into the position field of a 
fixture, the Pick a value from the list dialog box is automatically displayed. 
This is because a position cannot exist in WYSIWYG unless it is recorded 
in the Position Manager. You can select from the list of positions that 
already exist or you can click Managers menu to open the Position Manager 
to create a new position.

If you are making this change to a fixture that was previously hung on a 
different position, that fixture will be unhung and sent to the Flight Case 
under its new position field. From there, you can drag it back onto the 
drawing.

If the position does not yet exist in the drawing, you must draw a hang 
structure and assign it the appropriate position name before you will be 
able to hang the fixture again. For more information on drawing hang 
structures, refer to “Hang structures”.

For more information on drawing items from the Flight Case, refer to 
“Entering and modifying objects in the Flight Case”.

Inserting color in data mode

To insert color in Data mode

1 Click in the color field of the fixture for which you want to assign 
color.

2 Click the drop-down menu in the cell and select either None, Multiple 
Gel Input..., or Pick from Library.
Note:  If you know the catalog code for the gel, you can type the gel 
code in the cell to choose it. For example, if you want Rosco's 

 The Fixture button.
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"Roscolux Light Red" gel, type "R26" in the cell and hit ENTER. 
Rosco's "Roscolux Light Red" gel will be selected.
a. Use Pick from Library to select a color among those you have 

already used in your plot. Selecting this option will bring up the 
Color Select window where you can locate the color you want from 
a library.

b. Use Multiple Gel Input... if you already know the color that you 
want to assign (for example, R54, L112, and so on). Selecting 
this option will bring up the Multiple Gel Input... window where you 
can enter the color you want.

WYSIWYG accommodates multiple color entries for one fixture as 
follows:

 “Color1 & Color2” yields two color frames with one gel in each.

 “Color1 + Color2” yields one color frame with two gels in it.

 “Color1 / Color2” yields one color frame with one split gel in it.

Customizing spreadsheets

There are different ways to sort and view your data. You can modify a 
spreadsheet to suit your needs. Customizing a view allows you to change 
how the data is displayed and sorted.
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To modify a data sheet

1 From the Options menu, choose View Options.

Result: The View Options window appears. 

Note: You can also click the View Options tool on the Standard toolbar. 

Note: You can also right-click on the Spreadsheet shortcut and 
select Properties. 

2 In the General tab, specify how the data sheet will be displayed.
3 In the Data Options tab, specify the information that will be displayed 

in the data sheet. 
4 Click OK.

General tab
Options on the General tab affect the current data sheet.

 Scene: 
 Follow Current Scene: Select this checkbox to use the currently 

selected scene. Clear and select a different scene from the Scenes 
drop-down list.

 Scene: Name of the Wireframe view.

 The View Options button.
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 Appearance Options
 Display Filter Bar: Select this checkbox to display filters below the 

headings of each column.
 Alternate Row Colors: Select this checkbox then click the Color Select 

boxes to choose display the rows in two alternating colors.
 Word Wrap: Select this checkbox to automatically wrap the text in 

every cell.
 Tint Non-editable Columns: Select this checkbox to highlight the 

columns with non-editable data. 
 Display Options

 List Accessories under their Fixture: Select this checkbox to display the 
list of accessories added to the fixtures in rows that follow after.

 Identify Accessories: Select this checkbox and select the symbol that 
identifies the listed accessory.

 Show Only Selected: Select this checkbox to display only the fixtures 
that are selected in CAD.

 Sort by Selected Order: Select this checkbox to display the selected 
fixtures according to the order of selection.

Data Options tab

 Detail Level
 Fixtures and Accessories: Select this drop-down menu to display the 

details of fixtures and accessories in the spreadsheet.
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 Fixtures: Select this drop-down menu to display the details of the 
fixtures only on the Spreadsheet. 

 Column Options
 Column: Use the column table to specify column display and order 

of appearance.
 To change the location of a column in the spreadsheet, highlight 

the appropriate column heading in the Columns box, and then click 
the Up or Down button. 

 To hide a column from your view, clear the checkbox beside it.
 Rename: Type a new name in the Rename column to rename the 

title of the column. 
 Alignment: Click the drop-down menu in this column and select the 

text alignment to either Left, Center, or Right.
 Bkgd Color: Click the Color Select box in this column to change the 

background color of the column. This can be used to highlight 
important columns in your spreadsheets.

 Float Selected Columns: Select this checkbox to undock the selected 
column in the spreadsheet.

 Sort Options
 Enable Heading Sort: Select this checkbox to enable the ability to 

sort the spreadsheet by clicking on the Column Headings. When 
you click on a column heading, it becomes the new Key 1 sort 
parameter, and the existing sorting options propagate down to Key 
2 and Key 3. Clicking on the same column heading again will 
switch the sort from ascending to descending, and vice versa.

 To specify how entries should be sorted, choose the desired 
column headings in the Key 1, Key 2, and Key 3 drop-down lists. 
When fixtures have the same value in the first sort key, the 
spreadsheet is then sorted by the values of the second sort key.

 Click Ascend or Descend to sort the criteria in ascending or 
descending order, respectively.

 Select the Group By checkbox to group the spreadsheet into 
sections, one section for each value in the Key 1 field.

Font Options:
To display the Spreadsheet with your preferred font settings, right-click 
on the Spreadsheet and select Set Font. Choose your preferred font, 
style, color, size, and script, and click OK. The text in the Spreadsheet is 
now displayed with your new font settings. 
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Column Heading:
Some column options are also listed if you right-click on the column 
heading.

 Hide Column: Hides current column (will not be displayed)
 Show All Columns: A convenient way to show all columns
 Select Column: Since clicking on the column heading will re-sort the 

spreadsheet if this option is enabled, the Select Column option offers 
an easy way to select the column.

 Enable Heading Sort: A convenient way to enable/disable the Column 
Heading sort option.

 Freeze Columns: The selected column and all the columns to the left 
of it will freeze and always visible when scrolling over horizontally to 
the right.

 AutoFit Selected Column: The selected column will automatically 
resize so that all text is visible.

 AutoFit All Columns: All the columns will automatically resize so that 
all text is visible.

Filter bar:

When enabled, the Filter Bar appears on the first row of the Spreadsheet. 
The Filter Bar offers an easy way to filter the Spreadsheet or search for 
exact text or fixtures in any column. The Filter Bar accepts text in 
multiple columns simultaneously making it easier to find a fixture in your 
Spreadsheet.
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Note: To clear a filter string, you can click the X button which appears at 
the right side of the column. If you have multiple filters, you can click the 
X button which is located above the row headers (very far left column 
with row numbers), and this clears all filter strings and displays all rows 
in the Spreadsheet are displayed again.

To apply a data filter using the Filter Bar

1 In the spreadsheet, click the filter bar on the column you want to 
filter.

2 Type the specific text, or select the data from a drop-down 
menu you want to filter for.
Result: The spreadsheet refreshes, displaying only fixtures that 
meet the filter criteria.

To remove data filters

In the spreadsheet, click the X button which appears at the right side of 
the column.

Note: If you have multiple filters, you can click the X button which is 
located above the row headers (very far left column with row numbers), 
and this clears all filter strings and displays all rows in the Spreadsheet 
are displayed again.

Result: The spreadsheet returns to its unfiltered state.

Finding and replacing text in the spreadsheet

Information found in cells can be quickly accessed and edited using the 
Find or the Find and Replace functions. Find allows you to search your 
spreadsheet for words or whole phrases, then selects the words when 
found. Find and Replace searches your spreadsheet the same as Find, but 
with the additional option to replace the words.

To find text in the spreadsheet

1 From the Edit menu, select Find.

2 Alternately, you can use the shortcut “Ctrl + F”. 
Result: The Find window will open.
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3 In the Find what field, type the text you want to search for.
4 Select the Match case checkbox to search for only words that match 

the exact case of the text entered in the Find what field.
5 In the Direction section, select Up or Down to search the 

spreadsheet in the chosen direction.
6 To search for the next instance of the chosen text, click Find Next. 

To find and replace text in the spreadsheet

1 From the Edit menu, select Find and Replace.

2 Alternately, you can use the shortcut “Ctrl + Shift + H”. 
Result: The Replace window will open.

3 In the Find what field, type the text you want to search for.
4 In the Replace with field, type the text you want to replace any found 

text with.
5 Select the Match case checkbox to search for only words that match 

the exact case of the text entered in the Find what field.
6 To search for the next instance of the chosen text, click Find Next. 
7 To replace found text with the text written in the Replace with field, 

click Replace.
8 To replace all instances of the found text with the text written in the 

Replace with field, click Replace All.

Grouping the spreadsheet by a column

The group by option is available for the Column in Key 1 sort, which 
groups the Spreadsheet into sections. Each section has a button which 
expands (+) and collapses (-) so you can choose if you wish to displays 
the rows of data in a group or not. 
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Freezing spreadsheet columns

The Freezing Column options allows you to keep your information in 
place as you scroll through the rest of the spreadsheet. This is useful if 
the spreadsheet is very large and you have headings that you want to 
stay in place.

To freeze spreadsheet columns

Right-click a column header, and select Freeze Columns.

To unfreeze spreadsheet columns

Right-click a column header, and select Unfreeze Columns.

Creating a new spreadsheet

To create a new sheet

1 On the shortcut bar, click the Columns tab.

2 Right-click on the shortcut bar and choose New Spreadsheet.

3 Type a name for the new spreadsheet, and then click OK.
4 Scroll to the bottom of the list of Column shortcuts. Your new 

spreadsheet name should be at the bottom of the list. Click on the 
shortcut to view your spreadsheet.

Note: It may be easier to clone an existing spreadsheet and modify it 
than to start a new one from scratch. See “To clone a shortcut” for more 
details.
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Exporting a spreadsheet

The Spreadsheet can be exported to numerous formats, in case you wish 
to use the spreadsheet data from you lighting show in a different 
program.

To export a spreadsheet

1 Select File > Export.

2 An Export File dialog box appears for you to enter a file name, and 
select a file type. Supported file types include: Microsoft Excel (.xlsx) 
and (.xls), HTML (.htm), Comma Separated Values (.csv), WYSIWYG 
Spreadsheet (.wss)

3 Another option in the File menu is to Export to Worksheet. This option 
automatically copies a snapshot of the Spreadsheet into the 
Worksheet tab. This is convenient at the end of a project, because a 
worksheet can be inserted into a Layout (a Spreadsheet cannot be 
inserted directly anymore).
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Patch 

Introduction

The Patch view is a graphical representation of the patch field. It is used 
for two purposes:

 To create and/or edit a patch for the lights, video, or moving scenery 
in your drawing. 

 To monitor incoming DMX levels when using WYSIWYG Perform for 
simulation.

 

Working in the patch view

You can view one patch universe at a time. As you add new patch 
universes in either a spreadsheet view or a CAD drawing (using Quick 
Tools), their shortcuts are created automatically. You can also create new 
patch universes directly from the shortcut bar.
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To create a new patch universe

1 Click the Patch layout tab.

2 Right-click in the patch shortcut area and choose New Patch.
Result: A dialog box appears, prompting for the type of universe 
that you want to create, and the name of the new universe. 

3 Type the name of the patch universe. Patch universes can be named 
anything. For example, “A”, “Dimmers”, “Dim”, “Movers”, “Scrollers”, 
and so on.

4 Select the type of patch universe based on the type of console or 
system that you are using, either a DMX console, EDMX or a motion 
control system.

5 Click OK.
Result: The patch shortcut appears in the Patch tab.

Notes: 

 To change, delete, or modify a patch universe, right-click the 
shortcut icon for the universe that you want to change. Click on the 
command that you want to perform.

 To display the contents of a patch universe, click on the appropriate 
shortcut icon. The name of the universe is displayed at the top left 
corner of the Wireframe view.

Fixture patching methods
There are multiple ways to patch fixtures in WYSIWYG. The following 
section will guide you through some of the ways fixtures can be patched.

To patch fixtures in the patch view

1 Click and hold the desired fixture in the Wireframe view.

2 Drag the fixture to the desired patch location.
3 For re-patching, repeat the above steps, or click and drag the 

fixture’s patch information to the new location.
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To unpatch fixtures in the patch view

1 Select the fixture by clicking on the first channel (start cell) for that 
fixture. It should become highlighted.

2 Right-click and choose Unpatch.
Result: The fixture is unpatched; the value in the patch field for that 
fixture is deleted.

To patch fixtures and assign spot IDs using Quick Tools

Using Quick Tools, fixtures can be patched and assigned spot IDs by 
clicking on their Wireframe view image. The first fixture clicked will be 
assigned the patch and ID as configured in Quick Tools. The next fixture 
clicked will be assigned the next available channel in the patch and the 
next fixture ID in the sequence until you are finished using Quick Tools.

1 In CAD mode, in Wireframe view, go to Tools > Quick Tools > Quick 
Tools. Alternately click the Quick Tools icon on the Tools toolbar.

Result: The Quick Fixture Tool window appears.

2 In the Quick Fixture Tool window, in the Control Data section, select 
the Spot checkbox. 

3 In the Spot field, enter a number which will be the first fixture ID 
used in the sequence.

4 In the Control Data section, select the Patch checkbox. 

 The Quick Tools button.
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5 In the Patch field, enter the universe and channel the first fixture will 
patching to, separated by a period. 

Example: “A.1” would patch to universe A, chapter 1.
Note: The Custom Increment checkbox offers two options: Additional, 
where the increment is added at the end of each fixture patched; and 
Total, which is the total increment to the next fixture’s address.

6 Click Ok
Result: When a fixture is clicked on, it will be assigned a Universe 
and channel to operate on. The first fixture clicked will be assigned 
the to the channel number entered in Quick Tools. Subsequent 
fixtures clicked will be assigned the next sequential channel and Spot 
ID number.

7 Click on a fixture to patch it to a universe and channel. Clicking on 
each fixture that you want patched and assigned a spot ID.

8 To stop patching fixtures, right-click.
9 In the menu that appears, click Finish Quick Tools.

To patch fixtures and assign spot IDs using the data 
spreadsheet

In DATA mode, the Spreadsheet view has information on all fixtures 
created in the WYSIWYG project. Using the spreadsheet you can edit the 
patch information and Spot ID directly in the table.
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1 In Data mode, click on the Spreadsheet tab.

2 In the Columns section on the left side of the window, click All Data 
(Sortable).

Result: All fixture data will be displayed in the spreadsheet. 

3 In the Patch column, enter the appropriate patch information for 
each fixture.
Tip: You can use incremental data entry to assign sequential patch 
for a list of fixtures.
a. Select the series of fixtures you want to patch sequentially.

b. In the first cell, type “UniverseName.Starting Address+”. 

Example: “F.1+”
4 In the Spot column, enter a unique Spot ID for each fixture.

Tip: You can use incremental data entry to enter sequential 
numerical values. 
a. In the Spot column, select a series of fixtures.
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b. Enter in the first cell type the starting value of the data, and then 
a plus sign (+).

Example: If the first Spot number in the selected fixtures is 101, 
enter “101+”, then press ENTER. 

Result: The fixtures after the first cell will be assigned the next 
available value. This can be repeated as necessary. If this method is 
used to assign values, it is recommend that fixtures are first sorted 
so fixtures are organized. Fixtures can be sorted in order of position, 
or Unit # along a pipe/truss.

To patch the control of a video source

In WYSIWYG, you patch the control of a video source, not the actual 
video. This means that you can use the console device to control the 
progress of a live video stream or a video file by making the video play, 
pause, or rewind; you cannot use WYSIWYG to change different aspects 
of the video itself.

To control the video source, the DMX patch is allocated three channels. 
For details on controlling the video with the console device in Live mode, 
see “To control a DMX patched video source with a console”.

1 In the shortcut area, click the Patch tab.

2 Click the patch shortcut to which you have linked control of the video 
source. 
Result: The video patch appears in the patch universe.

3 Open the console device that you have connected to the video DMX 
patch.

4 Using the console controls, set the appropriate levels for the three 
channels. For details, see “To control a DMX patched video source 
with a console”.

5 Save your settings.
6 In the Shaded tab of Live mode, you can now use the console device 

to control the progress of the video. For details, see “To control a 
DMX patched video source with a console”.

To patch a motion axis to a DMX console device

In WYSIWYG, you can patch a motion axis to which one or more objects 
has been attached, and then use a console device or a motion control 
system to control the progress of the objects along the axis. 

You have the choice of patching the axis to either a DMX patch universe 
or a motion control universe, based on the type of console or system you 
will be using to move the objects. For details on patching the axis to a 
motion control universe, see “To patch a motion axis to a motion control 
system”.
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To control the object’s movement with a DMX console device, the DMX 
patch is allocated two channels, one each for coarse and fine movement. 
The DMX value represents the object’s percentage of movement. For 
example, if it is at 0, then the object is at 0% of its range of motion; if it 
is at 100, then the object has moved 100% of its range of motion. For 
details on controlling the object with the console device in Live mode, see 
“To control a DMX patched motion axis with a console”.

Note: Before performing the following procedure, the motion axis must 
already be linked to the patch universe. For details, see “To patch a 
motion axis to a DMX universe”.

1 In the shortcut area, click the Patch tab.

2 Click the patch shortcut to which you have linked control of the 
moving object. 
Result: The moving scenery patch appears in the patch universe.

3 Open the console device that you have connected to the DMX patch 
(for example, the Mini Console).

4 Using the console controls, move the slider of the first or second 
channel to advance the object to the desired position on the motion 
axis.
Note: The first channel is for coarse movement and can be used to 
advance the object quickly to any position along the entire path, 
from start to finish. The second channel is for fine movement. Its 
movement range is very slight and depends on the position that you 
have set on the first channel. For details, see “To control a DMX 
patched motion axis with a console”.

5 In the Shaded tab of Live mode, you can now use the console device 
to control the object’s movement along the axis. For details, see “To 
control a DMX patched motion axis with a console”.

To patch a motion axis to a motion control system

In WYSIWYG, you can patch a motion axis to which one or more objects 
has been attached, and then use a console device or a motion control 
system to control the progress of the objects along the axis. 

You have the choice of patching the axis to either a DMX patch universe 
or a motion control universe, based on the type of console or system you 
will be using to move the objects. For details on patching the axis to a 
DMX patch universe, see “To patch a motion axis to a DMX console 
device”.

When controlling the object’s movement with a motion control system, 
the patch indicates the ID on the motion control system that corresponds 
to the WYSIWYG axis ID, the axis name, and the position of the object on 
its path. When connected to a system (or to WYSIWYG’s Motion Control 
Console), you can watch the object’s position change in patch view as it 
moves along its path.
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Note: Before performing this procedure, the motion axis must already be 
linked to the patch universe. For details, see “To patch a motion axis to a 
motion universe”.

1 In the shortcut area, click the Patch tab.

2 Click the patch shortcut to which you have linked control of the 
moving object. 
Result: The motion control patch appears in the patch universe.

3 Open the console device or motion control system that you have 
connected to the motion control patch (for example, the Motion 
Control Console, shown below).

4 If you are using WYSIWYG’S Motion Control Console, in the ID box, type 
the motion control ID that you selected when configuring the axis. If 
you are patching a Frame, enter the name of the frame.
Note: If you do not know the ID, right-click on the axis, and then 
click Properties. Click the Axis tab. The ID appears in the Motion Patch - 
ID box. 

5 In the Length box, type the distance (in meters for linear axes, in 
degrees for rotational axes) that you want the object to travel along 
or around the axis. This can be the full length/angle of the axis, or 
only a portion of it if you do not want the object to travel along/
around the full path. For linear axes, if you type a value that is longer 
than the actual axis, the object stops at the end of the physical axis.

6 Click the Linear or Rotational option button according to the type of 
motion axis that you are patching.

7 In the Mode area, select the type of movement for the object:
 Manual: Select this option if you want to specify the precise 

location of a static object on the motion axis. You can then use 
the position slider at the bottom of the window to adjust the 
position and control the movement of the object manually.
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 Bounce: Select this option if you want the object to move forward 
and backward in a continuous loop along the motion axis.

 Forward: Select this option if you want the object to move forward 
along the axis from start to finish, and then start over again at 
the beginning in a continuous forward loop.

 Backward: Select this option if you want the object to move 
backwards along the axis from finish to start, and then begin over 
again in a continuous backwards loop.

8 If you have chosen any moving Mode value (that is, any value except 
Static), you can specify the length of time (in seconds) over which 
you want the full range of motion to take place. Type this value in the 
Duration box. The larger the number you type in this box, the slower 
the object moves.

9 Select New Axis if you are adding a linear or rotational frame. Select 
New Frame if you are adding a frame to the patch.

10 Click Save to save your settings. 
Note:  If you make any changes to the axis settings and save the 
changes, you can revert to the previous settings by clicking Load.

11 To see the object moving along the axis, you must first ensure that 
the Motion Control Console or the motion control system that you are 
using is connected and that the patched axis is bound. For details, 
see “To connect to a console” and “To control a motion-control 
patched motion axis with a motion control system”.

Reading the patch

Each box in the patch universe represents one DMX channel. Fixtures are 
represented by colored bumps or bars that span the number of required 
DMX channels. The color of the bar is the same as the fixture’s CAD layer.

The number in the top left corner is the DMX address.

The spot number and fixture type are identified across the bottom of the 
box(es).

The fixture parameter controlled by each channel is identified in the 
center of the box.

If you are connected to a console and are receiving DMX signals, the 
incoming DMX levels are displayed in the top right corner of each box.
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Reading the patch for streaming video sources
If you have patched a live video source or file, the patch appears as 
shown below:

Reading the patch for moving scenery
If you have patched a motion axis, the patch appears as shown below:

 For linear motion axes, the position of the object is reported in either 
metric or imperial units (for example, 16m). 

 For rotational axes, the value is shown in degrees (for example, 
42°).

 If the axis is unrecognized by the motion controller, then the object 
position is shown as a question mark (?).

Note: If the axis type is mismatched between that which you have drawn 
and the type that you choose in the Motion Control Console (for example, 
if the actual axis is linear, but you choose rotational in the Motion Control 
Console), then the cell in patch view turns to red.
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Patch view properties

You can view and modify patch universe properties such as the name, 
display details, and tooltip information that is displayed in a patch 
universe.

To view the properties of a patch universe

1 Right-click on the patch icon, and then select View Options. 

Result: The View Options dialog box appears.

Universe tab
Options on the Universe tab affect the binding/unbinding of the patch 
universe to a specific console or device output.

 ID: The name of the patch universe shortcut. 
 Name: The full name of the patch universe or port ID. 
 Source: The lighting control console or device and port to which the 

patch universe is bound.
 Bind: Associates the patch universe to a console or device output. 

This applies only when a console or device has been inserted in the 
Device Manager. 

 Unbind: Removes the association of the patch universe with the 
specified source. 
Tip: You can open the Device Manager without having to change to 
Live mode by double-clicking on the AF shortcut on the Status bar.

Display tab
Options on the Display tab set properties such as the color of a patch 
universe.
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 Updates per second: The frequency of updates from the console to the 
patch universe.

 Enable Tooltips: Select this checkbox to display information about the 
patch and the fixture when you hover over the start cell. 

 UnPatched Color: The color of a cell in the patch universe that is not 
patched. 

 Background Color: The color of the background of the patch view. 
 Text Color: The color of the text that is displayed in the patch 

universe. 
 Selected Color: The highlighted color of a selected fixture in the patch 

universe. 
 Column Width Size: Adjust the slider to resize the patch universe cells to the 

desired width.

To change the width of the patch cells

You can adjust the width of the cells in DMX and Motion Control patch 
universes.

1 Right-click anywhere in the patch universe and choose View Options.

2 Click the Display tab.
3 Adjust the Column Width Size slider to the preferred size.
4 Click OK.

Wireframe Details tab
Options on the Wireframe Details tab define the information to be shown in 
the tooltips when tooltips are enabled.
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 Use Document Defaults: Select this checkbox to reference the settings 
in Document Options (under the Options menu). Clear this checkbox 
and specify the tooltips that you want displayed.
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Errors 

Introduction

WYSIWYG sports an “on the fly” error checking engine. This means that 
as you are putting your lighting design together, WYSIWYG is continually 
checking for data errors such as multiple dimmers in one circuit, multiple 
channels in one dimmer, and various missing information. 

At any time, you can view the error reports that are available on the 
Errors shortcut bar. Error reports that have errors displayed will have an 
exclamation mark (!) after their name. You can edit/fix these errors on 
the spot; editing data on the error reports works the same way as the 
data spreadsheets explained in the previous section. As soon as you fix 
an error in an error spreadsheet, the entries are disabled to show that it 
has been fixed.

An indicator on the Status bar signals you when your document contains 
errors. This feature can be turned on or off. WYSIWYG is also set up to 
trigger an error notification when errors are detected. Error notifications 
can be turned on or off.

When an error is detected, the shortcut bar will display the shortcut icon 
with the warning symbol in red color instead of the check symbol in 
green color.
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Errors

WYSIWYG checks for the following errors:

Error Definition

Dimmers > Circuit Fixtures assigned to the same circuit 
have been assigned different 
dimmer numbers.

Patches > Circuit Fixtures assigned to the same circuit 
have been assigned different patch 
addresses.

Channels > Circuit Fixtures assigned to the same circuit 
have been assigned different 
channel numbers.

Patches > Dimmer Fixtures assigned to the same 
dimmer have been assigned 
different patch addresses.

Channels > Dimmer Fixtures assigned to the same 
dimmer have been assigned 
different channel numbers.

Channels > Patch Fixtures assigned to the same patch 
address have been assigned 
different channel numbers.

Spots > Patch Fixtures assigned to the same patch 
address have been assigned 
different spot numbers.

Missing Position The position field is empty.

Missing Unit The unit field is empty.

Missing Circuit Name The circuit name field is empty.

Missing Circuit # The circuit number field is empty.

Missing Dimmer The dimmer field is empty.

Missing Patch The patch field is empty.

Missing Channel The channel field is empty.

Missing Spot The spot field is empty.

Missing Color The color field is empty.

Missing Gobo The gobo field is empty.
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Error notifications

Error notifications occur when WYSIWYG detects an error for which an 
error notification trigger has been set.

To set error triggers

1 From the Options menu, choose Document Options.

2 Click the Error Tracking tab.

3 Select the errors for which you want to trigger an error notification 
and/or signal.

4 Click OK.
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To manage error triggers

1 When an error notification is triggered, the Data Error Notification 
dialog box appears: 

 

2 From this dialog box, you can perform one of the following actions:
a. Acknowledge the error, and then click OK to close the notification.
b. Acknowledge the error, and then click Show Me to open a new 

window that automatically navigates you to the appropriate error 
report.

c. Acknowledge the error, and then click Options to reset the error 
notification triggers as described above.

Error spreadsheet properties

Error spreadsheets may be sorted and modified in a similar manner as 
other spreadsheet views. 
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To modify an error sheet

1 Click the Errors layout tab.

2 From the Options menu, choose View Options. 
Result: The View Options window appears.

For information on the General, Data Options and Data Error Options tab, 
refer to “Customizing spreadsheets”.

On the Data Error Options tab, set triggers for the error that is 
displayed in the Name box on the General tab. For more information 
on triggers, refer to “To set error triggers”.
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Design mode

Design mode was created to provide lighting designers with an 
avenue for experimentation. Use it as a troubleshooting tool or as a 
creative tool to help you come up with cue concepts. In Design 
mode, you can create static lighting looks using the design tools, 
and then save and render those looks to output photo realistic 
pictures.

In this chapter
Layout tabs 721

Design tools 722

Fixture groups 736

Palettes 739

Looks 741

Cuelists 745

Camera Paths 748

Rendering 753

Background Rendering Manager 767
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Layout tabs

Introduction

Beneath the work area in each mode is a series of Layout tabs. These 
layouts provide various configurations of the views you are working with. 
To change layouts, click the tab that corresponds to the layout you wish 
to use. 

The Design mode contains the following Layout tabs:

 Wireframe: The work area displays a full-screen wireframe view.
 Quad: The work area is divided into quadrants, three of which can be 

modified to show plan, front, side, or isometric views. The lower-
right quadrant contains a shaded view.

 Shaded: The work area displays a full-screen shaded view.

Notes: 

 The wireframe views in Data mode are used for fixture selection only. 
To make any drawing modifications, you must return to CAD mode.

 You can change the properties of the fixtures in DESIGN mode by 
double-clicking on the fixture, which opens its Properties window.
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Design tools

Introduction

The design tools are available in the Design and Live modes. You must 
have your venue, scenery and fixtures drawn in order to use the design 
tools; however, you do not need to have all the data entered for the 
fixtures in Design mode. Design mode is intended so you do not need 
channel numbers or a patch. The design tools allow you to create virtual 
lighting looks without an external control console. You can rough-in static 
looks and render them for design presentations.

Though the Design mode looks a lot like the CAD mode, you cannot draw 
anything within the Design mode. If you need to make changes to your 
drawing, you need to switch over to the CAD mode. 

You can change the properties of the fixtures in DESIGN mode by 
double-clicking on the fixture, which opens its Properties window.

You can see the output of fixtures in the Wireframe and Shaded views 
within the Design mode. However, you can only select fixtures within the 
Wireframe views, unless you use Concept shortcuts as discussed in the 
next section.

The design tools are individual toolbars that enable you to control certain 
parameters for selected fixtures. Currently there are ten design tools: 

 Intensity
 Focus
 Iris
 Zoom
 Color 
 Gobo 
 Prism 
 Video
 Moving Scenery
 Footprint
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To turn the design tools on

1 From the Design menu, choose the tool name to activate or 
deactivate the desired design tool.

2 You can also toggle the tools on the Design toolbar. 

Note: Design tools have the same properties as other toolbars and can 
be rearranged on the screen to improve the layout of the working area. 
You can also resize design tools by stacking them into columns so that 
they take up less space on the screen.

To rearrange and resize design tools

1 Open the desired design tools using the steps above.

2 Click and drag one tool on top of another. When you release the 
mouse, the selected design tool lines up under the other.

3 Repeat step 2 for as many tools as will fit in a column.
4 If you overlay tools so that they are not completely visible, click on 

the triangle in the tools title bar. This expands or contracts the tool’s 
window.

5 If you click and drag a tool’s title bar off the column, it expands into 
its own window.

At Full and Focus

Toggle Intensity Designer Tool

Toggle Focus Designer Tool

Toggle Iris Designer Tool

Toggle Zoom Designer Tool

Toggle Color Designer Tool

Toggle Gobo Designer Tool

Toggle Prism Designer Tool

Toggle Video Designer Tool

Toggle Moving Scenery Designer Tool

Toggle Footprint Designer Tool

Render Wizard

Fade looks

Toggle Cuelist Editor Tool

Toggle Camera Path Editor Tool

Toggle Timeline Tool
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Using the design tools

Begin by selecting the desired fixtures.

To select fixtures

Select a fixture (or fixtures). You can select multiple fixtures by holding 
the CTRL key while clicking on the fixture symbols. You can also use 
fixture groups as described in "Fixture groups".

Tip: You can also right-click and drag a box around a section of your 
drawing to select fixtures. This displays a context-sensitive menu 
displaying all the fixture types contained within that box. You can then 
easily select “All Mac500,” for example.
Result: The selected fixtures are highlighted in green.

To invert fixture selection

Press CTRL+SHIFT+I to deselect all the currently selected fixture(s), and 
consequently select all the other fixtures previously not selected in 
Design and Live modes.

Press CTRL+I to apply invert selection to fixtures, screens and LED walls 
in Design and Live modes.

Intensity tool

To use the intensity tool

The Intensity tool provides many options for setting intensity levels.

Click the buttons for the extreme settings of intensity: Full (100%) and 
Off (0%). 
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You can quickly adjust the intensity by using the Plus or Minus buttons to 
alter intensity by 5%, 10% or 25%.

Use the dial to achieve any of the settings in between. To use the dial, 
click and hold the dial while you move the mouse up or down. The chosen 
intensity level is displayed in the intensity box as you move the mouse. 
Use the up/down arrows located above and below the dial to change the 
value by one.

Alternatively, you can enter a specific percentage by typing the number 
in the intensity box, and then pressing ENTER. The beams will update 
instantly.

If multiple fixtures are selected, the intensity level entered is assigned to 
all fixtures. If you select multiple fixtures that have varying intensity 
levels, “N/A” appears in the intensity box. 

The Fan feature enables you to select a group of fixtures, adjust the 
intensity as a group, and then spread the intensity out with a simple 
wheel. The fan allows for the distribution of intensity in the following 
configurations: Center, Left to Right, Right to Left, Chevron In, Chevron 
Out. Click the Fan button to set the wheel in Fanning mode (color 
changes), and then move the wheel up or down to change fanning 
spread of the selected fixtures.

Zoom and iris tools

To use the zoom and iris tools

The Zoom and Iris tools both work the same way. 

Use the buttons for the extreme settings of tight or wide. 

Use the dial to achieve any of the settings in between. To use the dial, 
click and hold the dial while you move the mouse up or down. The chosen 
value is displayed in the box as you move the mouse. Use the up/down 
arrows located above and below the dial to change the value by one.

Alternatively, you can enter a specific percentage by typing the number 
in the zoom or iris box, and then pressing ENTER. The beam will update 
instantly.

The Fan feature enables you to select a group of fixtures, adjust the 
zoom or iris as a group, and then spread the zoom/iris out with a simple 
wheel. The fan allows for the distribution of zoom/iris settings in the 
following configurations: Center, Left to Right, Right to Left, Chevron In, 
Chevron Out. Click the Fan button to set the wheel in Fanning mode 
(color changes), and then move the wheel up or down to change fanning 
spread of the selected fixtures.
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Gobo and prism tools

To use the gobo and prism tools

The Gobo and Prism tools work the same way. Specify the fixture type (if 
you have more than one selected), or the specific wheel to control (if that 
fixture type has multiple wheels) using the drop-down menu. Note that 
only fixtures with gobo or prism parameters appear on the list. Use the 
gobo/prism wheel scroll arrows to select the desired gobo/prism from the 
wheel. If no gobo/prism is desired, leave the wheel in the open slot.The 
dial will rotate this gobo if a rotating gobo is selected.

Color tool

To use the color tool

The Color tool offers many options for color selection.

Gobo display

Rotate dial

Wheel selection 
drop-down list
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Click the custom color box or use the greyscale arrow to adjust your 
selection. The Color model values update automatically. The fixture's 
output depends on its capabilities. If the fixture has CMY or color mixing 
capabilities, the output is the exact color you selected. If the fixture is 
only equipped with a color wheel or a non-mixing scroller, the fixture will 
output the closest color to that selected, based on the available colors on 
the wheel. 

The same principle works if you select a color from the library by clicking 
the Library button. The wheel/scroller selection drop-down list is as 
discussed for the gobo wheel. All of the available colors are displayed in 
the order in which they appear on the wheel or scroll.

To facilitate designing with various fixtures using different color mixing 
techniques, the Color tool also offers a drop-down list with three different 
color space models (RGB, CMY, HSI). If you know the RGB values of the 
desired color, you can enter them, and the custom color box will update. 
Or if you have the RGB value and want to convert it to the CMY 
equivalent, change the Color Mixing selection.

You can also preview the color selected at all times using the Color 
preview box. Double-clicking on the Color Preview box has the same 
functionality as double-clicking on the Color Picker area, but without 
affecting your position on the area.

Colors available on the
color wheel/scroller

Wheel/scroller selection
drop-down

Custom color selector

Clear selected color

Color preview

Color distribution

Color presets

Color stops

Color fan tool

Access gel library

Color wheel preview

Color model
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Note: These are valid value ranges for the color spaces:

RGB Color Space: R (0-255), G (0-255), B (0-255)
CMY Color Space: C (0-100), M (0-100), Y (0-100)
HSI Color Space: H (0-360), S (0-100), I (0-100) 

The Color Fan feature enables you to select a group of fixtures, adjust 
the color as a group, and then spread the color out with a simple wheel. 
The fan allows for the distribution of color in the following arrangements: 
Center, Left to Right, Right to Left, Chevron In, Chevron Out. 

Color Fan offers predefined Color Presets with defined color stops, or 
custom color stops can be created (limit 5 color stops) using colors 
chosen from the color selector or gel library. 

Focus tool

The focus tool works with fixtures that have variable pan and tilt 
parameters (i.e., automated fixtures). You must focus conventional 
fixtures in CAD mode.

Much like on a console, you can lock out Pan and/or Tilt from the Focus 
tool trackpad in order to prevent movement along a specific axis and help 
you focus your fixtures more effectively.

To use the Focus tool
The Focus tool gives you the option of using it in either Box or Wheel 
mode, as shown below:

Fan Left, CMY Rainbow configuration Chevron In, RGB Rainbow configuration
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From the Pan and Tilt drop-down box, choose whether you want to lock 
out either the Pan or Tilt direction. When you do so, you cannot move the 
fixture beams along the locked out axis. For example, if you select Pan 
Only, you cannot focus your fixtures along the Tilt axis. To enable 
focusing in all directions, leave the default Pan and Tilt selected.

Note: This setting applies only to the trackpad itself, and will not prevent 
you from clicking-and-dragging the beam in a Wireframe view or 
assigning a Focus Position.

In the focus trackpad, click, hold, and drag the mouse to control the 
position of the light beam. The Home button resets the fixture to pan = 
50% and tilt = 50%. 

To send the fixture's beam to a specific location, click the Focus button, 
and then click in your wireframe drawing. Use the focus position drop-
down list to focus the beams of light toward one of the Focus Positions 
that you created in CAD mode. 

You can also use the Focus tool to assign automated fixtures to focus 
objects that you have drawn in CAD mode. For more information on focus 
objects, see "Focusing fixtures".

Note: The Focus tool does not take into account the current viewing 
position or fixture settings. In one orientation, dragging to the right on 
the trackpad results in the beam moving left, but rotating the fixture 180 
degrees and dragging to the right will cause the beam to move to the 
right. This effect occurs with both moving mirror and moving head 
fixtures. 

Box mode Wheel mode
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The Fan feature enables you to select a group of fixtures, adjust their 
focus as a group, and then spread the pan/tilt out with a simple wheel. 
The fan allows for the distribution of pan/tilt settings in the following 
configurations: Center, Left to Right, Right to Left, Chevron In, Chevron 
Out.

Click the Fan button to set the wheel in Fanning mode (color changes), 
and then move the wheel up or down to change fanning spread of the 
selected fixtures.

Click and drag focusing
Instead of using the Focus tool, you can also focus fixtures by clicking on 
the beam in CAD mode Wireframe views and dragging the beam to the 
desired location. 

To focus fixtures with click and drag

1 On the CAD Options toolbar, ensure that Toggle Beam Dragging is 
enabled. 

2 Turn the fixture on.
3 Click on the fixture’s beam and drag it to the desired location.

To assign automated fixtures to focus objects

1 In CAD Mode, draw a Focus line by choosing Draw > Focus <object>.

Note: Any focus object can be drawn and have fixtures assigned.
2 In DESIGN mode, select the automated fixtures in the order in which 

you would like them to focus.
3 On the Focus tool, from the Focus Objects drop-down list, choose your 

focus object.

Video tool

Streaming video enables you to bring a live or pre-recorded video stream 
into WYSIWYG and play it back while you set looks in Design mode and 
while you precue in Live mode. 

Notes: 

 The Video tool is also available in Live mode.
 You can only incorporate live video if you have WYSIWYG Perform; 

you cannot select a video from a live capture device or CITP/MSEX 
stream if you have WYSIWYG Design.
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After you draw the screen and attach the video source or subsource or I-
Mag camera to it (or to a 3D primitive, an LED Wall, or to a projector that 
you have inserted from the Fixtures library), you can use the Video 
Designer tool in Design mode to start the playback or stream. You can 
view the video in any of the shaded views, using the controls on the 
Video Designer tool to pause, fast forward, rewind, or stop the video. 

To use the Video tool

Once you have the video source or subsource or I-Mag camera attached 
to an object, you must use the Video tool to control it. For more 
information, see "To draw a screen", "To configure a new video source for 
streaming video", and "To create a new video source in the Video 
Manager", and "To create an I-Mag Camera in the Video Manager". 

Note: If the video control is patched and DMX connected in Live Mode, 
then you will not be able to control the video or video subsource using 
any of the Video tool commands in Design mode. video sources and 
subsources can only be controlled by a Designer tool when the DMX 
source is disconnected; therefore, you must first disconnect the 
applicable console device from within Live Mode before using any of the 
Video tool commands. 

1 Click the Shaded tab to view the video screen(s) (or LED Walls or 
projectors) that you have drawn.

2 Click the Toggle Video Designer Tool icon to open the tool window. 
3 From the drop-down list, select the video source or subsource. 
4 Use the controls shown in the graphic above to play, pause, or stop 

the video. You can also use the slider to manually advance or rewind 
the video at your desired speed. 

Note: When you click the Pause button, the frame of the video that is 
playing at the time is held on the video screen; when you click the Stop 
button, the video stops playing and the screen goes blank. 

video source 
name

Progress slider

Click to play
video in a loop

Rewind to 
beginning

Advance to 
end

Stop

Pause

Play
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Footprint tool

Using the Footprint tool, you can change a footprint's focus distance for 
automated fixtures in the Shaded view of Design mode, in effect making 
the focus of the footprint "hard" or "soft".

Note: In this release of WYSIWYG, this feature is available in CAD and 
Design modes only: Footprint Focus is configurable for conventional 
fixtures in CAD mode and configurable for automated fixtures in Design 
mode (see "To focus a footprint for a conventional fixture"). Once 
configured, all fixtures can be visualized in Design mode. In an upcoming 
release, the Footprint Focus feature will be extended to function in Live 
Mode like all other Designer tools.

To use the Footprint tool

1 Select the automated fixture and open the Footprint tool.

2 Check Enable to enable Footprint Focus for the selected fixture(s).
3 Adjust the focus distance using the slider or by entering a value in 

the Focus Distance box. Click the Min and Max buttons to set the value 
to the fixture’s minimum or maximum focus distance, which are 
defined on the General tab of the fixture’s Property page in the 
Footprint Settings section.

4 Check Focus Lines to display focus lines for the selected fixture(s) in 
shaded views.

5 Check Sync to Focus Position to adjust the footprint focus distance to 
the specified Focus Position.
The effect is visible in the Shaded view when Footprint Focus is 
enabled on the Simulation tab of the View Options window.

Enable footprint focus

Set focus distance to maximum 
value set for fixture

Enter focus distance

Set focus distance to minimum 
value set for fixture
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Moving scenery tool

After drawing motion axes or frames and attaching objects to them, you 
can use the Moving Scenery Designer tool to make the object “move” 
along each axis.

You can simulate moving scenery by setting up looks containing motion 
axes or frames in Design mode. Once you create the look and specify its 
fade time, use the Moving Scenery Designer tool to customize the look 
by selecting the appropriate motion axis or frame and the object’s 
starting position on it. Then create a second look, repeating the same 
procedure to set the object’s starting position on either the same axis or 
frame, or a different one (if there is more than one axis attached 
together).

When you switch from one look to the next, you can see the object move 
from the starting point of the first look, to the starting point of the 
second look within the time period that you define as the “fade time”.

To use the Moving Scenery tool

After drawing motion axes/frames and attaching objects to them, you 
can use the Scenery tool to make the object “move” along each axis. 

1 In Design mode, click the Toggle Moving Scenery Designer Tool icon to 
open the tool. 

Note: You can also open the tool by clicking Design > Moving 
Scenery tool.
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2 From the drop-down list, select the appropriate motion axis or frame.
3 If you selected a linear axis, the X scroller is enabled. If you selected 

a rotational axis, the Rx scroller is enabled. If you selected a motion 
frame, all scrollers with activated motion ranges are enabled.

4 To move the object on the axis, you have four choices:
 Use the scroller to move the object back and forth along the axis.

 Click Start or End to move the object immediately to either the 
start or end of the motion axis.

 Click the Home button to move the object to its original position.

 For very precise positioning, in the box provided, type the 
object’s position as a percentage of its total range of movement 
and press ENTER. For example, if you want to see the object at 
the exact half-way mark, type 50 in this box, and then press 
ENTER.

Highlight fixtures

In Shaded view, Highlight sets the currently selected fixture(s) to an 
open beam at 100% full intensity temporarily, without changes to the 
fixture’s saved settings.

Highlight can be accessed from the Design menu or the Fixture Selection 
toolbar. 

Highlight is useful when identifying a single fixture or a small selection of 
fixtures within a large and complex plot.

To use the Highlight tool

1 From the Design menu, choose Highlight.

Tip: You may also use the Highlight tool on the Fixture Selection toolbar. 

2 In Shaded view, select a fixture or multiple fixtures.
Result: The selected fixture(s) is highlighted showing an open beam 
at full intensity.

3 Click on the next fixture that you wish to highlight.
Result: The next fixture selected is highlighted showing an open 
beam at full intensity, and the previously highlighted fixture goes 
back to its previous state.

Note: The displays in the Design tools windows associated with the 
highlighted fixture(s) will appear in white/clear.

 The Highlight button.



Reference Guide 735

January 2019 Design mode 

Update intensity labels

This feature offers the ability to display the intensity level applied to a 
fixture and appears as a Fixture Attribute. The intensity level value is 
displayed as part of the Fixture Symbol text in the wireframe views in 
CAD, Design, and Live modes; and in Layouts in the Presentation mode.

To use Update Intensity Labels tool

1 From the Options menu in CAD mode, choose Document Options.

2 In the Document Options window, click Fixture Attribute Details.
3 Select the Intensity checkbox under the Show on Plot column.
4 Click OK.

Result: The Update Intensity Labels tool is enabled and the current 
intensity value applied to a fixture is displayed as part of the Fixture 
Symbol text.

5 From the Design menu in Design mode, click Update Intensity Labels.
Result: The intensity value displayed in Layouts (Presentation 
mode) and Wireframe views is updated according to the current 
intensity level applied to the fixture.

6 From the Live menu in Live mode, click Update Intensity Labels.
Result: The intensity value displayed in Layouts (Presentation 
mode) and Wireframe views is updated according to the current 
intensity level applied to the fixture.
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Fixture groups

Introduction

Fixture groups are custom groups of fixtures. You can create fixture 
groups in CAD, Data, Design, or Live mode in any view that allows fixture 
selection. 

Creating fixture groups

Creating a fixture group allows you to select a group of fixtures at the 
same time. 

Fixture group shortcuts also enhance working with design tools in shaded 
views. Since design tools work with the current fixture selection, opening 
multiple fixture group shortcuts allow you to change different groups of 
fixtures, rather than having to select them individually in the Wireframe 
view. 

Notes: 

 Fixture groups are saved on the Fixture Group shortcut bar. 
 If ONLY fixtures are selected, either CTRL+G or CTRL+J will create a 

Fixture Group.
 If fixtures and more than one other object is selected, CTRL+G will 

create a normal “Objects Group” from the selected objects (the same 
if there were no fixtures in the selection), while CTRL+J will create a 
Fixture Group (the same as if CTRL+G was used with only fixtures 
selected).

To create a new fixture group

1 Select the fixtures that you want to group. If you are unfamiliar with 
selecting objects, refer to "Selecting".

2 Click the Fixture Groups shortcut bar.
3 Right-click the Fixture Groups shortcut bar, and then choose New 

Fixture Group. Alternately, you can click the new fixture icon.
4 Type the name of the fixture group, and then click OK.

Result: The fixture group is saved on the Fixture Groups shortcut bar.

Updating fixture groups

You can modify a fixture group shortcut by adding or removing fixtures 
as required. 
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To update fixture groups

1 Select the set of fixtures that you want to include in the fixture 
group.

2 Right-click on the Fixture Groups shortcut that you want to update, 
and then choose Update.
Result: The Fixture Groups shortcut is modified to include only the 
fixtures that you selected.

To add fixtures to an existing Fixture Group

1 On the Fixture Groups shortcut bar, click on a Fixture Group to select 
the fixtures in the group.

2 Press and hold CTRL and click on the fixtures that you wish to add to 
the selected Fixture Group.

3 Right-click on the selected Fixture Group on the Fixture Groups 
shortcut bar.

4 Select Update from the pop-up menu.
Result: The selected fixtures will be added to the Fixture Group.

To remove fixtures from an existing Fixture Group

1 On the Fixture Groups shortcut bar, click on a Fixture Group to select 
the fixtures in the group.

2 Press and hold CTRL and click on the fixtures you want to remove 
from the selected Fixture Group.

3 Right-click on the selected Fixture Group on the Fixture Groups 
shortcut bar.

4 Select Update from the pop-up menu.
Result: The selected fixtures will be removed from the Fixture 
Group.

Working with fixture groups

When you select a Fixture Groups shortcut, any currently selected objects 
are deselected, and the fixture group set is selected instead. 

If you press the CTRL key while selecting fixture groups, the fixture 
group is added to the current selection set. 

If you press the CTRL and SHIFT keys while selecting fixture groups, the 
fixture group is removed from the current selection set. 

Tip: Fixture groups can be used to select fixtures even while in 
Shaded view.
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Notes: 

 In a fixture group shortcut, multi-cell fixtures, such as cyc lights, can 
be selected either by cell or fixture. If the fixture group was created 
in Design mode using cells, the entire fixture is selected in the other 
modes. If the fixture group was created using fixtures, all cells are 
selected when in Design mode.

 When you replace a multi-cell fixture that is selected by circuit with a 
different multi-cell fixture that has a different number of circuits, the 
replacement fixture is selected by fixture and not by circuit.

 When you delete a fixture, the fixture is removed from all fixture 
groups that include that fixture.

 When you replace a fixture using the Replace Fixtures menu option, 
any fixture groups referring to that fixture are updated to refer to the 
fixture replacement.

 Any fixture added to a document will not initially be part of any 
fixture group.
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Palettes

Introduction

You can create palettes of color to facilitate color selection. A palette is a 
reference to a specific color and can be used on all color-changing 
fixtures and scrollers.

Creating palettes

Creating a Palette shortcut is helpful if you want to save your favourite 
CMY color mixes for later use. 

Note: You can create palettes in Design mode only. 

To create a palette

1 Select the fixture from which you want to capture the color.

Note: You can create a palette from only one fixture.
2 Right-click on the Palettes shortcut bar, and then choose New Palette.
3 Type the name of the palette, and then click OK.

Result: The CMY value is saved as a palette on the Palettes shortcut 
bar. This value can be a CMY mix, a color from the color wheel or 
scroll, or a combination of color sources.

Updating palettes

You can modify a Palette shortcut by modifying or replacing colors as 
required. 

To update a palette

1 Select the fixtures from which you would like to record the palette.

2 Right-click on the Palettes shortcut that you want to modify, and then 
choose Update.
Result: The Palette shortcut is updated with the new CMY values.

To apply a palette

Applying a color palette is the equivalent of setting up color parameters 
for the selected fixtures, except it is much faster.
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1 Select the fixtures for which you want to assign the specific color 
value.

2 Click on the desired palette shortcut. 
Result: The fixtures are assigned the recorded copy value. If the 
fixture has CMY or color mixing capabilities, the output is the exact 
color that you selected. If the fixture is only equipped with a color 
wheel or a non-mixing scroller, the fixture outputs the closest color to 
that selected, based on the available colors on the wheel.
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Looks

Saving lighting looks

Changes that you make with the design tools update the currently 
selected look. The name of the currently selected look is displayed at the 
top of the working area. Before making changes, always check that the 
currently selected look is the one that you want to modify.

To create a new lighting look

1 In the shortcuts bar, click Looks.
2 In the Looks shortcut area, right-click, and then select New Look.
3 In the Name box, type the name of the new look.
4 In the Fade time box, type the fade time in seconds for this look. This 

is the amount of time that it takes to “fade” to this look when you 
click on it from another look on the shortcut bar. For more 
information, see "Cross-fading between lighting looks" below.

5 Click OK.
6 Scroll to the bottom of the Looks shortcuts list.
7 Click on the shortcut for your new look.
8 Use the design tools to create your new lighting look.

Tip: To build on an existing look without losing it, clone the look 
shortcut and work from the copy of the shortcut. For more 
information on cloning shortcuts, refer to "To clone a shortcut".

Cross-fading between lighting looks

You can use the Looks shortcut bar to quickly set up and run timed 
transitions between lighting looks without the need of a lighting console. 
When you create a lighting look, you can specify its fade time in seconds. 
This is the amount of time that it takes to “fade” to this look when you 
click on it from another look on the shortcut bar. You can create multiple 
looks and specify different fade times for each of them. 

Once you create the look and specify the fade time, you can use the 
design tools to customize the look. For example, you can add color, 
gobos, and intensity to lighting, and set the position of moving lights. 
When you switch from one look to the next, you can see the movement 
of the lights from one position to the next, along with any changes you 
have made between looks, such as color, intensity, and so on. 
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To cross-fade between looks

1 In Design mode, in the shortcuts bar, click Looks.
2 In the Looks shortcut area, right-click, and then select New Look.
3 In the Name box, type the name of the new look.
4 In the Fade time box, type the fade time in seconds for this look. 
5 Click OK.
6 Scroll to the bottom of the Looks shortcuts list.
7 Click on the shortcut for your new look.
8 Use the design tools to create your new lighting look. You can set the 

color, intensity, zoom, iris, and add gobos. If you are using moving 
lights, you can also set the position of the lights.

9 To create the next look, in the Looks shortcut area, right-click, and 
then select New Look.

10 In the Name box, type the name of the new look.
11 In the Fade time box, type the fade time in seconds for this look. 
12 Click OK.
13 Scroll to the bottom of the Looks shortcuts list.
14 Click on the shortcut for your new look.
15 Use the design tools to create your new lighting look. You can set the 

color, intensity, zoom, iris, and add gobos. If you are using moving 
lights, you can also set the position of the lights.

16 Ensure that the Fade Looks menu is enabled so the look fades 
instead of jumping directly to the next look. 
Tip: If the button is not enabled, then you can “jump” from one look 
to the next by clicking the look shortcuts on the shortcut bar. Even if 
the button is enabled, you can always jump to the next look by right-
clicking the look shortcut, and selecting Jump to.

17 To watch the “fade” from the first look to the second look, click the 
shortcut for the second look. The image fades over the period of time 
that you specified for the second look.
Tips: 
 For a more realistic view of the fading between looks, click the 

Shaded tab. 

 When cross-fading between Looks, a simple countdown (of the 
remaining fade time) will be displayed in Shaded view.

 To jump directly to a specific look, right-click the look, and then 
select Jump to.
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Viewing moving scenery

You can use the Looks shortcut bar to quickly set up and run timed 
transitions between looks to simulate moving scenery. 

When you create a look, you can specify its fade time in seconds. This is 
the amount of time that it takes to “fade” to this look when you click on it 
from another look on the shortcut bar. You can create multiple looks and 
specify different fade times for each of them. 

Just as you can specify the fade time to watch the transition between 
lighting looks, so too can you use the fade time to simulate moving 
scenery. In the latter case, however, your Look must contain at least one 
motion axis with at least one object attached to it. 

Note: You can also combine Looks to simulate both moving lights and 
moving scenery in one “fade”. 

Once you create the look and specify its fade time, use the Moving 
Scenery Designer tool to customize the look by selecting the appropriate 
motion axis and the object’s starting position on it. Then create a second 
look, repeating the same procedure to set the object’s starting position 
on either the same axis, or a different one (if there is more than one axis 
attached together). 

When you switch from one look to the next, you can see the object move 
from the starting point of the first look, to the starting point of the 
second look.

To view moving scenery

Note: Before you perform this procedure, you must have drawn at least 
one motion axis and attached at least one object to it. For details, see 
"Drawing motion axes".

1 In Design mode, in the shortcuts bar, click Looks.
2 In the Looks shortcut area, right-click, and then select New Look.
3 In the Name box, type the name of the new look.
4 In the Fade time box, type the fade time in seconds for this look. 
5 Click OK.
6 Scroll to the bottom of the Looks shortcuts list.
7 Click on the shortcut for your new look.
8 Click the Toggle Moving Scenery Designer Tool icon.
9 From the drop-down list in the Scenery window, select the appropriate 

motion axis. 
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10 Click the slider to advance the object to the position where you want 
it to start on the selected axis. 
Note: You can also use the Start box to type the object’s position as a 
percentage of its full range of movement. For example, to show the 
object at the exact half-way mark on the motion axis, type 50. 

11 To create the next look, in the Looks shortcut area, right-click, and 
then select New Look.

12 In the Name box, type the name of the new look.
13 In the Fade time box, type the fade time in seconds for this look. 
14 Click OK.
15 Scroll to the bottom of the Looks shortcuts list.
16 Click on the shortcut for your new look.
17 From the drop-down list in the Scenery window, select the appropriate 

motion axis. 
18 Click the slider to advance the object to the position where you want 

it to start on the selected axis. 
19 Ensure that the Fade Looks menu is enabled so the look fades 

instead of jumping directly to the next look. 
Tip: If the button is not enabled, then you can “jump” from one look 
to the next by clicking the look shortcuts on the shortcut bar. Even if 
the button is enabled, you can always jump to the next look by right-
clicking the look shortcut, and selecting Jump to.

20 To watch the “fade” from the first look to the second look, click the 
shortcut for the second look. The object moves from the starting 
point of the first look to the starting point of the second look over the 
period of time that you specified as the fade time for the second 
look. 
Tips: 
 For a more realistic view of the fading between looks, click the 

Shaded tab.

 To jump directly to a specific look, right-click the look, and then 
select Jump to.

 For details on controlling the object’s movement with a console 
device, such as the Mini Console, see "To control a DMX patched 
motion axis with a console".
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Cuelists

About cuelists

Cuelists enable you to play back stored Looks in any order, without 
having to resort to the crossfade function described in the previous 
section. 

To create a Cuelist

1 On the Design toolbar, click the Toggle Cuelist Editor Tool icon.  

Result: The Cuelist Editor window appears.

 

2 In the top-right corner of the tool, click the Create a new Cuelist button.
3 Type a name for the Cuelist, and then click OK.
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To rename a Cuelist

1 In the Cuelist Editor tool, click the drop-down list on the top left corner 
and select the Cuelist that you want to rename.

2 With the Cuelist highlighted, type the new name, and then press 
ENTER.

To copy a Cuelist

This procedure is useful when you set up one Cuelist with Looks in a 
certain order, but want to see how the same Looks would "play out" in a 
different order.

1 Click to select the Cuelist that you want to copy.

2 Click the Clone current Cuelist button in the top right corner.

To delete a Cuelist

1 Click to select the Cuelist that you want to delete.

2 Click the Delete current Cuelist button in the top right corner.

To add a cue to the Cuelist

1 To add a cue to a Cuelist, select the Cuelist from the drop-down list 
on the top left corner.

2 Click the + button (lower right corner) to add a cue.

Note: To delete a cue, select it and then click the minus (- ) button in the 
bottom right corner.

To adjust the position of a cue

To adjust the position of a cue in the list, click to select it, and then move 
it up and down using the arrow buttons in the lower left corner.

To add a Look to a Cuelist

Once you add a cue, you can assign a Look to it by clicking the drop-
down list in the Look column and selecting the appropriate Look.

Setting cue triggers
There are two types of triggers that you can set for each cue in your 
Cuelists:

 Go: The fade for the current cue will start immediately (the delay 
time is 0 seconds).

 Follow: The fade for the current cue will activate automatically after 
the set delay time has passed. 



Reference Guide 747

January 2019 Design mode 

To switch between triggers, click to select the appropriate cue, and then 
click in the Trigger cell. From the drop-down list, you can toggle between 
Go and Follow.

Setting the fade time
The fade is the time (in seconds) that it takes to transition between the 
previous cue and the current cue. 

Notes: 

 The fade time is in no way related to the crossfade time set for 
individual looks.

 The fade always starts after the delay time has passed.

To enter the fade time, click to select the appropriate cue, and then click 
in the Fade cell to type the new fade time.

Setting the delay time

The delay is the time (in seconds) that it takes for lights to start fading 
into the current cue. To enter the delay time, click to select the 
appropriate cue, and then click in the Delay cell to type the new delay 
time.

To activate a cue

To activate a cue, hit the Go button. Note that if the next cue has a 
'follow' trigger, it will start as soon as its delay time has passed.

To stop playing a Cuelist

To stop playing a Cuelist, click the <|| button. Click the same button to 
step back through cues, disregarding fades and delays.

Tips: To "jump into" a cue (i.e., ignoring fade and delay times), 
double-click in the grey area to the left of the cue. You can use the 
arrow keys to navigate the Cuelist table.
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Camera Paths

Introduction

Once you draw a Camera path in CAD Mode, you can use the Camera 
Path Editor and the Timeline tool in Design or Live Mode to define the 
time interval between two nodes along the path. If there are Camera 
Targets inserted in the file, you can also specify when the camera should 
follow a camera target. Finally, you can also define the orientation and 
field angle of the Camera at the current node position. 

Once you have defined the time intervals and camera’s orientation, you 
can open the Timeline tool and watch the Camera path play in the 
Shaded View. Camera Path playback is also simulated in Full Screen 
mode.

You can also patch a camera path to a DMX universe and then control the 
camera’s movement through a console. For details, see "Patching 
Camera Paths".

Using the camera path editor

Once you create a Camera path in CAD mode, follow the steps in this 
section to define the time intervals between the nodes on the path, 
change camera behavior, assign targets to camera nodes, and reposition 
nodes in space. For details on drawing Camera paths, see "Drawing 
camera paths".

Camera path editor window

Camera path editor columns
 Node: This column gives you the Node number of the nodes on your 

Timeline.
 Shortest Path: When the Shortest Path checkbox is selected for a node, 

it forces the camera to rotate as little as possible when moving 
between two nodes on your timeline. When the Shortest Path 
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checkbox is unchecked for a node, the camera will take the longer of 
the two directions as it rotates to aim at the next node's target. This 
applies to Roll, Pitch and Yaw.

 X, Y, and Z Columns: The X, Y, and Z columns in the Camera Path Editor 
are editable position information for each of the nodes on your 
timeline. You may enter in distance values into these fields to re-
position your nodes as you see fit.

 Rx, Ry, and Rz Columns: These columns represent the rotation around 
each of the X, Y, and Z axes in WYSIWYG. These columns are non-
editable, but allow you to get positional information from your nodes.
 Rx, or Rotation around the X Axis = PITCH[tilting forward and 

backward]
 Ry, or Rotation around the Y Axis = ROLL [tilting side to side]
 Rz, or Rotation around the Z Axis = YAW [also called Heading or 

Direction]
 Interval: A node’s Interval is how long it takes in seconds to get from 

one node to another. For example, if the timing on node 2 is ten 
seconds (10s), then the camera would move for ten seconds before 
reaching node 2.

 Behavior: Behavior is the camera’s movement and direction behavior 
as it relates to the Camera Path. There are three types of Camera 
Behavior:
 Follow Path: The camera will follow straight along the path, not 

deviating in any way possible from the path as it travels between 
nodes.

 Follow Target: The camera will always point at an assigned Camera 
Target if this behavior is chosen for a node.

 User Defined: This option allows the camera to behave exactly as 
specified by a user, meaning that the camera will point wherever 
you point it when the User Defined behavior is chosen.

 Target: Each node can be assigned a different target when the Follow 
Target behavior in the Behavior column is chosen. The Target column 
is a drop-down list for choosing different targets in your drawing.

 Field Angle: This option allows you to enter in different field angles for 
each node.

To use the Camera path editor

1 In Wireframe view, from the Design menu, click Camera Path Editor.

2 In the Camera Path Editor, from the Camera Path drop-down list, select 
the Camera path that you want to edit.

3 In the Interval column, adjust the timing for each node along the 
path, specifying when you want the camera to be at that node.
 If you have placed targets along the path, and you want the 

Camera to follow a target at a particular node, in the Target 
column click in the cell corresponding to the node and, from the 
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drop-down list that appears, select Follow Target. Then, click in the 
adjacent Target cell to select the target.

 To define the orientation and field angle of the Camera at a 
particular node along the path, in the Camera Target column, 
click in the cell corresponding the node, and then select User 
Defined. 

4 Once you have defined the time intervals, you can use the Timeline 
tool to watch the Camera path play in the Shaded View. For details, 
see below.

Visual camera path builder tool

The Visual Camera Path Builder tool allows you to create a Camera Path 
on the fly while you move the Camera around your space. This tool 
essentially works by placing a node at the Camera’s current position once 
you’ve told WYSIWYG that you are satisfied with the Camera’s current 
placement on screen.

To use the Visual Camera Path Builder tool

1 Right-click in the Shaded View and select Visual Camera Path Builder.

2 Once you’ve started the Visual Camera Path Builder, you’ll be 
prompted to name your new path, add it to the Camera layer (or a 
layer of your choosing), and create the first node based on the 
Camera’s current position.

3 Once you click OK in the dialog box, you will then be in Visual Camera 
Path Editor mode. Maneuver the Camera around the space, and 
when you want to create a new node based on your Camera’s 
position, right-click in the Shaded View and choose the Add Node. At 
this point, you can also Abort your Camera Path in the Visual Camera 
Path Builder tool.

4 Move the Camera and right-click every time you would like to create 
a new node from your Camera’s current position in space.
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5 When you have created as many nodes as you would like to have in 
your Camera path, right-click again in the Shaded view and choose 
Finish Camera Path.

6 At this point, you can also Abort your Camera Path, or you can 
choose to Close the Camera path from your current view, which will 
create a seamless loop on the Camera path. When you are finished 
with the Visual Camera Path Builder tool, you will automatically exit 
the Visual Camera Path Builder tool mode.

To use the Timeline tool

Once you have adjusted the timing of a Camera path with the Camera 
path editor, switch to the Shaded view to watch the camera move along 
the path with the Timeline tool. This tool enables you to watch the timing 
in slow motion, regular speed, or up to four times the speed. 

Notes: 

 Camera Path playback is also simulated in Full Screen mode.
 Nodes of existing Camera Paths can be edited from a Shaded view 

when the Timeline's Previous Node or Next Node buttons are used; 
they can only be edited while playback is paused.

1 In Shaded view, click View > Timeline.

Result: The Timeline tool appears.

2 Use the controls to watch the Camera move along the path you have 
defined:
 Play: Click to start the camera path simulation in the Shaded 

view. While this plays, the red line moves along the timeline to 
display its current position. You can click on the red line indicator 
and scrub along the timeline, which updates the red line and the 
Camera simulation at the corresponding point along the path. 

 Stop: Click to stop the camera.

 Previous Node: Click to switch back to the previous node on the 
path.

Play
Previous 
Node

Playback 
Direction 
Toggle

Playback 
Speed 
Adjust Zoom

Stop Next 
Node

Toggle 
Loop

Show Node 
Numbers

Node
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 Next Node: Click to move to the next node on the path.

 Toggle PlayBack Direction: Click to switch the direction of the 
camera on the path.

 Toggle Loop: Click to keep the camera moving on the path in a 
continuos loop.

 Adjust Playback Speed: Click to choose the playback speed.

 Show Node Numbers: Click to show the node numbers in the 
timeline.

 Zoom: Use the slider to zoom in or out on the timeline.

Note: When the DMX Control for Cameras/Camera Paths is enabled in 
Camera Manager, the controls in the Timeline tool are disabled in LIVE 
mode, as DMX will be in control of all Camera Path playback and settings.
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Rendering

Introduction 

In WYSIWYG, you can render lighting looks to produce high quality 
images of your set and lighting. Rendering uses a full range of effects, 
including depth of field, motion blur, soft shadows, and antialiasing 
settings to produce a photorealistic image. 

Based on the product level that you are running, when you are creating a 
rendering, you have two choices:

 Render Wizard: (all product levels except Report) You can use the 
interactive editing and advanced visual effects of the Render Wizard 
to set up the look that you want to render, and then create the 
rendering. In this case, you must leave WYSIWYG running while the 
Render Wizard finishes the image. You have the choice of saving the 
image to an external folder that you specify or within WYSIWYG on 
the Images tab.

 Background Rendering Manager: (all product levels except Report and 
Perform - Console Edition) You can use the Render Wizard to set up 
the look that you want to render, and then send the render job to the 
Background Rendering Manager to create the rendering. 
This feature lets you use the Windows taskbar to queue render jobs 
that will execute in the background without requiring WYSIWYG to 
run, letting you do other tasks while the Render Engine works 
independently. You can also pause and resume renderings without 
losing your render, and shut down/restart your computer without 
losing your rendering progress. For details on this feature, see 
"Background Rendering Manager".

To render a lighting look

1 In the working area of the screen, display the lighting look that you 
want to render.

2 From the Design menu, choose Render.
Tip: You can also click the Render Wizard icon in the Design toolbar.
Result: The Render Wizard appears and guides you through a series of 
options. 
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Step 1 - Set Output Destination and Image Size

Click in the right pane to arrange the image that you want to render. 
You can click and drag the image around, zoom in and out with the 
mouse wheel (or PAGE UP / PAGE DOWN keys), or set up your shot 
accurately using a camera. 

Note: Make sure you use the appropriate aspect ratio (height vs. 
width) for the output device that you will be using to present the 
pictures. For example, TV is 4x3 (normally 640x480), HDTV is 16x9.
a. Dimensions: Type a value in pixels for the width and height of the 

final image.

b. Destination: Choose where you want to save the final image and 
whether you want to use the Background Rendering Manager to 
create it.

 Internal Image View: Select this option to have the Render Wizard 
create the image and store it on the Images tab in Presentation 
mode. 

 External Image: Select this option to have the Render Wizard 
create the image and store it in the location that you specify. 
Then type the file name for the image and click Browse to 
choose the folder where it will be saved. If desired, choose the 
file type, either .bmp or .jpg. If you do not make a selection, 
the image is stored as a .bmp image.

 Background Rendering Manager: Choose this option to send the 
render job to the Background Rendering Manager when you finish 
setting up your image in the Render Wizard. Type the file name 
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for the image, ensuring that it is a unique name, and then 
click Next. For details, see "Background Rendering Manager".

Note: If this is the first time you are using the Background Rendering 
Manager, you must configure it before the rendering process will 
begin. Upon clicking Finish in the Render Wizard, the Configuration Wizard 
appears, enabling you to configure settings such as the Network 
Port, the default folder for storing rendering files, and other Manager 
settings. For details, see "To configure the Background Rendering 
Manager". 
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Step 1b - Configure Background Rendering Manager

This step appears only if you chose to create and save the rendering 
with the Background Rendering Manager. If you chose to save the image 
internally or externally, proceed directly to Step 2 - Set Camera 
and Simulation Type. 

a. Connect to Local Host: Leave this checkbox selected to use the 
default values and have the Render Wizard send all jobs to the 
Background Rendering Manager that is running on your computer. 
To send render jobs to another computer in your network that is 
running the Background Rendering Manager, clear this checkbox 
and then type the server name and port number in the boxes 
provided. Note that when you send render jobs to a network 
computer, the Background Rendering Manager must be open and 
running on this destination computer; in this case, the act of 
sending a job from the Render Wizard does not launch the 
Background Rendering Manager.

b. Server Name: Type the name of the server in your network that is 
running the Background Rendering Manager where you want the 
Render Wizard to send all render jobs. The server must be running 
WYSIWYG Release 18 (or higher) and have a dongle attached.

c. Server Port: Type the port number that the WYSIWYG Render Wizard 
will use to send render jobs to the Background Rendering Manager, or 
accept the default port number shown. It must be a value 
between 1025 and 65,535. For proper communication, this 
number must match the port number that is configured in the 
Background Rendering Manager on the destination computer; 
therefore, if you change this value, you must also change it in the 
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Background Rendering Manager on the destination computer. For 
details, see "To configure the Background Rendering Manager".

Step 2 - Set Camera and Simulation Type

Options in Step 2 affect the composition of your image. 

a. Scene: Select a scene for the rendering. Scenes are groupings of 
layers used to organize a plot. For more information on scenes, 
refer to "Scenes".

b. Follow Current Scene: Select this checkbox to use the scene that is 
displayed in the Scene drop-down list. Clear the checkbox, and 
then select the desired scene from the Scene drop-down list. 

c. Camera: Select the camera for the rendering. Cameras are set up 
in CAD mode. For more information on cameras, refer to 
"Drawing cameras".

d. Aperture size: Use the slider to adjust the camera aperture. This 
adjustment changes the depth of field of the final image. The 
larger the aperture, the “fuzzier” the rendering. The focus point is 
always the target of the camera. 

Note: By default, the red lines indicating the Camera Target are 
visible. This is to aid in the composition of the image. It will not, 
however, be visible in your final rendering. To turn the target off 
(that is, set to not visible), right-click in the preview pane, and 
then choose View Options. For more information on shaded views, 
refer to "Modifying shaded views".

e. Ambient Light: Use the slider to set the ambient light level. This 
adjusts the overall light level, where 0% is complete black and 
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100% is a bright room. This does not affect the intensity of the 
fixtures in your lighting look. 

f. Pan tool moves objects: The Pan tool does not affect the outcome of 
your rendering. Rather the tool rotates the model on the target (if 
checked) or rotates the camera around the target (if unchecked). 
Both settings help you to compose your image. 

Step 3 - Add Atmospheric Effects to Your Rendering

 

Options in Step 3 affect the atmospheric conditions in your 
rendering. 

a. Atmospheric Options: The options that you set here affect the 
atmospheric conditions that are visible in your final rendering. To 
simulate atmospheric dust or fog, select Haze. For additional 
opacity, select Smoke. 

b. Density: Use the slider to set the visibility of the haze particles. A 
setting of 0% indicates that the particles cannot be seen.

c. Granularity: Use the slider to set the granularity of the smoke. This 
setting affects how fine smoke particles are. This option is 
available only if you choose Smoke under Atmospheric Options.
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Step 4 - Select How Shadows Will Be Simulated

Options in Step 4 affect the projection of shadows in your rendering.

a. Shadows: Select how you want shadows to be projected in the 
final rendering. If you choose None, then no shadows are 
calculated by WYSIWYG; that is, objects in the path of the light 
beam do not create shadows. Instead, all objects in the path of 
the virtual beam are illuminated, even if an object would normally 
block the beam from reaching another. As illustrated in the 
rendering below, all three surfaces are illuminated and the beam 
continues into infinity.
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To calculate which objects the beam of light will hit and which 
objects it will not hit, select Objects. Objects in the path of the 
virtual beam will not be illuminated by the beam if the beam has 
already been blocked by another object. However, WYSIWYG still 
does not calculate where the beam stops. As illustrated in the 
rendering below, the first surface is illuminated, but the beam is 
still continuing into infinity.

Select Atmospheric to calculate which objects the beam of light will hit and 
where the beam of light will end. This is a true representation of how light 
behaves. As illustrated in the rendering below, the first surface is illuminated 
and the beam also stops there.

b. Beam Saturation: Use the Beam Saturation slider to change the 
relative brightness of fixture beams. When set to Realistic, 
WYSIWYG accounts for all variations in lamp output, including gel 
transmission, color temperature, fixture efficiency, and lamp. 
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When set to Standard, all fixture beams are rendered at the same 
general intensity.

Step 5 - Define How Light Reflection Will Be Simulated

 

Options in Step 5 affect the radiosity level. Radiosity is defined as the 
combined processes of emission, transmission, and absorption of 
rays or reflecting beams of light. When using Radiosity, it is not 
necessary to use ambient lighting.

a. Radiosity: To generate a rendering that uses radiosity, select the 
Radiosity checkbox, and then choose from the available radiosity 
options. Fast radiosity results in a rendering with constant, flat 
lighting. Each subsequent option shows more calculated lighting. 
The number of bounces determines how many levels of reflection 
are permitted.

b. Disable Ambient Light: Select the Disable Ambient Light checkbox to 
ignore the ambient light settings from Step 1.

c. Render as Screen: Select the Render as Screen checkbox to display 
the LED wall as a screen with a projected image instead of a 
detailed grid of LED pixels forming the image. Render as Screen is 
only available if the source of your LED wall is color, image or 
video. Render as Screen does not work if the source of the LED wall 
is Dynamic DMX patch.
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Step 6 - Add Environmental or Outdoor Lighting to Your 
Rendering

Options in Step 6 affect the presence and quality of environmental or 
outdoor lighting. Note that for environmental lighting to have an 
effect, your show must not be contained within a venue.

a. Enable Environmental Lighting: To generate a rendering that 
considers outdoor lighting conditions, select the Enable 
Environmental Lighting checkbox. 

b. Date and Time: The date and time of the rendering determines the 
position of the sun and/or moon and the resulting amount of light 
available. The position of the sun is also determined by the 
geographic settings that are configured in Document Options and 
the north direction that is set in CAD mode. For more information 
on regional settings, refer to "Regional Settings tab". For more 
information on setting the direction that is north, refer to 
"Drawing a compass". 

c. Sky Conditions: The amount of light available determines the 
brightness of the resulting rendering. Use the Sky Conditions slider 
to adjust the quality of light.

d. Soft Shadow: Select the Enable soft shadow checkbox, and then use 
the slider to set the softness of shadows that are created by 
sunlight. The softer the shadow, the less sharp the resulting 
shadow.
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PREVIEW
When you click Next in Step 6, the Render Wizard calculates a small 
preview of the rendering and shows it in the right-hand view. It will 
always zoom to fit the full size of the rendered view first, but you can 
click in the view and zoom in and out using the PAGE UP/PAGE DOWN 
keys. Use the preview to fix any glaring errors in your rendering before 
you continue on to the final rendering.

Step 7 - Make Final Picture Adjustments

Options in Step 7 affect the quality of your final image.

a. Saturation: This is comparable to the exposure on a camera; it 
determines which pixels are represented as pure white. 

b. Brightness: This slider adjusts all pixels equally.
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Step 8 - Use Anti-Aliasing to Smooth or Sharpen Rough Edges

Options in Step 8 affect the antialiasing settings. Antialiasing is a 
method of smoothing out and sharpening rough or jagged edges of 
images to produce a more polished result. This method subsamples 
the pixel area and averages the results of neighboring samples to 
reduce the areas of high contrast (edges). 

a. Antialiasing Options: Choose how you want edges to appear in your 
final rendering. The Fast method samples the pixels quickly, but 
does not produce the highest quality. 

When you click Finish, the real rendering takes place. The total 
rendering time depends on the options that you selected and the 
complexity of the scenery and lighting. Based on the location where 
you chose to save the completed rendering in Step 1, your options 
vary upon clicking Finish:

 Internal and External Images: If you chose to save the 
rendering internally or externally, then you can minimize the 
Render Wizard window and continue working on other parts of your 
document as it renders. You can use the arrow keys, PAGE UP/
PAGE DOWN, mouse or scroll bars to explore the picture as it is 
being produced. The final image is saved to the destination you 
specified in step 1. 

 Background Rendering Manager Images: If you sent the 
render job to the Background Rendering Manager, then a status 
window appears, showing the progress as the render job is sent 
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to the Background Rendering Manager on the destination 
computer (either your own or another server in the network).

When the job has been sent successfully, you can open the 
Background Rendering Manager to check its progress. You can close 
the Render Wizard and WYSIWYG, queue jobs, pause and resume 
them, and shut down/restart your computer without losing the 
rendering progress. For details, see "To use the Background 
Rendering Manager".

Note: If this is the first time you are using the Background Rendering 
Manager, you must first configure it before the rendering process will 
begin. Upon clicking Finish in the Render Wizard, the Configuration Wizard 
appears, enabling you to configure settings such as the Network Port, the 
default folder for storing rendering files, and other Manager settings. For 
details, see "To configure the Background Rendering Manager".

Saving render settings

You can save the options that you set in the Render Wizard as a shortcut 
for quick access to these settings at a future time. There are two ways of 
saving a Render shortcut: 

 From the Render Wizard. 
 From the Render shortcut bar, in a similar manner as other shortcuts.

The Render shortcut bar is prepopulated with two shortcuts: Quick Render 
and Full Render. Quick Render shortcuts provide settings for a small, lower-
quality render, while Full Render shortcuts provide settings for a larger, 
high-quality rendering. 

To create a shortcut from the Render Wizard

1 From the Design menu, choose Render.

2 While working through the steps in the Render Wizard, you can, at any 
time, click Add Shortcut to save the current settings as a shortcut.

3 Type a name for the shortcut. 
4 Click OK. 

Result: The shortcut is added to the Render shortcut bar.

To create a shortcut from the Render shortcut bar

1 Right-click in the open space on the Render shortcut bar, and then 
choose New Render.

2 Type a name for the new render.
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3 Click OK.
Result: The Render shortcut is saved on the Render shortcut bar. The 
shortcut is preconfigured with the default values for each of the eight 
steps. These defaults are the same values that are used when you 
choose Render from the Menu bar or the toolbar. 

To modify a Render shortcut

1 Double-click on the Render shortcut that you want to modify. 

Result: The Render Wizard appears, with the values that are saved in 
the shortcut.

2 Modify the options as required.
Result: The settings are recorded in the shortcut and are available 
the next time that you select the shortcut.
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Background Rendering Manager

Introduction

Once you have used the Render Wizard to set up the look that you want 
to render, you can send the render job to the Background Rendering 
Manager to create the actual rendering. You can send multiple jobs to 
the Background Rendering Manager queue and then arrange the order of 
the queue or remove jobs from it. While you can send multiple jobs, the 
Background Rendering Manager processes only one job at a time, the job 
at the top of the queue. Once this job is finished, it will then 
automatically proceed to the next queued job, and so on. 

If you manually move a job in progress from the top of the queue down, 
you pause the rendering and start processing the next job in the queue. 
However, you do not lose the progress of any rendering jobs that have 
been started. When they reach the top of the queue, the Background 
Rendering Manager resumes rendering the image where it last left off.

The Background Rendering Manager processes render jobs 
independently without requiring WYSIWYG to run. This feature lets you 
work on other tasks while the renderings in the queue are processed in 
the order you arranged. You can work on new WYSIWYG files, or you can 
close WYSIWYG altogether and perform other tasks. You can even shut 
down your computer and restart later without losing the rendering 
progress.

When setting up renderings in the Render Wizard, you can send jobs to 
the Background Rendering Manager that resides on the same computer, 
or to another computer in your network that is also running the 
Background Rendering Manager (and has a dongle attached). By sending 
all rendering jobs to another computer, you free up CPU capacity on your 
own computer.

Configuring the background rendering manager

When you open the Background Rendering Manager for the first time, the 
Configuration Wizard appears, prompting you to choose settings, such as 
the network port, the startup options, and the folder where all renderings 
are stored.

This Wizard appears automatically when:

 You click Start > All Programs > WYSIWYG > WYSIWYG Background 
Rendering Manager to open the program for the first time.
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 You click Finish in the Render Wizard after setting up a rendering and 
choosing to send it to the Background Rendering Manager for the 
first time.

To configure the Background Rendering Manager

1 Click Start > All Programs > WYSIWYG > WYSIWYG Background 
Rendering Manager.

2 In the Welcome window, click Next.

 

3 Select whether you want the program to use the default settings or 
custom settings that you specify.
 Typical: Click this option to configure the program with the default 

working directory and network port settings.

 Advanced: Click this option to specify the working directory and 
network port settings for the program.

4 Click Next. If you chose Typical in the previous step, proceed directly 
to step 9. If you chose Advanced, the following window appears:

 

5 The working directory is used to store files that the render engine 
requires to generate renderings. To change the default working 
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directory shown (for example, if you have run out of space on the 
default drive), type the path and new folder name in the box 
provided, or click Browse to locate the folder. It is recommended that 
the folder be new and empty.

6 Click Next.

 

7 Type the incoming Network Port that the Background Rendering 
Manager will monitor for rendering jobs sent from WYSIWYG. 
Notes: 
 If you change this default port, you must also change the 

outbound port configured in the Render Wizard for sending jobs 
to this Background Rendering Manager. These two ports must 
match.

 When you choose the network port, Windows Firewall will 
automatically be configured to enable network communication. If 
you are using a different firewall, then you must configure its 
settings manually.

8 Click Next.

 

9 Choose the startup mode for the Background Rendering Manager. 
You can choose one option or both.
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 Run at Windows Startup: Select this option to have the Background 
Rendering Manager automatically start every time Windows starts 
up. With this option, the application immediately begins 
rendering submitted jobs as soon as you start up your computer, 
unless it was paused on last exit. 

 Start Minimized: Select this option to have the Background 
Rendering Manager appear as a minimized taskbar icon every 
time it starts. Double-click the icon to manually restore the 
application to its full size. If you select only this option, the 
Background Rendering Manager starts when you send a render 
job to it from a Render Wizard that is installed on this same 
computer. However, if you are sending render jobs from a 
different computer, then you will have to manually open the 
Background Rendering Manager on this computer before it will 
accept render jobs.

10 Click Next.
11 Click Finish.

Result: The Background Rendering Manager is now ready to use.

Tip: To change these settings at any time, you can run the 
Configuration Wizard again by clicking Tools > Configuration Wizard. 
You can also click Tools > Options to change these settings on one 
window.

Background rendering manager taskbar icons

Based on the settings that you chose when configuring the Background 
Rendering Manager, when the program is started, it appears either as a 
maximized window or a minimized icon on the right side of the Windows 
taskbar. The icon changes according to the current state of the program. 
Double-click the taskbar icon to open the program.

Background rendering manager window

When you open the Background Rendering Manager (either by sending a 
render job to it, or double-clicking the taskbar icon), the main window 
appears, showing you the status of all rendering jobs.

Icon Status

When this icon appears, the program is idle. Either it has not 
been configured yet, or no jobs have been sent to it.

When this icon appears, the program is currently processing a 
job in the queue.

When this icon appears, the program is paused. 

When this icon appears, the program has completed all jobs in 
the queue.
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Job pane
The Job pane shows you all jobs that have been successfully sent to the 
Background Rendering Manager. While you can send multiple jobs, the 
Background Rendering Manager processes only one job at a time, the job 
at the top of the queue. Once this job is finished, it will then 
automatically proceed to the next queued job, and so on. For tips on 
managing the jobs listed, see "Managing jobs in the background 
rendering manager queue".

Preview pane
This window shows you a visual representation of the rendering 
progress. Note that the final image is scaled to fit this pane and is not 
indicative of the quality of the actual rendering. To view the final 
rendering, you must export the image as a graphic file. For details, see 
"To export rendered images from the Background Rendering Manager".

Log window
Check the messages in the log window for an up-to-date status as the 
rendering job is processed. You can change and resize the font in this 
window by using the drop-down boxes provided.

Using the background rendering manager

Once you have configured the Background Rendering Manager, it is ready 
to accept render jobs from WYSIWYG. 
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To use the Background Rendering Manager

1 In WYSIWYG, open the Render Wizard and set up the rendering that 
you want to create, choosing Background Rendering Manager in Step 1.

2 Proceed through the steps of the Render Wizard, and then click 
Finish.
Result: The Submitting Render Job window appears, showing the 
progress as the job is sent to the Background Rendering Manager.

3 When the job is successfully sent, a WYSIWYG message box notifies 
you. The next step differs based on where you sent the job (either to 
your own computer, or another computer on the network):
 Background Rendering Manager residing on your 

computer: If you have sent the job to the Background Rendering 
Manager residing on the same computer as the Render Wizard, it 
automatically starts processing the rendering if there are no jobs 
currently being rendered (if it is currently processing a job, the 
new job is placed in the active queue). 

 Background Rendering Manager residing on a network 
computer: If you have sent the job to the Background Rendering 
Manager residing a network computer, you must first ensure that 
the Background Rendering Manager is started before it will 
process the job. The act of sending a rendering job does not start 
the Background Rendering Manager when it is installed on a 
network computer.

4 Open the Background Rendering Manager to check the progress of the 
rendering and arrange the rendering queue. For details, see 
"Managing jobs in the background rendering manager queue".

Note: You can shut down your computer while the Background 
Rendering Manager is processing the job without losing the rendering 
progress. You can also pause and resume the program. When you restart 
your computer or resume the program, the rendering continues where it 
last left off. (You might need to open the Background Rendering Manager 
manually before it will resume rendering.)

Managing jobs in the background rendering manager queue

The Job pane shows you all jobs that have been successfully sent to the 
Background Rendering Manager. While you can send multiple jobs, the 
Background Rendering Manager processes only one job at a time, the job 
at the top of the queue. Once this job is finished, it will then 
automatically proceed to the next queued job, and so on. 

As shown in the Status column in the following graphic, rendering jobs 
can have one of four statuses:
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 Rendering: This is the job that is currently being processed. Only 
one job can have this status at any given time. The values in the 
Progress and Time Left columns indicate when the job will be finished. 

 Queued: Jobs with this status are waiting to be processed. These 
can be new jobs or those that have already started, but have been 
interrupted by moving them down in the queue. In this latter case, 
when the job is moved back to the top of the queue, the rendering 
automatically resumes where it left off. 

 Stopped: Jobs with this status have been manually dequeued. This 
means that they will not automatically move up in the queue as jobs 
are completed. To process jobs with this status, you have to highlight 
them and click Queue to move them back into the active queue (or 
click Render Job Now to start rendering the job immediately).

 Completed: These are jobs that have been processed successfully. 
However, the actual rendering image still resides in the Background 
Rendering Manager. To export the image to a folder of your choice, 
highlight the completed job, and then click Save Rendering.

Background Rendering Manager buttons
The table below contains descriptions of the Background Rendering 
Manager buttons. Use these descriptions as a guideline when managing 
the jobs in the queue. 

Button Explanation

Resume Rendering: This button is enabled when you have 
paused all jobs in the Background Rendering Manager. Click this 
button to resume the rendering process, starting with the first 
job in the queue. The rendering continues where it last left off. 

Pause Rendering: This button is enabled when the 
Background Rendering Manager is currently processing a render 
job. Click this button to pause all rendering activity in the 
Background Rendering Manager.

Show Log Window: Click this button to show or hide the log 
window, listing all status and error messages of the Background 
Rendering Manager.

Show Render Window: Click this button to show or hide the 
window that shows the progress of the rendering.
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Render Job Now: When you have multiple render jobs in the 
queue waiting to be processed, highlight any rendering job with 
the Queued status and press this button to move the job to the 
top of the queue. The current rendering is paused and moved 
down one position and the new render job starts immediately.

Queue Job: This button is enabled only when you have selected 
a dequeued job (it is stopped, but its rendering progress is 
retained). Highlight the stopped job and then click this button to 
move it back into the queue. If there is a job being processed, 
the newly queued job is placed below it.

Dequeue Job: Highlight a job with the Queued status and then 
press this button to give the job the Stopped status. You can 
dequeue any job in the queue, those that are waiting to be 
processed as well as the job that is currently being rendered. 
When you dequeue a job, the Background Rendering Manager 
retains its rendering progress and resumes the rendering when 
you move the job back up to the top of the queue.

Move Job Up: This button enables you to move jobs up within 
their current status level when you have multiple jobs that are 
either Stopped or Queued. You cannot use this button to move a 
stopped job into the active queue. However, you can click the 
bottom job in the Queued status area and use this button to 
move it all the way to the top of the queue so that it starts being 
processed (click Render Job Now as a shortcut). You can also click 
the bottom job in the Stopped status area and move it up within 
this same area, if desired.

Move Job Down: This button enables you to move jobs down 
within their current status level when you have multiple jobs 
that are either Stopped or Queued. You cannot use this button 
to move a queued job into the Stopped status. However, you 
can click the top job in the Queued status area (the job that is 
currently being processed) and use this button to move it all the 
way to the bottom of the queue. You can also click the top job in 
the Stopped status area and move it down within this same 
area, if desired.

Delete Job: Highlight any job in the Job pane—those with the 
Rendering, Queued, Stopped, or Completed status—and press 
this button to delete the job and all supporting files from the 
Background Rendering Manager. Note that when you delete 
jobs, you cannot recover them and there will be no record of 
them.

Button Explanation
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To pause and resume all jobs in the Background Rendering 
Manager
To free up some CPU capacity on your computer (for example, if you are 
going to run another program), you can pause the Background Rendering 
Manager and the job that is currently in progress. When you click 
Resume, the job at the top of the queue continues rendering where it left 
off.

1 In the Background Rendering Manager window, click the Pause 
button. 

2 Click Resume when you want to resume rendering the job at the top 
of the queue.  

To move a render job to the top of the queue
When you move a Queued job to the top of the queue, the Background 
Rendering Manager automatically starts to process it. The current job is 
moved down one step in the queue to a paused status (any progress that 
had been made in the rendering is saved with the job).

1 In the Background Rendering Manager window, highlight the Queued 
job that you want to start rendering.

2 Press the Move Job Up button until the job is at the top of the queue. 

Result: The job starts rendering.

Tip: If you have many jobs in the queue, click the Render Job Now 
button to move a job from the bottom of the queue to the top and 
start rendering it immediately. 

Save Rendering: Highlight a Completed job that you want to 
save, and then click this button to export the rendering as a 
graphic file to the folder of your choice. You are then prompted 
to choose the location for the file and the file type (.bmp, .jpg, 
.tif, or .gif).

 The Pause button.

 The Resume button.

 The Move Job Up button.

Button Explanation
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To remove a render job from the queue
When you remove a job from the queue, it will not automatically move 
up in the queue as jobs are completed. Instead, to process jobs with this 
status, you have to highlight them and click Queue to move them back 
into the active queue.

1 In the Background Rendering Manager window, highlight the 
Rendering or Queued job that you want to remove from the queue.

2 Press the Dequeue button. 

Result: The job is moved out of the queue and given the Stopped 
status.

To move a stopped render job back into the queue
When you dequeue a job, you cannot use the Move Job Up button to move 
it back into the active queue; instead, you must use the Queue button to 
place the job back into the queue. The job will be processed when it 
reaches the top of the queue.

1 In the Background Rendering Manager window, highlight the 
Stopped job that you want to move back into the queue.

2 Press the Queue button. 

Result: The job moves to the active queue.

To move render jobs up or down in the queue
When you have multiple jobs that are either Queued or Stopped, you can 
move jobs up or down within their current status level. For example, you 
can use this feature to arrange the order in which the Background 
Rendering Manager will process queued jobs, or you can move a queued 
job to the top of the queue so that it is processed immediately.

1 In the Background Rendering Manager window, highlight the Queued 
or Stopped job that you want to move.

2 Press the Move Job Up or Move Job Down button repeatedly until the 
desired position is reached in the queue.   

 The Dequeue button.

 The Queue button.

 The Move Job Up button.

 The Move Job Down button.
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To export rendered images from the Background Rendering 
Manager
To use the rendered images that you create with the Background 
Rendering Manager, you must export them to a folder of your choice, in a 
graphic format like .bmp, .jpg, or .gif.

1 In the Background Rendering Manager window, highlight the 
Completed job that you want to export.

2 Click the Save Rendering button. 

3 Browse to the location where you want to save the rendered image.
4 In the File name box, type the name of the file.
5 From the Save as type drop-down list, choose a graphic format (.bmp, 

.jpg, .tif or .gif).
6 Click Save.

To delete render jobs from the Background Rendering 
Manager
You can delete any job—those with the Rendering, Queued, Stopped, or 
Completed status—and all of its supporting files from the Background 
Rendering Manager. Note that when you delete jobs, you cannot recover 
them and there will be no record of them.

1 In the Background Rendering Manager window, highlight the job that 
you want to delete.

2 Press the Delete button. A message box asks you to confirm your 
choice. 

3 Click Yes.

 The Save Rendering button.

 The Delete button.
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Chapter  12

Presentation mode

Presentation (Pres) mode contains all the necessary tools for 
creating professional printouts of your show document, including 
reports, plots, and images. 

In this chapter
Layout tabs 781

Reports 782

New Plots 794

Layouts 820

Images 865

Worksheets 866

Pipe tapes 870

Production Team Info Wizard 873
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Layout tabs

Introduction

Beneath the work area in each mode is a series of Layout tabs. These 
tabs provide various configurations of the views that you are working 
with. To change layouts, click the tab that corresponds to the layout that 
you want to use. 

Presentation mode contains the following Layout tabs:

 Reports: The work area displays reports formatted for printing.
 New Plots: The work area displays plots. 
 Layouts: The work area displays layouts formatted for printing.
 Images: The work area displays bitmap or jpeg images that are 

stored with the show file.
 Worksheet: The work area contains spreadsheets that the user can 

edit.
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Reports

Introduction

The Reports tab opens a series of pre-formatted reports that are 
generated by WYSIWYG, containing all data entered in CAD and Data 
modes. These reports are available for you to use as is, or to modify to 
suit your needs. Unlike the spreadsheets in Data mode, you cannot edit 
fixture data here. Reports are designed to be printed documents. You 
can, however, modify their setup and layout. 

Notes: 

 The “Rigging Points by Position” report on the Truss Rigging Point 
symbols will be replaced automatically when a file is loaded or 
merged. The new version will report on drawn Rigging Point objects.

 The “Rigging Points List” report (which does not group Rigging Points 
by the Position column) will be added automatically if it does not 
already exist in the file.
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Working with reports

To modify a report

1 In the Reports tab, right-click and select View Options.

Result: The View Options window appears.

Tip: You can use the View Options tool on the Standard toolbar. 

2 Modify the Scene options as desired.
3 Select the fixture categories from the Exclude the following Fixture 

Categories list in the Fixture Exclusions from this Report section, to remove 
from the report all fixtures under the categories.

4 Select the individual fixture types from the Exclude the following Fixture 
Types list in the Fixture Exclusions from this Report section, to remove 
from the report.

 The View Options button.
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5 Select the accessory types from the Exclude the following Accessory 
Types list in the Fixture Exclusions from this Report section, to remove 
from the report all accessories that was added to the fixtures.

6 Click OK.

General tab
Options on the General tab affect the scene that is displayed in the report.

 Follow Current Scene: Select this checkbox to filter the report according 
to the current scene. The current scene is displayed in the drop-down 
list on the Scene toolbar and in the Scene Database dialog box (from 
the Managers menu, choose Scenes). 
To filter your show information based on the scene selected, clear 
the checkbox, and then select the desired scene from the Scene drop-
down list. Only fixtures on the active layers (or layers in the scene) 
are displayed in the report. 
Tip: You can change the current scene at any time by using either 
the Scene toolbar or the Scene Database dialog box. For more 
information on scenes, refer to "Scenes".

Report tab
Options on the Report tab affect the appearance of the report. 
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 Report Defaults: Click this button to open the Report Defaults window.
 Report Type: Indicates the type of report. Can be either one of 

Fixtures or Truss. The Report Type determines the available options 
under Report Detail and the columns available for use in the report.

 Report Detail: Changing the detail level will change how the row 
information is displayed in your report. 
 Example 1: Given a Three Cell Cyc light, the Fixtures detail level 

will only give you one row of data: Three Cell Cyc. If you switch 
the detail level to Circuits, then you will get three rows of Three Cell 
Cyc, one for each circuit.

 Example 2: Given a Source 4 with a Scroller attachment, a report 
with the Fixtures detail level will simply display “Source 4”. The 
same report with the Fixtures and Accessories detail level will display 
one row for Source 4 and one row for the scroller attachment.

 Group By: Select a data field for grouping data. These groups will 
appear as separate tabs at the bottom of a report. In the case of an 
Instrument Schedule, fixtures are grouped by hanging position. Each 
position appears on a separate page.
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 Columns: Each row in the Columns table represents a column that 
can be displayed in the Report. To enable a header, select the 
checkbox on the row of the relevant data column.
 Columns – Group Total: This checkbox appears only when Group By is 

not set to None. When selected, WYSIWYG generates the sum-total 
of the data column underneath the last cell in that column.

 Columns – Report Total: When Group By is set to None, Group Total will 
generate a sum-total of the data column underneath the last cell in 
that column; otherwise, a new Totals tab will be created, listing 
the sum-total of the data for that column across all groups.

 Columns – Word Wrap: When selected, the text in that column will 
use word wrap to try to fit all the text in the cell.

 Up/Down: These controls let you re-order the way columns appear 
in your report. First, select a row in the Columns table, and re-
arrange it using Up/Down buttons.

 Move selected columns to top: When selected, all visible columns will 
be shifted to the top of the Columns table.

 Merge duplicate rows: When selected, all rows with duplicate Type 
names will be grouped into one row. For example, a report that 
has a Three Cell Cyc with Circuits Report Detail will show three 
individual rows, one for each circuit in the Three cell Cyc. With 
merge duplicate rows enabled, the three circuits will be combined 
into one row.

 Combine group sheets: When selected, multiple reports will be 
combined to be on the same sheet. When a Report is grouped by a 
column, this option is enabled. When selected, the separate Report 
sheets will be displayed on one Report tab. This option may be 
helpful if you wish to display the grouped Reports on a Layout with 
in one Report object. 

 Show totals of merged duplicates: This option is enabled only when 
Merge duplicate rows is enabled. After merging duplicate lines, this 
gives you the option to show the quantity of a single item, or the 
sum total of all the merged items. For example, if a Three Cell Cyc 
with Circuits Report Detail is merged, you can show the Wattage of 
an individual circuit (Show totals of merged duplicates OFF) or the 
total Wattage of all three circuits (Show totals of merged 
duplicates ON).

 List Accessories under their Fixture: This option is available if Fixtures 
and Accessories is selected from the Report Detail drop-down list. 
Select this checkbox to add the list of accessories attached to the 
fixture below the fixture.

 Identify Accessories: This option is available if the List Accessories 
under their Fixture checkbox is enabled which will add a symbol to 
identify the accessories on the list. Select this checkbox and click 
on the symbol from the drop-down list.

 Sort By: Contains the settings for how the report will be sorted. The 
keys sort fixtures in alphabetical or numeric order. When fixtures 
have the same value in the first sort key, the report is then sorted by 
the values of the second sort key, and so on for the third sort key. 
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For example, the standard Instrument Schedule sorts fixtures by 
position as Key 1, and unit number as Key 2. When a column is 
selected as a key, the visible option will be checked and greyed out. 
Columns that are sort keys must be visible.

 Filter By: Contains settings for the column that you selected from 
the Columns list. You can use filters to extract specific information 
from reports. A total of three filters can be applied to any given 
report. For example, you can create a report that displays all the 
fixtures that have notes. To do so, select the Notes column and the 
Visible checkbox, and then select the filter Not Empty. You will also 
have to make Position, Unit, and Channel visible so that you know 
which fixtures have these notes.

To create a new report

1 Click the Reports shortcut tab.

2 Right-click in the reports shortcut area, and then choose New Report.
3 Type the name of your new report.
4 Select the Report Type (Fixtures, Truss, etc.).
5 Select an existing report from which you would like to copy the 

columns, formatting, filters, etc.
6 Click OK.

Sharing Reports
You can save a Report to the application level, and then you can export 
or import this Report to and from other files.

To share a report

1 In the Reports tab, from the REPORT menu, choose Add Default 
Report.

Result: The Add Default Report dialog box appears.

2 Type the name of your default report.
3 Select the Default Report from the Select Default Report drop-down list.
4 Click OK.

Result: The Default Report that you added will be included in the list 
of Reports that can be exported and the list of Report Templates that 
can be imported from the File menu.

Redesigning Headings
You can customize the fonts, styles, and layouts used in the headings 
and text of your reports. These settings can be applied to the headings of 
all reports in your document as desired.
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To change the heading format

Report headings can be directly modified on the current report. You may 
add, remove, and change the formatting of cells within the report with a 
limited degree of freedom. For more information about the functionality 
of the spreadsheet, refer to "Worksheets".

To apply the current formatting to other reports
Once the editing has been completed, you can apply the look and feel of 
your current report by completing the following steps:

1 Select Report > Apply Current Report Template.

2 In the new dialog box, select the reports to which you want to apply 
the current format.

3 Click OK.

To merge cells

1 Select cells you wish to merge together.

2 Right-click and select Merge > Merge Cells.
Result: The cells will be merged and any text will span the merged 
cell.

To unmerge cells

1 Select cell you wish to separate.

2 Right-click and select Merge > Unmerge Cells.
Result: Cells will be unmerged.

Report Templates
You can customize the formatting used in the headings of your reports 
and apply the customized headings to all the reports in your document.

You can save the modified reports with the customized headings by 
exporting the file as Report Templates. Consequently, you can import the 
Report Templates into WYSIWYG and apply the customized headings to 
selected reports in your document.

To export report formatting
You can save the current report with customized heading format to a file, 
as follows:

1 Select File > Export > Report Template.

Result: The Export window appears.

2 In the Export window, type the name of your Report Template file.
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3 Select the file format that you would like to export to.
4 Click Save.

Note: For optimal compatibility with other WYG files, it is recommended 
that you export to the WYSIWYG Spreadsheet format (*.wss).

To import report formatting
You can import and apply the customized report heading format into 
WYSIWYG as follows:

1 Select File > Import Report Template.

Result: The Choose which Reports to import into window appears.

2 On the Choose which Reports to import into window, select the Report(s) 
where the customized heading format will be applied to.
Tip: 
 You may click Select All if you want to apply the customized 

heading format to all the reports in WYSIWYG.

 You may click Select None if you choose not to apply to any report.

 You may click Sort Alphabetically to display the list of reports in 
alphabetical order.

3 Click OK.
Result: The Import window appears.

4 From the Import window, select the exported Report Template file you 
wish to apply to the selected report document(s) in WYSIWYG.

5 Click Open.
Result: The customized heading format of the imported Report 
Template is applied to the selected report document(s).

Column widths

You can change the column widths in the report. A double-headed arrow 
appears when you float the cursor between the column separations at 
the top of the report. Double-click the column headings to have the 
column resize to fit (auto-fit) the contents.

Formatting Data section in Reports

Reports data cells in WYSIWYG can be formated in many different ways 
to suit your needs. Each column in a report can be individually formated, 
and every row that appears under that column will have the same 
formatting e.g. text alignment, font style, font color, font size, font style, 
background color. Reports can also be edited to have zebra stripes or 
have borders around columns. 
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To format a report column

1 Select a cell in the column you want to format. If you select a cell in 
a column, the entire column should be selected.

Note: Clicking the first cell of the first column, called the smart cell, 
will select every cell.

2 From the Reports menu, select Format Cell.
Result: The Format Cells window appears.

3 In the Format Cells window, edit the cells how you want.
Result: When finished editing, click OK.

Note: Alternatively, you can use the New Plot Text toolbar for editing 
the cells.

Zebra Striping
Zebra striping is a feature in reports where ever other data row will be 
highlighted in a report. 

To add zebra striping to a report

Note: Formatting a cell will override zebra stripping.

From the Reports menu, select Zebra Striping.

An example report spreadsheet 
without zebra stripping.

The same report spreadsheet with 
zebra stripping enabled. Notice 
the grey rows.
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Combining Report
It is possible to display the reports of multiple sheets of a group into a 
single report. This combined report will fit on a single page.

To combine reports

1 Right-click in a report and select View Options.

Result: The View Options window appears.

2 In the View Options window, in the Report tab, in the Columns section, 
enable Combine group sheets.

3 Click OK.
Result: The multiple pages of the group report will be merged and 
be displayed on a single page. 

Using formulas in spreadsheets

Over 100 formulas for common mathematical and logic functions are 
supported in WYSIWYG (you must manually enter the formula as text in 
a cell). Examples of formula include the following: 

ABS: determines the absolute value of the specified value, cell or 
expression. 

Syntax: ABS(value)
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Syntax: ABS(expression) 

Example: =ABS(-4) gives output 4
Example: =ABS(B4) alternatively, reference cells within your 
sheet

AVERAGE: finds the averages of a list of values.

Syntax: AVERAGE(value1, value2,...)

Syntax: AVERAGE(array1, array2, ...)

Example: =AVERAGE(1,2,3,4,5) gives output 3
Example: =AVERAGE(A1:A10) alternatively, reference cells in 
your sheet

CEILING: rounds a number up to the nearest multiple of the specified 
value. 

Syntax: CEILING (value, rounding multiple) 

Example: =CEILING(2.3, 1) rounds to the closest whole number 
in the negative range, gives output 3

FLOOR: rounds a number down to the nearest multiple of the specified 
value. 

Syntax: FLOOR (value, rounding multiple) 

Example: =FLOOR(2.3, 1) rounds to the closest whole number in 
the positive range, gives output 2

MAX: returns the maximum value from a given list of values.

Syntax: MAX(value1, value2,...)

Syntax: MAX(array1, array2,...)

Example: =MAX(1,2,3,4,5) gives 5
Example: =MAX(A1:A5, B2:B21) allows you to find the maximum 
value from multiple ranges

MEDIAN: returns the median, or the number in the middle of the 
provided set of numbers.
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Syntax: MEDIAN(value1, value2,...)

Syntax: MEDIAN(array1, array2,...)

Example: =MAX(1,2,3,4,5) gives 3
Example: =MAX(A1:A5, B2:B21) allows you to find the median 
value from multiple ranges

MIN: returns the minimum value from a given list of values.

Syntax: MIN(value1, value2,...)

Syntax: MIN(array1, array2,...)

Example: =MIN(1,2,3,4,5) gives 1
Example: =MIN(A1:A5, B2:B21) allows you to find the minimum 
value from multiple ranges

SUM: returns the sum of cells or range of cells.

Syntax: SUM(value1, value2,...)

Syntax: SUM(array1, array2,...)

Example: =SUM(1,2,3,4,5) gives output 15
Example: =SUM(A1:15) allows you to sum over a range of cells
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New Plots

Introduction

New Plots views were introduced so that you could more effectively 
manipulate a drawing developed in CAD mode to create a lighting plot or 
“schematic” for printing.

In the New Plots view you can:

 Manipulate all fixtures and hang structures in a plot without affecting 
the objects in the original CAD drawing/model. 

 Notate your plot using objects such as circles, lines, arrows, and text 
labels. 

 Rotate the position of vertical hang structures to better illustrate 
mounted fixtures.

 Move, rotate, or manipulate the layout of fixture attributes with click-
and-drag. 

Working in the new plots view

Working in a New Plots view is similar in some respects to working with a 
drawing in a CAD wireframe view. You can use your keyboard and mouse 
to navigate around the plot easily and quickly. A Command Line interface is 
available to help you when entering coordinates. 

IMPORTANT: Changes made to a drawing in CAD mode are not 
automatically reflected in the New Plots view. You must update plots 
manually to see the changes. For details, see "Updating plots".

Keyboard and mouse control
Navigating in a New Plots view is similar to navigating in CAD mode. The 
arrow keys are available to help you move in the direction that is noted 
on the key. As well, scroll bars along the side and bottom of the window 
will move you horizontally and vertically along the window. 

For a complete list of the navigation tools that are available, refer to 
"Keyboard and mouse control". 

Command Line
The Command Line toolbar is available to help you enter coordinates when 
placing objects such as lines in a New Plots view. For more information 
on Command Line, refer to "Command line".
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Creating a new plot

Plots are 2D schematics of your CAD model for printout. You can 
generate as many plots as you like. Once generated, the “view type” of 
the New Plot or schematic is set and cannot be changed. There are five 
plot types available. 

To create a new plot type

1 Click the New Plots shortcut tab.

2 Right-click in the New Plots shortcut area and choose the type of plot 
that you want to create.

3 Type the name of the plot.
4 Click OK.

Result: The type of plot that you chose is created and a shortcut to 
your new plot is added to the New Plots shortcut bar. For information 
on working with shortcuts, refer to "Working with shortcuts".

Note: The plot is created with a specific set of default properties, but you 
can modify these settings as required. For more information on the 
settings, refer to "Modifying the properties of a plot" below. 

Updating plots

Changes made to a drawing in CAD mode are not automatically reflected 
in the New Plots view. You must update plots manually. 

Plot Type Description

Plan Plot Generates the schematic 
from above looking down. 

Left Section Plot Generates the schematic 
looking from the left side 
through the venue. 

Right Section Plot Generates the schematic 
looking from the right side 
through the venue. 

Front Elevation Plot Generates the schematic 
looking from the front side 
through the venue. 

Back Elevation Plot Generates the schematic 
looking from the back side 
through the venue. 
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Note: WYSIWYG automatically replaces inserted Truss Rigging Point 
symbols that were inserted from the Library Browser with drawn Rigging 
Point objects whenever a file is loaded or merged. However, the 
replacement of Truss Rigging Point symbols do not automatically update 
New Plots. You must remove or replace the inserted Truss Rigging Point 
symbols from New Plots manually and click the Update New Plot 
command.

To update a plot

1 Select the plot that you want to update.

2 From the Options menu, choose Update New Plot.

Note: If the New Plots view already reflects the current CAD drawing, 
the option is disabled.

Modifying the properties of a plot

You can modify the border thickness, paper size, or scaling of a plot. 

To modify plot properties

1 Select the plot for which you want to modify the settings.

2 From the Options menu, choose View Options.
Tip: You can also use the View Options tool on the Standard toolbar. 

Result: The View Options dialog box appears.

 The View Options button.
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New Plot View Properties tab
Options on the New Plot View Properties tab affect the appearance of the 
plot. 

 Name: The name of the plot. 
 Grid On: Select this checkbox if you want gridlines to appear on the 

plot view. Gridlines are for reference only; they assist with the layout 
of plot items on the page. Gridlines do not appear in the printed 
output.

 Color: Click this color box to select a different color for the gridlines.
 Point Size: The size at which points are printed. 
 Paper Size: Choose the desired paper size from the drop-down list. If 

you do not find the size you want, choose Custom, and then specify 
the width and height as desired. The default values are 24.0” X 36.0” 
(imperial measurement) or A1 (metric measurement).

 Landscape: Select this checkbox if you want the page to be set up in 
landscape format.

 Margins: The margins for the plot. The default values are 1/2” 
(imperial measurement) or 1cm (metric measurement).

 Border Thickness: The thickness of the plot’s border. The border is 
drawn at the margins defined above. The default values are 1/16” 
(imperial measurement) or 1mm (metric measurement). 

 Scale: The scale at which the plot is drawn. If the scale you want to 
use for printing is not displayed, select Custom. The default values are 
1/4”=1’0” (imperial measurement) or 1:50 (metric measurement). 

 On paper: The scale ratio that you want to use on a paper copy of the 
plot view. 

 Real World: The “real” measurement for the scale ratio that you 
specify in the On paper box. For example, you may want to use a 
scaling of one inch in a paper copy of your plot. This one-inch 
measurement translates to a “realistic” measurement (for example, 
3 feet).

 Follow Current Scene: Select this checkbox to use the scene that is 
displayed in the drop-down list on the Scene toolbar. Clear the 
checkbox, and then select the desired scene from the Scene drop-
down list. For more information on scenes, refer to "Scenes".

 Units: The units of measurement for the plot. The coordinates at the 
bottom of the plot change according to the selection. This setting 
does not affect the printed output. 

 Print in Black and White: Select this checkbox if you want the plot to be 
displayed and printed in black and white. 

Tile Printing tab
Options on the Tile Printing tab affect the printout of the plot.
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 Show page guides: Select this checkbox if you want the printable 
outlines to be displayed on each sheet of paper that comprises the 
plot. The solid outline is the chosen printer’s paper size and 
orientation. 

 Show page number: Select this checkbox if you want the page numbers 
of the plot to be displayed in the center of each page. The page 
numbers are for reference only and do not appear in the printed 
output. 

 Tile options: Click the appropriate option button to enable one of the 
following:
 Top-Left: Click to place the top-left corner of the plot in the top-left 

corner of the first page, and then arrange the remaining pages 
accordingly. 

 Center: Click to place the center of the plot at the center of a page, 
and then arrange the remaining pages accordingly.

 Split Center: Click to place the center of the plot at the corner of 
four pages, and then arrange the remaining pages accordingly.
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Fixture Details tab
Options on the Fixture Details tab affect the fixture data that is displayed 
on the plot. 

 Use Document Defaults: Clear this checkbox if you do not want the 
currently selected fixture data displayed on the plot. The default 
fixture data is defined on the Wireframe Details tab in Document Options. 
For more information on this option, refer to "Wireframe Details tab".

Moving the page 

You can move the page around to capture the parts of the schematic that 
you want plotted or printed. 

To move the page

1 Select the plot that you want to adjust. 

2 Right-click and choose Move Page.
Result: A hand similar to the Pan tool is displayed.

3 Hold down the left mouse button and drag to move the page until the 
area of the schematic that you want on the page is contained within.

4 When you are finished, right-click and select Finish Move Page.
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Objects in New Plots

Objects that are contained in the drawing in CAD mode are transposed to 
the New Plot representation. This representation is a 2D presentation of 
the drawing, and as such, certain objects are displayed differently than 
they are in the 3D CAD mode drawing. 

A specific number of objects are used to represent the objects in the CAD 
drawing. These objects are listed in the following table.

Notes: 

 The only objects that you can edit in New Plots mode are fixtures and 
hang structures; you cannot select or modify any other object in your 
model in New Plots mode.

 Beams are not represented in the New Plots view.
 Some objects may not be visible if they are on a layer that is not in 

the current scene.

Relationship between objects in CAD mode and New Plots

Fixtures and hang structures are transposed to a New Plots view from 
CAD mode and can be manipulated independently of their counterparts 
in CAD. This means that in a New Plots view, they can be deleted, copied, 
moved, and have their properties modified without affecting the original 
object in CAD mode. For example, moving a pipe does not cause the 
same pipe to also move in CAD mode. You can easily create your lighting 
plot in a New Plots view independently of the drawing or “model” in CAD 
mode. 

In contrast, changes made to the original “model” in CAD mode are 
reflected in all New Plots views. Objects that are deleted in CAD mode 
are also deleted from all New Plots views. Similarly, objects added in CAD 
mode are also added to all New Plots views, provided the layer they are 
on is visible. Note, however, that in order for new objects to appear, you 
must first update the New Plot by right-clicking on it and selecting Update 

Object in CAD mode Resulting object in New Plots

Fixtures Representative symbols

Accessories Representative symbols

Riser Riser

Text Text

Arc Arc

Ellipse Ellipse

Circle Circle
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New Plot. The same logic applies to objects that are moved in CAD mode: 
moving an object causes the object to also move in all New Plots views 
as long as the relationship between the object in CAD mode and New 
Plots is intact. 

To achieve a relationship between fixtures and hang structures in CAD 
mode and fixtures and hang structures in New Plots views, various types 
of links are available. These links track the position and properties of the 
original CAD object in New Plots, and are referred to as the positional 
and properties links, respectively. For more information on these links 
and how they work, refer to "Links".

Relationship between objects in Data mode and New Plots

You cannot modify data, such as fixture attributes, directly in a New Plots 
view; instead, you must edit this data in Data mode. Data that is 
modified in the spreadsheet view in Data mode is also updated in CAD 
mode and in all New Plots views.

Links 

There are three types of links in the New Plots view: positional, 
properties, and attributes. 

The position link tracks the movement of fixtures and hang structures 
that are brought in from the original CAD drawing. By default, this link is 
in place until one of the fixtures and hang structures from the original 
CAD drawing is moved relative to its origin. 

The properties link tracks the changes to properties for fixtures and hang 
structures that are brought in from the original CAD drawing. These 
properties include the layer line color and line weight of an object. By 
default, this link is in place until you modify one or more of these 
properties.

The attribute link tracks the changes to the attribute layout of fixtures. 
By default, this link is in place until you move, rotate, or otherwise 
manipulate the layout of a fixture attribute. For more information on 
attribute layout, refer to "Attribute layout".

When a link to an object is broken, all subsequent changes that are made 
to that object in CAD mode will not be reflected in a New Plots view. You 
must reestablish the relationship or link to ensure that changes made in 
CAD or Data mode are reflected in a New Plots view. 

Reestablishing the link returns the object to its original state before the 
link was broken. For example, reestablishing the link of a fixture that has 
been moved off a pipe moves the fixture back to its original position on 
the pipe. 
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To reestablish links

1 Select the object for which you want to reestablish a link.

2 From the Edit menu, choose Restore Links.
Result: The Links dialog box appears.

Note: The Position Link checkbox is not selected. This means that an 
action occurred that broke that link. 

3 To reestablish the link, select the Position Link checkbox. 
4 Click OK. 

Result: The positional link is reestablished. 

Vertical hang structures

In the New Plots view, non-horizontal hang structures, such as booms 
and ladders can be rotated around their base to show all mounted 
fixtures. The rotation can be top, bottom, left, or right. 
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To rotate the position of a vertical hang structure

1 Select the hang structures that you wish to rotate. 

2 Right-click and choose Rotate Position. 
Result: The Rotate Position dialog box appears.

3 Select the direction in which you want to rotate the hang structure. 
4 In the Rotation Angle box, type the angle by which you want to rotate 

the hang structure. 
5 Click OK.

Result: The hang structure is rotated on the plot. 

As an example, you may have three booms on your plot that you 
want to rotate.
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After you rotate the hang structures 90 degrees to the right, the 
following is displayed.

Attribute layout

You can easily modify the layout of fixture attributes in a New Plots view 
by simply moving, rotating, or otherwise manipulating the appearance of 
the attribute. In a New Plots view, you can only manipulate the layout; 
you cannot modify the data contained within the attribute. To modify the 
data, you will need to go to CAD or Data mode and make the 
modifications. 

Fixture attribute values that are changed in CAD or Data mode are 
reflected in all New Plots views. 

The attributes that are displayed in a New Plots view are determined by 
the options you set on the Fixture Details tab. For more information, refer 
to "Fixture Details tab".

To manipulate the attribute layout for an individual symbol

1 Select the attribute whose layout you want to manipulate. 

2 Drag the attribute to the desired location on the page, and then 
release the mouse button.
Note: This action breaks the attribute link. 
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As an example, you may wish to move the channel attribute (the red 
“2”) shown on the plot below.

After you select and drag the attribute to the desired location, the 
following is displayed.

Drawing objects

You can add objects to the plot for notation. Objects that you can draw 
include lines, arcs, circles, and text labels. You can also insert symbols 
from the Library Browser. 
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Drawing circles
Drawing circles in a New Plots view is similar to drawing circles in CAD 
mode. You can access the Circle tool from the Draw menu or from the 
New Plot Options toolbar. For more information on drawing circles, refer to 
"Drawing circles".

Note: When you add objects such as circles to your plot, they are not 
added to your drawing in CAD mode. 

Drawing arcs
Drawing arcs in a New Plots view is similar to drawing arcs in CAD mode. 
You can access the Arc tool from the Draw menu or from the New Plot 
Options toolbar. For more information, refer to "Drawing arcs".

After you have drawn an arc, you can choose to add arrows to one or 
both ends of the arc. The default is none. For more information on adding 
arrows, refer to "Arrows Options: How arrows attached to the line will 
be shown.".

Drawing lines
Drawing lines in a New Plots view is similar to drawing lines in CAD mode. 
For more information, refer to "Drawing lines".

You can also use the appropriate Line tool from the Draw menu or the 
New Plot Options toolbar. The available line tools are as follows:

 Solid 

 Dot

 Center

 Dash

You can create a double line from a single line by modifying the 
properties of a line. For more information on creating double lines, refer 
to "Double Line: Select this checkbox to display the line as a double line.".

After you have drawn a line, you can choose to add arrows to one or both 
ends of the line. The default is none. For more information on adding 
arrows, refer to "Arrows Options: How arrows attached to the line will 
be shown.".

Note: When you add objects such as lines to your plot, they are not 
added to your drawing in CAD mode. 

Drawing text
Drawing text in a New Plots view is similar to drawing text in CAD mode. 
You can access the Text tool from the Draw menu or on the New Plot 
Options toolbar. For more information, refer to "Drawing text labels".
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Notes: 

 When you add an object such as text to your plot, it is not added to 
your drawing in CAD mode. 

 You can select any font that is installed on your computer to use in 
all text labels in New Plots. For details, see "To change the font used 
in New Plots".

To change the font used in New Plots
You can specify the font that you would like to appear globally in all new 
text labels that you create in New Plots.

Note: When you change the font globally, it does not affect existing 
labels in your file, only new ones that you draw. You cannot change the 
font of existing labels in New Plots view.

1 In New Plots view, click Options > Document Options.

2 Click the Fonts tab.
3 Under New Plots Text Labels, from the Font drop-down list, select the 

font that you want to appear in all new text labels.
4 Choose whether you want the letters to appear bold, underlined, or 

in italics.
5 Click OK.

Inserting symbols
You can insert symbols that are not associated with any object in CAD 
mode. This allows you to represent the fixtures when you draw a key or 
want to show the position of a boom in a plan view, for example. You can 
access the Symbol tool from the Draw menu or from the New Plot Options 
toolbar.

To learn how to insert symbols, see "To insert objects from the library". 
In the New Plots view, the Library Browser contains only the Symbol 
library. 

Editing objects

A number of tools are available in the New Plots view to help you 
manipulate objects. 

Note: Orthographic mode is available in New Plots from the Edit menu 
and also from the New Plots Options toolbar. When ortho mode is active, 
you can manipulate objects either vertically or horizontally. For more 
information on this mode, refer to "Ortho".

 The Symbol button.
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Selecting objects
Objects are transposed from CAD mode and can, therefore, be selected 
independently of that mode (for example, moving a pipe in New Plots will 
not cause it to also move in CAD mode). 

Fixture symbols are grouped with the hang structure to which they are 
mounted. Selecting and moving the hang structure will also move the 
mounted fixture symbols. Similarly, accessories are grouped with the 
fixture symbols to which they are attached and will also move with the 
fixture symbols. You can also select an individual fixture symbol 
separately from the hang structure if you want to move or modify it 
independently. 

The methods for selecting an object are similar to those for selecting an 
object in CAD mode. For more information on these methods, refer to 
"Selecting".

Copy
When you copy and paste an object in a New Plots view, a second 
representation of that same object is created. If you subsequently 
update the data for this object in either CAD or Data mode (for example, 
gel color or channel number), all representations of that object in all New 
Plots views are updated. 

Copied objects are not added to the drawing in CAD mode nor to the 
spreadsheet in Data mode.

You can copy and paste objects between New Plots views. 

To copy an object

1 Select the object to be copied.

2 From the Edit menu, choose Copy.
3 From the Edit menu, choose Paste. 
4 Click in the plot where you want to place the object. 

Cut
When you cut an object in a New Plots view it is not removed from CAD 
mode. However, cutting an object in CAD mode removes it from all New 
Plots views. 

Cutting an object adds it to the clipboard. You can subsequently paste 
the object into a New Plots view. 

You can cut and paste objects between New Plots views. 



Reference Guide 809

January 2019 Presentation mode 

To cut an object

1 Select the object to be cut.

2 From the Edit menu, choose Cut.
3 From the Edit menu, choose Paste. 
4 Click in the plot where you want to place the object. 

Delete
Deleting an object in a New Plots view does not delete the original object 
in CAD mode. However, deleting an object in CAD mode does delete the 
representation of that object in all New Plots views. 

To delete an object

1 Select the object to be deleted.

2 From the Edit menu, choose Delete.
Result: The object is removed from all New Plots views. 

Note: If you accidentally deleted an object, you can recover it by 
choosing Undo Delete from the Edit menu. 

Move
The Move command in the New Plots view supports both absolute and 
relative moves in a manner similar to CAD mode. For more information 
on this command, refer to "Moving".

When you move a hang structure, you also move all its attached fixtures 
and accessories. You also break the positional link between the pipe in 
CAD mode and the pipe in the New Plots view. All fixtures and 
accessories that are attached to that pipe still maintain their link to the 
original objects in CAD mode, even though they have also moved.

When you move a fixture off of a hang structure, you fix its location in 
relation to the hang structure. For example, if you move a fixture off a 
pipe, and then move the pipe 10 feet, the fixture also moves with the 
pipe. This action breaks the positional link of the fixture to the hang 
structure. 

Note: You can “nudge” objects up, down, left, or right a certain distance 
by using specific key combinations. Use the ALT+arrow keys to “nudge” 
an object a specific distance; use the ALT+SHIFT+arrow keys to “nudge” 
an object a tenth of that distance.

Align
You can use the Align tools to quickly and precisely align a series of 
objects that you have drawn or inserted from the Library into your 
drawing. For example, if you have manually placed some chairs in your 
drawing, you can select them all and align them in one of six ways. 
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Notes: You cannot use the Align tool to align fixtures.

You can align the selected objects from the:

 top
 bottom
 left
 right
 center (horizontally)
 center (vertically)

Before choosing any of these options, you must select one of following 
three options: 

 To First Selected: Objects selected after the first object was 
selected will align (Left, Right, Centered Horizontally, etc.) to that 
first object.

 To Last Selected: Objects selected before the last object was 
selected will align (Left, Right, Centered Horizontally, etc.) to that 
last object.

 To Extents: All selected objects (regardless of selection order) will 
align to the left-most, right-most, bottom-most, etc. point of the left-
most, right-most, bottom-most, etc. object, respectively.

To align objects

1 In the toolbar area, ensure that the New Plot Align toolbar is showing. 

2 Select the objects that you want to align by clicking and dragging a 
selection box around them, or selecting them individually.

3 On the New Plot Align toolbar, choose your preferred alignment option.
 Align to First Selected

 Align to Last Selected

 Align to Extents

Note: Before you align the objects, it is recommended you first 
verify that they will not overlap each other in their new positions. 

4 On the New Plot Align toolbar, select how you would like to align the 
selected objects:
 Align Top

 Align Bottom

 Align Left

 Align Right

 Center Horizontally

 Center Vertically
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Rotate
The Rotate command in a New Plots view works in a similar manner as it 
does in CAD mode. For more information on this command, refer to 
"Rotating objects".

Note: Rotating an object breaks its positional link.

Fillet
The Fillet command in a New Plots view works in a similar manner as it 
does in CAD mode. For more information on this command, refer to 
"Fillet".

Objects that are brought into New Plots from CAD mode

There are general properties for each fixture or hang structure that is 
brought into a New Plots view from CAD mode. You can modify these 
general properties as required. 

General tab
Options on the General tab affect the selected object’s color and line 
weight properties. 
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 Layer: A list of the layers or layer groups in your document is 
displayed. Click on a list item to change the layer on which the object 
will be drawn.

 Display with Layer Groups: Select this checkbox to display the layers as 
items organized in Layer Groups.

 Collapse All: Click the Collapse All button to display only the Layer 
Groups.

 Expand All: Click the Expand All button to display the Layer Groups and 
all the Layers.

 Use Layer Color: Select this checkbox to set the object’s color for 
wireframe views to be the same as the properties of the layer on 
which the object resides. For more information, refer to "Layer 
properties".
Clear the checkbox, and then use the color button to set a specific 
color for the object. 

 Line Weight: From the drop-down list, choose the specific line weight 
for the selected object. The applied line weight is visible in all 
Wireframe views in all modes. For objects only, you can also choose 
the default setting, ByLayer, which sets the object’s line weight to be 
the same as the properties of the layer on which the object resides. 
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The value Default means that the document's line weight setting from 
the Document Options > Object Settings window is applied to the object 
or layer. For more information, refer to "Layer properties".

 Fixture Symbol Fill: Options for fixture symbols to be filled with a 
choice of colors and fill percentage.
 Use Document Defaults: Select this checkbox to display fixtures with 

default fill settings that were set in the Document Options window. 
Clear this checkbox to activate Enable and the options for Percentage 
and Custom Color.

 Enable: Select this checkbox to enable Fixture Symbol Fill.
  Percentage: Select Percentage from the drop-down list if you wish 
to fill using the same hue of the Fixture Symbol, and set the 
percentage from the drop-down list for the hue intensity.

  Custom Color: Select Custom Color from the drop-down list and 
click the Color Select box to choose a different color.

 3D Truss / Pipe Symbol Fill: Options that affect how pipe and 
truss symbols are displayed in the plot.
 Use Document Defaults: Select this checkbox to display Truss and 

Pipe symbols with default fill settings that were set in the Document 
Options window. Clear this checkbox to activate Enable and the 
options for Percentage and Custom Color. 

 Enable: Select this checkbox to display Truss and Pipe symbols with 
thickness in 2D CAD Wireframe views and in associated paperwork 
views. (Not in isometric views) Clear this checkbox to display truss 
and pipe objects as line drawings.

 Pipe Thickness: Type a new value to change the default thickness.
 Symbol Fill: Click the drop-down list to select the fill option None or 

Percentage or Custom Color.
 Percentage: Select Percentage from the drop-down list if you wish to 

display using the same hue of the Pipe or Truss symbols, and set 
the percentage from the drop-down list for the hue intensity.

 Custom Color: Select Custom Color from the drop-down list and click 
the Color Select box to choose a different color.

Retrieve Item Data 
Catalog name and other information of fixtures and trusses can be 
retrieved and displayed in New Plots.

To retrieve data from a fixture or truss object in New Plots

1 From the Edit menu, choose Retrieve Item Data.

2 Point the cursor to the fixture or truss object you want to select, 
which highlights the object in orange outline.

3 Click on the fixture or truss item.
Result: The New Text Label window appears.
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4 In the New Text Label window, you can click Insert Item Data to display 
in your drawing, the information that you retrieved from the selected 
fixture or truss.
Note: You can also add other text and smart variables, and specify 
text properties in the New Text Label window.

Objects that are drawn in New Plots

Objects such as lines, arcs, symbols, circles, and text that are drawn in a 
New Plots view have general properties that are inherited from the layer 
on which they are drawn. Along with the general properties, a tab 
appears in the properties dialog box for each type of object that is 
selected. When you select multiple objects of different types, tabs appear 
for each type of object selected.

For more information, refer to "Drawing objects".

New Plot Object tab
Options on the New Plot Object tab affect the selected object’s color and 
line weight properties. 
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For a detailed description of the options available on this window, refer to 
the "General tab". 

Object-specific properties

Similar to objects in CAD mode, objects that are drawn in a New Plots 
view have properties that are specific to that object. 

 Text label: For a description of text label properties, refer to the 
"Text label tab".

 Symbol: For a description of symbol properties, refer to "Symbol 
properties".

 Line: Options on the Line tab affect how the line is drawn. 
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 Line Pattern
 Line Pattern: Choose a pattern for the selected line. Refer to 

"Drawing lines" for an illustration of each type.
 Scale: Type a value in this box to change the length and spacing of 

dots and dashes for the selected line. This value is applicable to 
center, dashed, or dotted lines only.

 Arrow Options: How arrows attached to the line will be shown.
 Display: Select this checkbox to show an arrow at the end(s) of the 

line.
 Location: Where the arrow will appear on the line.
 Arrow Size: How large the arrow will appear.
 Arrow Type: The style of arrow that will be displayed.

 Double Line
 Double Line: Select this checkbox to display the line as a double 

line.
 Distance: How far apart the double lines will be from each other.
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Circle: The properties are the same as when the object was originally 
drawn. For more information, refer to "Drawing circles".

Arc: The radius and angle properties are the same as when the object 
was originally drawn. The only property that is different is the addition of 
arrows to either side of the selected arc. 

 Radius: The radius of the selected arc.
 Start Angle: The start angle of the arc. Degrees increment counter 

clock-wise.
 End Angle: The end angle of the arc. Degrees increment counter 

clock-wise.
 Arrows Options: How arrows attached to the line will be shown.

 Display: Select this checkbox to show an arrow at the end(s) of the 
line.

 Location: Where the arrow will appear on the line.
 Arrow Size: How large the arrow will appear.
 Arrow Type: The style of arrow that will be displayed.
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Inserting new plots into layouts

Once you create your New Plot, you can insert it into the Layouts view. 
For example, you might want to insert it into a Layouts view so that you 
can add a legend, key, or report to your plot. 

For more information on inserting a New Plot, see "To insert New Plot 
items onto the layout".

Printing new plots

While you can print directly from the New Plots tab, it is strongly 
recommended that you first insert your completed New Plot into a Layout 
and print it from there. Doing so enables you to take advantage of the 
Layout tools (and others), use title blocks, add images, and so on.

If you have a large plot you can “tile print” the plot across multiple 
smaller sheets of paper. To set up how you want the plot arranged on the 
sheets of paper, refer to the "Tile Printing tab".

You can print your complete plot or specific pages of your plot based on 
the settings that you choose. 

Note: Objects outside the border are not printed, even if they are within 
the margins of the page. To adjust margins, refer to "Modifying the 
properties of a plot".

To print your plot

1 From the File menu, choose Print. 

Result: The Print dialog box appears.

2 From the Name drop-down list, choose the printer (or plotter) that 
you want to use. WYSIWYG records the name that you choose for 
future reference and displays it as the default printer for plots. 

3 To print all pages of a plot, select All.
4 To print select pages of a plot, select Pages, and then enter the range 

in the from and to boxes.
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5 To print multiple copies of pages, select the value from the Number of 
copies list box. 

6 Click OK.
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Layouts

Introduction

The Layouts tab opens the layout design and storage area. Layouts are 
created by arranging various CAD, report, image, and other items on a 
defined paper size.

There are two default layouts included in the layouts shortcuts. The Micro 
Layouts, which is designed to print on an 8.5” x 11” piece of paper, and 
the Big Layouts, which is designed to be plotted on a 36” x 48” sheet of 
paper. You can use either of these layouts as is, modify them to suit your 
needs, or create new layouts from scratch.

To save time, you can use the Layout Templates feature to select 
multiple objects in your layouts and group them for insertion into other 
drawings. For details, see "Layout templates". 

Creating a new layout

To create a new layout

1 Click the Layouts shortcut tab.

2 Right-click in the Layouts shortcut area, and then choose New Layout.
3 Type the name of the new layout.
4 Click OK.

Result: An empty layout is created. A shortcut to your new layout is 
added to the Layouts shortcut bar.

Note: By default, empty layouts are set up to use 8.5” x 11” sheets 
of paper.
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Working with layouts

To modify layout settings

1 Select the layout for which you want to modify the settings.

2 From the Options menu, choose View Options.
Tip: You can also use the View Options tool on the Standard toolbar. 

Result: The View Options dialog box appears.

Presentation tab
Options on the Presentation tab affect the appearance and printout of the 
layout.

 Name: The name of the layout.
 Background Color: Sets the background color of the layout view. This 

does not affect your printed copy.
 Grid On: Select this checkbox if you want gridlines to appear on the 

layout. Gridlines are for reference only; they assist with the design of 
items on the page. Gridlines do not appear in the printed output. 

 Color: Sets the color of the gridlines. 
 Show placeholders only: Select this checkbox to display only the 

placeholders for the various items in the layout. If unchecked, both 

 The View Options button.
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the placeholders and contents of the items in the layout are 
displayed. This is to facilitate the layout setup and does not affect the 
printout.

 Snap
 Snap: Select this checkbox to snap the items in the layout to the 

gridlines. 
 Interval: Specify the interval between the points on the grid. 

 Units: The units of measurement for the layout. The coordinates at 
the bottom of the layout change according to the selection. This does 
not affect the printed output. 

 Paper Size
 Paper Size: Choose the desired paper size from the drop-down list. 

If you do not find the size you want, choose Custom, and then 
specify the width and height as desired. 

 Landscape: Select this checkbox if you want the page to be set up in 
landscape format. 

 Tile Printing
 Show page guides: Select this checkbox if you want the printable 

outline to be displayed on each sheet of paper that comprises the 
layout. The solid outline is the chosen printer’s paper size and 
orientation. 

 Show page number: Select this checkbox if you want the page 
numbers of the layout to be displayed in the center of each page. 
The page numbers are for reference only and do not appear in the 
printed output. 

 Tile options: Select one of the following option buttons:
 Top-Left: Places the top-left corner of the layout in the top-left 

corner of the first page, and then arranges the remaining 
pages accordingly. 

 Center: Places the center of the layout at the center of a page, 
and then arranges the remaining pages accordingly.

 Split Center: Places the center of the layout at the corner of 
four pages, and then arranges the remaining pages 
accordingly.

Inserting items on layouts

Notes: 

 To adjust the view of the layout as you work on it, you can use your 
mouse wheel to zoom in or out and/or pan around with the middle 
mouse button. 

 To copy and paste items in your layout, select the item that you want 
to copy and click Edit > Copy (or press CTRL + C). Then, to paste the 
item, click Edit > Paste (or click CTRL + V) and click to place the 
pasted item.

Objects can be inserted from the following categories: 
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 basic shapes (lines, rectangles, ellipses, polygons, and text) 
 images (bitmap and jpeg)
 CAD items
 data items 
 report items 
 worksheet items (includes the default Title Block)
 legend items
 key items
 new plot items

To insert a line onto the layout

1 From the Insert menu, choose Line. 

Tips: 
 You can also use the Line tool from the Layout Insert toolbar. 

 Press SHIFT while drawing the line to draw it at a 45-degree 
angle, or along the X or Y axis. 

2 Click on the page where you want to start drawing the line and, 
holding the mouse button down, drag it to the end point of the line. 
Release the mouse button when you have the desired shape.

3 Click anywhere in the drawing to finish placing the line.
Result: The line is placed on the layout. 
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To insert a rectangle onto the layout

1 From the Insert menu, choose Rectangle. 

Tips: 
 You can also use the Rectangle tool from the Layout Insert toolbar. 

 Press SHIFT while drawing the outline of the rectangle to create a 
perfect square.

2 Click on the page at the starting point of the rectangle and, holding 
the mouse button down, drag out the shape of the rectangle. Release 
the mouse button when you have the desired shape.

3 Click anywhere in the drawing to finish placing the rectangle.
Result: The rectangle is placed on the layout.

To insert a rounded rectangle onto the layout

1 From the Insert menu, choose Round Rectangle. 

Tips: 
 You can also use the Round Rectangle tool from the Layout Insert 

toolbar. 

 Press SHIFT while drawing the outline of the rectangle to create a 
perfect square.

2 Click on the page at the starting point of the rectangle and, holding 
the mouse button down, drag out the shape of the rectangle. Release 
the mouse button when you have the desired shape.

3 Click anywhere in the drawing to finish placing the rectangle.
Result: The round rectangle is placed on the layout.

Note: You can only see the rounded corners of the rectangle if you zoom 
in on the drawing.

To adjust the corners of a rounded rectangle

You can adjust the roundness of the rectangle’s corners by following 
these steps:
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1 Select the rectangle.

2 Hover your cursor over the top-right corner until you see a curved 
arrow appear, as shown below: 

3 Click and drag the corners of the rectangle inward to the desired 
amount of roundness. 

To insert an ellipse onto the layout

1 From the Insert menu, choose Ellipse. 

Tips: 
 You can also use the Ellipse tool from the Layout Insert toolbar. 

 Press SHIFT while drawing the ellipse to draw a perfect circle 
instead.

2 Click on the page at the starting point of the ellipse and, holding the 
mouse button down, drag out the shape of the ellipse. Release the 
mouse button when you have the desired shape.

3 Click anywhere in the drawing to finish placing the ellipse.
Result: The ellipse is placed on the layout.

To insert text onto the layout

1 From the Insert menu, choose Text. 

Tip: You can also use the Text tool from the Layout Insert toolbar. 
2 Click on the page at the starting point of the text box and, holding 

the mouse button down, drag out the shape of the box. Release the 
mouse button when you have the desired shape.

3 Click anywhere in the drawing to finish placing the box.
Result: The text box is placed on the layout.

4 To type text in the new box, double-click the box, and then delete 
the default text.
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5 Type your custom text.
Tip: Press SHIFT+ENTER to force a new line of text if Text Wrapping 
is enabled on the New Plot Text toolbar.

6 Click anywhere in the drawing to finish adding the text.
Tips: 
 You can use the Layout Text toolbar to easily modify text. 

 You can also replace your layout text with variables by typing 
them directly. To do so, you must surround the variable with per 
cent symbols (%) when altering the text item’s properties. For 
example, to add the Chief Lighting Designer variable, you would 
type %Chief Lighting Designer%. For more information on the 
variables available in layouts, see "Smart Cells".

 You can also right-click the text object and select Item Properties to 
access more options.

 In the Properties window, you can also click Insert Smart Variables to 
select smart variable text listed in Production Team Info.

To insert image items onto the layout

1 From the Insert menu, choose Image. 

Tip: You can also use the Image tool from the Layout Insert toolbar. 
2 Click and drag a window (placeholder) on the page where you want 

the item to appear.
Result: The Select Image View to be referenced dialog box appears.

Note: The images listed here were imported in the Images layout 
tab. To import a new Image (for example, a logo) use this tab. See 
"Images" for more information.
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3 Select the image that you want to add to the layout, and then click 
Select.
Result: The image appears within the placeholder as drawn.

To insert CAD items onto the layout

1 From the Insert menu, choose CAD. 

Tip: You can also use the CAD item tool from the Layout Insert toolbar. 
2 Click and drag a window (placeholder) on the “page” where you want 

the item to appear.
Result: The CAD item, which is referenced from CAD mode, appears 
within the placeholder as drawn. By default, CAD items appear in 
plan view and at a scale of 1/16”=1’.

To insert report items onto the layout

1 From the Insert menu, choose Report. 

Tip: You can also use the Report tool from the Layout Insert toolbar. 
2 Click and drag a window (placeholder) on the “page” where you want 

the item to appear.
Result: The Select Report to be referenced dialog box appears.

3 Select the report item that you want to add to the layout, and then 
click OK.
Result: The selected report (referenced from Pres mode) appears 
within the placeholder as drawn.
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Note: If the Group By option has been set for a report, the report cannot 
be added to a layout. Setting the Group By option creates page breaks 
within the report and layouts do not support reports with page breaks. 
For more information on this option, refer to "Report tab".

To insert worksheet items onto the layout

1 From the Insert menu, choose Worksheet.

Tip: You can also use the Worksheet tool from the Layout Insert toolbar. 
2 Click and drag a window (placeholder) on the “page” where you want 

the item to appear.
Result: The Select Worksheet to be referenced dialog box appears.

3 Select the worksheet that you want to add to the layout, and then 
click OK. 
Result: The selected worksheet (referenced from Pres mode) 
appears within the placeholder as drawn.



Reference Guide 829

January 2019 Presentation mode 

To insert New Plot items onto the layout

1 From the Insert menu, choose New Plot.

2 Click and drag a window (placeholder) on the “page” where you want 
the item to appear.
Result: The Select New Plot to be referenced dialog box appears.

3 Select the New Plot item that you want to add to the layout, and then 
click OK. 
Result: The selected New Plot item (referenced from Pres mode) 
appears within the placeholder as drawn. To adjust the contents that 
are displayed within the placeholder, refer to "Adjusting the 
contents" for further details. 

Layout templates

The Layout Templates feature can be used to improve your workflow and 
save time. Layout Templates allow you to select multiple objects in your 
layouts and group them together. These groups can then be inserted into 
any layout in any WYSIWYG file. 

This is possible because once a Layout Template is created, it is added to 
the Layout Template Database and is saved with the current installation 
of WYSIWYG. As a result, Layout Templates are available in all files 
opened and created in the same installation of WYSIWYG. Layout 
Templates may be moved to other WYSIWYG installations and to new 
versions of the software via .WUD files.
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Layout Template icons
The Layout Insert toolbar includes the three icons for creating, inserting 
and deleting Layout Templates. You can also use the menu commands, 
as detailed in the procedures below.

For information on how to import or export Layout Templates, see 
"WYSIWYG User Data Profile"

To create a new Layout Template

1 In your layout, select the items that you want to include in the 
Layout Template. For example, you can select Title Blocks, Plot 
Notes, Custom Legends and Keys, Disclaimers, and so on.

2 Right-click and select Create Layout Template.
Tip: Alternately, you may click the Insert menu and choose Layout 
Template > Create.

3 Type a name for your new Layout Template.
4 Click OK. 

Tip: If you do not select any items in the Layout, saving a Layout 
Template will prompt you to save the entire Layout as a Layout 
Template. This includes Layout view options, such as Paper Size and 
Tile Printing. To insert the entire Layout, right-click on the Shortcut 
Bar (Layouts page), and select New Layout Using Layout Template.

To insert a Layout Template in a layout

Once you have created a Layout Template, you can insert it into other 
drawings as follows:

1 In your Layout, right-click and select Insert Layout Template.

Tip: Alternately, you may click the Insert menu and choose Layout 
Template > Insert.

2 In the window that appears, select the name of the Layout Template 
that you want to insert, and then click OK.

Create Layout
Template

Insert Layout
Template

Delete 
Layout Template
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3 Navigate to the location where you want to insert the Layout 
Template and click to place it.
Tip: If no items in a Layout are selected, saving a Layout Template 
will prompt you to save the entire Layout as a Layout Template. This 
includes Layout view options, such as Paper Size and Tile Printing. To 
insert the entire Layout, right-click on the Layouts shortcut bar and 
select New Layout Using Layout Template. Type a name for the new 
Layout, and then click OK to create it. The new Layout appears on the 
Layouts shortcut bar.

To delete a Layout Template from the database

Once you have created a Layout Template, you can delete it from the 
database. 

Attention: A deleted Layout Template will no longer be saved with your 
WYSIWYG file and you will no longer be able to insert it in subsequent 
drawings.

1 On the Layouts tab, on the Layout Insert toolbar, click the Delete Layout 
Template icon.

Tip: Alternately, you may click the Insert menu and choose Layout 
Template > Delete.

2 In the window that appears, select the name of the Layout Template 
that you want to delete, and then click the Delete checkbox.

3 Click OK to delete the Layout Template.

Content and item properties

As with all objects in WYSIWYG, the objects that you have placed on your 
page have unique properties. There are two types of properties: 

 Content Properties
 Item Properties

Content Properties
Content Properties affect the content of the presentation item. When you 
open these properties, you open a similar or identical dialog box to the 
View Options dialog box that appears when you are working on the original 
item in CAD, Data, or Pres mode. In this dialog box, you can modify the 
information to be displayed and control how it is displayed.
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To modify content properties

1 Select the presentation item that you want to modify.

2 From the Modify menu, choose Content Properties. 
Tip: You can also click the Content Properties tool on the Layout Edit 
toolbar. 
Result: The Content Properties dialog box appears.

Note: Content properties for CAD items are discussed in "CAD items".

Item Properties
Item Properties affect the placeholders and the scaling of the contents. 
Options here include the outline’s weight and color, and various printing 
options for the contents, such as scale.

To modify item properties

1 Select the presentation item you want to modify.

2 From the Modify menu, choose Item Properties. 
Tip: You can also click the Item Properties tool on the Layout Edit 
toolbar. 

Result: The Properties dialog box appears.

 

 The Item Properties button.
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Note: The first tab of the properties dialog box is identical regardless of 
the type of presentation item. Options here affect the outline and fill 
color of the placeholder.

CAD items

You can modify or edit CAD items to meet printing requirements. Their 
content properties are detailed below.

Note: Options which do not appear in the CAD item’s Content Properties 
follow the settings specified in Document Options.

To modify content properties of CAD items

1 Select the CAD item, right-click, and then choose Content Properties 
or click the Item Properties tool on the Layout Edit toolbar.

Result: The Content Properties window appears.

2 Modify options as desired.
3 When finished, click OK.
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General tab
Options on the General tab affect the scene that is displayed in the CAD 
item. Only fixtures and objects on the active layers are displayed in the 
layout.

 Follow Current Scene: Select this checkbox to use the scene that is 
displayed in the drop-down list on the Scene toolbar. Clear the 
checkbox, and then select the desired scene from the Scene drop-
down list. For more information on scenes, refer to "Scenes".

CAD Rotation tab
Options on the CAD Rotation tab affect the angle at which the CAD item is 
printed.

 Angle: Type an angle value in degrees if you want the drawing in the 
CAD item to be printed on an angle. This feature is helpful for 
printing booms.

CAD Printing tab
Options on the CAD Printing tab affect the scale for the drawing. 
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 Fit: If you select this option, the entire CAD drawing is scaled to fit 
inside the placeholder.

 Fixed: If you select this option, the CAD item is printed at the 
specified scale. To determine which portion of the CAD item is 
displayed inside the placeholder, choose Open Contents. Inside this 
view, you can move around a white rectangle that represents the 
placeholder. See "Adjusting the contents" for details on the 
functionality available with Open Contents.

 Variable: If you select this option, when you “open contents” you will 
be able to change the size of the white rectangle without affecting 
the original placeholder. The portion of the drawing contained within 
the white rectangle is scaled to fit in the placeholder. See "Adjusting 
the contents" for details on the functionality available with Open 
Contents.

 On paper: The scale ratio that you want to use on a paper copy of the 
layout. 

 Real World: The “real” measurement for the scale ratio that you 
specify in the On paper box. For example, you may want to use a 
scaling of one inch in a paper copy of your layout. This one-inch 
measurement translates to a “realistic” measurement (for example, 
3 feet).



836

Presentation mode  R42

 Point Size: The size at which points are printed.
 Hide Zero Intensity Fixture: Select this checkbox to hide any fixtures 

with an Intensity set to zero so they do not print.

View type tab
Options on the View type tab affect the view type of the CAD item. 

 View Type: The view types available are those discussed in "Plot 
types". 

 WorkPlane: The workplanes available are those discussed in "Plot 
types".

 Scrollbars: Select this checkbox to display the scrollbars on the 
bottom and left side edges of the layout. Clear this checkbox to turn 
the scrollbars off. 

Wireframe Details tab
Options on the Wireframe Details tab affect the amount of information that 
is shown in the CAD item.
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 Wireframe Details: Information of CAD items in wireframe that you can 
display on the plot. 
 Show on Plot: Select the corresponding checkboxes in this column 

to display the selected wireframe information in the plot.
 Select the checkbox on the top row of the column to select all 

check boxes below.
 Click on the arrows in leftmost column to expand and display the 

rows with additional options.
 Use Document Defaults: Select this checkbox to reference the options 

selected on the Wireframe Details tab of Document Options. Clear the Use 
Document Defaults checkbox to make specific changes for the active 
view.

Fixture Attribute Details tab
Options on the Fixture Attribute Details tab affect which attributes of the 
fixture are displayed with the fixture object.
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 Fixture Attributes: Select the attributes that you want displayed around 
the fixture symbols in the CAD item. To modify how the attributes are 
laid out, refer to Fixture Notation and Information Layout in "Fixture 
notation".
 Plot: Select the corresponding checkboxes in this column to display 

the selected attributes in the plot.
 Wireframe Views: Select the corresponding checkboxes in this 

column to display the attributes in the Tooltips in Wireframe view. 
Displays tooltips on the CAD item. Tooltips are the pop-up 
messages that display specific information about a fixture when 
you hover over it. Choose the information that you want to display 
in a tooltip by selecting the appropriate check boxes in the Fixture 
tooltips group box. Tooltips are often helpful when trying to locate a 
specific fixture in a plot.

 Shaded Views: Select this checkbox to display the attributes when 
you hover over a fixture in Shaded view.

Tip: Select the checkbox on the top row of the Plot or Wireframe Views 
or Shaded Views column to select all check boxes below.

 Use Document Defaults: Select this checkbox to reference the options 
selected on the Wireframe Details tab of Document Options. Clear the Use 
Document Defaults checkbox to make specific changes for the active 
view.
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Adjusting the contents

If you chose fixed or variable scaling on the CAD Printing tab or if you 
inserted a New Plots item, you can further set up how the item will 
appear within the placeholder by modifying the open contents.

To adjust the contents

1 With the item selected, from the Modify menu, choose Open 
Contents.

Tip: You can also click the Open Contents tool on the Layout Edit 
toolbar.
Result: A new window opens, displaying your drawing and the item 
placeholder. 

2 Adjust the positioning of the placeholder as desired.
Tip: To adjust the view of the contents, you can use your mouse 
wheel to zoom in or out or pan around by holding down the middle 
mouse button. 

3 Close the window.

New Plot items

New Plot items are inserted into your layout using the options specified 
when you created the item. You might want to modify these options if 
you wish to display or print the New Plot item in black and white, for 
example.

To modify content properties of New Plot items

1 Select the New Plot item on the layout.

2 From the Modify menu, choose Content Properties.
Tip: You can also click the Content Properties tool on the Layout Edit 
toolbar.
Result: The Content Properties window appears. 
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For an explanation of the options that are available, refer to 
"Modifying the properties of a plot".

Note: Any options that you modify here are also updated in the New 
Plots view that you inserted.

Image items

Special considerations should be given to printing images on layouts. To 
maintain the integrity of the image, WYSIWYG can maintain the aspect 
ratio of the image so as not to distort it.

To maintain aspect ratio

1 Select the image item on the layout.

2 From the Modify menu, choose Item Properties.
Tip: You can also click the Item Properties tool on the Layout Edit 
toolbar.

3 Click the Image tab. 

4 Select the Keep Aspect Ratio checkbox.
Result: When this box is checked, the height versus width 
relationship of the original image is maintained regardless of how 
you resize the placeholder.

Worksheet, report, and spreadsheet items

Worksheet, Report, and Spreadsheet items are inserted into your layout 
at a set scale (100%) regardless of the paper size. For readability 
purposes, you can readjust this value.
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To adjust the properties of Worksheet, Report, and 
Spreadsheet items

1 Select the worksheet, report, or spreadsheet item on the layout.

2 From the Modify menu, choose Item Properties.
Tip: You can also click the Item Properties tool on the Layout Edit 
toolbar.

3 Click the Worksheet, Report, or Spreadsheet tab as appropriate. 

4 From the Worksheet drop-down list box, select the item that you want 
to modify. The options vary based on the type of item that you have 
selected.

5 Click to select the Gridlines option to print gridlines.
6 In the Scale box, type a percentage value to increase or decrease the 

size of the contents.
7 Click Use Auto-fit to automatically fit the item in the bounding box, 

and then choose an auto-fit option:
 Attempt to fill: WYSIWYG will attempt to fill the bounding box, 

ignoring the scale specified in the Scale box. 

 Limit: WYSIWYG will still attempt to fill the bounding box; the 
scale specified in the Scale field will be considered.

8 Click to select Fit Whole Sheet to specify that Auto-fit should apply to 
the entire contents of the worksheet/spreadsheet/report

9 Click to toggle Fit all rows and Fit all columns to specify that Auto-fit 
should apply to all rows or all columns of the worksheet/
spreadsheet/report. Alternately, you can specify to which rows and 
columns it should apply.
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10 Click OK.

Legends
You may want to add a legend to your layout to provide a definition of 
the symbols used in the layout. To add a legend to a layout, you must 
first use the Legend Wizard to create the legend. The legend that you 
create can consist of the symbol name, wattage, count, and any other 
special notes. You can create multiple legends per layout. 

The Legend shortcuts in Layouts can be set to follow the Scenes available 
in the Scene Database.

To create legend items

1 Right-click on the Wizards shortcut bar, and then select New Legend.

Result: The Enter new Legend name dialog box appears.
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2 Type a name for the legend, and then click OK. 
Result: The legend shortcut is stored in the shortcut bar and the 
Legend Wizard opens. The Legend Symbols Editor appears as 
displayed below. All fixtures in your CAD drawing are listed in the 
Legend Editor for possible inclusion in the Legend. All the options to 
configure your Legend are available from this dialog box. 

a. Legend layout
Options found here affect the layout of your legend.

 Title: The Title field displays the name of the legend. Type a title in 
the Title box if you want a title other than the default name to be 
displayed. 

 Scene: The Scene field is not editable and only displays the name of 
the scene where the legend symbols listed in the Legend Editor 
table are displayed. A scene is set by right-clicking on the Legend 
shortcut >Properties. In the Scene Database window, you can choose 
the Scenes that you have created or (Current Layer Only) or (All 
Layers). 

 Automatic updates: By default, this option is on and will 
automatically update the legend when there are updates in your 
CAD drawing

 Display Columns: The Display Columns button is used to edit what 
columns are displayed in the legend. Clicking the button will bring 
up the Legend Options window. From here choose the columns that 
you want displayed by selecting the appropriate columns from the 
list. The Symbol and Name columns are displayed by default. Order 
the display of columns by clicking the Up and Down buttons. 
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 In the Rename column, type a name for the selected Legend 
Column header.

 Move Up: Select a row and use this button to move the fixture row 
up in the table. 

 Move Down: Select a row and use this button to move the fixture 
row down in the table. 

 Reset to Default: When a fixture row is selected that has cells that 
have been edited, this button becomes active. By clicking this 
button, the all the editable cells in the row will be reset to their 
default text. 

 Symbol: The Fixture Symbol section displays up to three symbols 
that represent a fixture from different views, Plan, Front, Side, if 
available. Use the checkbox under each symbol if you wish it in the 
Legend. 

Note:  At least one symbol must be displayed for each symbol. 
b. Legend information

Each symbol type that exists in your CAD drawing is displayed for 
possible inclusion in the legend. The counts of each symbol type is 
updated automatically as symbols with the same symbol type are 
added or deleted from the CAD drawing. 

Options found here affect the symbol information that is displayed in 
the legend. 

 Display checkbox: By default all fixtures are displayed in the legend, 
as identified by the checkbox. Clear this checkbox if you do not 
want the highlighted fixture in the table to be displayed in the 
Legend. 

 Symbol: This column displays the name of the Symbol from the 
Library which represents the fixture in your CAD drawing and will 
be displayed for this fixture on the Legend. 
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 Name: By default, the name of the fixture will be displayed, as 
listed in the Library Browser. If you wish to edit the displayed 
fixture name, click in the cell and type in your preferred Name for 
display. 

 Count: By default, the total number of the fixture in the drawing 
appears in the Count column. This value includes only hung 
fixtures in your show file. If you wish to edit this number, click in 
the cell and enter a new count. 

 Spares: By default, this column is blank. If you have spare fixtures 
that you would like to display on your Legend, click in the cell and 
enter a number of Spares. 

 Wattage: By default, the table displays the wattage for the Lamp in 
volts. If you wish to edit this value, click on the cell and enter a 
new Wattage value. 

 Lamp: displays the lamp of the fixture.    
 Fixture Options: displays any options that are available on the 

fixture. To edit this cell, click on it and add or remove any of the 
text. 

 Notes: Type in any additional notes that should be displayed for 
this fixture in the Legend. 

 Color Source: By default, the Color Source will be set to Plot Color, 
which means the Legend will automatically display the symbol 
using the Layer Color or Object Color of the fixture, if the color is 
the same for all instances of the fixture in your drawing. If the 
color is not the same, the Plot Color will automatically be set to 
Black. Alternatively, you can switch this column to Custom Color, 
and then select a custom color for the symbol from the color box 
on the Color column.

 Color: Click the color box to open a color picker. Select the new 
color that you want to apply to the symbol, and then click OK.

 Symbol Fill: By default, the Symbol Fill is set to Plot Color, which will 
automatically display a filled fixture symbol using the Symbol Fill 
that was set in the plot if all instances of the Fixture are set to the 
same Plot Color (otherwise, the fixture will not be filled 
automatically). Alternatively, you can switch this column to 
Custom Color, and then select the color from the color box on the 
Symbol Fill column.

 Fill Color: Click the color box to open a color picker. Select the new 
fill color that you want to apply to the symbol.

 Rotate: By default the checkbox is unchecked to display the fixture 
symbol in its default orientation. To rotate the symbol, click on the 
checkbox and select it.

 Mode: Displays the fixture’s mode setting.
 # Channels: Displays the total number of DMX channels required by 

the fixture.
Note: The Legends table will display information in blue text after a 
cell has been edited.
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c. Legend display options

How a legend appears in a report can be customized to meet your 
needs. 

Options found here affect how a legend appears in the report.

 Display Legend title: Enable this option to display a title for your 
legend.

 Display column headings: Enable this option to display the headings 
of columns in the legend.

 Display accessories: Enable this option to display accessories of 
fixtures.

 Line weight: This option determines how thick or thin symbol lines 
will appear.

 Max column width: The number sets the width of the columns. The 
width must be set in order to set Word Wrap option. (Note: The 
minimum width for a column is 30).

 Word wrap: Enable this option to wrap text that exceeds the max 
column width.

 Font: Use the drop-down list to select a support font style. 
 Font Size: Set the font size for all text in the legend.

Editing a legend
To make changes to the information that is displayed in the legend, click 
on the Legend Shortcut, and it will open the Legend Symbol Editor, and 
then make any necessary modifications. 

Note: In the Legends Wizard, the Legends table will display information in 
blue text after a cell has been edited.

Once a legend has been defined, it does not change until you make 
modifications to its settings, but the data associated to the fixtures may 
update if you selected the Automatic updates checkbox. If any new fixtures 
with different symbol types are added to the file or any removed, these 
additions/deletions will be automatically. 

To rename, delete, or clone the shortcut, follow the steps defined in 
"Working with shortcuts".

Inserting a legend onto the layout

Once the legend has been created using the Legend Wizard, you can place 
it onto the layout.

To insert a legend onto a layout

1 From the Insert menu, choose Legend Item.

Tip: You can also click the Legend tool on the Layout Insert toolbar. 
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2 Click and drag a window (placeholder) on the page where you want 
the item to appear.
Result: The Select Legend to be referenced dialog box appears.

3 Select the legend that you want to add to the page, and then click 
OK.
Result: The legend is added to the page at the position where you 
inserted the placeholder.
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Modifying the properties of a legend

To modify the properties of a legend

1 On the layout, right-click the legend that you want to modify and 
choose Item Properties. 

Tip: You can also click the Item Properties tool on the Layout Edit 
toolbar. 
Result: The Properties dialog box appears.

The General tab is similar for all items. For more information on this 
tab, see "To modify item properties".

Legend tab
Options on the Legend tab affect the scaling and content of the 
placeholder.
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 Legend: Select the legend that you want to be displayed on the 
layout. A list of all the legends you have created is displayed in the 
drop-down list. 

 Scaling Type: How you want the legend to scale. Can fit to the page or 
be fix ratio. 

 Scaling: The scale ratio in inches and feet at which the legend should 
be printed. If the scale that you want to use for printing is not 
displayed, select Custom.

 On paper: The scale ratio that you want to use on a paper copy of the 
layout. 

 Real World: The “real” measurement for the scale ratio that you 
specify in the On paper box. For example, you might want to use a 
scaling of one inch in a paper copy of your layout. However, this one-
inch measurement translates to a more “realistic” measurement (for 
example, 3 feet).

 Display Gridlines: Select this checkbox to show the gridlines in the 
legends table.

Legends in scenes
The Legends shortcut in Layouts can be set to follow Scenes.

To select the Scenes where Legends are displayed

1 In Layouts tab in PRES mode, right-click on the Legend shortcut and 
choose Properties.

Result: The Legend dialog box appears.

2 In the Scene section, choose the Scene where the Legend will be 
displayed.
 Follow Current Scene: Select this checkbox to choose the default 

scene that was set in the Scene Database.
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 Scene: Click the drop-down list and select the scene where the 
Legend will be displayed.

3 Click OK.
Result: Only the Legend symbols in the selected Scene will be 
displayed in the Layout.

Keys
You may want to add a key to your layout to provide a definition for the 
fixture notation used in the layout. To add a key to a layout, you must 
first use the Key Wizard to create the key. The key you create consists of 
the symbol of one given fixture and identifiers for the various attributes 
notated around the symbol. You can create multiple keys per layout. 

To create key items

1 Right-click on the Wizards shortcut bar, and then select New Key.
Result: The Enter new Key name dialog box appears.

2 Type a name for the key, and then click OK. 
Result: The key shortcut is stored on the shortcut bar and the Key 
Wizard opens. 
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Step 1 - Key Symbol Selection

Options in Step 1 allow you to choose the symbol that will represent 
the fixture or accessory in the key. 

 List of symbols: Select the symbols you want to use. You can choose 
up to one fixture symbol and one accessories symbol. The symbols 
available in this list are the default WYSIWYG symbols for each 
fixture or accessory type. When you select a symbol, it appears in 
the preview window to the right. 

 Change Symbol: Enables you to choose a different symbol from the 
more extensive symbols library which includes the USITT standards, 
among others. Follow the steps in “Changing Symbols” to perform 
the modifications.

 Delete Symbol: Click this button to remove the selected symbol from 
the preview window. 
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 Changing symbols
a. From the list of items in the window to the right of the preview 

window, select the symbol. To change the symbol, click the 
Change Symbol button. The following dialog box appears:

b. From the list on the left side, choose the new symbol. When you 
are finished making your choice, click Select. 
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Step 2 - Symbol Layout

 

For each attribute there are two entries. One is for the attribute 
itself, the other is to label the attribute. The label is distinguishable 
by the qualifier “Key” (for example, the attribute Focus and the label 
Key - Focus). An extension line is drawn between the label and the 
attribute. For each attribute and its label you must decide whether 
you want to display it in the key by having its checkbox selected in 
the Visible column. 

If an attribute is included, you can further specify how it will be 
displayed using the various formatting options (including text size 
and color, shape size and color, and justification).

You can also edit all the text, choose to give examples of attribute 
values, and provide custom definitions for the labels.
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Options in Step 2 allow you to choose the attributes and notation to 
be displayed around the chosen symbols. 

 Fixture: The name of the selected fixture.
 Filter: Enables either Attributes, Keys or both to be visible in the 

symbol layout.
 Display Title: Select this checkbox if you want the name of the 

symbol displayed in the key. Type a title in the Display Title box if 
you want a title other than the default name to be displayed.

 Key Title: The title that will appear for the key.
 Font Type: The selected font type for the key title.
 Font Size: The size of the font for the key title.
Note: The key title is not visible in the preview window and can not 
be seen until the key is inserted into the layout. 
 Zoom: Manages the magnification of the key in the preview 

window.
 Rotation: Manages the orientation of the key in the preview 

window.
 Grid Snap: When enabled the placement of objects will be aligned to 

grid points in the preview window.
 Visible: Select this checkbox if you want the attribute or label to be 

displayed around the symbol in your key.
 Property: The name of the symbol attribute.
 Color: Select this to set a specific color for the attribute or label.
 Text: Type the text that you want displayed for the attribute or 

label.
 Symbol Fill: Select this checkbox to add fill to the symbol, then click 

the color box to choose the fill color.
 Copy: Will copy the Color, Text, Shape and placement of objects in 

the preview window as they currently appear. 
 Paste: Will add all objects, settings and placements of objects that 

were previously saved using Copy.
Note: Copy and Paste work across different Keys.
 Text: How the text in the key will appear.

 Height: How large the text in the key will appear.
 Rotation: Specifies the attribute or label alignment in relation to 
the fixture symbol.

 Italics: Select this checkbox to italicize the attribute or label font. 
 Line weight: Adjust this value to increase or decrease the density 
of the label or attribute font.

 Text Anchor: Controls the justification for the text. This is in 
relation to the insertion point or shape.

 Horizontal: The horizontal justification for the text.
 Vertical: The vertical justification for the text.

 Shape: Associates a shape with the label or attribute, if desired. 
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 Style: What type of shape is associated with the label or 
attribute. You can choose from: none, circle, square, octagon, 
or diamond.

 Size: Increase or decrease the size of the shape as desired.
 Line Weight: The thickness of the line that makes the shape.

3 Set the position of the attribute or label by clicking and dragging on 
the label or attribute in the preview window. You can also select an 
attribute by clicking on it in the preview window. 

4 The key as it will be drawn on the layout is displayed in the preview 
window. Once all the attributes are set as desired, click Finish.
Result: The Wizard shortcut is stored in the shortcut bar with the 
name you specified in the Title box. 

Editing a key

To make changes to the information that is displayed in the key, open the 
Key Wizard by double-clicking on the key shortcut, and then make any 
necessary modifications. Once a key has been defined, it does not 
change until you make modifications to its settings. 

To rename, delete, or clone the shortcut, follow the steps defined in 
"Working with shortcuts".

Inserting a key into a layout

Once the key has been created using the Key Wizard, you can place it on 
the page. 

To insert a key into a layout

1 From the Insert menu, choose Key item.

Tip: You can also click the Key tool on the Layout Insert toolbar. 
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2 Click and drag a window (placeholder) on the “page” where you want 
the item to appear.
Result: The Select Key to be referenced dialog box appears.

3 Select the key that you want to add to the layout, and then click OK.
Result: Your key appears within the placeholder as drawn. By 
default key items are set to a scale of 1/16” = 1’.
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Modifying the properties of a key

To modify the properties of a key

1 On the layout, select the key that you want to modify.

2 From the Modify menu, choose Item Properties. 
Tip: You can also click the Item Properties tool on the Layout Edit 
toolbar. 
Result: The Properties dialog box appears.

The General tab is similar for all items. For more information on this 
tab, see "To modify item properties".

Key tab
Options on the Key tab affect the scaling and content of the placeholder.
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 Key: Select the key that you want to be displayed on the layout. A list 
of all the keys that you have created is displayed in the drop-down 
list. 

 Scaling Type: How you want the key to scale. Can fit to the page or be 
fix ratio.

 Scaling: The scale ratio in inches and feet at which the key should be 
printed. If the scale that you want to use for printing is not displayed, 
select Custom.

 On paper: The scale ratio that you want to use on a paper copy of the 
layout. 

 Real World: The “real” measurement for the scale ratio that you 
specify in the On paper box. For example, you might want to use a 
scaling of one inch in a paper copy of your layout. However, this one-
inch measurement translates to a “realistic” measurement (for 
example, 3 feet).

Sharing keys

Keys that have been previously created can be shared between 
WYSIWYG files on the same computer. The key first needs to be 
designated for sharing and saved to WYSIWYG itself. Then any other 
WYSIWYG file can insert the key or remove it from being shared.

To share a key

Note: A key must first be previously created in the current WYSIWYG file 
before it can be shared. 



Reference Guide 859

January 2019 Presentation mode 

1 In PRES mode, from the Insert menu, choose Share Keys, Share Keys 
with Other Files.

Result: The Share Key with Other Files window appears.

2 In the Share Key with Other Files window select the desired key from the 
drop down menu.

3 Click OK.
4 Enter a new name for the key that is being shared. This is how other 

WYSIWYG files will identify the key.
5 Click OK.

Result: The key is now shared with other WYSIWYG files on the 
same computer.

To insert a shared key into a file

1 In PRES mode, from the Insert menu, choose Share Keys, Insert 
Shared Keys. 

2 The Insert Shared Key window appears.

3 In the Insert Shared Key  window, enter a name for the imported key in 
the Enter Key Name field. This name will be how the imported key will 
appear in the current file.

4 Select the desired key to import from the Selected Shared Key drop 
down menu.

5 Click OK. 
Result: The selected key will be imported into the current WYSIWYG 
file.
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To removed a shared key

1 In PRES mode, from the Insert menu, choose Share Keys, Remove 
Shared Keys. 

2 The Removed Shared Key window appears.

3 In the Removed Shared Key window, for each key you want to remove, 
select the checkbox next to the key in the Delete column. 
Note: You can select all keys using the Select All button, or clear all 
keys using the Select None button.

4 Click OK. 
Result: The selected keys will be removed from sharing between 
WYSIWYG files. If a key was previously imported into a WYSIWYG 
file, it will remain in the file as it was imported.

Note: Shared Keys can be shared to other WYSIWYG installs and 
computers, by using the WUDs feature.

Layout tools

Locking items in Layouts
You can “lock” items in your Layouts to avoid accidentally moving or 
deleting them once you are satisfied with their placement. Once an item 
is locked, you can still select it (and access its Properties), but you can’t 
move or delete it.
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To lock an item in a Layout

1 In your Layout, click the item that you want to lock.

2 On the Layout Edit toolbar, click to select the Lock icon. 
Tip: Alternately, you can click CTRL + L to lock the selected item.
Result: The grips of the item turn red instead of black and you 
cannot move or delete the object.

To unlock an item in a Layout
When you click on an item in a Layout and see that its grips are red, or 
you notice that it cannot be moved or deleted, this means that the item 
is “locked.” Follow the procedure below to unlock it.

1 In your Layout, click the item that you want to unlock.

2 On the Layout Edit toolbar, click to select the Lock icon. 
Tip: Alternately, you can click CTRL + L to unlock the selected item.
Result: The grips of the item turn black instead of red and you can 
now move or delete the object.

Placeholders
You can move and resize placeholders at any time.

To resize a placeholder

1 Click to select the presentation item.

2 Click and drag the marker points of the placeholder to resize it.

Note: Resizing a placeholder affects the content that is displayed. You 
might have to edit the scale of the contents or revisit open contents. 

To move a placeholder

1 Click to select the presentation item.

2 When a small grey rectangle appears on your cursor, click and hold 
the left mouse button and drag the placeholder to the desired 
location.

3 Release the mouse button.
Tip: Use the gridlines of the presentation view to line up 
placeholders.

To copy a placeholder and its contents

1 Click to select the presentation item.

2 When a small grey rectangle appears on your cursor, press and hold 
the CTRL key.
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3 Click and hold the left mouse button and drag the copied item to the 
desired location.

4 Release the mouse button.

Ordering
To facilitate overlaying and underlaying placeholders, use the Bring to 
Front and Send to Back tools. Think of placeholders as being piled on top of 
each other. Bring to Front moves the selected placeholder and its contents 
to the top of the pile. Send to Back moves the selected placeholder and its 
contents behind all of the others.

To overlay a placeholder

1 Click to select the presentation item.

2 From the Modify menu, choose Bring to Front.
Tip: You can also use the Bring to Front tool on the Layout Edit toolbar 

To underlay a placeholder

1 Click to select the presentation item.

2 From the Modify menu, choose Send to Back.
Tip: You can also use the Send to Back tool on the Layout Edit toolbar. 

Printing layouts

If you have a large layout you can “tile print” the layout across multiple 
smaller sheets of paper. To set up how you want the layout arranged on 
the sheets of paper, see "Working with layouts".

You can print a complete layout or specific pages of a layout based on the 
settings that you choose when printing. 
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To print a layout

1 From the File menu, choose Print.

Result: The Print dialog box appears.

2 From the Name drop-down list, choose the printer (or plotter) that 
you want to use. WYSIWYG records the name that you choose for 
future reference and thereafter displays it as the default printer for 
layouts. 

3 To print all pages of a layout, select All.
4 To print select pages of a layout, click Pages, and then enter the 

range in the from and to boxes.
5 If you want to print multiple copies of the pages, select the value 

from the Number of copies list box. 
6 Click OK.

Batch printing

You can print multiple shortcuts at once on the Reports, Layouts, or 
Worksheets tabs in PRES mode, choosing to save them as PDF files in the 
folder of your choice.

1 On the Reports, Layouts, or Worksheets tab, click File > Batch 
Printing.

Result: The Batch Printing dialog box appears.

2 Select the shortcuts that you want to print. To print all, click the 
checkbox on the row on top of the list to select all the check boxes 
below.
 To print to PDF, select the Print to PDF checkbox, and then specify 

the output folder.

 To auto-select the paper size for print, select the Use layout Paper 
Size checkbox.

 The Landscape column indicates if the document prints in the 
landscape orientation (Yes) or portrait orientation (No).
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 To add a prefix to the printed file name, select the Prefix checkbox 
and type the prefix text in the Prefix box.

3 To change the output location for the printed file, enter the location 
in the Output Folder box or click Browse to select the new location.

4 Click OK.
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Images

Introduction

Images such as renderings and logos are stored in the Images tab of 
Presentation mode. Renderings are automatically saved here when you 
select “internal” in the Output Properties/Step 2 of the Render Wizard. Any 
other image files (bitmap or jpeg format) may be imported. 

To import a bitmap or a jpeg

1 Right-click on the Images shortcut tab, and then choose New Image.

2 Type the name of your image.
3 Click OK.
4 Click on the shortcut for your new image. The text “No Image 

Available” appears in the working area of the screen.
5 From the File menu, choose Import. 
6 Use the browser to find the image file that you want to import.
7 Click Open.

To export a bitmap or a jpeg

1 Select the image that you want to export.

2 From the File menu, choose Export. 
3 Use the browser to select a destination and a name for the image file 

that you want to export. Ensure that either bitmap (.bmp) or jpeg 
(.jpg) is selected in the Save As Type box.

4 Click Save.
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Worksheets

Introduction

The Worksheet tab contains a spreadsheet much like many other 
spreadsheet programs. You can enter data and create mathematical 
functions here, as well as import and export data to other spreadsheet 
programs. This functionality is useful when you are creating 
spreadsheets for crew requirements, schedules, budgets, or any other 
show-specific data.

To import data 

1 Select File > Import.

2 Select the file.
3 Click Open.

To export data

1 Select File > Export > Worksheet.

2 Enter the file name for your worksheet.
3 Click Save.

Note: For optimal compatibility with other WYG files, it is recommended 
that you export to the WYSIWYG Spreadsheet format (*.wss).

To export a Worksheet template

For large shows, you may want to save the formatting of your worksheet 
as follows:

1 Select File > Export > Worksheet Template.

2 Enter the file name for your worksheet.
3 Click Save.

To create a new Worksheet

1 Click the Worksheets shortcut tab.

2 Right-click in the worksheets shortcut area, and then choose New 
Worksheet.

3 Type the name of your new worksheet.
4 Click OK.
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To insert Smart Cells

1 In your worksheet, select a cell.

2 From the menu, select Worksheet > Insert Smart Cell.

To insert pictures

1 In your worksheet, select a cell.

2 From the menu, select Worksheet > Insert Picture.
3 Select a photo in one of the supported formats (*.BMP, *.JPG, *.GIF, 

*.TIFF, *.PNG, *.TGA).
4 Click OK.

To sort data

1 Select a cell block that needs to be sorted.

2 From the menu, select Worksheet > Sort > Ascending/Descending.

Adding/removing rows and columns

To add a row

1 Select the cell above which you want to add a row.

2 From the menu, select Worksheet > Add > Row.

To remove a row

1 Select a cell in the row that you want to remove.

2 From the menu, select Worksheet > Delete > Rows.

To add a column

1 Select a cell to the left of which you want to add a column.

2 From the menu, select Worksheet > Add > Column.

To remove a column

1 Select a cell in the column that you want to remove.

2 From the menu, select Worksheet > Delete > Column.
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Merging/Unmerging Cells

To merge cells

1 Select the block of cells that you would like to merge.

2 From the menu, select Worksheet > Merge Cells.

To unmerge cells

1 Select the block of cells that you would like to unmerge.

2 From the menu, select Worksheet > Unmerge Cells.

Zebra Striping

To enable Zebra Striping on your worksheet

1 From the menu, select Worksheet > Zebra Striping.

Note: Currently there is only one set of alternating colors that you can 
choose.

Hiding Headers

To hide the headers (the labeling of rows and columns)

From the menu, select Worksheet > Hide Headers.

Freezing Panes

Freezing panes will lock a series of cells to the top of the working area no 
matter how much you scroll. 

To freeze panes

1 Select the row below the section you want to freeze.

2 From the menu, select Worksheet > Freeze Panes.

Note: You can unfreeze panes by clicking Worksheet > Unfreeze Panes.

Formatting Cells

Each cell has a configurable Type, Border, Alignment, Font, and 
Background. To access these options, select a cell (or block of cells), and 
then select Worksheet > Format Cells.
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Exporting Spreadsheets data to Worksheets

Information from DATA mode spreadsheets can be automatically 
exported into a new PRES mode worksheet. This same data can then be 
inserted on a Layout if needed.

To export data to worksheets

1 In DATA mode, open the Spreadsheet tab.

2 From the File menu, select Export to Worksheet. 
Result: The Enter new Worksheet name window appears.

3 Enter the name for the new worksheet which the data will be 
exported.

4 Click OK.
Result: The data will be exported to PRES mode into a new 
worksheet.
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Pipe tapes

Introduction

WYSIWYG enables you to make “Pipe Tapes,” which are attached to a 
pipe at the beginning of a hang. The pipe tape indicates to the 
electricians where to hang the fixtures and displays pertinent information 
about the fixtures, such as circuit number, dimmer number, gel color, and 
so on, as specified by the user. This tool significantly increases the 
accuracy between the WYSIWYG plot and the real installation. 

For more information on the settings for the Pipe Tape printer, see 
"Additional Interfaces tab".

Note: Printers that support Pipe Tape printing are:

 Epson TM-T88VI
 Epson TM-T88III (model M129C)
 Epson TM-T20II Direct Thermal Printer
 Epson models supported by the OPOS ADK driver

To print a pipe tape

1 Connect the pipe tape printer to your computer through the serial 
port or USB or Ethernet port.

2 In CAD mode, select the pipe for which you want to generate a pipe 
tape.

Attention: Due to the rounding of measurement values between pixels 
to distances, the resulting discrepancy increases with distance. As of this 
release, the distance is off by 1 feet for every 7 feet, or a discrepancy of 
2.5 cm for every 2.0 m.
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3 From the Tools menu, choose Print Pipe Tape. 
Result: The Print Pipe Tape Setup dialog box appears. 

 

4 In the Fixture details group box, select the data fields that you want 
printed on the pipe tape for each fixture.

5 To print show information such as venue, lighting designer, and show 
name, select the Show Info checkbox. Show information is added via 
the Production Team Info Wizard. See "Production Team Info Wizard" in 
the following section for details.

6 To display a graphic in the header and/or footer, type a file name in 
the Bitmap File box or use the file browser to locate the file. To display 
correctly, the graphics selected must be monochrome bitmaps.

7 To print a total count of the fixtures on the selected pipe, select the 
Fixture Count checkbox. The total count is broken down by fixture 
type. 

8 To print a total count of the circuits used by the fixtures, select the 
Circuit Count checkbox. 

9 To display text in the footer and/or header of the pipe tape, type a 
text file name in the Text File box. 

10 To print a total count of the number of lenses mounted in the 
fixtures, select the Lens Count checkbox. The total count is broken 
down by fixture type. 

11 To print the weight of the fixtures on the pipe, select the Weight 
checkbox. 
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12 To display tick marks on the pipe tape, select the Show Tick Marks 
checkbox. Tick marks are placed every foot or half meter, based on 
the unit of measurement (imperial or metric). The tick marks are for 
reference purposes only. 

13 When you have finished making your selections, click Print to send 
the print job to the pipe tape printer. 

14 Click Save and Exit if you want to save the settings but do not want to 
print the pipe tape at this time.
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Production Team Info Wizard

Introduction

The Production Team Info Wizard helps you gather and enter all of the 
information associated with your production team in one easy to access 
place.

To use the Production Team Info Wizard

1 In CAD mode, click File > Production Team Info Wizard.

Result: The Welcome window of the Wizard appears.

2 Type the name and date of your show in the boxes provided.
3 Use the checkboxes in the “Does your production meet any of these 

requirements?” section to specify whether you want to see extra 
information for entering team members:
 This production will tour: This option gives the user information on a 

touring production’s needs, such as Crew Chief, Lighting Director, 
and so on.
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 This production is filmed or broadcast: This option gives the user extra 
fields for a typical film or television production crew.

 This production has more than 2 lighting suppliers: When your 
production is sourcing equipment from more than two lighting 
suppliers, this option gives you up to five contact field groups for 
your extra suppliers’ information.

 I have information for Grips, Lighting Technicians, Production Electricians, 
and Shooters: Check this box if you need to save contact 
information on the above types of production personnel. 

4 Click Next. 
5 Complete all the required information on each window of the Wizard, 

clicking Next to proceed to the next window.
6 When you reach the last screen, click Finish to save your information.

Result: You can access your information at any time through the 
Wizard itself (File > Production Team Info Wizard) or by choosing 
Options > Document Options > Production Team Info.
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Smart Cells

Introduction

Smart cells allow you to reference WYSIWYG variables in reports and 
worksheets to ensure that the same type of information is displayed in 
each report and worksheet. These variables are found in the report 
headings and in various title blocks in PRES mode.

Additionally, you can replace these variables in your Layout text by 
typing them directly. To do so, you must surround the variable with per 
cent symbols (%) when altering the text item’s properties. For example, 
to add the Chief Lighting Designer variable, you would type %Chief 
Lighting Designer%.

All variables shown in the Production Team Information Wizard and Production 
Team Info tab of the Options > Document Options window are available as 
smart cells. For more information on changing these variables, see 
"Production Team Info Wizard".

The following variables are accessible from a Smart Cell drop-down list 
(or by typing them in Text items in Layouts):

Available In

Variable Definition Source Reports Worksheets Layouts

Production 
Team Info 
variables

Any 
Production 
Team 
variable

Any variable 
as defined on 
the Production 
Team Info tab 
in Document 
Options. For 
more 
information on 
this tab, refer 
to "Production 
Team Info 
tab".

Y Y Y

Data The data 
that 
comprises 
the report

Information 
that is 
available in 
Data mode

Y N N
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Show Date The date of 
the show

The date of 
the show 
defined on the 
Production Team 
Info tab in 
Document 
Options.
For more 
information on 
this tab, refer 
to "Production 
Team Info 
tab".

Y Y Y

File The name 
of your 
WYSIWYG 
file

The name you 
chose when 
saving your 
document 
using either 
the Save or 
Save As 
command 
from the File 
menu.

Y Y Y

Group The name 
of the 
group

The Group By 
parameter 
chosen on the 
Report tab in 
View Options. 
For more 
information on 
this option, 
refer to 
"Report tab".

Y N N

Headings The 
column 
headings 
that 
comprise 
the report

The columns 
defined in the 
Report tab in 
View Options.
For more 
information on 
choosing 
these 
columns, refer 
to "Report 
tab".

Y N N

Available In

Variable Definition Source Reports Worksheets Layouts
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Scene The scene 
chosen for 
the report

The scene 
defined on the 
General tab in 
View Options.

Y Y Y

Show 
Name

The name 
of the 
show

The show 
defined on the 
Production Team 
Info tab in 
Document 
Options.
For more 
information on 
this tab, refer 
to "Production 
Team Info 
tab".

Y Y Y

Title The title of 
the report

The name of 
the report as 
defined on the 
shortcut bar 
(for example, 
Instrument 
Count).

Y Y Y

User The name 
of the 
current 
user

The user 
name defined 
in the 
Document 
Options, 
Document 
Summary tab, 
Modified By 
field.

Y Y Y

Venue The name 
of the 
Venue

The venue 
defined on the 
Production Team 
Info tab in 
Document 
Options.
For more 
information on 
this tab, refer 
to "Production 
Team Info 
tab".

Y Y Y

Available In

Variable Definition Source Reports Worksheets Layouts
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Show information

You can enter all of your show information at once using the Production 
Team Information Wizard. For details, see "Production Team Info Wizard". 
Alternately, you can enter your information manually using the edit fields 
in the Production Team Info tab. These fields appear in the headings of all 
reports and in the WYSIWYG default title block (for plots). They also 
appear in Smart Cells, if you have chosen to use them.

After information has been entered about your show, you can search and 
sort for the information entered using the search field in the Production 
Team Info tab. Information can also be favored. Doing so will add a Star 
icon next to the entry in the Fav column.

To input show info in the Production Team Info tab

1 From the Options menu, choose Document Options.

2 Click the Production Team Info tab.

3 Click the Filter drop-down list and choose which information to display 
in the table:
 Show All displays all the rows.
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 Show Favorites Only displays only the rows marked in the Fav 
column.

 Show Populated Rows Only displays all rows with user data.

 Organize by Production Team Info Wizard Pages displays the rows that 
were set in the Production Team Info Wizard menu.

4 In the Value column, type all the pertinent information in the boxes 
provided.

5 Click OK. 
Result: All reports are updated.

Tip: Click the Reset to Default button to sort the list back to its default 
order.

To search for show info in the Production Team Info tab

1 From the Options menu, choose Document Options.

2 Click the Production Team Info tab.
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3 At the top of each column there is a search field. Enter what you are 
looking for in either the Name Search or Value Search field.
Result: The Production Team Info tab will show only information 
matching your search criteria.

To mark show info as favored in the Production Team Info 
tab

1 From the Options menu, choose Document Options.

2 Click the Production Team Info tab.
3 Locate the information you want to favorite. Click the field in the Fav 

column next to the information.
Result: A Star will appear next to the information in the Fav column. 
You can now sort Production Team Info by Favorite.

Note: Clicking a field with an existing star will unfavorite the 
information.

4 Click OK. 
Result: All reports are updated.
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Live mode

Live mode is used for graphically simulating the output of a lighting 
control console or compatible offline editor. Live mode also has 
rendering ability, enabling you to create photo-realistic pictures of 
the simulated lighting looks. Unlike Design mode, Live mode 
displays transitions from cue to cue, allowing you to see the 
programmed movement of light over time. If you have configured a 
patched video source, you can use Live mode to control the 
progress of your video with the console device. And if you have 
patched and mapped an image to a light-emitting surface, you can 
control it with the Image Console.

Live mode is available only in WYSIWYG Perform.

In this chapter
Layout tabs 885

Connecting to consoles 886

Working with consoles 893

Image Console 899

AutoPatch 904

Visualization 906

Autofocus 908

Rendering 912

DMX Camera 913

Patching Camera Paths 916
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Layout tabs

Introduction

Beneath the work area in each mode is a series of Layout tabs. These 
tabs provide various configurations of the views that you are working 
with. To change layouts, click the appropriate tab. 

Live mode contains the following Layout tabs:

 Wireframe: The work area displays a full-screen wireframe view.
 Quad: The work area is divided into quadrants, three of which can be 

modified to show plan, front, or side views. The lower-right quadrant 
contains a shaded view.

 Shaded: The work area displays a full-screen shaded view.

Notes: 

 The wireframe views in Live mode are used for fixture selection only. 
To make any drawing modifications, you must return to CAD mode.

 You can change the properties of the fixtures in LIVE mode by 
double-clicking on the fixture, which opens its Properties window.
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Connecting to consoles

Introduction

To use Live mode, you need to insert and connect to a control console or 
compatible offline editor. If you use a DMX console, you require a DMX 
interface device to connect to WYSIWYG. 

You must ensure that the patch you have created in WYSIWYG and the 
patch in your console are exactly the same for simulation to work 
properly.

Connecting to a console

To connect to a console

1 Connect the console to the computer with the appropriate hardware.

2 From the Managers menu, choose Device Manager. 
Result: The Device Manager dialog box appears.

3 Click New. 
Result: The console library is displayed.
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4 Navigate through the console library until you find the console or 
device that you are connecting to. Click the console name to 
highlight it.
Note: If you are connecting to a console with a Wyg-it or Wyg-it2, 
you can select either the console or the Wyg-it device. The Address 
box discussed below must contain the name of the Wyg-it.

5 Click Insert. 
Result: The console appears in the Device Manager.

6 With the console name still selected, click Properties. 
Result: The Properties dialog box appears.

7 From the Protocol drop-down list, select the protocol used by the 
console. For example, DMX, SandNet. 
Result: The console model is displayed in the Model box. The name 
of the console is displayed in the Name box. 

8 In the Address box, type the designated address of the console, if 
applicable.
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9 A list of the output ports from the console appears in the Ports list. 
You must assign these outputs to WYSIWYG patch universes. Click 
the appropriate port to highlight it.
Notes: 
 Motion control systems have a single port named “Motion.”

 If you are working with a motion control system, then you can 
assign only to motion universes; if you are working with a DMX 
console then you can assign only to DMX universes.

10 Select the desired Patch Universe, and then click OK.
11 Repeat the above steps to bind all ports to their appropriate patch 

universes. 
Note: You cannot control a channel count exceeding that of the 
WYSIWYG Perform package that you purchased.

12 Click Close to close the Properties box.
13 Click Connect. 

Result: The status of the console changes to “connected.”

14 Click OK to exit the Device Manager.

Notes: 

 Once the console is running and connected to the WYSIWYG drawing, 
operate the console as you would in the live venue. Run up channels 
and record cues using the console. Remember that WYSIWYG does 
not store or save cues—this is done in your console’s memory. Once 
the console information is set up, you can set WYSIWYG to 
automatically connect to the console every time the file is opened.

 You can also perform the above procedure through the Device Manager 
Toolbar. For details, see "Device Manager toolbar".

To unassign the patch binding settings of multiple ports

1 From the Managers menu, choose Device Manager. 

Result: The Device Manager dialog box appears.

2 Select the console. 
3 Click Properties.
4 Select the ports for which you want to change the patch binding.
5 Click Unassign.

Result: All the selected ports will become unassigned.

To patch multiple ports simultaneously

Note: When assigning multiple ports to universes, the selected ports will 
be assigned to universes in sequential order. The universe sequence is 
based on availability, then alphabetical order.
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1 From the Managers menu, choose Device Manager. 

Result: The Device Manager dialog box appears.

2 Select the console. 
3 Click Properties.
4 Select the ports for which you want to patch.
5 Click Assign.

Result: The Quick Patch Assignment dialog box appears.

a. To have all universes available for patching, even ones that were 
previously assigned, select the checkbox by Show Assigned 
universes (Indicated by *). Otherwise, only unassigned universe will 
be available to patch.

6 In the Quick Patch Assignment window, from the Available Universes drop-
down menu, select the universe that will be assigned to the first 
selected port.
Result: A summary of the assignments will be displayed in the 
window. The dialog box displays a summary if there is a conflict with 
either a universe being unassigned or reassigned.
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7 Click OK.
Result: The ports will be patched to universes. The first port 
selected will be assigned to the first universe selected. The next 
sequential port will be patched to the next sequential universe. This 
continues until all the selected ports are assigned, or there are no 
more available universes to assign. 

8 Click Close to close the Properties box.
9 Click Connect. 

Result: The status of the console changes to “connected.”

10 Click OK to exit the Device Manager.

To connect the Image Console

The Image Console is produced by CAST Software and ships with 
WYSIWYG. It acts like a lighting console, media, or video server, enabling 
you to control color, intensity, and the image display of all patched LED 
surfaces that you have created with the LED Wizard.

1 From the Managers menu, choose Device Manager. 

Result: The Device Manager dialog box appears.

2 Click New. 
Result: The console library is displayed.

3 Double-click Consoles > Manufacturer > CAST Software, and then 
highlight Image Console. 

4 Click Insert. 
Result: The console appears in the Device Manager.
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5 With the console name still selected, click Properties. 
Result: The Properties dialog box appears.

6 Leave the defaults for Protocol, Model, and Name.
7 In the Address box, type the designated address of the console. Note 

that this address must match the Device Address that you type in the 
Image Console window. For details on configuring the Image Console, 
see "To configure the Image Console". 

8 A list of the output ports from the console appears in the Ports list. 
You must assign these outputs to WYSIWYG patch universes. 
Double-click the appropriate port to open the Quick Patch Assignment 
window.

9 In the Quick Patch Assignment window, select the appropriate patch 
universe, and then click OK.

10 Repeat the above steps to bind all required ports for your LED grid to 
their appropriate patch universes. 
Note: You cannot control a channel count exceeding that of the 
WYSIWYG Perform package that you purchased.

11 Click Close to close the Properties box.
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12 Click Connect. 
Result: The status of the console changes to “connected.”

13 Click OK to exit the Device Manager. You can now control the patched 
LED grid with the connected Image Console. For details, see "To 
control a patched grid of LEDs with the Image Console".

Device Manager toolbar

The Device Manager Toolbar simplifies your regular device connect/
disconnect operations. You can use the drop-down list on this toolbar to 
select a device (Consoles, Devices, Networks), and then click the connect 
icon or the disconnect icon.

The “All Devices” option in the drop-down list enables you to easily 
connect/disconnect all devices with one click without opening the Device 
Manager.
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Working with consoles

Introduction

This section contains instructions for editing the console settings, as well 
as using consoles to control various types of elements, such as video and 
motion axes.

Note: For information about the mapping of images onto patched light-
emitting surfaces, see "Image Console". 

To set the console to connect on load

1 From the Managers menu, choose Device Manager. 

Result: The Device Manager dialog box appears.

2 Select the console. 
3 Select the Connect on load checkbox.
4 Click OK to close the Device Manager.

To remove a console from the Device Manager

1 From the Managers menu, choose Device Manager. 

Result: The Device Manager dialog box appears.

2 Select the console that you want to remove.
3 Click Delete.

Result: The console is removed and all patch binding information is 
lost.

Controlling a DMX patched video source with a console

Note: If the video control is patched and DMX connected in Live Mode, 
then you will not be able to control the video using any of the Video 
Designer tool commands in Design mode. Video sources can only be 
controlled by a Designer tool when the DMX source is disconnected; 
therefore, you must first disconnect the applicable console device from 
Live Mode before using any of the Video Designer tool commands. 

After you have patched the control of a video source in Data mode, you 
can use the applicable console device to control the progress of the video 
in Live mode. 
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In WYSIWYG, you patch the control of a video source, not the actual 
video. This means that you can use the console device to control the 
progress of a live video stream or a video file by making the video play, 
pause, or rewind; you cannot use WYSIWYG to change different aspects 
of the video itself.

To control the video source, the DMX patch is allocated three channels 
with the following controls:

 First channel (Intensity): The video is off if the value is set 
between 1—128 (below 50%), it is on if the value is between 128—
255 (above 50%).

 Second channel (Control): The video is controlled by the position 
that you set on the third channel if the value is set between 1—84 
(between 1% and 33%), it is paused if the value is set between 85—
169 (between 33% and 66%), and it plays if the value is set between 
170—255 (between 66% and 100%).

 Third channel (Position): If you have set a value within the 
bottom third level of the second channel (between 1% and 33%), 
then you can use the third channel like a slider, advancing the video 
either backward or forward to the exact position that you want to 
see. If the value on the second channel is set to any level above 84 
(between 33% and 100%), then the third channel is disabled.

To control a DMX patched video source with a console

1 Ensure that the console device is connected to the patched video 
source. For details on connecting a console, see "To connect to a 
console".

 To play the video from start to finish, perform the following steps:

a. Set the first channel to a value between 128—255 (above 50%).
b. Set the second channel to a value between 255—170 (between 

100% and 66%).

 To pause the video, perform the following steps:

a. Set the first channel to a value between 128—255 (above 50%).
b. Set the second channel to a value between 255—170 (between 

100% and 66%) and play the video to the spot where you want 
to pause it. Then move the second channel to a value between 
169—85 (between 66% and 33%) to pause the video at this spot.

 To control the progress of the video manually, perform the 
following steps:

a. Set the first channel to a value between 128—255 (above 50%).
b. Set the second channel to a value between 84—1 (between 33% 

and 1%).

c. Slide the third channel up and down to control the progress of the 
video, forward and backward.
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Controlling a DMX patched motion axis with a console

After you have patched a motion axis in Data mode, you can use the 
applicable console device in Live mode to control the movement of any 
objects that are attached to the axis. 

To control the object, the DMX patch is allocated two channels with the 
following controls:

 First channel (Move): The first channel is for coarse movement 
and can be used to advance the object quickly to any position along 
the entire path, from start to finish. 

 Second channel (Move Fine): The second channel is used for 
further refining the object’s position that you set with the first 
channel. Adjust the slider on the second channel to move the object 
very slightly either forward or back from its current position. The 
movement achieved with this channel is so fine, that it is best viewed 
on linear axes that are quite long. Note that for rotation axes, the 
movement is so slight, that you may not be able to see it.

To control a DMX patched motion axis with a console

1 Ensure that the console device is connected to the patched motion 
axis. For details on connecting a console, see "To connect to a 
console".

2 To move the object quickly along the motion axis, adjust the slider 
on the first channel, stopping at the position where you want to leave 
the object.

3 To move the object in fine increments either forward or back from its 
current position, adjust the slider on the second channel.
Tip: To view fine movement, the object must be attached to a very 
long linear axis, or be set to rotate in a very wide arc. It is also a 
good idea to zoom in quite close to the object before moving it.

Controlling a motion-control patched motion axis with a 
motion control system

After you have patched a motion axis in Data mode, you can use the 
applicable motion control system in Live mode to control the movement 
of any objects that are attached to the axis.

Based on the type of system that you are using, you can control the 
object in different ways. The following procedure outlines how to control 
the object(s) with WYSIWYG’s Motion Control Console.
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To control a motion-control patched motion axis with a 
motion control system

1 Launch the Motion Control Console.

2 Ensure that the Motion Control Console (or the motion control system if 
you are using one) is connected to the patched motion axis. You 
connect the Motion Control Console (and motion control systems) in 
much the same way as you connect consoles. For details, see "To 
connect to a console".

3 To change the settings of a patched motion axis, highlight the axis in 
the left pane, and then choose from the following settings:
 ID box: To change the ID of the motion axis, type the new motion 

control ID. 

 Travel box: Type the distance (in meters for linear axes, in 
degrees for rotational axes) that you want the object to travel 
along or around the axis. This can be the full length/angle of the 
axis, or only a portion of it if you do not want the object to travel 
along/around the full path. For linear axes, if you type a value 
that is longer than the actual axis, the object stops at the end of 
the physical axis.

 Type: If you change the axis type so that it does not match the 
axis that you have drawn (for example, if the actual axis is linear, 
but you choose rotational here), the cell in patch view turns to 
red. 

 In the Mode area, select the type of movement for the object:

 Manual: Select this option if you want to specify the precise 
location of a static object on the motion axis. You can then 
use the position slider at the bottom of the window to adjust 
the position and control the movement of the object manually.

 Bounce: Select this option if you want the object to move 
forward and backward in a continuous loop along the motion 
axis.
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 Forward: Select this option if you want the object to move 
forward along the axis from start to finish, and then start over 
again at the beginning in a continuous forward loop.

 Backward: Select this option if you want the object to move 
backwards along the axis from finish to start, and then begin 
over again in a continuous backwards loop.

 Duration (sec) box: If you have chosen any moving Mode value 
(that is, any value except Static), you can specify the length of 
time (in seconds) over which you want the full range of motion to 
take place. The larger the number you type in this box, the slower 
the object moves.

 Position slider: For all moving modes (bounce, forward, 
backward), the slider indicates the position of the object when 
the console is sending data to WYSIWYG. For the static mode, 
while the console is started, drag the slider to adjust the position 
of the object on its axis. The position value changes in the box in 
the left pane.

 Position box: While the console is sending data to WYSIWYG, for 
all moving modes, this box shows the progress of the object’s 
movement along its axis; for the axes in the static mode, you can 
type the precise location of the object on the axis.

4 Click Update Axis to view your new settings.
5 Click Save to save the changes.

Note:  If you make any changes to the axis settings and save the 
changes, you can revert to the previous settings by clicking Load.

Connecting with a Wyg-it 2

WYG-it 2 is CAST Software’s DMX interface device. You require a DMX 
interface to connect a DMX console to WYSIWYG. Each WYG-it 2 has 2 
DMX inputs that enable you to visualize up to 1024 channels of DMX. The 
WYG-it 2 also has 2 DMX through ports that allow you to connect the 
console both to WYSIWYG and to the physical lighting equipment at the 
same time. WYG-it 2 is equipped with the necessary outputs to send 
Autofocus commands.

You can connect the WYG-it 2 to your computer by inserting the WYG-it 2 
USB cable into an available USB port. Once connected to your computer, 
the WYG-it 2 does not need an external power supply. 

Note: When WYG-it 2 is installed, the WYG-it DMX Interface 
configuration panel is accessible in the Control Panel of your computer. 
The WYG-it 2 name recorded in this configuration panel is the value that 
you must type in the Address box of the Device Manager Properties 
window.
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Mini Console

WYSIWYG contains an application that simulates a small console, called 
the Mini Console. You can use this application in lieu of a real console. To 
use the Mini Console, run the Mini Console application, found in the 
WYSIWYG section of the Windows Start menu. Connect as if you are 
using an external console. 

The Mini Console gives you control of a single DMX universe but does not 
record or playback cues.
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Image Console

Introduction

The Image Console is a control device much like the existing Mini 
Console, only specifically for controlling LED elements.

It acts like a lighting console, media, or video server, enabling you to 
control color, intensity, and the image display of all patched LED surfaces 
that you have created with the LED Wizard. 

This console enables you to control and test color, intensity, and image 
mapping independently or simultaneously in Live mode. 

Note: It is recommended that you configure the Image Console first and 
then use the LED Wizard to create the LED grid that will display the 
image. 

If you are going to choose multi-patch for color, single patch for intensity 
and you are going to use the Image Console to display an image on the 
LED grid, then it is recommended that you note the last patch address 
for intensity that is displayed in the configured Image Console and type 
this same address for the Dynamic Intensity Control Patch in the LED 
Wizard. 

In the following example of a configured Image Console, the last address 
for intensity is 193, so this is the value you would type in the LED Wizard 
for the Dynamic Intensity Control Patch. For details on using the LED 
Wizard, see "LED Wizard".
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To configure the Image Console

Note: After you configure the Image Console, you configure and patch a 
grid of light-emitting surfaces using the LED Wizard. For details, see "To 
use the LED Wizard". 

For optimum image viewing, the patch settings that you have defined for 
both intensity and color in the Image Console must match those that you 
define for the LED grid. For example, if you choose multi patch for both 
intensity and color in the Image Console, then you must also choose 
multi patch for both properties in the LED Wizard.

1 From the Start menu, choose WYSIWYG > Image Console.

Result: The Image Console appears.

2 Click Show multi-patch numbering if you have enabled multi-patch and 
want to see a graphical representation of the numbering of the 
surfaces in the grid, either along columns/rows or in a serpentine 
pattern.
Note: The graphic appears only after you have chosen an image and 
clicked Apply.

3 Complete the following fields on the Dimensions tab:
 Height: Type the number of rows that you are going to configure 

in the LED grid.

 Width: Type the number of columns that you are going to 
configure in the LED grid.

4 Click the Intensity tab and complete the following fields:
 Enable Dynamic Intensity: Select this checkbox to control the 

intensity of the light emitting surface in Live Mode when 
connected to a console. Then choose the patch properties below.

 Intensity slider: Use the slider to select the maximum intensity 
value of the light-emitting surface when connected to a console 
and viewed in Live mode, with 255 representing the brightest 
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possible intensity. This value enables you to control the scale of 
the intensity over a series of light-emitting surfaces. (When you 
disconnect from the console, the intensity is fixed at the static 
value.) Note that the DMX intensity value is treated as a 
percentage of the dynamic intensity value. For example, a DMX 
value of 127 results in 50% of the maximum intensity value that 
you set.

 Single Patch: Select this value to apply a single address that 
controls the intensity of the surface as a whole, and then choose 
whether you want to use the Default Single-Patch Address or 
specify the port and channel of the single patch address. 

 Multi Patch: Select this value if you want to use different addresses 
for each individual element in the grid. With multiple addresses, 
you can make different parts of the grid have varying intensity 
levels. 

5 Click the Color tab and complete the following fields:
 Enable Dynamic Color: Select this checkbox to control the color of 

the light-emitting surface in Live Mode when connected to a 
console. Then choose the patch properties below. 

 Single Patch: Select this value to apply a single address that 
controls the grid as a whole, and then choose the color 
properties. For example, if you choose red from the drop-down 
color-picker, every surface in the entire grid will be red. You could 
use this setting to create a string of holiday lights with the same 
color, and then control the intensity of the lights as one string to 
turn them all on or off simultaneously. Then choose the default 
single patch address or specify an address. 

 Multi-Patch: Select this value if you have chosen different 
addresses for each individual element in the grid. When you 
choose multi patch, you can apply a graphic to the grid, with the 
colors in the graphic mapped to each of the grid’s surfaces. 

 Image: Click the ellipsis button (...) to browse for the image 
that you want to map to the LED grid in your plot. You can 
choose from multiple graphic formats such as .gif, .jpg., or 
.bmp. For optimum results, the image size should be 
proportional to the grid size. For example, if your grid is 20 
columns wide by 20 rows high, then your image should be 
perfectly square. If your grid is 30 columns wide by 20 rows 
high, then your image size should be in the ratio of 3 X 2 (for 
example 600 X 400 pixels).

 Mode: Choose how the image is mapped to the surfaces in the 
grid. The 1:1 option is ideal for images that have the exact 
same dimensions as the grid on a pixel per row/column 
mapping (for example, if your grid is 20 x 20, then the image 
should also be 20 x 20 pixels). Choose Stretch to have the 
image stretched over the surfaces of the grid. Note that based 
on the image size, there might be distortion. Choose Stretch 



902

Live mode  R42

Preserving Aspect Ratio to stretch the image over the grid and 
keep its original aspect ratio. Note that this option is only 
suitable when the grid shape and image shape are the same. 
For example, if the image is rectangular, but the grid is 
square, some of the surfaces in the grid will remain blank 
because the image will not stretch to cover them. 

6 Click the Multi-Patch Numbering tab and complete the following fields:
 Start From: For multi-patch, choose where you want to start the 

numbering of the surfaces in your grid.

 Number Along: Select the direction of the numbering, either along 
the rows or columns of the grid.

 Alternate direction for each row/column: Select this checkbox to have 
the numbering progress in a serpentine pattern throughout the 
grid.

Note: Click Apply to see a preview of your numbering choice.
7 Click the Advanced tab and complete the following fields:

 Device Address: Type the address of the Image Console. This name 
must match the Image Console address configured in the 
Properties window of the Device Manager. For details on using the 
Device Manager to connect the Image Console, see "To connect 
the Image Console".

 DMX Channels per Port: Type the number of DMX channels required 
per port. Leave the default value of 512 for DMX universes. If you 
are using a universe with a greater number of ports (for example, 
EDMX), type the number of channels in this box. If you are using 
a protocol that supports more than 512 channels per port, type 
the value here.

8 Click Apply. 
Result: A preview of the grid appears in the left pane. To change the 
look of the grid, adjust any of the values, and then click Apply again.

9 To save your settings so you can open the Image Console and use 
the same properties at any time, click the Save icon, and then type a 
name for the console.

What’s next?
If you are going to choose multi-patch for color, single patch for intensity 
and you are going to use the Image Console to display an image on the 
LED grid, then it is recommended that you note the last patch address 
for intensity that is displayed in the configured Image Console and type 
this same address for the dynamic Intensity Control Patch in the LED 
Wizard. 
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In the following example of a configured Image Console, the last address 
for intensity is 180, so this is the value you would type in the LED Wizard 
for the Dynamic Intensity Control Patch. For details on using the LED 
Wizard, see "LED Wizard".

To control a patched grid of LEDs with the Image Console

There are three prerequisites to this procedure:

 First you must configure the Image Console.
 Second you must create and patch an LED grid. For details, see "To 

use the LED Wizard".
 Lastly you must connect the Image Console. For details, see "To 

connect the Image Console".

1 Click Live mode > Shaded tab and adjust the view so you can clearly 
see the grid that you have created.

2 From the Start menu, choose WYSIWYG > Image Console.
3 To open a configured and saved console, click File > Open, and then 

navigate to the .lxi file containing your saved console properties. If 
you have not yet configured your Image Console with the image you 
would like to display, perform the steps in the procedure "To 
configure the Image Console".

4 When you are satisfied with your settings, click Apply. Note the 
appearance of the LED grid in the Shaded tab. Adjust the properties 
of the Image Console as desired, and then click Apply again.
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AutoPatch

Introduction

AutoPatch is a protocol by which WYSIWYG can transfer the patch 
hookup to a compatible console. AutoPatch is only available in WYSIWYG 
Perform.

You must be connected to a compatible console for this feature to be 
enabled. All ports for which you want the patch information to be 
transferred must be properly bound. Only the hookup information in 
patch universes bound to the console’s outputs will transfer. 

The patch information is transferred over Ethernet.

To perform an AutoPatch

1 Connect to the console as described in "To connect to a console".

2 From the Live menu, choose AutoPatch.
Result: The AutoPatch dialog box appears.

3 Click Send Patch.
Result: WYSIWYG assembles the patch information for all the 
fixtures in the plot and then attempts to send the relevant patch 
information to each connected AutoPatch-capable device. 

Notes: 
 A fixture’s patch information is transmitted to a console only if 

the following conditions are met:

 The fixture has at least one part that is patched to a patch 
universe.

 The patch universe is bound to the console.

 The console is connected to WYSIWYG through the Device 
Manager.

 Some fixtures might have parts patched to two (or more) 
different consoles. In this situation, both consoles will receive the 
patch information for that fixture, but the port numbers given for 
each part will be set appropriately for each console.
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 It is recommended that you click Clear Patch prior to sending the 
patch to clear out the existing patch.

4 Click Close.

To clear the patch

1 Connect to the console as described in "To connect to a console".

2 From the Live menu, choose AutoPatch.
Result: The AutoPatch dialog box appears.

3 Click Clear Patch.
Result: WYSIWYG prompts each AutoPatch-capable device to clear 
the patch for each port that is bound to a WYSIWYG patch universe.

4 Click Close.
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Visualization

Introduction

There is a limitation on the number of DMX channels that can be 
simulated in Live mode. 102,400 channels (200 universes) of simulation 
are available in WYSIWYG. 

In Live mode, WYSIWYG will not simulate the DMX values being received 
on channels that exceed the channel count of your system. The unused 
channels display on the Status bar tracks the remaining channels for 
simulation.

Note: Fixtures on layers that are not visible or not included in the 
current scene are not counted. 

For more information on the Status bar, refer to "Status bar".

Simulation options

The Simulation options affect how fixtures respond in Live mode and how 
the beams are displayed in shaded views. Turning options off will yield 
faster simulation performance while compromising aesthetics. For 
optimal results, increase the processing power of your computer.

To change the simulation options

1 From the Options menu, choose Document Options. 

Result: The Document Options window appears.
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2 Click the Fixture Settings tab.

3 Make your selections, and then click OK to exit.
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Autofocus

Introduction

Autofocus is the protocol that WYSIWYG uses to “talk back” to a 
compatible console. Using the mouse in a Wireframe view or using the 
concept shortcuts and design tools at any time, you can direct the 
console to select fixtures, set focus, and control intensity, iris, and color. 
Autofocus is connected through MIDI, Serial, or Ethernet.

The following consoles are compatible with the Autofocus protocol:

 Flying Pig Systems WholeHog II 
 High End Systems WholeHog III 
 Barco/High End Systems WholeHog IV
 Compulite Vector
 ETC Congo, Pronto, Prisma NT, Focus NT
 MA Lighting grandMA 1 and 2
 LeHigh Rendition and Millenium
 Rosco Horizon software
 Chamsys MagicQ
 LightFactory software
 SGM Regia (all)

Assigning Spot Numbers to fixtures 

In addition to assigning DMX addresses to fixtures, you must assign 
specific Spot Numbers to them in Data mode. The Spot Number that is 
assigned to the fixture in WYSIWYG must match the Fixture ID/Spot 
Number assigned to the fixture in the console.

Note: Unless you assign a Spot Number, you cannot control the fixture 
using AutoFocus.
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To bind Autofocus to the console

1 Follow steps 1 through 14 of "To connect to a console".

2 Click Bind Autofocus. 
Note: The Bind Autofocus button is only available when a compatible 
console is selected in the Device Manager.
Result: The autofocus icon appears beside the name of the console 
in the Device Manager.

3 Click Connect.
4 Click OK to close the Device Manager.

Autofocus tools and menu commands

To select fixtures

The procedure for selecting fixtures in Live mode is the same as selecting 
fixtures in Design mode using the design tools and Concepts shortcuts. 
For more information, refer to "Using the design tools". 

To use the Autofocus tools

The procedure for using the autofocus tools is the same as using the 
design tools. For more information, refer to "Using the design tools".

 The autofocus icon.



910

Live mode  R42

To use the Autofocus menu commands

Right-click on a selected fixture or fixtures to open a menu with the 
following Autofocus commands:

 At Level and Focus: Sets the intensity of the selected lights on the 
connected Autofocus-compatible console to the level last 
specified by the Intensity command, and then launches the Focus 
command.

 Focus: When you click in a Wireframe view, the selected 
automated fixtures will focus (if they can) to that point. Click and 
drag to position them in real-time. Change the missing focus 
coordinate to alter the height at which you want to focus the 
fixtures.

 Intensity: Reveals a sub-menu where you can specify the level to 
set the intensity for the selected fixtures. The first option in the 
list is the last level you specified and by default is set to Full. You 
can also set the level to half and out.

 Iris: Sets the iris to either tight or wide. There is also a Specify 
option where you can set the iris to any percentage. The Specify 
value is retained for the session.

 Color: Fixtures that can mix color can be directed to either a 
palette color or an approximation of a manufacturer’s gel color. 
You can specify and save palette colors using the custom color 
creator or Palette shortcuts.

Tips: 
 You can repeat Autofocus commands by touching the Space bar. 

This way, you can select one fixture, adjust it, select another, and 
then press the Space bar to perform the same operation 
repeatedly.

 Alter the missing focus coordinate to focus fixtures at different 
heights.

 When focusing fixtures, you can click and drag in the wireframe 
view. If you are using WYSIWYG in the theatre, launch this 
command, and then look to the stage to position your lights.

 Working in an Isometric view, you can use the snap tools to focus 
fixtures to points on your set pieces.

 If you set the intensity to a specific value, the right-click menu 
option At Full and Focus changes to At ##% and Focus where ## 
is the specific value that you set.

 Select multiple fixtures by dragging a window around them. If 
you drag the window from right to left across projected beams, 
you can select the fixtures that produced the beams.

 To select fixtures by type, draw a box using the right mouse 
button. You will be prompted to isolate one or more types of 
fixtures.
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 Use the Concept shortcuts to create and select groups of fixtures.

 Use the Palette shortcuts to save and send color commands.
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Rendering

Introduction

At any time in Live mode you can generate a rendering of a lighting cue 
or static look. The Render Wizard calculates the rendering based on the 
DMX values being received at the moment when you click Finish.

To render a lighting look

1 In the working area of the screen, display the lighting look that you 
want to render.

2 From the Design menu, choose Render.
Tip: You can also click the Render Wizard tool on the Design toolbar.
Result: The Render Wizard opens and guides you through a series of 
options. Click Next and Back to navigate through the Render Wizard.

3 Click Finish. 
Result: WYSIWYG generates the rendering of your lighting look or 
cue. If the rendering is saved internally, it is available as an image in 
Presentation mode.

Note: For more information, see "Rendering".
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DMX Camera 

Introduction

With the DMX Camera utility, the camera's orientation (position and 
target), zooming, and roll features can all be manipulated and recorded 
to create a realistic rendering of a professional, fully edited film clip. 

It is important to distinguish between DMX Camera and cameras drawn 
in the CAD mode of WYSIWYG. Drawn cameras provide a single 
viewpoint; the camera can be moved, but only by one parameter at a 
time and there is no possibility to track or record camera movements. 
DMX Camera is not drawn in your plot and is completely maneuverable; 
each attribute is patched to a DMX channel and controlled through the 
console of your choice. Changes can be recorded on a separate cue list, if 
the console allows it; alternatively, camera changes can be recorded 
directly into previously created cues. The result is a recorded camera 
track that runs simultaneously with your show.

To use DMX Camera

1 From the Live drop-down menu, select DMX Camera Patch.

2 In the Enter DMX Camera Patch window, enter a new patch (for 
example, type Camera.1, where the "1" indicates the first channel 
number that the camera attributes will patch into).

3 In the Device Manager, bind the appropriate output of your selected 
console with the camera's patch universe, and then connect to the 
console.

4 In Live mode, click the Shaded tab. 
Result: The position and focus point coordinates and roll and zoom 
angles of the camera display on the Status bar.

5 From the Options menu, choose View Options.
6 Select the Options tab. 
7 From the Camera drop-down menu, select DMX control.
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8 Click OK.
Result: You should now have direct control over the DMX camera. It 
may be helpful to record the camera patch as a pop-up frame in data 
to view the attributes that you are modifying. 

To provide a fairly neutral starting point, it is recommended that the 
majority of the sixteen DMX Camera channels initially be set at a level of 
50 per cent. The exceptions are "camera Y coarse", which should be set 
at 40 per cent, and "target Y coarse", which should be set at 60 per cent. 
Adjusting these two attributes will ensure that the camera and the target 
are not occupying the same point in three-dimensional space. 
"Personalities" may be created to reflect this.

The camera's initial position will be dictated by the document origin (not 
to be confused with the user origin, which can be altered at any time).

The 16 camera parameters are as follows:

1. camera X coarse

2. camera X fine

3. camera Y coarse

4. camera Y fine

5. camera Z coarse

6. camera Z fine

7. target X coarse

8. target X fine

9. target Y coarse

10. target Y fine

11. target Z coarse

12. target Z fine

13. roll coarse

14. roll fine

15. zoom coarse

16. zoom fine

Notes: 

 The "coarse" parameter is defined as 100 metres/256 steps, or 0.39 
metres per step. 

 The "fine" parameter is defined as 100 metres/65536 steps, or 
0.0015 metres per step.
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 The zoom function of the DMX camera has a range of 5° to 100°. 
 The "coarse" zoom parameter is defined as 95°/ 256 steps, or 0.37° 

per step.
 The "fine" zoom parameter is defined as 95°/ 65536 steps, or 

0.00145° per step.
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Patching Camera Paths

Introduction

Once you draw a Camera Path in CAD mode, you can patch it to a DMX 
universe to control the camera’s movement along the path in Live mode. 

For details on Camera Paths, see "Camera Paths".

The Camera Path requires seven DMX channels, as shown in the DMX 
map below:

 Channel 1:Stop/Pause/Play… Stop: 0; Pause: 1-127; Play: 128-255.
 Channel 2:Looping… Enable: 0-127; Disable: 128-255.
 Channel 3:Direction… Forward: 0-127; Reverse: 128-255.
 Channel 4:Speed… x1: 0-127; x1/4: 128-159; x1/2: 160-191; x2: 

192-223; x4: 224-255.
 Channel 5:Position (Scrubbing): controls the playback start position 

along the camera path. This is similar to dragging the marker in the 
timeline but relative to camera path's total spatial length; please 
note that it is not possible to ‘scrub via DMX’ when a Flying Camera is 
playing, only when it is paused (i.e., Channel 1 is receiving a DMX 
value of 1 through 127).

 Channel 6:Reserved.
 Channel 7:Reserved.

To patch a camera path

1 Select the Camera Path.

2 Right-click and select Properties (or press ALT+<enter>).
3 Click the Camera Path tab.
4 In the Patch area at the bottom, click the DMX Patch radio button.
5 Select an existing Universe and then enter a channel number or click 

the ellipsis button to create a new Universe.
6 Click OK.
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Tips for controlling camera path playback via DMX

After binding the universe to which the camera path was patched to the 
connected console’s output, set Channel 1’s level to 128 or above to 
begin playback. 

Pause playback by setting this channel’s level to anywhere between 1 
and 127. While paused, increase the level of Channel 5 to begin 
scrubbing along the Timeline. 

Note: The flying camera will only move when scrubbed once the Position 
channel’s level becomes higher than the position along the Camera Path 
where playback was paused. This means that if playback was paused 
around the (physical) middle of the camera path, Channel 5’s level will 
have to reach above 127 (or so) before the Shaded View starts to 
update. Once the correct level is reached though, decreasing this 
channel’s level will scrub the flying camera back towards the start point 
of its camera path.

Much like when scrubbing along the timeline by clicking and dragging the 
marker with the mouse, Direction is ignored. In other words, regardless 
of whether Channel 3 tells the flying camera to move forward or 
backward, increasing Channel 5’s level will always move the flying 
camera towards the physical “end” point of its camera path, while 
decreasing this channel’s level will always move the flying camera 
towards the physical “start” point of its camera path.

Using cues on a console, it is very easy to begin playback of a flying 
camera from a position other than the camera path’s “start” point:

 Play; record Cue 1.
 Pause; record Cue 2 with a zero-count and make it auto-follow Cue 

1.
 Scrub to the position where playback is to start; record Cue 3 with a 

zero-count and make it auto-follow Cue 2.
 Play; record Cue 4 with a zero-count and make it auto-follow Cue 3.

Using multiple cameras

When multiple Camera Paths are patched, starting playback for a camera 
path that’s currently paused/stopped will “switch” to that flying camera 
immediately. To “switch back” to the flying camera that was playing 
initially, simply ‘nudge’ its Playback channel (i.e., set its level to 
something else within the “Play” range). This helps achieve ‘cutting’ 
between different camera shots. 
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To use multiple cameras

Using cues on a console, it is easy to Pause one camera, Play another, 
scrub the initial camera to a different position and then start its playback 
from that position:

1 Play the first camera; record Cue 1.

2 Play the second camera and Pause the first camera; record Cue 2. 
(Timing for Cue 2 depends on how far the first camera needs to 
move before cutting to the second.)

3 Scrub the first camera to a new position and ‘nudge’ the Playback 
channel for the second camera so it continues to play; record Cue 3 
with a zero-count and make it auto-follow Cue 2.

4 Play the first camera; record Cue 4. (Timing for Cue 4 depends on 
where the second camera needs to get before cutting back to the 
first.)
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Virtual Reality mode

The Shaded view in WYSIWYG features an integrated platform for 
virtual reality experience. 

In this chapter
Using virtual reality 921
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Using virtual reality

Introduction

In WYSIWYG’s Shaded view, you can immerse in the virtual reality 
feature to view and experience your show design in virtual reality mode.

Before you begin

The Virtual Reality feature in WYSIWYG is available to anyone who has 
the VIVE VR or OCULUS RIFT hardware system installed, connected 
and fully operational with the SteamVR application. 

Follow these instructions before you begin:

1 Ensure that your computer meets the minimum VIVE VR or Oculus 
Rift specifications.

2 Ensure that the VIVE VR or Oculus Rift system components are 
installed, connected, and working correctly.

3 Ensure that you have SteamVR installed and when you start it, all of 
the VR hardware is detected (headset, Controllers and Base 
Stations).

4 Ensure that you have installed WYSIWYG Release R42.

Using virtual reality in WYSIWYG

To start and end the VR feature in WYSIWYG

1 In WYSIWYG, switch to a Shaded view tab in CAD, DESIGN, or LIVE 
mode.

2 To start VR Mode, right-click on the Shaded view and choose the Start 
VR Mode menu. The Start VR Mode will appear on the menu list if 
SteamVR has detected all VR hardware, and your system meets the 
system requirements.
Tip: You can also press the F10 key to start VR Mode.
Note: While VR mode is enabled, WYSIWYG’s Shaded view will 
display on the screen what the headset is showing in the VR headset.

3 To exit VR Mode, right-click on the Shaded view and choose the Stop 
VR Mode menu. 
Tip: You can also press the F10 or ESC keys to exit VR Mode.
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To use the camera controls on VIVE VR Controllers

The camera controllers are used to interact with objects in the Shaded 
view, and access system controls.

 Menu Button: Use to toggle the control labels. This is helpful when 
familiarizing with the controls.

 Trackpad on the Right Controller: Use the Trackpad for moving around.
 Move Forward: Press to move forward.
 Move Backward: Press to move backward.
 Move Left: Press to move towards the left side.
 Move Right: Press to move towards the right side.

 Grip Button on the Right Controller: Press to move upwards.
 Grip Button on the Left Controller: Press to move downwards.
 Trackpad on the Left Controller: 

 Rotate Left: Use to pivot around your current position towards the 
left side.

 Rotate Right: Use to pivot around your current position towards the 
right side.

 Teleport More: Press to increase the distance of the dashed teleport 
arc, and then press the Trigger button to apply. The teleport arc 
shows you where you would be teleported to in the space.

 Teleport Less: Press to decrease the distance of the dashed teleport 
arc, and then press the Trigger button to apply. The teleport arc 
shows you where you would be teleported to in the space.

On the VIVE VR, when the button labels are displayed, the Controllers’ 
will display the following information in the virtual space.
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To use camera controls on OCULUS RIFT Controllers

The camera controls are used to interact with objects in the Shaded view, 
and access system controls.

 Menu Button: Click to toggle the control labels. This is helpful when 
familiarizing with the controls.

 Joystick on the Right Controller: Use the Joystick for moving around.
 Move Forward: Push forward to move forward.
 Move Backward: Push backwards to move backward.
 Move Left: Push left to move towards the left side.
 Move Right: Push right to move towards the right side.

 Grip Button on the Right Controller: Press to move downwards.
 Grip Button on the Left Controller: Press to move upwards.
 Joystick on the Left Controller: 

 Rotate Left: Push left to pivot around your current position towards 
the left side.

 Rotate Right: Push right to pivot around your current position 
towards the right side.

 Teleport More: Push forward to increase the distance of the dashed 
teleport arc, and then press the Trigger button to apply. The 
teleport arc shows you where you would be teleported to in the 
space.

 Teleport Less: Push backward to decrease the distance of the 
dashed teleport arc, and then press the Trigger button to apply. The 
teleport arc shows you where you would be teleported to in the 
space.
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On the OCULUS RIFT, when the button labels are displayed, the 
Controllers’ will display the following information in the virtual space.

VR GUI and Menus
The VR GUI and its menus offer the ability to select predefined shortcuts 
(e.g. Looks, Cameras, Camera Paths, Scenes), or Properties (e.g. 
Shaded View Properties) while viewing your show in VR.
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To use the VR menus

1 Press the Show Menu button on the Left Controller of either VIVE VR 
or OCULUS RIFT to display the VR GUI.

2 Use the Trackpad or Joystick to navigate the menu options.
 Looks: A carousel of Looks saved in the file will be visible for 

selection. 
a. Select the Look menu to display a carousel of Looks that were 

saved in the file. 
b. Use the Left and Right controls on the Left Controller to select the 

Look.

c. Use the Trigger button to actuate the Look. 

Result: WYSIWYG will update the current Look in your virtual 
Shaded view.

 Cameras: A carousel of Cameras created and available in the file will 
be displayed for selection.
a. Select the Cameras menu to display a carousel of Cameras that 

were created and available in the file. 
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b. Use the Left and Right controls on the Left Controller to select.

c. Use the Trigger button to actuate the Look. 

Result: WYSIWYG will update the current view to the Camera 
selected.

 Camera Paths: A carousel of Camera Paths created and available in the 
file will be displayed for selection.
a. Select the Camera Paths menu to display a carousel of Camera 

Paths that were created and available in the file. 
b. Use the Left and Right controls on the Left Controller to select.

c. Use the Trigger button to actuate the Camera Path.

Result: WYSIWYG will update and apply the Camera Path to 
the current view.

 Scenes: A carousel of Scenes saved in the file will be displayed for 
selection.
a. Select the Scene menu to display a carousel of Scenes that were 

saved in the file. 
b. Use the Left and Right controls on the Left Controller to select.

c. Use the Trigger button to actuate the Look. 

Result: WYSIWYG will update the current Scene in your virtual 
Shaded view.

 View Options: Shaded view properties will be displayed and available 
for changes.
a. In the View Options page, use the Trigger button to enter. 
b. Use Up and Down to select the option you wish to adjust. The 

option will be highlighted.

c. Use Left and Right to change the property value of the selected 
option.

d. Use the Trigger button to actuate/save the property changes.

 Menu Settings: Settings that affect how the menu page and virtual 
graphic user interface are displayed and used in the virtual space can 
be changed in the Menu Settings page. 
In Menu Settings, you can change the following settings:
 Smooth Teleport: Choose to display smooth teleport or instant 

teleport.
 Smooth Rotation: Choose to display smooth rotation or instant 

rotation.
 Haptics Enabled: Tactile sensation with VR space interaction and 

controls.
 Draw Model: Display of the controller model object in VR space.
 Draw Beam: Display of the beam and distances from the controller 

in VR space.
 Background Color: Adjust Red, Green, Blue and Alpha levels.
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 Menu Angle: Adjust how the Menu page is angled in the VR space.
 Move Speed: Adjust the interactive Menu response speed in the VR 

space.
 Menu Scale: Adjust the size of the Menu page in the VR space.
a. In the Menu Settings page, use the Trigger to enter. 
b. Use Up and Down to select the option you wish to adjust. The 

option will be highlighted.

c. Use Left and Right to change the property value of the selected 
option.

d. Use the Trigger button to actuate/save the property changes.
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Keyboard shortcuts and hotkeys

Keyboard shortcuts and hot keys help you to access commonly 
used commands more quickly. 

In this appendix
Keyboard shortcuts and hotkeys 931
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Keyboard shortcuts and hotkeys

Keyboard shortcuts

There are many keyboard shortcuts that can save you time when using 
WYSIWYG. 

Standardized WYSIWYG keyboard shortcuts are defined below. 

Description Keyboard shortcut 

Help F1

Displays context-
sensitive help

SHIFT + F1

Repeat last command F4 or SPACEBAR

Refresh current view F5

Relative or absolute 
coordinate toggle

F6

Ortho toggle F8

Snap toggle F9

Crosshairs toggle F7

Interactive object 
creation toggle in 
Wireframe view and      
Focus is inactive

F11

Full screen toggle in 
Shaded view and in Focus

F11

Save current document 
as...

F12

Repeat last command Space

Select all Ctrl+A

Select current layer CTRL + SHIFT + A

Create new layer CTRL + SHIFT + L

Copy CTRL + C

Find CTRL + F

Group CTRL + G
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Replace CTRL + H

Invert selection of 
objects in CAD

CTRL + I 

Invert selection of 
fixtures in CAD, Design 
and Live

CTRL + SHIFT + I

New Fixture Group CTRL + J

Move CTRL + M

New document CTRL + N

Open document CTRL + O

Print current view CTRL + P

Rotate CTRL + R

Save current document CTRL + S

Ungroup CTRL + U

Paste CTRL + V

Cut CTRL + X

Redo CTRL + Y

Undo CTRL + Z

Add to or remove from 
selection list

CTRL + Click

Copy selected objects CTRL + Drag

Rotate selected objects ALT + Drag

Mirror selected object CTRL + W

Nudges selected objects 
by ten times the grid 
spacing

ALT + ARROW KEYS

Nudges selected objects 
by one grid space

ALT + SHIFT + ARROW 
KEYS

Displays properties of 
selected object

ALT + ENTER

Move target ARROW KEYS

Rotates the isometric 
angle of the drawing in 
isometric view

CTRL + ARROW KEYS

Description Keyboard shortcut 



Reference Guide 933

January 2019 Keyboard shortcuts and hotkeys 

Note: If fixtures and more than one other object is selected, CTRL+G will 
create a normal “Objects Group” from the selected objects (the same if 
there were no fixtures in the selection set), while CTRL+J will create a 
Fixture Group (the same as if CTRL+G was used with only fixtures 
selected).

Rotates the isometric 
angle of the drawing in 
isometric view

CTRL + Click & Drag Third 
Mouse (Scroll Wheel)

Slow down isometric view 
angle rotation

Press and hold CTRL + 
SHIFT and tap +

Speed up isometric view 
angle rotation

Press and hold CTRL + 
SHIFT and tap -

Zoom in and out PAGE UP / PAGE DOWN

Zoom fit Z

Erases selected object DEL

Abort command ESC

Finish current command ENTER

Position Tool CTRL + ALT + P

Cuts and Adjustments CTRL + ALT + A

Fanning Tool CTRL + ALT + F

Camera Path Editor CTRL + ALT + E

Shaded View Settings 
Tool

CTRL + ALT + S

With object(s) selected, 
opens Position Tool with 
cursor in X

CTRL + SHIFT + X

With object(s) selected, 
opens Position Tool with 
cursor in Y

CTRL + SHIFT + Y

With an object(s) 
selected, opens Position 
Tool with cursor in Z

CTRL + SHIFT + Z

Description Keyboard shortcut 



934

Keyboard shortcuts and hotkeys  R42

Hotkeys

Hotkeys are keyboard shortcuts that act as commands entered from 
menus or toolbars. They are categorized according to the view and 
timing of usage. For example, certain hotkeys are only operational in plot 
views and only in the midst of performing an operation. 

Default hotkeys available in Plot Views

The following default hotkeys are useful when working in CAD mode.
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Start Operations

Mid Operations

Description Hotkey

Insert line L

Insert riser R

Insert cylinder C

Insert pipe P

Insert truss T

Insert text label B

Insert fixture F

Insert point .

Insert circle O

Insert arc U

Insert surface S

Focus position X

Insert screen N

LED Wizard W

Snap to grid G

Snap to midpoints M

Snap to endpoints E

Snap to intersection K

Zoom fit Z

Modify view V

ToolTips on/off Y

Insert dimension D

Insert rigging point ‘

Description Hotkey

Abort mode A

Finish mode F

Close line C



936

Keyboard shortcuts and hotkeys  R42

Quick increase I

Quick decrease D

Snap to grid G

Snap to midpoints M

Snap to endpoints E

Snap to intersection K

Rotate truss counter-
clockwise

Z

Rotate truss clockwise X

Truss rotate from one 
end to the other end

S

ToolTips on/off Y

Boolean subtract CTRL + B

Boolean unite CTRL + SHIFT + B

Distribute center CTRL+D

Distribute between two 
points

CTRL + SHIFT +D

Focus selected fixtures CTRL + F

Consolidate mesh CTRL + Q

Trim line CTRL + T

Extend line CTRL + SHIFT + T

Extrude CTRL + E

Extrude Objects CTRL + SHIFT + E

Quick Tools Q (fixtures are not 
selected)

Quick Focus Q (fixtures are selected)

Switch to first hang 
position of fixture.

1

Switch to second hang 
position of fixture.

2

Description Hotkey
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Default hotkeys available in Simulation Views

The following default hotkeys are helpful when working in Design and 
Live modes.

Start Operations

Mid Operations

Description Hotkey

At last and focus L

Focus F

At full intensity 1

At 50% intensity 5

Intensity off 0

Intensity specify S

Iris wide W

Iris tight T

Iris specify I

Zoom fit Z

Modify view V

ToolTips on/off Y

Description Hotkey

Abort mode A

Finish mode F

ToolTips on/off Y

Export image E

Save view as New 
Camera

C

Camera lock X
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Default hotkeys available in Layout View

The following default hot keys are helpful when working in Presentation 
mode - Layouts.

Start Operations

Mid Operations

Description Hotkey

Insert line L

Insert rectangle N

Insert round rectangle U

Insert ellipse E

Insert polygon G

Insert text T

Insert bitmap B

Insert plot view P

Insert data view D

Insert report view R

Insert spreadsheet X

Open bound view O

Bound view properties S

Move to front J

Move to back K

Placeholders only H

Print preview W

Zoom fit Z

Modify view V

Description Hotkey

Abort mode A

Finish mode F
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Default hotkeys available in New Plots View

The following default hot keys are helpful when working in Presentation 
mode - New Plots.

Start Operations

Mid Operations

Description Hotkey

Snap to end-point E

Snap to mid-point M

Snap to grid G

Snap to intersection K

Insert solid line L

Insect circle O

Insect Arc U

Insert text label B

Insert symbol S

Description Hotkey

Zoom fit Z
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Default hotkeys available in Patch Views

The following default hot keys are helpful when working in Data mode - 
Patch.

Start Operations

Mid Operations

Default hotkeys used to switch Wireframe Views

The following default hotkeys are used to switch between Wireframe view 
types in CAD and DATA modes.

Description Hotkey

Console modify C

Unpatch U

Modify view V

ToolTips on/off Y

Description Hotkey

Abort mode A

ToolTips on/off Y

Description Hotkey

Activate Plan View 1

Activate Left View 2

Activate Right View 3

Activate Front View 4

Activate Back View 5

Activate Isometric View 6
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Shaded View Camera Control

This feature enables you to choose the camera control in Shaded 
View.

In this appendix
Camera Control 943
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Camera Control

Introduction

The Shaded View Camera Control feature in the General tab of the Application 
Options window enables you to choose either Traditional WYSIWYG or Other 
3D Applications. 

When you select Traditional WYSIWYG, the commands used to control the 
camera(s) in Shaded view are standard WYSIWYG commands used in all 
versions of WYSIWYG. 

When you select Other 3D Applications, the commands used to control 
camera(s) in Shaded view comply with the commands of the different 3D 
application. 

Mouse Actions

Action Traditional WYSIWYG 0ther 3D Applications

Select at point With Selection Mode On, 
Left Mouse click

Always (i.e. permanent 
Selection Mode On), Left 
Mouse click

Selection box With Selection Mode On, 
Left Mouse button Up

Always (i.e. permanent 
Selection Mode On), Left 
Mouse click and drag; on 
Left Mouse button Up

Move camera along plane 
defined by initial camera 
position and camera axis 
as normal; target follows 
translation of camera

Ctrl+Left Mouse drag/
Right-click held during Left 
Mouse drag*

Middle Mouse drag*

Move camera around 
sphere with camera target 
at its center, target is fixed

Left Mouse drag* Right Mouse drag*

Pan camera along camera 
axis; target is fixed

Ctrl+Alt+Scroll Scroll

Pan camera and target 
along camera axis 
maintain distance between 
them

Ctrl+Scroll Ctrl+Scroll

Change Field of View Scroll Alt+Scroll

Fine control modifier Shift Shift
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*Affected by View Option, “Pan tool moves objects”.

Keyboard Actions

Roll Camera Middle Mouse drag Ctrl+Alt keyboard button 
+ Mouse Right button 
pressed, and the mouse is 
dragged

Right-click menu Right Mouse button Down Right Mouse button Up if 
and only if no drag 
occurred between Mouse 
down up

Camera pitch and yaw; 
camera axis rotates; 
camera target moves but 
maintains distance

Alt+Left Mouse drag* Alt+Right Mouse drag*

Key Traditional WYSIWYG Other 3D Applications

Field of View Page Up/Page Down 
(unmodified)

Alt+Page Up/Page Down

Pan camera and target 
along camera axis

Ctrl+Page Up/Page Down Ctrl+Page Up/Page Down

Roll Camera Alt+Page Up/Page Down Ctrl+Alt+Page Up/Page 
Down Keys

Pan camera only along 
camera axis; target is 
fixed

NONE Page Up/Page Down

Camera pitch and yaw Arrow Keys (unmodified) Alt+Arrow Keys

Move camera along plane Ctrl+Arrow Keys Ctrl+Arrow Keys

Move camera around 
sphere

Alt+Arrow Keys Arrow Keys

Fine control modifier Shift Shift

Action Traditional WYSIWYG 0ther 3D Applications
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Connecting to an Art-Net Device

WYSIWYG contains drivers that enable you to “listen” to incoming 
DMX data when connected to the updated Art-Net network device 
in LIVE mode.

In this appendix
Connecting to an Art-Net Device 947
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Connecting to an Art-Net Device

Introduction

WYSIWYG contains drivers that enable you to “listen” to incoming DMX 
data when connected to the updated Art-Net network device in LIVE 
mode.

To connect to an Art-Net device

1 Run WYSIWYG and start a new file.

2 Insert a venue, some hang structures, and fixtures.
3 Patch the fixtures to one or more Art-Net Patch Universes.

Note: Patching to EDMX will not work.
4 Switch to LIVE mode.
5 From the Options menu, select Application Options.

Result: The Application Options window appears.

6 On the Application Options window, click Additional Interfaces.
7 Click the Local Address drop-down list in the ArtNet Interface section of 

the Additional Interfaces tab, and select the IP address from which the 
incoming Art-Net Device is being received by your computer.

8 Click OK.
Result: A dialog box appears prompting to open the Device Manager, 
disconnect and reconnect for the change to take effect.

9 Click OK to close the dialog box and the Application Options window.
10 From the Managers menu, select Device Manager.

Result: The Device Manager window appears.

11 In the Device Manager window, click New.
Result: The Library Selection window appears.

12 In the Library Selection window, search for Art-Net (note spelling).
13 Select the single search result and click Insert.
14 With Artistic License Art-Net selected in the device list, click 

Properties.
15 Bind the Universes that you created to the incoming Art-Net ports.
16 When the binding is complete, click OK.
17 In the Device Manager window, with Artistic License Art-Net selected in 

the device list, click Connect.
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18 Close the Device Manager window.
Result: You are now connected to Art-Net and WYSIWYG will begin 
reacting to incoming Art-Net data.
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Connecting to an sACN Device

WYSIWYG contains drivers that enable you to “listen” to incoming 
sACN data when connected to the updated sACN network device in 
LIVE mode.

In this appendix
Connecting to an sACN Device 951
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Connecting to an sACN Device

Introduction

WYSIWYG contains drivers that enable you to “listen” to incoming sACN 
data when connected to the updated sACN network device in LIVE mode.

To connect to an sACN device

1 Run WYSIWYG and start a new file.

2 Insert a venue, some hang structures, and fixtures.
3 Patch the fixtures to one or more sACN Patch Universes.
4 Switch to LIVE mode.
5 From the Options menu, select Application Options.

Result: The Application Options window appears.

6 In the Application Options window, click Additional Interfaces.
7 Click the Local Address drop-down list in the sACN Interface section of 

the Additional Interfaces tab, and select the IP address from which the 
incoming sACN device data is being received by your computer.

8 Click OK.
Result: A dialog box appears prompting to open the Device Manager, 
disconnect and reconnect for the change to take effect.

9 Click OK to close the dialog box and the Application Options window.
10 From the Managers menu, select Device Manager.

Result: The Device Manager window appears.

11 In the Device Manager window, click New.
Result: The Library Selection window appears.

12 In the Library Selection window, search for sACN (note spelling).
13 Select the single search result and click Insert.
14 With sACN selected in the device list, click Properties.
15 Bind the Universes that you created to the incoming sACN ports.
16 When the binding is complete, click OK.
17 In the Device Manager window, with sACN selected in the device list, 

click Connect.
18 Close the Device Manager window.

Result: You are now connected to sACN and WYSIWYG will begin 
reacting to incoming sACN data.
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Note: WYSIWYG supports sACN priority. This means that if there are two 
consoles outputting sACN, and if one console has a higher priority, then 
the higher priority console will have it’s output prioritized over the other 
console.
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Connecting to a PSN 2.0 Device

WYSIWYG contains drivers that enable you to “listen” to incoming 
PSN 2.0 data when connected to the updated PosiStageNet 
network device in LIVE mode. 

In this appendix
Connecting to a PSN 2.0 Device 955
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Connecting to a PSN 2.0 Device

Introduction

WYSIWYG contains drivers that enable you to “listen” to incoming PSN 
2.0 protocol data when connected to the updated PosiStageNet network 
device in LIVE mode.

To connect to a PSN 2.0 device

1 Run WYSIWYG and start a new file.

2 Insert a venue, some hang structures, and fixtures.
3 Patch the fixtures into PSN 2.0 Patch Universes.
4 Switch to LIVE mode.
5 From the Live menu, select Device Manager.
6 In the Device Manager window, click New.
7 In the Library Selection window, search for PSN 2.0 (note spelling).
8 Select the single search result and click Insert.
9 With PSN 2.0 selected in the device list, click Properties.
10 Bind the Universes that you created to the incoming PSN 2.0 ports.
11 When the binding is complete, click OK.
12 In the Device Manager window, with PSN 2.0 selected in the device list, 

click Connect.
13 Close the Device Manager window.

Result: You are now connected and WYSIWYG will begin reacting to 
incoming PSN 2.0 data.
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Connecting to an RTTrPM Device

WYSIWYG contains drivers that enable you to “listen” to incoming 
RTTrPM data when connected to the updated RTTrPM network 
device in LIVE mode. 

In this appendix
Connecting to an RTTrPM Device 959
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Connecting to an RTTrPM Device

Introduction

WYSIWYG contains drivers that enable you to “listen” to incoming 
RTTrPM data when connected to the updated RTTrPM network device in 
LIVE mode.

To connect to an RTTrPM device

1 Run WYSIWYG and start a new file.

2 Insert a venue, some hang structures, and fixtures.
3 Patch the fixtures into RTTrPM Patch Universes.
4 Switch to LIVE mode.
5 From the Options menu, select Application Options.

Result: The Application Options window appears.

6 In the Application Options window, click Additional Interfaces.
7 Click the Local Address drop-down list in the RTTrPM Interface section of 

the Additional Interfaces tab, and select the IP address from which the 
incoming RTTrPM device data is being received by your computer.

8 Click the Group Address drop-down list and select the IP multicast 
address from group data transmissions.

9 Click the Port drop-down list and select the port used by the RTTrPM 
device connection.

10 Click OK. 
Result: A dialog box appears prompting to open the Device Manager, 
disconnect and reconnect for the change to take effect.

11 Click OK to close the dialog box and the Application Options window.
12 From the Managers menu, select Device Manager.

Result: The Device Manager window appears.

13 In the Device Manager window, click New.
Result: The Library Selection window appears.

14 In the Library Selection window, search for RTTrPM (note spelling).
15 Select the single search result and click Insert.
16 With RTTrPM selected in the device list, click Properties.
17 Bind the Universes that you created to the incoming RTTrPM ports.
18 When the binding is complete, click OK.
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19 In the Device Manager window, with RTTrPM selected in the device list, 
click Connect.

20 Close the Device Manager window.
Result: You are now connected and WYSIWYG will begin reacting to 
incoming RTTrPM data.
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Using the 3D Connexion Mouse 
with WYSIWYG

This new interface enables you to use a 3D Connexion mouse 
device, making camera movement and design in all six Degrees of 
Freedom (DoF) simpler and more intuitive. The device combines 
mouse interaction with many common buttons, all at your 
fingertips. Use the 3D Connexion mouse to control camera 
movement in Shaded Views and adjust the focus (pan/tilt) of a 
fixture.

In this appendix
Using the 3D Connexion Mouse 963
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Using the 3D Connexion Mouse

Introduction

This new interface enables you to use a 3D Connexion mouse device, 
making camera movement and design in all six Degrees of Freedom 
(DoF) simpler and more intuitive. The device combines mouse interaction 
with many common buttons, all at your fingertips. Use the 3D Connexion 
mouse to control camera movement in Shaded Views and adjust the 
focus (pan/tilt) of a fixture.

3D Connexion Menu
You can display the 3D Connexion menu at any time by pressing the 
Menu button while in the Shaded view. 

 Speed: You may modify the speed and sensitivity of the input from 
the 3D connexion mouse to any one of Low, Medium, and High.

 Motion Control – Pan/Zoom Only: Select this option to limit the input 
to control only Pan and Zoom while in Shaded views.

 Motion Control – Rotate Only: Select this option to limit the input to 
control only rotation while in Shaded views.

 Motion Control – Dominant Motion: Select this option to tell WYSIWYG 
to only consider the dominant motion while using the mouse. This is 
useful if you want smoother control over the Camera.

 Navigation Mode – Move Camera: Select this option to allow you to 
move the camera in Shaded views.

 Navigation Mode – Modify Fixture Pan/Tilt: Select this option to let you 
focus selected fixtures without having to hold down the ALT key.

 Navigation Mode – Encircle Target on Pan: Select this option to change 
the way in which you Pan In. 

Camera Navigation in Shaded View
The following will be the expected output for the indicated input on the 
3D mouse:

 Push Forward – Camera moves towards the object/scene.
 Pull Backwards – Camera moves away from the object / scene.
 Pull Up – Camera moves up while looking at the target.
 Push Down – Camera moves down while looking at the target.

The following will be the expected output for input rotation:

 Tilt Forward – Camera looks down (Target moves down).
 Tilt Backward – Camera looks up (Target moves up).
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 Twist Right (Clockwise) – Camera looks to the right.
 Twist Left (Anti Clockwise) – Camera looks to the left.

Switching the camera position on the 3D Mouse keys
The following occurs when you press the 3D Mouse keys on the 
SpacePilot Pro model:

 Fit - Automatically positions the camera forward or backward to a 
point where the whole scene is visible. Camera to target distance is 
maintained.

 T – Target is set to the center of the scene and camera is positioned 
to be looking at the Top View.

 B – Target is set to the center of the scene and camera is positioned 
to be looking at the Bottom View.

 F – Target is set to the center of the scene and camera is positioned 
to be looking at the Front View.

 BK – Target is set to the center of the scene and camera is 
positioned to be looking at the Back View.

 R – Target is set to the center of the scene and camera is positioned 
to be looking at the Right View.

 L – Target is set to the center of the scene and camera is positioned 
to be looking at the Left View.

 Iso1 – Target is set to the center of the scene and camera is 
positioned to be looking at the First Isometric View (Camera at the 
top left when looking from the front).

 Iso2 – Target is set to the center of the scene and camera is 
positioned to be looking at the Second Isometric View (Camera at 
the top right when looking from the front).

 Translation or Rotation Only - If you only want to translate or rotate 
the camera. The undesired motion will be filtered out. The 
Translations and Rotations toggle buttons will achieve this effect. In 
Space Pilot Explorer, use the 1 and 2 keys to achieve this.

 In the Space Pilot Explorer model, set the B (Bottom) and BK (Back) 
views by pressing and holding the SHIFT key while pressing the T or F 
keys accordingly. Set Iso1 and Iso2 by pressing 1 and 2 while 
pressing and holding the SHIFT key.

Focusing Pan/Tilt of Fixtures

Limited fixture control in Shaded view can be achieved using the 3D 
Connexion mouse:

 With only a single fixture selected, press the FIT key and the camera 
will be positioned behind the fixture looking toward the target on 
which the fixture is focused.

 With any number of fixtures selected, press and hold the ALT key 
while tilting the 3D mouse forward and back or twisting it left and 
right. The fixture pan and tilt adjusts accordingly. Note that fixture 
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control follows the WYSIWYG control conventions. Only conventional 
fixtures may be focused in CAD mode, and only moving head and 
mirror fixtures may be focused in DESIGN mode.
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CAST Software Cleaner Tool

The CAST Software Cleaner Tool is a standalone program that can 
be used to remove CAST programs and all associated files 
completely from your computer. 

In this appendix
CAST Software Cleaner Tool 969
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CAST Software Cleaner Tool

When to use the CAST Software Cleaner Tool

When installing/uninstalling CAST products, the process may fail and you 
may be unable to continue with installing/uninstalling the program. If 
you are unable to uninstall/install or repair the program by regular 
means, the CAST Software Cleaner Tool may be able to help. 

The CAST Software Cleaner Tool will search out all files related to the 
corrupted program on the affected computer, and then remove them. 
This should enable you to then perform a clean install of the CAST 
program without problems.

Note: Please consult with CAST Technical Support for access to the CAST 
Software Cleaner Tool. “Troubleshooting” for more information.

To use the CAST Software Cleaner Tool

1 In you computer that has CAST programs you want to remove, have 
the CAST Software Cleaner Tool installed.

2 Run the “CAST Cleaner.EXE” on your computer.
Result: The Cast Software Cleanup Tool window will open.

3 In the Cast Software Cleanup Tool window, under Versions Found, 
select the CAST program you want to remove from your computer.
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Index

Numerics
3D Connexion Mouse

Using, 943, 963

A
Absolute coordinates, 92, 378
Accessory, 610
Activation, 45
Adding

floorplans, 260
Additional Interfaces tab, 171
Aiming fixtures, 559
Alias definition, 579
Aligning objects, 479, 810
Alpha mapping, 431
Ambient light, 115
Antialiasing options, 764
Aperture, 757
Appearance tab

renaming elements in, 404
Application Options, 161
Arc Length Dimension tab, 422
Arc Length Dimensions, 308
Arcs

Drawing in CAD mode, 293
Drawing in New Plots, 806

Arena, 287
Arranging shortcuts, 69
Array, 479

Grid pattern, 484
Using to hang fixtures, 548

Aspect ratio, 840
Assembly Snap, 221, 527
Atmospheric options, 758
Attribute Anchor, 607
Attribute layout, 804
Attributes (Data fields), 684
Auto load, 165
Auto Recover, 167
Auto save, 165
Auto Truss Dimension, 312
Autofocus, 908
AutoPatch, 904
AutoUnit, 188, 509, 511
Axes

drawing, 342

B
Back view, 217
Background Rendering Manager

About, 767

Buttons, 773
Configuring, 767
Deleting jobs from, 777
Exporting images from, 777
Moving dequeued jobs back into queue, 

776
Moving jobs to top of queue, 775
Moving jobs up or down in queue, 776
Pausing, 775
Removing jobs from queue, 776
Resuming, 775
Taskbar icons, 770

Backup files, 165
Barndoors, 610
Base plates, 354
Batch printing, 863
Baud rate, 172
Beam angle, 581
Beams, 183
Big Layouts, 820
Bind

to console, 886
Bitmaps, 865
Black Box, 286
BlackTrax Frames, 348
Blocks

Custom library items, 351
Groups, 377

Boolean Operations
and intersection, 490
and projection, 490
and view planes, 491

Boolean operations, 489
Booms, 520
Break tool, 464, 465
Bringing to Front, 380
Budget

Cost, 578, 686
Bulb

Lamp, 581, 685

C
CAD environment, 206
CAD items, 833
CAD Options toolbar, 76
Camera, 332

changing the hotkey number, 335
deleting the hotkey number, 335
locking in shaded view, 336
using hotkeys, 334
Using Pitch, Roll and Yaw, 336

Camera controls, 103
Camera path editor, 749
Camera Paths, 748
Camera paths

patching, 916
Camera toolbar

using, 334
CAST Software Cleaner Tool, 953, 957, 967
Center line, 289
Channel count, 91
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Channels
Simulation, 91

Circle, 292
Circles, 806
Circuit Name data field, 685
Circuit Number data field, 685
Circuit Type data field, 686
Circus tents, 287
Clamp type, 589
Close the show document, 157
Color

Inserting, 610
Inserting multiple, 691

Color data field, 685
Color Temperature and Intensity Falloff 

features, 134
Color temperature calculations, 134
Color wheel, 727
Column Width Size, 712
Columns in Data mode, 684
Combining Report, 791
Command Line toolbar, 77
Compass, 341
Cones

drawing, 325
Connecting, 886

console, 886
Console data field, 686
Consoles

connecting, 886
Consolidated Mesh feature, 430

using, 502
Content properties, 831
Convert

Lines into surfaces, 466
Convert tool, 466
Co-ordinate display, 164
Coordinate notation, 207
Coordinates, 92, 206
Copy, 808
Cost data field, 686
Creating a new DMX universe, 702
Creating a new spreadsheet, 699
Cross-fading between lighting looks, 741
Cuelists, 745
Current

Set current layer, 439
Curved pipes, 515
Custom, 614
Custom color scroll, 612
Custom color wheels, 612
Custom fixtures

creating, 552
deleting, 554

Custom gobo wheels, 612
Custom gobos, 614

deleting, 616
Custom library items, 279

creating, 352
deleting, 353

Custom settings, 161
Custom Tab Manager, 204
Customer Experience Improvement 

Program (CEIP), 34
Customizing spreadsheet views, 687
Cut, 808
Cuts and Adjustments tool, 570
Cycle Selection, 371
Cylinders, 321

D
Data error tab, 196
Data fields, 684
Data Font toolbar, 77
Decimal display, 164
Delete, 809
Design toolbar, 78
Design tools, 722
Designer’s Remote, 910
Device Manager, 886
Device Manager toolbar, 78
Dimension

Arc Length, 308
Linear, 305
Radial, 309

Dimension line, 304
fonts used in, 305

Dimensions tab, 191
Dimmer data field, 684
Distance tool, 488
Distribute Objects, 488
Distributing fixtures, 550
Divide tool, 470
DMX, 886, 898
Document summary, 174
Dolly, 105
Dongle reauthorization, 42
Dot line, 289
Draw Details tab, 180
Draw menu

Wall command, 318
Draw toolbar, 79
Drawing

motion axes, 342
Walls, 318

Drawing aids, 282
Drawing pipes, 512
Drawing rectangles, 296
Drawing screens, 328
Drawing tips, 282
DWG, 148
DWG/DXF files

importing, 234
DXF, 148
DXF/DWG files, 234

E
Edit (Pres) toolbar, 80
Edit toolbar, 80
Editing a key, 855
Editing a legend, 846
Editing objects, 369
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EDMX, 171
EDMX address, 592
Elements

renaming, 404
Enhanced beam quality

Color Temperature & Footprint 
Intensity Falloff features of, 134

Entering data in the spreadsheet, 687
Environmental options, 762
Errors, 714
Ethernet, 908
Exit WYSIWYG, 160
Export to DWG/DXF, 254
Exporting

to 2D DWG/DXF, 254
to 3D DWG/DXF, 254

Extrude, 473
Extrude Objects, 474

F
Fading between lighting looks, 741
FAL Template Manager, 604
fastFan

Using in CAD mode, 566
Field angle, 581
File menu, 147
Fillet, 477
Filter Bar, 692
Fixture Details tab, 799
Fixture layout, 596
Fixture notation, 596
Fixture properties

Photometrics, 581
Fixture Settings tab, 185
Fixture snap, 220
Fixtures, 546

Distribute and array feature, 551, 552
Distributing along pipes/truss, 550
Distributing between two points on 

pipes/truss, 551
Distributing from the center of pipes/

truss, 552
Distributing in a direction on pipes/

truss, 551
Hanging multiple, 548
Inserting in CAD mode, 546
Selecting, 549
Using Array feature to hang, 548

Flight Case, 618
Floor mount, 509, 520
Floorplans

adding, 260
Hiding after importing, 268

Flow control, 172
Focus

Design tool, 728
Focus data field, 685
focus lines

assigning fixtures to, 563
Focus position, 609
Focus tool, 728

Focusing
click and drag method, 730

Focusing fixtures, 559
Font

changing in New Plots, 807
changing in Text Labels, 303

Fonts tab, 193
Footnotes data field, 685
Footprint Intensity Falloff, 136
Footprint tool

using (CAD mode), 574
using (Design mode), 732

Frame size, 617
Frame tents, 287
French curve, 290
Front view, 217
Full screen mode, 61

G
Gels, 726

Inserting, 610
Inserting multiple, 691

General object properties, 386
Gobo data field, 685
Gobo wheels

Custom, 612
Gobos

Custom, 614
Design tool, 726
Inserting, 610

Graphics, 865
Grid array, 484
Grid options, 181
Group tab, 378
Grouping, 377

H
Hang structure, 509, 556
Hang Structure Settings tab, 187
Hanging, 546
Hanging fixtures, 546
Hanging multiple fixtures, 548
Hanging truss, 520
Hatch style, 609
Hatching, 388
Hidden line, 289
Hide Floorplan, 268
Hookup data field, 685
Hot keys, 931, 934

Patch views, 940
Presentation views, 938, 939
Simulation, 937

I
Image Console

configuring, 900
controlling LES grids with, 903
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Image items, 840
Image Manager, 667
Image placeholder for video, 664
Images, 865
Imperial units, 208
Importing

DWG/DXF files, 234
SketchUp files, 222, 223, 229

Importing .3DS files, 258
Importing .DAE files, 258
Importing .FBX files, 258
Importing .OBJ files, 258
Importing DWG/DXF files, 237, 245
Importing fixtures, 269
Importing floorplans, 260
In-Place update, 27
Insert (Pres) toolbar, 81
Insertable, 152
Inserting

Color in Data mode, 691
Fixtures in CAD mode, 546
Fixtures in Data mode, 690
Positions in Data mode, 691

Installing
In-Place update, 27
WYSIWYG, 26
WYSIWYG Learn, 27
WYSIWYG Network, 27

Intensity design tool, 724
Interactive mode, 222
Intersect Objects, 489
Intersecting objects, 497
Intersection

and the Boolean Operations feature, 
490

Intruction Tooltip, 93
Inverse Square Law calculations, 136
Isometric view, 217
Item properties, 832

J
jpeg file, 615, 758, 823, 865

K
Key

Instrument labels, 596
Keyboard and mouse control, 94
Keyboard shortcuts, 931
Keys, 850

L
Ladders, 509, 520
Lamp Type data field, 685
Lamps, 275
Languages, 62
Lasers, 623
Latitude, 176

Layer data field, 686
Layer Groups, 451
Layer prefixes, 445
Layers, 438
Layers toolbar, 81
Layout

fixture data, 596
Layout tabs

CAD, 201
Data, 683
Design, 721
Live, 885
Pres, 781, 921

Layouts
locking items in, 861
Locking out items in, 860
unlocking items in, 861

Layouts (Pres mode), 820
Lease

Renewing, 50
Lease Details

Obtaining, 49
Leases, 47
LED Wizard, 626
Left view, 216
Legend items, 842
Library Browser, 273

using the Search feature in, 275
Library objects

applying textures to, 278
replacing, 276

Library shortcuts, 67
Light emission, 405
Line

Drawing lines, 289
Line color, 449
Line weight, 449
Linear axis, 342
Linear Scales, 311
Lines, 806

Converting into surfaces, 466
Live toolbar, 82
Location setup, 176, 341
Locations tab, 173
Longitude, 176
Looks

and moving scenery, 743

M
Marker grips, 385
Material Reflections, 437
Materials, 403, 433
Measurement mode, 304
Membership and Leases, 47
Menu bar, 73
Merge, 155
Merge Objects, 489
Merging

SketchUp files, 229
Merging documents, 155
Metric units, 208
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Micro Layouts, 820
MIDI, 908
Mini Console, 898
Mirror tool, 382
Mirroring, 382
Mirroring Pipes, 517
Mirroring Truss, 534
Missing coordinate, 213, 214
Model data field, 686
Modes, 57, 58
Modifying wireframe views, 97
Motion axes

drawing, 342
Motion axis

adding vertex to linear, 346
attaching objects to, 345
attaching to a DMX patch, 344
attaching to a motion patch, 344
changing path of, 346
drawing linear, 343
drawing rotation, 344
moving objects on with a console 

device, 895
moving objects on with a motion 

control system, 896
patching to DMX console device, 706
patching to motion control system, 707

Motion control system
moving objects with, 896

Mountable yokes, 617
Move, 809
Move Page, 799
Move tool, 378
Moving, 556
Moving head, 592
Moving mirror, 592
Moving scenery

reading the patch for, 710
viewing, 743

Moving Scenery tool, 733
using, 733

Multi-source light
applying color to with Quick Tools, 611

N
Navigation shortcuts, 67
New Back Elevation Plot, 795
New Front Elevation Plot, 795
New Left Section Plot, 795
New Plan Plot, 795
New Plot View Properties tab, 797
New Plots, 794

Attribute layout, 804
changing font used in, 807
Creating a new plot type, 795
Drawing objects, 805
Editing objects, 807
Inserting into layouts, 829, 839
Modifying properties of a plot, 796
Objects, 800
Objects drawn in New Plots, 814

Printing, 818
Reestablish links, 801
Relationship with objects in CAD, 800
Relationship with objects in Data, 801
Selecting objects, 808
Updating, 795
Working in, 794

New Right Section Plot, 795
New Show, 147
Nudging, 380
Number of color frames data field, 686
Number of data channels data field, 686
Number of lamps data field, 686

O
Object representation in New Plots, 800
Object Settings tab, 189
Object-specific properties, 412
Offset, 518
Offset data field, 685
Open a show document, 148
Open GL tab, 169
Options, 161
Orbit, 104
Origin, 181, 206
Ortho, 92, 219
Owner data field, 686

P
Palette shortcuts, 739
Pan data field, 685
Paperwork, 782
Passwords, 52
Patch, 701

changing width of cells in, 712
Patch data field, 684
Patch universe, 701
Patch views

Hot keys, 940
Patching

motion axes (DMX), 706
motion axes (motion control system), 

707
Patching fixtures, 702
Performance, 122
Photo quality pictures, 753
Photometrics, 547, 581
Pipe, 327, 554
Pipe and Drape Wizard, 354
Pipe snap, 221
Pipe tape, 870
Pipes

Distributing multiple fixtures on, 551, 
552

Pivot, 104
Plan view, 216, 217
Plot type, 216
Points, 291
Polygons
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drawing, 297
Pop-up frames, 60
Ports

console, 886
Position, 509
Position data field, 685
Position Manager, 509
Precision, 180, 422, 423
Presence option, 759
Presentation items, 822
Presentation views

Hot keys, 938, 939
Print, 157
Printing

Batch, 863
Printing layouts, 862
Product Configuration Wizard, 36
Production Team Info Wizard, 873
Projection

and the Boolean Operations feature, 
490

Properties
Dimension, 420
Errors, 718
Focus position, 560
General, 386
Layouts, 821
Legend, 848, 857
Library item, 278
Line, 415
Patch universe, 711
Pipe, 518
Point, 415
Report, 783
Spreadsheet, 693
Symbol, 609
Text label, 418
Wireframe view, 96

Proscenium Arch, 285
Protractor tab, 425
Purge command, 154
Purpose data field, 685

Q
Quick focus, 565
Quick Light Emission Tools, 408
Quick Motion Patch Tool, 349
Quick tools, 581

R
Radial Dimension tab, 423
Radial Dimensions, 309
Radiosity, 761
Reading the patch, 709
Reassembling Truss, 528
Reauthorization

for dongles, 42
Redo, 376
Regional profile, 162

Regional settings, 176
Relative, 378
Relative coordinates, 92
Rename fixture type, 579
Renaming object elements, 404
Render shortcuts, 765
Rendering, 680, 753, 912
Replacing fixtures, 552
Report Defaults tab, 195
Reports, 782, 879

Creating, 787
Reset origin, 206
Reseting Orientation, 382
Resizing

Spheres, 385
Revolve, 502, 509
Rigging points, 539
Right view, 217
Riser, 318
Roll, 105
Room Builder, 282
Rotate, 811
Rotate tool, 381
Rotating, 381
Rotating objects in place, 382
Rotation axis, 343
Ruler

changing origin of, 211
toggling on and off, 210

Ruler icons, 209
Ruler Tool, 208

S
Saturation, 763
Save, 149
Save As, 149
Saving a lighting look, 741
Scaling, 383
Scattering, 119
Scenes, 459
Scenes toolbar, 83
Schedules, 782
Screen layout, 57
Screen Properties, 331
Scrollbars, 100
Scrollers, 614, 726
Scrolls, 612
Selecting alternate mount points during 

assembly, 528
Selecting objects, 369
Selection sets, 489
Selection toolbar, 83
Send the show document through e-mail, 

160
Sending to Back, 380
Setting display size for shortcuts, 69
Settings

regional, 176
Shaded View Profiles, 136
Shaded View Selection, 373
Shaded views, 103
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Sharing Keys, 858
Shortcut, 66
Shortcut bar

Create Shortcuts
Fixture groups, 736
Images, 865
Layouts, 820
Library Objects, 277
Lighting looks, 741
Palette, 739
Patch Universes, 702
Render, 765
Spreadsheets, 699

Shortcuts, 66
arranging, 69
delete, 68
new, 68
ordering, 68
setting display size, 69

Show information, 794
Shutter cuts, 567
Shutters tab, 592
Sidedness

Changing for an object, 410
Sidedness tab, 409
Simulation

Channels, 91
Simulation options, 680, 912
Simulation views

Hot keys, 937
SketchUp files

importing, 222, 223, 229
Merging, 229

Snap, 92, 182, 220
Soft shadow, 762
Solid line, 289
Sphere, 323
Spheres

Resizing, 385
Spin data field, 685
Spline, 290
Split gels, 691
Splitting video, 658
Spot data field, 684
Spot Numbers

assigning to fixtures, 908
Spreadsheets, 684
Spreadsheets Toolbar, 84
Standard toolbar, 84
Status bar, 91
Status data field, 686
Stock, 612
Streaming video

reading the patch for, 710
Subtract Objects, 489
Subtract tool

cutting holes in walls with, 499
Subtracting objects, 498
Surfaces, 314
Surfaces as Curtains, 315
Symbols, 596, 807

T
Tag data field, 686
Tape printer, 870
Template, 151
Tents, 287
Text label, 299, 505, 806
Text Labels

changing font of, 303
Textures, 166, 430

applying to library objects, 278
Tile printing, 798, 822
Tile Printing tab, 797
Tilt data field, 685
Time of Day Lighting tab, 129
Time zones, 176
Timeline tool, 751
Title block, 823, 878
Toolbars, 73, 168
Tools

CAD, 463
Design, 722

Tools toolbar, 85
Tooltips, 178
Tophats, 610
Troubleshooting, 4
Truss

Distributing multiple fixtures on, 551, 
552

Hanging truss, 520
Indicators for assembly, 520
rolling, 529
Rolling truss, 528

Truss cross members, 183
Truss Manager, 535
Truss snap, 221, 527
Turbulence, 127
Type data field, 685

U
Undo, 376
Ungrouping, 377
Unicode, 26
Unit data field, 685
Unite Objects, 489
Uniting objects, 496, 497
Universe

Patch, 701
Unused channels, 91
Upgrades, 23, 45
User Data

Exporting, 64
Importing, 64

User Data Profile, 63
USITT symbols, 609

V
Vertex, 464, 472

adding to a linear axis, 346
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Vertical hang structures, 802
Vertical justification of a line, 420
Video

patching in the patch view, 706
splitting, 658

Video Manager, 653
Video source

configuring new, 665
controlling with a console device, 894

Video tool, 731
View - full screen, 61
View Options

Error, 718
Flight Case, 620
Layouts, 821
Patch universe, 711
Report, 783
Shaded views, 111
Spreadsheet, 693
Wireframe views, 97

View shortcuts, 96
View toolbar, 86
Viewer, 197
Viewing

moving scenery, 743
Views/tools shortcuts, 67
Visual camera path builder tool, 750
Visual Effects, 124
Visualization Requirements, 25

W
Walls, 318
Wattage data field, 685
Weight data field, 685
Welcome window, 57
Wheels, 614, 726
Window Position Management, 88
Window toolbar, 86
Wireframe views, 94
Workplane, 217
WYSIWYG

Design, 11
Perform, 13, 17, 20
Report, 5, 9
starting for the first time, 36

WYSIWYG Learn, 17, 27
WYSIWYG Network, 19
WYSIWYG Perform - Console Edition, 5, 15
WYSIWYG Viewer, 197

Y
Yokes

mountable, 617

Z
Zebra Striping, 790
Zoom, 106, 722

Zooming, 96
Zoom tools, 94
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