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wysiwyg Tips & Tricks 
by Dany Tancou

TIP 1 - Using wysiwyg’s Import Floorplan Feature

The Import Floorplan feature is extremely useful when a CAD file of the venue for your upcoming show is not available, and all you can 
get your hands on is a .JPG, .BMP, or .PDF* image of the floorplan. Naturally, the image has to be drawn to scale (i.e., a 50’ wall and a 
100’ wall have to be represented by lines of different, proportionate lengths) and at least one dimension in the drawing should be known 
(i.e., “the ‘east’ wall is 86’ long”). 

You can easily import such an image into wysiwyg’s CAD mode or, for greater precision, into the Plan View’s background. You can then 
use the image as a visual guide when drawing the venue with wysiwyg’s drawing and object modification tools. Note that the imported 
floorplan will not appear on any wysiwyg printouts; it is simply meant to be a drawing aid, similar to using tracing paper to make a copy 
of a drawing.

In this tip you will learn how to import a floorplan image, scale it properly, 
and then use it to build the venue. While this tip features a rather simple 
venue, you can use the steps below in all cases. 

Here is the image of the floorplan:  

In addition to the details shown in the image, the following information is known
The venue is 24’ tall.1. 
All doors are 7’6” wide and 10’ tall.2. 
The dotted lines represent windows along the side walls of the venue. The windows start 3’ off the floor, and are 8’ wide and 12’ tall. 3. 
The distance between the windows is 12’.
The squares around the doors and running down the length of the room represent floor-to-ceiling columns.4. 
The stage is 2’6” tall.5. 

With the New Year comes a new newsletter and that means a new set of tips to keep your wysiwyg skills sharp. 
The following tips will show you how to import floorplan images into wysiwyg and how to create Concepts in 
Data mode, two very different but equally useful procedures.

Importing PDF Files 

*While you cannot import PDF files directly into wysiwyg, 
you can still use them as drawing aids by following these 
steps:

Open the PDF file with Adobe Acrobat Reader.1. 
Maximize the Acrobat Reader application window.2. 
Click View Menu > Zoom > Fit Page. This ensures 3. 
that the floorplan fills the viewing area as much as 
possible.
On your keyboard, press the PrintScreen button.4. 
Open the graphics editing program of your choice. 5. 
(For example, you can open Microsoft Paint by click-
ing Start > Programs > Accessories > Paint.)
Start a new file, and then paste (CTRL+V) the 6. 
screenshot of the floorplan into it.
Crop the image as tightly as possible to remove the 7. 
Acrobat interface, leaving only the floorplan visible.
Save the file in BMP format. (While larger in size, 8. 
BMP files offer better resolution for the drawing work 
you are about to do in wysiwyg.)
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TIP 1 - Using wysiwyg’s Import Floorplan Feature - Continued

Importing the image/floorplan into wysiwyg

Create a new 1. wysiwyg file.
Click2.  File > Import Floorplan. 
Result:  The Open File window appears.
Navigate to the location where the floorplan image is stored, select the file, and click 3. Open. (Note that wysiwyg only lists the types 
of files that it can import:  BMP, JPG, PNG, GIF, TIF, and TGA.) 
Result:  A message appears asking you to define a known length in the floorplan that you are importing.
Click 4. OK. 

Result:  The floorplan image appears and wysiwyg prompts you (in the bottom left corner of the window) to click the starting point 
of the area that you are going to measure (the Dimension). 

For greater accuracy, zoom in on one of the venue’s sides or corners and click to set the starting point of the dimension.  5. 

Note: It makes no difference which venue dimension/side you choose to define, as long as you know what that dimension is. In 
this example, I chose the bottom side of the venue. Note in the screenshot below how I carefully positioned the cursor at the exact 
starting point of the line representing the wall of the venue.  
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Click 6. Tools > Ortho > X Axis to enable ortho for the X axis. Doing so provides greater measuring accuracy by ensuring that the 
dimension line is straight when you scroll over to the other end of the wall.
Zoom out, and then zoom in on the other corner of the wall and click to set the end point of the dimension. Again, ensure that you 7. 
zoom in as much as possible to define this point properly. 

TIP 1 - Using wysiwyg’s Import Floorplan Feature - Continued
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Result:  A window appears prompting you to enter the length of the dimension you just defined. In this example, as shown on the 
floorplan image, the wall is 104’ long, so I will enter that value here:

Click 8. OK. 
Result:  The view scales according to the dimension that you entered.
Zoom out to see the entire floorplan once again. (Note that the Zoom Fit or Zoom Fit All commands will not work since you have 9. 
not drawn anything yet.)
Click 10. File > Save, choose a location to save the file, type a file name, and then click Save.

You are now ready to start tracing (drawing) the venue on top of the floorplan image. 

We will start by drawing the walls of the venue as lines, which we will then extrude into surfaces. Once this is done, we will use the 
Boolean Subtract tool to create the doors and windows. Finally, we will use the Surface tool to create the venue’s floor and ceiling, and 
the Riser tool to create the stage and columns represented by the squares around the doors and those running down the length of the room.

Creating the Walls

For greater accuracy, enable ortho on the Y axis by clicking 1. Tools > Ortho > Y Axis. (X ortho should still be enabled.)  
Create a new layer called 2. Venue by clicking Edit > Layers, clicking New, and then typing Venue for the layer name. Highlight 
the new layer Venue and click Set Current to make it the current layer. (Note that when you draw a venue using wysiwyg’s Draw 
menu, wysiwyg automatically creates this layer. However, since you are drawing the venue by hand, it is recommended that you 
create this layer yourself.)
From the Draw menu, click 3. Line > Solid, zoom in on the first corner of the venue that you measured (step 5 above), and then click 
to set the starting point of the line.

TIP 1 - Using wysiwyg’s Import Floorplan Feature - Continued
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To set the end point of this line, scroll over and click on the second corner that you measured before (step 7 above).*4. 
Without finishing the Line command, continue to draw the line upwards in a counter-clockwise direction around the venue to create 5. 
what will become the right wall of the venue. Again, you can click on the corner in the floorplan or 
simply enter the dimension for the wall--in this case 84’.
Without finishing the Line command, continue back towards the left to create what will become 6. 
the upper wall of the venue, and click to set the line at the corner.
Next, we have to define a diagonal wall. Since we do not have any information about the angle 7. 
at which this wall is placed, we have to draw it manually. First, disable Ortho mode by pressing 
the F8 key. Then, without finishing the Line command, click on the end point of this wall where it 
joins the next diagonal wall.
Draw the next diagonal wall in the same fashion, keeping Ortho disabled.8. 
Enable Y Ortho mode once again (click 9. Tools > Ortho > Y Axis) to ensure that the next wall is 
perfectly vertical and, without finishing the Line command, click to select the end point of this 
wall. (This is the wall that runs behind the stage, parallel to the wall with the main entrance to the venue.)
Press F8 to disable Ortho mode one last time, and, without finishing the Line command, click the point where the two diagonal 10. 
walls meet to draw the second-last wall.
Finally, right-click and select Close Line to close the line and end the Line tool.11. 
Result:12.  You have now drawn the outline of the venue.

Extruding the Lines into Actual Walls 

Next, we have to extrude the multi-segment line we just drew into Surfaces that will become the actual walls of the venue.

Click on the line to select it, and then click 1. Tools > Extrude > Lines into Surfaces. 
Result:  The Extrude window appears.
For the extrusion distance, enter the height of the venue walls (24’, as mentioned above), and then click 2. OK. 
Result:  The lines are transformed into surfaces. Switching to Isometric View will show this…

*Alternately (and in order to check 
the accuracy of the dimension you 
defined), you could simply move 
your cursor towards the right, type 
104’, and then press <Enter>. If 
the dimension was defined cor-
rectly, the end point of the line you 
are drawing should appear in the 
same place where you clicked in 
step 7 above.

TIP 1 - Using wysiwyg’s Import Floorplan Feature - Continued
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Creating Doors and Windows

Once the walls are complete, it is a good idea to create the doors and windows before drawing anything else. If you leave this task for 
later, other objects may interfere (either visually or actually) with the Boolean Subtract operations that need to be performed.  

Note: Since the purpose of this Tip is to show how to build a venue from an imported floorplan, it does not include details about the 
Boolean Subtract tool. Consult the wysiwyg Reference Guide for detailed instructions on using this tool. 

One important thing to note is that the Boolean Subtract tool will not work on these walls until you ungroup them. Since the outline of 
the venue was drawn as a single, multi-segment line, it was extruded as a “single” object, which resulted in individual surfaces grouped 
together. To ungroup the surfaces, simply select them, right-click, and select Ungroup.

Ungroup the walls of the venue by clicking on a wall to select them all, and then right-clicking and selecting Ungroup. 1. 
For each of the doors and windows in the venue, perform a Boolean Subtract operation to “cut” the door/window out of the wall. For 2. 
details on this operation, see the wysiwyg Reference Guide.

Once you have completed this procedure, the venue looks like this:

Drawing the Floor and Ceiling

When we draw a venue using wysiwyg’s Venue tool, the floor and the ceiling are created automatically. Since we have created the 
venue by hand, however, we must also draw the floor and ceiling by hand using the Surface tool. The easiest and most accurate way to 
do so is to snap to the corners of the walls.

Switch to Isometric view.1. 
Press F8 to disable Ortho.2. 
On the CAD Options toolbar, click to enable End Point Snap.3. 
From the Draw menu, select 4. Surface.

TIP 1 - Using wysiwyg’s Import Floorplan Feature - Continued

https://www.cast-soft.com/cast/products/wyg-reference.php
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Begin by clicking on the same corner of the room where you started drawing before, and continue drawing the surface that will 5. 
become the floor in a counter-clockwise fashion by clicking on each of the corners, as shown in the next screenshot: 

Repeat these steps to create the ceiling, snapping to the top end points of the walls.6. 

Creating the Columns

Since we have no information about the size of the columns other than the fact that they stretch from floor to ceiling (and are, therefore, 
24’ high), we’ll draw the risers that will represent the columns in Interactive mode.  Before you begin, it is recommended that you create 
another layer called “Columns”, make it current, and then draw the columns on this layer.  Once finished, proceed with the following 
steps:

Switch to Plan view.1. 
From the Draw menu, select 2. Riser. 
Result:  The New Riser window appears.
Click the Interactive button. 3. 
Result:  The New Riser window disappears and you can now draw the riser.
Zoom in on one of the columns, and click on one corner of the square representing the column to start drawing the first corner of 4. 
the riser.
Click on the (diagonally) opposite corner of the square to pick the second corner of the riser. 5. 
Result:  The New Riser window appears again, allowing you to define the Height (and make adjustments to the Width and Depth, 
if necessary).
Enter 6. 24’ for the height, and then click OK to create the riser (column).
Repeat these steps to create the remaining columns in the venue.  7. 

Tip: Since the columns around the doors on the diagonal walls are the same size as the columns around the doors on the right wall, 
you can simply copy one of the columns from the right wall over to the diagonal wall, and then rotate it to match the angle of the column 
in the imported floorplan. Keep copying and pasting columns until you have drawn all of them.
 

TIP 1 - Using wysiwyg’s Import Floorplan Feature - Continued
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When finished with this procedure, your venue should look something like this in an Isometric view:
 

Final Considerations

Since we are finished drawing the venue, we no longer need to see the imported floorplan in the background of our Plan View, so let’s 
hide it. To do so, simply right-click in empty space within the Plan View and choose Hide Floorplan. You also have the option to delete 
the floorplan image, but I suggest keeping it there for a while just in case.

TIP 1 - Using wysiwyg’s Import Floorplan Feature - Continued
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And last, but most certainly not least, consider the venue’s Sidedness:  when switching to Shaded View, we can see our venue, but it 
does not appear like a Venue that was drawn from the Draw menu. That is, we cannot see “into” the venue when the camera is outside.
To overcome this, we must change the surfaces that we have drawn (walls, floor, and ceiling) into Single-Sided surfaces. Working in 
Quad view is recommended here, as the results of changing the surfaces in this way will be displayed immediately.

Switch to Quad view.1. 
Click 2. Edit > Layers to open the Layer Database. 
Highlight the 3. Columns layer, and deselect the check mark beside Editable to make this layer uneditable. This way, when you se-
lect everything in the next step, the columns will not be included in the selection set.
Click 4. OK.
In a wireframe pane of your drawing, select everything (either by drag-selecting or with CTRL+A).5. 
Right-click and select 6. Properties.
Change to the 7. Sidedness tab.
From the Sidedness drop-down box, select 8. Single Sided and click Apply.   
Result:  The Shaded pane of the Quad view changes.

If, for some reason, one or more surfaces do not appear correctly, select the surfaces in question, view their Properties once again, 
click the Sidedness tab, and click to place a check mark in the Flip Normal check box.

When complete, the venue should appear like this in Shaded View:

TIP 1 - Using wysiwyg’s Import Floorplan Feature - Continued
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TIP 2 - Creating Concepts Easily in Data Mode

About Concepts

wysiwyg’s Concepts shortcuts enable you to group fixtures so you can select them faster and easier. Concepts are extremely useful in 
many situations when you 

are selecting fixtures in Design mode and have so many fixtures turned on that the large number of beam lines makes it al-•	
most impossible to select more fixtures without deselecting others by mistake,
need to select multiple individual cells of multi-cell fixtures—in fact, such selection can only be achieved by using Concepts, •	
select fixtures in full Shaded View. This feature is especially handy when pre-programming a show with an AutoFocus-capable •	
console because Concept selection is transferred to the console’s live programmer in the same manner as any other fixture 
selection.

Concepts can be created in any mode or view in which fixtures can be selected, including Data mode. They can contain as little as one 
fixture, and multiple Concepts can contain the same fixture.  

To create a Concept (in any mode)

Open the Concepts shortcuts by clicking 1. Concepts in the shortcut bar on the left side of the wysiwyg application window.
In your file, select the fixtures that you want to group together by drag-selecting or using CTRL+click.  2. 
Right-click in the shortcuts area and select 3. New Concept from the pop-up menu. 
Result:  A window appears, prompting you to name the Concept.
Enter a name for this Concept. The name should be as descriptive as possible, while remaining as brief as possible.  For example, 4. 
you could use names such as “Mac 700s – Back – SL”, “VL 2500s – FOH1”, “ACLs – MidSR”, “All BAX”, “DI-BAX SL”, “Boom 1 – 
SL – Low”, “Warm DS Fronts”, “Red Cyc”, “Special MidSC”, and so on.
Click 5. OK. 
Result:  A new icon appears in the Concepts shortcuts area.  

From now on, regardless of which mode or view is active, when you click this shortcut icon, you will select the fixtures that you added to 
the Concept in step 2 above.

To add fixtures to an existing Concept

In the Concepts shortcut area, click to select the Concept that you want to modify.1. 
In your drawing, CTRL+click to select the fixture(s) that you want to add to this Concept.2. 
Right-click on the Concept icon and select 3. Update.

To remove fixtures from a Concept

In the Concepts shortcut area, click to select the Concept that you want to modify.1. 
In your drawing, CTRL+click on the selected fixture(s) that you want to remove from the Concept.2. 
Right-click on the Concept icon and select 3. Update.

Using Data Mode to Create Concepts

The best place to create Concept shortcuts is in Data mode—more specifically on the Spreadsheet, 
H Select, or the V Select tabs. wysiwyg’s ability to sort and filter spreadsheets in any number of ways 
makes listing fixtures in a logical manner very easy, and therefore, it’s a snap to select several fixtures 
that share common attributes. Sorting, filtering, and selecting can be further streamlined/enhanced by 
assigning a Purpose to each fixture in the file*. Note that Concepts which include individual cells of 
multiple multi-cell fixtures can only be created in Data mode.

You can assign a Purpose to any 
fixture by accessing its Properties, 
clicking the Fixture tab, and then 
entering a description in the Pur-
pose field. Examples of Purposes 
include “Cyc”, “Effect”, “Diagonal 
Back”, “Top”, “Special”, and so on. 
To assign the same purpose to 
multiple fixtures at once, use the 
QuickTool in CAD mode. 
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Here are two examples of Concepts that could be created in Data mode
 

(1) Creating Concepts for the individual colors of our Cyc fixtures’ cells.
(2) Creating three different Concepts for our front of house fixtures.  

Example 1 - Creating Concepts for the individual colours of our Cyc fixtures’ cells

Let’s assume that we are using the same type of three-cell Cyc fixtures, and they are all gelled as follows:  the stage left cell is red, the 
middle cell is blue, and the stage right cell is green. To begin, we’ll filter the spreadsheet to only show the Cyc fixtures.

In Data mode, click the Spreadsheet, H select, or V Select tabs, whichever you feel most comfortable with (or whichever makes 1. 
most sense to you).
In the Type column, right-click and select 2. Add Data Filter. 
Result:  The Specify Filter dialog appears.

From the Text drop-down, select the three-cell Cyc fixture.3. 
Click 4. OK. 
Result:  The spreadsheet now only shows the three-cell Cyc fixtures in the file.  (Visually, we know that we are looking at a filtered 
spreadsheet because the background of the Type column is now highlighted blue.)
Click the 5. Color column header to sort the spreadsheet by the colour/gel assigned to the Cyc fixtures’ cells. 

Result: Triangle brackets (i.e., “<” or “>”) appear around the column name to indicate that the spreadsheet is now sorted by this column.

TIP 2 - Creating Concepts Easily in Data Mode - Continued
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Finally, select the fixtures to be included in the new Concept by clicking on the gray box at the left of each row of the spreadsheet. As with 6. 
any other selections, a single click will select the fixture and deselect anything else selected; CTRL+click will add to the current selection 
set; clicking and dragging will select multiple fixtures (in the order in which they are listed).

Once you have selected the fixtures, create the new Concept as described above in the procedure To create a Concept (in any mode). 7. 
Repeat this procedure to create Concepts for the blue and green cells.8. 

Note that when a either of these Concepts are selected by clicking on them in the Concepts Shortcuts area, all the three-cell Cyc fixtures will 
be highlighted, but in reality only one the corresponding cells are actually selected.  Go ahead, give it a try in Design Mode…! 

Example 2 - Creating three different Concepts for our front of house fixtures

For our second example, we have six Source 4 fixtures (among others) at our FOH position, three with a “warm” gel and three with a “cool” gel. 
The Purpose attribute that was assigned to these fixtures is “Front Light”.  We would like to create/have three Concepts here, in order for our 
selections to be flexible:

one that includes all of these fixtures•	
one that only contains the “warm” fixtures•	
one that only contains the “cool” fixtures•	

Since no other fixtures at the FOH position have a “Front Light” Purpose, begin by using the same steps as above to filter the spreadsheet 1. 
to only show this Purpose.  (Note that unlike in the above example, we are not filtering by (fixture) Type, because Source 4 fixtures are 
also used elsewhere in the show, and applying such a filter might cause us to incorporate the wrong fixtures into these Concepts.)  
Click the Color column header to sort the spreadsheet by color.  2. 
Select the appropriate fixtures for each of the concepts:3. 

Select all listed fixtures to create the “All Fronts” Concept•	
To create the “Cool Fronts” Concept, select only the fixtures with the “cool” colour.•	
To create the “Warm Fronts” Concept, select only the fixtures with the “warm” colour.•	

Tip: Another way to accomplish this is to filter the spreadsheet to only show the LX FOH Position, and then sort the spreadsheet by two keys: 
Purpose and Color. To perform multi-key sorting, right-click anywhere in the spreadsheet , select View Options and then switch to the Data 
View Options tab. In the Sort Options area, select which columns to sort by, and then click OK.

TIP 2 - Creating Concepts Easily in Data Mode - Continued


